 Contents

Click on the topic icons in the list below to jump to the main sections in this Help system.

CALIFORNIA PROPOSITION 65 WARNING

ENGINE EXHAUST

ABSTRACT

SAFETY INSTRUCTIONS

REVISION NOTIFICATION

INTRODUCTION

TROUBLESHOOTING INFORMATION

SAFETY PRECAUTIONS

Exhaust (Start/Run Engine)

Glasses

Welding

Pressurized Fluids

Fuel

Batteries

Fire

Cleaning Agent

Working on a Running Engine

Optimized Idle

ELECTRONIC COMPONENTS AND WIRING SCHEMATICS

OVERVIEW

PLD-MR - ENGINE-RESIDENT CONTROL UNIT

Environmental Conditions

Temperature

Vibration

Water Intrusion

Engine Sensor Harness

Power Supply (PLD-MR)

Fuses (PLD-MR)

Proportional Valve Control

Connectors (PLD-MR)

VEHICLE CONTROL UNIT - ON-HIGHWAY

Vehicle Interface Harness Design

Digital Inputs

Analog Inputs

Digital Outputs

Data Links

Ignition

Vehicle Interface Harness Wiring

VIH to PLD-MR Connector Wiring

VIH to Engine Harness Connector Wiring

VIH Power Wiring

Communications - SAE J1939 Data Link

Communications - SAE J1587/J1708 Data Link

Communications - Propriety IES-CAN Data Link

Power Supply - 12 Volt System

Average Current Draw

Battery Isolator

Main Power Shutdown

Fuses (VCU)

Connectors_1

Data Link Connector

SAE J1708/J1587 Data Link 6-Pin Connector

WIRES AND WIRING

General Requirements

General Wire

Deutsch Terminal Installation and Removal

Deutsch Terminal Installation Guidelines

Deutsch Terminal Removal

Splicing Guidelines

Clipped and Soldered Splicing Method

Splicing and Repairing Straight Leads - Alternate Method 1

Splicing and Repairing Straight Leads - Alternate Method 2

Shrink Wrap

Staggering Wire Splices

CONDUIT AND LOOM

TAPE AND TAPING

SENSORS

Factory-Installed Sensors

OEM Installed Sensors

Engine Coolant Level Sensor

Vehicle Speed Sensor

Magnetic Pickup - Vehicle Speed Sensor Settings

Magnetic Pickup

SAE J1939 Data Link

GRID HEATER

CRUISE CONTROL CIRCUIT

ENGINE FAN

SINGLE-SPEED FAN (FAN TYPE 4)

DUAL FAN (FAN TYPE 6) - MBE 4000 ENGINE

TWO-SPEED FAN (FAN TYPE 0 OR 1) - MBE 4000 ENGINE

VARIABLE-SPEED FAN (FAN TYPE 5)

PARKING BRAKE SWITCH

VEHICLE POWER SHUTDOWN - OPTIONAL

STARTER LOCKOUT

ACCELERATOR PEDAL INSTALLATION

OPERATION

FEATURES

TROUBLESHOOTING

DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

DDEC-VCU

Wiring the Grid Heater

Grid Heater

TROUBLESHOOTING PID 45

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

DESCRIPTION OF PID 91 - ACCELERATOR PEDAL SENSOR FAULT

TROUBLESHOOTING PID 91

DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 100

DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 102

DESCRIPTION OF PID 103 - TURBO NO REVOLUTION FAULT

TROUBLESHOOTING PID 103

DESCRIPTION OF PID 105 - INTAKE AIR TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 105

DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

TROUBLESHOOTING PID 110

DESCRIPTION OF PID 111 - COOLANT OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 111

DESCRIPTION OF PID 158 - BATTERY CHARGING FAULT

TROUBLESHOOTING PID 158

DESCRIPTION OF PID 168 - BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

Power Supply

VIH Power Wiring_1

TROUBLESHOOTING PID 168

DESCRIPTION OF PID 174 - SUPPLY FUEL TEMPERATURE SENSOR FAULT

TROUBLESHOOTING PID 174

DESCRIPTION OF PID 175 - ENGINE OIL TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 175

DESCRIPTION OF PID 190 - ENGINE SPEED OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 190

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

DESCRIPTION OF SID 57 - EXHAUST BRAKE FAULT

TROUBLESHOOTING SID 57

DESCRIPTION OF SID 58 - ENGINE BRAKE FAULT

TROUBLESHOOTING SID 58

DESCRIPTION OF SID 59 - DUAL-SPEED FAN LOW STAGE OPERATION FAULT

TROUBLESHOOTING SID 59

DESCRIPTION OF SID 60 - DUAL-SPEED FAN HIGH STAGE OPERATION FAULT

TROUBLESHOOTING SID 60

DESCRIPTION OF SID 64 - CAMSHAFT POSITION SENSOR FAULT

TROUBLESHOOTING SID 64

DESCRIPTION OF SID 146 EGR SYSTEM FAULT

TROUBLESHOOTING SID 146

DESCRIPTION OF SID 230 - THROTTLE CONTROL FAULT

TROUBLESHOOTING SID 230

DESCRIPTION OF SID 232 - ACCELERATOR PEDAL SUPPLY VOLTAGE FAULT

TROUBLESHOOTING SID 232

DESCRIPTION OF SID 233 - PLD-MR FAULT (ERRONEOUS DATA)

TROUBLESHOOTING SID 233

DESCRIPTION OF SID 242 - CRUISE CONTROL SET/RESUME SWITCH FAULT

TROUBLESHOOTING SID 242

DESCRIPTION OF SID 243 - CRUISE CONTROL SET AND RESUME SWITCH FAULT

TROUBLESHOOTING SID 243

DESCRIPTION OF SID 248 - PLD-MR DDEC-VCU DATALINK FAULT

TROUBLESHOOTING SID 248

DESCRIPTION OF SID 254 - DDEC-VCU FAULT

TROUBLESHOOTING SID 254

FIGURES

55-Pin Wiring Harness Connector

Accelerator (Throttle) Pedal Wiring Schematic

Accelerator Pedal to DDEC-VCU Connector

Accelerator Pedal to DDEC-VCU Connectors

Camshaft Position Sensor

Close-up View of Oil Combination Sensor

Connector Positions on DDEC-VCU

Constant Throttle Solenoid Valve Connector Wiring

Crankshaft Position Sensor and Bracket Location

Crankshaft Position Sensor and Camshaft Position Sensor Wiring

Crankshaft Position Sensor Location

Cruise Control Circuit

DDEC-VCU Grid Heater Wiring

Dual Fan on an MBE 4000 Engine

EGR Temperature Sensor Pins and 55-Pin Connector Wires

EGR Valve Wiring Diagram

Engine Coolant Level Sensor Connector Wire Locations - 440L Engine

Engine Coolant Level Sensor Connector Wire Locations - Acterra Engine

Engine Coolant Level Sensor Installation

Engine Coolant Level Sensor Connections

Engine Coolant Level Sensor Location - Top of Radiator Tank

Engine Coolant Level Sensor Specifications

Engine Coolant Temperature Sensor Wiring

Engine Harness Connector for MBE 900 EGR Engine

Engine Oil Combination Sensor Wiring Harness Connections

Exhaust brake and Cooling Fan Wiring

Grid Heater Figure

Injector Unit Pump Wiring on 6-Cylinder Engine

Location of Camshaft Position Sensor and Crankshaft Position Sensor

Location of Constant Throttle Solenoid Valve

Location of DDEC-VCU and Wiring Harness Connectors

Location of Engine Coolant Temperature Sensor on the MBE 4000 Engine

Location of Engine Coolant Temperature Sensor on the MBE 900 Engine

Location of Engine Oil Combination Sensor on the MBE 4000 Engine

Location of Engine Oil Combination Sensor

Location of Fan Control Wires

Location of Pins on Engine Oil Combination Sensor

Location of PLD-MR Control Unit

Location of Supply Fuel Temperature Sensor

Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine

Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine

Location of Wiring Harness Connectors

Locking Terminal into Connector

Main Power Supply Shutdown 12 or 24 Volt Systems

MBE 4000 Non-EGR Engine Brake

MBE 900 Non-EGR VIH to Engine Harness Wiring

NAFTA Architecture

Parking Brake Digital Input

Pin Locations on Fan Electrical Connector

PLD-MR and Harness Connectors

PLD-MR Connectors

PLD-MR Control Unit Data Plate

PLD-MR Control Unit on Engine

PLD-MR Engine Bulkhead Schematic - Acterra

PLD-MR Engine Bulkhead Schematic - Business Class

Positioning the Leads

Power Wiring

Pushing Contact into Grommet

Recommended Strain Relief of Spliced Joint

Removal Tool Insertion

Removal Tool Position

Securing the Leads With a Clip

Sensor Location on the MBE 4000 Engine

Sensor Location on the MBE 4000 Engine (CMP sensor)

Sensor Location on the MBE 6-Cylinder Engine

Sensor Location on the MBE 900 Engine

Sensor Locations on the MBE 4000 Engine with EGR

Sensor Locations on the MBE 900 Engine with EGR

Setting Wire Gage Selector and Positioning the Contact

Single-Speed Fan on an MBE 4000 Engine

Single-Speed Fan on an MBE 900 Engine

Splicing Straight Leads - Alternate Method 1

Splicing Straight Leads - Alternate Method 2

Starter Lockout

Supply Fuel Temperature Sensor Connector

Supply Fuel Temperature Sensor Pins and 55-Pin Connector Wires

Terminal Locations on Injector Unit Pump

The Correct and Incorrect Method of Staggering Multiple Splices

The DDEC-VCU

The Vehicle Control Unit

Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine

Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine

Turbo Boost Air Combination Sensor

Turbo Speed Sensor Location

Turbo Speed Sensor Terminal and Wire Locations

Two-Speed Fan on an MBE 4000 Engine

Typical Accelerator Pedal Installation

Typical Exhaust Brake Installation

Typical MBE 4000 Engine Harness - Non-EGR Engine

Typical On-Highway MBE 900 Engine Harness - Non-EGR Engine

Typical On-Highway MBE 900 Six-cylinder Engine Harness - EGR Engine

Typical On-Highway Vehicle Interface Harness with a DDEC-VCU

Variable-Speed Fan on an MBE 4000 Engine

Variable-Speed Fan on an MBE 900 Engine

Vehicle Power Shutdown Relay

Vehicle Speed Sensor Wiring Figure

Vehicle Speed Sensor Figure

Wiring for 6-Pin Data Link Connector

Wiring for 9-Pin Data Link Connector

TABLES

16-Pin Connector to the PLD-MR

4-Cylinder Engine Injector Unit Pump Low Resistance Wires/Repair Wires

6-Cylinder Engine Injector Unit Pump Low Resistance Wires/Repair Wires

Analog Inputs table

Applied Load Criteria for Terminals

Communication Interface Data Links

Configurable Parameters on the DDEC-VCU 15- and 18-Pin Connectors

Current Draw for DDEC-VCU Configuration

Current Draw for PLD-MR Configuration

DDEC-VCU 15-pin Connector Part Numbers

DDEC-VCU 15-Pin VIH Connector Pin Assignments

DDEC-VCU 18-pin Connector Part Numbers

DDEC-VCU 18-Pin VIH Connector Pin Assignments

DDEC-VCU 21-pin Connector Part Numbers

DDEC-VCU 21-Pin VIH Connector Pin Assignments

DDEC-VCU-to-PLD-MR 16-pin Connector Part Numbers

Digital Inputs table

Digital Outputs table

Enabling the Engine Coolant Level Sensor

Engine Coolant Level Sensor Installation Kit P/N 23515397 (1/4 in NPTF)

Engine Coolant Level Sensor Installation Kit P/N 23515398 (3/8 in. NPTF)

Engine Harness - Pins 0-27

Engine Harness - Pins 28-50

Engine Harness - Pins 51-54

Engine Harness Connector for Engines with Two Solenoid Air Valves for Engine Brakes - MBE 4000 Only

Engine Harness Connector for MBE 900 EGR Engine table

Engine Harness Connector for MBE 900 Non-EGR Engine

Function and Guidelines for OEM-installed Sensors

Function of Factory-Installed Sensors

Fuse Current and Blow Time

Fuse Holder Part Numbers

Fuse Temperature and Current

J1708/1587 DDEC-VCU to VIH Connector Pin Assignments

J1939 DDEC-VCU to VIH Connector Pin Assignments

Magnetic Pickup Vehicle Speed Sensor Requirements

Maximum Average Current Draw

Metri-Pack 280 Connectors and Part Numbers

Nominal Power and Resistance

Nominal Power and Resistance (12V and 24V systems)

OEM 8-Pin Connector for MBE 4000 Non-EGR Engine

OEM Connectors for Constant Throttle Valve/Exhaust Flap and Fan on MBE 900 EGR and Non-EGR Engines

PLD-MR Current Consumption

PLD-MR Part Numbers and Software Versions

PLD-MR Polarity/Overload Protection

PLD-MR Short Circuit Recognition Thresholds

PLD-MR Voltage Supply

Proportional Valves

Propriety IES-CAN Data Link

Recommended Splicing Tools (Clipped and Soldered Splicing Method)

Recommended Splicing Tools_1

Removal Tools for Deutsch Terminals

Required Components to Incorporate an SAE J1939/J1587 Data Link in the VIH with the 9-Pin Connector

Required Components to Incorporate an SAE J1939/J1587 Data Link in the VIH with the 6-Pin Connector

Selected Harness Pin Locations

Sensor Types

Vehicle Speed Sensor Parameters (Table 2)

Vehicle Speed Sensor Parameters (Magnetic Pickup)

Vehicle Speed Sensor Wiring Table


001 05 - Current Below Normal or Open Circuit

  1. 05 - Current Below Normal or Open Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a current below normal or open circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If fault code 168 04 is active in addition to code 001 05, refer to 168 04 - Battery Voltage Low Fault.

b. If following fault codes are active in addition to code 001 05, refer to Required Action:

6-Cylinder Engine - 002 05 and 003 05.

4-Cylinder Engine - 002 05.

c. If following fault codes are active in addition to code 001 05, refer to 168 04 - Battery Voltage Low Fault.

6-Cylinder Engine - 168 04 and 003 05.

4-Cylinder Engine - 168 04 and 002 05.

d. If only fault code 001 05 is active with no additional fault codes, go to step 2.

  2. Bridge terminals K10 and K11 of unit pump 1.

a. If new fault 001 06 is not active when bridging terminals, repair open circuit in 55-pin connector wire 54 attached to terminal K10 of unit pump 1. Erase fault code memory. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine.

b. If new fault 001 06 is active when bridging terminals, go to step 3.

  3. Swap the unit pump.

a. If fault code 001 05 is not active after swapping pump, replace the original unit pump. Erase fault code memory.

b. If fault code 001 05 is still active after swapping pump, go to step 4.

  4. Clean and check contacts.

a. If fault code 001 05 is not active after cleaning and checking contacts, erase fault code memory.

b. If fault code 001 05 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


001 06 Through 006 06 - Short Circuit

  1. 06 Through 006 06 - Short Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot an injector unit pump short circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display.

a. If fault code 001 06, 002 06, 003 06, 004 06, 005 06 or 006 06 is active while the engine is running, go to step 2.

b. If fault code 001 06, 002 06, 003 06, 004 06, 005 06 or 006 06 is active after disconnecting pump, refer to Required Action.

  2. Measure the resistance between ground and the wire sides of injector unit pumps 1, 2, 3, 4, 5 or 6.

a. If resistance is less than 30 k [image] on any wire, refer to Required Action.

b. If resistance is more than 30 k [image], go to step 3.

  3. Swap the unit pump.

a. If fault code 001 06, 002 06, 003 06, 004 06, 005 06 or 006 06 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault code 001 06, 002 06, 003 06, 004 06, 005 06 or 006 06 is still active after swapping pump, go to step 4.

  4. Check and clean contacts as required.

a. If fault code 001 06, 002 06, 003 06, 004 06, 005 06 or 006 06 is not active after checking and cleaning contacts, erase fault code memory.

b. If fault code 001 06, 002 06, 003 06, 004 06, 005 06 or 006 06 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


001 07 - No Plunger

  1. 07 - No Plunger

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a no plunger fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display.

a. If fault code 001 07 is not active after running the engine for at least 5 minutes, erase fault code memory.

b. If fault code 001 07 is still active after running the engine for at least 5 minutes, go to step 2.

  2. Check for additional fault codes:

a. If additional fault code 001 06 is produced, refer to 001 06 Through 006 06 - Short Circuit.

b. If additional fault code 168 04 is produced, refer to 168 04 - Battery Voltage Low Fault.

c. If additional fault code 001 05 is produced, refer to 001 05 - Current Below Normal or Open Circuit.

d. If additional fault code 002 07 is produced, go to step 3.

e. If additional fault code 003 07 is produced, go to step 4.

  3. Measure resistance between the following 55-pin connector wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires on 6-cylinder engine and see Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires on 4-cylinder engines.

Wire 54 to terminal K10 on unit pump 1.

Wire 47 to terminal K13 on unit pump 2.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 5.

  4. Measure resistance between the following 55-pin connector wires:

Wire 54 to terminal K10 of unit pump 1.

Wire 53 to terminal K14 of unit pump 3.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 5.

  5. Swap unit pump. Start engine.

a. If fault 001 07 is not active after swapping pump, replace original unit pump. Erase fault code memory.

b. If fault 001 07 is still active after swapping pump, contact Detroit Diesel Technical Service.


001 12 Through 006 12 - Idle Smoothness Governor at Limit

  1. 12 Through 006 12 - Idle Smoothness Governor at Limit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot an idle smoothness governor at limit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If a fault code between 001 06 and 006 06 is active in addition to any fault code between 001 12 and 006 12, refer to 001 06 Through 006 06 - Short Circuit.

b. If a fault code between 001 12 and 006 012 is active with no additional fault codes, go to step 2.

  2. Run an idle speed balance test.

a. If injectors are out of balance, identify and correct faulty injectors.

b. If injectors are in balance, go to step 3.

  3. Perform a comparative compression test on all cylinders.

a. If the test reveals a compression leak in the relevant cylinder, determine the cause and repair/correct the compression leak. Erase fault code memory.

b. If the test does not reveal a compression leak in the relevant cylinder, contact Detroit Diesel Technical Service.


001 14 Through 006 14 - Single Cylinder Correction at Idle

  1. 14 Through 006 14 - Single Cylinder Correction at Idle

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a single cylinder correction at idle fault, perform the following step:

  1. Contact Detroit Diesel Technical Service.


 002 05 - Current Below Normal or Open Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a current below normal or open circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If fault code 168 04 is active in addition to code 002 05, refer to 168 04 - Battery Voltage Low Fault.

b. If following fault codes are active in addition to 002 05, refer to 168 04 - Battery Voltage Low Fault.

6-Cylinder Engine - 168 04 and 001 05 and 003 05.

4-Cylinder Engine - 168 04 and 001 05.

c. If following fault codes are active in addition to 002 05, refer to Required Action:

6-Cylinder Engine - 001 05 and 003 05.

4-Cylinder Engine - 001 05.

d. If only fault code 002 05 is active with no additional fault codes, go to step 2.

  2. Bridge the following unit pump terminals:

    6. Cylinder Engine - K12 and K13 on injector unit pump 2.

    4-Cylinder Engine - K12 and K13 on unit pump 2.

a. If new fault 002 06 is not active on 6-cylinder engines or if new fault 001 06 is not active on 4-cylinder engines while bridging terminals, refer to Required Action.

b. If new fault 002 06 is active on 6-cylinder engines or if new fault code 001 06 is active on 4-cylinder engines while bridging terminals, go to step 3.

  3. Swap unit pump.

a. If fault 002 05 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 002 05 is still active after swapping pump, go to step 4.

  4. Clean and check contacts.

a. If fault code 002 05 is not active after cleaning and checking contacts, erase fault code memory.

b. If fault code 002 05 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


 002 07 - No Plunger

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a no plunger fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display.

a. If fault code 002 07 is not active after running the engine for at least 5 minutes, erase fault code memory.

b. If fault code 002 07 is still active after running the engine for at least 5 minutes, go to step 2.

  2. Check for additional fault codes:

a. If additional fault code 002 06 is produced, refer to 001 06 Through 006 06 - Short Circuit.

b. If additional fault code 168 04 is produced, refer to 168 04 - Battery Voltage Low Fault.

c. If additional fault code 002 05 is produced, refer to 002 05 - Current Below Normal or Open Circuit.

d. If additional fault code 001 07 is produced, go to step 3.

e. If additional fault code 003 07 is produced, go to step 5.

  3. Measure resistance between the following 55-pin connector wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires on 6-cylinder engine and see Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires on 4-cylinder engines.

Wire 54 to terminal K10 on unit pump 1.

Wire 47 to terminal K13 on unit pump 2.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Swap unit pump. Start engine.

a. If fault 002 07 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 002 07 is still active after swapping pump, contact Detroit Diesel Technical Service.

  5. Measure resistance between the following 55-pin connector wires:

Wire 54 to terminal K10 of unit pump 1.

Wire 53 to terminal K14 of unit pump 3.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.


003 05 - Current Below Normal or Open Circuit

  • 05 - Current Below Normal or Open Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a current below normal or open circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If fault code 168 04 is active in addition to code 003 05, refer to 168 04 - Battery Voltage Low Fault.

b. If following fault codes are active in addition to 003 05, refer to 168 04 - Battery Voltage Low Fault.

6-Cylinder Engine - 168 04 and 001 05 and 002 05.

4-Cylinder Engine - 168 04 and 004 05.

c. If following fault codes are active in addition to 003 05, refer to Required Action:

6-Cylinder Engine - 001 05 and 004 05.

4-Cylinder Engine - 004 05.

d. If only fault code 003 05 is active with no additional fault codes, go to step 2.

  2. Bridge the following unit pump terminals:

    6. Cylinder Engine - K14 and K15 on injector unit pump 3.

    4-Cyl Eng. - K14 and K15 on unit pump 3.

a. If new fault 003 06 is not active while bridging terminals, refer to Required Action.

b. If new fault 003 06 is active while bridging terminals, go to step 3.

  3. Swap unit pump.

a. If fault 003 05 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 003 05 is still active after swapping pump, go to step 4.

  4. Clean and check contacts.

a. If fault code 003 05 is not active after cleaning and checking contacts, erase fault code memory.

b. If fault code 003 05 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


003 07 - No Plunger

  • 07 - No Plunger

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a no plunger fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If fault code 003 07 is not active after running the engine for at least 5 minutes, erase fault code memory.

b. If fault code 003 07 is still active after running the engine for at least 5 minutes, go to step 2.

  2. Check for additional fault codes:

a. If additional fault code 003 05 is produced, refer to 003 05 - Current Below Normal or Open Circuit.

b. If additional fault code 168 04 is produced, refer to 168 04 - Battery Voltage Low Fault.

c. If additional fault code 003 06 is produced, refer to 001 06 Through 006 06 - Short Circuit.

d. If additional fault code 002 07 is produced, go to step 3.

e. If additional fault code 001 07 is produced, go to step 5.

  3. Measure resistance between the following 55-pin connector wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires on 6-cylinder engine and see Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires on 4-cylinder engines.

Wire 53 to terminal K14 on unit pump 3.

Wire 47 to terminal K13 on unit pump 2.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Swap unit pump. Start engine.

a. If fault 003 07 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 003 07 is still active after swapping pump, contact Detroit Diesel Technical Service.

  5. Measure resistance between the following 55-pin connector wires:

Wire 54 to terminal K10 of unit pump 1.

Wire 53 to terminal K14 of unit pump 3.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.


 004 05 - Current Below Normal or Open Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a current below normal or open circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display.

a. If fault code 168 04 is active in addition to code 004 05, refer to 168 04 - Battery Voltage Low Fault.

b. If following fault codes are active in addition to 004 05, refer to 168 04 - Battery Voltage Low Fault.

6-Cylinder Engine - 168 04 and 005 05 and 006 05.

4-Cylinder Engine - 168 04 and 003 05.

c. If following fault codes are active in addition to 004 05, refer to Required Action:

6-Cylinder Engine - 005 05 and 006 05.

4-Cylinder Engine - 003 05.

d. If only fault code 004 05 is active with no additional fault codes, go to step 2.

  2. Bridge the following unit pump terminals:

    6. Cylinder Engine - K38 and K58 on injector unit pump 4.

    4-Cyl Eng. - K16 and K17 on injector unit pump 4.

a. If new fault 004 06 is not active while bridging terminals, refer to Required Action.

b. If new fault 004 06 is active while bridging terminals, go to step 3.

  3. Swap unit pump.

a. If fault 004 05 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 004 05 is still active after swapping pump, go to step 4.

  4. Clean and check contacts.

a. If fault code 004 05 is not active after cleaning and checking contacts, erase fault code memory.

b. If fault code 004 05 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


 004 07 - No Plunger

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a no plunger fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If fault code 004 07 is not active after running the engine for at least 5 minutes, erase fault code memory.

b. If fault code 004 07 is still active after running the engine for at least 5 minutes, go to step 2.

  2. Check for additional fault codes:

a. If additional fault code 004 05 is produced, refer to 004 05 - Current Below Normal or Open Circuit.

b. If additional fault code 168 04 is produced, refer to 168 04 - Battery Voltage Low Fault.

c. If additional fault code 004 06 is produced, refer to 001 06 Through 006 06 - Short Circuit.

d. If additional fault code 006 07 is produced, go to step 3.

e. If additional fault code 005 07 is produced, go to step 5.

  3. Measure resistance between the following 55-pin connector wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires on 6-cylinder engine and see Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires on 4-cylinder engines.

Wire 44 to terminal K21 on unit pump 6.

Wire 38 to terminal K38 on unit pump 4.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Swap unit pump. Start engine.

a. If fault 004 07 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 004 07 is still active after swapping pump, contact Detroit Diesel Technical Service.

  5. Measure resistance between the following 55-pin connector wires:

Wire 45 to terminal K19 of unit pump 5.

Wire 38 to terminal K38 of unit pump 4.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.


 4-Cylinder Engine Injector Unit Pump Low Resistance Wires/Repair Wires

Resistance Less than 30 k [image] inInjector Unit Pump Terminal Wire
Repair Short to Ground in Injector Unit Pump Terminal Wire
Unit Pump No.
         Terminal No.
         Wire No.
Unit Pump No.
         Terminal No.
         Wire No.

K10
         54

K10
         54

K11
         16

K11
         16

K12
         16
2
         K13
         53
2
         K13
         53

K12
         16

K11
         16

K12
         16

K14
         45
3
         K14
         45

K15
         9
3
         K15
         9

K16
         9
4
         K17
         44
4
         K17
         44

K16
         9
3
         K15
         9

4
         K16
         9


 005 05 - Current Below Normal or Open Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a current below normal or open circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display:

a. If fault code 168 04 is active in addition to code 005 05, refer to 168 04 - Battery Voltage Low Fault.

b. If fault codes 168 04 and 004 05 and 006 05 are active in addition to 005 05, refer to 168 04 - Battery Voltage Low Fault.

c. If fault codes 004 05 and 006 05 are active in addition to 005 05, refer to Required Action.

d. If only fault code 005 05 is active with no additional fault codes, go to step 2.

  2. Bridge terminals K18 and K19 on injector unit pump 5.

a. If new fault 005 06 is not active while bridging terminals, refer to Required Action.

b. If new fault 005 06 is active while bridging terminals, go to step 3.

  3. Swap unit pump.

a. If fault 005 05 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 005 05 is still active after swapping pump, go to step 4.

  4. Clean and check contacts.

a. If fault code 005 05 is not active after cleaning and checking contacts, erase fault code memory.

b. If fault code 005 05 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


 005 07 - No Plunger

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a no plunger fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display.

a. If fault code 005 07 is not active after running the engine for at least 5 minutes, erase fault code memory.

b. If fault code 005 07 is still active after running the engine for at least 5 minutes, go to step 2.

  2. Check for additional fault codes:

a. If additional fault code 005 05 is produced, refer to 005 05 - Current Below Normal or Open Circuit.

b. If additional fault code 168 04 is produced, refer to 168 04 - Battery Voltage Low Fault.

c. If additional fault code 005 06 is produced, refer to 001 06 Through 006 06 - Short Circuit.

d. If additional fault code 006 07 is produced, go to step 3.

e. If additional fault code 004 07 is produced, go to step 5.

  3. Measure resistance between the following 55-pin connector wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires on 6-cylinder engine and see Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires on 4-cylinder engines.

Wire 44 to terminal K21 on unit pump 6.

Wire 45 to terminal K19 on unit pump 5.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Swap unit pump. Start engine.

a. If fault 005 07 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 005 07 is still active after swapping pump, contact Detroit Diesel Technical Service.

  5. Measure resistance between the following 55-pin connector wires:

Wire 45 to terminal K19 of unit pump 5.

Wire 38 to terminal K38 of unit pump 4.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.


 006 05 - Current Below Normal or Open Circuit

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a current below normal or open circuit fault, perform the following steps with unit pump connected and engine running:

  1. Check fault code display.

a. If fault code 168 04 is active in addition to code 006 05, refer to 168 04 - Battery Voltage Low Fault.

b. If fault codes 168 04 and 004 05 and 005 05 are active in addition to 006 05, refer to 168 04 - Battery Voltage Low Fault.

c. If fault codes 004 05 and 005 05 are active in addition to 006 05, refer to Required Action.

d. If only fault code 006 05 is active with no additional fault codes, go to step 2.

  2. Bridge terminals K20 and K21 on injector unit pump 6.

a. If new fault 006 06 is not active while bridging terminals, refer to Required Action.

b. If new fault 006 06 is active while bridging terminals, go to step 3.

  3. Swap unit pump.

a. If fault 006 05 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 006 05 is still active after swapping pump, go to step 4.

  4. Clean and check contacts.

a. If fault code 006 05 is not active after cleaning and checking contacts, erase fault code memory.

b. If fault code 006 05 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


 006 07 - No Plunger

For overviews, see:

DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

TROUBLESHOOTING SIDS 1-6

To troubleshoot a no plunger fault, perform the following steps with unit pump connected and engine running:Check fault code display:

a. If fault code 006 07 is not active after running the engine for at least 5 minutes, erase fault code memory.

b. If fault code 006 07 is still active after running the engine for at least 5 minutes, go to step 2.

2. Check for additional fault codes:

a. If additional fault code 006 05 is produced, refer to 006 05 - Current Below Normal or Open Circuit.

b. If additional fault code 168 04 is produced, refer to 168 04 - Battery Voltage Low Fault.

c. If additional fault code 006 06 is produced, refer to 001 06 Through 006 06 - Short Circuit.

d. If additional fault code 005 07 is produced, go to step 3.

e. If additional fault code 004 07 is produced, go to step 5.

f. If only fault code 006 07 is active with no additional fault codes, go to step 4.

  3. Measure resistance between the following 55-pin connector wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires on 6-cylinder engine and see Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires on 4-cylinder engines.

Wire 44 to terminal K21 on unit pump 6.

Wire 45 to terminal K19 on unit pump 5.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Swap unit pump. Start engine.

a. If fault 006 07 is not active after swapping pump, replace original cylinder unit pump. Erase fault code memory.

b. If fault 006 07 is still active after swapping pump, contact Detroit Diesel Technical Service.

  5. Measure resistance between the following 55-pin connector wires:

Wire 44 to terminal K21 of unit pump 6.

Wire 38 to terminal K38 of unit pump 4.

a. If resistance is not greater than 30 k [image], refer to Required Action.

b. If resistance is greater than 30 k [image], go to step 4.


 6-Cylinder Engine Injector Unit Pump Low Resistance Wires/Repair Wires

Resistance Less than 30 k [image] inInjector Unit Pump Terminal Wire
Repair Short to Ground in Injector Unit Pump Terminal Wire
Unit Pump No.
         Terminal No.
         Wire No.
Unit Pump No.
         Terminal No.
         Wire No.

K10
         54

K10
         54

K11
         16

K11
         16

K12
         16

K15
         16
3
         K14
         53
3
         K14
         53

K15
         16

K11
         16

3
         K15
         16

K12
         16
2
         K13
         47
2
         K13
         47

K12
         16

K11
         16

K12
         16

K15
         16
5
         K19
         45
5
         K19
         45

K18
         9

K58
         9

K18
         9

K20
         9
6
         K21
         44
6
         K21
         44

K20
         9
4
         K58
         9

5
         K18
         9

6
         K20
         9
4
         K38
         38
4
         K38
         38

K58
         9
4
         K58
         9

5
         K18
         9

6
         K20
         9


 16-Pin Connector to the PLD-MR

Pin
         Signal Type
         Function

Data Link
         CAN Interface (High Line)

Data Link
         CAN Interface (Low Line)

Data Link
         CAN HF Ground

Data Link
         CAN HF Ground

Power Supply
         Battery Voltage (+)

Power Supply
         Battery Voltage (+)

NC
         NC

Digital Output
         Starter Control Signal

Ground
         Battery Ground (-)

Digital Output
         Proportional Valve 1-4 High Side Supply

Ground
         Battery Ground (-)

Digital Output
         Starter High Side Control

Digital Data Link
         Diagnostic Link K-line (ISO)

Digital Output
         Proportional Valve 3 Low Side Control

Ignition Input
         Ignition

Digital Output
         Proportional Valve 4 Low Side Control


 021 01 - Crankshaft Position Sensor Signal Voltage Too Low

For overviews, see:

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

Troubleshoot a CKP sensor signal voltage too low fault as follows:

  1. If fault occurs only when cranking the engine (and engine will not start), check that the CKP and Camshaft Position (CMP) sensors are correctly wired to the PLD-MR. See Crankshaft Position Sensor and Camshaft Position Sensor Wiring.

a. If wires are not correctly wired, repair or replace wires as required. Erase fault code memory.

b. If wires are correctly wired, go to step 2.

  2. If fault occurs at other times then when cranking the engine (and engine will not start), check the CKP sensor position.

a. If fault is not active after checking CKP sensor position, repair the CKP sensor clamping sleeve. Erase fault code memory.

b. If fault is still active after checking the CKP sensor position, go to step 3.

  3. Check the flywheel sensor position through the inspection window of the timing case using turning tool.

a. If sensors are out of position, repair or replace, as required. Erase fault code memory.

b. If sensors are not out of position, go to step 4.

  4. Check crankshaft axial play.

a. If axial play is not within specifications, repair or replace crankshaft thrust bearings, as required. Erase fault code memory.

b. If axial play is within specifications, contact Detroit Diesel Technical Service.


 021 03 - Crankshaft Position Sensor Open Circuit

For overviews, see:

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

Troubleshoot a CKP sensor open circuit fault as follows:

  1. Bridge pins 2 and 19 on the 55-pin connector. See Crankshaft Position Sensor and Camshaft Position Sensor Wiring. Pin locations are listed in Selected Harness Pin Locations.

a. If new fault 021 04 is active, replace CKP sensor and clamping sleeve. Erase fault code memory.

b. If new fault 021 04 is not active, go to step 2.

  2. Check and clean contacts.

a. If fault 021 03 is still active, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.

b. If fault 021 03 is not active, erase fault code memory.


 021 04 - Crankshaft Position Sensor Short to Ground

For overviews, see:

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

Troubleshoot a CKP sensor short to ground fault as follows:

  1. Unplug the 55-pin connector from the PLD-MR.

a. If new fault code 021 03 is active, replace the CKP sensor and clamping sleeve. Erase fault code memory.

b. If new fault code 021 03 is not active, go to step 2.

  2. Check and clean contacts.

a. If fault 021 04 is active, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.

b. If fault 021 04 is not active, check the contact, clean contacts (if necessary), and erase fault code memory.


 021 07 - No Match of Camshaft and Crankshaft Signals

For overviews, see:

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

Troubleshoot a no match of camshaft and crankshaft signals fault as follows:

  1. Perform a polarity test on the engine speed sensor.

a. If fault 021 07 is not active after performing test, erase fault code memory.

b. If fault 021 07 is active after performing test, go to step 2.

  2. Reseat the CKP and CMP sensors and check for crossed wires on the 55-pin connector. See Crankshaft Position Sensor and Camshaft Position Sensor Wiring.

a. If wires are crossed, repair or replace wires. Erase fault code memory.

b. If wires are not crossed, contact Detroit Diesel Technical Service.


 021 08 - Sensor Time Out

For overviews, see:

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

Troubleshoot a sensor time out fault, as follows:

  1. If fault 021 03 is active in addition to fault 021 08 with engine running, refer to 021 03 - Crankshaft Position Sensor Open Circuit.

  2. If fault 021 04 is active in addition to fault 021 08 with engine running, refer to 021 04 - Crankshaft Position Sensor Short to Ground.

  3. Check the sensor position.

a. If fault 021 08 is not active after checking position, replace CKP sensor clamping sleeve. Erase fault code memory.

b. If fault 021 08 is active after checking position, go to step 4.

  4. Perform a polarity test on the CKP sensor.

a. If test confirms polarity is reversed (fault 021 14 is present), check for crossed wires on the 55-pin connector and repair or replace wires. See Crankshaft Position Sensor and Camshaft Position Sensor Wiring. Erase fault code memory.

b. If sensor polarity is not reversed, go to step 5.

  5. Replace the engine speed sensor.

a. If fault 021 08 is not active, erase fault code memory.

b. If fault 021 08 is still active, go to step 6.

  6. Check the flywheel sensor position in the timing case through the inspection window using turning tool.

a. If sensors are out of position, repair or replace the spring bushing, as required. Erase fault code memory. See Crankshaft Position Sensor Location.

b. If sensors are not out of position, go to step 7.

  7. Check crankshaft axial play.

a. If axial play is not within specifications, repair or replace crankshaft thrust bearings, as required. Erase fault code memory.

b. If axial play is within specifications, contact Detroit Diesel Technical Service.


 021 14- Pins Swapped

For overviews, see:

DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

TROUBLESHOOTING SID 21

Troubleshoot a pins swapped fault as follows:

  1. Perform a polarity test on the engine speed sensor.

a. If polarity is not reversed, erase fault code memory.

b. If polarity is reversed (fault 021 14 is present), go to step 2.

  2. Reseat the CKP and CMP sensors and check for crossed wires. See Crankshaft Position Sensor and Camshaft Position Sensor Wiring.

a. If crossed wires are found, repair or replace wires. Erase fault code memory.

b. If crossed wires are not found, contact Detroit Diesel Technical Service.


045 03;Open Circuit Fault

 045 03 - Open Circuit Fault

For overviews, see:

DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

TROUBLESHOOTING PID 45

Perform the following step to troubleshoot an open circuit fault.

  1. Measure the resistance between wire 10 on the 12-pin connector and the grid heater ground.

a. If resistance is greater than 70 m [image] [image] for a 12-volt system, replace the grid heater. Erase fault code memory.

b. If resistance is less than 70 m [image] [image] for a 12-volt system, contact Detroit Diesel Technical Service.


045 04;Short to Ground Fault

 045 04 - Short to Ground Fault

For overviews, see:

DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

TROUBLESHOOTING PID 45

Perform the following step to troubleshoot a short to ground fault.

  1. Measure the resistance between wire 10 on the 12-pin connector and the grid heater ground.

a. If resistance is 0 [image] [image], replace the grid heater. Erase fault code memory.

b. If resistance is greater than 0 [image], contact Detroit Diesel Technical Service.


55-Pin Wiring Harness Connector

 Pin Locations on 55-Pin Connector

  1. 55-Pin Connector


 057 05 - Open Circuit in the Engine Brake Flap Solenoid Valve and Wiring

For overviews, see:

DESCRIPTION OF SID 57 - EXHAUST BRAKE FAULT

TROUBLESHOOTING SID 57

Perform the following procedures to troubleshoot an open circuit in the engine brake flap solenoid valve and wiring.

If the engine has no exhaust brake flap, perform the following step:

  1. Read Parameter 00601.

a. If Parameter 00601 is "Not Active", contact Detroit Diesel Technical Service Group.

b. If Parameter 00601 is "Active", refer to Required Actions. If the engine has an exhaust brake flap, perform the following steps:

  1. Measure the resistance between the 55-pin connector wires 12 and 51 of the bridged exhaust brake. See Exhaust brake and Cooling Fan Wiring.

a. If the resistance is less than 3 [image], contact Detroit Diesel Technical Service Group.

b. If the resistance is greater than or equal to 3 [image], refer to Required Actions.

  2. Bridge the exhaust brake solenoid wires and read the active fault codes.

a. If Fault Code 057 06 is present, refer to Required Actions.

b. If there are no active fault codes, erase the fault code memory and troubleshooting is done.


 057 06 - Short in the Engine Brake Flap Solenoid Valve and Wiring

For overviews, see:

DESCRIPTION OF SID 57 - EXHAUST BRAKE FAULT

TROUBLESHOOTING SID 57

Perform the following procedures to troubleshoot a short in the engine brake flap solenoid valve and wiring.

If the engine has no exhaust brake flap, perform the following step:

  1. Read Parameter 00601.

a. If Parameter 00601 is "Not Active", contact Detroit Diesel Technical Service Group.

b. If Parameter 00601 is "Active", refer to Required Actions.

If the engine has an exhaust brake flap, perform the following steps:

  1. Measure the resistance between the 55-pin connector wire 12 and vehicle ground. See Exhaust Brake and Cooling Fan Wiring.

a. If the resistance is less than 30 k [image], refer to Required Actions.

b. If the resistance is greater than or equal to 30 k [image], contact Detroit Diesel Technical Service Group.

  2. Measure the resistance between the 55-pin connector wire 51 and vehicle ground. See Exhaust Brake and Cooling Fan Wiring.

a. If the resistance is less than 30 k [image], refer to Required Actions.

  3. Measure the resistance between the 55-pin connector wires 12 and 51. See Exhaust Brake and Cooling Fan Wiring.

a. If the resistance is less than 3 k [image], refer to Required Actions.

  4. Unplug the exhaust brake solenoid and read the active fault codes.

a. If Fault Code 057 05 is present, refer to Required Actions.

b. If there are no active fault codes, erase the fault code memory and troubleshooting is done.


 058 03 - Constant Throttle Solenoid Valve Short to Power

For overviews, see:

DESCRIPTION OF SID 58 - ENGINE BRAKE FAULT

TROUBLESHOOTING SID 58

Troubleshoot a Constant Throttle Solenoid Valve short to power fault as follows:

  1. Determine if the engine has a constant throttle solenoid valve. See Location of Constant Throttle Solenoid Valve.

a. If the engine has a constant throttle solenoid valve, repair short to power in 55-pin connector wire 50. Erase fault code memory. See Constant Throttle Solenoid Valve Connector Wiring.

b. If the engine does not have a constant throttle solenoid valve, go to step 2.

  2. Check for a setting of Parameter 006 02.

a. If Parameter 006 02 is not active, contact Detroit Diesel Technical Service.

b. If Parameter 006 02 is active, set parameters 006 03 and/or 006 04 to "Not Active." Erase fault code memory.


 058 05 - Constant Throttle Solenoid Valve Open Circuit

For overviews, see:

DESCRIPTION OF SID 58 - ENGINE BRAKE FAULT

TROUBLESHOOTING SID 58

Troubleshoot a Constant Throttle Solenoid Valve open circuit fault as follows:

  1. Determine if the engine has a constant throttle solenoid valve. See Location of Constant Throttle Solenoid Valve.

a. If the engine does not have a constant throttle solenoid valve, go to go to step 2.

b. If the engine has a constant throttle solenoid valve, go to step 3.

  2. Check for a setting of Parameter 006 02.

a. If Parameter 006 02 is not active, contact Detroit Diesel Technical Service.

b. If Parameter 006 02 is active, set parameters 006 03 and/or 006 04 to "Not Active." Erase fault code memory.

  3. Bridge wires 1 and 2 on the constant throttle solenoid valve connector. See Constant Throttle Solenoid Valve Connector Wiring.

a. If new fault code 058 06 is active, go to step 4.

b. If new fault code 058 05 is active, go to step 5.

  4. Measure the resistance between wire 52 on the 55-pin connector and vehicle ground. See Constant Throttle Solenoid Valve Connector Wiring.

a. If resistance is less than 30 k [image], repair short to ground in wire 52. Erase fault code memory.

b. If resistance is greater than 30 k [image], repair or replace the constant throttle solenoid valve. Erase fault code memory.

  5. Measure the resistance between wire 52 and wire 50 on the 55-pin connector. See Constant Throttle Solenoid Valve Connector Wiring.

a. If resistance is less than 3 [image], contact Detroit Diesel Technical Service.

b. If resistance is greater than 3 [image], repair open circuit or bad contact in wire 50 or 52. Erase fault code memory.


 058 06 - Constant Throttle Solenoid Valve Short to Ground

For overviews, see:

DESCRIPTION OF SID 58 - ENGINE BRAKE FAULT

TROUBLESHOOTING SID 58

Troubleshoot a Constant Throttle Solenoid Valve short to ground fault as follows:

  1. Determine if the engine has a constant throttle solenoid valve. See Location of Constant Throttle Solenoid Valve.

a. If the engine has a constant throttle solenoid valve, go to step 2.

b. If the engine does not have a constant throttle solenoid valve, go to step 3.

  2. Measure the resistance between wire 50 on the 55-pin connector and vehicle ground. See Constant Throttle Solenoid Valve Connector Wiring.

a. If resistance is greater than 30 k [image], contact Detroit Diesel Technical Service.

b. If resistance is less than 30 k [image], repair short to ground in wire 50. Erase fault code memory.

c. If fault code 058 06 is still active, go to step 4.

  3. Check for a setting of Parameter 006 02.

a. If Parameter 006 02 is not active, contact Detroit Diesel Technical Service.

b. If Parameter 006 02 is active, set parameters 006 03 and/or 006 04 to "Not Active." Erase fault code memory.

  4. Measure the resistance between wire 50 and wire 52 on the 55-pin connector. See Constant Throttle Solenoid Valve Connector Wiring.

a. If resistance is less than 3 [image], repair short circuit between wires 50 and 52. Erase fault code memory.

b. If fault 058 06 is still active, go to step 5.

  5. Unplug the constant throttle solenoid valve.

a. If new fault code 057 05 is active, repair or replace the constant throttle solenoid valve. Erase fault code memory.


 059 05 - Fan Open Circuit

For overviews, see:

DESCRIPTION OF SID 59 - DUAL-SPEED FAN LOW STAGE OPERATION FAULT

TROUBLESHOOTING SID 59

Perform the following steps to troubleshoot a fan open circuit fault:

  1. Bridge pins 1 and 3 on the fan electrical connector. See Pin Locations on Fan Electrical Connector.

a. If new fault code 059 06 is active, repair or replace the fan control clutch. Erase fault code memory.

b. If new fault code 059 06 is not active, go to step 2.

  2. Measure the resistance between wires 41 and 12 on the 55-pin wiring harness connector. See Location of Fan Control Wires.

a. If resistance is less than 3 [image], contact Detroit Diesel Technical Service.

b. If resistance is greater than 3 [image], repair open circuit or bad contact in wire 41 or 12. Erase fault code memory.


 059 06 - Fan Short to Ground

For overviews, see:

DESCRIPTION OF SID 59 - DUAL-SPEED FAN LOW STAGE OPERATION FAULT

TROUBLESHOOTING SID 59

Perform the following steps to troubleshoot a fan short-to-ground fault:

  1. Unplug the fan.

a. If new fault code 059 05 is active, repair or replace the fan control clutch. Erase fault code memory.

b. If new fault code 059 05 is not active, go to step 2.

  2. Measure the resistance between wires 41 and 12 on the fan electrical connector. See Location of Fan Control Wires.

a. If resistance is less than 3 [image], repair short circuit between wires 41 and 12. Erase fault code memory.

b. If resistance is greater than 3 [image], go to step 3.

  3. Measure the resistance between wires 43 and 12 on the fan electrical connector. See Location of Fan Control Wires.

a. If resistance is less than 3 [image], repair short circuit between wires 43 and 12. Erase fault code memory.

b. If resistance is greater than 3 [image], go to step 4.

  4. Measure the resistance between wire 41 on the fan electrical connector and vehicle ground. See Location of Fan Control Wires.

a. If resistance is less than 30 k [image], repair short to ground in wire 41. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 5.

  5. Measure the resistance between wire 43 on the fan electrical connector and vehicle ground. See Location of Fan Control Wires.

a. If resistance is less than 30 k [image], repair short to ground in wire 43. Erase fault code memory.

b. If resistance is greater than 30 k [image], contact Detroit Diesel Technical Service.


 060 05 - Fan Open Circuit

For overviews, see:

DESCRIPTION OF SID 60 - DUAL-SPEED FAN HIGH STAGE OPERATION FAULT

TROUBLESHOOTING SID 60

Perform the following steps to troubleshoot a fan open circuit fault.

  1. Bridge pins 2 and 3 on the fan electrical connector. See Pin Locations on Fan Electrical Connector.

a. If code 060 06 is active, repair or replace the fan control clutch. Erase fault code memory.

b. If code 060 06 is not active, go to step 2.

  2. Measure resistance between pins 43 and 12 on the 55-pin connector. See 55-Pin Wiring Harness Connector and see Location of Fan Control Wires.

a. If resistance is less than 3 [image], contact Detroit Diesel Technical Service.

b. If resistance is greater than 3 [image], repair open circuit in wire 43 or wire 12 on the 55-pin connector. Erase fault code memory.


 060 06 - Fan Short to Ground

For overviews, see:

DESCRIPTION OF SID 60 - DUAL-SPEED FAN HIGH STAGE OPERATION FAULT

TROUBLESHOOTING SID 60

Perform the following steps to troubleshoot a fan short to ground fault:

  1. Unplug cooling fan.

a. If new fault 060 05 is active when the cooling fan is unplugged, repair or replace the fan control clutch. Erase fault code memory.

b. If new fault 060 05 is not active when the cooling fan is unplugged, go to step 2.

  2. Measure the resistance between wire 41 and wire 12 on the 55-pin connector. See Location of Fan Control Wires.

a. If the resistance is less than 30 k [image], repair short circuit between wire 41 and wire 12 on the 55-pin connector. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 3.

  3. Measure the resistance between wire 43 and wire 12 on the 55-pin connector. See Location of Fan Control Wires.

a. If resistance is less than 30 k [image], repair short circuit between wire 43 and wire 12 on the 55-pin connector. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Measure the resistance between wire 43 and vehicle ground.

a. If resistance is greater than 30 k [image], contact Detroit Diesel Technical Service.

b. If resistance is less than 30 k [image], repair short to ground in wire 43 of the 55-pin connector. Erase fault code memory.


 064 03 - Open Circuit

For overviews, see:

DESCRIPTION OF SID 64 - CAMSHAFT POSITION SENSOR FAULT

TROUBLESHOOTING SID 64

Perform the following steps to troubleshoot an open circuit.

  1. Bridge pins 1 and 20 of the 55-pin connector and check for active fault codes. See Camshaft Position Sensor.

a. If no new fault codes were active, go to step 2.

b. If a new fault code 064 04 is active, refer to Required Actions.

  2. Check for active codes.

a. If fault code 064 03 was active, refer to Required Actions.

b. If fault code 064 03 was not active, refer to Required Actions.


 064 04 - Short to Ground

For overviews, see:

DESCRIPTION OF SID 64 - CAMSHAFT POSITION SENSOR FAULT

TROUBLESHOOTING SID 64

Perform the following step to troubleshoot a short to ground.

  1. Check the engine speed sensor for reversed polarity and check for active codes.

a. If the polarity is correct and fault code 064 14 was not active, go to step 2.

b. If the polarity is not correct and fault code 064 04 was active, refer to Required Actions.

  2. Check the engine speed sensor for reversed polarity and check for active codes.

a. If the polarity is correct and fault code 064 14 was active, go to step 5.

b. If the polarity is not correct and fault code 064 14 was not active, go to step 3.

  3. Disconnect 55-pin connector and check for active codes.

a. If fault code 064 03 was not active, go to step 5.

b. If fault code 064 03 was active, refer to Required Actions.

  4. Reconnect the 55-pin connector.

  5. Visually inspect the 55-pin connector for damage and check for active codes.

a. If fault code 064 04 was not active, refer to 064 08 - Time Out.

b. If fault code 064 04 was active, refer to Required Actions.

  6. Reconnect the 55-pin connector.


 064 08 - Time Out

For overviews, see:

DESCRIPTION OF SID 64 - CAMSHAFT POSITION SENSOR FAULT

TROUBLESHOOTING SID 64

Perform the following steps to troubleshoot a time out.

  1. Start and run the engine.

  2. Check for active fault codes.

a. If fault codes 064 03 and 064 08 are not active, go to step 5.

b. If fault codes 064 03 and 064 08 are active, refer to Required Actions.

  3. Shut down the engine.

  4. Start and run the engine.

  5. Check for active fault codes.

a. If fault codes 064 04 and 064 08 are not active, go to step 7.

b. If fault codes 064 04 and 064 08 are active, refer to Required Actions.

  6. Shut down the engine.

  7. Start and run the engine.

  8. Ensure that the sensor is correctly positioned and check for active codes.

a. If the sensor position is correct and fault code 064 08 is active, refer to 064 14 - Pins Swapped.

b. If the sensor position is incorrect and fault code 064 08 is not active, refer to Required Actions.

  9. Shut down the engine.

  10. Ensure that the sensor is correctly positioned and check for active codes.

a. If the sensor position is correct and fault code 064 08 is active, refer to Required Actions.

b. If the sensor position is incorrect and fault code 064 08 is not active, refer to Required Actions.


 064 14 - Pins Swapped

For overviews, see:

DESCRIPTION OF SID 64 - CAMSHAFT POSITION SENSOR FAULT

TROUBLESHOOTING SID 64

Perform the following step to troubleshoot pins swapped.

  1. Check the engine speed sensor for reversed polarity and check for active codes.

a. If fault code 064 14 was not active, erase the fault code memory.

b. If fault code 064 14 is active, refer to Required Actions.


 084 03 - Faulty Vehicle Speed Sensor

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following steps to troubleshoot a faulty VSS.

  1. Measure the battery voltage between wires 439S- and 439S+ at the VSS.

a. If battery voltage was not recorded, refer to 084 04 - Faulty Vehicle Speed Sensor.

b. If battery voltage was recorded, go to step 2.

  2. What fault code is active when bridging the disconnected VSS wires?

a. If fault 084 04 was recorded, refer to 084 04 - Faulty Vehicle Speed Sensor.

b. If no fault code was recorded, refer to Required Actions for required steps.


 084 03 - Open Circuit

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following steps to troubleshoot an open circuit.

  1. Measure the voltage between wires 439S- and 439S+. See Vehicle Speed Sensor Wiring.

a If there is no voltage present, go to step 2.

b If there is voltage present, refer to Required Actions.

  2. What fault code was active when bridging the disconnected VSS wires?

a If PID 084 FMI 03 is present go to step 3

b If PID 084 FMI 04 is present, refer to 084 03 - Faulty Vehicle Speed Sensor

  3. What fault is active when bridging wire 439S+ (at the VSS) to ground?

a If fault code 084 03 was recorded, refer to Required Actions.

b If fault code 084 04 was recorded, refer to Required Actions.

c If no fault codes were recorded, refer to 084 04 - Faulty Vehicle Speed Sensor for required steps.


 084 03 - Short to Power

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following steps to troubleshoot a short to power.

  1. Measure for battery voltage between wires 439S- and 439S+ at the VSS.

a. If battery voltage was not recorded, refer to 084 04 - Faulty Vehicle Speed Sensor.

b. If battery voltage was recorded, refer to Required Actions.


 084 04 - Faulty DDEC-VCU

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following steps to troubleshoot a faulty DDEC-VCU. See Location of DDEC-VCU and Wiring Harness Connectors.

  1. Disconnect the VSS.

  2. Check for active codes.

a. If fault code 084 04 was not recorded after disconnecting the VSS and waiting more than ten seconds, refer to 084 04 - Short to Ground.

b. If fault code 084 04 was recorded after disconnecting the VSS and waiting more than 10 seconds, refer to Required Actions.


 084 04 - Faulty Vehicle Speed Sensor

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following step to troubleshoot a faulty VSS.

  1. Check for active codes.

a. If fault 084 04 was recorded after disconnecting the VSS and waiting more than 10 seconds, refer to Required Actions.

b. If fault code 084 04 was not recorded after disconnecting the VSS and waiting more than 10 seconds, refer to 084 04 - Faulty DDEC-VCU.


084 04 - Short Between Wires 439S_ and 439S-

 084 04 - Short Between Wires 439S+ and 439S-

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following steps to troubleshoot 084 04 short between wires 439S+ and 439S-.

NOTE: The short could be between the DDEC-VCU and the Bulkhead connector or between the Bulkhead connector and the VSS.

  1. Disconnect the VSS and wait ten seconds.

  2. Check for active codes.

a. If fault code 084 04 was not active, contact the Detroit Diesel Technical Support Group.

b. If fault code 084 04 was active, go to step 3.

  3. Disconnect the 15-Pin connector.

  4. Check for active codes.

a. If fault code 084 04 was active, contact the Detroit Diesel Technical Support Group.

b. If fault code 084 04 was not active, go to step 5.

  5. Measure for continuity between the VSS wires 439S+ and 439S-.

a. If no continuity was measured, contact the Detroit Diesel Technical Support Group.

b. If continuity was measured, refer to Required Actions.


 084 04 - Short to Ground

For overviews, see:

DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

TROUBLESHOOTING PID 84

Perform the following steps to troubleshoot the 084 04 Wire 439S+ short to ground.

  1. Disconnect the VSS and wait ten seconds.

  2. Check for active codes.

a. If fault code 084 04 was not active after disconnecting the VSS and waiting ten seconds, refer to 084 04 - Short Between Wires 439S+ and 439S-.

b. If fault code 084 04 was active after disconnecting the VSS and waiting ten seconds, go to step 3.

  3. Disconnect the 15-Pin connector.

  4. Check for active codes.

a. If fault code 084 04 was not active after disconnecting the 15-Pin connector, refer to 084 04 - Short Between Wires 439S+ and 439S-.

b. If fault code 084 04 was active after disconnecting the 15-Pin connector, go to step 5.

  5. Measure for continuity between the VSS wires 439S+ and 439S-.

a. If continuity was recorded between wires 439S+ and 439S-, refer to 084 04 - Short Between Wires 439S+ and 439S-.

b. If continuity was not recorded between wires 439S+ and 439S-, refer to Required Actions.


 091 02 - Position Active Fault (Erratic Data)

For overviews, see:

DESCRIPTION OF PID 91 - ACCELERATOR PEDAL SENSOR FAULT

TROUBLESHOOTING PID 91

Perform the following steps to troubleshoot a position active fault.

  1. Check for active codes.

a. If fault code 091 04 was active, refer to 091 04 - Voltage Low.

b. If fault code 091 03 was active, refer to 091 03 - Voltage High.

c. If no other fault codes were active, go to step 2.

  2. Measure the power supply voltage to the AP assembly.

a. If the voltage measured was not within the range of 4.8 - 5.2 V, go to step 3.

b. If the voltage measured was within the range of 4.8 - 5.2 V, refer to Required Actions.

  3. Unplug the AP connector from the foot pedal and measure the power supply voltage.

a. If the power voltage was not within 4.8 - 5.2 V, go to step 5.

b. If the power voltage was within 4.8 - 5.2 V, refer to Required Actions.

  4. Reconnect the AP connector.

  5. Measure the power supply voltage to the AP assembly with wires 440P+ (pin 9 of the 21-pin connector) and 440P- (pin 14 of the 21-pin connector) disconnected. See Accelerator Pedal to DDEC-VCU Connectors.

a. If the power voltage was not within 4.8 - 5.2 V, contact the Detroit Diesel Technical Service Group.

b. If the power voltage was within 4.8 - 5.2 V, refer to Required Actions.


 091 03 - Voltage High

For overviews, see:

DESCRIPTION OF PID 91 - ACCELERATOR PEDAL SENSOR FAULT

TROUBLESHOOTING PID 91

Perform the following steps to troubleshoot voltage high.

  1. Check for continuity between wires 440P+ and 440T with the 21-pin connector disconnected. See Accelerator Pedal to DDEC-VCU Connectors.

a. If continuity was not measured, go to step 2.

b. If continuity was measured, refer to Required Actions.

  2. Check for continuity in wire 440P- between pin 14 of the 21-pin connector and the AP sensor connector pin B.

a. If continuity was measured, go to step 3.

b. If continuity was not measured, refer to Required Actions.

  3. Check for continuity in wire 440T between the AP sensor connector pin A and pin 11 of the 21-pin connector.

a. If continuity was measured, refer to Required Actions.

b. If continuity was not measured, refer to Required Actions.


 091 04 - Voltage Low

For overviews, see:

DESCRIPTION OF PID 91 - ACCELERATOR PEDAL SENSOR FAULT

TROUBLESHOOTING PID 91

Perform the following steps to troubleshoot voltage low.

  1. Measure for a short to ground from wire 440T at the AP connector.

a. If a short to ground was not measured, go to step 2.

b. If a short to ground was measured, refer to Required Actions.

  2. Check for continuity in wire 440P+.

a. If continuity was not measured, refer to Required Actions.

b. If continuity was measured, refer to Required Actions.


 100 01 - Oil Pressure Low

For overviews, see:

DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 100

Perform the following steps to troubleshoot a low oil pressure fault code:

  1. Check for active codes.

a. If fault codes 100 01 and 100 03 are both active, refer to 100 03 - Oil Combination Sensor Open Circuit.

b. If fault codes 100 01 and 100 04 are both active, refer to 100 04 - Oil Combination Sensor Short to Ground

c. If only fault code 100 01 is active, go to step 2.

  2. Observe the stability of the oil pressure.

a. If the oil pressure is in normal operating range and stable, go to step 3.

b. If the oil pressure is fluctuating, go to step 4.

  3. Check the oil level.

a. If the oil level is high, refer to Required Actions.

NOTE: An increase in the engine oil level indicates fuel may be leaking into the engine oil.

b. If the engine oil level is low, fill oil to proper level. Erase fault code memory.

  4. Check the operation of the oil gage. If the oil gage readings are erratic, refer to Required Action.

  5. Check the condition of the oil pump suction pipe. If the pipe is loose or cracked, refer to Required Action.

  6. Check the condition of the oil pump drive and driven gears. If either gear is loose, refer to Required Action.

  7. Check for a faulty oil pressure relief valve. If the relief valve does not open at the set pressure or sticks open, refer to Required Action.

  8. If fault code 100 01 is still active, contact Detroit Diesel Technical Service Group.


 100 02 - Oil Combination Sensor Data Erratic

For overviews, see:

DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 100

Perform the following steps to troubleshoot erratic data from the oil combination sensor:

  1. With the engine shut down, all oil drained into the oil pan, and the vehicle on a level surface, check the oil level.

a. If the oil level is not within the "normal" operating range on the dipstick, add the recommended oil to bring it to the proper level. Erase fault code memory.

b. If the oil level is within the "normal" operating range on the dipstick, go to step 2.

  2. Check for additional active fault codes.

a. If fault code 100 03 is active in addition to code 100 02, refer to 100 03 - Oil Combination Sensor Open Circuit.

b. If fault code 100 04 is active in addition to code 100 02, refer to 100 04 - Oil Combination Sensor Short to Ground.

c. If only fault code 100 02 is active, check and clean sensor contacts (remove any corrosion). See Engine Oil Combination Sensor Wiring Harness Connections. Erase fault code memory.


 100 03 - Oil Combination Sensor Open Circuit

For overviews, see:

DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 100

Perform the following steps to troubleshoot an oil combination sensor open circuit fault:

  1. Check for additional active fault codes with combination sensor connected.

a. If fault code 175 03 is active in addition to code 100 03, repair open circuit in 55-pin connector wire 15 to pin 1 of the sensor. See Engine Oil Combination Sensor Wiring Harness Connections. Erase fault code memory.

b. If only fault 100 03 is active, go to step 2.

  2. Bridge pins 1 and 4 of the combination sensor. See Engine Oil Combination Sensor Wiring Harness Connections.

a. If new fault 100 04 is active, repair short to power in 55-pin connector wire 32 to pin 4 of the sensor. Erase fault code memory.

b. If new fault 100 04 is not active, repair open circuit in 55-pin connector wire 32 to pin 4 of the connector. Erase fault code memory.


 100 04 - Oil Combination Sensor Short to Ground

For overviews, see:

DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 100

Perform the following steps to troubleshoot an oil combination sensor short-to-ground fault:

  1. Unplug the oil combination sensor and check for active fault codes.

a. If new fault codes 175 03 and 100 03 are active, replace the combination sensor. Erase fault code memory.

b. If new fault code 175 03 is active in addition to code 100 04, go to step 2.

  2. Measure the resistance between pins 1 and 3 on the combination sensor. See Engine Oil Combination Sensor Wiring Harness Connections.

a. If resistance is less than 30 k [image], repair short circuit between 55-pin connector wires 15 and 6. Erase fault code memory.

b. If resistance is more than 30 k [image], go to step 3.

  3. Measure the resistance between pin 4 on the combination sensor and vehicle ground. See Engine Oil Combination Sensor Wiring Harness Connections.

a. If resistance is less than 30 k [image], repair short to ground in 55-pin connector wire 32 to pin 4 of the combination sensor. Erase fault code memory.

b. If resistance is more than 30 k [image], go to step 4.

  4. Measure the resistance between pin 3 on the combination sensor and vehicle ground. See Engine Oil Combination Sensor Wiring Harness Connections.

a. If resistance is less than 30 k [image], repair short to ground in 55-pin connector wire 6 to pin 3 of the combination sensor. Erase fault code memory.

b. If resistance is more than 30 k [image], go to step 5.

  5. Check and clean contacts (remove any corrosion), then check for active codes.

a. If fault 100 04 is still active, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.

b. If fault 100 04 is not active, erase fault code memory.


 100 14 - Oil Pressure Very Low

For overviews, see:

DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 100

Perform the following steps to troubleshoot an oil pressure very low fault:

  1. Check for additional active fault codes.

a. If fault code 100 03 is active in addition to code 100 04, refer to 100 03 - Oil Combination Sensor Open Circuit.

b. If fault code 100 04 is active in addition to code 100 04, refer to 100 04 - Oil Combination Sensor Short to Ground.

c. If only fault code 100 14 is active, go to step 2.

  2. Start engine and check oil pressure.

a. If pressure is fluctuating, go to step 3.

b. If pressure is low but stable, go to step 4.

  3. Stop the engine and allow sufficient time for the oil to drain into the oil pan. Perform the following steps:

a. Check the oil level. Add recommended oil to bring it to the proper level, if required.

b. Check for faulty oil gage. Replace, if required.

c. Check for loose or cracked oil pump suction pipe. Repair or replace, as required.

d. Check for loose drive or driven oil pump gear. Repair or replace, as required.

e. Check for faulty oil pressure relief valve. Repair or replace, as required.

f. Erase fault code memory.

  4. Stop the engine and allow sufficient time for the oil to drain into the oil pan. Check the oil level.

a. If oil is above maximum level with no oil previously added, go to step 5.

b. If oil is not above maximum level, contact Detroit Diesel Technical Service.

  5. Check for possible fuel in oil.

a. If fuel is found, locate and repair source of fuel leak. Change the Oil. Erase fault code memory.

b. If fuel is not found, contact Detroit Diesel Technical Service.


 102 00 - Boost Pressure High Fault

For overviews, see:

DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 102

Perform the following steps to troubleshoot a boost pressure high fault:

  1. Check for historic fault codes in addition to 102 00.

a. If other historic fault codes are present, troubleshoot other fault codes first.

b. If only fault code 102 00 is present, go to step 2.

  2. Check the condition of the boost air combination sensor (look for cracks, corrosion, missing or bent pins). See Turbo Boost Air Combination Sensor.

a. If sensor is not in good condition, replace sensor. Erase fault code memory.

b. If sensor is in good condition, go to step 3.

  3. Check waste gate operation.

a. If waste gate is not working, repair or replace the turbocharger. Erase fault code memory.

b. If waste gate is working, go to step 4.

  4. Measure turbo boost pressure.

a. If boost pressure is not within acceptable range, repair or replace the turbocharger. Erase fault code memory.

b. If boost pressure is within acceptable range, contact Detroit Diesel Technical Service.


 102 01 - Boost Pressure Low Fault

For overviews, see:

DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 102

Perform the following steps to troubleshoot a boost pressure low fault:

  1. Check for a restricted air filter or air intake system.

a. If the air filter or air intake system is restricted, replace the air filter and/or eliminate the restriction in the air intake system. Erase fault code memory.

b. If the air filter or air intake system is not restricted, go to step 2.

  2. Check the condition of the boost air combination sensor. See Turbo Boost Air Combination Sensor.

a. If sensor is not in good condition, replace sensor. Erase fault code memory.

b. If sensor is in good condition, go to step 3.

  3. Visually inspect the CAC (charge air cooler) and the CAC hoses for leaks.

a. If leaks are found, repair or replace the CAC and/or CAC hoses. Erase fault code memory.

b. If no leaks are found, go to step 4.

  4. Check for a faulty turbocharger (compressor wheel does not spin freely or is rubbing on side walls).

a. If the turbocharger is faulty, replace it. Erase fault code memory.

b. If the turbocharger is not faulty, go to step 5.

  5. Check for other historic fault codes.

a. If other historic fault codes are present, refer to the other fault codes.

b. If only fault code 102 01 is present, go to step 6.

  6. Check waste gate operation.

a. If waste gate is not working, repair or replace the turbocharger. Erase fault code memory.

b. If waste gate is working, go to step 7.

  7. Verify that fuel delivery is within specifications (no restrictions to fuel flow).

a. If fuel delivery is not within specifications, eliminate restrictions in fuel delivery system. Erase fault code memory.

b. If fuel delivery is within specifications, contact Detroit Diesel Technical Service.


 102 02 - Boost Pressure Sensor Data Erratic Fault

For overviews, see:

DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 102

Perform the following steps to troubleshoot a boost pressure sensor data erratic fault:

  1. Check for additional active fault codes.

a. If fault code 233 12 is active in addition to fault code 102 02, refer to 233 12 - PLD-MR Failed or Programmed Incorrectly.

b. If only fault code 102 02 is active, go to step 2.

  2. Measure turbo boost pressure with the engine running. Stop the engine and compare with atmospheric pressure.

a. If boost pressure is within the acceptable range, check and clean the combination sensor contacts (remove any corrosion). Erase fault code memory.

b. If boost pressure is not within the acceptable range, go to step 3.

  3. Bridge pins 1 and 3 of the combination sensor. See Turbo Boost Air Combination Sensor and Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine.

a. If new fault code 102 04 is active after bridging pins, replace the sensor. Erase fault code memory.

b. If fault code 102 04 is not active after bridging pins, go to step 4.

  4. Measure the resistance between pin 3 of the combination sensor and wire 7 of the 55-pin connector harness. See Turbo Boost Air Combination Sensor and Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine.

a. If resistance is greater than 3 [image], repair open circuit in 55-pin connector wire 7 to pin 3 of the sensor. Erase fault code memory.

b. If resistance is less than 3 [image], check and clean contacts (remove any corrosion). Erase fault code memory.


 102 03 - Boost Pressure Sensor Open Circuit Fault

For overviews, see:

DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 102

Perform the following steps to troubleshoot a boost pressure sensor open circuit fault:

  1. Check for additional active fault codes.

a. If fault code 105 03 is active in addition to fault code 102 03 with boost air combination sensor connected, repair open circuit in 55-pin connector wire 21 to pin 1 of the sensor. See Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine. Erase fault code memory.

b. If only fault code 102 03 is active with sensor connected, go to step 2.

  2. Bridge pins 1 and 4 of the combination sensor. See Turbo Boost Air Combination Sensor and Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine.

a. If new fault 102 04 is active, repair short to power in 55-pin connector wire 29 to pin 4 of the sensor. Erase fault code memory.

b. If fault 102 04 is not active, repair open circuit in 55-pin connector wire 29 to pin 4 of the sensor. Erase fault code memory.


 102 04 - Boost Pressure Sensor Short to Ground Fault

For overviews, see:

DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 102

Perform the following steps to troubleshoot a boost pressure sensor short to ground fault:

  1. Unplug the boost air combination sensor and check fault codes.

a. If new faults 102 03 and 105 03 are active, replace the sensor. Erase fault code memory.

b. If new fault 105 03 is active in addition to fault 102 04, go to step 2.

  2. Measure the resistance between pins 1 and 3 on the combination sensor. See Turbo Boost Air Combination Sensor view "A", and Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine.

a. If resistance is less than 30 k [image], repair short circuit between wires 21 and 7 on the 55-pin connector harness. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 3.

  3. Measure the resistance between pin 4 of the combination sensor and vehicle ground. See Turbo Boost Air Combination Sensor view "A", and Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine.

a. If resistance is less than 30 k [image] , repair short to ground in 55-pin connector wire 29 to pin 4 of the sensor. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 4.

  4. Measure the resistance between pin 3 of the combination sensor and vehicle ground. See Turbo Boost Air Combination Sensor view "A", and Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine.

a. If resistance is less than 30 k [image], repair short to ground in 55-pin connector wire 7 to pin 3 of the sensor. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 5.

  5. Clean and check combination sensor contacts (remove corrosion).

a. If fault is not active, erase fault code memory.

b. If fault is still active, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.


103 07 - Turbo No Revolution Fault

 9.2.1 103 07 - Turbo No Revolution Fault

Troubleshoot a Turbo No Revolution fault as follows:

  1. With the engine stopped and at ambient temperature, unplug the TSS from the TSS connector. See Turbo Speed Sensor Location.

  2. Measure the resistance between the sensor terminals. See Turbo Speed Sensor Terminal and Wire Locations.

a. If resistance is approximately 900 [image], refer to Required Action.

b. If resistance is zero or higher than 950 [image], replace the sensor.


 105 03 - Intake Air Temperature Sensor Open Circuit

For overviews, see:

DESCRIPTION OF PID 105 - INTAKE AIR TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 105

Perform the following steps to troubleshoot an IAT sensor open circuit fault:

  1. With boost air combination sensor connected, check for additional active fault codes. See Turbo Boost Air Combination Sensor.

a. If fault code 102 03 is active in addition to 105 03, repair open circuit in 55-pinconnector wire 21 (on MBE 900 - see Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine) or wire 29 (on MBE 4000 - see Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine) to pin 1 of the sensor. Erase fault code memory.

b. If fault code 110 03 is active in addition to 105 03, go to step 2.

c. If only fault code 105 03 is active, go to step 3.

  2. Measure the voltage at pin 2 of the combination sensor. See Turbo Boost Air Combination Sensor.

a. If more than 10 V, repair short to vehicle system power in 55-pin connector wire 48 (on the MBE 900 - see Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine) or wire 7 (on the MBE 4000 - see Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine) to pin 2 of the sensor. Erase fault code memory.

b. If less than 10 V, go to step 5.

  3. Bridge pins 1 and 2 of the combination sensor. See Turbo Boost Air Combination Sensor.

a. If new fault code 105 04 is not active, repair open circuit in 55-pin connector wire 48 (on the MBE 900 - see Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine) or wire 7 (on the MBE 4000 - see Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine) to pin 2 of the sensor. Erase fault code memory.

b. If new fault code 105 04 is active, go to step 4.

  4. Bridge pins 1 and 2 of the combination sensor on the plug side. See Turbo Boost Air Combination Sensor.

a. If new fault 102 04 is not active, replace the combination sensor. Erase fault code memory.

b. If new fault 102 04 is active, repair short to power in 55-pin connector wire 48 (on the MBE 900 - see Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine) or wire 7 (on the MBE 4000 - see Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine) to pin 2 of the sensor. Erase fault code memory.

  5. With combination sensor connected, measure the voltage at pin 1 of the sensor. See Turbo Boost Air Combination Sensor.

a. If less than 4.5 V, inspect and repair or replace all plug connectors, as required. Erase fault code memory.

b. If more than 4.5 V, repair short to vehicle system power in 55-pin connector wire 34 to pin 1 of the Engine Coolant Temperature sensor. See Engine Coolant Temperature Sensor Wiring. Erase fault code memory.


 105 04 - Intake Air Temperature Sensor Short to Ground

For overviews, see:

DESCRIPTION OF PID 105 - INTAKE AIR TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 105

Perform the following steps to troubleshoot an IAT sensor short to ground fault:

  1. Unplug the boost air combination sensor and check for additional fault codes.

a. If new fault code 105 03 is active in addition to code 105 04, replace the sensor. Erase fault code memory.

b. If new fault code 105 03 is not active, go to step 2.

  2. Measure the resistance between pin 2 of the combination sensor and vehicle ground. See Turbo Boost Air Combination Sensor.

a. If resistance is less than 30 k [image], repair short to ground in 55-pin connector wire 48 (on the MBE 900 - see Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine) or wire 7 (on the MBE 4000 - see Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine) to pin 2 of the sensor. Erase fault code memory.

b. If resistance is greater than 30 k [image], go to step 3.

  3. Check and clean the sensor contacts (remove any corrosion).

a. If fault 105 04 is still active after checking and cleaning, replace the PLD-MR. Erase fault code memory.

b. If fault 105 04 is not active after checking and cleaning, erase fault code memory.


 110 00 - Engine Coolant Temperature High

For overviews, see:

DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

TROUBLESHOOTING PID 110

Perform the following steps to troubleshoot a coolant temperature high fault:

  1. If fault 110 03 is active in addition to 110 00, refer to 110 03 - Engine Coolant Temperature Sensor Open Circuit.

  2. If fault 110 04 is active in addition to 110 00, refer to 110 04 - Engine Coolant Temperature Sensor Short to Ground.

  3. If fault 111 01 is active in addition to 110 00, refer to 111 01 - Engine Coolant Level Low.

  4. If only fault code 110 00 is active, refer to Required Action.


 110 03 - Engine Coolant Temperature Sensor Open Circuit

For overviews, see:

DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

TROUBLESHOOTING PID 110

Perform the following steps to troubleshoot a coolant temperature sensor open circuit fault:

  1. If faults 105 03 and 110 03 are active at the same time, refer to 105 03 - Intake Air Temperature Sensor Open Circuit.

  2. If faults 105 03 and 110 03 are not active at the same time, go to step 3.

  3. Bridge ECT sensor pins 1 and 2. See Engine Coolant Temperature Sensor Wiring.

a. If fault code 110 04 is not the only active code, go to step 4.

b. If fault code 110 04 is the only active code, replace the ECT sensor.

c. Erase fault code memory.

  4. Bridge pin 1 of the ECT sensor to ground. See Engine Coolant Temperature Sensor Wiring.

a. If fault code 110 04 is still active, repair open circuit in wire between pin 34 of the 55-pin connector and pin 1 of the coolant temperature sensor.

b. If fault code 110 04 is no longer active, see below.

c. Erase fault code memory.

  5. Check the resistance between pin 3 of the 55-pin connector and pin 2 of the ECT sensor. See Engine Coolant Temperature Sensor Wiring.

a. If resistance is greater than 3 [image], refer to Required Action.

b. If resistance is less than 3 [image], refer to Required Action.


 110 04 - Engine Coolant Temperature Sensor Short to Ground

For overviews, see:

DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

TROUBLESHOOTING PID 110

Perform the following steps to troubleshoot an ECT sensor short-to-ground fault.

  1. Unplug the ECT sensor.

a. If fault 110 03 is not active, go to step 3.

b. If fault 110 03 is active, replace ECT sensor.

c. Erase fault code memory.

  2. Reconnect ECT sensor.

  3. Check the resistance between pin 1 of the ECT sensor and ground. See Engine Coolant Temperature Sensor Wiring.

a. If resistance is greater than 30 k [image], go to step 4.

b. If resistance is 30 k [image] or less, repair short to ground in wire between pin 34 of the 55-pin connector and pin 1 of the ECT sensor.

c. Erase fault code memory.

  4. Check and clean all contacts.

a. If fault 110 04 is active after checking and cleaning the contacts, refer to Required Action.

b. If fault 110 04 is not active after checking and cleaning the contacts, refer to Required Action.


 110 14 - Engine Coolant Temperature Very High

For overviews, see:

DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

TROUBLESHOOTING PID 110

Perform the following steps to troubleshoot an engine coolant temperature very high fault.

  1. If only fault code 110 14 is active, refer to Required Action.

  2. If fault code 110 03 is active in addition to fault code 110 14, refer to 110 03 - Engine Coolant Temperature Sensor Open Circuit.

  3. If fault code 110 04 is active in addition to fault code 110 14, refer to 110 04 - Engine Coolant Temperature Sensor Short to Ground.


 111 01 - Engine Coolant Level Low

For overviews, see:

DESCRIPTION OF PID 111 - COOLANT OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 111

Perform the following steps to troubleshoot a coolant level low fault:

  1. Check fault code display.

a. If fault 111 03 is active in addition to fault 111 01, refer to 111 03 - Engine Coolant Level Sensor Open Circuit.

b. If fault 111 04 is active in addition to fault 111 01, refer to 111 04 - Engine Coolant Level Sensor Short to Ground.

c. If the coolant level in the reservoir is not within limit, refer to Required Action.

d. If the coolant level in the reservoir is within limit, refer to Required Action.


 111 03 - Engine Coolant Level Sensor Open Circuit

For overviews, see:

DESCRIPTION OF PID 111 - COOLANT OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 111

Perform the following steps to troubleshoot an ECL sensor open circuit fault:

  1. Check the voltage between the DDEC-VCU 15-pin connector wires 440 (440G on Acterra) and 440L on the ECL sensor. See Engine Coolant Level Sensor Connector Wire Locations - 440L Engine for 440L engine sensor wiring and see Engine Coolant Level Sensor Connector Wire Locations - Acterra Engine for Acterra engine sensor wiring.

a. If voltage is about 5 volts, replace ECL sensor. Erase fault code memory.

b. If voltage is the same as battery voltage, repair short to wire in ECL sensor wire 440L. Erase fault code memory.

c. If voltage is 0 volts, go to step 2.

  2. Bridge wire 440L to battery ground.

a. If fault 111 03 is active, repair open circuit in ECL sensor wire 440L. Erase fault code memory.

b. If fault 111 04 is active, repair open circuit in ECL sensor wire 440 (440G on Acterra). Erase fault code memory.


 111 04 - Engine Coolant Level Sensor Short to Ground

For overviews, see:

DESCRIPTION OF PID 111 - COOLANT OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 111

Perform the following steps to troubleshoot an ECL sensor short to ground fault:

  1. Disconnect the ECL sensor.

a. If fault 111 04 is not active after disconnecting the sensor, replace the ECL sensor.

b. If fault 111 04 is active after disconnecting the sensor, go to step 2.

  2. Disconnect the 15-pin connector.

a. If fault 111 04 is active after disconnecting the connector, replace the DDEC-VCU. Erase fault code memory.

b. If fault 111 04 is not active after disconnecting the 15-pin connector, repair short to ground in ECL sensor wire 440L. Erase fault code memory.


 146 00 - EGR Temperature above Normal

For overviews, see:

DESCRIPTION OF SID 146 EGR SYSTEM FAULT

TROUBLESHOOTING SID 146

Perform the following steps to troubleshoot EGR temperature above normal:

If fault codes 110 00 and 146 00 are active at the same time, refer to DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE. Repair or replace, as required.

  1. Verify coolant level is correct.

  2. Check for blockage in radiator and charge air cooler.

  3. Check fan belt condition (slippage).

  4. Check for proper location of fan shroud.

  5. Check for proper radiator hose condition (no collapsed hoses).

  6. Check for proper viscous fan operation.

  7. Check for restricted EGR cooler.

Erase fault code memory.

If fault 146 00 is still active, verify coolant flow through EGR cooler. Repair or replace parts as necessary. Erase fault code memory.

Perform the following steps to troubleshoot an EGR temperature sensor circuit fault:

  1. Bridge EGR temperature sensor between pins 1 and 2. See EGR Temperature Sensor Diagram.

a. If fault code 146 00 is not the only active code, go to step 2.

b. If fault code 146 00 is the only active code, replace the EGR temperature sensor.

c. Erase fault code memory.

  2. Bridge pin 1 of the EGR temperature sensor to ground.

a. If fault code 146 00 is still active, repair open circuit in wire between pin 28 of the 55-pin connector and pin 1 of the EGR temperature sensor.

b. If fault code 146 00 is no longer active, erase fault code memory.

c. If fault code 146 00 is still active, go to step 3.

  3. Check the resistance between pin 22 of the 55-pin connector and pin 2 of the EGR temperature sensor.

a. If resistance is greater than 3 [image], repair open circuit in wire between pin 22 of the 55-pin connector and pin 2 of the EGR temperature sensor.

b. If resistance is less than 3 [image], check all contacts and connections. Remove corrosion, if evident.

c. If fault code 146 00 is not active, erase fault code memory.

d. If fault code 146 00 is still active, go to step 4.

  4. Check for damaged reed valve as follows:

a. Look for open valves (damaged or stuck).

b. Look for presence of soot deposit in the valve. Clean as necessary.

c. Replace the valve if necessary.

  5. If fault code 146 00 is still active, contact Detroit Diesel Technical Service for authorization to replace the DDEC-ECU.


 146 01 - EGR Temperature below Normal

For overviews, see:

DESCRIPTION OF SID 146 EGR SYSTEM FAULT

TROUBLESHOOTING SID 146

Perform the following steps to troubleshoot EGR temperature below normal:

Verify that the PLD-MR hardware and software are correct. The software level is: SW60- HW D3.1. PLD-MR hardware part number is: 0014466440. This information is available using the DDDL or Minidiag2 electronic tools. Remove and replace if required.

If fault codes 146 01 and 146 12 are active at the same time, check the EGR valve for damage.

If fault codes 146 01 and 146 00 are active at the same time, check fault code 146 00. Refer to 146 00 - EGR Temperature above Normal.

If fault code 146 01 is the only active code, check the reed valve as follows:

a. Look for open valves (damaged or stuck).

b. Look for presence of soot deposit in the valve. Clean as necessary.

c. Replace the valves if necessary.

If fault code 146 01 is still active, check the EGR shutoff valve for damage. Replace if necessary. Erase fault code memory.

If fault code 146 01 is still active, contact Detroit Diesel Technical Service for authorization to replace the DDEC-ECU.


146 02 - Data Erratic

 146 02 - EGR Data Erratic

For overviews, see:

DESCRIPTION OF SID 146 EGR SYSTEM FAULT

TROUBLESHOOTING SID 146

If fault codes 146 02 and 146 00 are active at the same time, refer to 146 00 - EGR Temperature above Normal.

If fault code 146 02 is the only code active, perform the following steps:

  1. Check EGR valve wiring between the valve and the DDEC-ECU. Look for: bad wire connection, corrosion on terminals, short circuit, lost continuity between the DDEC-ECU and the EGR valve. For wiring diagram, see EGR Valve Wiring Diagram.

  2. Check the resistance between pin 42 of the 55-pin connector and pin 2 of the EGR valve.

a. If the resistance is greater than 3 [image], repair open circuit in wire between pin 42 of the 55-pin connector and pin 2 of the EGR valve. Erase fault code memory.

b. If the resistance is less than 3 [image], check all contacts and connections. Remove corrosion if evident.

c. If fault code 146 02 is not active, erase fault code memory.

d. If fault code 146 02 is still active, go to step 3.

  3. Bridge pin 3 of the EGR valve to ground.

a. If fault code 146 02 is no longer active, repair open circuit in wire between pin 11 of the 55-pin connector and pin 3 of the EGR valve.

b. If fault code 146 02 is no longer active, erase fault code memory.

b. If fault code 146 02 is still active, go to step 4.

  4. Check the resistance between pin 50 of the 55-pin connector and pin 1 of the EGR valve.

a. If the resistance is greater than 3 [image], repair the open circuit in the wire between pin 50 of the 55-pin connector and pin 1 of the EGR valve.

b. If fault code 146 02 is no longer active, erase fault code memory.

b. If the resistance is less than 3 [image], contact DDC Technical Service.


 146 07 - EGR Valve not Responding

For overviews, see:

DESCRIPTION OF SID 146 EGR SYSTEM FAULT

TROUBLESHOOTING SID 146

If fault codes 146 07 and 146 02 are both active, refer to 146 02 - Data Erratic.

If fault code 146 07 is the only code active, perform the following steps: Check for lost continuity between the DDEC-ECU and the EGR valve (PV2). Refer to 146 02 - Data Erratic.

If fault code 146 07 is still active, contact DDC Technical Service for test procedure for the EGR valve.

If fault code 146 07 is still active, contact DDC Technical Service for DDEC-ECU replacement authorization.

If fault code is no longer active, erase fault code memory.


 146 12 - Bad Component

For overviews, see:

DESCRIPTION OF SID 146 EGR SYSTEM FAULT

TROUBLESHOOTING SID 146

Perform the following steps to troubleshoot EGR - Bad Component:

  1. Check the EGR valve flap for freedom of movement. Remove soot and clean deposits if necessary.

  2. Contact DDC Technical Service for instructions to verify flap valve functionality by performing a PV2 activation test.

If fault code 146 12 is still active, replace the EGR valve.


 158 00 - Battery Voltage Switched - High

For overviews, see:

DESCRIPTION OF PID 158 - BATTERY CHARGING FAULT

TROUBLESHOOTING PID 158

Perform the following steps to troubleshoot the high voltage fault code 158 00.

  1. Start the engine and rev at rated speed.

  2. Measure the voltage across the battery terminals. See Power Wiring.

a. If the voltage is greater than 14.5 V, troubleshoot the battery, starting, and charging system for an overvoltage condition. Refer to the OEM Vehicle Manual.

b. If the voltage is between 14.5 and 11.0 V and fault code 158 00 is still active, contact the Detroit Diesel Technical Support Group.

  3. Erase the fault code memory.


 158 01 - Battery Voltage Switched - Low

For overviews, see:

DESCRIPTION OF PID 158 - BATTERY CHARGING FAULT

TROUBLESHOOTING PID 158

Perform the following steps to troubleshoot the low voltage fault code 158 01.

  1. Turn the ignition on.

  2. Measure the voltage across the battery terminals. See Power Wiring.

  3. If the voltage is less than 11.0 V, troubleshoot the battery, starting, and charging system for an undervoltage condition. Refer to the OEM Vehicle Manual.

  4. Measure the voltage between pins 2 and 3 of the 21-pin connector. See Power Wiring.

  5. If the voltage is between 11.0 and 14.5 V, refer to Required Action.

  6. Start and run the engine. Measure the voltage drop between pin 2 of the 21-pin connector and the positive battery terminal.

  7. If the voltage was less than 11.0 V (ignition on and engine not running) and voltage drop between pin 2 of the 21-pin connector and the positive battery terminal is greater than 0.5 V (engine running), refer to Required Action.

  8. With the engine still running, measure the voltage drop between pin 3 of the 21-pin connector and the negative battery terminal.

a. If the voltage is less than 11.0 V and voltage drop between pin 3 of the 21-pin connector and the negative battery terminal is greater than 0.5 V, refer to Required Action.

b. If the voltage is less than 11.0 V and voltage drop between pin 3 of the 21-pin connector and the negative battery terminal is less than 0.5 V, contact the Detroit Diesel Technical Support Group.


 158 02 - PLD-MR and DDEC-VCU Signals Unmatched

For overviews, see:

DESCRIPTION OF PID 158 - BATTERY CHARGING FAULT

TROUBLESHOOTING PID 158

Perform the following steps to troubleshoot the fault code 158 02 for unmatched PLD-MR and DDEC-VCU signals.

  1. Check for active codes.

a. If fault codes 158 02 and 168 03 are both still active, refer to 168 03 - Battery Voltage High Fault.

b. If fault codes 158 02 and 158 01 are both still active, refer to 158 01 - Battery Voltage Switched - Low

c. If fault codes 158 02 and 158 00 are both still active, refer to 158 00 - Battery Voltage Switched - High.

d. If fault codes 158 02 and 168 04 are both still active, refer to 168 04 - Battery Voltage Low Fault.

  2. Measure the difference in voltage inputs between the DDEC-VCU and PLD-MR. See Power Wiring.

a. If the voltage difference is less than 1.0 V, contact Detroit Diesel Technical Service Group.

b. If the voltage difference is greater than 1.0 V with the DDEC-VCU indicating the low voltage, refer to Required Actions.

c. If the voltage difference is greater than 1.0 V with the PLD-MR indicating the low voltage, refer to Required Actions.


 168 03 - Battery Voltage High Fault

For overviews, see:

DESCRIPTION OF PID 168 - BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 168

Perform the following steps to troubleshoot a battery voltage high fault:

  1. Measure battery voltage with the engine running at maximum rpm.

a. If greater than 14.5 volts, check for proper alternator operation and repair or replace, as required.

b. Erase fault code memory.


 168 04 - Battery Voltage Low Fault

For overviews, see:

DESCRIPTION OF PID 168 - BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 168

Perform the following steps to troubleshoot a battery voltage low fault:

  1. Check the condition of the alternator drive belt and replace, if required.

a. If fault is no longer active, erase fault code memory.

b. If fault is still active, go to step 2.

  2. Check for loose alternator mounting and retighten or repair, as required.

a. If fault is no longer active, erase fault code memory.

b. If fault is still active, go to step 3.

  3. Check for proper alternator operation and repair or replace, as required.

a. If fault is no longer active, erase fault code memory.

b. If fault is still active, go to step 4.

  4. Check the condition of the battery (does it hold the charge?) and replace, if required.

a. If fault is no longer active, erase fault code memory.

b. If fault is still active, go to step 5.

  5. Measure the resistance of the individual wires in the ground circuit.

a. If resistance is greater than 0.5 [image] in any wire, repair or replace the wire and connector. Erase fault code memory.

b. If resistance is less than 0.5 [image] in all wires, go to step 6.

  6. Measure the resistance of the individual wires in the power circuit with the engine running and battery voltage greater than 12.5 V.

a. If resistance is greater than 0.5 [image] in any wire, repair or replace the power circuit wires and connector. Erase fault code memory.

b. If resistance is less than 0.5 [image] in any wire, go to step 7.

  7. Measure the current drop of the individual wires in the ground circuit.

a. If the current drop is more than 0.2 volts in any wire, repair or replace the ground circuit wires and connector. Erase fault code memory.

b. If the current drop is less than 0.2 volts in any wire, go to step 8.

  8. Measure the current drop of the individual wires in the power circuit.

a. If the current drop is more than 0.2 volts in any wire, repair or replace the power circuit wires and connector. Erase fault code memory.


 174 03 - Supply Fuel Temperature Sensor Open Circuit

For overviews, see:

DESCRIPTION OF PID 174 - SUPPLY FUEL TEMPERATURE SENSOR FAULT

TROUBLESHOOTING PID 174

Perform the following steps to troubleshoot an SFT sensor open circuit fault:

  1. If faults 174 03 and 175 03 are active at the same time, refer to 175 03 - Engine Oil Temperature Open Circuit.

  2. If faults 174 03 and 175 03 are not active at the same time, go to step 3.

  3. Bridge pins 1 and 2 of the SFT sensor.

a. If fault 174 04 is the only active fault after bridging pins, replace SFT sensor. Erase fault code memory.

b. If fault 174 04 is not the only active fault after bridging pins, go to step 4.

  4. Bridge pin 1 of the SFT sensor connector to ground. See Supply Fuel Temperature Sensor Connector.

a. If fault 174 04 is not active after bridging pin 1 to ground, refer to Required Action.

b. If fault 174 04 is active after bridging pin 1 to ground, go to step 5.

  5. Measure the resistance in 55-pin connector wire 4 to pin 2 of the SFT sensor connector. See Supply Fuel Temperature Sensor Pins and 55-Pin Connector Wires.

a. If resistance is less than 3 [image], refer to Required Action.

b. If resistance is more than 3 [image], refer to Required Action.


 174 04 - Supply Fuel Temperature Sensor Short to Ground

For overviews, see:

DESCRIPTION OF PID 174 - SUPPLY FUEL TEMPERATURE SENSOR FAULT

TROUBLESHOOTING PID 174

Perform the following steps to troubleshoot an SFT sensor short-to-ground fault.

  1. Unplug the SFT sensor connector.

a. If new fault 174 03 is active after the connector is unplugged, refer to Required Action.

b. If new fault 174 03 is not active after the connector is unplugged, go to step 2.

  2. Check the resistance between pin 1 of the SFT sensor and ground.

a. If resistance is less than 30 [image], refer to Required Action.

b. If resistance is greater than 30 [image], refer to Required Action.


 175 03 - Engine Oil Temperature Open Circuit

For overviews, see:

DESCRIPTION OF PID 175 - ENGINE OIL TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 175

Perform the following steps to troubleshoot an engine oil temperature open circuit fault:

  1. If fault 100 03 is active in addition to fault 175 03 with oil combination sensor connected, resolve as follows:

a. Repair open circuit in wire between pin 15 of 55-pin connector and pin 1 of the oil combination sensor. See Engine Oil Combination Sensor Wiring Harness Connections.

b. Erase fault code memory.

  2. If fault 174 03 is active in addition to fault 175 03 with oil combination sensor connected, go to step 4.

  3. If only fault 175 03 is active with oil combination sensor connected, go to step 5.

  4. Measure the voltage at pin 2 of the oil combination sensor connector. See Location of Pins on Engine Oil Combination Sensor.

a. If the voltage is above 10 volts, refer to Required Action.

b. If the voltage is below 10 volts, go to step 6.

  5. Bridge pins 1 and 2 of the oil combination sensor connector.

a. If new fault 175 04 is active after bridging pins, go to step 7.

b. If new fault 175 04 is not active after bridging pins, refer to Required Action.

  6. Measure the voltage at pin 1 of the oil combination sensor connector.

a. If the voltage is below 4.5 volts, inspect all plug connectors and repair or replace, as required. Erase fault code memory.

b. If the voltage is above 4.5 volts, refer to Required Action.

  7. Bridge pins 1 and 2 of the oil combination sensor connector.

a. If new fault 100 04 is not active after bridging pins, refer to Required Action.

b. If new fault 100 04 is active after bridging pins, refer to Required Action.


175 04 - Engine Oil Temperature Short to Ground

 16.2.2 175 04 - Engine Oil Temperature Short to Ground

Perform the following steps to troubleshoot an engine oil temperature short to ground fault:

  1. Unplug the engine oil combination sensor.

a. If new fault 175 03 is not active after unplugging sensor, go to step 2.

b. If new fault 175 03 is active after unplugging sensor, replace oil combination sensor. Erase fault code memory.

  2. Measure the resistance between pin 2 on the engine oil combination sensor and ground.

a. If resistance is less than 30 k [image], repair short to ground in 55-pin connector wire 39 to pin 2 on sensor connector. Erase fault code memory.

b. If resistance is more than 30 k [image], go to step 3.

  3. Clean and check contacts.

a. If fault 175 04 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.

b. If fault 175 04 is not active after cleaning and checking the contacts, erase fault code memory.


175 04 - Engine Oil Temperature Short to Grou_1

 175 04 - Engine Oil Temperature Short to Ground

For overviews, see:

DESCRIPTION OF PID 175 - ENGINE OIL TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

TROUBLESHOOTING PID 175

Perform the following steps to troubleshoot an engine oil temperature short to ground fault:

  1. Unplug the engine oil combination sensor.

a. If new fault 175 03 is not active after unplugging sensor, go to step 2.

b. If new fault 175 03 is active after unplugging sensor, replace oil combination sensor. Erase fault code memory.

  2. Measure the resistance between pin 2 on the engine oil combination sensor and ground.

a. If resistance is less than 30 k [image], repair short to ground in 55-pin connector wire 39 to pin 2 on sensor connector. Erase fault code memory.

b. If resistance is more than 30 k [image], go to step 3.

  3. Clean and check contacts.

a. If fault 175 04 is still active after cleaning and checking contacts, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.

b. If fault 175 04 is not active after cleaning and checking the contacts, erase fault code memory.


 230 05 - Idle Validation Switch Open Circuit Fault

For overviews, see:

DESCRIPTION OF SID 230 - THROTTLE CONTROL FAULT

TROUBLESHOOTING SID 230

Perform the following steps to troubleshoot an idle validation switch open circuit fault:

  1. Check for battery voltage at position "D," wire 440V1, on the AP sensor connector. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If voltage is present in wire 440V1, repair short to vehicle power in wire 440V1. Erase fault code memory.

b. If no voltage is present in wire 440V1, go to step 2.

  2. Check for battery voltage at position "F," wire 440G, on the AP sensor connector. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If voltage is present in wire 440G, repair short to ground in wire 440G. Erase fault code memory.

b. If voltage is not present in wire 440G, go to step 3.

  3. Check for continuity in wire 440G between pin "F" on the pedal sensor connector and pin 3 on the 18-pin wiring harness connector. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If there is no continuity in wire 440G, repair open circuit in wire 440G. Erase fault code memory.

b. If there is continuity in wire 440G, go to step 4.

  4. Check for continuity in wire 440V1 between the pin "D" on the pedal sensor and pin 12 on the 18-pin wiring harness connector. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If there is no continuity in wire 440V1, repair short circuit in wire 440V1. Erase fault code memory.

b. If there is continuity in wire 440V1, replace the AP.


 230 12- Idle Validation Switch Short to Ground Fault

For overviews, see:

DESCRIPTION OF SID 230 - THROTTLE CONTROL FAULT

TROUBLESHOOTING SID 230

Perform the following steps to troubleshoot an idle validation switch short to ground fault:

  1. Check wire 440V2 for short to ground. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If wire 440V2 is shorted to ground, repair short to ground in wire 440V2. Erase fault code memory.

b. If wire 440V2 is not shorted to ground, replace the AP. Erase fault code memory.


 232 03 - Accelerator Pedal Supply Voltage Above Normal

For overviews, see:

DESCRIPTION OF SID 232 - ACCELERATOR PEDAL SUPPLY VOLTAGE FAULT

TROUBLESHOOTING SID 232

Troubleshoot a AP supply voltage above normal fault as follows:

  1. Check for battery voltage at position "C," wire 440P+ on the AP sensor connector. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If voltage is present in wire 440P+, repair short to vehicle power in wire 440P+. Erase fault code memory.

b. If voltage is not present in wire 440P+, go to step 2.

  2. Check for battery voltage at position "A," wire 440T, on the AP sensor connector. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If voltage is present in wire 440T, repair short to vehicle power in wire 440T. Erase fault code memory.

b. If voltage is not present in wire 440T, go to step 3.

  3. Check for continuity between wires 440P+ and 440T with the 21-pin connector disconnected. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If there is continuity between wires 440P+ and 440T, repair short circuit between wires 440P+ and 440T connecting the DDEC-VCU to the AP sensor. Erase fault code memory.

b. If there is no continuity between wires 440P+ and 440T, erase fault code memory.


 232 04 - Accelerator Pedal Supply Voltage Below Normal

For overviews, see:

DESCRIPTION OF SID 232 - ACCELERATOR PEDAL SUPPLY VOLTAGE FAULT

TROUBLESHOOTING SID 232

Troubleshoot a AP supply voltage below normal fault as follows:

  1. Disconnect the AP assembly.

a. If fault 232 04 is not active after disconnecting the pedal, replace the AP assembly. Erase fault code memory.

b. If fault 232 04 is active after disconnecting the AP assembly, go to step 2.

  2. Check for continuity between wires 440P+ and 440V2 connecting the DDEC-VCU to the AP sensor. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If there is continuity between wires 440P+ and 440V2, repair short circuit between wires 440P+ and 440V2 connecting the DDEC-VCU to the AP sensor. Erase fault code memory.

b. If there is no continuity between wires 440P+ and 440V2, go to step 3.

  3. Check for a short to ground in throttle position sensor power wire 440P+. See Accelerator (Throttle) Pedal Wiring Schematic.

a. If wire 440P+ is shorted to ground, repair short to ground in wire 440P+. Erase fault code memory.

b. If wire 440P+ is not shorted to ground, erase fault code memory.


 233 12 - PLD-MR Failed or Programmed Incorrectly

For overviews, see:

DESCRIPTION OF SID 233 - PLD-MR FAULT (ERRONEOUS DATA)

TROUBLESHOOTING SID 233

Troubleshoot a PLD-MR failed or programmed incorrectly fault as follows:

  1. Reset the parameters on the PLD-MR.

a. If fault code 233 12 is not active after resetting parameters, stop. Fault code has been cleared.

b. If fault code 233 12 is still active after resetting parameters, go to step 2.

  2. Check PLD parameters to ensure they are correct for the vehicle configuration.

a. If parameters are not correct, reset parameters on the PLD-MR.

b. If parameters are correct, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.


 233 14 - Incorrect or Misprogrammed PLD-MR

For overviews, see:

DESCRIPTION OF SID 233 - PLD-MR FAULT (ERRONEOUS DATA)

TROUBLESHOOTING SID 233

Troubleshoot an incorrect or misprogrammed PLD-MR as follows:

  1. Check to ensure the PLD-MR is correct for the engine.

a. If PLD-MR is correct for the engine, go to step 2.

b. If PLD-MR is not correct for the engine, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.

  2. Reset the PLD parameters.

a. If fault code 233 14 is not active after PLD parameters are reset, stop. Fault code has been cleared.

b. If fault code 233 14 is still active after PLD parameters are reset, go to step 3.

  3. Check PLD parameters to ensure they are correct for the vehicle configuration.

a. If PLD parameters are not correct, reset parameters on PLD-MR. Erase fault code memory.

b. If PLD parameters are correct, contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.


 248 02 - Proprietary Datalink Fault

For overviews, see:

DESCRIPTION OF SID 248 - PLD-MR DDEC-VCU DATALINK FAULT

TROUBLESHOOTING SID 248

Perform the following steps to troubleshoot a proprietary datalink fault.

  1. With the ignition switch set to the ON position and the engine not running, check for battery voltage at pin 15 on the small PLD-MR wiring harness connector on the 16-pin connector wiring harness. See PLD-MR Engine Bulkhead Schematic - Business Class and see PLD-MR Engine Bulkhead Schematic - Acterra for wiring schematics.

a. If no battery voltage is measured, refer to Required Actions.

b. If battery voltage is measured, go to step 2.

  2. Disconnect and reconnect the small harness connector (16-pin).

a. If fault 248 02 is not active, refer to Required Actions.

b. If fault 248 02 is active, go to step 3.

  3. Disconnect and reconnect the 15-pin connector.

a. If fault code 248 02 is not active, refer to Required Actions.

b. If fault code 248 02 is active, go to step 4.

  4. Check for continuity in wire 439D+ between 15-pin connector pin 13 and the small PLD-MR harness 16-pin connector pin 1. See PLD-MR Engine Bulkhead Schematic - Business Class and see PLD-MR Engine Bulkhead Schematic - Acterra for wiring schematics.

a. If no continuity is measured, refer to Required Actions.

b. If continuity is measured, go to step 5.

  5. Check for continuity in wire 439D- between 15-pin connector pin 15 and small PLD-MR harness 16-pin connector pin 2.

a. If no continuity is measured, refer to Required Actions.

b. If continuity is measured, refer to Required Actions.


 248 14 - DDEC-VCU Internal Error

For overviews, see:

DESCRIPTION OF SID 248 - PLD-MR DDEC-VCU DATALINK FAULT

TROUBLESHOOTING SID 248

Perform the following step to troubleshoot a DDEC-VCU internal error fault.

  1. Check for continuity in wires 439D- and 439D+ connecting the PLD-MR and the DDEC-VCU. See PLD-MR Engine Bulkhead Schematic - Business Class and see PLD-MR Engine Bulkhead Schematic - Acterra for wiring schematics.

a. If continuity was not measured in wires 439D- and 439D+, refer to Required Actions.

b. If continuity was measured in wires 439D- and 439D+, go to step 2.

  2. Check for a short to power between wires 439D- and 439D+ connecting the PLD-MR to the DDEC-VCU.

a. If a short was measured, refer to Required Actions.

b. If a short was not measured, go to step 3.

  3. Check for a short to ground in wires 439D- and 439D+ connecting the PLD-MR to the DDEC-VCU.

a. If a short was detected, refer to Required Actions.

b. If a short was not detected, refer to Required Actions.


 ABSTRACT

This Help system provides instructions for troubleshooting the MBE Electronics System.

Next topic

SAFETY INSTRUCTIONS

Previous topic

ENGINE EXHAUST


 ACCELERATOR PEDAL INSTALLATION

The Accelerator Pedal (AP) sends an input signal which the DDEC-VCU uses to calculate engine power proportional to the foot pedal position. This assembly is also referred to as the Accelerator Pedal Sensor (AP Sensor) assembly.

See Typical Accelerator Pedal Installation for installation requirements.

Next topic

OPERATION

Previous topic

STARTER LOCKOUT


 Accelerator Pedal to DDEC-VCU Connectors

  1. Accelerator Pedal

  2. 18-Pin DDEC-VCU Connector (VC3)

  3. 21-Pin DDEC-VCU Connector (VC1)


 Accelerator Pedal to DDEC-VCU Connector

  1. 21-Pin DDEC-VCU Connector (VC1)

  2. 15-Pin DDEC-VCU Connector (VC4)

  3. 18-Pin DDEC-VCU Connector (VC3)

  4. DDEC-VCU


 Accelerator (Throttle) Pedal Wiring Schematic

  1. Accelerator Pedal

  2. 21-Pin DDEC-VCU Connector (VC1)

  3. 18-Pin DDEC-VCU Connector (VC3)


 Analog Inputs

The analog inputs are listed in Analog Inputs.

Next topic

Digital Outputs

Previous topic

Digital Inputs


Analog Inputs table

 Analog Inputs

Pin | Description | VBat | Vmin | Pull-up or Pull-down Resistor
15/07 | Engine Coolant Level Sensor | 5 V | 0 V | 40 [image] to 5V Pull-up
15/08 | Air Filter Restriction Sensor | 5 V | 0 V | 200 k [image] to 5 V Pull-up
18/18 | Remote Throttle Signal | 5 V | 0 V | 200 k [image] to 5 V Pull-up
21/11 | Accelerator Pedal Signal | 5 V | 0 V | Williams Pedal Terminal A, 47 k [image] to Ground Pull-down


 Applied Load Criteria for Terminals

Wire Gage | Must Withstand Applied Load
14 AWG | 200 N (45 lb)
16 AWG | 120 N (27 lb)
18 AWG | 90 N (20 lb)


 Average Current Draw

The maximum average current draw is listed in Maximum Average Current Draw. This information should be used to size the alternator.

The current draw for a DDEC-VCU configuration is listed in Current Draw for DDEC-VCU Configuration.

The current draw for a PLD-MR is listed in Current Draw for PLD-MR Configuration.

Next topic

Battery Isolator

Previous topic

Power Supply - 12 Volt System


 Batteries

Electrical storage batteries emit highly flammable hydrogen gas when charging and continue to do so for some time after receiving a steady charge.

BATTERY EXPLOSION AND ACID BURN
To avoid injury from battery explosion or contact with battery acid, work in a well ventilated area, wear protective clothing, and avoid sparks or flames near the battery. If you come in contact with battery acid:
Flush your skin with water.
Apply baking soda or lime to help neutralize the acid.
Flush your eyes with water.
Get medical attention immediately.
Always disconnect the battery cable before working on the electrical system.

PERSONAL INJURY
To avoid injury from accidental engine startup while servicing the engine, disconnect/disable the starting system.

Next topic

Fire

Previous topic

Fuel


 Battery Isolator

MBE electronic controls do not require a battery isolator. However, some applications require a battery that is dedicated to the engine and completely isolated from the rest of the vehicle. Commercially available battery isolators can be used.

Next topic

Main Power Shutdown

Previous topic

Average Current Draw


 CALIFORNIA PROPOSITION 65 WARNING

Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.

Next topic

ENGINE EXHAUST


 Camshaft Position Sensor


 Cleaning Agent

Avoid the use of carbon tetrachloride as a cleaning agent because of the harmful vapors that it releases. Ensure the work area is adequately ventilated. Use protective gloves, goggles or face shield, and apron.

PERSONAL INJURY
To avoid injury from harmful vapors or skin contact, do not use carbon tetrachloride as a cleaning agent.

Next topic

Working on a Running Engine

Previous topic

Fire


 Clipped and Soldered Splicing Method

The tools required are listed in Recommended Splicing Tools.

Criteria: Splicing Straight Leads
 No more than one strand in a 16-strand wire may be cut or missing.
Use Sn 60 solder with rosin core flux.
The exposed wire must be clean before the splice is soldered.
Soldering splice connectors is optional. To solder splice connectors:

  1. Position the leads, so one overlaps the other. See Positioning the Leads.

  2. Secure the leads with a commercially available clip and hand tool. See Securing the Leads With a Clip.

  3. Use a suitable electric soldering iron to heat the wires. Apply the solder to the heated wire and clip (not to the soldering iron) allowing sufficient solder flow into the splice joint.

  4. Pull on wire to assure crimping and soldering integrity. The criteria listed in Applied Load Criteria for Terminals must be met.

  5. Loop the lead back over the spliced joint and tape. See Recommended Strain Relief of Spliced Joint.

Next topic

Splicing and Repairing Straight Leads - Alternate Method 1

Previous topic

Splicing Guidelines


 Close-up View of Oil Combination Sensor

  1. Oil Combination Sensor

  2. Turbocharger


 Communication Interface Data Links

Pin
         Description
         Potential
         UBat
         Umin
         Further Data
15/15
         Engine-CAN (Low)
         -
         2/3 VBat
  1. 3 Vmin
ISO/DIS 11992,
One Wire Capability
15/14
         CAN-HF-Ground
         GND
         -
         -
         100nFtoGround
15/13
         Engine-CAN (High)
         -
  2. 3 VBat
  1. 3 Vmin
ISO/DIS 11992,
One Wire Capability
21/17
         SAE 1708, A
         -
         -
         -
         Only Partly Implemented
21/18
         SAE 1708, A
         -
         -
         -
         Only Partly Implemented
21/19
         SAE J1939 CAN (High)
         5 V
         -
         -
         -
21/20
         CAN-HF-Ground
         GND
         -
         -
         100 nF to ground
21/21
         SAE J1939 CAN (Low)
         5 V
         -
         -
         -


Communications - Propriety IES-CAN Data Link

 Communications - Proprietary IES-CAN Data Link

The low speed proprietary IES-CAN link between the PLD-MR and the DDEC-VCU must be a twisted shielded cable with 0.75 mm diameter wire (approximately 20 AWG), bundle shielded with drain wire and 30 twists per meter. The insulation is rated to 105 °C (221 °F). Termination resistors for the IES-CAN link are located in the DDEC-VCU and PLD-MR. The wiring for the PLD-MR 16-pin connector and the DDEC-VCU 15-pin connector are listed in Proprietary IES-CAN Data Link.

NOTE: A special cable must be used for the proprietary IEC-CAN data link.

Next topic

Power Supply - 12 Volt System

Previous topic

Communications - SAE J1587/J1708 Data Link


 Communications - SAE J1587/J1708 Data Link

SAE J1587 Data Link+ and SAE J1587 Data Link- are used for the SAE J1708/J1587 communication link.

The DDEC-VCU connector pin assignments for SAE J1708/J1587 are listed in J1708/1587 DDEC-VCU to VIH Connector Pin Assignments.

The following SAE documents cover the SAE J1587/J1708 Data Link. Contact the Society of Automotive Engineers to obtain documents.

SAE J1587 | Electronic Data Interchange Between Microcomputer Systems in Heavy-Duty Vehicle Applications
SAE J1708 | Serial Data Communications Between Microcomputer Systems in Heavy-duty Vehicle Applications

Next topic

Communications - Proprietary IES-CAN Data Link

Previous topic

Communications - SAE J1939 Data Link


 Communications - SAE J1939 Data Link

SAE J1939 Data Link (+), SAE J1939 Data Link (-), and SAE J1939 Data Link Shield are used as the J1939 communication link. J1939 cable is required for the J1939 data link. Termination resistors are required per the SAE specification. Refer to SAE J1939-11 for specific requirements.

The DDEC-VCU connector pin assignments for SAE J1939 are listed in J1939 DDEC-VCU to VIH Connector Pin Assignments.

The following SAE documents cover the SAE J1939 Data Link. Contact the Society of Automotive Engineers to obtain documents.

SAE J1939 | Top Layer (Overview)
SAE J1939/11 | Physical Layer
SAE J1939/21 | Data Link Layer
SAE J1939/71 | Vehicle Application Layer
SAE J1939/01 | Truck and Bus Applications
SAE J1939/73 | Application Layer - Diagnostics
J1939 cable is available from the following sources:

Belden Electronics Division | Tyco Electronics Corporation
2200 U.S. 27 South Richmond, IN 47374 Phone: 1-800-235-3361 www.belden.com | Raychem Wire & Harnessing 300 Constitution Drive Menlo Park, CA 94025 www.raychem.com

Next topic

Communications - SAE J1587/J1708 Data Link

Previous topic

VIH Power Wiring


 CONDUIT AND LOOM

Conduit must be used to protect the harness cable and cable splices.

NOTICE:
The conduit must not cover any connectors, switches, relays, fuses, or sensors.
The following guidelines should be used when designing a harness:

NOTICE:
Wires should be sized and cut to near equal length prior to installing conduit.
The distance between the back of the connector or other listed devices to the end of the conduit should not exceed:

25 mm (1.0 in.) for a single connector/device

75 mm (3.0 in.) for multiple connectors/devices

All cable breakouts and conduit ends must be secured in place with conduit outlet rings or tape.

Criteria: Conduit and Loom
 Due to the wide variety of operating conditions and environments, it is the responsibility of the OEM to select a conduit that will survive the conditions of the specific applications. Flame retardant convoluted polypropylene conduit or equivalent may be used for most installations. Heat retardant nylon conduit or oil, water, acid, fire, and abrasion resistant non-metallic loom conforming to SAE J562A* is also acceptable. The diameter of conduit should be selected based on the number of wires being protected.
  • If non-metallic loom is used, secure the ends with tightly wrapped nylon straps to prevent unraveling.

Conduit should cover the wires without binding and without being excessively large.

Next topic

TAPE AND TAPING

Previous topic

Staggering Wire Splices


 Configurable Parameters on the DDEC-VCU 15- and 18-Pin Connectors

Pin
         Function
         Parameters

15/12 | Relay 1 | 0 = Disabled 1 = Starter Protection 2 = Acc. Pedal Kick Down position 3 = Transmission Output 1
15/09 | Relay 2 | 0 = Disabled 1 = Grid Heater 2 = Acc. Pedal Idle Position
15/11 | Relay 3 | 0 = Acc. Pedal Idle Position 1 = Actual Torque 2 = Vehicle Speed 3 = Engine Speed 4 = Coolant Temperature 5 = Acc. Pedal Torque 6 = Booster Temperature 7 = Oil Pressure Warning Lamp 8 = Coolant Temp Warning Lamp
18/01 | Relay 4 | 0 = Kickdown Position 1 = Actual Torque 2 = Vehicle Speed 3 = Engine Speed 4 = Coolant Temp 5 = Pedal Torque 6 = Booster Air Temp 7 = Oil Pressure Warning Lamp 8 = Coolant Temp Warning Lamp
18/08 | Engine Brake Low, Engine Brake Switches Low and High | 0 = Not Active 1 = Active
18/09
         Engine Brake High
         High
0
0

1

1
         /Low
0
1

0

1
= Engine Brakes Disabled
= Engine Brake Step 1: Decompression Valve Enabled
= Engine Brake Step 2: Decompression Valve and Exhaust Flap Enabled
= Not Implemented


 Connector Positions on DDEC-VCU

  1. 21-Pin DDEC-VCU Connector (VC1)

  2. 18-Pin DDEC-VCU Connector (VC3)

  3. 15-Pin DDEC-VCU Connector (VC4)

  4. DDEC-VCU


Connectors_1

 Connectors

There are three connectors to the DDEC-VCU, a 21-pin connector, an 18-pin connector and a 15-pin connector. The OEM is responsible for the three connectors at the DDEC-VCU and the one connector at the PLD-MR.

NOTE: The connectors are not water tight and cannot be subject to water spray.

The part numbers for the DDEC-VCU 21-pin connector are listed in DDEC-VCU 21-pin Connector Part Numbers.

The part numbers for the DDEC-VCU 18-pin connector are listed in DDEC-VCU 18-pin Connector Part Numbers.

The part numbers for the DDEC-VCU 15-pin connector are listed in DDEC-VCU 15-pin Connector Part Numbers.

The part numbers for the DDEC-VCU-to-PLD-MR connector is listed in DDEC-VCU-to-PLD-MR 16-pin Connector Part Numbers.

The part numbers for the OEM connectors (see MBE 900 Non-EGR VIH to Engine Harness Wiring and Engine Harness Connector for MBE 900 EGR Engine) for Engine Brakes and Fan Control and constant throttle valve/exhaust flap for the MBE 900 Non-EGR and EGR engine are listed in OEM Connectors for Constant Throttle Valve/Exhaust Flap and Fan on MBE 900 EGR and Non-EGR Engines.

The part numbers for the OEM 8-pin connector for the MBE 4000 non-EGR engine are listed in OEM 8-Pin Connector for MBE 4000 Non-EGR Engine.

Next topic

Data Link Connector

Previous topic

Fuses


Connectors (PLD-MR)

 Connectors

See PLD-MR Connectors for the connectors to the PLD-MR.

Next topic

VEHICLE CONTROL UNIT - ON-HIGHWAY

Previous topic

Proportional Valve Control


 Constant Throttle Solenoid Valve Connector Wiring


 Crankshaft Position Sensor and Bracket Location

  1. CKP Sensor Bracket

  2. Shear Bolt (2 Qty.)

  3. Spring Bushing

  4. CKP Sensor

  5. Reference Hole on Flywheel Edge


 Crankshaft Position Sensor and Camshaft Position Sensor Wiring


 Crankshaft Position Sensor Location

  1. Crankshaft Position Sensor Bracket

  2. Shear Bolt

  3. Spring Bushing

  4. Crankshaft Position Sensor

  5. Reference Hole on the Flywheel Edge


 CRUISE CONTROL CIRCUIT

The following is a list of switches and DDEC-VCU sensors that are required for Cruise Control operation:

Cruise Control ON/OFF (Switch or J1939)

Service Brake (Switch or J1939)

Clutch Released for Manual Transmission (Switch or J1939)

Set/Coast (Switch or J1939)

Resume/Accel (Switch or J1939)

Vehicle Speed Sensor (or J1939)

See Cruise Control Circuit for a diagram of the cruise control circuit.

Next topic

ENGINE FAN

Previous topic

GRID HEATER


 Cruise Control Circuit


 Current Draw for DDEC-VCU Configuration

Configuration | Condition | Current
DDEC-VCU | Ignition Off | 100 µA
 | Ignition On and Engine Stopped | 200 mA


 Current Draw for PLD-MR Configuration

Configuration
         Condition
         Current
PLD-MR
         Ignition Off
  1. A

Ignition On and Engine Stopped
         400 mA


 Data Link Connector

The connector used to connect the data links is a 9-pin Deutsch connector for the SAE J1939 Data Link and the SAE J1708/J1587 Data Link.

The components listed in Required Components to Incorporate an SAE J1939/J1587 Data Link in the VIH with the 9-Pin Connector are required to incorporate a SAE J1939/J1587 Data Link in a VIH for diagnostic and reprogramming devices.

The following illustration shows the wiring for the 9-pin connector (see Wiring for 9-Pin Data Link Connector).

The maximum length for the SAE J1939 Data Link is 40 m (130 ft).

The SAE J1587/J1708 Data Link must be twisted pairs. The twists are a minimum of 12 turns per 305 mm (1 ft). The maximum length for the SAE J1587/J1708 Data Link is 40 m (130 ft).

Next topic

SAE J1708/J1587 Data Link 6-Pin Connector

Previous topic

Connectors


 Data Links

The Data Links that provide the communication interface are listed in Communication Interface Data Links.

Next topic

Ignition

Previous topic

Digital Outputs


 DDEC-VCU

The Vehicle Control Unit (DDEC-VCU) is the interface between the DDEC-VCU and the vehicle/equipment for engine control and manages the vehicle/equipment functions. See The DDEC-VCU.

See also

Wiring the Grid Heater

Grid Heater

DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

TROUBLESHOOTING PID 45


 DDEC-VCU 15-pin Connector Part Numbers

Part | DDC Part Number
DDEC-VCU 15-pin connector | 013 545 63 26
Terminal (Vehicle) 0.5-1.0 mm wire | 013 545 76 26
Terminal (Power) 1.5-2.5 mm wire | 013 545 78 26
Seals: 1.0 mm wire | 000 545 28 39
Seals: 1.5 - 2.5 mm wire | 000 545 29 39
Plug | 000 545 62 80


 DDEC-VCU 15-Pin VIH Connector Pin Assignments

Pin | Signal Type | Function
15/01 | Digital Input - Switch to Ground, Normally Open, Disables Engine Start if Closed | Transmission Neutral Switch
15/02 | Digital Input - Switch to Ground, Normally Open, Sets Speed Ratio if Closed | Dual Speed Axle
15/03 | Data Link | Vehicle Speed Signal Input for Tachometer
15/04 | - | Reserved
15/05 | Configurable High Side Digital Output | Power Supply for PWM Pedal Gear Out 1, Output for Modulation Valve (e.g. Allison Automatic Transmission)
15/06 | Configurable High Side Digital Output | Engine Brake 2, Exhaust Flap
15/07 | Analog Input | Engine Coolant Level Sensor
15/08 | Analog Input | Air Filter Sensor
15/09 | Configurable High Side Digital Output | Relay 2 The configurable parameters are listed in Configurable Parameters Table.
15/10 | Configurable High Side Digital Output | Engine Brake 1, Decompression Valve
15/11 | Configurable Low Side Digital Output | Relay 3 The configurable parameters are listed in Configurable Parameters Table.
15/12 | Configurable Low Side Digital Output | Relay 1 The configurable parameters are listed in Configurable Parameters Table.
15/13 | Data Link | MBE Proprietary CAN (+) (PLD-MR)
15/14 | Data Link | MBE Proprietary CAN Shield (PLD-MR)
15/15 | Data Link | MBE Proprietary CAN (-) (PLD-MR)


 DDEC-VCU 18-pin Connector Part Numbers

Part | DDC Part Number
DDEC-VCU 18-pin connector | 013 545 64 26
Terminal (Vehicle) 0.5-1.0 mm wire | 013 545 76 26
Terminal (Power) 1.5-2.5 mm wire | 013 545 78 26
Seals: 1.0 mm wire | 000 545 28 39
Seals: 1.5 - 2.5 mm wire | 000 545 29 39
Plug | 000 545 62 80


 DDEC-VCU 18-Pin VIH Connector Pin Assignments

Pin
         Signal Type
         Function

18/01 | Configurable Low Side Digital Output | Relay 4 The configurable parameters are listed in Configurable Parameters Table.
18/02 | Digital Input - Normally Closed (open if clutch is pressed) | Clutch Switch 1
18/03 | Digital Input | Idle Validation Switches
18/04 | Digital Input - Normally Open | Cruise Control, Set/Coast
18/05 | Digital Input - Normally Open | Cruise Control, Res/Accel
18/06 | Digital Input - Normally Open | Cruise Control, On/Off
18/07 | Digital Input - Normally Open | Remote Accelerator Select Switch
18/08 | Digital Input - Normally Open | Engine Brake Low, Engine Brake Switches Low and High The configurable parameters are listed in Configurable Parameters Table.
18/09 | Digital Input - Normally Open | Engine Brake High The configurable parameters are listed in Configurable Parameters Table.
18/10 | Digital Input - Normally Open | Remote PTO Switch
18/11 | Digital Input - Normally Open | Limiter 0
18/12 | Digital Input - Normally Open | Limiter 1
18/13 | Digital Input - Normally Open | Engine Shutdown Override
18/14 | Digital Input - Normally Open | Limiter 2 (Air Condition Status - Fast Idle)
18/15 | Digital Input - Normally Open | Fan Override
18/16 | Digital Input - Normally Open | Throttle Inhibit
18/17 | Sensor Supply | Remote PTO Power Supply and Air Cleaner Sensor
18/18 | Analog Input | Remote Throttle Signal


 DDEC-VCU 21-pin Connector Part Numbers

Part | DDC Part Number
DDEC-VCU 21-pin connector | 013 545 65 26
Terminal (Vehicle) 0.5-1.0 mm wire | 013 545 76 26
Terminal (Power) 1.5-2.5 mm wire | 013 545 78 26
Seals: 1.0 mm wire | 000 545 28 39
Seals: 1.5 - 2.5 mm wire | 000 545 29 39
Plug | 000 545 62 80


 DDEC-VCU 21-Pin VIH Connector Pin Assignments

Pin
         Signal Type
         Function

21/01 | - | Battery Voltage
21/02 | Digital Input | Ignition (+12 V)
21/03 | - | Battery Ground
21/04 | Digital Output - Low Side | Oil Level Lamp*
21/05 | Digital Output - Low Side | Red Stop Lamp*
21/06 | Digital Output - Low Side | Amber Warning Lamp*
21/07 | Digital Output - Low Side | Wait to Start Lamp
21/08 | Digital Output - Low Side | Air Filter Warning Lamp
21/09 | Sensor Supply | Accelerator Pedal Power Supply (+5 V supply)
21/10 | Digital Input - Normally Open | Plug (not used, must be plugged)
21/11 | Analog Input | Accelerator Pedal Signal
21/12 | Pulse Input | PWM Throttle Signal, Path 1
 |  | Idle Validation 2 (Throttle Active)
21/13 | Pulse Input | PWM Throttle Signal, Path 2
 |  | Idle Validation 1 (Idle Active)
21/14 | - | PWM Accelerator Pedal Ground
 |  | Analog Pedal Ground
21/15 | Digital Input - Normally Closed | Service Brake Switch
21/16 | Digital Input - Normally Open | Park Brake Switch
21/17 | Data Link | SAE J1708 (+)
21/18 | Data Link | SAE J1708 (-)
21/19 | Data Link | SAE J1939 (+)
21/20 | Data Link | J1939 Shield
21/21 | Data Link | SAE J1939 (-)
  • If output is active while engine is running, shut down the engine immediately and initiate an error diagnosis.


 DDEC-VCU Grid Heater Wiring


 DDEC-VCU-to-PLD-MR 16-pin Connector Part Numbers

Part | DDC Part Number
PLD-MR 16-pin connector | 000 153 00 22
Terminal (DDEC-VCU) 0.5-1.0 mm wire | 011 545 77 26
Terminal (power) 1.0-2.5 mm wire | 011 545 76 26
Seals: 1.0 mm | 000 545 28 39
Seals: 1.5-2.5 mm | 000 545 29 39
Plug | 000 545 62 80
Cover | 000 153 00 82


 DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

The digital output for the grid heater relay is monitored for high/low state conformity. At the start of the preheating state and the starting state, and during the first two seconds of the preheating state, the intake air manifold temperature is measured to check if the cold start device (grid heater) works.

PID 45 indicates that a fault occurred during operation of the grid heater.

The diagnostic condition is typically:

Open Circuit (045 03).

Short to Ground (045 04).

TROUBLESHOOTING PID 45

See also

DDEC-VCU

Wiring the Grid Heater

Grid Heater


 DESCRIPTION OF PID 84 - VEHICLE SPEED SENSOR FAULT

PID 84 indicates that during engine operation the vehicle speed that is measured by the Vehicle Speed Sensor (VSS) is less than the expected value for the current engine speed/conditions. See Vehicle Speed Sensor. The road speed limiter (if equipped) will use top gear ratio and limit engine speed.

This diagnostic condition is typically:

Open Sensor Signal Circuit (084 03)

Short to Ground (084 04)

TROUBLESHOOTING PID 84


 DESCRIPTION OF PID 91 - ACCELERATOR PEDAL SENSOR FAULT

PID 91 indicates that during operation, the Accelerator Pedal (AP) sensor input voltage is:

Erratic (91 02)

High (91 03)

Low (91 04)

The Accelerator Pedal is remotely mounted and connected to the DDEC-VCU. See Typical Accelerator Pedal Installation, Accelerator Pedal to DDEC-VCU Connectors, and Accelerator Pedal to DDEC-VCU Connector.

TROUBLESHOOTING PID 91


 DESCRIPTION OF PID 100 - ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

PID 100 indicates that the PLD-MR control unit has detected the engine oil pressure is operating outside of the normal operating conditions.

Oil Pressure Low (100 01)

Oil Combination Sensor Data Erratic (100 02)

Oil Combination Sensor Open Circuit (100 03)

Oil Combination Sensor Short to Ground (100 04)

Oil Pressure Very Low (100 14)

TROUBLESHOOTING PID 100


 DESCRIPTION OF PID 102 - TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

PID 102 indicates that the PLD-MR has detected turbo boost pressure operating outside of the normal range.

The diagnostic condition is typically:

Boost Pressure High (102 00)

Boost Pressure Low (102 01)

Boost Pressure Sensor Data Erratic (102 02)

Boost Pressure Sensor Open Circuit (102 03)

Boost Pressure Sensor Short to Ground (102 04)

Boost pressure is monitored by the turbo boost air combination sensor installed in the intake manifold. See Turbo Boost Air Combination Sensor.

TROUBLESHOOTING PID 102


 DESCRIPTION OF PID 103 - TURBO NO REVOLUTION FAULT

PID 103 indicates that the PLD-MR has not received a turbo speed monitoring signal from the Turbo Speed Sensor (TSS).

Certain engines equipped with a turbo brake require turbo speed monitoring during the braking mode in order to control engine brake power. The speed is controlled through the TSS installed on the turbo shaft housing. See Turbo Speed Sensor Location. PID 103 is logged when the PLD-MR on the engine fails to receive the monitoring signal from the sensor.

TROUBLESHOOTING PID 103


 DESCRIPTION OF PID 105 - INTAKE AIR TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

PID 105 indicates that the PLD-MR has detected the intake air temperature outside of the normal operating range.

The diagnostic condition is typically:

Intake Air Temperature (IAT) Sensor Open Circuit (105 03).

IAT Sensor Short to Ground (105 04).

Intake air temperature is monitored by the turbo boost air combination sensor installed in the intake manifold. See Turbo Boost Air Combination Sensor.

TROUBLESHOOTING PID 105


 DESCRIPTION OF PID 110 - COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

PID 110 indicates the PLD-MR control unit has detected a fault message that the coolant temperature has exceeded the recommended normal operating range.

The diagnostic condition is typically:

Engine Coolant Temperature High (110 00)

Engine Coolant Temperature Open Circuit (110 03)

Engine Coolant Temperature Short to Ground (110 04)

Engine Coolant Temperature Very High (110 14)

TROUBLESHOOTING PID 110


 DESCRIPTION OF PID 111 - COOLANT OUTSIDE NORMAL OPERATING RANGE

PID 111 indicates that the coolant level is outside of the normal operating range.

The diagnostic condition is typically:

Engine Coolant Level Low (111 01)

Engine Coolant Level (ECL) Sensor Open Circuit (111 03)

ECL Sensor Short to Ground (111 04)

TROUBLESHOOTING PID 111


 DESCRIPTION OF PID 158 - BATTERY CHARGING FAULT

PID 158 indicates that there is a concern with the battery, starting, and charging system.

The diagnostic condition is typically:

High System Voltage (158 00)

Low System Voltage (158 01)

Unmatched PLD-MR and DDEC-VCU Signals (158 02)

TROUBLESHOOTING PID 158


 DESCRIPTION OF PID 168 - BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

PID 168 indicates that the PLD-MR control unit has detected engine battery voltage outside the normal operating range.

The diagnostic condition is typically:

Battery Voltage High (168 03)

Battery Voltage Low (168 04)

TROUBLESHOOTING PID 168

See also:

Power Supply

VIH Power Wiring


 DESCRIPTION OF PID 174 - SUPPLY FUEL TEMPERATURE SENSOR FAULT

PID 174 indicates the PLD-MR unit has detected that the fuel temperature is outside the normal operating range.

The diagnostic condition is typically:

Supply Fuel Temperature (SFT) Sensor Open Circuit (174 03)

SFT Sensor Short to Ground (174 04)

TROUBLESHOOTING PID 174


 DESCRIPTION OF PID 175 - ENGINE OIL TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

PID 175 indicates that the PLD-MR control unit has detected engine oil temperature outside the normal operating range.

The diagnostic condition is typically:

Engine Oil Temperature Open Circuit (175 03)

Engine Oil Temperature Short to Ground (175 04)

TROUBLESHOOTING PID 175


 DESCRIPTION OF PID 190 - ENGINE SPEED OUTSIDE NORMAL OPERATING RANGE

PID 190 indicates the PLD-MR control unit has detected engine operating outside of the normal range.

The diagnostic condition is typically:

Engine Speed High (190 00)

A Crankshaft Position sensor (variable reluctance magnetic pickup) is used to monitor engine speed along with crankshaft position. A camshaft position sensor is used to monitor engine speed and camshaft position for functions such as fuel control strategy. See Location of Camshaft Position Sensor and Crankshaft Position Sensor.

TROUBLESHOOTING PID 190


 DESCRIPTION OF SID 21 - CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

SID 021 indicates that the PLD-MR control unit has detected the Crankshaft Position (CKP) sensor operating outside of normal operating conditions.

The diagnostic condition is typically:

CKP Sensor Signal Voltage Too Low (021 01)

CKP Sensor Open Circuit (021 03)

CKP Sensor Short to Ground (021 04)

No Match of Camshaft and Crankshaft Signals (021 07)

CKP Sensor Time Out (021 08)

CKP Sensor Pins Swapped (021 14)

See Sensor Location on the MBE 6-Cylinder Engine for sensor locations on the typical MBE 6-cylinder engine.

NOTE: Sensor locations are similar on the 4-cylinder engine. The Engine Oil Level (EOL) sensor, if used, is located at the bottom of the oil pan.

The engine harness is delivered to the factory with the engine sensors and the PLD-MR already connected. See Typical On-Highway MBE 900 Engine Harness - Non-EGR Engine for a typical six-cylinder engine harness. Engine harness sensor pin locations are listed in Selected Harness Pin Locations.

The CKP sensor and its bracket are located on the flywheel housing. See Crankshaft Position Sensor and Bracket Location. In most cases the CKP sensor bracket is replaced only when the flywheel housing is replaced.

TROUBLESHOOTING SID 21


 DESCRIPTION OF SID 57 - EXHAUST BRAKE FAULT

SID 57 indicates that during engine operation of the exhaust brake, a fault occurred with the solenoid that actuates the exhaust brake valve. See Typical Exhaust Brake Installation.

NOTE: The exhaust brake solenoid is commonly located on the firewall, not shown in the following figure.

This diagnostic condition is typically:

Open Circuit (057 05)

Short to Ground (057 06)

TROUBLESHOOTING SID 57


 DESCRIPTION OF SID 58 - ENGINE BRAKE FAULT

SID 58 indicates that a fault occurred during operation of the engine brake.

The diagnostic condition is typically:

Constant Throttle Solenoid Valve Short to Power (058 03)

Constant Throttle Solenoid Valve Open Circuit (058 05)

Constant Throttle Solenoid Valve Short to Ground (058 06)

The engine brake function is activated by the constant throttle solenoid valve mounted on the side of the block. See Location of Constant Throttle Solenoid Valve.

The constant throttle solenoid valve is linked to the engine PLD-MR through a 2-pin connector harness attached to the large 55-pin connector harness. See 55- Pin Wiring Harness Connector. For the four-cylinder MBE 900 engines, air pressure passing through the constant throttle solenoid valve from the adjacent air compressor enables engine braking during engine operation. For the six-cylinder MBE 900 and MBE 4000 engines, oil pressure enables engine braking.

TROUBLESHOOTING SID 58


 DESCRIPTION OF SID 59 - DUAL-SPEED FAN LOW STAGE OPERATION FAULT

SID 59 indicates that a fault occurred during low stage operation of the electronically controlled dual-speed cooling fan. The fan is linked to the engine PLD-MR through the large 55-pin wiring harness connector. See Location of Wiring Harness Connectors.

The fan fault diagnostic condition is typically:

Open Circuit (059 05).

Short to Ground (059 06).

TROUBLESHOOTING SID 59


 DESCRIPTION OF SID 60 - DUAL-SPEED FAN HIGH STAGE OPERATION FAULT

SID 060 indicates that a fault occurred during high stage operation of the electronically controlled, dual-speed cooling fan. The fan is linked to the engine PLD-MR through the large 55-pin wiring harness connector. See Location of Wiring Harness Connectors for PLD-MR and wiring harness connector locations.

The fan fault diagnostic condition is typically:

Open Circuit (060 05)

Short to Ground (060 06)

TROUBLESHOOTING SID 60


 DESCRIPTION OF SID 64 - CAMSHAFT POSITION SENSOR FAULT

SID 64 indicates that during engine operation, a fault occurred with the camshaft position sensor.

The Camshaft Position sensor (CMP sensor) senses camshaft position. The camshaft position is used to calculate crankshaft position, specific cylinder positions, and engine speed for functions such as fuel control strategy.

The diagnostic condition is typically:

Open Circuit (64 03)

Short to Ground (64 04)

Time Out (64 08)

Pins Swapped (64 14)

See Sensor Location on the MBE 900 Engine for the sensor locations on the MBE 900 engine.

See Typical On-Highway MBE 900 Engine Harness - Non-EGR Engine for typical MBE 900 engine harness.

See Sensor Location on the MBE 4000 Engine for the location of the MBE 4000 camshaft/crankshaft sensors.

See Typical MBE 4000 Engine Harness - Non-EGR Engine for a typical MBE 4000 engine harness.

See PLD-MR and Harness Connectors for the 55-pin and 16-pin connectors.

TROUBLESHOOTING SID 64


DESCRIPTION OF SID 146 EGR SYSTEM FAULT

 DESCRIPTION OF SID 146 - EGR SYSTEM

The EGR Temperature Sensor is located in the EGR supply tube on the top front section of the engine. See Sensor Locations on the MBE 900 EGR Engine for the MBE 900 engine and Sensor Locations on the MBE 4000 EGR Engine for the MBE 4000 engine.

SID 146 indicates that during engine operation, the EGR is experiencing operation outside the normal range, resulting in one or more of the following fault codes:

EGR Temperature above Normal (146 00)

EGR Temperature below Normal (146 01)

Bad Component (146 12)

EGR Valve not Responding (146 07)

Data Erratic (146 02)

TROUBLESHOOTING SID 146


 DESCRIPTION OF SID 230 - THROTTLE CONTROL FAULT

SID 230 indicates that a fault has occurred in the throttle control.

The diagnostic condition is typically:

Idle Validation Switch Open Circuit (230 05)

Idle Validation Switch Short to Ground (230 12)

Accelerator Pedal - The accelerator pedal (AP) sends an input signal which the DDEC-VCU uses to calculate engine power proportional to the foot pedal position. See Location of DDEC-VCU and Wiring Harness Connectors. This assembly is also referred to as the AP Sensor assembly.

Accelerator Pedal Installation- MBE electronic controls are compatible with an AP which has an output voltage that meets SAE J1843 and has less than 5% of voltage supply closed throttle variability. See Typical Accelerator Pedal Installation.

The AP is an OEM-supplied part. Vendor sources may be contacted for additional design and installation details.

TROUBLESHOOTING SID 230


 DESCRIPTION OF SID 232 - ACCELERATOR PEDAL SUPPLY VOLTAGE FAULT

SID 232 indicates that a fault has occurred in the supply voltage to the Accelerator Pedal (AP) assembly.

The diagnostic condition is typically:

AP Supply Voltage above Normal (232 03).

AP Supply Voltage below Normal (232 04).

Voltage is supplied to the AP through the 21-pin connector attached to the PLD-MR and the 18-pin connector attached to the DDEC-VCU. See Location of DDEC-VCU and Wiring Harness Connectors for connector locations within the vehicle and see Connector Positions on DDEC-VCU for connector positions on the DDEC-VCU.

TROUBLESHOOTING SID 232


 DESCRIPTION OF SID 233 - PLD-MR FAULT (ERRONEOUS DATA)

SID 233 indicates that a fault has occurred in the PLD-MR, making the PLD-MR data erroneous.

This diagnostic condition is typically:

PLD-MR Failed or Programmed Incorrectly (233 12).

Incorrect or Misprogrammed PLD-MR (233 14).

The PLD-MR or engine-resident control unit is located on the left-hand side of the engine. See Location of PLD-MR Control Unit. The PLD-MR is connected by a proprietary datalink to the DDEC-VCU. All necessary data and information is exchanged through the datalink. The DDEC-VCU then broadcasts all information on the J1587 and J1939 data links, where it can be read by minidiag2.

NOTE: To obtain a replacement PLD-MR control unit, all data given on the control unit data plate is required. The data plate is located on the face of the PLD-MR unit.

TROUBLESHOOTING SID 233


 DESCRIPTION OF SID 242 - CRUISE CONTROL SET/RESUME SWITCH FAULT

SID 242 indicates that a fault has occurred in the cruise control Set/Resume Switch. See Cruise Control Circuit.

The diagnostic condition is typically:

"SET" and "RES" Contacts Closed at the Same Time (242 12)

TROUBLESHOOTING SID 242


 DESCRIPTION OF SID 243 - CRUISE CONTROL SET AND RESUME SWITCH FAULT

SID 243 indicates that a fault has occurred in the cruise control SET and RESUME switches. See Cruise Control Circuit for the typical cruise control circuit.

The diagnostic condition is typically:

SET and RES Contacts Closed at the Same Time (243 12).

TROUBLESHOOTING SID 243


 DESCRIPTION OF SID 248 - PLD-MR DDEC-VCU DATALINK FAULT

SID 248 indicates that a fault has occurred in the PLD-MR DDEC-VCU datalink.

The diagnostic condition is typically:

Proprietary Datalink Fault (248 02)

DDEC-VCU Internal Error Fault (248 14)

See Location of DDEC-VCU and Wiring Harness Connectors for location of wiring harness connectors. See Connector Positions on DDEC-VCU for connector positions on DDEC-VCU. See PLD-MR Engine Bulkhead Schematic - Business Class and see PLD-MR Engine Bulkhead Schematic - Acterra for wiring schematics.

TROUBLESHOOTING SID 248


 DESCRIPTION OF SID 254 - DDEC-VCU FAULT

SID 254 indicates that a fault has occurred in the DDEC-VCU.

This diagnostic condition is typically:

Internal Error in DDEC-VCU (254 12).

See Location of DDEC-VCU and Wiring Harness Connectors for location of DDEC-VCU.

TROUBLESHOOTING SID 254


 DESCRIPTION OF SIDS 1-6 INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

SIDS 1-6 indicate that an injector unit pump, cylinders 1 through 6, is not operating in a normal manner.

The diagnostic condition is typically:

Current Below Normal or Open Circuit (001/6-05)

Short Circuit (001/6-06)

No Plunger (001/6-07)

Idle Smoothness Governor at Limit (001/6 12)

Single Cylinder Correction at Limit (001/6 14)

TROUBLESHOOTING SIDS 1-6


 Deutsch Terminal Installation and Removal

The method of terminal installation and removal varies. The following sections cover Deutsch terminal installation and removal.

Next topic

Deutsch Terminal Installation Guidelines

Previous topic

General Wire


 Deutsch Terminal Installation Guidelines

Deutsch connectors have cable seals molded into the connector. These connectors are push-to-seat connectors with cylindrical terminals. The diagnostic connector terminals are gold plated for clarity.

NOTICE:
Improper selection and use of crimp tools have varying adverse effects on crimp geometry and effectiveness. Proper installation of terminals require specialized tools. Do not attempt to use alternative tools.
The crimp tool to use in Deutsch terminal installation is J 34182 (Kent-Moore®part number).

NOTICE:
Terminal crimps must be made with the crimp tool J 34182 to assure gas tight connections.

NOTICE:
If a separate seal is required, be sure to install the seal onto the wire before stripping the insulation.
Use the following instructions for installing Deutsch terminals:

  1. Strip approximately 6 mm (0.25 in.) of insulation from the cable.

  2. Remove the lock clip, raise the wire gage selector, and rotate the knob to the number matching the gage wire that is being used.

  3. Lower the selector and insert the lock clip.

  4. Position the contact so that the crimp barrel is 0.8 mm (0.03 in.) above the four indenters. See Setting Wire Gage Selector and Positioning the Contact. Crimp the cable.

  5. Grasp the contact approximately 25 mm (1 in.) behind the contact crimp barrel. Hold the connector with the rear grommet facing you. See Pushing Contact into Grommet.

  6. Push the contact into the grommet until a positive stop is felt. See Pushing Contact into Grommet. A slight tug will confirm that it is properly locked into place. See Locking Terminal into Connector.

Next topic

Deutsch Terminal Removal

Previous topic

Deutsch Terminal Installation and Removal


 Deutsch Terminal Removal

The appropriate size removal tool should be used when removing cables from connectors. The proper removal tools are listed in Removal Tools for Deutsch Terminals.

Remove Deutsch terminals as follows:

  1. With the rear insert toward you, snap the appropriate size remover tool over the cable of contact to be removed. See Removal Tool Position.

  2. Slide the tool along the cable into the insert cavity until it engages and resistance is felt. Do not twist or insert tool at an angle. See Removal Tool Insertion.

  3. Pull contact cable assembly out of the connector. Keep reverse tension on the cable and forward tension on the tool.

Next topic

Splicing Guidelines

Previous topic

Deutsch Terminal Installation Guidelines


 Digital Inputs

The DDEC-VCU has 18 digital inputs located on the VIH. These inputs are in low state by providing a connection to battery ground and placed in high state by providing an open circuit.

Digital Input Requirements:

High State: | Battery (+) >Ein> 7.0 V
Low State: | Vin< 3.0 V
Isink: | Capable of sinking 5-20 mA
The digital inputs are listed in Digital Inputs.

Next topic

Analog Inputs

Previous topic

Vehicle Interface Harness Design


Digital Inputs table

 Digital Inputs

Connector Pin
         Description
         Vmax
         Vmin
         Pull-up Resistor
         Input Requirement

DDEC-VCU 15/01
         Transmission Neutral
         VBat
         0 V
  2. 35 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 15/02
         Dual Road Speed Axle
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/02
         Clutch Switch
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/04
         Cruise Control Set/Coast
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/05
         Cruise Control Resume/Accel
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/06
         Cruise Control On/Off Switch
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/07
         Throttle Select
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/08
         Engine Brake Low
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/09
         Engine Brake High
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/10
         Remote PTO Switch
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/11
         Limiter 0
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/12
         Limiter 1
         VBat
         0 V
         2.35 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/13
         Shutdown Override Switch
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/14
         Air Conditioner (Limiter 2)
         VBat
         0 V
         2.35 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/15
         Fan Override
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 18/16
         Throttle Inhibit
         VBat
         0 V
         5 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 21/15
         Service Brake Switch
         VBat
         0 V
         2.35 k
V on<3.0 V
V off>7.0 V
DDEC-VCU 21/16
         Park Brake Switch
         VBat
         0 V
         2.35 k
V on<3.0 V
V off>7.0 V


 Digital Outputs

The digital outputs are listed in Digital Outputs.

Next topic

Data Links

Previous topic

Analog Inputs


Digital Outputs table

 Digital Outputs

Pin
         Description
         IMax
         VBat
         PMaxLamp
         Output Type
DDEC-VCU 5/05
         Power Supply Accelerator Pedal PWM
Gear Out 1
         2 A
         VBat
         -
         High-side Driver
DDEC-VCU 15/06
         Engine Brake 2, Exhaust Flap
         2 A
         VBat
         -
         High-side Relay Driver
DDEC-VCU 15/09
         Relay 2
         2 A
         VBat
         -
         Low-side Relay Driver
DDEC-VCU 15/10
         Engine Brake 1, Constant Throttle
  1. 8 A
VBat
         -
         High-side Relay Driver
DDEC-VCU 15/11
         Relay 3
         250 mA
         VBat
         -
         Low-side Relay Driver, Short Protected
DDEC-VCU 15/12
         Relay 1
  1. 3 A
VBat
         -
         Low-side Relay Driver, Short Protected
DDEC-VCU 18/01
         Relay 4
  1. 3 A
VBat
         -
         Low-side Relay Driver, Short Protected
DDEC-VCU 18/03
         Idle Validation Switch Ground
         250 mA
         0 V
         -
         Input for William's Pedal Terminal F
DDEC-VCU 21/04
         Oil Level Lamp
         250 mA
         VBat
  2. W at 12 V
Low-side Relay Driver, Short Protected
DDEC-VCU 21/05
         Red Stop Lamp
         250 mA
         VBat
         2 W at 12 V
         Low-side Relay Driver, Short Protected
DDEC-VCU 21/06
         Amber Warning Lamp
         150 mA
         VBat
         2 W at 12 V
         Low-side Relay Driver, Short Protected
DDEC-VCU 21/07
         Wait to Start Lamp
         250 mA
         VBat
         2 W at 12 V
         Low-side Relay Driver, Short Protected
DDEC-VCU 21/08
         Air Filter Lamp
         250 mA
         VBat
         2 W at 12 V
         Low-side Relay Driver, Short Protected


 DUAL FAN (FAN TYPE 6) - MBE 4000 ENGINE

See Dual Fan on an MBE 4000 Engine for the schematic showing a dual fan (fan type 6) on an MBE 4000 engine.

Next topic

TWO-SPEED FAN (FAN TYPE 0 OR 1) - MBE 4000 ENGINE

Previous topic

SINGLE-SPEED FAN (FAN TYPE 4)


 Dual Fan on an MBE 4000 Engine


EGR Temperature Sensor Pins and 55-Pin Connector Wires

 EGR Temperature Sensor Diagrams


 EGR Valve Wiring Diagram


 ELECTRONIC COMPONENTS AND WIRING SCHEMATICS

OVERVIEW

PLD-MR - ENGINE-RESIDENT CONTROL UNIT

VEHICLE CONTROL UNIT - ON-HIGHWAY

WIRES AND WIRING

CONDUIT AND LOOM

TAPE AND TAPING

SENSORS

GRID HEATER

CRUISE CONTROL CIRCUIT

ENGINE FAN

PARKING BRAKE SWITCH

VEHICLE POWER SHUTDOWN - OPTIONAL

STARTER LOCKOUT

ACCELERATOR PEDAL INSTALLATION

Next topic

OVERVIEW

Previous topic

Optimized Idle


 Enabling the Engine Coolant Level Sensor

Parameter
         Range
         Default
         Parameter ID
Enable ECL Sensor Input
         0 = Disabled
1 = Enabled

  1. 13 02


 Engine Coolant Level Sensor Connector Wire Locations - 440L Engine

  1. ECL Sensor

  2. Engine Bulkhead Connector

  3. 15-Pin Connector

  4. Ground Splice Pack No. 2


 Engine Coolant Level Sensor Connector Wire Locations - Acterra Engine

  1. ECL Sensor

  2. Engine Bulkhead Connector

  3. 15-Pin Connector

  4. Ground Splice Pack No. 1


 Engine Coolant Level Sensor Installation


 Engine Coolant Level Sensor Installation Kit P/N 23515398 (3/8 in. NPTF)

Component | Part Number
ECL Sensor | 23520381
Metri-Pack Connector Kit | 15300027
Metri-Pack Terminals | 12077411
Secondary Lock | 15300014
Wire Seal | 12015323
Terminal | 12103881


 Engine Coolant Level Sensor

The ECL Sensor provides an input to the engine protection system and warns the operator if a low coolant level has been reached. Other non-DDC supplied engine coolant level sensors may be used but may require the use of a signal interface.

The main component of the ECL Sensor consists of a conductivity probe, which connects to the DDEC-VCU (see Engine Coolant Level Sensor Specifications).

NOTICE:
The probe has an operational temperature range of -40 to 125 °C (-40 to 257 °F). Exposure to temperatures beyond this range may result in unacceptable component life, or degraded sensor accuracy.
The connector listed in Metri-Pack 280 Connectors and Part Numbers is a Metri-Pack 280 series push-to-seat connector.

The OEM must connect the ECL Sensor probe as shown in the next illustration (see Engine Coolant Level Sensor Installation). Polarity of the ground and signal must be correct for proper operation.

The probe should be located in either the radiator top tank or a remote mounted surge tank. It should be mounted horizontally in the center of the tank and must be in a position to signal low coolant before aeration occurs. Typically, this is a height representing 98% of the drawdown quantity. The probe should be located so that it is not splashed by deaeration line, stand pipe or coolant return line flows. The insulated portion of the probe should be inserted into the coolant 15 mm (0.5 in.) or more past the inside wall of the tank. See Engine Coolant Level Sensor Location - Top of Radiator Tank.

Determine proper location for low coolant level sensor while running the drawdown test. It must actuate a warning before the satisfactory drawdown level is reached.

The ECL Sensor components are OEM supplied hardware and can be purchased as kits or individual components, depending on OEM requirements.

The following kits listed in Engine Coolant Level Sensor Installation Kit P/N 23515397 (1/4 in NPTF) and Engine Coolant Level Sensor Installation Kit P/N 23515398 (3/8 in. NPTF) provide all the necessary hardware for proper installation of the ECL Sensor. Kits are available through the DDC parts distribution network.

The sensor must be enabled with VEPS or the minidiag2 as listed in Enabling the Engine Coolant Level Sensor.

Next topic

Vehicle Speed Sensor

Previous topic

OEM Installed Sensors


Engine Coolant Level Sensor Connections

 Engine Coolant Level Sensor Installation


 Engine Coolant Level Sensor Installation Kit P/N 23515397 (1/4 in NPTF)

Component | Part Number
ECL Sensor | 23520380
Metri-Pack Connector Kit | 15300027
Metri-Pack Terminals | 12077411
Secondary Lock | 15300014
Wire Seal | 12015323
Terminal | 12103881


 Engine Coolant Level Sensor Location - Top of Radiator Tank


 Engine Coolant Level Sensor Specifications


 Engine Coolant Temperature Sensor Wiring


 ENGINE EXHAUST

Consider the following before servicing engines:

PERSONAL INJURY
Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.
Always start and operate an engine in a well ventilated area.
If operating an engine in an enclosed area, vent the exhaust to the outside.
Do not modify or tamper with the exhaust system or emission control system.

Next topic

ABSTRACT

Previous topic

CALIFORNIA PROPOSITION 65 WARNING


 ENGINE FAN

Engine Brakes and Fan Control

Single Fan (refer to SINGLE-SPEED FAN (FAN TYPE 4))

Dual Fans (refer to DUAL FAN (FAN TYPE 6) - MBE 4000 ENGINE)

Two-Speed Fan (refer to TWO-SPEED FAN (FAN TYPE 0 OR 1) - MBE 4000 ENGINE)

Variable-Speed Single Fan (PWM) (refer to VARIABLE-SPEED FAN (FAN TYPE 5))

Next topic

SINGLE-SPEED FAN (FAN TYPE 4)

Previous topic

CRUISE CONTROL CIRCUIT


 Engine Harness - Pins 0-27

Pin
         Wire Color
         Signal Type
         Function

900
         4000

0
         N/A
         N/A
         Digital Input
         Oil Separator Diagnosis

Blk/Yel
         Blk/Yel
         Sensor Return
         Camshaft Position (CMP) Sensor (-)

Blk/Viol
         Blk/Viol
         Sensor Return
         Crankshaft Position (CKP) Sensor (-)

Wht/Yel
         Wht/Yel
         Sensor Return
         Engine Coolant Temp Sensor

Brn/Grn
         Brn/Grn
         Sensor Return
         Supply Fuel Temp Sensor

N/A
         Grn/Wht
         Sensor Return
         Passive Engine Oil Press / Booster/ Fan Speed Sensor

Brn/Gray
         Wht/Blk
         Sensor Supply
         Active Engine Oil Press Sensor

Grn
         Grn
         Sensor Supply
         Intake Manifold Press Sensor

N/A
         N/A
         Frequency Input
         Turbo Speed No. 2 Sensor

Red/Blu
         Red/Blu
         Injector Return
         Injector Valves Bank 2 (B - D - F - H)

Gray/Yel
         N/A
         Sensor Return
         Active Engine Oil Press Sensor Alternative Oil Combination Sensor, each w/ Speed Sensor

N/A
         Brn/Wht
         Output Return
         Proportional Valve - Ground

Red/Blk
         Brn/Red
         Output Supply
         Proportional Valve Bank (PV 1 - 4)

N/A
         N/A
         Sensor Supply
         Optional Fuel Press / P3

N/A
         N/A
         Sensor Supply
         Scavenging Gradient Sensor / Fan Speed Sensor

Brn/Wht
         Gray/Yel
         Sensor Return
         Engine Oil Temp / Scavenging Gradient Sensor

Red/Grn
         Red/Grn
         Injector Return
         Injector Valve Bank 1 (A - C - E - G)

N/A
         N/A
         Frequency Input
         Fan Speed Sensor

N/A
         N/A
         High Side Control Output
         Starter

Brn/Viol
         Brn/Viol
         Frequency Input
         CKP Sensor (+)

Brn/Yel
         Brn/Yel
         Frequency Input
         CMP Sensor (+)

Grn/Yel
         N/A
         Sensor Return
         Intake Manifold Temp Sensor

N/A
         N/A
         Sensor Return
         Optional Fuel Pressure

N/A
         Blu
         Sensor Return
         Intake Manifold Press Sensor

N/A
         Grn/Viol
         Frequency Input
         Turbo Speed No. 1 Sensor

N/A
         N/A
         Digital Input
         Service Engine Switch - Start

Digital Input
         Passive Engine Oil Press Sensor

N/A
         N/A
         High Side Control
         Proportional Valve 5


 Engine Harness - Pins 28-50

Pin
         Wire Color
         Signal Type
         Function

900
         4000

N/A
         N/A
         Analog Input
         Optional Fuel Pressure

Viol
         Viol
         Analog Input
         Intake Manifold Pressure Sensor

N/A
         N/A
         Sensor Supply
         Service Engine Switch (Start/Stop)

N/A
         N/A
         Analog Input
         Optional Press Gradient (Boost/Exhaust)

Grn/Blu
         Brn/Gray
         Analog Input
         Active Engine Oil Press Sensor

Wht
         Wht
         Analog Input
         Engine Oil Level (EOL) Sensor

Red/Yel
         Red/Yel
         Analog Input
         Engine Coolant Temp Sensor

N/A
         N/A
         Digital Input
         Service Engine Switch - Stop

Brn/Blu
         Brn/Blu
         Analog Input
         Supply Fuel Temp Sensor

N/A
         N/A
         Injector Output - High Side
         Injector/Solenoid Valve H

Wht/Blu
         Wht/Blu
         Injector Output - High Side
         Injector/Solenoid Valve F

Gray/Brn
         Gray/Brn
         Analog Input
         Engine Oil Temp Sensor

N/A
         Brn/Blk
         PWM/Digital Output - Low Side
         Proportional Valve 6

Blu/Wht
         Red
         PWM/Digital Output - Low Side
         Proportional Valve 3

N/A
         Blu/Blk
         Sensor Supply
         Proportional Valve 6

Blu/Red
         Blk/Wht
         PWM/Digital Output - Low Side
         Proportional Valve 4

Gray/Yel
         Wht/Blu
         Injector Output - High Side
         Injector/Solenoid Valve D

Gray/Viol
         Gray/Grn
         Injector Output - High Side
         Injector/Solenoid Valve B

N/A
         N/A
         Injector Output - High Side
         Injector/Solenoid Valve G

Gray/Blu
         Gray/Viol
         Injector Output - High Side
         Injector/Solenoid Valve E

Brn
         Brn
         Analog Input
         Intake Manifold Temp Sensor

Yel
         Yel
         Sensor Return
         EOL Sensor

Grn/Wht
         Gray/Viol
         PWM/Digital Output - Low Side
         Proportional Valve 2


 Engine Harness - Pins 51-54

Pin
         Wire Color
         Signal Type
         Function

900
         4000

Red/Wht
         Wht/Red
         PWM/Digital Output - Low Side
         Proportional Valve 1

Brn/Red
         Gray/Viol
         Output Supply
         Proportional Valve 2

Gray/Grn
         Gray/Blu
         Injector Output - High Side
         Injector/Solenoid Valve C

Gray/Blk
         Gray/Blk
         Injector Output - High Side
         Injector/Solenoid Valve A


 Engine Harness Connector for MBE 900 EGR Engine


 Engine Harness Connector for MBE 900 Non-EGR Engine

Description | Engine Harness Connector/Pin | PLD-MR 55 Pin Connector
Fan Control, Switch to Bat- (PV3, PV4) | Y70/Pin 1 | 41
Fan Control Power | Y70/ Pin 2 | 12
Compression Brake Control, Switch to Bat- (PV2) | Y49/ Pin 1 | 50
Compression Brake Power | Y49/Pin 2 | 52
Exhaust Flap Control, Switch to Bat- (PV1) | Y91/Pin 1 | 51
Exhaust Flap Power | Y91/Pin 2 | 12


 Engine Harness Connector for Engines with Two Solenoid Air Valves for Engine Brakes - MBE 4000 Only

Description | Engine Harness 8-pin Connector | PLD-MR 55-pin Connector
Fan Control -Control 31, Switch to Bat- (PV3) | A | 41
Fan Control No. 2, Switch to Bat- (PV4) | B | 43
Compression Brake Control, Switch to Bat- (PV2) | C | 50
Fan and Wastegate/E-Flap Voltage Supply (PV1,3,4) | D | 12
Exhaust Flap/Wastegate Control, Switch to Bat- (PV1) | E | 51
Compression Brake Voltage Supply (PV2) | F | 52
Turbo Brake Control, Switch to Bat-(PV6) | G | 40
Turbo Brake Voltage Supply (PV6) | H | 42


Engine Harness Connector for MBE 900 EGR Engine table

 Engine Harness Connector for MBE 900 EGR Engine

Description | Engine Harness Connector/Pin | PLD-MR 55 Pin Connector
Fan Control, Switch to Bat- (PV3, PV4) | Y70/Pin 1 | 41
Fan Control Power | Y70/ Pin 2 | 12
Compression Brake Ground | Y49/ pin 1 | 11
Compression Brake Control, Switch to Bat+ (PV5) | Y49/Pin 2 | 27
Exhaust Flap Control, Switch to Bat- (PV1) | Y91/Pin 1 | 51
Exhaust Flap Power | Y91/Pin 2 | 12


 Engine Oil Combination Sensor Wiring Harness Connections


 Engine Sensor Harness

The Engine Sensor Harness (ESH) is factory installed and delivered connected to the engine sensors and the PLD-MR. See Typical On-Highway MBE 900 Engine Harness - Non-EGR Engine and Typical On-Highway MBE 900 Six-cylinder Engine Harness - EGR Engine for the MBE 900 ESH for non-EGR and EGR engines. See Typical MBE 4000 Engine Harness - Non-EGR Engine for the MBE 4000 ESH (non-EGR).

The wiring for the 55-pin ESH connector to the PLD-MR is listed in Engine Harness - Pins 0-27 , Engine Harness - Pins 28-50 and Engine Harness - Pins 51-54. The side of the connector shown is looking into the pins.

Next topic

Power Supply

Previous topic

Water Intrusion


 Environmental Conditions

Temperature, atmospheric conditions, and vibration must be considered. The PLD-MR is resistant to all fluids and toxic gases occurring in the engine compartment.

Temperature

Vibration

Water Intrusion

Next topic

Temperature

Previous topic

PLD-MR - ENGINE-RESIDENT CONTROL UNIT


 Exhaust brake and Cooling Fan Wiring


 Exhaust (Start/Run Engine)

Before starting and running an engine, adhere to the following safety precautions:

PERSONAL INJURY
To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked.

PERSONAL INJURY
Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.
Always start and operate an engine in a well ventilated area.
If operating an engine in an enclosed area, vent the exhaust to the outside.
Do not modify or tamper with the exhaust system or emission control system.
All engine installations, especially those within enclosed spaces, should be equipped with an exhaust discharge pipe so that exhaust gases are delivered into the outside air.

Next topic

Glasses

Previous topic

SAFETY PRECAUTIONS


 Factory-Installed Sensors

The sensors integrated into the factory-installed Engine Harness are listed in Function of Factory-Installed Sensors.

See Sensor Location on the MBE 900 Engine for sensor locations on the MBE 900 engine

NOTE: The 6-cylinder engine is shown; sensor locations are similar on the 4-cylinder engine.

NOTE: The Barometric Pressure Sensor (BARO Sensor) is integrated into the PLD-MR control unit.

NOTE: The EOL Sensor, if used, is located at the bottom of the oil pan.

Two sensors are not easily visible from the left-hand side of the MBE 4000 engine. The Boost Air Combination Sensor is located on the right-hand side of the charge air manifold, behind the No. 2 cylinder head. The Oil Combination Sensor is located at the base of the oil filter. See Sensor Location on the MBE 4000 Engine for sensor locations on the MBE 4000 engine.

NOTE: The EOL Sensor, if used, is located at the bottom of the oil pan.

Next topic

OEM Installed Sensors

Previous topic

SENSORS


 FEATURES

The operating advantages offered by the MBE Electronic Engine Control are:

Has effective protection of engine from overloading.

Engine parameters are easily set for particular applications.

Integrated backup computer keeps engine operational if main computer fails.

Engine continues to operate if CAN connection is interrupted.

Warning signals are issued in critical states.

Electronic fault store reduces costs of service.

Next topic

Troubleshooting

Previous topic

OPERATION


 Fire

Keep a charged fire extinguisher within reach. Ensure you have the proper type of extinguisher on hand.

FIRE
To avoid injury from fire, keep a fire extinguisher near the grinding machine in case excessive heat should ignite the oil.

Next topic

Cleaning Agent

Previous topic

Batteries


 Fuel

Keep the hose and nozzle or the funnel and container in contact with the metal of the fuel tank when refueling.

FIRE
To avoid injury from fire, keep all potential ignition sources away from diesel fuel, including open flames, sparks, and electrical resistance heating elements. Do not smoke when refueling.
The following cautions should be followed when filling a fuel tank:

FIRE
To avoid injury from fire caused by heated diesel-fuel vapors:
Keep those people who are not directly involved in servicing away from the engine.
Stop the engine immediately if a fuel leak is detected.
Do not smoke or allow open flames when working on an operating engine.
Wear adequate protective clothing (face shield, insulated gloves and apron, etc.).
To prevent a buildup of potentially volatile vapors, keep the engine area well ventilated during operation.

FIRE
To avoid injury from fire, contain and eliminate leaks of flammable fluids as they occur. Failure to eliminate leaks could result in fire.

Next topic

Batteries

Previous topic

Pressurized Fluids


 Function and Guidelines for OEM-installed Sensors

Sensor | Part Number | Function
Engine Coolant Level Sensor (ECL Sensor) | 23522855 23520380 23520381 | Senses coolant level for engine protection. Refer to Engine Coolant Level Sensor.
Vehicle Speed Sensor (VSS) | -- | Senses vehicle speed for Cruise Control and Vehicle Speed Limiting. Refer to Vehicle Speed Sensor.
  • Available in some applications


 Function of Factory-Installed Sensors

Sensor | Function
Camshaft Position Sensor | Senses camshaft position and engine speed for functions such as fuel control strategy.
Crankshaft Position Sensor | Indicates specific cylinder positions and engine speed.
Engine Coolant Temperature Sensor (ECT Sensor) | Senses coolant temperature for functions such as engine protection, fan control and engine fueling.
Engine Oil Level Sensor | Senses oil level for functions such as engine protection.
Engine Oil Pressure Sensor (EOP Sensor) | Senses gallery oil pressure for functions such as engine protection.
Engine Oil Temperature Sensor (EOT Sensor) | Senses oil temperature for functions such as reducing variation in fuel injection and fan control.
Intake Manifold Pressure Sensor (IMP Sensor) | Senses turbo boost for functions such as smoke control and engine protection.
Intake Manifold Temperature Sensor (IMT Sensor) | Senses boost temperature
Supply Fuel Temperature Sensor (SFT Sensor) | Senses fuel temperature for functions such as engine fueling.
Turbo Speed Sensor [MBE 4000 only] | Monitors turbo speed.


 Fuse Current and Blow Time

% of Rated Fuse Current
         Minimum Blow Time
         Maximum Blow Time
100%
         100 hours
         -
135%
  1. minute
30 minutes
200%
         6 seconds
         40 seconds


 Fuse Holder Part Numbers

Part | Part Number
Fuse Holder | 12033769
Cover | 12033731
Terminals | 12066614


 Fuse Temperature and Current

Temperature | % of Rated Fuse Current
-40 [image] C (-40 [image] F) | 110% max
+25 [image] C (+77 [image] F) | 100%
+120 [image] C (+248 [image] F) | 80% min


Fuses (PLD-MR)

 Fuses

A Battery (+) fuse and an ignition circuit fuse must be provided by the vehicle wiring harness. Blade-type automotive fuses are normally utilized; however, manual or automatic reset circuit breakers which meet the following requirements are also acceptable. The fuse voltage rating must be compatible with the PLD-MR's maximum voltage of 32 volts.

The ignition fuse current rating must be sized for the loads utilized in each application; however, a rating of between 5 and 10 amps is usually sufficient.

The Battery (+) fuse current rating must satisfy two criteria:

Must not open during normal operation

Must open before the PLD-MR is damaged during a reverse battery condition

Bussmann ATC-40 and Delphi Packard Electric Systems MaxiFuse 40 amp rated fuses or equivalent will satisfy these requirements. Acceptable blow times versus current and temperature derating characteristics are listed in Fuse Current and Blow Time and Fuse Temperature and Current.

Next topic

Proportional Valve Control

Previous topic

Power Supply


Fuses (VCU)

 Fuses

A battery (+) fuse and an ignition circuit fuse must be provided by the vehicle wiring harness. Blade-type automotive fuses are normally utilized; however, manual or automatic reset circuit breakers which meet the following requirements are also acceptable. The fuse voltage rating must be compatible with the DDEC-VCU - PLD-MR's maximum operating voltage of 16 volts.

The ignition fuse current rating must be sized for the loads utilized in each application; however, a rating of between 5 and 10 amps is usually sufficient.

Next topic

Connectors

Previous topic

Main Power Shutdown


 General Requirements

NOTE: Avoid renumbering DDC circuits, since all troubleshooting guides reference the circuit numbers shown in the schematic. DDC suggests including a prefix or suffix with the DDC circuit numbers when conflicts exist.

Next topic

General Wire

Previous topic

WIRES AND WIRING


 General Wire

All wires used in conjunction with the MBE Electronic Controls must meet the following criteria:

NOTICE:
DDC does not recommend using any type of terminal lubricant or grease compounds. These products may cause dirt or other harmful substances to be retained in the connector. DDC has not tested these products and cannot stand behind their use.

NOTICE:
Insulation must be free of nicks.

Criteria: Wires
Tape, conduit, loom or a combination thereof must be used to protect the wires. Refer to CONDUIT AND LOOM and TAPE AND TAPING.
All wires must be annealed copper wire (not aluminum).
All wires must comply with SAE J1128.
All wires must be insulated with cross-link polyethylene (XLPE) such as GXL, or any self-extinguishing insulation having a minimum rating of -40 °C (-40 °F) to 125 °C (257 °F).

Next topic

Deutsch Terminal Installation and Removal

Previous topic

General Requirements


 Glasses

Select appropriate safety glasses for the job. It is especially important to wear safety glasses when using tools such as hammers, chisels, pullers or punches.

EYE INJURY
To avoid injury from flying debris, wear a face shield or goggles.

Next topic

Welding

Previous topic

Exhaust (Start/Run Engine)


 GRID HEATER

The grid heater (see Grid Heater) is driven by a load relay switched to supply voltage. The installation of a fused high current, as well as the recommended monitoring of the load contact of the load relay, is the responsibility of the vehicle manufacturer. A sticking load contact of the load relay can be monitored via input 12/10, but there is no automatic power cut off. If a sticking load contact occurs, the grid heater control lamp will flash and the grid heater load circuit must be switched off manually.

Nominal power and resistance for the 12 V and 24 V grid heaters are listed in Nominal Power and Resistance

NOTE: The grid heater requires a 250 Amp relay for 12 V systems, a 120 Amp for 24 V systems.

Next topic

CRUISE CONTROL CIRCUIT

Previous topic

Magnetic Pickup - Vehicle Speed Sensor Settings


 Grid Heater

The grid heater, see Grid Heater, is driven by the load relay switched to supply voltage. The installation of a fused high current, as well as the recommended monitoring of the load contact of the load relay, is the responsibility of the vehicle manufacturer.

A sticking contact on the load relay can be monitored via input pin 10 of the 12-pin connector, but there is no automatic power cut off. If a load contact sticks, the grid heater control lamp will flash and the grid heater load crcuit must be switched off manually.

Nominal power and resistance for the 12-volt grid heater is listed in Nominal Power and Resistance.

NOTE: The grid heater requires a 250 amp relay for 12-volt systems.

See also

DDEC-VCU

Wiring the Grid Heater

DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

TROUBLESHOOTING PID 45


Grid Heater Figure

 Grid Heater


 Ignition

The ignition source is 12 volts. The DDEC-VCU and PLD-MR ignition must be an independent input sourced directly from the battery post via a weatherproof blade type fuse, circuit breaker, or equivalent. Ignition sinks a maximum of 25 mA. The ignition fuse rating must be sized for the loads utilized in the application; however, a rating between 5 and 10 amps is usually sufficient. Fuse holders for blade type fuses may be purchased from the DDC Parts Distribution Center. The fuse holder accepts a wire diameter with an OD of 2.89 - 3.65 mm. Part numbers are listed in Fuse Holder Part Numbers.

Ignition voltage must be provided in the crank and run modes.

Next topic

Vehicle Interface Harness Wiring

Previous topic

Data Links


 Injector Unit Pump Wiring on 6-Cylinder Engine

  1. Unit Pump No. 1

  2. Unit Pump No. 2

  3. Unit Pump No. 3

  4. Unit Pump No. 4

  5. Unit Pump No. 5

  6. Unit Pump No. 6


 INTRODUCTION

Detroit Diesel Corporation (DDC) is the world leader in diesel engine electronics. DDC has made technological leaps in engine performance and fuel economy. Today, we build the most dependable electronically controlled diesel engine in the industry.

Our goal at Detroit Diesel is to be the most customer focused and most responsive engine manufacturer in the world.

Next topic

TROUBLESHOOTING INFORMATION

Previous topic

INTRODUCTION


INTRODUCTION Contents

 INTRODUCTION

INTRODUCTION

TROUBLESHOOTING INFORMATION

SAFETY PRECAUTIONS

Next topic

INTRODUCTION

Previous topic

REVISION NOTIFICATION


 J1939 DDEC-VCU to VIH Connector Pin Assignments

Pin
         Signal Type
         Function

21/19 | Data Link | SAE J1939 (+)
21/20 | Data Link | J1939 Shield
21/21 | Data Link | SAE J1939 (-)


 J1708/1587 DDEC-VCU to VIH Connector Pin Assignments

Pin | Signal Type | Function
21/17 | Data Link | SAE J1708 (+)
21/18 | Data Link | SAE J1708 (-)


 Location of Camshaft Position Sensor and Crankshaft Position Sensor

  1. Camshaft Position Sensor (magnetic pickup)

  2. Crankshaft Position Sensor (magnetic pickup)


 Location of Constant Throttle Solenoid Valve

  1. Constant Throttle Solenoid Valve

  2. PLD-MR

  3. Unit Pumps

  4. Air Compressor


 Location of DDEC-VCU and Wiring Harness Connectors

  1. Passenger-Side Dash

  2. DDEC-VCU

  3. 15-Pin Connector

  4. 18-Pin Connector

  5. 21-Pin Connector


 Location of Engine Coolant Temperature Sensor on the MBE 4000 Engine

  1. Cylinder Block

  2. Engine Coolant Temperature Sensor

  3. High-Pressure Fuel Line

  4. Engine Sensor Harness


 Location of Engine Coolant Temperature Sensor on the MBE 900 Engine

  1. Coolant Delivery Hose

  2. Crankcase Breather Hose

  3. Front Connector Housing

  4. Connector Housing Gasket

  5. Oil Separator

  6. Electrical Connector

  7. Engine Coolant Temperature Sensor

  8. Coolant Pump Connector Fitting

  9. Mounting Bolt


 Location of Engine Oil Combination Sensor

  1. Wiring Connector

  2. Oil Combination Sensor


 Location of Engine Oil Combination Sensor on the MBE 4000 Engine

  1. Oil Filter Housing

  2. Oil Combination Sensor

  3. Heat Exchanger Housing

  4. Cylinder Block


 Location of Fan Control Wires


 Location of Pins on Engine Oil Combination Sensor

  1. Pin 1

  2. Pin 2

  3. Pin 3

  4. Pin 4

  5. Oil Combination Sensor Connector


 Location of PLD-MR Control Unit


 Location of Supply Fuel Temperature Sensor

  1. SFT Sensor


 Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine

  1. Unit Pump No. 1

  2. Unit Pump No. 2

  3. Unit Pump No. 3

  4. Unit Pump No. 4

  5. Unit Pump No. 5

  6. Unit Pump No. 6


 Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine

  1. Unit Pump No. 1

  2. Unit Pump No. 2

  3. Unit Pump No. 3

  4. Unit Pump No. 4


 Location of Wiring Harness Connectors

  1. PLD-MR (Engine Computer)

  2. Large 55-Pin Wiring Harness Connector

  3. Small 16-Pin Wiring Harness Connector


 Locking Terminal into Connector


 Magnetic Pickup

The magnetic pickup requirements are listed in Magnetic Pickup Vehicle Speed Sensor Requirements. Magnetic Pickup size is determined by installation requirements.

The VSS is wired to the 15-pin connector of the DDEC-VCU. The VSS pin wiring is listed in Vehicle Speed Sensor Wiring.

Magnetic Vehicle Speed Sensors can be obtained from the following sources:

Wabash Technologies | Airpax Instruments | Invensys Electro Corporation
1375 Swan Street Huntington, Indiana 46750-0829 Tel: 260-356-8300 www.wabashtech.com | Phillips Technologies 150 Knotter Drive Chesire, Connecticut 06410 Tel: 800-643-0643 | 1845 57th Street Sarasota, Florida 34231 Tel: 1-800-446-5762 Fax: 941-355-3120 www.electrocorp.com
Next topic

SAE J1939 Data Link

Previous topic

Magnetic Pickup - Vehicle Speed Sensor Settings


 Magnetic Pickup - Vehicle Speed Sensor Settings

To obtain accurate vehicle mileage, the parameters listed in Vehicle Speed Sensor Parameters must be programmed with VEPS or the minidiag2.

Next topic

Magnetic Pickup

Previous topic

Vehicle Speed Sensor


 Magnetic Pickup Vehicle Speed Sensor Requirements

Parameters
         Range
Frequency Range
  1. - 3000 Hz
Low Threshold Voltage
         >1.7 Volts


 Main Power Shutdown

The main power supply shutdown schematic shows the DDC approved method for main power switch implementation. See Main Power Supply Shutdown 12 or 24 Volt Systems.

NOTE: Switches must remain closed for 30 seconds after ignition is off for the PLD-MR and DDEC-VCU to write non-volatile data.

NOTE: Disconnecting positive power is not sufficient to isolate the DDEC-VCU for welding purposes.

NOTICE:
When welding, the following must be done to avoid damage to the electronic controls or the engine:
Both the positive (+) and negative (-) battery leads must be disconnected before welding.
The welding ground wire must be in close proximity to welding location - the engine must never be used as a grounding point.
Welding on the engine or engine-mounted components is NEVER recommended.
NOTE: The alternator should be connected directly to the battery for isolation purposes.

Next topic

Fuses

Previous topic

Battery Isolator


 Main Power Supply Shutdown 12 or 24 Volt Systems


 Maximum Average Current Draw

System
         Maximum Average Current Draw
(12 V Nominal Supply)

Idle
         Full Load/Rated Speed
PLD-MR - Engine Loads
  1. 2 A total
12.5 A total
DDEC-VCU - Vehicle Loads*
         350 mA total
         5.4 A total
  • Vehicle loads are controlled by the OEMs who can best determine the total maximum current draw for their installation.


 MBE 900 Non-EGR VIH to Engine Harness Wiring


 MBE 4000 Non-EGR Engine Brake


 Metri-Pack 280 Connectors and Part Numbers

Coolant Level Sensor Connector

Connector | P/N: 15300027
Terminal | P/N: 12077411
Seal | P/N: 12015323
Secondary Lock | P/N: 15300014


 NAFTA Architecture


 Nominal Power and Resistance

Data
         12 Volt
Nominal Power at 1000 C (1832 F)
  1. 9 kw ± 10%
Resistance at Rated Temperature
         62 m [image] ± 10%


 Nominal Power and Resistance (12V and 24V systems)

Data
         12 Volt
         12 Volt
Nominal Power at 1000 C (1832 F)
  1. 9 kw ± 10%
  1. 9 kw ± 10%
Resistance at Rated Temperature
         62 m [image] ± 10%
         250 m [image] ± 10%
NOTE: The grid heater requires a 250 Amp relay for 12 V systems, a 120 Amp for 24 V systems.


 OEM 8-Pin Connector for MBE 4000 Non-EGR Engine

Part
         DDC Part Number
8-pin Delphi Connector, 8WM M/P 150 Blk
         030 545 8828
8-pin Delphi Connector, TPA
         000 545 4073
Terminal, M/P 150M 0.35-0.50 mm
         034 545 0028
Terminal, M/P 150M 0.75-1.00 mm
         665 545 9026
Terminal, M/P 150M 0.50-1.00 mm
         030 545 4128
Terminal, M/P 150M 1.00-1.50 mm
         030 545 9026
Seal, 1.29-1.70
  1. 5545 1280
Seal, 1.60-2.15
  1. 5545 1380
Seal, 2.03-2.85
  1. 5545 1480


 OEM Connectors for Constant Throttle Valve/Exhaust Flap and Fan on MBE 900 EGR and Non-EGR Engines

Part | Part Number
Constant Throttle/Exhaust Flap 2-pin Connector | Tyco 106462 1
Terminal | Tyco 1 962916 1
Seal | Tyco 828905 1
Fan 3-Pin Connector | Bosch 928 402 452
Terminal | Tyco 1 962916 1
Seal | Tyco 828905 1
Cavity Plug | Tyco 828922


 OEM Installed Sensors

All sensors must be of the proper type and continuously monitor vehicular and environmental conditions, so the PLD-MR can react to changing situations.

The OEM is responsible for installing the sensors listed in Function and Guidelines for OEM-installed Sensors.

NOTE: The OEM harness must be securely fastened every 150 mm (6 in.). It is required that the harness be fastened within 150 mm (6 in.) of the sensor.

Next topic

Engine Coolant Level Sensor

Previous topic

Factory-Installed Sensors


 OPERATION

FEATURES

The MBE Electronics system is an electronic control system that monitors and determines all values required for the operation of the engine. A diagnostic interface is provided to connect an external diagnosis tester.

Besides the engine related sensors and the engine-resident control unit (PLD-MR), this system has a cab-mounted control unit for vehicle engine management. There are several different modules used for vehicle engine management such as the DDEC-Vehicle Control Unit (DDEC-VCU) and the FMR. The specific DDEC-VCU used is application dependent. The connection to the vehicle is made via a CAN interface which digitally transmits the nominal values (e.g. torque, engine speed specification, etc.) and the actual values (e.g. engine speed, oil pressure, etc.). There are five different architectures used for the different vehicle engine management modules and the PLD-MR.

The engine control system monitors both the engine and the datalink connecting the electronic control units. The DDEC-VCU then broadcasts all information on the J1587 and J1939 datalinks, where it can be read by Minidiag2 and the other vehicle systems. When a malfunction or other problem is detected, the system selects an appropriate response; for example, the emergency running mode may be activated.

Next topic

FEATURES

Previous topic

ACCELERATOR PEDAL INSTALLATION


 Optimized Idle

Optimized Idle must be turned on by the factory via order entry or mainframe setup.

UNEXPECTED ENGINE START
To avoid injury from an unexpected startup of an engine equipped with the Optimized Idle system, remove the starter relay from the relay holder.

PERSONAL INJURY
To avoid injury from accidental engine startup, replace a defective ECM with an ECM programmed with identical inputs and outputs.

Next topic

ELECTRONIC COMPONENTS AND WIRING SCHEMATICS

Previous topic

Working on a Running Engine


 OVERVIEW

MBE Electronic Controls require several electronic control units and their harnesses.

The engine control system monitors and determines all values which are required for the operation of the engine. The engine-resident control unit is the PLD-MR (refer to PLD-MR - ENGINE-RESIDENT CONTROL UNIT).

The vehicle control system monitors the vehicle systems. The vehicle control system broadcasts all information on the J1587 and J1939 Data Links, where it can be read by minidiag2. The vehicle control system module is the DDEC-Vehicle Control Unit (DDEC-VCU), refer to VEHICLE CONTROL UNIT - ON-HIGHWAY.

The harnesses connect the electronic control units to sensors and switches, injectors, and miscellaneous application devices like throttle controls, instrument panel gages and lights. This section describes the functionality of the harnesses and the electronic control units.

Next topic

PLD-MR - ENGINE-RESIDENT CONTROL UNIT

Previous topic

ELECTRONIC COMPONENTS AND WIRING SCHEMATICS


 Parking Brake Digital Input


 PARKING BRAKE SWITCH

A Park Brake Switch may be installed (see Parking Brake Digital Input). Idle Shutdown Timer operates with a digital input configured as a park brake and switched to battery ground. The time can range from 1 to 5000 seconds (approximately 1 hr and 38 minutes).

Next topic

VEHICLE POWER SHUTDOWN - OPTIONAL

Previous topic

VARIABLE-SPEED FAN (FAN TYPE 5)


 Pin Locations on Fan Electrical Connector

  1. Pin 1

  2. Pin 2

  3. Pin 3

  4. Fan Connector


 PLD-MR - ENGINE-RESIDENT CONTROL UNIT

The PLD-MR monitors and determines all values which are required for the operation of the engine.

The PLD-MR control unit (see PLD-MR Control Unit on Engine) is located on the left-hand side of the engine.

The PLD-MR processes the data received from the DDEC-VCU for engine control management.

The data is then compared to the parameters stored in the PLD-MR.

From these data, quantity and timing of injection are calculated and the unit pumps are actuated accordingly through the solenoid valves.

The part numbers for the PLD-MR versions in production in NAFTA are listed in PLD-MR Part Numbers and Software Versions.

NOTE: To obtain a replacement control unit, all the data given on the control unit data plate are required (see PLD-MR Control Unit Data Plate ).

Next topic

Environmental Conditions

Previous topic

OVERVIEW


 PLD-MR and Harness Connectors

  1. PLD-MR

  2. Engine Electrical Connector (55-pin)

  3. Vehicle Electrical Connector (16-pin)


 PLD-MR Connectors


 PLD-MR Control Unit Data Plate


 PLD-MR Control Unit on Engine


 PLD-MR Current Consumption

Current Consumption
         Voltage Version

 | 24 V | 12 V
Peak Power Consumption (without solenoid drivers) | 8.0 A cyclic, depending on engine rpm and series | 12.5 A cyclic, depending on engine rpm and series
Standby Voltage Supply (ignition off and after completion backup phase) | I < 1 mA | I < 1 mA


 PLD-MR Engine Bulkhead Schematic - Business Class


 PLD-MR Engine Bulkhead Schematic - Acterra


 PLD-MR Part Numbers and Software Versions

PLD-MR | Part Number | Software Version
D21 | 000 446 78 40 | Rel. 53 (12/24 V), 4 cylinder
D21 | 000 446 74 40 | Rel. 53 (12/24 V), 6 cylinder
D3 | 000 446 85 40 | Rel. 56 (12/24 V), 4 cylinder
D3 | 000 446 84 40 | Rel. 56 (12/24 V), 6 cylinder


 PLD-MR Polarity/Overload Protection

Polarity/Overload Protection
         Voltage Version

 | 24 V | 12 V
Polarity Protection | Continuous polarity of battery (+) and battery (-) without damage of system | Continuous polarity of battery (+), battery (-) and ignition without damage of system
Overload Resistance | 58 V | 58 V
Overload Resistance | 100 V (see SAE J1455) | 100 V (see SAE J1455)


 PLD-MR Short Circuit Recognition Thresholds

Short Circuit Recognition Thresholds
         Voltage Version

24 V
         12 V
Ground Short
         20 A
         20 A
Starter to Ground
         2.5 A
         2.5 A
Solenoid Valve to Return Line
         32 A
         32 A
Proportional Valve Supply to Ground
         14 A
         14 A
Proportional Valve to Ground *
         2 A
         2 A
  • Open circuit fault greater than 40 k [image] resistance


 PLD-MR Voltage Supply

Voltage Supply
         Voltage Version

 | 24 V | 12 V
Nominal Voltage | 22 V [image] V [image] 30 V | 11 V [image] V [image] 16 V
Low Voltage | 8 V [image] V [image] 22 V Limited Operating Range | 6.5 V [image] V [image] 11 V Limited Operating Range
Overload Switch-off | V > 33 V | V > 33 V


 Positioning the Leads


 Power Supply

The voltage supply for the PLD-MR is listed in PLD-MR Voltage Supply.

See PLD-MR Connectors for the connectors to the PLD-MR.

The wiring for the VIH 16-pin connector to the PLD-MR is listed in 16-Pin Connector to the PLD-MR. The side of the connector shown is looking into the pins.

See also:

VIH Power Wiring

DESCRIPTION OF PID 168 - BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 168


 Power Supply - 12 Volt System

Normal operating voltage for the DDEC-VCU and PLD-MR is 11-16 VDC.

NOTICE:
Operating the DDEC-VCU or PLD-MR over the voltage limits of 16 volts will cause damage to the DDEC-VCU or PLD-MR.

Operating the DDEC-VCU and/or PLD-MR between 8 and 11 volts may result in degraded engine operation. (Transient operation in this range during engine starting is considered normal for 12 volt systems.)

NOTICE:
Reversing polarity will cause damage to the DDEC-VCU and/or PLD-MR if the Power Harness is not properly fused.

NOTE: All output loads, ignition and DDEC-VCU power must be powered from the same battery voltage source.

Next topic

Average Current Draw

Previous topic

Communications - Proprietary IES-CAN Data Link


Power Supply (PLD-MR)

 Power Supply

NOTE: The PLD-MR and DDEC-VCU must be powered from the same battery voltage source.

The voltage supply for the PLD-MR is listed in PLD-MR Voltage Supply.

The polarity/overload protection for the PLD-MR is listed in PLD-MR Polarity/Overload Protection.

The current consumption for the PLD-MR is listed in PLD-MR Current Consumption.

The short circuit recognition thresholds for the PLD-MR are listed in PLD-MR Short Circuit Recognition Thresholds.

Next topic

Fuses

Previous topic

Engine Sensor Harness


 Power Wiring


 Pressurized Fluids

Be extremely careful when dealing with fluids under pressure. Fluids under pressure can have enough force to penetrate the skin. These fluids can infect a minor cut or opening in the skin. If injured by escaping fluid, see a doctor at once. Serious infection or reaction can result without immediate medical treatment.

PERSONAL INJURY
To avoid injury from the sudden release of a high-pressure hose connection, wear a face shield or goggles.

PERSONAL INJURY
To avoid injury from penetrating fluids, do not put your hands in front of fluid under pressure. Fluids under pressure can penetrate skin and clothing.

Next topic

Fuel

Previous topic

Welding


 Proportional Valve Control

The proportional valve control on the PLD-MR controls external setting and switching elements. The output function of the proportional valves is determined by the configuration. The outputs of the control unit can be configured as pulse width modulated (PWM) or digital outputs. The proportional valve control outputs can be enabled or disabled by minidiag2.

The output function of the proportional valves is listed in Proportional Valves.

Next topic

Connectors

Previous topic

Fuses


 Proportional Valves

Valve | Signal | Function MBE 900 Non-EGR Engine | Function MBE 900 EGR Engine | Function MBE 4000 EGR Engine | Low Side Control Pin | Power Supply Pin (Switched VBat)
PV1 | PWM/Digital Output | Exhaust Flap or Wastegate | Exhaust Flap or Wastegate | Wastegate | 55/51 | 55/12
PV2 | PWM/Digital Output | Compression Brake | EGR Valve | EGR Valve | 55/50 | 55/52
PV3 | PWM/Digital Output | Fan 1 | Fan 1 | Fan 1 | 55/41 | 55/12
PV4 | PWM/Digital Output | Fan 2 | Fan 2 | Fan 2 | 55/43 | 55/12
PV5 | PWM/Digital Output | Unused | Compression Brake | Compression Brake | 55/11 - Ground | 55/27 - High Side Control
PV6 | PWM/Digital Output | Unused | Grid Heater | Turbo Brake or Exhaust Flap | 55/40 | 55/42


Propriety IES-CAN Data Link

 Proprietary IES-CAN Data Link

DDEC-VCU 15-Pin | Function | PLD-MR 16-Pin
15/13 | IES-CAN Data Link (+) | 16/1
15/14 | IES-CAN Data Link (Shield) | 16/2
15/15 | IES-CAN Data Link (-) | 16/3


 Pushing Contact into Grommet


Recommended Splicing Tools_1

 Recommended Splicing Tools

Tool | Part Number
Heat Gun | --
Wire Stripper | --
Splice Clips (commercially available) | Wire size dependent
Heat Shrink Tubing | Raychem HTAT or equivalent
Terminal Crimper for Metri-Pack 280 (12 AWG) | Kent-Moore J 38125-6
Terminal Crimper for Metri-Pack 280 (18 AWG) | Kent-Moore J 39848
Terminal Crimper for Weather Pack | Kent-Moore J 35606
Terminal Crimper for Deutsch | Kent-Moore J 34182
Terminal Crimper for Metri-Pack 150 | Kent-Moore J 35123


Recommended Splicing Tools (Clipped and Soldered Splicing Method)

 Recommended Splicing Tools

Tool | Part Number
Heat Gun | --
Sn 60 Solder with Rosin Core Flux | --
Wire Stripper | --
Splice Clips (commercially available) | Wire size dependent
Heat Shrink Tubing | Raychem HTAT or equivalent


 Recommended Strain Relief of Spliced Joint


 Removal Tool Insertion


 Removal Tool Position


 Removal Tools for Deutsch Terminals

Tool | Kent-Moore Part Number
Removing (12 AWG) | J 37451
Removing (16-18 AWG) | J 34513-1


 Required Components to Incorporate an SAE J1939/J1587 Data Link in the VIH with the 9-Pin Connector

Component | DDC Part Number | Deutsch Part Number
9-Pin Deutsch Connector | 23529496 | HD10-9-1939P
Connector Cover | 23529497 | HDC 16-9
Two (2) Cavity Plugs | 23507136 | 114017
Seven (7) Terminals | 23507132 | 0460-202-16141


 Required Components to Incorporate an SAE J1939/J1587 Data Link in the VIH with the 6-Pin Connector

Component | DDC Part Number | Deutsch Part Number
6-Pin Deutsch Connector | 23513052 | HD10-6-12P
Connector Cover | 23507154 | HDC 16-6
Two (2) Cavity Plugs | 23507136 | 114017
Four (4) Terminals | 23513053 | 0460-220-1231


 REVISION NOTIFICATION

Modifications to the manual are announced in the form of Service Information Bulletins. The bulletins include attachment pages and are posted on the World Wide Web (www.detroitdiesel.com/svc/sibinex.htm).

Revisions to the manual will be published marked with a revision bar. Sections containing revisions will have added information in the page footer.

Next topic

INTRODUCTION

Previous topic

SAFETY INSTRUCTIONS


 SAE J1708/J1587 Data Link 6-Pin Connector

The components are required to incorporate a SAE J1708/J1587 Data Link in a VIH so a diagnostic devices can be attached without a unique jumper are listed in Required Components to Incorporate an SAE J1939/J1587 Data Link in the VIH with the 6-Pin Connector.

Wiring for 6-Pin Data Link Connector shows the wiring for the 6-pin connector.

Next topic

WIRES AND WIRING

Previous topic

Data Link Connector


 SAE J1939 Data Link

A VSS wired to the DDEC-VCU is not required if the transmission output shaft message is being transferred over the SAE J1939 data link. To obtain accurate vehicle mileage, the parameters listed in Vehicle Speed Sensor Parameters must be programmed with VEPS or the minidiag2.

Next topic

GRID HEATER

Previous topic

Magnetic Pickup


 SAFETY INSTRUCTIONS

To reduce the chance of personal injury and/or property damage, the instructions contained in this Troubleshooting Help system must be carefully observed. Proper service and repair are important to the safety of the service technician and the safe, reliable operation of the engine.

If part replacement is necessary, the part must be replaced with one of the same part number or with an equivalent part number. Do not use a replacement part of lesser quality. The service procedures recommended and described in this Help system are effective methods of performing repair. Some of these procedures require the use of specially designed tools. Accordingly, anyone who intends to use a replacement part, procedure or tool which is not recommended, must first determine that neither personal safety nor the safe operation of the engine will be jeopardized by the replacement part, procedure or tool selected.

It is important to note that this Help system contains various "Cautions" and "Notices" that must be carefully observed in order to reduce the risk of personal injury during repair, or the possibility that improper repair may damage the engine or render it unsafe. It is also important to understand that these "Cautions" and "Notices" are not exhaustive, because it is impossible to warn personnel of the possible hazardous consequences that might result from failure to follow these instructions.

Kent-Moore® is a registered trademark of SPX Corporation.

Next topic

REVISION NOTIFICATION

Previous topic

ABSTRACT


 SAFETY PRECAUTIONS

The following safety precautions must be observed when working on a Detroit Diesel engine:

Exhaust (Start/Run Engine)

Glasses

Welding

Pressurized Fluids

Fuel

Batteries

Fire

Cleaning Agent

Working on a Running Engine

Optimized Idle

Next topic

Exhaust (Start/Run Engine)

Previous topic

TROUBLESHOOTING INFORMATION


 Securing the Leads With a Clip


 Selected Harness Pin Locations

Pin
         Wire Color
         Signal Type
         Function

6-Cylinder
         4-Cylinder

Blk/Yel
         Blk/Yel
         Sensor Return
         CMP Sensor (-)

Blk/Viol
         Blk/Viol
         Sensor Return
         CKP Sensor (-)
19
         Brn/Viol
         Brn/Viol
         Frequency Input
         CKP Sensor (+)
20
         Brn/Yel
         Brn/Yel
         Frequency Input
         CMP Sensor (+)


 Sensor Location on the MBE 4000 Engine

  1. Boost Air Combination Sensor

  2. Camshaft Position Sensor (on camshaft)

  3. Crankshaft Position Sensor

  4. Engine Coolant Temperature Sensor

  5. Barometric Pressure Sensor (integrated into PLD-MR)

  6. Supply Fuel Temperature Sensor

  7. Oil Combination Sensor


Sensor Location on the MBE 4000 Engine (CMP sensor)

 Sensor Location on the MBE 4000 Engine

  1. Camshaft Position Sensor

  2. Crankshaft Position Sensor


 Sensor Location on the MBE 6-Cylinder Engine

  1. Engine Oil Pressure (EOP) Sensor

  2. Engine Coolant Temperature (ECT) Sensor

  3. Intake Manifold Pressure (IMP) Sensor

  4. Supply Fuel Temperature (SFT) Sensor

  5. Barometric Pressure (Baro) Sensor *

  6. Camshaft Position (CMP) Sensor - on Cylinder Block

  7. CKP Sensor - on Timing Case

  • The Baro sensor is integrated into the PLD-MR unit.


 Sensor Location on the MBE 900 Engine

  1. Oil Combination Sensor

  2. Engine Coolant Temperature Sensor

  3. Boost Air Combination Sensor

  4. Supply Fuel Temperature Sensor

  5. Barometric Pressure Sensor (integrated into PLD-MR)

  6. Camshaft Position Sensor (on camshaft)

  7. Crankshaft Position Sensor (on timing case)


Sensor Locations on the MBE 900 Engine with EGR

 Sensor Locations on the MBE 900 EGR Engine

  1. EGR Temperature Sensor

  2. Engine Coolant Temperature Sensor

  3. Fuel Temperature Sensor

  4. Barometric Pressure Sensor (integrated into DDEC-ECU)

  5. Camshaft Position Sensor

  6. Crankshaft Position Sensor (on timing case)

  7. Intake Manifold Pressure/Temperature Sensor

  8. Engine Oil Temperature Sensor

  9. Engine Oil Pressure Sensor


 Sensor Locations on the MBE 4000 Engine with EGR

  1. Intake Air Pressure/Temperature Sensor

  2. EGR Temperature Sensor

  3. Camshaft Position Sensor (on camshaft)

  4. Crankshaft Position Sensor

  5. Engine Coolant Temperature Sensor

  6. Barometric Pressure Sensor (integrated into DDEC-ECU)

  7. Fuel Temperature Sensor

  8. Engine Oil/Pressure Sensor


 Sensor Types

Sensor Type | Description
Variable Reluctance/Magnetic Pick-up | Used to monitor the crankshaft position, engine speed, turbo speed (MBE 4000 only), and vehicle speed.
Thermistor | Used to monitor temperatures.
Variable Capacitance | Used to monitor manifold, and oil gallery pressures.
Variable Resistance (Potentiometer) | Used to sense throttle position.
Switch | Used to signal coolant level, inlet air restriction, and oil level.


 SENSORS

The MBE Electronic Controls system is designed to operate with several types of sensors as listed in Sensor Types.

The sensors integrated into the Engine Harness are factory-installed (refer to Factory-Installed Sensors). The sensors integrated into the Vehicle Interface Harness are installed by the OEM (refer to OEM Installed Sensors).

Next topic

Factory-Installed Sensors

Previous topic

TAPE AND TAPING


 Setting Wire Gage Selector and Positioning the Contact


 Shrink Wrap

Shrink wrap is required when splicing non insulated connections. Raychem HTAT or any equivalent heat shrink dual wall epoxy encapsulating adhesive polyolefin is required. Shrink wrap must extend at least 6 mm (0.25 in.) over wire insulation past splice in both directions.

Alpha Wire Corporation
 711 Lidgerwood Ave
P.O. Box 711
Elizabeth, New Jersey 07207-0711
  1. 800-52ALPHA
www.alphawire.com
         Tyco Electronics Corporation
 Raychem Cable Identification and Protection
300 Constitution Drive
Menlo Park, CA 94025
Phone: 1-800-926-2425
www.raychem.com
To heat shrink wrap a splice:

NOTICE:
The heat shrink wrap must overlap the wire insulation about 6 mm (0.25 in.) on both sides of the splice.
  1. Select the correct diameter to allow a tight wrap when heated.

  2. Heat the shrink wrap with a heat gun; do not concentrate the heat in one location, but apply the heat over the entire length of shrink wrap until the joint is complete.

  3. Repeat step 2 to apply a second layer of protection (if required by splicing guidelines).

Next topic

Staggering Wire Splices

Previous topic

Splicing and Repairing Straight Leads - Alternate Method 2


 SINGLE-SPEED FAN (FAN TYPE 4)

This section provides a schematic of the specific connection from the PLD-MR to the single-speed fan (fan type 4). See Single-Speed Fan on an MBE 4000 Engine for an MBE 4000 engine or Single-Speed Fan on an MBE 900 Engine for an MBE 900 engine.

Next topic

DUAL FAN (FAN TYPE 6) - MBE 4000 ENGINE

Previous topic

ENGINE FAN


 Single-Speed Fan on an MBE 900 Engine


 Single-Speed Fan on an MBE 4000 Engine


 Splicing and Repairing Straight Leads - Alternate Method 1

The tools required are listed in Recommended Splicing Tools.

Criteria: Splicing Straight Leads
 No more than one strand in a 16-strand wire may be cut or missing.
The recommended method to splice straight leads follows:

  1. Locate broken wire.

  2. Remove insulation as required; be sure exposed wire is clean and not corroded.

  3. Insert one wire into the splice clip until it butts against the clip. Stop and crimp (see Splicing Straight Leads - Alternate Method 1, A).

  4. Insert the other wire into the splice clip until it butts against the clip stop (see Splicing Straight Leads - Alternate Method 1, B).

NOTICE:
Any terminal that is cracked or ruptured is unacceptable as malfunctions may occur.
  5. Visually inspect the splice clip for cracks, rupture, or other crimping damage. Remove and replace damaged clips before proceeding.

  6. Pull on wire to ensure the splice integrity. The criteria listed in Applied Load Criteria for Terminals must be met.

  7. Shrink the splice clip insulative casing with a heat gun to seal the splice (see Splicing Straight Leads - Alternate Method 1, C).

NOTICE:
Splices may not be closer than 305 mm (12 in.) apart to avoid degradation in circuit performance. Replace wire to avoid having splices closer than 305 mm (12 in.) apart.
  8. Loop the lead back over the spliced joint and tape. See Recommended Strain Relief of Spliced Joint.

Next topic

Splicing and Repairing Straight Leads - Alternate Method 2

Previous topic

Clipped and Soldered Splicing Method


 Splicing and Repairing Straight Leads - Alternate Method 2

This method is not allowed or recommended for power or ignition circuits. The tools required are listed in Recommended Splicing Tools.

Criteria: Splicing Straight Leads
 No more than one strand in a 16-strand wire may be cut or missing.
An acceptable option for splicing straight leads is:

  1. Locate broken wire.

  2. Remove insulation as required; be sure exposed wire is clean and not corroded.

  3. Slide a sleeve of glue lined, shrink tubing (Raychem HTAT or equivalent) long enough to cover the splice clip on the wire and overlap the wire insulation, about 6 mm (0.25 in.) on both sides (see Splicing Straight Leads - Alternate Method 2, A).

  4. Insert one wire into splice clip until it butts against the splice clip. Stop and crimp (see Splicing Straight Leads - Alternate Method 2, B).

  5. Insert the remaining wires into the splice clip one at a time until each butts against the splice clip; stop and crimp (see Splicing Straight Leads - Alternate Method 2, B).

NOTICE:
Any terminal that is cracked or ruptured is unacceptable as malfunctions may occur.
  6. Visually inspect the terminal for cracks, rupture, or other crimping damage. Remove and replace damaged terminal before proceeding.

  7. Slide the shrink tubing over the crimped splice clip (see Splicing Straight Leads - Alternate Method 2, C).

  8. Shrink tubing with a heat gun to seal the splice (see Splicing Straight Leads - Alternate Method 2, D).

NOTICE:
A minimum of two layers of heat shrink tubing must be applied to splices that have more than one lead in or out.
  9. Loop the lead back over the spliced joint and tape. See Recommended Strain Relief of Spliced Joint.

Next topic

Shrink Wrap

Previous topic

Splicing and Repairing Straight Leads - Alternate Method 1


 Splicing Guidelines

The following are guidelines which may be used for splices. The selection of crimpers and splice connectors is optional. Select a high quality crimper equivalent to the Kent-Moore tool, J 38706, and commercially available splice clips.

The recommended technique for splicing and repairing circuits (other than power and ignition circuits) is a clipped and soldered splice. Alternatively, any method that produces a high quality, tight (mechanically and electronically sound) splice with durable insulation is considered to be acceptable.

Next topic

Clipped and Soldered Splicing Method

Previous topic

Deutsch Terminal Removal


 Splicing Straight Leads - Alternate Method 1

NOTICE:
Splices may not be closer than 305 mm (12 in.) apart to avoid degradation in circuit performance. Replace wire to avoid having splices closer than 305 mm (12 in.) apart.


 Splicing Straight Leads - Alternate Method 2

NOTICE:
Splices may not be closer than 305 mm (12 in.) apart to avoid degradation in circuit performance. Replace wire to avoid having splices closer than 305 mm (12 in.) apart.
No nicks in insulation are allowed.


 Staggering Wire Splices

Position spliced wires properly as follows:

NOTICE:
You must stagger positions to prevent a large bulge in the harness and to prevent the wires from chafing against each other.
  1. Stagger the position of each splice (see The Correct and Incorrect Method of Staggering Multiple Splices) so there is at least a 65 mm (2.5 in.) separation between splices.

NOTICE:
A minimum of two layers of heat shrink tubing extending 6 mm (0.25 in.) past the splice must be used to complete the splice.
  2. Heat shrink a minimum of two layers of heat shrink tubing.

  3. Tape the spliced wires to each other. Refer to CONDUIT AND LOOM.

Next topic

CONDUIT AND LOOM

Previous topic

Shrink Wrap


 STARTER LOCKOUT

The starter lockout output circuit drives a normally closed relay, which interrupts the starting signal when the output has been activated. See Starter Lockout.

Next topic

ACCELERATOR PEDAL INSTALLATION

Previous topic

VEHICLE POWER SHUTDOWN - OPTIONAL


 Starter Lockout


 Supply Fuel Temperature Sensor Connector

  1. Pin 1

  2. Pin 2

  3. SFT Sensor Connector


 Supply Fuel Temperature Sensor Pins and 55-Pin Connector Wires


 TAPE AND TAPING

Tape must be used when conduit is utilized. Be sure to follow the tape manufacturers' guidelines. The harness manufacturer may use tape under the harness covering (conduit or loom) to facilitate harness building. Tape must be tightly wrapped at all conduit interconnections with a minimum of two layers (refer to CONDUIT AND LOOM). Be sure to firmly secure the start and finish ends of tape.

NOTICE:
Black vinyl electrical tape should not be used in applications where the temperature exceeds 80 °C (176 °F).

Criteria: Tape
 In applications where the temperature does not exceed 80 °C (176 °F), black vinyl electrical tape that is flame retardant and weather resistant may be used.
In applications where temperature exceeds 80 °C (176 °F), vinyl electrical tape should not be used. For these applications, adhesive cloth backed, flame retardant polyethylene or fiber glass tape (Delphi No. PM-2203, Polikan No. 165 or equivalent) is recommended.

Criteria: Taping
 The tape must extend a minimum of 25 mm (1 in.) past the conduit.
The tape must be crossed over butted conduit ends.
The tape must be extended a minimum of 25 mm. (1 in) in each direction at all branches.

Next topic

SENSORS

Previous topic

CONDUIT AND LOOM


 Temperature

The ambient operating temperature range is -40 to 125 [image] C (-40 to 257 °F).

Next topic

Vibration

Previous topic

Environmental Conditions


 Terminal Locations on Injector Unit Pump

  1. Unit Pump

  2. Terminal

  3. Terminal


 The Correct and Incorrect Method of Staggering Multiple Splices


 The DDEC-VCU


 The Vehicle Control Unit


 Troubleshooting

Click in the Description and Troubleshooting columns for Help in troubleshooting the following faults:

PID
         SID
         Fault
         Description
         Troubleshooting
45
COLD START (GRID HEATER) FAULT

84
VEHICLE SPEED SENSOR FAULT

91
ACCELERATOR PEDAL SENSOR FAULT

100
ENGINE OIL PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

102
TURBO BOOST PRESSURE OUTSIDE OF NORMAL OPERATING RANGE

103
TURBO NO REVOLUTION FAULT

105
INTAKE AIR TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

110
COOLANT TEMPERATURE ABOVE RECOMMENDED NORMAL OPERATING RANGE

111
COOLANT OUTSIDE NORMAL OPERATING RANGE

158
BATTERY CHARGING FAULT

168
BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

174
SUPPLY FUEL TEMPERATURE SENSOR FAULT

175
ENGINE OIL TEMPERATURE OUTSIDE OF NORMAL OPERATING RANGE

190
ENGINE SPEED OUTSIDE NORMAL OPERATING RANGE

  1. 6
INJECTOR UNIT PUMP NOT OPERATING IN A NORMAL MANNER

21
         CRANKSHAFT POSITION SENSOR OUTSIDE OF NORMAL OPERATING CONDITIONS

57
         EXHAUST BRAKE FAULT

58
         ENGINE BRAKE FAULT

59
         DUAL-SPEED FAN LOW STAGE OPERATION FAULT

60
         DUAL-SPEED FAN HIGH STAGE OPERATION FAULT

64
         CAMSHAFT POSITION SENSOR FAULT

146
         EGR SYSTEM FAULT

230
         THROTTLE CONTROL FAULT

232
         ACCELERATOR PEDAL SUPPLY VOLTAGE FAULT

233
         PLD-MR FAULT (ERRONEOUS DATA)

242
         CRUISE CONTROL SET/RESUME SWITCH FAULT

243
         CRUISE CONTROL SET AND RESUME SWITCH FAULT

248
         PLD-MR DDEC-VCU DATALINK FAULT

254
         DDEC-VCU FAULT

Previous topic

FEATURES


 TROUBLESHOOTING INFORMATION

Instructions for repair in this Help system are generic. For example, "Repair Open" is used to advise the technician that a particular wire has been determined to be broken. In some cases it may not be best to try and locate the open. It may be that the best repair technique is to replace a complete harness. The technician should make the determination of the proper repair, with the best interest of the customer in mind.

Instructions to "Contact Detroit Diesel Technical Service" indicate that at the time of this publication, all known troubleshooting checks have been included. Review any recent Service Information Bulletins (SIB) or Service Information letters before calling.

It is also suggested that other DDC outlets be contacted. e.g. if you are a dealer or user, contact your closest DDC Distributor.

Ensure you have the engine serial number when you call. The FAX number for Detroit Diesel Technical Service is 313-592-7888.

Instructions in this Help system may suggest replacing a non DDC component. It may be required to contact the supplier of the component, e.g. truck manufacturer for a TPS concern, to obtain approval to replace the component.

Instructions to check terminals and connectors should include checking for proper contact tension. Using a mating terminal, a modest force should be required to remove a terminal from its mate. Replace terminals with poor tension.

After completing any repair, always clear fault codes that may have been generated during the troubleshooting process.

Important: To ensure you receive updates to the manual should the need arise, you must fill out the Information Card in the front of the manual.

Next topic

SAFETY PRECAUTIONS

Previous topic

INTRODUCTION


 TROUBLESHOOTING PID 45

The following procedures will troubleshoot PID 45:

045 03 - Open Circuit Fault

045 04 - Short to Ground Fault


 TROUBLESHOOTING PID 84

The following procedures will troubleshoot PID 84.

084 03 - Open Circuit

084 03 - Faulty Vehicle Speed Sensor

084 03 - Short to Power

084 04 - Faulty Vehicle Speed Sensor

084 04 - Faulty DDEC-VCU

084 04 - Short to Ground

084 04 - Short Between Wires 439S+ and 439S-


 TROUBLESHOOTING PID 91

The following procedure will troubleshoot PID 91.

091 02 - Position Active Fault (Erratic Data)

091 03 - Voltage High

091 04 - Voltage Low


 TROUBLESHOOTING PID 100

The Oil Combination Sensor contains an Engine Oil Pressure sensor and an Oil Temperature Sensor. It is located at the base of the oil filter, mounted on the right-front side of the engine. See Location of Engine Oil Combination Sensor and Close-up View of Oil Combination Sensor.

The following procedures will troubleshoot PID 100.

100 01 - Oil Pressure Low

100 02 - Oil Combination Sensor Data Erratic

100 03 - Oil Combination Sensor Open Circuit

100 04 - Oil Combination Sensor Short to Ground

100 14 - Oil Pressure Very Low


 TROUBLESHOOTING PID 102

The following procedures will troubleshoot PID 102.

102 00 - Boost Pressure High Fault

102 01 - Boost Pressure Low Fault

102 02 - Boost Pressure Sensor Data Erratic Fault

102 03 - Boost Pressure Sensor Open Circuit Fault

102 04 - Boost Pressure Sensor Short to Ground Fault


 TROUBLESHOOTING PID 103

See also:

DESCRIPTION OF PID 103 - TURBO NO REVOLUTION FAULT

There are two possible causes for this fault code:

Failed sensor.

Sensor too close to the turbo shaft (not enough air gap).

The following procedure will troubleshoot 103 07 - Turbo No Revolution Fault:

  1. With the engine stopped and at ambient temperature, unplug the TSS from the TSS connector. See Turbo Speed Sensor Location.

  2. Measure the resistance between the sensor terminals. See Turbo Speed Sensor Terminal and Wire Locations.

a. If resistance is approximately 900 [image], refer to Required Action.

b. If resistance is zero or higher than 950 [image], replace the sensor.


 TROUBLESHOOTING PID 105

The following procedures will troubleshoot PID 105.

105 03 - Intake Air Temperature Sensor Open Circuit

105 04 - Intake Air Temperature Sensor Short to Ground


 TROUBLESHOOTING PID 110

The Engine Coolant Temperature (ECT) sensor is mounted on the front connector housing toward the front of the cylinder block directly below the oil separator on the MBE 900 engines (see Location of Engine Coolant Temperature Sensor on the MBE 900 Engine) and on the side of cylinder block between units pumps No. 2 and 3 on the MBE 4000 engines (see Location of Engine Coolant Temperature Sensor on the MBE 4000 Engine).

Data from the ECT sensor is routed through wire pin locations 3 and 34 on the large, 55-pin PLD wiring harness connector. See 55-Pin Wiring Harness Connector.

110 00 - Engine Coolant Temperature High

110 03 - Engine Coolant Temperature Sensor Open Circuit

110 04 - Engine Coolant Temperature Sensor Short to Ground

110 14 - Engine Coolant Temperature Very High


 TROUBLESHOOTING PID 111

The ECL sensor is installed in the radiator top tank or in a remote-mounted surge tank and is connected to the VIH-VCU 15-pin connector. See Engine Coolant Level Sensor Location - Top of Radiator Tank for typical top tank location. See Engine Coolant Level Sensor Installation for typical sensor installation. See Location of DDEC-VCU and Wiring Harness Connectors for the typical location of the VIH-VCU inside the tractor cab.

The following procedures will troubleshoot PID 111:

111 01 - Engine Coolant Level Low

111 03 - Engine Coolant Level Sensor Open Circuit

111 04 - Engine Coolant Level Sensor Short to Ground


 TROUBLESHOOTING PID 158

The following procedures will troubleshoot PID 158.

158 00 - Battery Voltage Switched - High

158 01 - Battery Voltage Switched - Low

158 02 - PLD-MR and DDEC-VCU Signals Unmatched


 TROUBLESHOOTING PID 168

The following procedures will troubleshoot PID 168.

168 03 - Battery Voltage High Fault

168 04 - Battery Voltage Low Fault


 TROUBLESHOOTING PID 174

The following will troubleshoot PID 174. See Location of Supply Fuel Temperature Sensor for SFT sensor location.

The following procedures will troubleshoot PID 174:

174 03 - Supply Fuel Temperature Sensor Open Circuit

174 04 - Supply Fuel Temperature Sensor Short to Ground


 TROUBLESHOOTING PID 175

The engine oil combination sensor monitors engine oil temperature and engine oil pressure. The sensor is installed in the front of the base of the oil filter for the MBE 900 engines (see Location of Engine Oil Combination Sensor) and at the front of the heat exchanger housing for the MBE 4000 engines (see Location of Engine Oil Combination Sensor on the MBE 4000 Engine). The following procedures will troubleshoot PID 175.

175 03 - Engine Oil Temperature Open Circuit

175 04 - Engine Oil Temperature Short to Ground


 TROUBLESHOOTING PID 190

See also:

DESCRIPTION OF PID 190 - ENGINE SPEED OUTSIDE NORMAL OPERATING RANGE

Perform the following steps to troubleshoot an engine speed high fault:

  1. Reset the PLD-MR and DDEC-VCU.

a. If fault code 190 00 is not active after resetting the PLD-MR and DDEC-VCU, erase fault code memory.

b. If fault code 190 00 is still active after resetting the PLD-MR and DDEC-VCU, go to step 2.

  2. Check for additional active fault codes.

a. If additional fault codes are active, refer to the active faults.

NOTE: If this fault code is a historic code, engine overspeed is suspect.

b. If only fault code 190 00 is active, contact Detroit Diesel Technical Service.


 TROUBLESHOOTING SID 21

Perform the following steps to troubleshoot SID 21.

021 01 - Crankshaft Position Sensor Signal Voltage Too Low

021 03 - Crankshaft Position Sensor Open Circuit

021 04 - Crankshaft Position Sensor Short to Ground

021 07 - No Match of Camshaft and Crankshaft Signals

021 08 - Sensor Time Out

021 14 - Pins Swapped


 TROUBLESHOOTING SID 57

Perform the following steps to troubleshoot SID 57. See PLD-MR and Harness Connectors for the Engine Electrical Connector (55-pin).

057 05 - Open Circuit in the Engine Brake Flap Solenoid Valve and Wiring

057 06 - Short in the Engine Brake Flap Solenoid Valve and Wiring


 TROUBLESHOOTING SID 58

The following procedures will troubleshoot SID 58.

058 03 - Constant Throttle Solenoid Valve Short to Power

058 05 - Constant Throttle Solenoid Valve Open Circuit

058 06 - Constant Throttle Solenoid Valve Short to Ground


 TROUBLESHOOTING SID 59

The following procedures will troubleshoot SID 59.

059 05 - Fan Open Circuit

059 06 - Fan Short to Ground


 TROUBLESHOOTING SID 60

The following procedures will troubleshoot SID 60.

060 05 - Fan Open Circuit

060 06 - Fan Short to Ground


 TROUBLESHOOTING SID 64

The following procedure will troubleshoot SID 64.

064 03 - Open Circuit

064 04 - Short to Ground

064 08 - Time Out

064 14 - Pins Swapped


 TROUBLESHOOTING SID 146

Data for the EGR temperature sensor is routed through pins 28 and 22 on the large, 55-pin PLD-MR wiring harness connector. See Pin Locations on 55-Pin Connector.

The following procedures will troubleshoot SID 146.

146 00 - EGR Temperature above Normal

146 01 - EGR Temperature below Normal

146 02 - EGR Data Erratic

146 07 - EGR Valve not Responding

146 12 - Bad Component


 TROUBLESHOOTING SID 230

The following procedures will troubleshoot SID 230.

230 05 - Idle Validation Switch Open Circuit Fault

230 12 - Idle Validation Switch Short to Ground Fault


 TROUBLESHOOTING SID 232

Perform the following steps to troubleshoot SID 232:

232 03 - Accelerator Pedal Supply Voltage Above Normal

232 04 - Accelerator Pedal Supply Voltage Below Normal


 TROUBLESHOOTING SID 233

Perform the following steps to troubleshoot SID 233:

233 12 - PLD-MR Failed or Programmed Incorrectly

233 14 - Incorrect or Misprogrammed PLD-MR


 TROUBLESHOOTING SID 242

242 12 - Cruise Control Switch SET and RES Contacts Closed at the Same Time

See also:

DESCRIPTION OF SID 242 - CRUISE CONTROL SET/RESUME SWITCH FAULT

Troubleshoot a cruise control SET/RESUME switch fault as follows:

  1. Turn ignition on and place the cruise control switch in the "Off" position. Do not start the engine.

  2. Note the driver console display.

a. If cruise control switch status "RES" is displayed, go to step 3.

b. If cruise control switch status "SET" is displayed, go to step 4.

  3. Unplug the cruise control switch.

a. If "RES" status is no longer displayed, replace the cruise control SET/RES switch. Erase fault code memory.

b. If "RES" status is still displayed, repair short to ground in wire 440F to pin 5 of the 18-pin connector. Erase fault code memory. See Location of DDEC-VCU and Wiring Harness Connectors and see Connector Positions on DDEC-VCU for connector location.

  4. Unplug the cruise control switch. See Connector Positions on DDEC-VCU.

a. If "SET" status is no longer displayed, replace the cruise control SET/RES switch. Erase fault code memory.

b. If "SET" status is still displayed, repair short to ground in wire 440E to pin 4 of the 18-pin connector. Erase fault code memory. See Location of DDEC-VCU and Wiring Harness Connectors and see Connector Positions on DDEC-VCU for connector location.


 TROUBLESHOOTING SID 243

243 12 - Cruise Control Switch SET and RES Contacts Closed at the Same Time

See also:

DESCRIPTION OF SID 243 - CRUISE CONTROL SET AND RESUME SWITCH FAULT

Perform the following steps to troubleshoot a Cruise Control Switch SET and RES Contacts Closed at the Same Time fault.

  1. Turn the ignition on and set the cruise control switch to the OFF position. Do not start the engine, since all troubleshooting will be done with the engine off.

  2. Note the driver display console.

a. If the RES status is not displayed, go to step 3.

b. If the RES status is displayed, go to step 5.

  3. Check the cruise control switch status.

a. If the switch status is not displayed as "SET," contact Detroit Diesel Technical Service.

b. If the switch status is displayed as "SET," go to step 4.

  4. Unplug the cruise control switch.

a. If the status of the SET switch is displayed as "OFF," replace the cruise control SET/RES switch. Erase fault code memory.

b. If the status of the SET switch is displayed as "ON," repair short to ground in 18-pin connector wire 440E. See Location of DDEC-VCU and Wiring Harness Connectors for wiring harness connector locations and see Connector Positions on DDEC-VCU for connector positions on DDEC-VCU. Erase fault code memory.

  5. Unplug the RES switch.

a. If the status of the RES switch is not "RES," replace the cruise control SET and RES switch. Erase fault code memory.

b. If the status of the RES switch is "RES," repair short to ground in 18-pin connector wire 440F. Erase fault code memory. See Location of DDEC-VCU and Wiring Harness Connectors for wiring harness connector locations and see Connector Positions on DDEC-VCU for connector positions on DDEC-VCU.


 TROUBLESHOOTING SID 248

The following procedure will troubleshoot SID 248.

248 02 - Proprietary Datalink Fault

248 14 - DDEC-VCU Internal Error


 TROUBLESHOOTING SID 254

254 12 - DDEC-VCU Internal Error

See also:

DESCRIPTION OF SID 254 - DDEC-VCU FAULT

Perform the following steps to troubleshoot 254 12, DDEC-VCU internal error.

  1. Reset the DDEC-VCU.

NOTE: Turning the ignition off for more than 10 seconds will reset the DDEC-VCU.

  2. Check for active fault codes.

a. If fault code 254 12 is no longer active, erase fault code memory.

b. If fault code 254 12 is still active, go to step 3.

  3. Check for other active fault codes.

a. If there are other active fault codes, refer to their appropriate sections.

b. If there are no other fault codes, replace the DDEC-VCU. Erase fault code memory.


 TROUBLESHOOTING SIDS 1-6

Refer to the following illustrations when troubleshooting SIDs 1-6.

See Injector Unit Pump Wiring on 6-Cylinder Engine for injector unit pump locations on the 6-cylinder engine.

See Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for the injector unit pump wiring on the 4-cylinder engine.

See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for the injector unit pump wiring on the 6-cylinder engine.

See Terminal Locations on Injector Unit Pump for the injector unit pump wiring on the 4-cylinder engine.

Troubleshoot SIDs 1-6 as follows:

  1. 05 - Current Below Normal or Open Circuit

  2. 05 - Current Below Normal or Open Circuit

  3. 05 - Current Below Normal or Open Circuit

  4. 05 - Current Below Normal or Open Circuit

  5. 05 - Current Below Normal or Open Circuit

  6. 05 - Current Below Normal or Open Circuit

  1. 06 Through 006 06 - Short Circuit

  1. 07 - No Plunger

  2. 07 - No Plunger

  3. 07 - No Plunger

  4. 07 - No Plunger

  5. 07 - No Plunger

  6. 07 - No Plunger

  1. 12 Through 006 12 - Idle Smoothness Governor at Limit

  1. 14 Through 006 14 - Single Cylinder Correction at Idle


 Turbo Boost Air Combination Sensor


 Turbo Boost Air Combination Sensor Wiring for MBE 900 Engine


 Turbo Boost Air Combination Sensor Wiring for MBE 4000 Engine


 Turbo Speed Sensor Location

  1. TSS Connector

  2. Turbo Speed Sensor

  3. Turbocharger


 Turbo Speed Sensor Terminal and Wire Locations


 TWO-SPEED FAN (FAN TYPE 0 OR 1) - MBE 4000 ENGINE

See Two-Speed Fan on an MBE 4000 Engine for the schematic showing a two-speed fan (fan type 0 or 1) on an MBE 4000 engine.

Next topic

VARIABLE-SPEED FAN (FAN TYPE 5)

Previous topic

DUAL FAN (FAN TYPE 6) - MBE 4000 ENGINE


 Two-Speed Fan on an MBE 4000 Engine


 Typical Accelerator Pedal Installation


 Typical Exhaust Brake Installation

  1. Exhaust Pipe

  2. Constant Torque Clamp

  3. Bracket

  4. Exhaust Brake Cylinder

  5. Mounting Stud

  6. Turbocharger

  7. Exhaust Brake Valve Housing


 Typical MBE 4000 Engine Harness - Non-EGR Engine


 Typical On-Highway MBE 900 Engine Harness - Non-EGR Engine


 Typical On-Highway MBE 900 Six-cylinder Engine Harness - EGR Engine


 Typical On-Highway Vehicle Interface Harness with a DDEC-VCU


TShootMBEuntitled

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in 55-pin connector wire:

    6. Cylinder Engine- Wire 53 attached to terminal K14 of injector unit pump 3.

    4-Cylinder Engine- Wire 45 attached to terminal K14 of injector unit pump 3.

  2. Erase fault code memory.


TShootMBEuntitled00000002

 No Help available

There is no troubleshooting Help available for this combination of SID/PID and FMI numbers.


TShootMBEuntitled00000103

 Required Actions

Perform the following steps to resolve 084 03 Wire 439S- Open Circuit.

  1. Replace the VSS.

  2. Erase the fault code memory.


TShootMBEuntitled00000105

 Required Actions

Perform the following steps to resolve 084 03 - Wire 439S+ Short to Power.

  1. Repair the short to power in VSS wire 439S+.

  2. Erase the fault code memory.


TShootMBEuntitled00000107

 Required Actions

Perform the following steps to resolve the 084 04 - Faulty VSS.

  1. Replace the VSS.

  2. Erase the fault code memory.


TShootMBEuntitled00000109

 Required Actions

Perform the following steps to resolve the 084 04 - Faulty DDEC-VCU.

  1. Replace the DDEC-VCU.

  2. Erase the fault code memory.


TShootMBEuntitled00000111

 Required Actions

Perform the following steps to resolve 084 04 Wire 439S+ Short to Ground.

  1. Repair the short to ground in the VSS wire 439S+.

  2. Erase the fault code memory.


TShootMBEuntitled00000113

 Required Actions

Perform the following steps to resolve 084 04 Short Between Wires 439S+ and 439S-.

  1. Repair the short circuit in the VSS wires 439S+ and 439S-.

  2. Erase the fault code memory.


TShootMBEuntitled00000117

 Required Actions

Perform the following step to resolve a position active fault.

  1. Repair or replace wires 440T, 440P+, and 440P- (pins 11, 9, and 14 of the 21-pin connector) as necessary.


TShootMBEuntitled00000118

 Required Actions

Perform the following steps to resolve a position active fault.

  1. Replace the AP assembly.

  2. Erase the fault code memory.


TShootMBEuntitled00000119

 Required Actions

Perform the following steps to resolve a position active fault.

  1. Repair or replace wires 440P+ and 440P- (pins 9 and 14 of the 21-pin connector).

  2. Replace the DDEC-VCU, if necessary.

  3. Erase the fault code memory.


TShootMBEuntitled00000121

 Required Actions

Perform the following steps to resolve voltage high.

  1. Repair the short circuit between wires 440P+ and 440T connecting the DDEC-VCU to the AP sensor.

  2. Erase the fault code memory.


TShootMBEuntitled00000122

 Required Actions

Perform the following steps to resolve voltage high.

  1. Repair the open circuit in wire 440P- connecting the DDEC-VCU to the AP connector.

  2. Erase the fault code memory.


TShootMBEuntitled00000123

 Required Actions

Perform the following steps to resolve voltage high.

  1. Repair the open circuit in wire 440T connecting the DDEC-VCU to the AP connector.

  2. Erase the fault code memory.


TShootMBEuntitled00000124

 Required Actions

Perform the following steps to resolve voltage high.

  1. Replace the AP assembly.

  2. Erase the fault code memory.


TShootMBEuntitled00000126

 Required Actions

Perform the following steps to resolve voltage low.

  1. Repair the short to ground in wire 440T.

  2. Erase the fault code memory.


TShootMBEuntitled00000127

 Required Actions

Perform the following steps to resolve voltage low.

  1. Repair the open circuit in wire 440P+.

  2. Erase the fault code memory.


TShootMBEuntitled00000128

 Required Actions

Perform the following steps to resolve voltage low.

  1. Replace the AP assembly.

  2. Erase the fault code memory.


TShootMBEuntitled00000132

 Required Actions

Perform the following steps to resolve a high oil level:

  1. Check for fuel entering into the engine oil system and repair as required.

NOTE: An increase in the engine oil system level indicates fuel may be entering into the engine oil system.

  2. Change the engine oil.

  3. Erase the fault code memory.


TShootMBEuntitled00000133

 Required Action

Perform the following steps to resolve a faulty oil gage:

  1. Repair or replace the oil gage as required.

  2. Erase the fault code memory.


TShootMBEuntitled00000134

 Required Action

Perform the following steps to resolve a faulty oil pump suction pipe:

  1. If the suction pipe is cracked, replace it.

  2. If the suction pipe is loose, reinstall it.

  3. Erase the fault code memory.


TShootMBEuntitled00000135

 Required Action

Perform the following steps to resolve a loose drive or driven gear:

  1. Repair or replace loose gears as required.

  2. Erase the fault code memory.


TShootMBEuntitled00000136

 Required Action

Perform the following steps to resolve a faulty oil pressure relief valve:

  1. Repair or replace a faulty oil pressure relief valve as required.

  2. Erase the fault code memory.


TShootMBEuntitled00000150

 Required Action

Resolve a Turbo No Revolution fault as follows:

  1. Remove the TSS from the turbo shaft housing. See Turbo Speed Sensor Location.

  2. Adjust the air gap by adding a 0.020 in. washer between the sensor body and the housing.

  3. Install the sensor into the turbo shaft housing.

  4. Start the engine and check for active codes.

a. If any codes are still active, repeat steps 1 through 3.

b. If no codes are active, troubleshooting is done.


TShootMBEuntitled00000158

 Required Action

Perform the following steps to resolve a coolant temperature high fault. Repair or replace, as required.

  1. Check for coolant loss.

  2. Check for blockage in radiator and charge air cooler.

  3. Check fan belt condition (slippage).

  4. Check for proper location of fan shroud.

  5. Check for proper radiator hose condition (no collapsed hoses).

  6. Check for proper viscous fan operation.


TShootMBEuntitled00000160

 Required Action

Perform the following steps to resolve an ECT sensor open circuit fault:

  1. Repair open circuit in wire between pin 3 of the 55-pin connector and pin 2 of the ECT sensor.

  2. Erase fault code memory.


TShootMBEuntitled00000161

 Required Action

Perform the following steps to resolve an ECT sensor open circuit fault:

  1. Check all contacts and connections. Remove corrosion, if evident.

a. If fault 110 03 is not active, erase fault code memory.

b. If fault 110 03 is still active, go to step 2.

  2. Contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on the new PLD-MR.


TShootMBEuntitled00000163

 Required Action

Perform the following steps to resolve an ECT sensor short-to-ground fault.

  1. Contact Detroit Diesel Technical Service for authorization to replace the PLD-MR.

  2. Set parameters on the new PLD-MR.


TShootMBEuntitled00000164

 Required Action

Perform the following steps to resolve an ECT sensor short-to-ground fault.

  1. Erase fault code memory.


TShootMBEuntitled00000166

 Required Action

Perform the following steps to resolve a coolant temperature high fault. Repair or replace, as required.

  1. Check for coolant loss.

  2. Check for blockage in radiator and charge air cooler.

  3. Check fan belt condition (slippage).

  4. Check for proper location of fan shroud.

  5. Check for proper radiator hose condition (no collapsed hoses).

  6. Check for proper viscous fan operation.


TShootMBEuntitled00000170

 Required Action

Perform the following steps to resolve a coolant level low fault. Repair as required.

  1. Check for coolant leak at cylinder head gasket.

  2. Check for coolant leak at air compressor head gasket.

  3. Check for external coolant leak at hose connections.

  4. Check for coolant in oil.

  5. Check for loose or faulty radiator cap.


TShootMBEuntitled00000171

 Required Action

Perform the following step to resolve a coolant level low fault.

  1. If the Switch/Indicator Datalink Monitor Template does not indicate that the coolant level is full, replace the ECL sensor.

  2. Erase fault code memory.


TShootMBEuntitled00000178

 Required Action

Perform the following steps to resolve fault code 158 01.

  1. Replace the DDEC-VCU.

  2. Erase the fault code memory.


TShootMBEuntitled00000179

 Required Action

Perform the following steps to resolve fault code 158 01.

  1. Replace or repair the supply side wires and connectors between pin 2 of the 21-pin connector and battery.

  2. Erase the fault code memory.


TShootMBEuntitled00000180

 Required Action

Perform the following steps to resolve fault code 158 01.

  1. Replace or repair the ground side wires and connectors between pin 3 of the 21-pin connector and battery ground.

  2. Erase the fault code memory.


TShootMBEuntitled00000182

 Required Actions

Perform the following steps to resolve fault code 158 02.

  1. Replace or repair the bad contacts and/or voltage supply for pins 2 (ignition) and 3 (ground) of the 21-pin connector.

  2. Erase the fault code memory.


TShootMBEuntitled00000183

 Required Actions

Perform the following steps to resolve fault code 158 02.

  1. Replace or repair the bad contacts and/or voltage supply for pin 15 (power) and pins 9 and 11 (ground) on 16-pin connector.

  2. Erase the fault code memory.


TShootMBEuntitled00000193

 Required Action

Perform the following steps to resolve an SFT sensor open circuit fault:

  1. Repair or replace open circuit in wire between pin 36 of the 55-pin connector and pin 1 of the SFT sensor. See 55-Pin Wiring Harness Connector.

  2. Erase fault code memory.


TShootMBEuntitled00000194

 Required Action

Perform the following steps to resolve an SFT sensor open circuit fault:

  1. Check all contacts and connections.

  2. Contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.

  3. Erase fault code memory.


TShootMBEuntitled00000195

 Required Action

Perform the following steps to resolve an SFT sensor open circuit fault:

  1. Repair open circuit in 55-pin connector wire 4 to pin 2 of the SFT sensor connector. See Supply Fuel Temperature Sensor Pins and 55-Pin Connector Wires.

  2. Erase fault code memory.


TShootMBEuntitled00000197

 Required Action

Perform the following steps to resolve an SFT sensor short-to-ground fault.

  1. Remove and replace SFT sensor.

  2. Erase fault code memory.


TShootMBEuntitled00000198

 Required Action

Perform the following steps to resolve an SFT sensor short-to-ground fault.

  1. Repair short to ground in 55-pin connector wire 36 to pin 1 of the SFT sensor connector.

  2. Erase fault code memory.


TShootMBEuntitled00000199

 Required Action

Perform the following steps to resolve an SFT sensor short-to-ground fault.

  1. Clean and check the SFT sensor contacts.

  2. If fault 174 03 is active after cleaning and checking the contacts, perform the following steps:

a. Contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameters on new PLD-MR.

b. Erase fault code memory.


TShootMBEuntitled00000203

 Required Action

Perform the following steps to resolve an engine oil temperature open circuit fault:

  1. Replace oil combination sensor.

  2. Erase fault code memory.


TShootMBEuntitled00000204

 Required Action

Perform the following steps to resolve an engine oil temperature open circuit fault:

  1. Repair short to power in wire between pin 39 of the 55-pin connector and pin 2 of the oil combination sensor connector.

  2. Erase fault code memory.


TShootMBEuntitled00000205

 Required Action

Perform the following steps to resolve an engine oil temperature open circuit fault:

  1. Repair open circuit in wire between pin 39 of the 55-pin connector and pin 2 of the oil combination sensor.

  2. Erase fault code memory.


TShootMBEuntitled00000206

 Required Action

Perform the following steps to resolve an engine oil temperature open circuit fault:

  1. Repair short to power in wire between pin 36 of the 55-pin connector and pin 1 of the oil combination sensor connector.

  2. Erase fault code memory.


TShootMBEuntitled00000213

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault.

See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine.

  1. Repair open circuit in the following 55-pin connector wire:

    6. Cylinder Engine - Wire 16 attached to terminal K11 of unit pump 1 or terminal K15 of unit pump 3 or terminal K12 of unit pump 2.

    4-Cylinder Engine - Wire 16 attached to terminal K11 of unit pump 1 or terminal K12 of unit pump 2.

  2. Erase fault code memory.


TShootMBEuntitled00000215

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in 55-pin connector wire:

    6. Cylinder Engine - Wire 16 attached to terminal K11 of injector unit pump 1 or terminal K12 of unit pump 2 or terminal K15 of unit pump 3.

    4-Cylinder Engine - Wire 16 attached to terminal K11 of injector unit pump 1 or terminal K12 of unit pump 2

  2. Erase fault code memory.


TShootMBEuntitled00000216

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in 55-pin connector wire:

    6. Cylinder Engine - Wire 47 attached to terminal K13 of injector unit pump 3.

    4-Cylinder Engine - Wire 16 attached to terminal K12 of injector unit pump 2.

  2. Erase fault code memory.


TShootMBEuntitled00000218

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in 55-pin connector wire:

    6. Cyl Eng.- Wire 16 attached to terminal K11 of injector unit pump 1 or terminal K15 of unit pump 3 or terminal K12 of unit pump 2.

    4-Cyl Eng.- Wire 9 attached to terminal K15 of injector unit pump 3 or terminal K16 of unit pump 4.

  2. Erase fault code memory.


TShootMBEuntitled00000221

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in the following 55-pin connector wire:

    6. Cylinder Engine- Wire 9 attached to terminal K58 of injector unit pump 4 or terminal K18 of unit pump 5 or terminal K20 of unit pump 6.

    4-Cylinder Engine- Wire 9 attached to terminal K15 of injector unit pump 3 or terminal K16 of unit pump 4

  2. Erase fault code memory.


TShootMBEuntitled00000222

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in the following 55-pin connector wire:

    6. Cylinder Engine- Wire 38 attached to terminal K38 of injector unit pump 4.

    4-Cylinder Engine- Wire 44 attached to terminal K17 of injector unit pump 4.

  2. Erase fault code memory.


TShootMBEuntitled00000224

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair intermittent open circuit in 55-pin connector wire 9 attached to terminal K58 of injector unit pump 4 or terminal K18 of unit pump 5 or terminal K20 of unit pump 6.

  2. Erase fault code memory.


TShootMBEuntitled00000225

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in 55-pin connector wire 45 attached to terminal K19 of injector unit pump 5.

  2. Erase fault code memory.


TShootMBEuntitled00000227

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair intermittent open circuit in 55-pin connector wire 9 attached to terminal K58 of injector unit pump 4 or terminal K18 of unit pump 5 or terminal K20 of unit pump 6.

  2. Erase fault code memory.


TShootMBEuntitled00000228

 Required Action

Perform the following steps to resolve a current below normal or open circuit fault:

  1. Repair open circuit in 55-pin connector wire 9 attached to terminal K20 of injector unit pump 6.

  2. Erase fault code memory.


TShootMBEuntitled00000230

 Required Action

Perform the following steps to resolve a short circuit fault:

  1. On 6-cylinder engines, repair short to ground in the required injector unit pump wire listed in 6-Cylinder Engine Injector Unit Pump Low Resistance Wires/Repair Wires. See Location of Unit Pumps, Terminals and Wires on 6-Cylinder Engine for location of pump wires.

  2. On 4-cylinder engines, repair short to ground in the required injector unit pump wire listed in 4-Cylinder Engine Injector Unit Pump Low Resistance Wires/Repair Wires. See Location of Unit Pumps, Terminals and Wires on 4-Cylinder Engine for location of pump wires.

  3. Erase fault code memory.


TShootMBEuntitled00000232

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wire:

Wire 54 to terminal K10 of unit pump 1.

Wire 47 to terminal K13 of unit pump 2.

  2. Erase fault code memory.


TShootMBEuntitled00000233

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wires:

Wire 54 to terminal K10 of unit pump 1.

Wire 53 to terminal K14 of unit pump 3.

  2. Erase fault code memory.


TShootMBEuntitled00000235

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wire:

Wire 54 to terminal K10 of unit pump 1.

Wire 47 to terminal K13 of unit pump 2.

  2. Erase fault code memory.


TShootMBEuntitled00000236

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wires:

Wire 47 to terminal K13 of unit pump 2.

Wire 53 to terminal K14 of unit pump 3.

  2. Erase fault code memory.


TShootMBEuntitled00000238

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wire:

Wire 53 to terminal K14 of unit pump 3.

Wire 47 to terminal K13 of unit pump 2.

  2. Erase fault code memory.


TShootMBEuntitled00000239

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wires:

Wire 54 to terminal K10 of unit pump 1.

Wire 53 to terminal K14 of unit pump 3.

  2. Erase fault code memory.


TShootMBEuntitled00000241

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wire:

Wire 44 to terminal K21 of unit pump 6.

Wire 38 to terminal K38 of unit pump 4.

  2. Erase fault code memory.


TShootMBEuntitled00000242

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wires:

Wire 38 to terminal K38 of unit pump 4.

Wire 45 to terminal K19 of unit pump 5.

  2. Erase fault code memory.


TShootMBEuntitled00000244

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wire:

Wire 44 to terminal K21 of unit pump 6.

Wire 45 to terminal K19 of unit pump 5.

  2. Erase fault code memory.


TShootMBEuntitled00000245

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wires:

Wire 38 to terminal K38 of unit pump 4.

Wire 45 to terminal K19 of unit pump 5.

  2. Erase fault code memory.


TShootMBEuntitled00000247

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wire:

Wire 44 to terminal K21 of unit pump 6.

Wire 45 to terminal K19 of unit pump 5.

  2. Erase fault code memory.


TShootMBEuntitled00000248

 Required Action

To resolve a no plunger fault, perform the following steps:

  1. Repair short circuit in the following 55-pin connector wires:

Wire 44 to terminal K21 of unit pump 6.

Wire 38 to terminal K38 of unit pump 4.

  2. Erase fault code memory.


TShootMBEuntitled00000262

 Required Actions

Perform the following steps to resolve 057 05 for an engine with no exhaust brake flap.

  1. Set Parameters 00603 and 00604 to "Not Active".

  2. Erase the fault code memory.


TShootMBEuntitled00000263

 Required Actions

Perform the following steps to resolve 057 05 with an open circuit.

  1. Repair open circuit and/or replace bad contacts in the 55-pin connector wires 51 and/or 12.

  2. Erase the fault code memory.


TShootMBEuntitled00000264

 Required Actions

Perform the following steps to resolve 057 05.

  1. Remove and replace the exhaust brake flap solenoid valve.

NOTE: The solenoid valve is typically located on the firewall.

  2. Erase the fault code memory.


TShootMBEuntitled00000266

 Required Actions

Perform the following steps to resolve 057 06 for an engine with no exhaust brake flap.

  1. Set Parameters 00603 and 00604 to "Not Active".

  2. Erase the fault code memory.


TShootMBEuntitled00000267

 Required Actions

Perform the following steps to resolve 057 06, short to ground in the 55-pin connector wire 12.

  1. Repair the short to ground in the 55-pin connector wire 12.

  2. Erase the fault code memory.


TShootMBEuntitled00000268

 Required Actions

Perform the following steps to resolve 057 06, short to ground in the 55-pin connector wire 51.

  1. Repair the short to ground in the 55-pin connector wire 51.

  2. Erase the fault code memory.


TShootMBEuntitled00000269

 Required Actions

Perform the following steps to resolve 057 06, short between the 55-pin connector wires 12 and 51.

  1. Repair the short between the 55-pin connector wires 12 and 51.

  2. Erase the fault code memory.


TShootMBEuntitled00000270

 Required Actions

Perform the following steps to resolve 057 06.

  1. Remove and replace the exhaust brake flap solenoid valve.

NOTE: The solenoid valve is typically located on the firewall.

  2. Erase the fault code memory.


TShootMBEuntitled00000287

 Required Actions

Perform the following steps to resolve an open circuit.

  1. Replace the camshaft position sensor and the clamping sleeve.

  2. Erase the fault code memory.


TShootMBEuntitled00000288

 Required Actions

Perform the following steps to resolve an open circuit.

  1. Contact Detroit Diesel Technical Service for authorization to replace the PLD-MR. Set parameter on new PLD-MR.

  2. Erase the fault code memory.


TShootMBEuntitled00000289

 Required Actions

Perform the following steps to resolve an open circuit.

  1. Inspect the contacts for damage and repair as necessary.

  2. Erase the fault code memory.


TShootMBEuntitled00000291

 Required Actions

Perform the following steps to resolve a short to ground.

  1. Ensure that the camshaft position sensor wires are properly connected (not crossed) on the 55-pin connector. Repair as necessary. See Camshaft Position Sensor.

  2. Erase the fault code memory.


TShootMBEuntitled00000292

 Required Actions

Perform the following steps to resolve a short to ground.

  1. Refer to TROUBLESHOOTING PID 100 to troubleshoot fault code 100 04.

NOTE: A faulty oil pressure sensor will cause erratic codes.

  2. Erase fault code memory.


TShootMBEuntitled00000293

 Required Actions

Perform the following steps to resolve a short to ground.

  1. Contact Detroit Diesel Technical Service for authorization to replace the PLD-MR.

  2. Set parameters on the new PLD-MR.

  3. Erase fault code memory.


TShootMBEuntitled00000295

 Required Actions

Perform the following steps to resolve a time out.

  1. Troubleshoot active fault code 064 03. Refer to 064 03 - Open Circuit.

  2. Erase the fault code memory.


TShootMBEuntitled00000296

 Required Actions

Perform the following step to resolve a time out.

  1. Troubleshoot for active fault code 064 04. Refer to 064 04 - Short to Ground.


TShootMBEuntitled00000297

 Required Actions

Perform the following steps to resolve a time out.

  1. Remove and replace the camshaft sensor sleeve.

  2. Erase the fault code memory.


TShootMBEuntitled00000298

 Required Actions

Perform the following steps to resolve a time out.

  1. Remove the camshaft sensor and ensure that the sensor bores are not damaged. If damaged is present, repair as necessary.

  2. Check the camshaft sensor for proper axial play. Repair as necessary if the axial play is incorrect.

  3. Erase the fault code memory.


TShootMBEuntitled00000300

 Required Actions

Perform the following steps to resolve a pins swapped. See Camshaft Position Sensor.

  1. Reseat the camshaft (B16) and crankshaft (B15) sensors.

  2. Ensure that the 55-pin connector wires are not crossed. If crossed, repair as necessary.

  3. Erase the fault code memory.


TShootMBEuntitled00000327

 Required Actions

Perform the following steps to resolve a proprietary datalink fault.

  1. Restore battery voltage at wire 15 on the small engine harness connector (16-pin) on the PLD-MR.


TShootMBEuntitled00000328

 Required Actions

Perform the following steps to resolve a proprietary datalink fault.

  1. Clean or repair as required the terminals on the small engine harness connector (16-pin) plug on the PLD-MR. See PLD-MR Engine Bulkhead Schematic - Business Class and see PLD-MR Engine Bulkhead Schematic - Acterra for wiring schematics.

  2. Erase the fault code memory.


TShootMBEuntitled00000329

 Required Actions

Perform the following steps to resolve a proprietary datalink fault.

  1. Replace or clean the 15-pin connector contacts on the DDEC-VCU as required.

  2. Erase fault code memory.


TShootMBEuntitled00000330

 Required Actions

Perform the following steps to resolve a proprietary datalink fault.

  1. Replace the twisted wire pair set 439D- and 439D+ between the PLD-MR and the DDEC-VCU.

  2. Erase the fault code memory.


TShootMBEuntitled00000331

 Required Actions

Perform the following steps to resolve a proprietary datalink fault.

  1. Check the DDEC-VCU and PLD-MR ground wires for continuity.

  2. Erase the fault code memory.


TShootMBEuntitled00000333

 Required Actions

Perform the following steps to resolve a DDEC-VCU internal error fault.

  1. Replace the twisted pair wire set 439D- and 439D+ between the PLD-MR and the DDEC-VCU.

  2. Erase the fault code memory.


TShootMBEuntitled00000334

 Required Actions

Perform the following steps to resolve a DDEC-VCU internal error fault.

  1. Inspect and clean the wire contacts as required.

  2. Erase the fault code memory.


TShootMBEuntitled00000437

Front
Looking into the Pins


TShootMBEuntitled00000453

Front
Looking into the Pins on the Harness


TShootMBEuntitled00000456

Front
Looking into the Pins on the Harness


TShootMBEuntitled00000458

Front
Looking into the Pins on the Harness


TShootMBEuntitled00000460

Front
Looking into the Pins on the Harness


TShootMBEuntitled00000498

 Boost Pressure (PLD) - Boost pressure out of range

There is currently no troubleshooting Help for PID 102 13.


TShootMBEuntitled00000499

 Turbo Charger 1 / 2 - No revolution on charger #2

There is currently no troubleshooting Help for PID 103 14.


TShootMBEuntitled00000500

 Intake Manifold Temperature (PLD) - Data valid but above normal

There is currently no troubleshooting Help for PID 105 00.


TShootMBEuntitled00000501

 Air Filter Sensor (VCU) - Data valid but above normal

There is currently no troubleshooting Help for PID 107 00.


TShootMBEuntitled00000502

 Air Filter Sensor (VCU) - Open circuit

There is currently no troubleshooting Help for PID 107 03.


TShootMBEuntitled00000503

 Air Filter Sensor (VCU) - Shorted to ground

There is currently no troubleshooting Help for PID 107 04.


TShootMBEuntitled00000504

 Engine Coolant Level (VCU) - Data valid but very low

There is currently no troubleshooting Help for PID 111 14.


TShootMBEuntitled00000505

 Turbo Compressor Outlet Temperature (PLD) - Data above normal

There is currently no troubleshooting Help for PID 404 00.


TShootMBEuntitled00000506

 Turbo Compressor Outlet Temperature (PLD) - Data below normal

There is currently no troubleshooting Help for PID 404 01.


TShootMBEuntitled00000507

 Gridheater (VCU) - Grid heater defect

There is currently no troubleshooting Help for PID 45 12.


TShootMBEuntitled00000508

 Gridheater (VCU) - Special instructions.

There is currently no troubleshooting Help for PID 45 14.


TShootMBEuntitled00000509

 Vehicle Speed Sensor (VCU) - Data valid but above normal operating range

There is currently no troubleshooting Help for PID 84 00.


TShootMBEuntitled00000510

 Vehicle Speed Sensor (VCU) - Anti-tamper fault 1

There is currently no troubleshooting Help for PID 84 01.


TShootMBEuntitled00000511

 Vehicle Speed Sensor (VCU) - Data erratic

There is currently no troubleshooting Help for PID 84 02.


TShootMBEuntitled00000512

 Vehicle Speed Sensor (VCU) - Anti-tamper fault 2

There is currently no troubleshooting Help for PID 84 05.


TShootMBEuntitled00000513

 Vehicle Speed Sensor (VCU) - Grounded Circuit

There is currently no troubleshooting Help for PID 84 06.


TShootMBEuntitled00000514

 Vehicle Speed Sensor (VCU) - Speed signal not plausible

There is currently no troubleshooting Help for PID 84 14.


TShootMBEuntitled00000515

 Adaptive Cruise Control (VCU) - Special Instructions

There is currently no troubleshooting Help for PID 86 14.


TShootMBEuntitled00000516

 Fuel Pressure (PLD) - Sensor data over MAX

There is currently no troubleshooting Help for PID 94 00.


TShootMBEuntitled00000517

 Fuel Pressure (PLD) - Sensor data under MIN

There is currently no troubleshooting Help for PID 94 01.


TShootMBEuntitled00000518

 Fuel Pressure (PLD) - Sensor data incorrect

There is currently no troubleshooting Help for PID 94 02.


TShootMBEuntitled00000519

 Fuel Pressure (PLD) - Open circuit

There is currently no troubleshooting Help for PID 94 03.


TShootMBEuntitled00000520

 Fuel Pressure (PLD) - Shorted to ground

There is currently no troubleshooting Help for PID 94 04.


TShootMBEuntitled00000521

 Fuel Pressure (PLD) - Measured data incorrect

There is currently no troubleshooting Help for PID 94 14.


TShootMBEuntitled00000522

 Maintenance Alarm System (VCU) - Data valid but above normal

There is currently no troubleshooting Help for PID 95 00.


TShootMBEuntitled00000523

 Maintenance Alarm System (VCU) - Voltage above normal or shorted high

There is currently no troubleshooting Help for PID 95 03.


TShootMBEuntitled00000524

 Maintenance Alarm System (VCU) - Volgage below normal or shorted low

There is currently no troubleshooting Help for PID 95 04.


TShootMBEuntitled00000525

 Engine Oil Level - Data valid but above normal (VCU)

There is currently no troubleshooting Help for PID 98 00.


TShootMBEuntitled00000526

 Engine Oil Level - Data valid but below normal (VCU)

There is currently no troubleshooting Help for PID 98 01.


TShootMBEuntitled00000527

 Engine Oil Level - Oil level to high or to low (PLD)

There is currently no troubleshooting Help for PID 98 02.


TShootMBEuntitled00000528

 Engine Oil Level - oil level sensor MIN (PLD)

There is currently no troubleshooting Help for PID 98 03.


TShootMBEuntitled00000529

 Engine Oil Level - Oil level sensor MAX (PLD)

There is currently no troubleshooting Help for PID 98 04.


TShootMBEuntitled00000530

 Engine Oil Level - Open circuit (PLD)

There is currently no troubleshooting Help for PID 98 05.


TShootMBEuntitled00000531

 Engine Oil Level - Data valid but very low (VCU)

There is currently no troubleshooting Help for PID 98 14.


TShootMBEuntitled00000532

 Injector Cylinder #1 (PLD) - Shorted to high

There is currently no troubleshooting Help for SID 1 03.


TShootMBEuntitled00000533

 Injector Cylinder #1 (PLD) - Shorted to ground

There is currently no troubleshooting Help for SID 1 04.


TShootMBEuntitled00000534

 Injector Cylinder #7 (PLD) - current below normal or open circuit

There is currently no troubleshooting Help for SID 7 05.


TShootMBEuntitled00000535

 Injector Cylinder #7 (PLD) - shorted circuit

There is currently no troubleshooting Help for SID 7 06.


TShootMBEuntitled00000536

 Injector Cylinder #7 (PLD) - no plunger

There is currently no troubleshooting Help for SID 7 07.


TShootMBEuntitled00000537

 Injector Cylinder #7 (PLD) - idle smoothness governor at limit

There is currently no troubleshooting Help for SID 7 12.


TShootMBEuntitled00000538

 Injector Cylinder #7 (PLD) - single cylinder correction at limit

There is currently no troubleshooting Help for SID 7 14.


TShootMBEuntitled00000539

 Injector Cylinder #8 (PLD) - Current below normal or open circuit

There is currently no troubleshooting Help for SID 8 05.


TShootMBEuntitled00000540

 Injector Cylinder #8 (PLD) - Shorted circuit

There is currently no troubleshooting Help for SID 8 06.


TShootMBEuntitled00000541

 Injector Cylinder #8 (PLD) - No plunger

There is currently no troubleshooting Help for SID 8 07.


TShootMBEuntitled00000542

 Injector Cylinder #8 (PLD) - Idle smoothness governor at limit

There is currently no troubleshooting Help for SID 8 12.


TShootMBEuntitled00000543

 Injector Cylinder #8 (PLD) - Single cylinder correction at limit

There is currently no troubleshooting Help for SID 8 14.


TShootMBEuntitled00000544

 Remote Throttle Pedal Supply - Out of range

There is currently no troubleshooting Help for SID 29 02.


TShootMBEuntitled00000545

 Remote Throttle Pedal Supply - Open load

There is currently no troubleshooting Help for SID 29 03.


TShootMBEuntitled00000546

 Remote Throttle Pedal Supply - Shorted to ground

There is currently no troubleshooting Help for SID 29 04.


TShootMBEuntitled00000547

 Grid Heater - No increasing boost temperature after activation (VCU)

There is currently no troubleshooting Help for SID 38 00.


TShootMBEuntitled00000548

 Grid Heater - Grid Heater relay permanently closed (VCU)

There is currently no troubleshooting Help for SID 38 01.


TShootMBEuntitled00000549

 Grid Heater - Grid Heater relay permanently open (VCU)

There is currently no troubleshooting Help for SID 38 02.


TShootMBEuntitled00000550

 Grid Heater - Open circuit (VCU)

There is currently no troubleshooting Help for SID 38 03.


TShootMBEuntitled00000551

 Grid Heater - Shorted to ground (VCU)

There is currently no troubleshooting Help for SID 38 04.


TShootMBEuntitled00000552

 Engine Starter Motor Relay or OI Alarm - Shorted to high source (PLD)

There is currently no troubleshooting Help for SID 39 03.


TShootMBEuntitled00000553

 Engine Starter Motor Relay or OI Alarm - Open circuit (PLD)

There is currently no troubleshooting Help for SID 39 05.


TShootMBEuntitled00000554

 Engine Starter Motor Relay or OI Alarm - Shorted to ground (PLD)

There is currently no troubleshooting Help for SID 39 06.


TShootMBEuntitled00000555

 Engine Starter Motor Relay or OI Alarm - Starter does not engage (PLD)

There is currently no troubleshooting Help for SID 39 07.


TShootMBEuntitled00000556

 Engine Starter Motor Relay or OI Alarm - Relay jammed (PLD)

There is currently no troubleshooting Help for SID 39 14.


TShootMBEuntitled00000557

 Gear output 1 (VCU) - open circuit

There is currently no troubleshooting Help for SID 43 03.


TShootMBEuntitled00000558

 Gear output 1 (VCU) - shorted to ground

There is currently no troubleshooting Help for SID 43 04.


TShootMBEuntitled00000559

 Gear output 2 (VCU) - open circuit

There is currently no troubleshooting Help for SID 44 03.


TShootMBEuntitled00000560

 Gear output 2 (VCU) - shorted to ground

There is currently no troubleshooting Help for SID 44 04.


TShootMBEuntitled00000561

 Auxiliary PWM Driver #5 - Shorted High (PLD)

There is currently no troubleshooting Help for SID 53 03.


TShootMBEuntitled00000562

 Auxiliary PWM Driver #5 - Shorted to ground (PLD)

There is currently no troubleshooting Help for SID 53 04.


TShootMBEuntitled00000563

 Auxiliary PWM Driver #5 - Bank 2 shorted (PLD)

There is currently no troubleshooting Help for SID 53 11.


TShootMBEuntitled00000564

 Auxiliary PWM Driver #6 - Open circuit (PLD)

There is currently no troubleshooting Help for SID 54 03.


TShootMBEuntitled00000565

 Accessory bus shutdown (VCU) - short to battery

There is currently no troubleshooting Help for SID 56 03.


TShootMBEuntitled00000566

 Accessory bus shutdown (VCU) - open circuit or shorted to ground

There is currently no troubleshooting Help for SID 56 04.


TShootMBEuntitled00000567

 Auxiliary PWM Driver #1 (Exhaust Flap or Variable Geometry Turbocharger) PLD - Shorted High (PLD)

There is currently no troubleshooting Help for SID 57 03.


TShootMBEuntitled00000568

 Auxiliary PWM Driver #1 (Exhaust Flap or Variable Geometry Turbocharger) PLD - Shorted to ground (PLD)

There is currently no troubleshooting Help for SID 57 04.


TShootMBEuntitled00000569

 Auxiliary PWM Driver #3 (Dual Sp. Fan Low Stage or Single Sp. Fan) PLD - Shorted High (PLD)

There is currently no troubleshooting Help for SID 59 03.


TShootMBEuntitled00000570

 Auxiliary PWM Driver #4 (Dual Sp. Fan High Stage or Single Sp. Fan) PLD - Shorted High (PLD)

There is currently no troubleshooting Help for SID 60 03.


TShootMBEuntitled00000571

 Flamestart Valve - Open circuit

There is currently no troubleshooting Help for SID 71 05.


TShootMBEuntitled00000572

 Flamestart Valve - Shorted to ground

There is currently no troubleshooting Help for SID 71 06.


TShootMBEuntitled00000573

 Optimized Idle (VCU) - Mechanical system not responding properly

There is currently no troubleshooting Help for SID 123 07.


TShootMBEuntitled00000574

 Oil separator - Diagnosis Shorted to Ground

There is currently no troubleshooting Help for SID 151 04.


TShootMBEuntitled00000575

 Oil separator - Oil separator defect

There is currently no troubleshooting Help for SID 151 12.


TShootMBEuntitled00000576

 Fan Speed - Time out (PLD)

There is currently no troubleshooting Help for SID 159 00.


TShootMBEuntitled00000577

 Adaptive Cruise Control (VCU) - Special Instructions

There is currently no troubleshooting Help for SID 216 14.


TShootMBEuntitled00000578

 Idle Validation Switch - Wiring idle validation switch GAS1 and GAS2 twisted or open circuit at potentiometer ground

There is currently no troubleshooting Help for SID 230 01.


TShootMBEuntitled00000579

 J1939 Data Link - J1939 message was received at least one time and is now missing

There is currently no troubleshooting Help for SID 231 02.


TShootMBEuntitled00000580

 Throttle Pedal Supply (VCU) - data erratic

There is currently no troubleshooting Help for SID 232 02.


TShootMBEuntitled00000581

 PLD - Bad Device - No additional key can be learned

There is currently no troubleshooting Help for SID 233 00.


TShootMBEuntitled00000582

 PLD - Bad Device - Wrong key or no transponder code on proprietary D

There is currently no troubleshooting Help for SID 233 02.


TShootMBEuntitled00000583

 PLD - Bad Device - No transponder code on hardwire

There is currently no troubleshooting Help for SID 233 09.


TShootMBEuntitled00000584

 PLD - Bad Device - Calibration error

There is currently no troubleshooting Help for SID 233 11.


TShootMBEuntitled00000585

 Engine Brake Calibration (PLD) - Engine brake calibration parameters are not sensible

There is currently no troubleshooting Help for SID 253 09.


TShootMBEuntitled00000587

 Required Action

Perform the following steps to resolve PID 84 fault code - 439S+ Open Circuit.

  1. Repair and replace open circuit in VSS wire 439S+.

  2. Erase the fault code memory.


 VARIABLE-SPEED FAN (FAN TYPE 5)

See Variable-Speed Fan on an MBE 4000 Engine for an MBE 4000 engine or Variable-Speed Fan on an MBE 900 Engine for an MBE 900 engine of the schematic showing a variable-speed fan (fan type 5) installation.

Next topic

PARKING BRAKE SWITCH

Previous topic

TWO-SPEED FAN (FAN TYPE 0 OR 1) - MBE 4000 ENGINE


 Variable-Speed Fan on an MBE 900 Engine


 Variable-Speed Fan on an MBE 4000 Engine


 VEHICLE CONTROL UNIT - ON-HIGHWAY

The DDEC-VCU is the interface between the PLD-MR and the truck for engine control and manages other vehicle functions (see The Vehicle Control Unit).

The DDEC-VCU also communicates over the J1587 and J1939 Data Links to the vehicle (see NAFTA Architecture).

Within the DDEC-VCU, sets of data for specific applications are stored. These include idle speed, maximum running speed, and speed limitation.

The DDEC-VCU receives data from the operator (accelerator pedal position, switches, various sensors) and other electronic control units (for example, the anti-lock brake system, transmission controllers).

From this data, instructions are computed for controlling the engine and transmitted to the PLD-MR via the proprietary data link.

Next topic

Vehicle Interface Harness Design

Previous topic

Connectors


 Vehicle Interface Harness Design

The OEM supplied Vehicle Interface harness (VIH) connects the DDEC-VCU to the PLD-MR and other vehicle systems (see Typical On-Highway Vehicle Interface Harness with a DDEC-VCU).

Next topic

Digital Inputs

Previous topic

VEHICLE CONTROL UNIT - ON-HIGHWAY


 Vehicle Interface Harness Wiring

The wiring for the VIH 15-pin connector to the DDEC-VCU is listed in DDEC-VCU 15-Pin VIH Connector Pin Assignments. The side of the connector shown is looking into the pins.

The wiring for the VIH 18-pin connector to the DDEC-VCU is listed in DDEC-VCU 18-Pin VIH Connector Pin Assignments. The side of the connector shown is looking into the pins.

The wiring for the VIH 21-pin connector for the DDEC-VCU is listed in DDEC-VCU 21-Pin VIH Connector Pin Assignments. The power and communication links are wired through this connector. The side of the connector shown is looking into the pins.

Next topic

VIH to PLD-MR Connector Wiring

Previous topic

Ignition


 VEHICLE POWER SHUTDOWN - OPTIONAL

Vehicle Power Shutdown is used with Idle Timer Shutdown or Engine Protection Shutdown. After the idle timer times out or engine protection shuts the engine down, the Vehicle Power Shutdown relay shuts down the rest of the electrical power to the vehicle.

A Vehicle Power Shutdown relay can be installed to shutdown all electrical loads when the engine is shutdown (See Vehicle Power Shutdown Relay). The engine will shutdown after the specified idle time and will reset the relay (ignition circuit).

Next topic

STARTER LOCKOUT

Previous topic

PARKING BRAKE SWITCH


 Vehicle Power Shutdown Relay


 Vehicle Speed Sensor

The DDEC-VCU can calculate vehicle speed, providing that it is properly programmed and interfaced with a Vehicle Speed Sensor (VSS) that meets MBE requirements. The VSS (see Vehicle Speed Sensor) provides a vehicle speed signal for use in Cruise Control and Vehicle Speed Limiting. The VSS signal type can be changed with the VEPS, or minidiag2.

NOTE: DDC does not approve of the use of signal generator sensors.

Next topic

Magnetic Pickup - Vehicle Speed Sensor Settings

Previous topic

Engine Coolant Level Sensor


Vehicle Speed Sensor Figure

 Vehicle Speed Sensor


Vehicle Speed Sensor Parameters (Table 2)

 Vehicle Speed Sensor Parameters

Parameter
         Range
         Default
         Parameter ID
VSS Input Configuration
         3 = Transmission output shaft speed on the SAE J1939 Data Link*
         0 = No VSS
  1. 13 08
Axle Ratio
  1. - 20.0
5.29
  1. 13 09
Tire Revs/Kilometer
         160 - 1599
         312
  1. 13 11
Top Gear Ratio
         0.1 - 2.55

  1. 13 12
Two Speed Axle - Second Axle Ratio
  1. - 20.0
5.29
  1. 13 13
  • Range must be set to 3.


 Vehicle Speed Sensor Parameters (Magnetic Pickup)

Parameter
         Range
         Default
         Parameter ID
VSS Input Configuration
  1. = Magnetic Pickup*
0 = No VSS
  1. 13 08
Axle Ratio
  1. - 20.0
5.29
  1. 13 09
Number of Output Shaft Teeth
         0 - 250
         16
  1. 13 10
Tire Revs/Kilometer
         160 - 1599
         312
  1. 13 11
Top Gear Ratio
         0.1 - 2.55

  1. 13 12
Two Speed Axle - Second Axle Ratio
  1. - 20.0
5.29
  1. 13 13
  • Range must be set to 1.


Vehicle Speed Sensor Wiring Figure

 Vehicle Speed Sensor Wiring


Vehicle Speed Sensor Wiring Table

 Vehicle Speed Sensor Wiring

Connector/Pin | Function
15/3 | VSS (+)
15/4 | VSS (-)


 Vibration

The vibration load for the PLD-MR is maximum 3 g at 10 Hz - 1000 Hz with damping elements.

Next topic

Water Intrusion

Previous topic

Temperature


 VIH Power Wiring

The OEM-supplied VIH power wiring (see Power Wiring) supplies 12 volts to the DDEC-VCU and PLD-MR. The system must be sourced directly from the battery. The terminals are designed to accept 14 AWG standard wall wire.

Power must be sourced directly from the battery. An electrically solid connection to the battery or bus bar is required so the battery can filter electrical noise from the power lines. Power for other vehicle systems must not be sourced from the VIH power wires. Do not use chassis ground.

NOTE: The ground wire must be electrically separate from chassis ground.

Power and ground bus bars may be used. The bus bar must be connected to the battery posts with 0 AWG or larger wire depending upon the total vehicle current requirement. The connecting wires must be as short as possible to minimize circuit resistance. Do not connect the ground wire to the chassis ground.

Next topic

Communications - SAE J1939 Data Link

Previous topic

VIH to Engine Harness Connector Wiring


VIH Power Wiring_1

 VIH Power Wiring

The OEM-supplied VIH power wiring (see Power Wiring) supplies 12 volts to the DDEC-VCU and PLD-MR. The terminals are designed to accept 14 AWG standard wire size.

See also:

Power Supply

DESCRIPTION OF PID 168 - BATTERY VOLTAGE OUTSIDE NORMAL OPERATING RANGE

TROUBLESHOOTING PID 168


 VIH to Engine Harness Connector Wiring

The wiring for the 8-pin connector to the Engine Harness required for engine brakes and fan control for the MBE 4000 is listed in Engine Harness Connector for Engines with Two Solenoid Air Valves for Engine Brakes - MBE 4000 Only.

See MBE 4000 Non-EGR Engine Brake for an engine brake schematic.

The wiring for the 8-pin connector to the Engine Harness required for Engine Brakes and Fan Control for the Non-EGR MBE 900 is listed in Engine Harness Connector for MBE 900 Non-EGR Engine. See MBE 900 Non-EGR VIH to Engine Harness Wiring for a schematic.

The wiring for the 8-pin connector to the Engine Harness required for engine brakes and fan control for the MBE 900 EGR engine is listed in Engine Harness Connector for MBE 900 EGR Engine. See Engine Harness Connector for MBE 900 EGR Engine for a schematic.

Next topic

VIH Power Wiring

Previous topic

VIH to PLD-MR Connector Wiring


 VIH to PLD-MR Connector Wiring

The wiring for the VIH 16-pin to the PLD-MR is listed in 16-Pin Connector to the PLD-MR. The side of the connector shown is looking into the pins.

Next topic

VIH to Engine Harness Connector Wiring

Previous topic

Vehicle Interface Harness Wiring


 Water Intrusion

The PLD-MR can be exposed to steam cleaning and pressure washing. Care should be taken not to pressure spray the connectors.

Next topic

Engine Sensor Harness

Previous topic

Vibration


 Welding

Wear welding goggles and gloves when welding or using an acetylene torch. Ensure that a metal shield separates the acetylene and oxygen tanks. These must be securely chained to a cart.

PERSONAL INJURY
To avoid injury from arc welding, gas welding, or cutting, wear required safety equipment such as an arc welder's face plate or gas welder's goggles, welding gloves, protective apron, long sleeve shirt, head protection, and safety shoes. Always perform welding or cutting operations in a well ventilated area. The gas in oxygen/acetylene cylinders used in gas welding and cutting is under high pressure. If a cylinder should fall due to careless handling, the gage end could strike an obstruction and fracture, resulting in a gas leak leading to fire or an explosion. If a cylinder should fall resulting in the gage end breaking off, the sudden release of cylinder pressure will turn the cylinder into a dangerous projectile. Observe the following precautions when using oxygen/acetylene gas cylinders:
Always wear required safety shoes.
Do not handle tanks in a careless manner or with greasy gloves or slippery hands.
Use a chain, bracket, or other restraining device at all times to prevent gas cylinders from falling.
Do not place gas cylinders on their sides, but stand them upright when in use.
Do not drop, drag, roll, or strike a cylinder forcefully.
Always close valves completely when finished welding or cutting.

FIRE
To avoid injury from fire, check for fuel or oil leaks before welding or carrying an open flame near the engine.

Next topic

Pressurized Fluids

Previous topic

Glasses


 WIRES AND WIRING

Detroit Diesel Corporation recommends color coding and hot stamping wire numbers in contrasting colors at intervals of 100 mm (4 in.) or less.

Next topic

General Requirements

Previous topic

SAE J1708/J1587 Data Link 6-Pin Connector


 Wiring for 6-Pin Data Link Connector


 Wiring for 9-Pin Data Link Connector


 Wiring the Grid Heater

The output (pin 7 of the 21-pin connector) activates the grid heater control lamp. The output (pin 10 of the 15-pin connector) activates the load relay for the grid heater. The digital input (pin 10 of the 12-pin connector) can be used for monitoring the load contacts of the load relay. If the output is shut off, the relay is switched to the supply voltage or to ground. See DDEC-VCU Grid Heater Wiring.

See also

DDEC-VCU

Grid Heater

DESCRIPTION OF PID 45 - COLD START (GRID HEATER) FAULT

TROUBLESHOOTING PID 45


 Working on a Running Engine

When working on an engine that is running, accidental contact with the hot exhaust manifold can cause severe burns. Remain alert to the location of the rotating fan, pulleys and belts. Avoid making contact across the two terminals of a battery which can result in severe arcing, or battery explosion.

PERSONAL INJURY
To avoid injury from rotating belts and fans, do not remove and discard safety guards.

PERSONAL INJURY
To avoid injury when working near or on an operating engine, remove loose items of clothing and jewelry. Tie back or contain long hair that could be caught in any moving part causing injury.

Next topic

Optimized Idle

Previous topic

Cleaning Agent