Contents

 ABSTRACT, INTRODUCTION AND CONTENTS

ABSTRACT

This Help system provides instruction for troubleshooting the Detroit Diesel Electronic Controlled (DDEC®) engines, with one (single) ECU.

Specifically covered in this Help are troubleshooting and repair steps that apply to the DDEC V.

INTRODUCTION

Detroit Diesel Corporation is the world leader in diesel engine electronics. DDC has made technological leaps in engine performance and fuel economy. Today, we build the most dependable electronically controlled diesel engine in the industry.

Our goal at Detroit Diesel is to be the most customer focused and most responsive engine manufacturer in the world.

See also

TROUBLESHOOTING INFORMATION

SAFETY PRECAUTIONS

CONTENTS

Click on the topic icons in the list below to jump to the main sections in this Help system.

CALIFORNIA PROPOSITION 65 WARNING

ENGINE EXHAUST

ECU REPLACEMENT WARNING

SOFTWARE UPGRADES

SAFETY INSTRUCTIONS

REVISION NOTIFICATION

SAFETY PRECAUTIONS

OPERATION

ECU AND SENSOR LOCATIONS

BASIC KNOWLEDGE REQUIRED

FLASH CODES VS SAE CODES

TESTING / SERVICE TOOLS / TIPS

TOOLS

CONNECTORS, TERMINALS, AND SPLICING

DDEC ECU SOFTWARE FEATURES

DIAGNOSING A DDEC SYSTEM FAULT

INTERMITTENT FAULT

FLASH CODE 11 - VSG VOLTAGE LOW

FLASH CODE 12 - VSG HIGH

FLASH CODE 13 - ECL VOLTAGE LOW

FLASH CODE 14 - TEMP SENSOR HIGH

FLASH CODE 15 - TEMP SENSOR LOW

FLASH CODE 16 - ECL VOLTAGE HIGH

FLASH CODE 17 - THROTTLE VALVE HIGH: RELATIVE HUMIDITY SENSOR HIGH

FLASH CODE 18 - THROTTLE VALVE LOW; RELATIVE HUMIDITY SENSOR LOW

FLASH CODE 19

FLASH CODE 20

FLASH CODE 21 - TPS HIGH

FLASH CODE 22 - TPS LOW

FLASH CODE 23 - FUEL TEMP SENSOR HIGH

FLASH CODE 24 - FUEL TEMP SENSOR LOW

FLASH CODE 25

FLASH CODE 26 - AUXILIARY SHUTDOWN ACTIVE

FLASH CODE 27 - AIR TEMP SENSOR HIGH

FLASH CODE 28 - AIR TEMP SENSOR LOW

FLASH CODE 29 - TCI / TCO TEMPERATURE LOW

FLASH CODE 30

FLASH CODE 31 - ENGINE BRAKE FAULT CODE

FLASH CODE 32 - AWL / RSL FAULT

FLASH CODE 33 - TBS HIGH

FLASH CODE 34 - TBS LOW

FLASH CODE 35 - OPS HIGH

FLASH CODE 36 - OPS LOW

FLASH CODE 37 - FRS VOLTAGE HIGH

FLASH CODE 38 - FRS VOLTAGE LOW

FLASH CODE 39 - EGR VALVE / VNT VANE FAULT

FLASH CODE 40

FLASH CODE 41 - TOO MANY SRS

FLASH CODE 42 - TOO FEW SRS

FLASH CODE 43 - COOLANT LEVEL LOW

FLASH CODE 44 - TEMP HIGH

FLASH CODE 45 - OIL PRESSURE LOW

FLASH CODE 46 - BATTERY VOLTAGE LOW

FLASH CODE 47 - AIR / FUEL PRESSURE HIGH

FLASH CODE 48 - AIR / FUEL / EGR PRESSURE LOW OR EGR / TCI / TCO TEMPERATURE LOW

FLASH CODE 49 - TCO OR TCI TEMPERATURE HIGH

FLASH CODE 50

FLASH CODE 51 - TCO OR TCI TEMPERATURE CIRCUIT FAILED HIGH

FLASH CODE 52 - ECU FAULT

FLASH CODE 53 - ECU MEMORY FAULT

FLASH CODE 54 - VSS FAULT

FLASH CODE 55 - J1939 DATA LINK FAULT

FLASH CODE 56 - J1587 DATA LINK FAULT

FLASH CODE 57

FLASH CODE 58 - CRUISE CONTROL INPUT FAULT

FLASH CODE 59

FLASH CODE 60

FLASH CODE 61 - INJECTOR RESPONSE LONG

FLASH CODE 62 - OUTPUT FAULT

FLASH CODE 63 - PWM FAULT

FLASH CODE 64

FLASH CODE 65 - AIR FILTER RESTRICTION INPUT VOLTAGE LOW

FLASH CODE 66

FLASH CODE 67

FLASH CODE 68 - IDLE VALIDATION FAULT

FLASH CODE 69

FLASH CODE 70

FLASH CODE 71 - INJECTOR RESPONSE SHORT

FLASH CODE 72 - VEHICLE OVERSPEED

FLASH CODE 73 - AIR FILTER RESTRICTION HIGH

FLASH CODE 74 - OI SAFETY LOOP

FLASH CODE 75 - BATTERY VOLT HIGH

FLASH CODE 76 - ENGINE OVERSPEED / BRAKE

FLASH CODE 77 - EXHAUST BACK PRESSURE FAULT AND SEVERAL INFORMATION CODES

FLASH CODE 78 - CRUISE CONTROL / ADAPTIVE CRUISE CONTROL

FLASH CODE 79

FLASH CODE 80

FLASH CODE 81 - OIL LEVEL OR EXHAUST TEMP CIRCUIT FAILED HIGH

FLASH CODE 82 OIL LEVEL OR EXHAUST TEMP CIRCUIT FAILED LOW

FLASH CODE 83 EGR TEMP, EGR DELTA-PRESSURE, EXHAUST TEMP, OR EXTERNAL PUMP PRESSURE HIGH

FLASH CODE 84

FLASH CODE 85 - ENGINE OVERSPEED

FLASH CODE 86 - PGS SENSOR HIGH

FLASH CODE 87 - PGS SENSOR LOW

FLASH CODE 88

FLASH CODE 89

ENGINE SENSOR HARNESS

VEHICLE HARNESS

ENGINE WIRING SCHEMATICS

VEHICLE WIRING SCHEMATICS

DDEC PRO-LINK OPERATION

Figures

Next topic


 68 Pin Connector Wires and Terminals


 Accelerator Pedal Sensor

The Accelerator Pedal contains the AP Sensor which converts the operator's hand throttle and/or foot pedal input into a signal for the ECU.

Next topic

AIR FILTER RESTRICTION SENSOR

Previous topic


 Active Codes

Active codes are conditions that are presently occurring and causing the AWL to be illuminated.

All current active codes will be displayed for the entire system, including single, dual and triple ECU applications. The display for each code is as follows:

Line 1: ## MID: XXX XXXXXXXX

Line 2: PID Description

Line 3: FMI Description

Line 4: A## PID: XXX FMI: XX

Explanation:

##: Indicates the DDC diagnostic flash code number

MID: Message Identification Character

PID: Parameter Identification Character

FMI: Failure Mode Identifier

A##: Numerical count of active codes

Indicates additional codes are stored in ECU memory

Next topic

INACTIVE CODES

Previous topic


 Add Coolant Level Sensor Installation

See MAS Pigtail for MAS pigtail.


 Air Compressor Governor System

The air compressor governor system can be set on the mainframe only. This system is similar to the pressure governor system, but for air compressor applications. 6N4C change adjusts the engine speed to compensate for air pressure loads. ECU Software 4.01 is required.

Next topic

CRUISE CONTROL

Previous topic


 Air Filter Restriction Sensor

The Air Filter Restriction sensor, AFR, has two indicator points, the first indicates the air filter has approximately 50% life left, the second indicates that the filter is plugged. This sensor is only used with the Maintenance Alert System. See Air Filter Restriction Sensor.

The AFR sensor is mounted downstream of the air filter and upstream of the turbocharger. The AFR sensor must be in a straight section of pipe or where the OEM mechanical unit is normally mounted. This sensor must be enabled with the Vehicle Electronic Programming System (VEPS) or the DDEC Reprogramming System (DRS).

Next topic

ENGINE COOLANT LEVEL SENSOR

Previous topic


Air Filter Restriction Sensor_1

 Air Filter Restriction Sensor


 Air Filter Restriction Sensor Wiring Diagram


 Air Temperature Sensor


Air Temperature Sensor_1

 Air Temperature Sensor


 AMBER WARNING LAMP AND RED STOP LAMP FAULT

The following steps will troubleshoot a fault with the AWL or RSL. These lights are used to alert the operator of engine faults; flash any trouble codes stored in the ECU; and illuminate for five seconds and then go out during a start sequence, as a bulb check.

Determine Fault

Perform the following to determine fault:

  1. If the AWL or RSL is always on, refer to Display ECU Light Status.

  2. If the AWL or RSL never lights, refer to Activate Light With Diagnostic Data Reader.


 Attempt to Make Codes Active

Perform the following steps to read the active codes.

  1. Start and run the engine for eight minutes. Warm the engine. Coolant/oil temperature must be greater than 140°F (60°C).

  2. If required, perform road test with an assistant.

[a] If AWL or RSL illuminate, read codes and refer to the section number that matches the flash code number logged .

[b] If AWL or RSL do not illuminate and no codes log, return to service.

[c] If AWL or RSL do not illuminate but symptom occurs, refer to INTERMITTENT CODE OR A SYMPTOM AND NO CODES, and Diagnosis by Symptom.


 Barometric Pressure Sensor

The Barometric Pressure sensor senses barometric pressure for EGR control. See Barometric Pressure Sensor - Series 60.

Next topic

CAMSHAFT AND CRANKSHAFT POSITION SENSORS

Previous topic


 Barometric Pressure Sensor - Series 60 Engine


 BASIC KNOWLEDGE REQUIRED

See

BASIC KNOWLEDGE REQUIRED

DDEC DIAGNOSTIC CODES

GENERAL DIAGNOSTIC INFORMATION

READING CODES WITH DIAGNOSTIC DATA READER

ELECTRICAL CIRCUITS

USE OF DIGITAL VOLT-OHM METER

SERVICING DDEC CONNECTORS

IMPORTANT INFORMATION

EXPLANATION OF ABBREVIATIONS AND TERMS

Next topic

DDEC DIAGNOSTIC CODES

Previous topic


 BASICS

The following listed items should be checked prior to starting any troubleshooting:

Ensure engine serial number on the ECU matches the serial number on the cylinder block.

Walk around the vehicle. Look for obvious problems such as leaks (air or liquid).

Inspect ECU for worn isolators, debris or bolts lodged between ECU and cylinder block.

Broken wiring connectors.

Fuel Supply - Full on.

Fuel tank level.

Vehicle damage.

Investigate any prior repairs, if applicable.

Check for poor mating of the connector halves or terminals not fully seated in the connector body (backed out terminals).

Look for improperly formed or damaged terminals. All connector terminals in the problem circuit should be carefully inspected to determine proper contact tension. Use a mating terminal to test the contact tension.

Electrical system interference caused by a defective relay, ECU driven solenoid, or a switch causing an electrical surge. Look for problems with the charging system (alternator, etc.). In certain cases, the problem can be made to occur when the faulty component is operated as in the case of a relay.

Verify alternator grounds are clean and making good contact. Disconnect the alternator belt to test.

Wiggle wires and harnesses to try to make the problem active, or re-occur.

Next topic

ECU PROGRAMMING

Previous topic


 Batteries

Electrical storage batteries emit highly flammable hydrogen gas when charging and continue to do so for some time after receiving a steady charge.

To avoid injury from battery explosion or contact with battery acid, work in a well-ventilated area, wear protective clothing, and avoid sparks or flames near the battery. Always establish correct polarity before connecting cables to the battery or battery circuit. If you come in contact with battery acid:
Flush your skin with water.
Apply baking soda or lime to help neutralize the acid.
Flush your eyes with water.
Get medical attention immediately.
Always disconnect the battery cable before working on the electrical system.

To avoid injury from accidental engine startup while servicing the engine, disconnect/disable the starting system.

Next topic

FIRE

Previous topic


 Bottom View of Shroud, ECU Connector and Conduit


 Calibration

You can use the DDDL to:

Read and display the current calibration from an ECU.

Create a calibration for the ECU on an individual engine.

Save a single calibration with an ECU password so that the same calibration can be used conveniently for a fleet of vehicles with the same password, or can be used by a technician who does not have access to the password.

Change the engine rating of a vehicle.

Set the injector calibration when you replace the injectors.

View an audit trail of ECU and injector calibration changes.

Next topic

DDEC REPROGRAMMING SYSTEM

Previous topic


 Calibration Functions

The following calibration functions can be performed with DDDL.

Retrieve and display the current calibration from an ECU.

Save a calibration for the ECU in an individual truck.

Save a single calibration with an ECU password, so that the same calibration can be used conveniently for a fleet of trucks with the same password, or can be used by a technician who has no access to the password.

Change the engine rating of a truck.

Set the fuel injector calibration when you replace the fuel injectors.

Set the ECU clock automatically using the PC's internal clock.

View an audit trail of an ECU, fuel injector calibration, ECU clock changes, and Vehicle Speed setting changes.

All operations that change the engine calibration are password protected, with more potentially damaging operations requiring higher levels of password authority.

Next topic

DIAGNOSTIC AND MAINTENANCE FUNCTIONS

Previous topic


 CALIFORNIA PROPOSITION 65 WARNING

Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.

Next topic

ENGINE EXHAUST

Previous topic


 Camshaft and Crankshaft Position Sensors

The Camshaft Position sensor, CMP, is a variable reluctance type sensor that indicates crank position of every cylinder. The CMP Sensor tells the ECU where the rotation of the engine is or when to fuel each cylinder. The Crankshaft Position sensor, CKP, indicates a specific cylinder in the firing order.

See CMP Sensor and CKP Sensor - Series 60 Engine for the Series 60 engine CKP Sensor and CMP Sensor.

See CMP Sensor and CKP Sensor - Series 50 Engine for the Series 50 engine CKP Sensor and CMP Sensor.

Next topic

ENGINE COOLANT TEMPERATURE SENSOR

Previous topic


 Changing Passwords Using the Diagnostic Data Reader

DDR software level must be 2.00 or higher.

  1. In the event a customer loses or forgets his/her password, contact a Detroit Diesel Regional Office, or the Detroit Diesel Technical Service Department with the engine serial number. These contacts can provide an alternate (backdoor) password. You should also ensure that there is not any "maximum" or "rating" security enabled on the mainframe for that unit.

  2. Using the DDR select the Password Change option in the area that you need to change. Password changing for Customer Password can be found in the "ENGINE" section, under "Calibration Change". Changing the password for engine rating and function lockout is found under their respective headings under the "Reprogram Cal" menu. Changing the injector password is found in the "ENGINE" section, under "Fuel Injector Information".

  3. Enter the alternate password as the current password. The alternate password is a six character alpha numeric code. Enter alpha characters with the DDR by using the up or down arrow keys, that scroll you through the alphabet. Use the side arrow keys to move the cursor to the next position, or to back up to correct an entry.

  4. Once all six positions are filled press the enter key.

  5. Enter the new password you wish to enter (maximum four positions). Press enter.

  6. Depending on the area you are changing, you will get a message that the password is successfully changed, or prompt you to confirm that this is what you really want to do.

  7. Turn the ignition off, unplug the DDR.

Next topic

PRESSURE GOVERNOR SYSTEM (FIRE TRUCK)

Previous topic


Check Delta P Sensor (code 411/0)

 Check Delta P Sensor

This same procedure may be found in the Series 60 EGR Technician's Guide (7SE60) as part of Test C.

Check the Delta P Sensor as follows:

  1. Remove the Delta P Sensor from the mounting plate.

EYE INJURY
To avoid injury from flying debris when using compressed air, wear adequate eye protection (face shield or safety goggles) and do not exceed 276 kPa (40 psi) air pressure.
  2. Blow down through the sensor tubes (by way of the holes in the mounting plate) using an airline.

  3. Gently shake the sensor to remove any moisture before reinstalling the sensor. Moisture in the sensor does not cause permanent damage.

  4. Turn the ignition ON (key ON, engine OFF).

  5. Connect either Detroit Diesel Diagnostic Link (DDDL) or the Diagnostic Data Reader (DDR).

  6. Read the Delta P counts.

a. If the Delta P counts read 86–118, verify that the Venturi Tube hoses-to-Delta P Sensor are correctly installed and are not damaged. Also visually inspect the delivery pipe for damage and proper assembly. Repair as necessary, and verify repairs.

NOTE: Reversed and damaged hoses will have an adverse effect on engine performance resulting in black exhaust smoke and engine surging.

b. If the Delta P counts are out of the 86–118 range, replace the sensor. Verify repairs.


 Check EGR Thermocouple Resistance

Check the EGR Temperature Sensor as follows:

  1. Bridge sensor pins 1 and 2.

  2. Check the EGR Temperature Sensor with an ohm-meter at one of the temperatures listed below:

Temperature | Ohms
100°C (212°F) | 14370 to 1190 ohms
0°C (32°F) | 657 to 1003 ohms

a. If the ohms are the same as those in the table, the EGR Temperature Sensor is good. Replace the EGR cooler. Verify repairs.

b. If the ohms are not the same, replace the sensor and verify repairs.


 Check for EGR valve stuck open or partly open (PID 411/FMI 0)

This same procedure may be found in the Series 60 EGR Technician's Guide (7SE60) as Test A.

Check for a stuck EGR valve as follows:

  1. Remove the turbocharger to charge-air-cooler (CAC) pipe.

PRESSURIZED CHARGE COOLER SYSTEM
To avoid eye or face injury from flying debris, wear a face shield or goggles.
  2. Pressurize the CAC inlet to 207 kPa (30 psi) using special tool TLZ00100 or equivalent.

  3. Using DDDL, monitor the boost psi.

a. If the pressure is below 187 kPa (27 psi), visually inspect the CAC, hoses, and the delivery tube for leaks. Repair as necessary.

b. If the pressure is 187 kPa (27 psi) or higher, continue to step 4.

  4. Disconnect the EGR actuator oil lines.

NOTE: The oil line fitting is a 37 degree JIC #6 fitting.

  5. Connect a regulated air supply line to the EGR actuator regulated to 69 kPa (10 psi).

  6. Using DDDL, activate EGR (PWM #2) to 90%.

  7. Monitor the boost kPa (psi) pressure for pressure drops when the EGR valve opens.

NOTE: The pressure should have dropped significantly to approximately 62 kPa (9 psi) or less.

a. If the air pressure dropped to 62 kPa (9 psi), no further testing is required. Verify repairs.

b. If the pressure dropped slightly, perform step 8.

  8. Physically inspect the EGR valve for a mechanical failure. If the EGR valve is not functioning correctly, replace the EGR valve.

a. If no active codes are present, verify repairs.

b. If code p 411/0 is still active, check the Delta P Sensor.


 Check for EGR valve stuck open or partly open (PID 412/FMI 0)

This same procedure may be found in the Series 60 EGR Technician's Guide (7SE60) as Test A.

Check for a stuck EGR valve as follows:

  1. Remove the turbocharger to charge-air-cooler (CAC) pipe.

PRESSURIZED CHARGE COOLER SYSTEM
To avoid eye or face injury from flying debris, wear a face shield or goggles.
  2. Pressurize the CAC inlet to 207 kPa (30 psi) using special tool TLZ00100 or equivalent.

  3. Using DDDL, monitor the boost psi.

a. If the pressure is below 187 kPa (27 psi), visually inspect the CAC, hoses, and the delivery tube for leaks. Repair as necessary.

b. If the pressure is 187 kPa (27 psi) or higher, continue to step 4.

  4. Disconnect the EGR actuator oil lines.

NOTE: The oil line fitting is a 37 degree JIC #6 fitting.

  5. Connect a regulated air supply line to the EGR actuator regulated to 69 kPa (10 psi).

  6. Using DDDL, activate EGR (PWM #2) to 90%.

  7. Monitor the boost kPa (psi) pressure for pressure drops when the EGR valve opens.

NOTE: The pressure should have dropped significantly to approximately 62 kPa (9 psi) or less.

a. If the air pressure dropped to 62 kPa (9 psi), no further testing is required. Verify repairs.

b. If the pressure dropped slightly, go to step 8.

  8. Physically inspect the EGR valve for a mechanical failure. If the EGR valve is not functioning correctly, replace the EGR valve.

a. If no active codes are present, verify repairs.

b. If code p 412/0 is still active, check EGR thermocouple resistance.


 CKP and CMP Sensors


 Cleaning Agent

Avoid the use of carbon tetrachloride as a cleaning agent because of the harmful vapors that it releases. Ensure the work area is adequately ventilated. Use protective gloves, goggles or face shield, and apron.

To avoid injury from harmful vapors or skin contact, do not use carbon tetrachloride as a cleaning agent.

Next topic

WORKING ON A RUNNING ENGINE

Previous topic


 Clear Codes

This feature allows diagnostic codes stored in the ECMs to be erased. An audit trail of when the codes were last erased will be displayed in engine hours.

Engine Hours of Last Clear Codes: XXXX

Next topic

MESSAGE IDENTIFICATION DESCRIPTIONS

Previous topic


 Clearing Codes

Fault codes can only be cleared using the DDR.

NOTE: Removing the battery cables will not clear codes.

Next topic

READING CODES

Previous topic


 Clipped and Soldered Splicing Method

The tools required are listed in the following table.

Tool | Part Number
Heat Gun | -
Sn 60 solder with rosin core flux | --
Wire Stripper | Kent-Moore J 35615 or equivalent
Splice Clips (commercially available) | Wire size dependent
Heat Shrink Tubing | Raychem HTAT or equivalent
Recommended Splicing Tools

Criteria: Splicing Straight Leads

No more than one strand in a 16 strand wire may be cut or missing.

Use Sn 60 solder with rosin core flux.

The exposed wire must be clean before the splice is soldered.

Soldering splice connectors is optional. To solder splice connectors:

  1. Position the leads, so one overlaps the other. See Positioning the Leads.

  2. Secure the leads with a commercially available clip and hand tool. See Securing the Leads With a Clip.

  3. Use a suitable electronic soldering iron to heat the wires. Apply the solder to the heated wire and clip (not to the soldering iron) allowing sufficient solder flow into the splice joint.

  4. Pull on wire to assure crimping and soldering integrity. The criteria listed in the following table must be met.

Wire Gauge | Must Withstand Applied Load
14 AWG | 45 lb (200 N)
16 AWG | 27 lb (120 N)
18 AWG | 20 lb (90 N)

  5. Shrink wrap.

  6. Loop the lead back over the spliced joint and tape. See Recommended Strain Relief of Spliced Joint.

Next topic

SPLICING AND REPAIRING STRAIGHT LEADS - ALTERNATE METHOD 1

Previous topic


CMP Sensor and CKP Sensor - Series 50

 CMP Sensor and CKP Sensor - Series 50 Engine


 CMP Sensor and CKP Sensor - Series 60 Engine


 CONDUIT AND LOOM

Conduit must be used to protect the harness wires and wire splices.

NOTICE:
The conduit must not cover any connectors, switches, relays, fuses, or sensors.
The following guidelines should be used when designing a harness:

NOTICE:
Wires should be sized and cut to near equal length prior to installing conduit.
The distance between the back of the connector or other listed devices to the end of the conduit should not exceed:

  1. 0 in. (25 mm) for a single connector/device

3 in. (75 mm) for multiple connectors/devices

All wire breakouts and conduit ends must be secured in place with conduit outlet rings or tape.

Criteria: Conduit and Loom

Due to the wide variety of operating conditions and environments, it is the responsibility of the OEM to select a conduit that will survive the conditions of the specific applications. Flame retardant convoluted polypropylene conduit or equivalent may be used for most installations. Heat retardant nylon conduit or oil, water, acid, fire, and abrasion resistant non-metallic loom conforming to SAE J562 APR86 Nonmetallic Loom (A)* is also acceptable. The diameter of conduit should be selected based on the number of wires being protected.

  • If non-metallic loom is used, secure the ends with tightly wrapped nylon straps to prevent unraveling.

Conduit should cover the wires without binding and without being excessively large.

Contact the Society of Automotive Engineers to obtain documents.

Next topic

TAPE AND TAPING

Previous topic


 Connector Service Loop

  1. Tie Wrap 2. Service Loop


 Connector Shroud

The shroud is used to protect the connectors from dirt and direct spray and to route the wires in the correct orientation. The shroud is designed for 25-30 mm conduit.

NOTE: The shroud is REQUIRED.

Different views of the connector shroud may be seen in the next illustration (see Electronic Control Unit Connector Shroud).

Two screws are required to attach the shroud to the ECU. The torque specification for these screws is 50 in.·lb.

NOTE: Replacement oversized screws are available in case of a thread failure of the connector.

Next topic

ENVIRONMENTAL CONDITIONS

Previous topic


 CONNECTORS

The DDEC V ECU has two 68-pin Tyco connectors - one for the engine and the other for the vehicle. Each connector has 60 18 AWG terminals and eight 14 AWG terminals (see ECU 68-pin Tyco Connector).

Next topic

ECU VEHICLE INTERFACE HARNESS CONNECTOR

Previous topic


 CONNECTORS, TERMINALS, AND SPLICING

For details, see

CONNECTORS

WIRES AND WIRING

CONDUIT AND LOOM

TAPE AND TAPING

Next topic

CONNECTORS

Previous topic


 Continuity Checks

In addition to measuring the specific resistance value of a circuit, some meters will also register if a continuous electrical path exists. If a path exists, the circuit is said to have continuity. (This continuity check can be used in any section of this troubleshooting guide where the test is looking for greater than, less than, or equal to 5 ohms.) An open circuit (broken electrical path) would haveresistance and would not have continuity. To utilize the continuity feature of certain meters:

  1. Place the function/range switch in any [image] [image] range.

  2. Connect the red lead to the V- [image] connector and the black lead to the com connector on the meter. With the test leads separated or measuring an out-of-range resistance, the digital display will indicate OL (over limit) Some meters show "1 +, 1, or [image] [image]."

  3. Put one test probe at one end of the wire or circuit to be tested. Use the other test lead to trace the circuit. When continuity is established, an ohm ( [image]) symbol will display in the upper left corner of the digital display. If contact in the wire is maintained long enough (about 1/4 second), the OL will disappear and the resistance value of the wire or circuit will display next to the symbol.

  4. If your VOM does not work in the manner described above, you must know how your VOM operates in order to use this troubleshooting guide.

Next topic

VOLTAGE MEASUREMENTS

Previous topic


Coolant Level Sensor Connector

 Check Engine Coolant Level Sensor Connector


 Coolant Temperature Sensor


 Coolant Temperature Sensor Circuits


 Coolant Temperature Sensor (Oil Temperature Sensor similar)


 Cruise Control

Cruise control can be set with the DDR or programming station.

Auto Resume

Yes or No. Will re-engage cruise if clutch switch is used to disable. Second press of clutch must be done within 3 seconds of the disengage and cruise will resume at the previously set speed.

Minimum Cruise Speed

Can be set with the DDR or programming station. Normally 20 mph, newer ECU software may allow setting to as low as 10 mph.

Maximum Cruise Speed

Can be set with the DDR or programming station. Limited to the calculated gear bound vehicle speed at rated engine r/min, or if progressive shift = yes, then max cruise speed is limited to high gear r/min. Also limited to vehicle speed limit (if set).

Engine Brake Cruise

Can be set with the DDR or programming station. Refer to engine brake information. Refer to Engine Brake (Jake Brake).

Next topic

CRUISE SWITCH VARIABLE SPEED GOVERNOR

Previous topic


 CRUISE CONTROL INOPERATIVE

Before using this procedure, all basic mechanical checks and physical inspections should have been performed with no problem found. Also the diagnosis of the DDEC system in DIAGNOSING A DDEC SYSTEM FAULT referred you to this section.

NOTE: Some ECU software on newer engines will require that the ECU 'detects' activity on a brake, clutch and cruise active circuits. Following each ignition on cycle the ECU will require the brake, clutch and cruise activate (circuit goes open and close or message sent to the ECU) before cruise will be allowed to operate.

Determine Type of Cruise Control System

Perform the following to determine the type of cruise control system:

  1. Check that this is a DDEC cruise control system.

  2. Turn ignition ON.

  3. Plug DDR into DDL connector.

  4. Select calibration configuration (cruise control).

  5. Is cruise control enabled?

[a] If cruise control is enabled, refer to Check Pin Assignments.

[b] If cruise is not enabled, refer to DDEC V Installation and Application manual, 7SA821, for requirements of installing cruise control.


 Cruise Switch Variable Speed Governor

The cruise switch can be set with the DDR or programming station. Requires Vehicle Speed Sensor (VSS) set to Yes.

Initial r/min= 1000 r/min default, initial r/min to ramp up to when set.

R/min incr= 25 r/min default, r/min increase when res/accl switch is enabled.

Next topic

DATA PAGES

Previous topic


 Cylinder Cutout Sequence

Start with the Menu Selection screen.

  1. Select ENGINE and ENTER.

  2. Go down and select FUEL INJECTOR INFO and ENTER.

  3. Go to CYLINDER CUTOUT and ENTER.

  4. Select NEW TEST and ENTER, or REVIEW LAST TEST and ENTER.

  5. Select IDLE and ENTER or 1000 RPM and ENTER.

  6. Select AUTO and ENTER, or MANUAL and ENTER three times.

  7. Test is now in progress.

NOTE: Test results stay stored in the Pro-Link memory as long as the DDR remains powered up.


 Data Link Connector

The SAE J1708/J1587 nine-pin data link connector is required. DDC recommends that the OEM-supplied Data Link Connector be conveniently positioned in a well protected location facilitating subsequent DDDL usage (i.e., reprogramming, diagnostics, etc.).

The components listed in the following table are required to incorporate a SAE J1939/J1587 Data Link in a VIH for diagnostic and reprogramming devices.

Component | DDC Part Number | Deutsch Part Number
Nine-pin Deutsch Connector | 23529496 | HD10-9-1939P
Connector Cover | 23529497 | HDC 16 - 9
Two (2) Cavity Plugs | 23507136 | 114017
Seven (7) Terminals | 23507132 | 0460-202-16141
See Wiring for 9-pin Data Link Connector for an illustration showing the wiring for the nine-pin connector.

The maximum length for the SAE J1939 Data Link is 130 ft (40 m).

The SAE J1587/J1708 Data Link must be twisted pairs. The twists are a minimum of 12 turns per foot (305 mm). The maximum length for the SAE J1587/J1708 Data Link is 130 ft (40 m).

Next topic

WIRES AND WIRING

Previous topic


 Data Pages

Enable data pages on the mainframe (up to 7.00 ECU software). This is automatic with ECU software level 20.xx or higher.

Next topic

ENGINE BRAKE (JAKE BRAKE)

Previous topic


 DDDL INSTRUMENTATION WINDOWS

The Instrumentation window is displayed when you choose "Normal Instrumentation" or "Diagnostic Instrumentation" from the Diagnostics menu. The window displays live data measurements from the ECU connected to your PC. See Normal Options for an illustration of the options available from a normal window. See Diagnostic Window for an illustration of the options available in the diagnostic window. The natural gas option was added to the diagnostic window in version 4.10. The EGR window was added in version 4.20. The List window was added in version 5.0.

Next topic

DDEC INSTRUMENTATION WINDOW FEATURES

Previous topic


 DDDL Kit


 DDEC BENEFITS

All Detroit Diesel On-Highway engines come standard with Detroit Diesel Electronic Controls (DDEC®). The state of the art Electronic Control Module (ECU) allows precise control of the engine management system that provides:

Excellent engine performance

Optimum fuel economy

Emissions to meet current laws without after treatment

Engine diagnostics

Simple programming

Next topic

FEATURES

Previous topic


 DDEC DESCRIPTIONS

To read codes, use the diagnostic data reader or depress and hold the diagnostic request switch with the ignition ON, engine at idle or not running. Active codes will be flashed on the RSL.

Inactive codes will be flashed on the AWL. The cycle will repeat until the operator releases the diagnostic request switch. Flash codes, descriptions, and SAE faults are listed in the following table.

DDC Code # (Flashed)
         PID
         SID
         FMI
         Description
11
         187
         -
         4
         Variable Speed Governor Sensor Voltage Low
11
         187
         -
         7
         Variable Speed Governor Switch System Not Responding
12
         187
         -
         3
         Variable Speed Governor Sensor Voltage High
13
         111
         -
         4
         Coolant Level Sensor Input Voltage Low
13
         111
         -
         6
         Add Coolant Level Sensor Input Voltage Low
13
         -
         146
         6
         EGR Valve Current Too High
14
         110
         -
         3
         Coolant Temperature Sensor Input Voltage High
14
         175
         -
         3
         Oil Temperature Sensor Input Voltage High
15
         110
         -
         4
         Coolant Temperature Sensor Input Voltage Low
15
         175
         -
         4
         Oil Temperature Sensor Input Voltage Low
16
         111
         -
         3
         Coolant Level Sensor Input Voltage High
16
         111
         -
         5
         Add Coolant Level Sensor Input Voltage High
16
         -
         146
         5
         EGR Valve Current Too Low
21
         91
         -
         3
         Throttle Position Sensor Input Voltage High
22
         91
         -
         4
         Throttle Position Sensor Input Voltage Low
23
         174
         -
         3
         Fuel Temperature Sensor Input Voltage High
24
         174
         -
         4
         Fuel Temperature Sensor Input Voltage Low
25
         -
         -
         -
         Reserved for ‘‘No Codes"
26
         -
         25
         11
         Aux. Shutdown #1 Active
26
         -
         61
         11
         Aux. Shutdown #2 Active
27
         105
         -
         3
         Intake Manifold Temperature Sensor Input Voltage High
27
         171
         -
         3
         Ambient Air Temperature Sensor Input Voltage High
27
         172
         -
         3
         Air Temperature Sensor Input Voltage High
28
         105
         -
         4
         Intake Manifold Temperature Sensor Input Voltage Low
28
         171
         -
         4
         Ambient Air Temperature Sensor Input Voltage Low
28
         172
         -
         4
         Air Temperature Sensor Input Voltage Low
29
         351
         -
         4
         TCI Temperature Circuit Failed Low
29
         404
         -
         4
         Turbo Compressor Temperature Out Sensor Input Voltage Low
31
         -
         51
         3
         Aux. Output #3 Open Circuit (High Side) - E49
31
         -
         51
         4
         Aux. Output #3 Short To Ground (High Side) - E49
31
         -
         51
         7
         Aux. Output #3 Mechanical System Fail - E49
31
         -
         52
         3
         Aux. Output #4 Open Circuit (High Side) - E48
31
         -
         52
         4
         Aux. Output #4 Short to Ground (High Side) - E48
31
         -
         52
         7
         Aux. Output #4 Mechanical System Failure - E48
31
         -
         260
         3
         Aux. Output #12 (E46) Open Circuit (High Side)
31
         -
         260
         4
         Aux. Output #12 (E46) Short To Ground (High Side)
31
         -
         260
         7
         Aux. Output #12 (E46) Mechanical System Failure (High Side)
31
         -
         261
         3
         Aux. Output #13 (E47) Open Circuit (High Side)
31
         -
         261
         4
         Aux. Output #13 (E47) Short To Ground (High Side)
31
         -
         261
         7
         Aux. Output #13 (E47) Mechanical System Failure
31
         -
         262
         3
         Aux. Output #14 (E50) Open Circuit (High Side)
31
         -
         262
         4
         Aux. Output #14 (E50) Short To Ground (High Side)
31
         -
         262
         7
         Aux. Output #14 (E50) Mechanical System Failure (High Side)
31
         -
         263
         3
         Aux. Output #15 (E51) Open Circuit (High Side)
31
         -
         263
         4
         Aux. Output #15 (E51) Short To Ground (High Side)
31
         -
         263
         7
         Aux. Output #15 (E51) Mechanical System Failure
31
         -
         264
         3
         Aux. Output #16 (E52) Open Circuit (High Side)
31
         -
         264
         4
         Aux. Output #16 (E52) Short To Ground (High Side)
31
         -
         264
         7
         Aux. Output #16 (E52) Mechanical System Failure
31
         -
         265
         3
         Aux. Output #17 (E53) Open Circuit (High Side)
31
         -
         265
         4
         Aux. Output #17 (E53) Short To Ground (High Side)
31
         -
         265
         7
         Aux. Output #17 (E53) Mechanical System Failure
32
         -
         238
         3
         RSL Short to Battery (+)
32
         -
         238
         4
         RSL Open Circuit
32
         -
         239
         3
         AWL Short to Battery (+)
32
         -
         239
         4
         AWL Open Circuit
33
         102
         -
         3
         Turbo Boost Pressure Sensor Input Voltage High
34
         102
         -
         4
         Turbo Boost Pressure Sensor Input Voltage Low
35
         100
         -
         3
         Oil Pressure Sensor Input Voltage Low
36
         100
         -
         4
         Oil Pressure Sensor Input Voltage Low
37
         94
         -
         3
         Fuel Pressure Sensor Input Voltage High
37
         95
         -
         3
         Fuel Restriction Sensor Input Voltage High
38
         94
         -
         4
         Fuel Pressure Sensor Input Voltage Low
38
         95
         -
         4
         Fuel Restriction Sensor Input Voltage Low
39
         -
         146
         2
         EGR Leak - Boost Power
39
         -
         146
         7
         EGR Valve Not Responding
39
         -
         146
         12
         EGR Leak - Boost Jake
39
         -
         147
         2
         VNT Vanes Not Responding - Boost Power
39
         -
         147
         7
         VNT Vanes Not Responding - EGR
39
         -
         147
         11
         VNT Vanes at Max - Jake
39
         -
         147
         12
         VNT Vanes Not Responding - Boost Jake
39
         -
         147
         14
         EGR Flow too Low
41
         -
         21
         0
         Too Many SRS (missing TRS)
42
         -
         21

Too few SRS (missing SRS)
43
         111
         -

Coolant Level Low
44
         105
         -
         0
         Intake Manifold Temperature High
44
         105
         -
         14
         Engine Power Derate Due To Inlet Manifold Temperature
44
         110
         -
         0
         Coolant Temperature High
44
         110
         -
         14
         Engine Power Derate Coolant Temperature
44
         172
         -
         0
         Air Inlet Temperature High
44
         175
         -
         0
         Oil Temperature High
44
         175
         -
         14
         Oil Temperature Derate
45
         100
         -

Oil Pressure Low
46
         -
         155
         4
         Injector Vreg Voltage Failed Low
46
         168
         -

ECU Battery Voltage Low
46
         -
         211

Vehicle Sensor Supply Voltage Low
46
         -
         212
         4
         Injector Vslope Voltage Failed Low
46
         -
         214

RTC Backup Battery Voltage Low
46
         -
         221
         4
         Injector ILpullin Voltage Failed Low
46
         -
         232

Sensor Supply Voltage Low
47
         94
         -
         0
         Fuel Pressure High
47
         102
         -
         14
         Engine Power Derate Due To Boost Pressure
47
         102
         -
         0
         Turbo Boost Pressure High
47
         106
         -
         0
         Air Inlet Pressure High
48
         94
         -

Fuel Pressure Low
48
         106
         -

Air Inlet Pressure Low
48
         351
         -

TCI Temperature Below Range
48
         404
         -

Turbo Compressor Temperature Out Low
48
         411
         -

EGR Delta Pressure Low
48
         412
         -

EGR Temperature Low
49
         351
         -
         0
         TCI Temperature Above Range
49
         404
         -
         0
         Turbo Compressor Out Temperature High
49
         404
         -
         14
         Engine Power Derate Due To TCO Temperature
51
         351
         -
         3
         TCI Temperature Circuit Failed High
51
         404
         -
         3
         Turbo Compressor Out Temperature Sensor Input Voltage High
52
         -
         254
         12
         A/D Conversion Fail
53
         -
         253

Memory Check Failed On Startup
53
         -
         253
         12
         Memory Write Error - Single Location
53
         -
         253
         13
         Calibration Memory Error
53
         -
         253
         14
         Memory Write Error - All Locations
54
         84
         -
         12
         Vehicle Speed Sensor Fault
55
         -
         216
         14
         Other ECU Fault (This fault is logged in conjunction with another fault to indicate missing information from another ECU.)
55
         -
         231
         12
         J1939 Data Link Fault
58
         40
         -
         9
         Engine Retarder Switch Not Responding
58
         40
         -
         12
         Engine Retarder Switch Failed
58
         70
         -
         9
         Park Brake/Safety Loop Switch Not Responding
58
         70
         -
         12
         Park Brake/Safety Loop Switch Failed
58
         92
         -
         0
         Torque Overload
58
         -
         216
         7
         ECU Information Not Responding (Mux'd Dashboard Devices)
58
         -
         242
         9
         Cruise Control Resume/Accel Switch Not Responding
58
         -
         242
         12
         Cruise Control Resume/Accel Switch Failed
58
         -
         243
         9
         Cruise Control Set/Coast Switch Not Responding
58
         -
         243
         12
         Cruise Control Set/Coast Switch Failed
58
         -
         244
         9
         Cruise Control Enable Switch Not Responding
58
         -
         244
         12
         Cruise Control Enable Switch Failed
58
         -
         245
         9
         Clutch Pedal Switch Not Responding
58
         -
         245
         12
         Clutch Pedal Switch Failed
58
         -
         246
         9
         Service Brake Pedal Switch Not Responding
58
         -
         246
         12
         Service Brake Pedal Switch Failed
61
         -
         xxx
         0
         Injector xxx Response Time Long
61
         -

6
         Injector #1 Circuit Short To Ground
61
         -

6
         Injector #2 Circuit Short To Ground
61
         -

6
         Injector #3 Circuit Short To Ground
61
         -

6
         Injector #4 Circuit Short To Ground
61
         -

Injector #5 Circuit Short To Ground
61
         -
         6
         6
         Injector #6 Circuit Short To Ground
62
         -
         26
         3
         Aux. Output #1 Short to Battery (+) - V4
62
         -
         26
         4
         Aux. Output #1 Open Circuit - V4
62
         -
         26

Aux. Output #1 Mechanical System Not Responding Properly -V4
62
         -
         40
         3
         Aux. Output #2 Short to Battery (+) - V5
62
         -
         40
         4
         Aux. Output #2 Open Circuit - V5
62
         -
         40
         7
         Aux. Output #2 Mechanical System Not Responding Properly - V5
62
         -
         53
         3
         Aux. Output #5 Short to Battery (+) -V6
62
         -
         53
         4
         Aux. Output #5 Open Circuit - V6
62
         -
         53
         7
         Aux. Output #5 Mechanical System Not Responding Properly - V6
62
         -
         54
         3
         Aux. Output #6 Short to Battery (+) - V7
62
         -
         54
         4
         Aux. Output #6 Open Circuit - V7
62
         -
         54
         7
         Aux. Output #6 Mechanical System Not Responding Properly - V7
62
         -
         55
         3
         Aux. Output #7 Short to Battery (+) - V40
62
         -
         55
         4
         Aux. Output #7 Open Circuit - V40
62
         -
         55
         7
         Aux. Output #7 Mechanical System Not Responding Properly - V40
62
         -
         56
         3
         Aux. Output #8 Short to Battery (+) - V53
62
         -
         56
         4
         Aux. Output #8 Open Circuit - V53
62
         -
         56
         7
         Aux. Output #8 Mechanical System Not Responding Properly - V53
62
         -
         250
         12
         J1587 Data Link Fault
62
         -
         257
         3
         Aux.Output #9 (V54) Short To Battery
62
         -
         257
         4
         Aux.Output #9 (V54) Open Circuit
62
         -
         257
         7
         Aux.Output #9 (V54) Mechanical System Failure-Pin Top 2
62
         -
         258
         3
         Aux Output #10 (V55) Short To Battery
62
         -
         258
         4
         Aux Output #10 (V55) Open Circuit
62
         -
         258
         7
         Aux Output #10 (V55) Mechanical System Failure Top 2
62
         -
         259
         3
         Aux Output #11 (E13) Short To Battery
62
         -
         259
         4
         Aux Output #11 (E13) Open Circuit
62
         -
         259
         7
         Aux Output #11 (E13) Mechanical System Failure
62
         -
         260
         3
         Aux Output #12 Open Circuit - Pin E46
62
         -
         260
         4
         Aux Output #12 Short to Gnd - Pin E46
62
         -
         260
         7
         Aux Output #12 Mechanical System Failure - Pin E46
62
         -
         261
         3
         Aux Output #13 Open Circuit - Pin E47
62
         -
         261
         4
         Aux Output #13 Short to Gnd - Pin E47
62
         -
         261
         7
         Aux Output #13 Mechanical System Failure - Pin E47
62
         -
         262
         3
         Aux Output #14 Open Circuit - Pin E50
62
         -
         262
         4
         Aux Output #14 Short to Gnd - Pin E50
62
         -
         262
         7
         Aux Output #14 Mechanical System Failure - Pin E50
62
         -
         263
         3
         Aux Output #15 Open Circuit - Pin E51
62
         -
         263
         4
         Aux Output #15 Short to Gnd - Pin E51
62
         -
         263
         7
         Aux Output #15 Mechanical System Failure - Pin E51
62
         -
         264
         3
         Aux Output #16 Open Circuit - Pin E52
62
         -
         264
         4
         Aux Output #16 Short to Gnd - Pin E52
62
         -
         264
         7
         Aux Output #16 Mechanical System Failure - Pin E52
62
         -
         265
         3
         Aux Output #17 Open Circuit - Pin E53
62
         -
         265
         4
         Aux Output #17 Short to Gnd - Pin E53
62
         -
         265
         7
         Aux Output #17 Mechanical System Failure - Pin E53
63
         -
         57
         0
         PWM #1 (V52) Above Normal Range
63
         -
         57

PWM #1 (V52) Below Normal Range
63
         -
         57
         3
         PWM #1 (V52) Short to Battery (+)
63
         -
         57
         4
         PWM #1 (V52) Open Circuit
63
         -
         57
         7
         PWM #1 (V52) Mechanical System Failure
63
         -
         58
         0
         PWM #2 (V46) Above Normal Range
63
         -
         58

PWM #2 (V46) Below Normal Range
63
         -
         58
         3
         PWM #2 (V46) Short to Battery (+)
63
         -
         58
         4
         PWM #2 (V46) Open Circuit
63
         -
         58
         7
         PWM #2 (V46) Mechanical System Failure
63
         -
         59
         0
         PWM #3 (E01) Above Normal Range
63
         -
         59

PWM #3 (E01) Below Normal Range
63
         -
         59
         3
         PWM #3 (E01) Short to Battery (+)
63
         -
         59
         4
         PWM #3 (E01) Open Circuit
63
         -
         59
         7
         PWM #3 (E01) Mechanical System Failure
63
         -
         60
         0
         PWM #4 (E04) Above Normal Range
63
         -
         60

PWM #4 (E04) Below Normal Range
63
         -
         60
         3
         PWM #4 (E04) Short to Battery (+)
63
         -
         60
         4
         PWM #4 (E04) Open Circuit
63
         -
         60
         7
         PWM #4 (E04) Mechanical System Failure
63
         -
         267
         0
         PWM #5 (E08) Above Normal Range
63
         -
         267

PWM #5 (E08) Below Normal Range
63
         -
         267
         3
         PWM #5 (E08) Short to Battery (+)
63
         -
         267
         4
         PWM #5 (E08) Open Circuit
63
         -
         267
         7
         PWM #5 (E08) Mechanical System Failure
63
         -
         268
         0
         PWM #6 (E11) Above Normal Range
63
         -
         268

PWM #6 (E11) Below Normal Range
63
         -
         268
         3
         PWM #6 (E11) Short to Battery (+)
63
         -
         268
         4
         PWM #6 (E11) Open Circuit
63
         -
         268
         7
         PWM #6 (E11) Mechanical System Failure
64
         103
         -
         0
         Turbo Overspeed
64
         103
         -
         8
         Turbo Speed Sensor Input Failure - Abnormal Period
65
         107
         -
         3
         Air Filter Restriction Sensor Voltage High
65
         107
         -
         4
         Air Filter Restriction Sensor Voltage Low
66
         99
         -
         3
         Oil Filter Restriction Sensor Voltage High
66
         99
         -
         4
         Oil Filter Restriction Sensor Voltage Low
67
         106
         -
         3
         Air Inlet Pressure Sensor Input Voltage High
67
         106
         -
         4
         Air Inlet Pressure Sensor Input Voltage Low
67
         109
         -
         3
         Coolant Pressure Circuit Failed High
67
         109
         -
         4
         Coolant Pressure Circuit Failed Low
68
         -
         230
         5
         TPS Idle Validation Circuit Fault (open circuit)
68
         -
         230
         6
         TPS Idle Validation Circuit Fault (short to ground)
71
         -
         xxx

Injector xxx Response Time Short
72
         84
         -
         0
         Vehicle Overspeed
72
         84
         -
         11
         Vehicle Overspeed (Absolute)
74
         70
         -
         4
         Optimized Idle Safety Loop Short to Ground
74
         99
         -
         0
         Oil Filter Restriction High
75
         -
         155
         3
         Injector Vreg Voltage Failed High
75
         168
         -
         0
         ECU Battery Voltage High
75
         -
         211
         0
         Vehicle Sensor Supply Voltage High
75
         -
         212
         3
         Injector Vslope Voltage Failed High
75
         -
         214
         0
         RTC Backup Battery Voltage High
75
         -
         221
         3
         Injector Ipullin Voltage Failed High
75
         -
         232
         0
         Sensor Supply Voltage High
76
         121
         -
         0
         Engine Overspeed With Engine Brake
77
         21
         -
         0
         ECU Temperature Above Range
77
         21
         -

ECU Temperature Below Range
77
         21
         -
         3
         ECU Temperature Failed High
77
         21
         -
         4
         ECU Temperature Failed Low
77
         73
         -

Fire Pump Pressure Low
77
         81
         -
         0
         Exhaust Back Pressure High
77
         81
         -

Exhaust Back Pressure Low
77
         81
         -
         3
         Exhaust Back Pressure Sensor Voltage High
77
         81
         -
         4
         Exhaust Back Pressure Sensor Voltage Low
77
         81
         -
         12
         Exhaust Back Pressure at Rampdown Threshold
77
         95
         -

Fuel Filter Differential Pressure Low
77
         99
         -

Oil Filter Differential Pressure Low
77
         100
         -
         0
         Engine Oil Pressure High
77
         102
         -

Turbo Boost Pressure Low
77
         105
         -

Inlet Manifold Temperature Low
77
         107
         -

Air filter Restriction Pressure Low
77
         108
         -
         0
         Barometric Pressure High
77
         108
         -

Barometric Pressure Low
77
         109
         -
         0
         Coolant Pressure High
77
         110
         -

Coolant Temperature Low
77
         111
         -
         0
         Coolant Level High
77
         151
         -
         11
         Service Now Lamp Fault Expiration
77
         171
         -
         0
         Ambient Air Temperature High
77
         171
         -

Ambient Air Temperature Low
77
         172
         -

Air Inlet Temperature Low
77
         174
         -
         0
         Fuel Temperature High
77
         174
         -

Fuel Temperature Low
77
         175
         -

Engine Oil Temperature Low
77
         177
         -
         0
         Transmission Oil Temperature High
77
         177
         -

Transmission Oil Temperature Low
77
         177
         -
         3
         Transmission Oil Temperature Failed High
77
         177
         -
         4
         Transmission Oil Temperature Failed Low
77
         222
         -
         14
         Anti-Theft Fault Present
77
         -
         151
         11
         Service Now Lamp Fault Expiration
78
         86
         -
         14
         Cruise Control/Adaptive Cruise Control Fault
81
         98
         -
         3
         Oil Level Sensor Input Voltage High
81
         173
         -
         3
         Exhaust Temperature Sensor Input Voltage High
81
         355
         -
         3
         Engine Oil Life Sensor Circuit Failed High
81
         411
         -
         3
         EGR Delta Pressure Circuit Failed High
81
         412
         -
         3
         EGR Temperature Circuit Failed High
81
         355
         -
         3
         Engine Oil Life Sensor Circuit Failed High
82
         98
         -
         4
         Oil Level Sensor Input Voltage Low
82
         101
         -
         4
         Crankcase Pressure Sensor Input Voltage Low
82
         153
         -
         4
         Extended Crankcase Pressure Input Voltage Low
82
         173
         -
         4
         Exhaust Temperature Sensor Input Voltage Low
82
         355
         -
         4
         Engine Oil Life Sensor Circuit Failed Low
82
         411
         -
         4
         EGR Delta Pressure Circuit Failed low
82
         412
         -
         4
         EGR Temperature Circuit Failed Low
83
         73
         -
         0
         Aux Pump Pressure High
83
         98
         -
         0
         Oil Level High
83
         101
         -
         0
         Crankcase Pressure High
83
         153
         -
         0
         Extended Crankcase Pressure High
83
         173
         -
         0
         Exhaust Temperature High
83
         355
         -
         9
         Coolant In Oil Detected
83
         355
         -
         14
         Change Oil Now
83
         411
         -
         0
         EGR Delta Pressure High
83
         412
         -
         0
         EGR Temperature High
84
         98
         -

Oil Level Low
84
         355
         -

Change Oil Soon
85
         190
         -
         0
         Engine Overspeed
85
         190
         -
         14
         Engine Overspeed Signal
86
         73
         -
         3
         Aux Pump Pressure Sensor Input Voltage High
86
         108
         -
         3
         Barometric Pressure Sensor Input Voltage High
87
         73
         -
         4
         Pump Pressure Sensor Input Voltage Low
87
         108
         -
         4
         Barometric Pressure Sensor Input Voltage Low
89
         95
         -
         0
         Fuel Filter Restriction High
89
         111
         -
         12
         Maintenance Alert Coolant Level Fault
-
         -
         240

FRAM Checksum Incorrect
-
         -
         240
         13
         TPU Checksum Incorrect
-
         -
         253
         2
         Calibration Checksum Incorrect
-
         -
         253
         9
         Calibartion Checks Invalid
-
         -
         253
         13
         Calibration Versions Invalid
-
         -
         254
         0
         External RAM Failed
-
         -
         254

Internal RAM Failed
-
         -
         254
         6
         Module Forced To Boot Mode
-
         -
         254
         12
         Boot Code Checksum Incorrect

Next topic

TESTING / SERVICE TOOLS / TIPS

Previous topic


 DDEC DIAGNOSTIC CODES

The DDEC V system allows for an increased processor speed and increased memory.

NOTE: Due to the nature of the DDEC V System always start your diagnosis with refer to DDEC ECU SOFTWARE FEATURES.

A diagnostic code indicates a problem in a given circuit (i.e. diagnostic Flash Code 14 indicates a problem in the oil or coolant temperature sensor circuit). This includes the oil or coolant temperature sensor, connector, harness, and Electronic Control Module (ECU). The procedure for finding the problem can be found in Flash Code 14, refer to FLASH CODE 14 - TEMP SENSOR HIGH. Similar sections are provided for each code. Remember, diagnosis should always begin at the start of the section. For an oil or coolant temperature sensor problem, it will quickly lead you to FLASH CODE 14 - TEMP SENSOR HIGH, but first you verify the code or symptom.

Since the self-diagnostics do not detect all possible faults, the absence of a code does not mean there are not problems in the system. If a DDEC problem is suspected, even in the absence of a code, refer to DIAGNOSING A DDEC SYSTEM FAULT, anyway. This section can lead you to other sections that can aid in the troubleshooting process - where DDEC problems may occur, but do not generate a code. Basic mechanical checks are not covered in this manual.

Next topic

GENERAL DIAGNOSTIC INFORMATION

Previous topic


 DDEC ECU SOFTWARE FEATURES

This section is a brief description of DDEC system ECU software features and what is required to activate the feature (DDR, PC, etc.).

NOTE: For a complete description of features, refer to publication 7SA800, DDEC III Application and Installation manual.

Next topic

AIR COMPRESSOR GOVERNOR SYSTEM

Previous topic

TAPE AND TAPING

See also


 DDEC FEATURE SUMMARY

The "x" in a column indicates that this feature has always been available. The numbers indicate the software release that the feature was introduced. A number in the DDR column represents the ECU software release that made the feature available, or able to be changed with the tool listed in the comments column. Parameters that are configured in the Application Code Only are listed in the following table.

Parameter Name | APPL Code 6N4C Only | Mainframe Only | Program Station | DDR / DDL | Comments
Air Compressor Governor System | 4 | - | - | - | -
Air Temp Sensor | x | - | - | - | -
Air Temp Torque Reduction | 3 | - | - | - | -
Barometric Pressure Sensor | x | - | - | - | -
Coolant Level Sensor | x | - | - | - | -
Coolant Pressure Sensor | x | - | - | - | -
Crankcase Pressure Sensor | x | - | - | - | -
Cruise MIN r/min | x | - | - | - | Typically 1100 r/min
Disable EOP on VSG | x | - | - | - | Typically fire trucks only
Dual Fuel BOI | x | - | - | - | Methanol engines; replaces fuel pressure sensor
Enable Engine Brakes | x | - | - | - | May be Jakes, KD (S55) or DVB (S55) beginning w/R4
Engine Overtemp Protection | x | - | - | - | Engine power limiting based on high engine temps OTS, CTS, ICTS
Engine Protection Configuration | x | - | - | - | Temp limits F & amt of power/speed reduction
Engine Sync | x | - | - | - | -
Engine Sync Pulses | x | - | - | - | Typically 12
Fan Control Configuration | x | - | - | - | Includes activation temps
Fuel Pressure Sensor | x | - | - | - | -
Glow Plugs | x | - | - | - | Methanol engines
Idle Operation at Zero VSG | x | - | - | - | Typically set for on-highway applications
Intercooler Temp Sensor | x | - | - | - | -
LSG Low Side Diagnostics (Code 22) | x | - | - | - | -
LSG Override VSG | x | - | - | - | -
Oil Pressure Sensor | x | - | - | - | -
Oil Temp Sensor | x | - | - | - | -
Pressure Governor System | x | - | - | - | Fire truck applications
PWM Fan Control | 3 | - | - | - | Assigned to PWM4 w/R3; can be programmed for PWM2 or PWM4 w/R4*
PWM Fan Control Configuration | 3 | - | - | - | Includes duty cycle levels and temperatures
VSG | x | - | - | - | -
VSG Low Side Diagnostics (Code 11) | x | - | - | - | Typically not set for on-highway applications
VSG Operation at Higher Vehicle Speeds | 5 | - | - | - | Typically set to 3 mph
VSG Using Foot Pedal | x | - | - | - | Changes scale of r/min per count
  • Typically PWM2 for S149; PWM4 for S50/S60

The parameters that are configured in the mainframe screens only are listed in the following table.

Parameter Name | APPL Code 6N4C Only | Mainframe Only | Program Station | DDR / DDL | Comments
6N4C Group | - | x | - | - | -
6N4D Group | - | x | - | - | -
ATI Port | - | 4 | - | - | None or TURBO SPD or NAT GAS or VSG FREQ (Pin x-1)
Digital Torque Limiting | - | 5 | - | - | Utilizes selection of a predefined torque curve and/or speed
Fan Type (Digital Output) | - | x | - | - | -
Full Power Continuous Override | - | x | - | - | -
Hot Idle Speed | - | x | - | - | Some industrial only max 1400 r/min
Max Cold Idle Speed | - | 3 | - | - | Restricted for automatic trans to 700 r/min
Maximum Security | - | x | - | - | -
Override CCPS Faults | - | 3 | - | - | Intended for EMD
Override OPS Low Faults | - | 3 | - | - | Intended for EMD
Rating Security | - | x | - | - | -
Starter Lockout Speed Settings | - | 5 | - | - | Allows use of this output for other functions
VSG is Primary | - | x | - | - | -

Parameters that can be configured by the OEM, programming station, and/or the DDR are listed in the following table.

Parameter Name
         APPL Code 6N4C Only
         Mainframe Only
         Program Station
         DDR / DDL
         Comments
ACG Integral Gain
         -
         4
         4
         -
         Air Compressor Gov
ACG Pressure Increment
         -
         4
         4
         -
         -
ACG Proportional Gain
         -
         4
         4
         -
         -
Engine Sensor Harness Outputs (3)
         -
         x
         x
         -
         -
Fan A/C Timer
         -
         5
         5
         -
         Typically set to 180 seconds (3 minutes)
PGS Cavitation Time Out
         -
         x
         x
         -
         -
PGS Engine Speed Increment
         -
         x
         x
         -
         -
PGS Integral Gain
         -
         x
         x
         -
         -
PGS Proportional Gain
         -
         x
         x
         -
         -
PGS Pump Pressure Increment
         -
         x
         x
         -
         -
Vehicle Interface Harness Inputs (12)
         -
         x
         x
         -
         -
Vehicle Interface Harness Outputs (3)
         -
         x
         x
         -
         -
ACG Delta Pressure to Load
         -
         4
         4
         4
         Air Compressor Gov
ACG Delta Pressure to Unload
         -
         4
         4
         4
         -
ACG Maximum Pressure - 1,2,3
         -
         4
         4
         4
         -
ACG Minimum Pressure - 1.2.3
         -
         4
         4
         4
         -
Auxiliary Stop 1 or 2 Protection Level
         -
         x
         x
         x
         -
Coolant Level Protection Level
         -
         x
         x
         x
         -
Crankcase Pressure Protection Level
         -
         x
         x
         x
         -
Cruise Auto Resume
         -
         x
         x
         x
         -
Cruise Control Enable
         -
         x
         x
         x
         -
Cruise Maximum Speed
         -
         x
         x
         x
         -
Cruise Minimum Speed
         -
         x
         x
         x
         -
Dynamic Fan Braking
         -
         x

2
         -
Engine Brake Cruise
         -
         x
         x
         x
         -
Engine Brake Increment
         -
         x
         x
         x
         -
Engine Brake Low
         -
         x
         x
         x
         -
Engine Brake-Svc Brake Activation
         -
         -
         5
         5
         When set requires tap of svc brake to activate Jakes
Engine Brake - Minimum mph
         -
         -
         5
         5
         Allows deactivation of Jakes below a vehicle speed
FEI - Calculation Type
         -
         5
         5
         5
         Fuel Economy Incentive
FEI Conversion Factor, mph per mpg
         -
         5
         5
         5
         -
FEI - Maximum mph
         -
         5
         5
         5
         -
FEI - Minimum mpg
         -
         5
         5
         5
         -
Feature Password Protection
         -
5
         4
         (Function Lockout)
Half Engine Enable
         -
         -
         -
         7
         Enable/disable Half engine idle, Off, If Cold, On, N/A
Idle Shutdown Override
         -
         x
         x
         x
         -
Idle Speed Offset
         -
         -
         -
         x
         Idle Adjust Normal +100 to -25 rpm
Idle Timer
         -
         x
         x
         x
         -
Idle Timer Operates ON
         -
         x
         x
         x
         Idle Gov only, or Idle and VSG Governor
Idle Timer Override Defeat, max temp
         -
         2
         2
         2
         -
Idle Timer Override Defeat, min temp
         -
         2
         2
         2
         -
Idle Timer Shutdown
         -
         x
         x
         x
         -
Injector Calibration Codes
         -
         -
         -
         x
         -
Intercooler Temp Protection Level
         -
         x
         x
         x
         -
LSG Droop
         -
         x
         x
         x
         -
Max Vehicle Overspeed with Fuel
         -
         x
         x
         x
         -
Max Vehicle Overspeed w/o Fuel
         -
         x
         x
         x
         -
Oil Pressure Protection Level
         -
         x
         x
         x
         -
Oil Temp Protection Level
         -
         x
         x
         x
         -
Progressive Shift Configuration
         -
         x
         x
         x
         -
Rating Selection (Rating Override)
         -
         6N4M
         x
         x
         -
Transmission Type (PWM #1)
         -
         x
         x
         x
         -
Unit Number
         -
         -
         -
         4
         -
Vehicle Speed Limiting
         -
         x
         x
         x
         -
Vehicle Speed Max
         -
         x
         x
         x
         -
Vehicle Speed Sensor
         -
         x
         x
         x
         -
VIN
         -
         -
         x
         x
         -
VSG Alt Min RPM
         -
         x
         x
         x
         -
VSG Cruise Init Speed
         -
         x
         x
         x
         -
VSG Cruise RPM Increment
         -
         x
         x
         x
         -
VSG Droop
         -
         x
         x
         x
         -
VSG Maximum RPM
         -
         x
         x
         x
         -
VSG Minimum RPM
         -
         x
         x
         x
         -
VSG Using Cruise Switch
         -
         x
         x
         x
         -
VSS Anti Tamper
         -
         -
         7
         5
         -
VSS Axle Ratio
         -
         x
         x
         x
         -
VSS Final Gear Ratio
         -
         x
         x
         x
         -
VSS Number of Teeth
         -
         x
         x
         x
         -
VSS Sensor Type
         -
         x
         x
         x
         Typically tailshaft; also wheel or J1939
VSS Signal Type
         -
         2
         2
         2
         Typically magnetic; also open-collector/switch
VSS Tire Revolutions
         -
         x
         x
         x
         -

DDEC Features, code 6N5, are listed in the following table.

Parameter Name | Code | Mainframe Only | Program Station | DDR | Comments
No DDEC Feature | 6N5-NONE | - | - | - | -
ECU Data Pages Only | 6N5-0001 | - | - | - | -
Optimized Idle Only | 6N5-0002 | - | - | - | -
Data Pages and Optimized Idle | 6N5-0003 | - | - | - | -

Next topic

DIAGNOSING A DDEC SYSTEM FAULT

Previous topic


 DDEC Instrumentation Window Features

The normal instrumentation window is also displayed when you choose "Open" from the Snapshot menu unless the Fault Codes window is already open.

When you have an open snapshot and the Instrumentation window is selected, playback controls are added to the bottom of the Instrumentation window. You can use these to replay the snapshot. The Instrumentation window is used in the same way whether you are viewing live data or a snapshot.

Instrument Pages

The instruments in the Instrumentation window are grouped together on tabs. You can choose how they are grouped by choosing Normal Instrumentation or Diagnostic Instrumentation commands in the Diagnostics menu.

To view the different pages of data shown in the window, click on the tab labeling the page holding the data. You may also hold the "Control" key down while you press the number key shown on the tab.

NOTE: An individual can customize the information shown in the Instrumentation window using the Graph or User pages.

Multi-ECU Engines

Provided you are using a PC display with a resolution of at least 800 X 600 (small fonts), some of the Normal Instrumentation pages show details for each of the ECMs in a multi-ECU engine.

NOTE: Whatever the resolution of your display you can also monitor parameters in the different ECMs by assigning them to instruments on the User pages or by choosing them for display on the Graph page.

Instruments

The results of measurements are presented in a variety of ways, depending on the quantity measured.

You can tell from an instrument if the ECU is not transmitting data for that measurement. The way "No Data" is shown depends on whether the instrument is:

A meter.

A thermometer.

A digital meter.

Text.

Magnified View of Instruments

To display a magnified view of just one of the instruments on your screen, click on the instrument to enlarge it; click on it again to return it to the normal size. (this is particularly useful if you want to monitor a measurement while you are working at some distance from the display).

Next topic

USING SNAPSHOT REPLAY CONTROLS

Previous topic


 DDEC MANUALS

The following DDC manuals provide more information about specific DDEC features:

Construction & Industrial EDM and AIM Installation and Troubleshooting (7SA801)

Construction & Industrial EDM and AIM User Manual (6SE710)

ProDriver DC User Manual (6SE703)

Electronic Fire Commander Installation and Troubleshooting (6SE476)

Engine Synchro Shift™ Troubleshooting (6SE498)

Optimized Idle - DDEC V - Installation and Troubleshooting (in process)

IRIS User and Installation Guide (7SA804)

Next topic

CONNECTORS, TERMINALS, AND SPLICING

Previous topic


 DDEC PRO-LINK OPERATION

The following procedures suggest several ways to use the Pro-Linkon the DDEC system, see Pro-Link.

Diagnostic Codes

Cylinder Cutout Sequence

Injector Calibration Update

Reprogram Calibration

Snapshot Sequence

Print Function


 DDEC RELATED PUBLICATIONS

The following manuals, listed in the following table:

Publication | Number
DDEC V Application and Installation manual | 7SA821
Optimized Idle Installation and Troubleshooting | 7SA741
Optimized Idle User Manual | 6SE518
Optimized Idle Troubleshooting and Reprogramming | 18SA366
DDC Ether Start | 7SA727
Series 60 Driving Tips (includes VHS video) | 25STV0161
Electronic Fire Commander | 6SE476

Next topic

ECU AND SENSOR LOCATIONS

Previous topic


 DDEC REPROGRAMMING SYSTEM

This information was not available at time of publication; the information will be sent to bookholders when it becomes available.

Next topic

DDEC MANUALS

Previous topic


 DDEC SYSTEM - HOW IT WORKS

The major components of the DDEC system consist of the electronic control module (ECU), the electronic unit injectors (EUI) and the various system sensors. The purpose of the sensors is to provide information to the ECU regarding various engine performance characteristics. The information sent to the ECU is used to instantaneously regulate engine and vehicle performance.

Next topic

SENSORS

Previous topic


DDEC Vehicle Interface Module, J 41005

 DDEC Vehicle Interface Module, J 41005 (DDEC V Harness Required)

Requires J 41005-5 adaptor harness to work with DDEC V.


 Delta-P Sensor and Related Parts

Delta-P Sensor
         8.
         Clip

Stud
         9.
         Delta-P Tube

Isolator
         10.
         Nut

Hose Clamp
         11.
         Bracket

Delta-P Tube
         12.
         Thermostat Housing

Nut
         13.
         Bolt

Delivery Pipe


 Detroit Diesel Diagnostic Link

For mobile applications, Detroit Diesel Diagnostic Link (DDDL) must be used by personnel other than the vehicle operator.

The vehicle operator must maintain control of the vehicle while an assistant performs the diagnostic evaluations.

To avoid injury from engine shutdown in an unsafe situation, ensure the operator knows how to override the stop engine condition on a DDEC-equipped unit.

To avoid injury from loss of vehicle/vessel control, the operator of a DDEC equipped engine must not use or read any diagnostic tool while the vehicle/vessel is moving

Next topic

ETHER START

Previous topic


DETROIT DIESEL DIAGNOSTIC LINK_1

 DETROIT DIESEL DIAGNOSTIC LINK

The Detroit Diesel Diagnostic Link®(DDDL) is a sophisticated PC software package supporting the setting up, maintenance and repair of engines using the DDEC V ECU. DDDL software contains a powerful trip-reporting program assisting fleet managers to effectively and efficiently run their operations. Additionally, time and money saving diagnostic and troubleshooting tools offered by DDDL allow mechanics and technicians to pinpoint opportunities to improve operations and identify problems quickly. The latest version of DDDL (4.2) has full diagnostic support for Series 60 EGR engines. For additional information, refer to the on-line Help within the program.

Next topic

CALIBRATION

Previous topic


 Deutsch Terminal Installation Guidelines

Deutsch connectors have wire seals molded into the connector. These connectors are push-to-seat connectors with cylindrical terminals.

NOTICE:
Improper selection and use of crimp tools have varying adverse effects on crimp geometry and effectiveness. Proper installation of terminals require specialized tools. Do not attempt to use alternative tools.
The crimp tool to use in Deutsch terminal installation is J 34182 (Kent-Moore part number).

NOTICE:
Terminal crimps must be made with the Deutsch crimp tool P/N: HDT-48-00 to assure gas tight connections.

NOTICE:
If a separate seal is required, be sure to install the seal onto the wire before stripping the insulation.
Use the following instructions for installing Deutsch terminals:

  1. Strip approximately 1/4 in. (6 mm) of insulation from the wire.

  2. Remove the lock clip, raise the wire gage selector, and rotate the knob to the number matching the gauge wire that is being used.

  3. Lower the selector and insert the lock clip.

  4. Position the terminal so that the crimp barrel is 1/32 of an inch above the four indenters. See Setting Wire Gage Selector and Positioning the Terminal. Crimp the wire.

  5. Grasp the terminal approximately one inch behind the terminal crimp barrel. Hold the connector with the rear grommet facing you. See Pushing Terminal Into Grommet.

  6. Push the terminal into the grommet until a positive stop is felt. See Pushing Terminal Into Grommet. A slight tug will confirm that it is properly locked into place. See Locking Terminal Into Connector.

Next topic

DEUTSCH TERMINAL REMOVAL

Previous topic


 Deutsch Terminal Removal

The appropriate size removal tool should be used when removing wires from connectors. The proper removal tools are listed in the following table.

Tool | Kent-Moore Part Number
Removing (12 AWG) | J 37451
Removing (16-18 AWG) | J 34513-1
Remove Deutsch terminals as follows:

  1. With the rear insert toward you, snap the appropriate size remover tool over the wire of the terminal to be removed. See Removal Tool Position.

  2. Slide the tool along the wire into the insert cavity until it engages and resistance is felt. Do not twist or insert tool at an angle. See Removal Tool Insertion.

  3. Pull terminal wire assembly out of the connector. Keep reverse tension on the wire and forward tension on the tool.

Next topic

ECU CONNECTOR WIRE INTO SHROUD INSTALLATION

Previous topic


 DIAGNOSING A DDEC SYSTEM FAULT

The following procedure is the starting point for diagnosing DDEC codes using the Diagnostic Data Reader (DDR).

Amber Warning Lamp

Perform the following steps to check the Amber Warning Lamp (AWL):

  1. Turn the ignition on while at the same time observing the Check/Stop Engine light (engine not running).

[a] If the AWL comes on and stays on, refer to Read Active Codes.

[b] If the AWL comes on for up to five seconds, and then turns off, refer to Read Inactive Codes.

[c] If the AWL does come on, but the condition of light is erratic or intermittent, refer to AMBER WARNING LAMP AND RED STOP LAMP FAULT.

[d] If the AWL does not come on, refer to INTERMITTENT FAULT and choose the appropriate symptom.

Next section

INTERMITTENT FAULT

Previous topic


 Diagnostic and Maintenance Functions

The following diagnostic and maintenance functions can be performed with DDDL.

Monitor a wide range of parameters while connected 'live' to the ECU.

Select a group of parameters and plot how they have varied over the last two minutes.

Take and save a snapshot of how the parameters vary over a period of time, so that you can replay the snapshot for detailed analysis.

Monitor fault codes as they occur while connected live to the ECU. You can also clear any inactive fault codes stored in the ECU.

Test for faults by checking the effect on performance of cutting out individual cylinders.

View the ECU output functions and set them to particular values to support troubleshooting. This can be particularly useful when troubleshooting electrical problems.

View engine and trip totals.

View the status of a set of maintenance monitors.

Next topic

USING THE SNAPSHOT FEATURE IN DDDL

Previous topic


 Diagnostic Codes

Start with the Menu Selection screen.

  1. To call up active codes:

[a] Select ENGINE and ENTER three times.

  2. To call up inactive codes:

[a] Select ENGINE and ENTER twice.

[b] Select INACTIVE CODES and ENTER.

  3. To clear codes:

[a] Select ENGINE and push ENTER twice.

[b] Go down and select CLEAR CODES and ENTER.

[c] Left to YES, and ENTER.

[d] Wait and then push FUNC three times.

[e] Go to lines 1 and 2 of the Engine Data List, Active and Inactive Codes, and verify that both lines display NO.


 Diagnostic Connector


Diagnostic Connector_1

 Diagnostic Connector


 DIAGNOSTIC REQUEST SWITCH INOPERATIVE

Before using this procedure, all basic mechanical checks and physical inspections should have been performed with no problem found. Also the diagnosis of the DDEC system in DIAGNOSING A DDEC SYSTEM FAULT referred you to this section.

Check Diagnostic Request Circuit

Perform the following steps to check the diagnostic request circuit:

  1. Turn ignition ON; engine not running.

  2. Plug in DDR.

  3. Select Switch/Light Status.

  4. Depress and hold diagnostic request switch.

  5. Observe the Diagnostic Request Status on the DDR.

[a] If the display reads ON, refer to Check Red Stop Lamp and Amber Warning Lamp Bulbs.

[b] If the display reads OFF, the diagnostic request line (V25) is open, or is not being grounded when the switch is depressed. Check the V24 wire and ground for diagnostic request switch. Repair the problem; refer to Verify Repairs.

[c] If no diagnostic request on the DDR input list, the ECU is not configured for diagnostic request operation. Refer to the DDEC Application and Installation manual, 7SA821.


 DIAGNOSTIC TOOLS

Different tools facilitate access to the programming and diagnostic capabilities of DDEC. The different tools are:

Vehicle Electronics Programming System (VEPS) gives OEMs the ability to reprogram the ECU (refer to VEHICLE ELECTRONIC PROGRAMMING SYSTEM)

Detroit Diesel Diagnostic Link (DDDL) software requests and receives engine data and diagnostic codes (refer to DETROIT DIESEL DIAGNOSTIC LINK)

DDEC Reprogramming System (DRS) gives the service person the ability to reprogram the ECU (refer to DDEC REPROGRAMMING SYSTEM)

DDEC Manuals contain necessary information for DDEC users (refer to DDEC MANUALS)

Next topic

VEHICLE ELECTRONIC PROGRAMMING SYSTEM

Previous topic


 Diagnostic Window


 Digital Diesel Sensor Stimulator, P/N: 23516937


 Dimensions of Electronic Control Unit with Connector Shrouds


 Driver Questionnaire

Ask the driver to answer the following questions before attempting to repair an intermittent problem, or a problem with symptoms but no diagnostic codes. Use this and the response guideline to these questions.

  1. How often does the problem occur? Can you and the driver take the vehicle and demonstrate the problem in a short time?

  2. Has the vehicle been to other shops for the same problem? If so, what was done there?

  3. Did the radio, dash gages, or lights momentarily turn OFF when the problem occurred?

  4. Does the problem occur only at specific operating conditions? If so, at what load? Is it light, medium, or heavy?

  5. Does the problem occur at a specific engine operating temperature? If so, at what engine temperature?

  6. Does the problem occur only when above or below specific outside temperatures? In what temperature range?

  7. Does the problem occur during other conditions e.g. during or after rain, spray washing, snow?

  8. Did the problem occur at a specific vehicle speed? If so, at what vehicle speed?

  9. Does the problem occur at specific engine r/min? If so, at what engine r/min?

Next topic

QUESTIONNAIRE RESPONSE GUIDELINE

Previous topic


 DRS Interface Module (Programming ECU)


 ECU


 ECU 68-pin Tyco Connector


 ECU AND SENSOR LOCATIONS

The engine-mounted Electronic Control Unit (ECU) (see Electronic Control Unit) includes control logic to provide overall engine management. The ECU continuously performs self-diagnostic checks and monitors other system components. System diagnostic checks are made at ignition-on and continue throughout all engine-operating modes.

The DDEC V ECU has two 68-pin Tyco connectors - one for the engine and the other for the vehicle.

DDEC V supports three independent data links. There are two links on the Vehicle Interface Harness (VIH). One link is based on SAE J1708, and the second is SAE J1939. The other link, on the Engine Harness, is CAN based and will be used for proprietary communications such as multi-ECU applications and DDC factory programming.

Connector shrouds protect the two 68-pin Tyco connectors (see Electronic Control Unit with Connector Shrouds).

See Dimensions of Electronic Control Unit with Connector Shrouds for the ECU outline and dimensions.

Next topic

CONNECTOR SHROUD

Previous topic


 ECU CONNECTOR WIRE INTO SHROUD INSTALLATION

The following procedures for using tape, ties, and conduit must be followed to ensure proper placement of the shroud over the ECU connectors:

  1. Use heavy electrical tape where wires exit conduit into the shroud (see Bottom View of Shroud, ECU Connector and Conduit, A).

  2. Use a tie strap to secure the shroud to the conduit and connector (see Bottom View of Shroud, ECU Connector and Conduit, B).

  3. Check that the conduit extends past the innermost ring on the shroud inlet. The conduit must extend this far (see Bottom View of Shroud, ECU Connector and Conduit, C).

  4. The two locking tabs in the shroud furthest from the wire inlet must be securely latched into the connector. The two tabs closest to the wire inlet should be snapped over the connector tabs (see Shroud Tabs).

  5. Ensure that the wires are not pinched between the connector and any of the shroud's protrusions during assembly (see Side View of Shroud, ECU Connector and Conduit, D).

Next topic

FCI APEX TERMINAL INSTALLATION AND REMOVAL

Previous topic


 ECU engine Harness connector

The EH 68 - pin Tyco connector pinout for the Series 60 are listed in the following tables.

Pin | Wire Color | Signal Type | Function
E-1 | Blk | PWM Output - Low Side | EGR Hydraulic Valve Control
E-2 | Wht | Analog Input - 1.5k Pull-up | Air Temp
E-3 | - | Analog Input - 51k Pull-down | Spare
E-4 | Blk | PWM Output - Low Side | VGT VPOD Control
E-5 | Yel | Analog Input - 1.5k Pull-up | Coolant Temp
E-6 | - | Analog Input - 51k Pull-down | Spare
E-7 | Tan | Analog Input - 1.5k Pull-up | Oil Temp
E-8 | - | PWM Output - Low Side | Spare
E-9 | Orn | Analog Input - 1.5k Pull-up | Fuel Temp
E-10 | - | Analog Input - 1.5k Pull-up | Spare
E-11 | - | PWM Output - Low Side | Spare
E-12 | Gra | Sensor Supply #3 | Sensor Supply
E-13 | - | Digital Output - Low Side | Spare
E-14 | Blk | Sensor Return #4 | Sensor Return
E-15 | Blk | Sensor Return #3 | Sensor Return
E-16 | Yel | Analog Input - 51k Pull-down | Fuel Restriction (MAS)
E-17 | Ppl | CMP Sensor (-) | CMP Sensor (-)
E-18 | Dk Grn | CMP Sensor (+) | CMP Sensor (+)
E-19 | Lt Blu | CKP Sensor (+) | CKP Sensor (+)
E-20 | Wht | CKP Sensor (-) | CKP Sensor (-)
E-21 | Dk Grn | Analog Input - 51k Pull-down | Oil Level (MAS)
E-22 | Dk Blu | Analog Input - 1.5k Pull-up | Turbo Compressor Out Temp
E-23 | - | Analog Input - 1.5k Pull-up | Spare
E-24 | - | Analog Input - 51k Pull-down | Spare
E-25 | - | Analog Input - 51k Pull-down | Spare
E-26 | Gra | Sensor Supply #4 | Sensor Supply
E-27 | - | Analog Input - 1.5k Pull-up | Spare
E-28 | - | Ground Pin | Spare
E-29 | - | Ground Pin | Spare
E-30 | - | Ground Pin | Spare
E-31 | Brn | Analog Input - 51k Pull-down | Oil Pressure
E-32 | - | Frequency Input (+) - Aux 3 | Spare
E-33 | - | Frequency Input (-) - Aux3 | Spare
E-34 | Blk | Frequency Input (-) - Aux2 | Turbo Speed Sensor ( - )
E-35 | Brn | Frequency Input (+) - Aux2 | Turbo Speed Sensor (+)
E-36 | - | Analog Input - 1.5k Pull-up | Spare
E-37 | Pnk | Analog Input - 51k Pull-down | Barometric Pressure
E-38 | - | Analog Input - 51k Pull-down | Spare
E-39 | Lt Grn | Analog Input - 51k Pull-down | Turbo Boost
E-40 | Dk Blue | CAN2 (+) | CAN2 (+)
E-41 | - | Analog Input - 51k Pull-down | Spare
E-42 | Blk | Ground Pin | VGT VPOD Gnd
E-43 | Blk | Ground Pin | EGR Rate Sensor Gnd
E-44 | - | Ground Pin | Spare
E-45 | - | Ground Pin | Spare
E-46 | Lt Grn | Digital Output - High Side | Switched Battery (+) - VGT
E-47 | - | Digital Output - High Side | Spare
E-48 | Red | Digital Output - High Side | Jake Med/High
E-49 | Orn | Digital Output - High Side | Jake Low
E-50 | - | Digital Output - High Side | Spare
E-51 | Yel | Digital Output - High Side | Switched Battery (+) - EGR
E-52 | Red | Digital Output - High Side | Switched Battery (+) - EGR Rate Sensor
E-53 | - | Digital Output - High Side | Spare
E-54 | Pnk | CAN2 (-) | CAN2 (-)
E-55 | Blk | CAN2S | CAN2 Shield
E-56 | - | Analog Input - 51k Pull-down | Spare
E-57 | - | Analog Input - HWOLS | No Connection
E-58 | - | Analog Input - 1.5k Pull-up | Spare
E-59 | - | RTC BATT+ | External RTC Battery (+)
E-60 | - | Ground Pin | Spare
E-61 | Wht | Injector High Common | S60 Common Cyl #1,2,3
E-62 | Wht | Injector High Common | S60 Common Cyl #4,5, 6
E-63 | Wht | Injector A - LO1 | S60 Cyl #1
E-64 | Wht | Injector A - LO2 | S60 Cyl #3
E-65 | Wht | Injector A - LO3 | S60 Cyl #2
E-66 | Wht | Injector B - LO1 | S60 Cyl #5
E-67 | Wht | Injector B - LO2 | S60 Cyl #6
E-68 | Wht | Injector B - LO3 | S60 cyl #4

The EH 68 - pin Tyco connector pinout for the Series 50 is listed in the following table.

Pin | Wire Color | Signal Type | Function
E-1 | Blk | PWM Output - Low Side | Switched Battery (-) - EGR On/Off
E-2 | Wht | Analog Input - 1.5k Pull-up | Air Temp
E-3 | - | Analog Input - 51k Pull-down | Spare
E-4 | Blk | PWM Output - Low Side | VGT VPOD Control
E-5 | Yel | Analog Input - 1.5k Pull-up | Coolant Temp
E-6 | - | Analog Input - 51k Pull-down | Spare
E-7 | Tan | Analog Input - 1.5k Pull-up | Oil Temp
E-8 | - | PWM Output - Low Side | Spare
E-9 | Orn | Analog Input - 1.5k Pull-up | Fuel Temp
E-10 | - | Analog Input - 1.5k Pull-up | Spare
E-11 | - | PWM Output - Low Side | Spare
E-12 | Gra | Sensor Supply #3 | Sensor Supply
E-13 | - | Digital Output - Low Side | Spare
E-14 | Blk | Sensor Return #4 | Sensor Return
E-15 | Blk | Sensor Return #3 | Sensor Return
E-16 | Yel | Analog Input - 51k Pull-down | Fuel Restriction (MAS)
E-17 | Ppl | CMP Sensor (-) | CMP Sensor (-)
E-18 | Dk Grn | CMP Sensor (+) | CMP Sensor (+)
E-19 | Lt Blu | CKP Sensor (+) | CKP Sensor (+)
E-20 | Wht | CKP Sensor (-) | CKP Sensor (-)
E-21 | - | Analog Input - 51k Pull-down | Oil Level (MAS)
E-22 | Dk Blu | Analog Input - 1.5k Pull-up | Spare
E-23 | - | Analog Input - 1.5k Pull-up | Spare
E-24 | - | Analog Input - 51k Pull-down | Spare
E-25 | - | Analog Input - 51k Pull-down | Spare
E-26 | Gra | Sensor Supply #4 | Sensor Supply
E-27 | - | Analog Input - 1.5k Pull-up | Spare
E-28 | - | Ground Pin | Spare
E-29 | - | Ground Pin | Spare
E-30 | - | Ground Pin | Spare
E-31 | Brn | Analog Input - 51k Pull-down | Oil Pressure
E-32 | - | Frequency Input (+) - Aux 3 | Spare
E-33 | - | Frequency Input (-) - Aux3 | Spare
E-34 | Blk | Frequency Input (-) - Aux2 | Turbo Speed Sensor ( - )
E-35 | Brn | Frequency Input (+) - Aux2 | Turbo Speed Sensor (+)
E-36 | - | Analog Input - 1.5k Pull-up | Spare
E-37 | Pnk | Analog Input - 51k Pull-down | Spare
E-38 | - | Analog Input - 51k Pull-down | Spare
E-39 | Lt Grn | Analog Input - 51k Pull-down | Turbo Boost
E-40 | Dk Blu | CAN2 (+) | CAN2 (+)
E-41 | - | Analog Input - 51k Pull-down | Spare
E-42 | - | Ground Pin | Spare
E-43 | - | Ground Pin | Spare
E-44 | - | Ground Pin | Spare
E-45 | - | Ground Pin | Spare
E-46 | Lt Grn | Digital Output - High Side | Switched Battery (+) - VGT
E-47 | Lt Blu | Digital Output - High Side | Spare
E-48 | Red | Digital Output - High Side | Jake Med/High
E-49 | Orn | Digital Output - High Side | Jake Low
E-50 | Red | Digital Output - High Side | Battery (+) Supply EGR Rate Sensor
E-51 | Yel | Digital Output - High Side | EGR On/Off Control
E-52 | - | Digital Output - High Side | Spare
E-53 | - | Digital Output - High Side | Spare
E-54 | Pnk | CAN2 (-) | CAN2 (-)
E-55 | - | CAN2S | CAN2 Shield
E-56 | - | Analog Input - 51k Pull-down | Spare
E-57 | - | Analog Input - 51k Pull-down | Spare
E-58 | - | Analog Input - 1.5k Pull-up | Spare
E-59 | NA | RTC BATT+ | External RTC Battery (+)
E-60 | Wht | No Connection | No Connection
E-61 | Wht | Injector High Common | S50 Common Cyl #1,4
E-62 | Wht | Injector High Common | S50 Common Cyl #2,3
E-63 | Wht | Injector A - LO1 | S50 Cyl #1
E-64 | Wht | Injector A - LO2 | S50 Cyl #4
E-65 | Wht | Injector A - LO3 | Spare
E-66 | Wht | Injector B - LO1 | S50 Cyl #3
E-67 | Wht | Injector B - LO2 | S50 Cyl #2
E-68 | Wht | Injector B - LO3 | Spare

The 68 - pin connector part numbers are listed in the following table.

Description | DDC Part Number | Tyco Part Number
Engine Harness Connector Assembly | 23528253 | 776315-2
Shroud | 23532347 | 776501-1
Shroud Screws (M6x1.0x12mm Torx Socket Head) | 23531065 | -
14 AWG Terminal (Large) (Terminal only) | 23528272 | 776093-1
18 AWG Terminal (Standard) (Terminal only) | 23528271 | 776326-4
14 AWG Terminal (Large) (crimped with 12 in. wire) | 23528255 | --
18 AWG Terminal (Standard) (crimped with 12 in. wire) | 23528254 | -
Cavity Plug | 23528274 | 776364

The 68-pin connector center screw must be torqued to 50 in·lb (5.6 N·m)

The shroud is required to protect the connectors from dirt and direct spray and to route the wires in the correct orientation.

If a replacement wire and/or terminal is required, the wires will arrive assembled with the terminals crimped on the wires (see 68 Pin Connector Wires and Terminals).

Next topic

DATA LINK CONNECTOR

Previous topic


 ECU Engine Harness Connector


 ECU Label


 ECU Programming

The ECU Label is attached to the ECU.

Every DDEC system engine serial number has its own file in the DDC Mainframe.

NOTICE: Failure to match the serial number on the engine with the ECU programming may result in incorrect calibration results and engine damage.

ECU programming must be done to match the serial number you are currently working on. Failure to do so may result in incorrect calibration and engine damage.

Programming a DDEC V ECU must be done with an engine file set up for the DDEC V system.

For a summary of features and how to change them, refer to DDEC ECU SOFTWARE FEATURES.

Next topic

OPERATOR INFORMATION

Previous topic


 ECU REPLACEMENT WARNING

Unintended engine startup, acceleration, or shutdown could cause personal injury or death.
This ECU is programmed for specific options. replacing this ECU with one that has not been programmed with these exact options could have unintended results.
Only replace with an ECU that has the identical inputs and outputs programmed.
Next topic

SOFTWARE UPGRADES

Previous topic


 ECU Vehicle Harness Connector


ECU Vehicle Harness Connector_1

 ECU Vehicle Harness Connector


 ECU Vehicle interface Harness connector

The VIH 68 - pin Tyco connector pinout for the Series 60 is listed in the following table.

Pin | Wire Color | Signal Type | Function | Req/Typical
V-1 | Dk Grn/Blk | Digital Output - Low Side | AWL | Required
V-2 | Blk/Yel | Digital Output - Low Side | RSL | Required
V-3 | Wht/Dk Grn | Analog Input - 1.5k Pull-up | Service Brake Released | Required
V-4 | Blk/Lt Blu | Digital Output - Low Side | Fan Control #1 | Typical: Fan
V-5 | Blk/Lt grn | Digital Output - Low Side | Top2 Shift Solenoid | Typical: Top2
V-6 | Blk/Orn | Digital Output - Low Side | Top2 Lockout Solenoid | Typical: Top2
V-7 | Blk/Wht | Digital Output - Low Side | Vehicle Power Shtdn | Typical
V-8 | Wht/Orn | Analog Input - 1.5k Pull-up | Resume/Accel | Typical: CC
V-9 | Ppl/Wht | Analog Input - 1.5k Pull-up | Cruise Enable | Typical: CC
V-10 | Lt Grn/Wht | Analog Input - 1.5k Pull-up | Clutch Released | Typical: CC
V-11 | Yel/Red | Sensor Supply #1 | Sensor Supply #1 | Required
V-12 | Wht/ Red | Sensor Supply #2 | Sensor Supply #2 | Required
V-13 | Lt Blu/Yel | Analog Input - 300k Pull-down | Throttle Position | Required
V-14 | Ppl/Yel | Analog Input - 300k Pull-down | VSG | Typical
V-15 | Pnk | Ignition | Ignition | Required
V-16 | Red/Wht | Analog Input - 1.5k Pull-up | Idle Validation | Required
V-17 | Lt Blu/ Orn | Frequency Input (+) VSS | Vehicle Speed (+) | Required
V-18 | Lt Blu/ Blk | Frequency Input (-) VSS | Vehicle Speed (-) | Required
V-19 | - | No Connection | No Connection | No Conn
V-20 | - | No Connection | No Connection | No Conn
V-21 | - | No Connection | No Connection | No Conn
V-22 | Yel/Lt Blu | Analog Input - 51k Pull-down | Air Filter Restriction | Typical: MAS
V-23 | Yel/Dk Grn | Analog Input - 1.5k Pull-up | Exhaust Temp (Bus/Coach) | Typical
V-24 | Dk Grn/Wht | Analog Input - 1.5k Pull-up | SEO/Diag Request | Required
V-25 | Grey/Wht | Analog Input - 1.5k Pull-up | A/C Status | Typical: Fan
V-26 | Yel/Lt Grn | Analog Input - 1.5k Pull-up | Engine Brake Disable | -
V-27 | Yel/Wht | Analog Input - 1.5k Pull-up | Turbo Compressor In Temp | Required
V-28 | - | No Connection | No Connection | No Conn
V-29 | Wht/Yel | Analog Input - 51k Pull-down | Exhaust Back Press or Water Pump Press or Air Compressor Press | Typical
V-30 | - | No Connection | No Connection | No Conn
V-31 | Tan | Frequency Output | Tachometer | Typical
V-32 | Dk Blu/Orn | Frequency Input (+) Aux 1 | Fan Speed (+) | -
V-33 | Dk Blu/Blk | Frequency Input (-) Aux 1 | Fan Speed (-) | -
V-34 | - | No Connection | No Connection | No Conn
V-35 | - | No Connection | No Connection | No Conn
V-36 | - | No Connection | No Connection | No Conn
V-37 | Orn/Yel | Analog Input - 120K Pull-up | Add Coolant Level | Typical: MAS
V-38 | Lt Gr/Yel | Analog Input - 120K Pull-up | Coolant Level Shtdn | Required
V-39 | Lt Blu/Wht | Analog Input - 1.5K Pull-up | Engine Brake Low | Typical: Jake
V-40 | Orn/Blk | Digital Output - Low Side | OI Alarm | Typical: OI
V-41 | Dk Grn/Yel | Analog Input - 1.5K Pull-up | Aux Shtdn #1 | -
V-42 | Grey/Yel | Analog Input - 1.5K Pull-up | OI Thermostat | Typical: OI
V-43 | Dk Blu/Red | J1939+ | J1939+ | Required
V-44 | Dk Blu/Yel | J1939S | J1939 Shield | Required
V-45 | - | No Connection | No Connection | No Conn
V-46 | Dk Grn/Brn | PWM Output - Low Side | Variable Speed Fan | -
V-47 | Wht/Lt Blu | Analog Input - 1.5k Pull-up | Set/Coast | Typical; CC
V-48 | Tan/ Yel | Analog Input - 1.5k Pull-up | Throttle Inhibit | -
V-49 | Pink/Wht | Analog Input - 1.5k Pull-up | Fan Control Override | Typical
V-50 | Tan/ Wht | Analog Input - 1.5k Pull-up | Park Brake | Typical
V-51 | Dk Blu/Wht | Analog Input - 1.5k Pull-up | Engine Brake Medium | Typical: Jake
V-52 | Dk Grn/Orn | PMW Output Low Side | Trans % Load | -
V-53 | Blk/Red | Digital Output - Low Side | Ether Start | -
V-54 | Blk/Pnk | Digital Output - Low Side | OI Starter | Typical: OI
V-55 | Lt Grn/Blk | Digital Output - Low Side | OI Active Lamp | Typical: OI
V-56 | Dk Grn/ Grey | J1587 + | J1587 + | Required
V-57 | Dk Grn | J1587 - | J1587 - | Required
V-58 | Dk Blu | J1939 - | J1939 - | Required
V-59 | Dk Blu | Sensor Return #2 | Sensor Return | Required
V-60 | Yel/ Blk | Sensor Return #1 | Sensor Return | Required
V-61 | Red/Blk | Battery + | +12V / +24V | Required
V-62 | Red/ Lt Blu | Battery + | +12V / +24V | Required
V-63 | Brn/Blk | Battery - | Ground | Required
V-64 | Brn/ Lt Grn | Battery - | Ground | Required
V-65 | Red/ Lt Grn | Battery + | +12V / +24V | Required
V-66 | Red/ Pnk | Battery + | +12V / +24V | Required
V-67 | Brn/Wht | Battery - | Ground | Required
V-68 | Brn/Yel | Battery - | Ground | Required

The VIH 68 - pin Tyco connector pinout for the Series 50 is listed in the following table.

Pin | Wire Color | Signal Type | Function | Req/Typical
V-1 | Dk Grn/Blk | Digital Output - Low Side | AWL | Required
V-2 | Blk/Yel | Digital Output - Low Side | RSL | Required
V-3 | Wht/Dk Grn | Analog Input - 1.5k Pull-up | Service Brake Released | Required
V-4 | Blk/Lt Blu | Digital Output - Low Side | Fan Control #1 | Typical: Fan
V-5 | Blk/Lt grn | Digital Output - Low Side | Top2 Shift Solenoid | Typical: Top2
V-6 | Blk/Orn | Digital Output - Low Side | Top2 Lockout Solenoid | Typical: Top2
V-7 | Blk/Wht | Digital Output - Low Side | Vehicle Power Shtdn | Typical
V-8 | Wht/Orn | Analog Input - 1.5k Pull-up | Resume/Accel | Typical: CC
V-9 | Ppl/Wht | Analog Input - 1.5k Pull-up | Cruise Enable | Typical: CC
V-10 | Lt Grn/Wht | Analog Input - 1.5k Pull-up | Clutch Released | Typical: CC
V-11 | Yel/Red | Sensor Supply #1 | Sensor Supply #1 | Required
V-12 | Wht/ Red | Sensor Supply #2 | Sensor Supply #2 | Required
V-13 | Lt Blu/Yel | Analog Input - 300k Pull-down | Throttle Position | Required
V-14 | Ppl/Yel | Analog Input - 300k Pull-down | VSG | Typical
V-15 | Pnk | Ignition | Ignition | Required
V-16 | Red/Wht | Analog Input - 1.5k Pull-up | Idle Validation | Required
V-17 | Lt Blu/ Orn | Frequency Input (+) VSS | Vehicle Speed (+) | Required
V-18 | Lt Blu/ Blk | Frequency Input (-) VSS | Vehicle Speed (-) | Required
V-19 | - | No Connection | No Connection | No Conn
V-20 | - | No Connection | No Connection | No Conn
V-21 | - | No Connection | No Connection | No Conn
V-22 | Yel/Lt Blu | Analog Input - 51k Pull-down | Air Filter Restriction | Typical: MAS
V-23 | Yel/Dk Grn | Analog Input - 1.5k Pull-up | Exhaust Temp | Typical
V-24 | Dk Grn/Wht | Analog Input - 1.5k Pull-up | SEO/Diag Request | Required
V-25 | Grey/Wht | Analog Input - 1.5k Pull-up | A/C Status | Typical: Fan
V-26 | Yel/Lt Grn | Analog Input - 1.5k Pull-up | Engine Brake Disable | Typical
V-27 | Yel/Wht | Analog Input - 1.5k Pull-up | Spare |
V-28 | - | No Connection | No Connection | No Conn
V-29 | Wht/Yel | Analog Input - 51k Pull-down | Exhaust Back Pressure | Typical
V-30 | - | No Connection | No Connection | No Conn
V-31 | Tan | Frequency Output | Tachometer | Typical
V-32 | Dk Blu/Orn | Frequency Input (+) Aux 1 | Fan Speed (+) | -
V-33 | Dk Blu/Blk | Frequency Input (-) Aux 1 | Fan Speed (-) | -
V-34 | - | No Connection | No Connection | No Conn
V-35 | - | No Connection | No Connection | No Conn
V-36 | - | No Connection | No Connection | No Conn
V-37 | Orn/Yel | Analog Input - 120K Pull-up | Add Coolant Level | Typical: MAS
V-38 | Lt Gr/Yel | Analog Input - 120K Pull-up | Coolant Level Shtdn | Required
V-39 | Lt Blu/Wht | Analog Input - 1.5K Pull-up | Engine Brake Low | Typical: Jake
V-40 | Orn/Blk | Digital Output - Low Side | OI Alarm | Typical: OI
V-41 | Dk Grn/Yel | Analog Input - 1.5K Pull-up | Aux Shtdn #1 | -
V-42 | Grey/Yel | Analog Input - 1.5K Pull-up | OI Thermostat | Typical: OI
V-43 | Dk Blu/Red | J1939+ | J1939+ | Required
V-44 | Dk Blu/Yel | J1939S | J1939 Shield | Required
V-45 | - | No Connection | No Connection | No Conn
V-46 | Dk Grn/Brn | PWM Output - Low Side | Variable Speed Fan | -
V-47 | Wht/Lt Blu | Analog Input - 1.5k Pull-up | Set/Coast | Typical; CC
V-48 | Tan/ Yel | Analog Input - 1.5k Pull-up | Throttle Inhibit | Typical
V-49 | Pink/Wht | Analog Input - 1.5k Pull-up | Fan Control Override | Typical
V-50 | Tan/ Wht | Analog Input - 1.5k Pull-up | Park Brake | Typical
V-51 | Dk Blu/Wht | Analog Input - 1.5k Pull-up | Engine Brake Medium | Typical: Jake
V-52 | Dk Grn/Orn | PMW Output Low Side | Trans % Load | -
V-53 | Blk/Red | Digital Output - Low Side | Ether Start | -
V-54 | Blk/Pnk | Digital Output - Low Side | OI Starter | Typical: OI
V-55 | Lt Grn/Blk | Digital Output - Low Side | OI Active Lamp | Typical: OI
V-56 | Dk Grn/ Grey | J1587 + | J1587 + | Required
V-57 | Dk Grn | J1587 - | J1587 - | Required
V-58 | Dk Blu | J1939 - | J1939 - | Required
V-59 | Dk Blu | Sensor Return #2 | Sensor Return | Required
V-60 | Yel/ Blk | Sensor Return #1 | Sensor Return | Required
V-61 | Red/Blk | Battery + | +12V / +24V | Required
V-62 | Red/ Lt Blu | Battery + | +12V / +24V | Required
V-63 | Brn/Blk | Battery - | Ground | Required
V-64 | Brn/ Lt Grn | Battery - | Ground | Required
V-65 | Red/ Lt Grn | Battery + | +12V / +24V | Required
V-66 | Red/ Pnk | Battery + | +12V / +24V | Required
V-67 | Brn/Wht | Battery - | Ground | Required
V-68 | Brn/Yel | Battery - | Ground | Required

The 68-pin VIH-to-ECU connector part numbers are listed in the following table.

Description | DDC Part Number | Tyco Part Number
Engine Harness Connector Assembly | 23528253 | 776315-2
Shroud | 23532347 | 776501-1
Shroud Screws (M6x1.0x12mm Torx Socket Head) | 23531065 | -
14 AWG Terminal (Large) (Terminal only) | 23528272 | 776093-1
18 AWG Terminal (Standard) (Terminal only) | 23528271 | 776326-4
14 AWG Terminal (Large) (crimped with 12 in. wire) | 23528255 | --
18 AWG Terminal (Standard) (crimped with 12 in. wire) | 23528254 | -
Cavity Plug | 23528274 | 776364
The 68-pin connector center screw must be torqued to 50 in·lb (5.6 N·m)

The shroud is required to protect the connectors from dirt and direct spray and to route the wires in the correct orientation.

If a replacement wire and/or terminal is required, the wires will arrive assembled with the terminals crimped on the wires (see 68 Pin Connector Wires and Terminals).

Next topic

ECU ENGINE HARNESS CONNECTOR

Previous topic


 ECU-to-Input / Sensor Return


 EGR Delta P Sensor


 EGR Delta-Pressure Sensor Wiring


 EGR Rate Sensor Schematic


 EGR Temperature Sensor


 EGR Temperature Sensor Wiring


 EGR Valve Assembly with Oil Lines

EGR Valve and Actuator Assembly
         3.
         Oil Outlet Hose and Fitting

Oil Inlet Hose and Fitting


 EGR Valve Coil Wiring


 ELECTRICAL CIRCUITS

Before using this manual, you should understand the theory of electricity and know the meaning of voltage and ohms. You should understand what happens in a circuit with an open or shorted wire. You should be able to read and understand a wiring diagram.

You should be able to use jumper wires to make circuit checks.

Next topic

USE OF DIGITAL VOLT-OHM METER

Previous topic


 Electronic Control Module Vehicle Harness Connector


 Electronic Control Unit

The engine-mounted Electronic Control Unit includes control logic to provide overall engine management. The ECU continuously performs self-diagnostic checks and monitors other system components. System diagnostic checks are made at ignition-on and continue throughout all engine-operating modes. See Electronic Control Unit.

The DDEC V ECU has two 68-pin Tyco connectors - one for the engine and the other for the vehicle.

DDEC V supports three independent data links. There are two links on the Vehicle Interface Harness (VIH). One link is based on SAE J1708, and the second is SAE J1939. The other link, on the Engine Harness, is Controller Area Network CAN based and will be used for proprietary communications such as multi-ECU applications and DDC factory programming.

Connector shrouds protect the two 68-pin Tyco connectors. See Electronic Control Unit with Connector Shrouds.

Next topic

DDEC RELATED PUBLICATIONS

Previous topic


Electronic Control Unit_1

 Electronic Control Unit


 Electronic Control Unit Connector Shroud


 Electronic Control Unit with Connector Shrouds


 Electronic Fire Commander Harness


 Engine Brake Harness Schematic


 ENGINE BRAKE INOPERATIVE

The following procedure will troubleshoot DDEC controlled Engine Brake Inoperative.

Engine Brake Inoperative

Perform the following steps to troubleshoot the inoperative engine brake:

  1. Turn ignition ON.

  2. Plug in DDR.

  3. View Diagnostic Data List to see if the correct application is programmed into the ECU.

  4. Next to Engine Brake, the display should read ON or OFF. If it reads N/A, the DDC mainframe must be changed and the ECU must be reprogrammed after the change is made.

  5. If the ECU is correctly configured, go to the view calibration area with the DDR and check to ensure that the two required inputs (Engine Brake Low and Engine Brake Medium) are configured.

  6. If the inputs are not configured, or incorrectly configured, this must be corrected using the DDEC reprogramming station.

  7. If the inputs are configured correctly, print or write down the inputs and outputs for future reference. Refer to Check Switches. Refer to the appropriate Application and Installation manual for engine brake operation.


 Engine Brake (Jake Brake)

Enabling the engine brake is done on the mainframe. Once turned on, output cavities S3 and T3 are automatically configured to provide voltage to the brake solenoids when the ECU calibrated parameters are met allowing activation.

Also requires two inputs, engine brake low and engine brake med.

Several options are available (programming station or DDR set) relative to engine brake operations:

Dynamic Fan Braking

Enables the cooling fan whenever the engine brake is in high mode. This feature is able to be configured with the programming station or DDR. (DDR software level 2.0 or higher.)

Engine Brake / Service Brake

This feature forces the operator to, in addition to the normal requirements, press the service brake in order to initiate the engine brake(s). Can be set with the DDR or programming station.

Engine Brake Minimum MPH

This feature allows the customer to set a minimum mph to allow the engine brake to activate. Can be set with the DDR or programming station.

Engine Brake Cruise

Allows engine brakes to activate to programmed levels automatically based on vehicle speed increases. Initial speed is low. The speed of the increments is medium, then high. Level (high, med, low) is limited by dash position switch.

Can be set with the DDR or programming station.

Next topic

ENGINE PROTECTION FEATURES

Previous topic


 Engine Coolant Level Sensor


 Engine Coolant Level Sensor and Circuits


Engine Coolant Level Sensor (ECL)

 Engine Coolant Level Sensor

The Engine Coolant Level sensor, ECL, is required for DDEC V installations. Its purpose is to provide an input to the engine protection system and warn the operator if a low coolant level has been reached. Other non-DDC supplied engine coolant level sensors may be used but may require the use of a signal interface.

The main component of the ECL sensor consists of a conductivity probe, that connects to the ECU; see Engine Coolant Level Sensor Specifications.

NOTICE: The probe has an operational temperature range of -40 to 257°F (-40 to 125°C). Exposure to temperatures beyond this range may result in unacceptable component life, or degraded sensor accuracy.

Next topic

ELECTRONIC CONTROL UNIT

Previous topic


 Engine Coolant Level Sensor Specifications


 Engine Coolant Temperature Sensor

The Engine Coolant Temperature sensor, ECT, is a thermistor type sensor that has a variable resistance, when exposed to different temperatures. The ECT Sensor senses coolant temperature.

See Engine Coolant Temperature Sensor - Series 60 and Series 50 Engines for the ECT sensor.

Next topic

ENGINE OIL LEVEL SENSOR

Previous topic


 Engine Coolant Temperature Sensor - Series 60 and Series 50 Engines


 ENGINE CRANKS BUT WILL NOT START

The following procedures will diagnose engine cranks but will not start.

Amber Warning Lamp

Perform the following steps to check the AWL:

  1. Turn ignition on while observing the Check/Red Stop Lamp.

[a] If the light comes on and stays on, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[b] If the light comes on for up to five seconds, and then goes off, refer to Fuel Check.

[c] If the lights are off, refer to Check DDEC Fuses.


 ENGINE EXHAUST

Consider the following before servicing engines:

Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.
Always start and operate an engine in a well ventilated area.
If operating an engine in an enclosed area, vent the exhaust to the outside.
Do not modify or tamper with the exhaust system or emission control system.

Next topic

ECU REPLACEMENT WARNING

Previous topic


 Engine Fuel Restriction Sensor


 Engine Harness

The Engine Harness (EH) is installed at the factory and is delivered connected to all engine sensors, the fuel injection system, and the ECU.

See Series 60 EGR Engine Senors for the location of the Series 60 EGR engine sensors.

The EH 68 - pin Tyco connector pinout for the Series 60 are listed in the following tables.

Pin Wire | Color | Signal Type | Function
E-1 | Blk | PWM Output - Low Side | EGR Hydraulic Valve Control
E-2 | Wht | Analog Input - 1.5k Pull-up | Air Temp
E-3 | - | Analog Input - 51k Pull-down | Spare
E-4 | Blk | PWM Output - Low Side | VGT VPOD Control
E-5 | Yel | Analog Input - 1.5k Pull-up | Coolant Temp
E-6 | - | Analog Input - 51k Pull-down | Spare
E-7 | Tan | Analog Input - 1.5k Pull-up | Oil Temp
E-8 | - | PWM Output - Low Side | Spare
E-9 | Orn | Analog Input - 1.5k Pull-up | Fuel Temp
E-10 | - | Analog Input - 1.5k Pull-up | Spare
E-11 | - | PWM Output - Low Side | Spare
E-12 | Gra | Sensor Supply #3 | Sensor Supply
E-13 | - | Digital Output - Low Side | Spare
E-14 | Blk | Sensor Return #4 | Sensor Return
E-15 | Blk | Sensor Return #3 | Sensor Return
E-16 | Yel | Analog Input - 51k Pull-down | Fuel Restriction (MAS)
E-17 | Ppl | CMP Sensor (-) | CMP Sensor (-)
E-18 | Dk Grn | CMP Sensor (+) | CMP Sensor (+)
E-19 | Lt Blu | CKP Sensor (+) | CKP Sensor (+)
E-20 | Wht | CKP Sensor (-) | CKP Sensor (-)
E-21 | Dk Grn | Analog Input - 51k Pull-down | Oil Level (MAS)
E-22 | Dk Blu | Analog Input - 1.5k Pull-up | Turbo Compressor Out Temp
E-23 | - | Analog Input - 1.5k Pull-up | Spare
E-24 | - | Analog Input - 51k Pull-down | Spare
E-25 | - | Analog Input - 51k Pull-down | Spare
E-26 | Gra | Sensor Supply #4 | Sensor Supply
E-27 | - | Analog Input - 1.5k Pull-up | Spare
E-28 | - | Ground Pin | Spare
E-29 | - | Ground Pin | Spare
E-30 | - | Ground Pin | Spare
E-31 | Brn | Analog Input - 51k Pull-down | Oil Pressure
E-32 | - | Frequency Input (+) - Aux 3 | Spare
E-33 | - | Frequency Input (-) - Aux3 | Spare
E-34 | Brn | Frequency Input (-) - Aux2 | Turbo Speed Sensor (+)
E-35 | Blk | Frequency Input (+) - Aux2 | Turbo Speed Sensor (-)
E-36 | - | Analog Input - 1.5k Pull-up | Spare
E-37 | Pnk | Analog Input - 51k Pull-down | Barometric Pressure
E-38 | - | Analog Input - 51k Pull-down | Spare
E-39 | Lt Grn | Analog Input - 51k Pull-down | Turbo Boost
E-40 | Dk Blue | CAN2 (+) | CAN2 (+)
E-41 | - | Analog Input - 51k Pull-down | Spare
E-42 | Bk | Ground Pin | VGT VPOD Gnd
E-43 | Bk | Ground Pin | EGR Rate Sensor Gnd
E-44 | - | Ground Pin | Spare
E-45 | - | Ground Pin | Spare
E-46 | Lt Grn | Digital Output - High Side | Switched Battery (+) - VGT
E-47 | - | Digital Output - High Side | Spare
E-48 | Red | Digital Output - High Side | Jake Med/High
E-49 | Orn | Digital Output - High Side | Jake Low
E-50 | - | Digital Output - High Side | Spare
E-51 | Yel | Digital Output - High Side | Switch Battery (+) - EGR
E-52 | Red | Digital Output - High Side | Switched Battery (+) -EGR Rate Sensor
E-53 | - | Digital Output - High Side | Spare
E-54 | Pnk | CAN2 (-) | CAN2 (-)
E-55 | Blk | CAN2S | CAN2 Shield
E-56 | - | Analog Input - 51k Pull-down | Spare
E-57 | - | Analog Input - HWOLS | No Connection
E-58 | - | Analog Input - 1.5k Pull-up | Spare
E-59 | - | RTC BATT+ | External RTC Battery (+)
E-60 | - | Ground Pin | Spare
E-61 | Wht | Injector High Common | S60 Common Cyl #1,2,3
E-62 | Wht | Injector High Common | S60 Common Cyl #4,5,6
E-63 | Wht | Injector A - LO1 | S60 Cylinder #1
E-64 | Wht | Injector A - LO2 | S60 Cylinder #3
E-65 | Wht | Injector A - LO3 | S60 Cylinder #2
E-66 | Wht | Injector B - LO1 | S60 Cylinder #5
E-67 | Wht | Injector B - LO2 | S60 Cylinder #6
E-68 | Wht | Injector B - LO3 | S60 Cylinder #4

Next topic

BASIC KNOWLEDGE REQUIRED

TESTING / SERVICE TOOLS / TIPS

Previous topic


 Engine Harness Connector


 Engine Harness Connector to Synchronous Reference Sensor


 Engine Harness Connector to Synchronous Sensor


 Engine Harness Connector to Air Filter Restriction Sensor


 Engine Harness Connector to Oil Pressure Sensor


 Engine Harness Connector to Timing Reference Sensor


 Engine Harness Connector to Turbo Boost Sensor


 Engine Harness to Air Temperature Sensor Connector


 Engine Oil Level Sensor

The Engine Oil Level sensor, EOL, is factory installed at DDC and is incorporated into the DDC Engine Harness for applicatins which have the Maintenance Alert system (MAS). See Engine Oil Level Sensor - Series 60 and Series 50 Engines.

Next topic

ENGINE OIL PRESSURE SENSOR

Previous topic


 Engine Oil Level Sensor - Series 60 and Series 50 Engines


 Engine Oil Pressure Sensor

The Engine Oil Pressure sensor, EOP, is a variable capacitance sensor that produces a linear analog signal, indicating engine oil pressure. See Engine Oil Pressure Sensor - Series 60 and Series 50 Engines.

Next topic

ENGINE OIL TEMPERATURE SENSOR

Previous topic


Engine Oil Pressure Sensor_1

 Engine Oil Pressure Sensor


 Engine Oil Pressure Sensor - Series 60 and Series 50 Engines


 Engine Oil Temperature Sensor

The Engine Oil Temperature sensor, EOT, is a thermistor type sensor that has a variable resistance, when exposed to different temperatures. See Engine Oil Temperature Sensor - Series 60 and Series 50 Engines.

The ECU uses the EOT sensor signal to determine the quantity and timing of fuel required to optimize starting over a range of temperatures. The EOT Sensor provides a signal to vary idle speed and injection timing resulting in improved cold starts and reduced white smoke. It also activates the engine protection, if the oil temperature exceeds the specified limits.

Next topic

FUEL RESTRICTION SENSOR

Previous topic


 Engine Oil Temperature Sensor - Series 60 and Series 50 Engines


 Engine Protection Features

Engine protection features can be set with the DDR or programming station. Three features are available:

Shutdown

Rampdown

Warning

Next topic

ENGINE SYNCHRO SHIFT

Previous topic


 ENGINE SENSOR HARNESS

DESCRIPTION OF ENGINE SENSOR HARNESS

Referral to this section indicates a fault within the Engine Sensor Harness affecting signals of various sensors used by the DDEC system.


 Engine Synchro Shift

Engine Synchro Shift™ (ESS) can be set with the programming station. ESS is a joint development between DDC and Rockwell.

The ESS system automatically synchronizes the transmission by matching the engine r/min speed to the road speed of the vehicle, eliminating the need to use the clutch pedal for shifting gears.

Refer to publication number 6SE498, Engine Synchro Shift (ESS) Troubleshooting Manual.

Requires an ESS transmission type, two inputs (in gear and in neutral), and two outputs (high range solenoid and low range solenoid).

Next topic

ETHER START

Previous topic


 ENGINE WIRING SCHEMATICS

INJECTOR HARNESS WIRING SCHEMATIC

Series 60 Injector Harness with Jake Brake

EGR Rate Sensor Schematic

Speed Sensors Schematic

Pressure Sensors Schematic

Temperature Sensors Schematic

VPOD, Injector, and MAS Schematic

VPOD, Coolant, Oil Temperature, EGR, and VNT VPOD Schematic


 Environmental Conditions

The following environmental conditions must be considered.

Temperature

The ambient operating temperature range is -40°F (-40°C) minimum and 221°F (105°C) maximum.

Atmospheric Pressure

The engine-mounted ECU can withstand atmospheric pressures ranging from 62.0 to 120 kPa absolute that result from altitude and weather changes in the operating and non-operating conditions.

Water Intrusion

The ECU can be exposed to steam cleaning and pressure washing. Care should be taken not to pressure spray the connectors.

Next topic

ENGINE HARNESS

Previous topic


 ERRATIC PERFORMANCE AND NO CODES

The following troubleshooting chart resolves erratic performance and no codes displayed. For troubleshooting procedures, refer to the appropriate engine service manual.

Check the following symptoms to determine possible fault, listed in the following table.

Symptom | Possible Fault
Cannot get full power. | Plugged fuel filters. Hose not connected to Turbo Boost Sensor. Verify injector calibration(s) are correct.
Cannot get full throttle. | Mis-calibrated Throttle Position Sensor.
Runs rough; misses and occasionally stalls. | Improper gapping of Timing Reference and Synchronous Reference Sensor. Fuel leaks. Loose battery power, ignition or ground wires Injector failure. Vehicle speed sensor failure. Injector harness failure.
Engine idles high after warm-up or hangs. | Incorrect calibration of the Automotive Limiting Speed Governor (ALSG) linkage or pedal problem. VSG signal wire shorted to voltage source.
Low road speed. | Determine road speed specifications for vehicle manufacturer data. If road speed is less than specified and all mechanical checks are correct, then cruise control calibration is suspected.
Vehicle surges or bucks. | VSS may be supplying incorrect data to the ECU.


 Ether Start

Some pressurized fluid may be trapped in the system. To avoid personal injury, loosen all connections slowly to avoid contact with fluid. When required, spray fluid into a proper container. The engine starting fluid used in DDEC Ether Start Systems contains ethyl and is extremely flammable and toxic.

The engine starting fluids used in DDEC Ether Start Systems contain ethyl ether and is extremely flammable and toxic. To avoid injury, spray the fluid from the bottom of the valve into an appropriate container.

Next topic

EXHAUST (START/RUN ENGINE)

Previous topic


Ether Start_1

 Ether Start

Ether start can be set with the programming station only. Requires ECU software level to be greater than 3.00, and enable output for Ether Start. Refer to Ether Start manual, 7SA727.

Next topic

FAN CONTROLS

Previous topic


 Event Drop Down Box


 EXHAUST GAS RECIRCULATION SYSTEM BASIC CHECKS FOR SERIES 60 ENGINES

For all EGR related concerns (may include exhaust smoke complaints) and Code 39 etc., perform the following steps. If any corrections are made as a result of these checks, test the unit again before proceeding further:

Basic checks for all Series 60 EGR engines require the following tools:

  1. 000 Ohm resistor (low watt)

DDR suite 9 or DDDL version 6.0 of higher

Volt Ohm Meter

Pressure gage 0 - 200 psi (0-1378 kPa)

Pressure gage 0 - 100 psi (0-689 kPa)

Regulated shop air pressure (10 psi)


 Exhaust (Start/Run Engine)

Before starting and running an engine, adhere to the following safety precautions:

To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked.

Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.
Always start and operate an engine in a well ventilated area.
If operating an engine in an enclosed area, vent the exhaust to the outside.
Do not modify or tamper with the exhaust system or emission control system.

Next topic

GLASSES

Previous topic


 Exhaust Temperature and Pressure Sensor Wiring Schematic


 EXPLANATION OF ABBREVIATIONS AND TERMS

The following abbreviations and terms listed in the following table, will be used throughout the electrical flowcharts.

Abbreviations
         Terms
AAT
         Ambient Air Temperature - calculated via the TCI temp sensor
ABS
         Anti-lock Braking System
A/C
         Air Conditioning
ACG
         Air Compressor Governor
ACLS
         Add Coolant Level Sensor
ACP
         Air Compressor Pressure Sensor
ACS
         Application Code System
A/D
         Analog to Digital: The computer inside the ECU uses an A/D converter to convert a sensor voltage into a number with which the computer can work.
AECL
         Add Engine Coolant Level Sensor
AFR Sensor
         Air Filter Restriction Sensor
AIM
         Auxiliary Interface Module
ALSG
         Automotive Limiting Speed Governor
AP
         Accelator Pedal
AP Sensor
         Accelerator Pedal Sensor
ASR
         Anti-Skid Regulation: Data supplied by the ECU for use with ABS (anti-lock braking system).
A/T
         Automatic Transmission
ATI
         Auxiliary Timed Input
ATS
         Air Temperature Sensor: Monitors engine air temperature.
AWL
         Amber Warning Lamp
  • Amber Warning Lamp: Typically mounted on the instrument panel. The AWL has two functions: 1. It is used as a warning lamp to inform the operator of the vehicle that a fault has occurred and the unit should be taken in for service as soon as possible. 2. It is used by the operator or technician to "flash out inactive trouble codes to help diagnose a problem.
BAT
         Battery
BOI
         Beginning of Injection: The number of crank angle degrees, before top-dead-center
(TDC),
         where the ECU is requesting the injectors be turned on.
BPS
         Back Pressure Sensor
BPP
         Brake Pedal Position
CAN
         Controller Area Network: J 1939 high speed control data link.
CCM
         Crankcase Monitor Sensor: Monitors crankcase pressure (currently on 149 engines only).
CCPS
         Crankcase Pressure Sensor
CKP
         Crankshaft Position Sensor
CKT
         Circuit
CLS
         Coolant Level Sensor: Monitors coolant level at the radiator top tank or heat exchanger.
CMP
         Camshaft Position Sensor
COM
         Common
CPP
         Clutch Pedal Position Switch
CPS
         Coolant Pressure Sensor: Monitors coolant pressure.
CTS
         Coolant Temperature Sensor: Monitors coolant temperature.
DCC
         Diagnostic Connector, Cab
DDC
         Detroit Diesel Corporation
DDEC
         Detroit Diesel Electronic Controls
DDEC III
         Third generation Detroit Diesel Electronic Controls
DDEC IV
         Fourth generation Detroit Diesel Electronic Controls
DDL
DDDL
         Diagnostic Data Link: The lines (wires) over which the ECU transmits information that can be read by a Diagnostic Data Reader.
DDL+
DDDL+
         Data Link, positive side: J 1587 data link.
DDL-
DDDL-
         Data Link, negative side: J 1587 data link
DDR
         Diagnostic Data Reader: The hand held tool used for troubleshooting the DDEC system MPSI PRO-LINK 9000.
DLC
         Data Link Connector
DPS
         Delta-P Sensor - measures a difference in pressure at a given location
DRS
         Distributor Reprogramming Station
DT
         Diagnostic Tool; either DDR (MPSI Pro-Link) or DDDL (PC software used in a similar manner as DDR)
DTC
         Diagnostic Trouble Code
DTM
         Diagnostic Test Mode Switch
ECL Sensor
         Engine Coolant Level Sensor
ECU
         Electronic Control Module: The controller of DDEC system. It reads the engine and vehicle inputs, sensors and switches, calculates injector firing and duration, and fires injectors at appropriate times.
ECT
         Engine Coolant Temperature Sensor
ECU
         Engine Control Unit
EDM
         Electronic Display Module
EEPROM
         Electrically Erasable Programmable Read Only Memory.
EFC
         Electronic Fire Commander
EFR Sensor
         Engine Fuel Restriction Sensor
EFPA
         Electronic Foot Pedal Assembly: Contains the throttle position sensor.
EFT Sensor
         Engine Fuel Temperature Sensor
EGR
         Exhaust Gas Recirculation
EH
         Engine Harness
EOL Sensor
         Engine Oil Level Sensor
EOP
         Engine Over-temperature Protection
EOP Sensor
         Engine Oil Pressure Sensor
EOT
         Engine Oil Temperature Sensor
ESH
         Engine Sensor Harness
ESS
         Engine Synchro Shift
ET Sensor
         Exhaust Temperature Sensor
EUI
         Electronic Unit Injector
FEI
         Fuel Economy Incentive
FMI
         Failure Mode Identifier - number used to identify a failure mode
FPS
         Fuel Pressure Sensor: Monitors fuel pressure.
FRS
         Fuel Restriction Sensor
FTS
         Fuel Temperature Sensor: Monitors fuel temperature.
GND
         Ground
HEI
         Half Engine Idle
IAT Sensor
         Intake Air Temperature Sensor
IMP
         Intake Manifold Pressure Sensor
INJ
         Injector (fuel)
ISD
         Idle Shutdown: Programmable feature of the DDEC system.
IVS
         Idle Validation Switch: A switch used to establish the idle speed position.
LSG
         Limiting Speed Governor.
MAP
         Manifold Air Pressure
MAS
         Maintenance Alert System
MID
         Message Identification Character
MPG
         Miles Per Gallon
MPH
         Miles Per Hour
N/A
         Not Applicable.
OECL
         Optical Engine Coolant Level Sensor
OEM
         Original Equipment Manufacturer
OI
         Optimized Idle
OLS
         Oil Level Sensor: Monitors oil level.
OPS
         Oil Pressure Sensor: Monitors oil pressure.
OTS
         Oil Temperature Sensor: Monitors oil temperature.
PGN
         Parameter Group Number
PGS
         Pressure Governor System: Regulates engine speed to maintain a selected external pump pressure.
PID
         Parameter Identifier
PING
         Pilot Injection Natural Gas
PSG
         Pressure Sensor Governor
PTO
         Power Take-Off. Also, referred to as VSG (Variable Speed Governor).
PW
         Pulsewidth
PWM
         Pulsewidth Modulated: Modulated signal provided by the DDEC system.
RES/ACAWL
         Resume/Accelerate Switch used for cruise control.
RFP Sensor
         Rail Fuel Pressure Sensor
RH
         Relative Humidity
RHS
         Relative Humidity Sensor
RSL
         † Red Stop Lamp: Typically mounted on the instrument panel. It has two functions:
  1. It is used as warning to the operator that a potential engine damaging condition has been detected. If the DDEC system is programmed for shutdown, the engine will shutdown on its own within 30 seconds. The engine should not be run until the condition is corrected.
  2. It is used by the operator or technician to "flash" out active trouble codes.
SEO
         Stop Engine Override: Allows the stop engine condition to be overridden in case it is required.
SET/COAST
         Set/Coast Switch: Used in cruise control.
SID
         System Identifier - value used that identifies a sensor or a system
SNEF
         Signal to Noise Enhancement Filter (Module)
SRS
         Synchronous Reference Sensor: Indicates a specific cylinder in the firing order.
TBS
         Turbocharger Boost Sensor: Monitors turbo boost.
TBD
         To be determined.
TCI
         Turbo Compressor Inlet
TCO
         Turbo Compressor Outlet
TD
         Tachometer Driver: An output from the ECU for electronic tachometers and or data loggers.
TDC
         Top Dead Center
TPS
         Throttle Position Sensor: Used to detect throttle request (a component of the EFPA).
Also,
         referred to as LSG.
TRS
         Timing Reference Sensor: Used to detect whenever any cylinder is about to be fired.
VEPS
         Vehicle Electronic Programmimg System
VGT
         Variable Geometry Turbocharger
VIH
         Vehicle Interface Harness (OEM Wiring)
VIN
         Vehicle Identification Number
VLS
         Vehicle Limiting Speed
VNT
         Variable Nozzle Turbine
VOM
         Volt Ohm Meter
VPOD
         Variable Output Pressure Device - used to accurately position the VNT and EGR valve.
VSG
         Variable Speed Governor. Also, referred to as PTO (Power Take-Off).
VSS
         Vehicle Speed Sensor: Used to detect vehicle speed.
VSS OC
         Vehicle Speed Sensor Open Collector: An ECU input which must be used in addition to the VSS positive input when certain types of vehicle speed sensors are used.
Refer to the Application and Installation manual for installation.
  • As a light bulb check and system check, the check engine light will come on for about 5 seconds when the ignition is turned on.

If the AWL remains on, or comes back on, the self diagnostic system has detected a problem. If the problem goes away, the light will go out, but a trouble code will be stored in the ECU as an inactive code.

† As a light bulb check and system check, the stop engine light will come on for about 5 seconds when the ignition is turned on.

Next topic

FLASH CODES VS SAE CODES

Previous topic


 Factory-installed Sensors

The sensors integrated into the factory-installed Engine Harness are listed in the following table. Some DDEC sensors are used with optional features.

Sensor | Function
Barometric Pressure Sensor (Baro Sensor) | Senses barometric pressure.
Camshaft Position Sensor (CPM Sensor) | Senses crankshaft position and engine speed for functions such as fuel control strategy.
Crankshaft Position Sensor (CKP Sensor) | Indicates a specific cylinder in the firing order.
Engine Coolant Temperature Sensor (ECT Sensor) | Senses coolant temperature for functions such as engine protection, fan control and engine fueling.
Engine Oil Level (EOL Sensor) | Detects oil level at four quarts low. Used in the Maintenance Alert System.
Engine Oil Pressure Sensor (EOP Sensor) | Senses gallery oil pressure for functions such as engine protection.
Engine Oil Temperature Sensor (EOT Sensor) | Senses oil temperature for functions such as reducing variation in fuel injection and fan control.
Fuel Restriction Sensor | Detects fuel restriction for replacement of fuel filter. Used in Maintenance Alert System.
Intake Air Temperature Sensor (IAT Sensor) | Senses air temperature for functions such as fan control and engine fueling.
Intake Manifold Pressure Sensor (IMP Sensor) | Senses turbo boost for functions such as smoke control and engine protection.
Mass Air Flow Sensor | Measures EGR flow rate.
Supply Fuel Temperature Sensor (SFT Sensor) | Senses fuel temperature for functions such as engine fueling.
Turbo Compressor Temperature Out Sensor | Senses turbo out air temperature.
Turbo Speed Sensor (TSS) | Senses turbo speed for overspeed conditions.

Next topic

BAROMETRIC PRESSURE SENSOR

Previous topic


 Fan Controls

Fan type is set in the mainframe; None; Single; Dual; Two Speed; are the allowed types. The correct inputs (if any are needed or desired) and outputs must be configured to an available cavity with the programming station.

Required Outputs: Configure to any output cavity

Fan control #1 for Single

Fan control #1 and Fan control #2 for Dual or Two-Speed types

Inputs are optional: Configure to any input cavity with the programming station

Auxiliary Fan Control

Fan Override

Next topic

FUEL ECONOMY INCENTIVE

Previous topic


 FAN OPERATIONAL CONCERN (ON/OFF TYPE)

This section covers only the DDEC controlled fan operation, (fan type single, dual or two-speed).

If the function is assigned, see description of DDEC fan control logic, listed in the following table.

Cavity | Wire # | Function | Output/Input
X# | # | Fan Control 1 | Output - Required
X# | # | Aux. Fan Control | Input - Optional
X# | # | Fan Override | Input - Optional

TROUBLESHOOTING

See also


 FAN OPERATIONAL CONCERN (VARIABLE SPEED TYPE)

The DDEC system via a PWM (Pulsewidth Modulation) signal will go to a high voltage (7-8 volts on a 12-volt system) on a cold engine for a low speed, and to a low voltage (0.8 - 1.0 volts on a 12-volt system) for a high speed.

Fan speed is ramped up as temperatures increase, as listed in the following table. Calibrations can vary. The table is provided only as a guide.

Coolant Temperature | Speed
up to 197°F | Low speed
about 203°F | Medium speed
208°F and above | High speed


 Fault Code Window


 Fault Code Window Information (DDDL 4.1 and Later)

Time stamps are included for the beginning and ending of each fault code.

Current engine hours have been added to the Window.

Certain parameters will display a minimum/maximum value attained during the time the code was active.

Next topic

THE FAULT CODE WINDOW INFORMATION (DDEC II)

Previous topic


 FAULT CODES AND DDDL

The Fault Codes window is displayed when you choose "Fault Codes" from the Diagnostics menu. See Fault Code Window.

NOTE: The screen below shows the Fault Codes window for a DDEC III or IV.

Next topic

FAULT CODES WINDOW INFORMATION (ALL DDDL VERSIONS)

Previous topic


FAULT CODES AND DDDL_1

 FAULT CODES AND DDDL

The Fault Codes window is displayed when you choose "Fault Codes" from the Diagnostics menu. See Fault Code Window

Next topic

FAULT CODES WINDOW INFORMATION (ALL DDDL VERSIONS)

Previous topic


 Fault Codes Window Information (All DDDL Versions)

The light bulb symbol on the left indicates if the code is still active.

The window displays both the DDEC flash code and the SAE code notation (SID or PIDand the FMI). The engine hour when the code first occurred is displayed.

If the code is historic, the engine hour when the code last appeared is displayed as well, along with the total duration time of the code for all counts logged.

You may access the troubleshooting help guide for a particular code by highlighting the code you wish to work on with a single left mouse click and then selecting the Troubleshooting Help option.

Next topic

ACTIVE CODES

Previous topic


Fault Codes Window Information (All DDDL Vers_1

 Fault Codes Window Information (All DDDL Versions)

The light bulb symbol on the left indicates if the code is still active.

The window displays both the DDEC flash code and the SAE code notation (SID or PID and the FMI). The engine hour when the code first occurred is displayed.

If the code is historic, the engine hour when the code last appeared is displayed as well, along with the total duration time of the code for all counts logged.

You may access the troubleshooting help guide for a particular code by highlighting the code you wish to work on with a single left mouse click and then selecting the Troubleshooting Help option.

Next topic

FAULT CODE WINDOW INFORMATION (DDDL 4.1 AND LATER)

Previous topic


 FCI Apex Female Terminal Installation

Install the terminal as follows:

  1. Determine if the connector is new or used.

[a] If the connector is new, the blue Terminal Assurance Position (TPA) is in an unlocked position so go to 2.

[b] If the connector is used, pull the TPA out (see Installing the Terminal).

  2. Insert the crimped terminal into the connector until it clicks (see Installing the Terminal).

  3. Push the TPA into the locked (fully seated) position.

NOTE: The TPAs will self lock when the connectors are mated.

Next topic

FCI APEX FEMALE TERMINAL REMOVAL

Previous topic


 FCI Apex Female Terminal Removal

Remove the terminal as follows:

  1. Using pliers pull out the blue Terminal Position Assurance (TPA) that is located inside the connector (see Removing the Terminal).

  2. Using a FCI APEX repair tool (P/N: 54900002) or a #2 jeweler's screwdriver, press back the terminal locking tang (see Pressing the Locking Tang).

  3. Pull the cable back through the connector (see Removing the Terminal).

Next topic

SPLICING GUIDELINES

Previous topic


 FCI Apex Male Terminal Installation

Install the FCI APEX male terminal as follows:

  1. Determine if the connector is new or used.

[a] If the connector is new, the red Terminal Assurance Position (TPA) is in an unlocked position so go to step 2.

[b] If the connector is used, pull the TPA out (see Installing the FCI Male Terminal).

  2. Insert the crimped terminal into the connector until it clicks (see Installing the FCI Male Terminal). The orientation of the terminal is not critical.

  3. Push the TPA into the locked (fully seated) position.

NOTE: The TPAs will self lock when the connectors are mated.

Next topic

FCI APEX MALE TERMINAL REMOVAL

Previous topic


 FCI Apex Male Terminal Removal

Remove the terminal as follows:

  1. Using pliers pull out the red Terminal Position Assurance (TPA) (see Removing the Terminal).

  2. Using a FCI APEX repair tool (P/N: 54900002) or a #2 jeweler's screwdriver, press back the terminal locking tang (see Pressing the Locking Tang).

  3. Pull the cable back through the connector (see Removing the Terminal).

Next topic

FCI APEX FEMALE TERMINAL INSTALLATION

Previous topic


 FCI APEX Terminal Installation And Removal

The following sections cover FCI APEX male and female terminal installation and removal.

Next topic

FCI APEX MALE TERMINAL INSTALLATION

Previous topic


 FEATURES

The following features are part of the DDEC system:

Air Compressor Control | Anti-Lock Brake System | Cruise Control
Diagnostics | EDM and AIM | Electronic Fire Commander
Engine Brake Controls | Engine Protection | Engine Ratings
Ether Start | Fan Control | Fuel Economy Incentive
Half Engine Idle | Idle Shutdown Timer | IRIS
Low Gear Torque Limiting | Maintenance Alert System | Management Information Products
Optimized Idle | Passmart | Passwords
Pressure Sensor Governor | Progressive Shift | Tachometer Drive
Throttle Control/Governors | Transmission Interface | Transmission Retarder
Two-Speed Axle | Vehicle Speed Limiting | Vehicle Speed Sensor Anti-Tampering
Next topic

DDEC SYSTEM - HOW IT WORKS

Previous topic


Figures

68 Pin Connector Wires and Terminals

Add Coolant Level Sensor Installation

Air Filter Restriction Sensor

Air Filter Restriction Sensor Wiring Diagram

Air Temperature Sensor

Air Temperature Sensor

Barometric Pressure Sensor - Series 60 Engine

Bottom View of Shroud, ECU Connector and Conduit

CKP and CMP Sensors

CMP Sensor and CKP Sensor - Series 50

CMP Sensor and CKP Sensor - Series 60 Engine

Connector Service Loop

Coolant Level Sensor and Circuits

Coolant Temperature Sensor

Coolant Temperature Sensor (Oil Temperature Sensor similar)

Coolant Temperature Sensor Circuits

DDDL Kit

DDEC Vehicle Interface Module, J 41005

Delta-P Sensor and Related Parts

Diagnostic Connector

Diagnostic Connector

Diagnostic Window

Digital Diesel Sensor Stimulator, P/N: 23516937

Dimensions of Electronic Control Unit with Connector Shrouds

DRS Interface Module (Programming ECU)

ECU

ECU 68-pin Tyco Connector

ECU Engine Harness Connector

ECU Label

ECU Vehicle Harness Connector

ECU Vehicle Harness Connector

ECU-to-Input / Sensor Return

EGR Delta P Sensor

EGR Delta-Pressure Sensor Wiring

EGR Rate Sensor Schematic

EGR Temperature Sensor

EGR Temperature Sensor Wiring

EGR Valve Assembly with Oil Lines

Electronic Control Module Vehicle Harness Connector

Electronic Control Unit

Electronic Control Unit Connector Shroud

Electronic Control Unit with Connector Shrouds

Electronic Fire Commander Harness

Engine Brake Harness Schematic

Engine Coolant Level Sensor

Engine Coolant Level Sensor Connector

Engine Coolant Level Sensor Specifications

Engine Coolant Temperature Sensor - Series 60 and Series 50 Engines

Engine Fuel Restriction Sensor

Engine Harness Connector

Engine Harness Connector to Air Filter Restriction Sensor

Engine Harness Connector to Oil Pressure Sensor

Engine Harness Connector to Synchronous Reference Sensor

Engine Harness Connector to Synchronous Sensor

Engine Harness Connector to Timing Reference Sensor

Engine Harness Connector to Turbo Boost Sensor

Engine Harness to Air Temperature Sensor Connector

Engine Oil Level Sensor - Series 60 and Series 50 Engines

Engine Oil Pressure Sensor

Engine Oil Pressure Sensor - Series 60 and Series 50 Engines

Engine Oil Temperature Sensor - Series 60 and Series 50 Engines

Event Drop Down Box

Exhaust Temperature and Pressure Sensor Wiring Schematic

Fault Code Window

Flash Code Method

Front Face of Connector

Fuel Filter Restriction Sensor

Fuel Restriction Sensor

Fuel Restriction Sensor - Series 60 and Series 50 Engines

Fuel Temperature Sensor

Fuel Temperature Sensor

Injector Harness

Injector Harness

Injectors

Inlet Air Temperature Sensor

Installing the FCI Male Terminal

Installing the Terminal

Intake Air Temperature Sensor - Series 60 and Series 50 Engines

Intake Manifold Pressure Sensor

Locking Terminal Into Connector

Maintenance Alert System

Maintenance Pro Display Harness

MAS Pigtail

Mass Air Flow Sensor

Measuring Battery Voltage

Normal Options

Oil Level Sensor

Oil Pressure Sensor

Oil Temperature Sensor

Open Window

Optimized Idle Schematic

Optimized Idle System Overview

Pins V61 through V68 to Battery Leads

Positioning the Leads

Power Harness

Pressing the Locking Tang

Pressing the Locking Tang

Pressure Sensors Schematic

Pressure Transducer

Pressure Transducer and Harness Connector

Pro-Link

Pro-Link 9000

Pro-Link 9000 Printer, J 38480

Pro-Link Diagnostic Data Reader, J 38500

Pump Pressure Sensor

Pushing Terminal Into Grommet

Recommended Strain Relief of Spliced Joint

Record Snapshot

Removal Tool Insertion

Removal Tool Position

Removing the Terminal

Removing the Terminal

Removing the Terminal

Removing the Terminal Position Assurance

Replay Control Window

Securing the Leads With a Clip

Selecting Fault Codes

Series 60 EGR Engine Senors

Series 60 Injector

Series 60 Injector Harness with Jake Brake

Setting Wire Gage Selector and Positioning the Terminal

Shroud Tabs

Side View of Shroud, ECU Connector and Conduit

Speed Sensors Schematic

Splicing Straight Leads - Alternate Method 1

Splicing Straight Leads - Alternate Method 2

Supply Fuel Temperature Sensor - Series 60 and Series 50 Engines

TCI Connector

TCO Connector

Temperature Sensor Circuits (View 1)

Temperature Sensor Circuits (View 2)

Temperature Sensors Schematic

The Correct and Incorrect Method of Staggering Multiple Splices

The Intake Manifold Pressure Sensor - Series 60 and Series 50 Engines

Throttle Position Sensor

Throttle Position Sensor

Turbo Boost Sensor

Turbo Boost Sensor Schematic

Turbo Compressor Inlet Sensor

Turbo Compressor Outlet Temperature Circuit

Turbo Compressor Temperature Out Sensor - Series 60 Engine

Turbo Speed Sensor - Series 60 and Series 50 Engines

Turbo Speed Sensor Wiring

Turbocharger Compressor Outlet Temperature Circuit

Tyco Connector and Locking Tabs

Typical Variable Speed Governor Circuit

Typical Variable Speed Governor Circuit

Vehicle Harness Connector

Vehicle Harness Schematic Overview

VGT/VPOD Schematic

VIH-to-ECU Connector (Pins V17 and V18)

VIH-to-ECU Connector (Pins V43, V44 and V56-58)

VIH-to-ECU Connector (Pins V11, V29 and V60)

Voltage Measurement Hook-up

Volt-Ohm Meter, J 39299

VPOD, Coolant, Oil Temperature, EGR, and VNT VPOD Schematic

VPOD, Injector, and MAS Schematic

Wiring for 9-pin Data Link Connector


 Fire

Keep a charged fire extinguisher within reach. Ensure you have the proper type of extinguisher on hand.

To avoid injury from fire, keep a fire extinguisher near the grinding machine in case excessive heat should ignite the oil.

Next topic

CLEANING AGENT

Previous topic


 FIRE TRUCK PRESSURE GOVERNOR FAULT

The following procedure will troubleshoot fire truck pressure governor fault.

Pressure Governor Operation

The Pressure Sensor Governor (PSG) System is a DDEC feature, programmed to allow the engine speed to change in order to maintain a steady water pump pressure (pressure mode) or hold a steady engine speed (RPM Mode).

NOTE: Most applications today incorporate the Detroit Diesel Electronic Fire Commander.

Verify Correct Pressure Sensor Governor Configuration

Perform the following steps to verify the PSG configuration. Refer to the Application and

Installation manual for the appropriate engine model to ensure correct inputs and outputs are configured. Required In / Outs are listed in the following table.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. View H2O governor enabled (engine configuration).

  4. View In / Outs. Verify correct configuration.

[a] If the system is enabled and the in/outs are correctly configured, refer to Identify Problem.

[b] If the problem was found, correct the settings and retest. Refer to the DDEC V Application And Installation manual, 7SA821.

Inputs | Outputs
PSG Mode, (Press / RPM) | PSG Active
PSG Enable | Cruise Active
Res / Accel | -
Set / Coast | -
Required In / Outs

  5. `Using the DRS Select (PSG + Sensor Tab), verify that the water pump sensor has been configured correctly (V29 - water pump pressure).

[a] If the water pump sensor has been configured correctly, refer to Identify Problem.

[b] If the water pump sensor has not been configured correctly, configure and test.


 FLASH CODE 11 - VSG VOLTAGE LOW

DESCRIPTION OF FLASH CODE 11

Flash Code 11 indicates that the Variable Speed Governor (VSG) input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage. This diagnostic condition is typically:

Open sensor signal circuit (No VSG throttle control installed.)

Open sensor +5 volt supply circuit

Sensor signal is shorted to the sensor return circuit or to ground

Sensor +5 volt supply is shorted to sensor return circuit or to ground (This condition will result in numerous sensor codes.)

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 11

The SAE J1587 equivalent code for Flash Code 11 is p 187/4, Variable Speed Governor (VSG) input low.


 FLASH CODE 12 - VSG HIGH

DESCRIPTION OF FLASH CODE 12

Flash Code 12 indicates that the Variable Speed Governor (VSG) input to the ECU has exceeded 95% (normally > 4.75 volts) of the sensor supply voltage. This diagnostic condition is typically:

Open sensor return circuit

Sensor signal circuit is shorted to the sensor +5 volt supply

Throttle sensor not adjusted properly at full throttle

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 12

The SAE J1587 equivalent code for Flash Code 12 is p 187/3, Variable Speed Governor (VSG) input high.


 FLASH CODE 13 - ECL VOLTAGE LOW

DESCRIPTION OF FLASH CODE 13

Flash Code 13 indicates that the Engine Coolant Level Sensor (ECL) or ADD Coolant Level Sensor input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage. See Coolant Level Sensor. This diagnostic condition is typically:

Sensor signal is shorted to the sensor return circuit or to ground

Deteriorated coolant

Flash code 13 may also indicate that the ECU has detected too high a current level for the Exhaust Gas Recirculation (EGR) Valve.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 13

The SAE J1587 equivalent codes for Flash Code 13 are p 111/4, coolant level circuit low; and 111/6, ACLS failed low.

TROUBLESHOOT FLASH CODE 13, p 111/4 (coolant level circuit low)

TROUBLESHOOT FLASH CODE 13, p 111/6 (add coolant level sensor failed low)

TROUBLESHOOT FLASH CODE 13, p 146/6 Exhaust Gas Recirculation (EGR) Valve current high


 FLASH CODE 14 - TEMP SENSOR HIGH

DESCRIPTION OF FLASH CODE 14

Flash Code 14 indicates that the engine Coolant Temperature Sensor (CTS) or Oil Temperature Sensor (OTS), See Coolant Temperature Sensor (Oil Temperature Sensor similar), input to the ECU has exceeded 95% (normally >4.75 volts) of the sensor supply voltage.

NOTE: This code will only be logged during warm engine operation.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor return circuit

SAE J1587 EQUIVALENT CODES FOR FLASH CODE 14

The SAE J1587 equivalent codes for Flash Code 14 are:

p 110/3 - coolant temperature circuit high

p 175/3 - oil temperature circuit high


 FLASH CODE 15 - TEMP SENSOR LOW

DESCRIPTION OF FLASH CODE 15

Flash Code 15 indicates that the Coolant Temperature Sensor (CTS), or Oil Temperature Sensor (OTS), see Coolant Temperature Sensor (Oil Temperature Sensor similar), input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Sensor signal is shorted to the sensor return circuit or to ground

SAE J1587 EQUIVALENT CODES FOR FLASH CODE 15

The SAE J1587 equivalent codes for Flash Code 15 are:

p 110/4 - coolant temperature circuit low

p 175/4 - oil temperature circuit low


 FLASH CODE 16 - ECL VOLTAGE HIGH

DESCRIPTION OF FLASH CODE 16

Flash Code 16 indicates that the engine Coolant Level Sensor (ECL), see Engine Coolant Level Sensor, input to the ECU has exceeded 95% (normally > 4.75 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor ground circuit

Flash code 16 may also indicate that the ECU has detected too low a current measured from the Exhaust Gas Recirculation (EGR) Valve.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 16

The SAE J1587 equivalent code for Flash Code 16 is p 111/3, coolant level circuit high; and 111/5, ACLS circuit high.

TROUBLESHOOT FLASH CODE 16 p 111/3 (coolant level circuit high)

TROUBLESHOOT FLASH CODE 16 p 111/5 (ACLS circuit failed high)

TROUBLESHOOT FLASH CODE 16, p 146/5 Exhaust Gas Recirculation (EGR) Valve current too low


FLASH CODE 17 - THROTTLE VALVE HIGH: RELATIVE HUMIDITY SENSOR HIGH

 FLASH CODE 17

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


FLASH CODE 18 - THROTTLE VALVE LOW; RELATIVE HUMIDITY SENSOR LOW

 FLASH CODE 18

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 19

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 20

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 21 - TPS HIGH

DESCRIPTION OF FLASH CODE 21

Flash Code 21 indicates that the Throttle Position Sensor (TPS), see Throttle Position Sensor, input to the ECU has exceeded 95% (normally >4.75 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor return circuit

Sensor signal circuit is shorted to the sensor +5 volt supply

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 21

The SAE J1587 equivalent code for Flash Code 21 is p 091/3, TPS circuit high.

General Throttle Information (Limiting Speed Governor)

The correct TPS counts for DDEC III engines at idle should be 64 - 205 counts.

  1. Typical DDEC foot pedals today, at idle, provide 90 - 175 counts.

  2. The DDEC system will log a TPS low volt code (PID 091, FMI 4, Flash Code 22) if the TPS counts go below 48.

  3. The DDEC system will log a TPS high volt code (PID 091, FMI 3, Flash Code 21) if the TPS counts go above 968 counts.

  4. In order to go from 0% to 100% throttle, the counts have to increase 546 above the idle count, or 100 counts, whichever is greater.

  5. If an idle validation switch (IVS) is configured, to go from 0% to 100% throttle, the counts have to increase 546 above the counts at which the IVS opens or 100 counts, whichever is greater.

  6. If 0% throttle is attained with the foot off the pedal, and if 100% throttle is attained with the pedal to the floor, then the pedal should not be considered a factor for low power complaints.

TROUBLESHOOT FLASH CODE 21


 FLASH CODE 22 - TPS LOW

DESCRIPTION OF FLASH CODE 22

Flash Code 22 indicates that the Throttle Position Sensor (TPS), see Throttle Position Sensor, input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor +5 volt supply circuit

Sensor signal is shorted to sensor return circuit or to ground

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 22

The SAE J1587 equivalent code for Flash Code 22 is p 091/4, Throttle Position Sensor (TPS) circuit low.

General Throttle Information (Limiting Speed Governor)

The correct TPS counts for DDEC engines at idle should be 64 - 205 counts.

  1. Typical DDEC III foot pedals today, at idle, provide 90 - 175 counts.

  2. The DDEC system will log a TPS low volt code (PID 091, FMI 4, Flash Code 22) if the TPS counts go below 48.

  3. The DDEC system will log a TPS high volt code (PID 091, FMI 3, Flash Code 21) if the TPS counts go above 968 counts.

  4. In order to go from 0% to 100% throttle, the counts have to increase 546 above the idle count, or 100 counts, whichever is greater.

  5. If an idle validation switch (IVS) is configured, to go from 0% to 100% throttle, the counts have to increase 546 above the counts at which the IVS opens or 100 counts, whichever is greater.

  6. If 0% throttle is attained with the foot off the pedal, and if 100% throttle is attained with the pedal to the floor, then the pedal should not be considered a factor for low power complaints.

TROUBLESHOOT FLASH CODE 22


 FLASH CODE 23 - FUEL TEMP SENSOR HIGH

DESCRIPTION OF FLASH CODE 23

Flash Code 23 indicates that the engine Fuel Temperature Sensor (FTS), see Fuel Temperature Sensor, input to the ECU has exceeded 95% (normally >4.75 volts) of the sensor supply voltage.

NOTE: This code will only be logged during warm engine operation.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor circuit return

Sensor signal circuit is shorted to the sensor +5 volt supply

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 23

The SAE J1587 equivalent code for Flash Code 23 is p 174/3, fuel temperature circuit high.


 FLASH CODE 24 - FUEL TEMP SENSOR LOW

DESCRIPTION OF FLASH CODE 24

Flash Code 24 indicates that the engine Fuel Temperature Sensor (FTS), see Fuel Temperature Sensor, input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Sensor signal circuit is shorted to sensor return circuit or to ground

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 24

The SAE J1587 equivalent code for Flash Code 24 is p 174/4, fuel temperature circuit low.


 FLASH CODE 25

DESCRIPTION OF FLASH CODE 25

Code 25 will be flashed to indicate that the DDEC system has no active or inactive codes. No troubleshooting is required.

If using the DDR, the description will read:

No Active Codes or No Inactive Codes - refer to INTERMITTENT FAULT: Troubleshooting Faults W/O Codes.


 FLASH CODE 26 - AUXILIARY SHUTDOWN ACTIVE

DESCRIPTION OF FLASH CODE 26

Flash Code 26 indicates that the Auxiliary Engine Shutdown #1 or #2 switch input to the ECU is active. The active switch input represents a low (grounded) external input circuit to the ECU.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 26

The SAE J1587 equivalent codes for Flash Code 26 are:

s 025/11 - auxiliary shutdown #1 active

s 061/11 - auxiliary shutdown #2 active


 FLASH CODE 27 - AIR TEMP SENSOR HIGH

DESCRIPTION OF FLASH CODE 27

Flash Code 27 indicates that the engine Air Temperature Sensor (ATS), see Air Temperature Sensor, input to the ECU has exceeded 95% (normally > 4.75 volts) of the sensor supply voltage.

NOTE: This code will only be logged during warm engine operation.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor return circuit

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 27

The SAE J1587 equivalent code for Flash Code 27 is p 172/3, air temperature circuit high.


 FLASH CODE 28 - AIR TEMP SENSOR LOW

DESCRIPTION OF FLASH CODE 28

Flash Code 28 indicates that the engine Air Temperature Sensor (ATS), see Air Temperature Sensor, input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Sensor signal circuit is shorted to sensor return

Sensor signal circuit is shorted to ground

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 28

The SAE J1587 equivalent code for Flash Code 28 is p 172 4, air temperature circuit low.


 FLASH CODE 29 - TCI / TCO TEMPERATURE LOW

DESCRIPTION OF FLASH CODE 29

Flash Code 29 indicates the signal voltage for the TCI (Turbo Compressor Inlet) or TCO (Turbo Compressor Outlet) temperature sensor went below calibration limits.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 29

The SAE J1587 equivalent codes for Flash Code 29 are p 351/4, turbo compressor inlet (TCI) low voltage and p 404/4, turbo compressor outlet (TCO) low voltage.

TROUBLESHOOT FLASH CODE 29

See TCO Connector for the TCO Connector and see TCI Connector for the TCI Connector.


 FLASH CODE 30

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 31 - ENGINE BRAKE FAULT CODE

DESCRIPTION OF FLASH CODE 31

Flash Code 31 indicates the engine brake low or medium circuit has an open or is shorted to battery ground.

This diagnostic condition is typically:

Output circuit open

Output wire is shorted to ground

SAE J1587 EQUIVALENT CODE FOR FLASH CODE

The SAE J1587 equivalent code for Flash Code 31 is s 51/3, 51/4, s 52/3, or 52/4.


 FLASH CODE 32 - AWL / RSL FAULT

DESCRIPTION OF FLASH CODE 32

Flash Code 32 indicates that the wire for the RSL or AWL is open or shorted to Battery +.

This diagnostic condition is typically:

Open/broken output wire

Shorted output wire

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 32

The SAE J1587 equivalent code for Flash Code 32 is:

s 238/3 RSL short to battery

s 238/4 RSL open circuit

s 239/3 AWL short to battery

s 239/4 AWL open circuit


 FLASH CODE 33 - TBS HIGH

DESCRIPTION OF FLASH CODE 33

Flash Code 33 indicates that the engine Turbo Boost Sensor (TBS) input to the ECU has exceeded 95% (normally > 4.75 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor return circuit

Sensor signal circuit is shorted to the sensor +5 volt supply

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 33

The SAE J1587 equivalent code for Flash Code 33 is p 102/3.


 FLASH CODE 34 - TBS LOW

DESCRIPTION OF FLASH CODE 34

Flash Code 34 indicates that the engine Turbo Boost Sensor (TBS) input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor +5 volt supply circuit

Sensor signal is shorted to sensor return circuit or to ground

Sensor +5 volt supply is shorted to the sensor return circuit or ground

Plugged or restricted air filter.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 34

The SAE J1587 equivalent code for Flash Code 34 is p 102/4.


 FLASH CODE 35 - OPS HIGH

DESCRIPTION OF FLASH CODE 35

Flash Code 35 indicates that the engine Oil Pressure Sensor (OPS), see Oil Pressure Sensor, input to the ECU has exceeded 95% (normally > 4.75 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor return circuit

Sensor signal circuit is shorted to the sensor +5 volt supply

Failed/damaged sensor

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 35

The SAE J1587 equivalent code for Flash Code 35 is p 100/3, oil pressure circuit high.

NOTE: Code 35 is logged if oil pressure is high, engine is warm, and engine is at idle.


 FLASH CODE 36 - OPS LOW

DESCRIPTION OF FLASH CODE 36

Flash Code 36 indicates that the engine Oil Pressure Sensor (OPS), see Oil Pressure Sensor, input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor +5 volt supply circuit

Sensor signal is shorted to sensor return circuit or to ground

Sensor +5 volt supply is shorted to the sensor return circuit

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 36

The SAE J1587 equivalent code for Flash Code 36 is p 100/4, oil pressure circuit low.


 FLASH CODE 37 - FRS VOLTAGE HIGH

DESCRIPTION OF FLASH CODE 37

Flash Code 37 indicates that the Fuel Restriction Sensor (FRS),see Fuel Restriction Sensor, input to the ECU has exceeded 95% (normally > 4.75 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor return circuit

Sensor signal circuit is shorted to the sensor +5 volt supply

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 37

The SAE J1587 equivalent code for Flash Code 37 is p 95/3 fuel restriction input voltage high.


 FLASH CODE 38 - FRS VOLTAGE LOW

DESCRIPTION OF FLASH CODE 38

Flash Code 38 indicates that Fuel Restriction Sensor (FRS), see Fuel Restriction Sensor, input to the ECU has dropped below 5% (normally < 0.25 volts) of the sensor supply voltage.

This diagnostic condition is typically:

Open sensor signal circuit

Open sensor +5 volt supply circuit

Sensor signal is shorted to sensor return circuit or to ground

Sensor +5 volt supply is shorted to the sensor return circuit

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 38

The SAE J1587 equivalent code for Flash Code 38 is p 95/4, FRS, fuel pressure restriction input voltage low.


 FLASH CODE 39 - EGR VALVE / VNT VANE FAULT

DESCRIPTION OF FLASH CODE 39

Flash Code 39 is used for several EGR (Exhaust Gas Recirculation) system or VNT (Variable Nozzle Turbine) operational faults. These codes are typically logged in the ECU when one of the components are faulty.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 39

The SAE J1587 equivalent codes for Flash Code 39, EGR valve fault:

s 146/2, EGR leak - Boost Power

s 146/12, EGR leak - Boost Jake

s 146/7, EGR Valve not responding

The SAE J1587 equivalent codes for Flash Code 39, VNT vane fault:

s 147/2, VNT Vanes not responding - Boost Power

s 147/12, VNT Vanes not responding - Boost Jake

s 147/14, EGR flow too low s 147/11, VNT Vanes at Max - Jake

s 147/7, VNT Vanes not responding - EGR

There are no wires to check for Flash Code 39. The sensor values and the ECU calibration are used to decide a mechanical fault is present.

TROUBLESHOOT FLASH CODE 39

The following procedure will troubleshoot Flash Code 39.

For all EGR related codes, always perform the basic checks in EGR-1. Performing the basic checks will troubleshoot the components that will be responsible for logging these codes for Series 60 engines refer to MAINTENANCE ALERT SYSTEM.

If the basic checks all pass, and no fault can be found with the VNT/turbocharger or EGR valve, then it is recommended that the information you have collected be available to discuss with Detroit Diesel Technical Service.

  1. Code s 146/7 - occurs if actual EGR rate during EGR mode operation is less than it should be. This fault will lock boost mode operation and illuminate the AWL for the remainder of the ignition cycle.

  2. Code s 146/2 - occurs if actual EGR rate during Power Boost mode operation is greater than a calibrated value. This fault will illuminate the AWL for the duration of the fault being active.

  3. Code s 146/12 - occurs if actual EGR rate during Boost Jake mode operation is greater than a calibrated value. This fault will illuminate the AWL for the duration of the fault being active.

  4. Code s 147/7 - occurs if error in actual EGR rate vs desired EGR rate (Actual - Desired) during EGR mode operation. This FMI signifies excessive EGR flow. This fault will lock boost mode operation and illuminate the AWL for the remainder of the ignition cycle if the actual is greater than the desired.

  5. Code s 147/2 - occurs if error in actual boost vs desired boost during Power Boost mode operation is greater than it should be. This fault will illuminate the AWL for the duration of the fault being active.

  6. Code s 147/12 - occurs if error in actual boost vs desired boost during Jake Boost mode operation is greater than it should be. This fault will illuminate the AWL for the duration of the fault being active.

  7. Code s 147/14 - occurs if error in actual EGR rate vs desired EGR rate (Desired - Actual) during EGR mode operation. This FMI signifies low EGR flow. This fault will illuminate the AWL for the duration of the fault being active.

Verify Repairs

Perform the following steps to verify repairs:

  1. Reassemble the engine.

  2. Start and run the engine.

  3. Perform a road test.

  4. Check for logged codes.

[a] For Series 60 engines, refer to MAINTENANCE ALERT SYSTEM. Or, call Detroit Diesel Technical Service.

[b] If no codes are logged, repairs are complete.


 FLASH CODE 40

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 41 - TOO MANY SRS

DESCRIPTION OF FLASH CODE 41

Flash Code 41 indicates that the ECU has detected extra Synchronous Reference Sensor pulses, or the ECU has detected missing Timing Reference Sensor pulses, see CKP and CMP Sensors.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 41

The SAE J1587 equivalent code for Flash Code 41 is s 021/0.


 FLASH CODE 42 - TOO FEW SRS

DESCRIPTION OF FLASH CODE 42

Flash Code 42 indicates that the ECU has detected missing Synchronous Reference Sensor (SRS) pulses, or the ECU has detected extra Timing Reference Sensor (TRS) pulses, see CKP and CMP Sensors.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 42

The SAE J1587 equivalent code for Flash Code 42 is s 021/1.


 FLASH CODE 43 - COOLANT LEVEL LOW

DESCRIPTION OF FLASH CODE 43

Flash Code 43 indicates that the ECU has detected that the engine coolant level has dropped below the recommended safe operating range, see Coolant Level Sensor.

This code indicates that the coolant level is below the ACLS sensor probe. Add coolant and return to service. If the code persists with the level of coolant full, contact Detroit Diesel Technical Service.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 43

The SAE J1587 equivalent code for Flash Code 43 is p 111/1.


 FLASH CODE 44 - TEMP HIGH

DESCRIPTION OF FLASH CODE 44

Flash Code 44 indicates that the ECU has detected that the engine coolant temperature has exceeded the recommended safe operating range. See Coolant Temperature Sensor.

It also indicates that the ECU has detected that the engine oil temperature has exceeded the recommended safe operating range. This normally occurs due to a mechanical fault.

The FMI of 14 is an advice for the engine derate for high oil temperature or coolant temperature. This code is stored for information only. This code will not turn on the AWL. No troubleshooting is suggested or recommended for this code. Clear the inactive code and return to service.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 44

The SAE J1587 equivalent code for Flash Code 44 is p 110/0, coolant temperature high.

The SAE J1587 equivalent code for Flash Code 44 is p 175/0, oil temperature high.

The SAE J1587 equivalent code for Flash Code 44 is p 175/14, oil temperature derate.

The SAE J1587 equivalent code for Flash Code 44 is p 110/14 coolant temperature derate.


 FLASH CODE 45 - OIL PRESSURE LOW

DESCRIPTION OF FLASH CODE 45

Flash Code 45 indicates that the ECU has detected that the engine oil pressure has dropped below the recommended safe operating range. See Engine Oil Pressure Sensorfor the engine oil pressure sensor.

Conditions: ECU looks for a minimum pressure vs. speed. This can vary for each engine type.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 45

The SAE J1587 equivalent code for Flash Code 45 is p 100/1, oil pressure low.


 FLASH CODE 46 - BATTERY VOLTAGE LOW

DESCRIPTION OF FLASH CODE 46

Flash Code 46 indicates that the DDEC system has detected that the main battery supply voltage to the ECU has dropped below the recommended operating range.

The DDEC system will operate on 12 or 24 volts.

Normal operating voltage of the DDEC system is 11 to 32 volts DC, measured at the ECU.

Operating the ECU between 6 and 11 volts may result in degraded engine operation. (Transient operation in this range during engine starting is considered normal for 12-volt systems.)

Operating the ECU over 32 volts will cause damage.

Reversing polarity will cause damage to the ECU if the power harness is not properly fused.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 46

The SAE J1587 equivalent codes for Flash Code 46 are as follows.

p 168/1.

s 211/1 - sensor supply voltage low (Pins V 11 / V 12).

Troubleshoot by referring to ENGINE SENSOR HARNESS, vehicle harness.

s 232/1 - sensor supply voltage low (Pins E 12/E 26).

Troubleshoot by referring to VEHICLE HARNESS, engine harness.

The power harness supplies 12 or 24 volts to the ECU. The system must be sourced directly from the battery.

NOTE: Connection to reverse polarity will damage the system if not properly fused.


 FLASH CODE 47 - AIR / FUEL PRESSURE HIGH

DESCRIPTION OF FLASH CODE 47

Flash Code 47 indicates that the ECU has detected that the fuel pressure, air inlet pressure, or turbo boost pressure has exceeded a programmed operating range. This normally occurs due to a mechanical fault in the air system or fuel system of the engine. See Intake Manifold Pressure Sensor.

NOTE: Not all engines use a fuel pressure sensor.

For gas engines, code 47 indicates that the air inlet pressure has exceeded a calibration limit programmed in the ECU.

For diesel engines, code 47 indicates that the turbo boost pressure has exceeded a calibration limit programmed in the ECU.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 47

The SAE J1587 equivalent code for Flash Code 47 is p 106/0, air inlet pressure high.

The SAE J1587 equivalent code for Flash Code 47 is p 102/0, turbo boost pressure high (Diesel-fueled engines).

TROUBLESHOOT FLASH CODE 47

This (Diesel-fueled engine) code is a mechanical fault. Check for reasons for high turbo boost pressure, e.g. VNT stuck. Refer to appropriate service manual, section 6.


 FLASH CODE 48 - AIR / FUEL / EGR PRESSURE LOW OR EGR / TCI / TCO TEMPERATURE LOW

DESCRIPTION OF FLASH CODE 48

Flash Code 48 indicates that the ECM has detected that the Fuel Pressure has dropped below a programmed limit. This condition is normally associated with a restriction in the fuel supply system (currently not used):

Plugged fuel filter

Low fuel supply

NOTE:Not all engines use a fuel pressure sensor.

For gas engines, code 48 indicates that the air inlet pressure has dropped below a calibration limit.

Flash Code 48 is also used to identify the EGR Delta-Pressure, or EGR temperature is below programmed limits. This condition is typically due to:

EGR valve not opening completely

EGR valve not opening at all - leaking CAC.

Leaking EGR piping/hoses.

Flash Code 48 also indicates the exhaust gas temperature fell below calibrated limits, or EGR Delta-Pressure fell below calibrated limits. Possible causes include:

EGR valve not opening

EGR valve not opening fully

Leaking CAC

Flash Code 48 also indicates the TCI (Turbo Compressor Inlet) or TCO (Turbo Compressor Outlet) temperature fell below the calibrated limits. Possible causes include:

Leaking CAC

Leaking inlet piping

EGR valve not opening properly

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 48

The SAE J1587 equivalent codes for Flash Code 48 are

p 094/1, fuel pressure low.

p 412/1, EGR temperature low.

p 411/1, EGR Delta-Pressure low.

p 351/1, TCI temperature below range.

p 404/1, TCO temperature below range.

TROUBLESHOOT FLASH CODE 48

Fuel Pressure code is logged as a result of a mechanical fault. Check for reasons for low fuel pressure. Refer to appropriate service manual, section 5.

For all EGR related codes, always perform the basic checks in (EGR-1). For the Series 60 engines, refer to MAINTENANCE ALERT SYSTEM.

Then, go to Check for Other Codes to continue troubleshooting code 48.


 FLASH CODE 49 - TCO OR TCI TEMPERATURE HIGH

DESCRIPTION OF FLASH CODE 49

Flash Code 49 indicates the Turbo Compressor Inlet (TCI) temperature or Turbo Compressor Outlet (TCO) temperature went above the calibrated limits.

Possible causes are:

Restricted air filter

EGR valve stuck open

High exhaust back pressure

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 49

The SAE J1587 equivalent codes for Flash Code 49 are:

p 351/0, TCI temperature above range;

p 404/0, TCO temperature above range; and

p 404/14, TCO derate.

TROUBLESHOOT FLASH CODE 49

There is no recommended DDEC troubleshooting for this code. Perform basic checks. Contact Detroit Diesel Technical Service with a snapshot and code logging details for instructions.

Code p 404/14 is logged without turning on a AWL or broadcasting the fault. This FMI (14) is an information code only - 404/14 is logged when the ECU derates the engine due to high TCO temperature.


 FLASH CODE 50

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 51 - TCO OR TCI TEMPERATURE CIRCUIT FAILED HIGH

DESCRIPTION OF FLASH CODE 51

Flash Code 51 indicates the Turbo Compressor Inlet (TCI) or Turbo Compressor Outlet (TCO) temperature circuit voltage has exceeded established limits.

Possible causes are:

Open wire

Failed sensor

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 51

The SAE J1587 equivalent codes for Flash Code 51 are

p 351/3, TCI temperature failed high

p 404/3, TCO temperature failed high.


 FLASH CODE 52 - ECU FAULT

DESCRIPTION OF FLASH CODE 52

Flash Code 52 indicates that the DDEC system ECMs internal Analog to Digital (A/D) Convertor device has malfunctioned. Intermittent diagnostic conditions of this type can be caused by faulty external electrical system.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 52

The SAE J1587 equivalent code for Flash Code 52 is s 254/12.


 FLASH CODE 53 - ECU MEMORY FAULT

DESCRIPTION OF FLASH CODE 53

Flash Code 53 indicates that the ECU was unable to read a valid copy of an engine data record (calibration, faults, or accumulators) stored in nonvolatile memory.

Flash Code 53 also indicates that the ECU was unable to update an engine data record (calibration, faults, or accumulators) stored in nonvolatile memory.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 53

The SAE J1587 equivalent code for Flash Code 53 is s 253/12, EEPROM write fail.

The SAE J1587 equivalent code for Flash Code 53 is s 253/2, nonvolatile checksum incorrect.


 FLASH CODE 54 - VSS FAULT

DESCRIPTION OF FLASH CODE 54

Flash Code 54 indicates that during engine operation the vehicle speed that is measured by the Vehicle Speed Sensor (VSS) is less than the expected value for the current engine speed/conditions.

This diagnostic condition is typically an open sensor signal circuit. In a system without VSS anti-tampering, the code is logged when the rpm >1500 and PW >15° and vehicle speed < 3 mph.

With or without VSS anti-tampering, mph will be limited if the code is logged.

NOTE: Code will not be logged for the first five hours of ECMs life (total engine hours).

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 54

The SAE J1587 equivalent code for Flash Code 54 is p 084/12.


 FLASH CODE 55 - J1939 DATA LINK FAULT

DESCRIPTION OF FLASH CODE 55

Flash Code 55 indicates the ECU has detected a fault in the J1939 Data Link.

Incorrect programming.

Wiring fault, J1939 data link wires. See VIH-TO-ECU CONNECTOR.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 55

The SAE J1587 equivalent code for Flash Code 55 is s 231/12, ECU fault and s 216/14, missing other ECU; it also indicates DDEC ECU has lost its connection with other ECU devices or indicates a loss or shorted J1939 data link. If code is logged with:

Code 86/14 - smart cruise has a fault.

Code 84/12 - programmed wrong or shorted J1939 data link.


 FLASH CODE 56 - J1587 DATA LINK FAULT

DESCRIPTION OF FLASH CODE 56

Flash Code 56 indicates that the J1587 (diagnostic) data link is no longer allowing the ECU to transmit data.

This diagnostic condition is typically:

Either or both of the data link circuits are open at some point in the network.

Either or both of the data link circuits are shorted to ground at some point in the network.

Either or both of the data link circuits are shorted to battery (+) at some point in the network.

The pair of data link circuits are shorted together.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 56

The SAE J1587 equivalent code for Flash Code 56 is s 250/12. See VIH-to-ECU Connector.


 FLASH CODE 57

TROUBLESHOOT FLASH CODE 57

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 58 - CRUISE CONTROL INPUT FAULT

DESCRIPTION OF FLASH CODE 58

The following procedure will troubleshoot Flash Code 58.

This code is not covered in this manual. If changes occur, notification will be sent from DDC.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 58

The SAE J1587 equivalent code for Flash Code 58 are listed in the following table.

Flash Code
         SID
         FMI
         Description
58
         s 216
         7
  • ECU information not responding
58
         s 242
         9
         Cruise control resume/accel switch not responding
58
         s 242
         12
         Cruise control/accel switch failed
58
         s 243
         9
         Cruise control set/coast switch not responding
58
         s 243
         12
         Cruise control set/coast switch failed
58
         s 244
         9
         Cruise control enable switch not responding
58
         s 244
         12
         Cruise control enable switch failed
58
         s 245
         9
         Clutch pedal switch not responding
58
         s 245
         12
         Clutch pedal switch failed
58
         s 246
         9
         Service brake pedal switch not responding
58
         s 246
         12
         Service brake pedal switch failed
58
         p 40
         9
         Engine retarder switch not responding
58
         p 40
         12
         Engine retarder switch failed
58
         p 70
         9
         Park brake/safety loop switch not responding
58
         p 70
         12
         Park brake/safety loop switch failed
  • Mux'd dashboard devices

If code is logged w/216.14, troubleshoot by referring to FLASH CODE 55 - J1939 DATA LINK FAULT or contact Detroit Diesel Technical Service.


 FLASH CODE 59

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 60

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 61 - INJECTOR RESPONSE LONG

DESCRIPTION OF FLASH CODE 61

Flash Code 61 indicates that the time it takes from when the DDEC III ECU requests an Injector be turned on to when the injector solenoid valve actually closes is longer than the high limit of the expected range. Engine oil temperature must be greater than 87°F (30°C).

This diagnostic condition is typically:

Bad injector harness and or connection (high resistance)

Poor vehicle grounds

Sticky solenoid valve

NOTE: The injector diagnostic SID (Subsystem Identifier) indicates which cylinder number has an injector with a long response time. The injector number describes the cylinder and or bank which has the injector with a long response time. The DDR will display the injector text description.

Injector response times generally increase with low battery supply voltage and decrease with high battery supply voltage. Although injector response times vary from injector to injector at a given r/min, each individual injector response time should remain relatively consistent from one firing to the next. Wide variations in response time (typically ± 0.2 msec) for one injector at a steady engine r/min may indicate an electrical problem (faulty alternator or voltage regulator, poor or broken ground cables, etc.).

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 61

The SAE J1587 equivalent code for Flash Code 61 is s 001/0, or s 002/0, or s 003/0, or s 004/0, or s 005/0 or s 006 /0 (six cylinder engine).

(FMI 6 = Grounded Circuit)


 FLASH CODE 62 - OUTPUT FAULT

DESCRIPTION OF FLASH CODE 62

Flash Code 62 indicates that the function assigned to the Auxiliary Output #5 through #17 circuit output has an open circuit or short to battery (+). A short to battery (+) is detected when the DDEC ECU is unsuccessful in turning "ON" the configured function.

The DDEC ECU supplies a switched ground to the AUXILIARY OUTPUT circuit to turn ON the function assigned.

Flash Code 62 may also indicate that the function assigned to the Auxiliary Output #1, #2, #5 through #17 circuit output is open, shorted to ground. This diagnostic condition is detected when the Auxiliary Output # "X" function is OFF and the DDEC ECU measures a low voltage on the circuit output.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 62

The SAE J1587 equivalent codes for Flash Code 62 are listed in the following table.

SAE J1587 Code | Output Number | Fault
s026 3 | Auxiliary output #1 | Short to battery
s026 4 | Auxiliary output #1 | Open circuit
s040 3 | Auxiliary output #2 | Short to battery
s040 4 | Auxiliary output #2 | Open circuit
s053 3 | Auxiliary output #5 | Short to battery
s053 4 | Auxiliary output #5 | Open circuit
s054 3 | Auxiliary output #6 | Short to battery
s054 4 | Auxiliary output #6 | Open circuit
s055 3 | Auxiliary output #7 | Short to battery
s055 4 | Auxiliary output #7 | Open circuit
s056 3 | Auxiliary output #8 | Short to battery
s056 4 | Auxiliary output #8 | Open circuit
s057 3 | Auxiliary output 9 | Short to battery
s057 4 | Auxiliary output 9 | Open circuit
s058 3 | Auxiliary output 10 | Short to battery
s058 4 | Auxiliary output 10 | Open circuit
s059 3 | Auxiliary output 11 | Short to battery
s059 4 | Auxiliary output 11 | Open circuit
s060 3 | Auxiliary output 12 | Short to battery
s060 4 | Auxiliary output 12 | Open circuit
s061 3 | Auxiliary output 13 | Short to battery
s061 4 | Auxiliary output 13 | Open circuit
s062 3 | Auxiliary output 14 | Short to battery
s062 4 | Auxiliary output 14 | Open circuit
s063 3 | Auxiliary output 15 | Short to battery
s063 4 | Auxiliary output 15 | Open circuit
s064 3 | Auxiliary output 16 | Short to battery
s064 4 | Auxiliary output 16 | Open circuit
s065 3 | Auxiliary output 17 | Short to battery
s065 4 | Auxiliary output 17 | Open circuit
TROUBLESHOOT FLASH CODE 62


 FLASH CODE 63 - PWM FAULT

DESCRIPTION OF FLASH CODE 63

Flash Code 63 indicates that the pulse width modulation (PWM) output(s) used is either shorted to battery positive or open-circuited.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 63

The SAE J1587 equivalent code for Flash Code 63 is s 057/3, or s 057/4, or s 058/3, or s 058/4.

Flash Code
         SID
         FMI
         Description
63
         s 57
         0
         PWM #1 (V 52) above normal range
63
         s 57

PWM #1 (V 52) below normal range
63
         s 57
         3
         PWM #1 (V 52) short to battery
63
         s 57
         4
         PWM #1 (V 52) open circuit
63
         s 57
         7
         PWM #1 (V 52) mechanical system failure
63
         s 58
         0
         PWM #2 (V 46) above normal range
63
         s 58
         0
         PWM #2 (V 46) below normal range
63
         s 58
         3
         PWM #2 (V 46) short to battery
63
         s 58
         4
         PWM #2 (V 46) open circuit
63
         s 58
         7
         PWM #2 (V 46) mechanical system failure
63
         s 59
         0
         PWM #3 (E 01) above normal range
63
         s 59

PWM #3 (E 01) below normal range
63
         s 59
         3
         PWM #3 (E 01) short to battery
63
         s 59
         4
         PWM #3 (E 01) open circuit
63
         s 59
         7
         PWM #3 (E 01) mechanical system failure
63
         s 60
         0
         PWM #4 (E 04) above normal range
63
         s 60

PWM #4 (E 04) below normal range
63
         s 60
         3
         PWM #4 (E 04) short to battery
63
         s 60
         4
         PWM #4 (E 04) open circuit
63
         s 60
         7
         PWM #4 (E 04) mechanical system failure
63
         s 267
         0
         PWM #5 (E 08) above normal range
63
         s 267

PWM #5 (E 08) below normal range
63
         s 267
         3
         PWM #5 (E 08) short to battery
63
         s 267
         4
         PWM #5 (E 08) open circuit
63
         s 267
         7
         PWM #5 (E 08) mechanical system failure
63
         s 268
         0
         PWM #6 (E 11) above normal range
63
         s 268

PWM #6 (E 11) below normal range
63
         s 268
         3
         PWM #6 (E 11) short to battery
63
         s 268
         4
         PWM #6 (E 11) open circuit
63
         s 268
         7
         PWM #6 (E 11) mechanical system failure
TROUBLESHOOT FLASH CODE 63


 FLASH CODE 64

DESCRIPTION OF FLASH CODE 64

Flash Code 64 is used to identify a turbo speed fault.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 64

The SAE J1587 equivalent code for Flash Code 64 is p 103/8, turbo speed sensor input failure and p 103/0, turbo overspeed. The turbo speed (an EGR code) has exceeded a programmed limit; performance concerns may result during active code.

For all EGR related codes, always perform the basic checks in EGR-1.


 FLASH CODE 65 - AIR FILTER RESTRICTION INPUT VOLTAGE LOW

DESCRIPTION OF FLASH CODE 65

For diesel-fueled engines, Flash Code 65 indicates that the air filter sensor input voltage has exceeded or dropped below the expected range.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 65

For diesel engines, the SAE J1587 equivalent codes for Flash Code 65 are 107/3, air filter sensor voltage high, and 107/4, air filter sensor voltage low.


 FLASH CODE 66

DESCRIPTION OF FLASH CODE 66

Flash Code 66 indicates the oil filter sensor input to the ECU has exceeded or dropped below the allowed range.

This code is not covered in this Troubleshooting Help. If changes occur, notification will be sent from DDC.


 FLASH CODE 67

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 68 - IDLE VALIDATION FAULT

DESCRIPTION OF FLASH CODE 68

Flash Code 68 indicates that the ECU has detected a fault in the idle validation switch (IVS) logic.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 68

The SAE J1587 equivalent code for Flash Code 68 is s 230/5 (open circuit) or s 230/6 (short to ground).

NOTE: Code 230/5 (open) is set when TPS counts are less than 120 and IVS input is opened.

NOTE: Code 230/6 (short to ground) is set when TPS counts are greater than 282 and IVS input is grounded to battery (-).


 FLASH CODE 69

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 70

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 71 - INJECTOR RESPONSE SHORT

DESCRIPTION OF FLASH CODE 71

Flash Code 71 indicates that the time it takes from when the DDEC ECU requests an injector be turned on, to when the injector solenoid valve actually closes, is shorter than the lower limit of the expected range.

This diagnostic condition is typically:

Aerated fuel system

High system battery (+) supply voltage

Mechanical injector failure

Failed solenoid

NOTE: The injector diagnostic SID (Subsystem Identifier) indicates which cylinder number has an injector with a short response time. The injector number describes the cylinder and bank that has the injector with a short response time. The DDR will display the injector text description.

Injector response times generally increase with low battery supply voltage and decrease with high battery supply voltage. Although injector response times vary from injector to injector at a given r/min, each individual injector response time should remain relatively consistent from one firing to the next. Wide variations in response time (typically ± 0.2 ms) for one injector at a steady engine r/min may indicate an electrical problem (faulty alternator or regulator, poor or broken ground cables, etc.). See Series 60 Injector for injector diagram.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 71

The SAE J1587 equivalent code for Flash Code 71 is s 001/1, or s 002/1, or s 003/1, or s 004/1, or s 005/1, or s 006/1.


 FLASH CODE 72 - VEHICLE OVERSPEED

DESCRIPTION OF FLASH CODE 72

Flash Code 72 indicates that the vehicle speed signal to the ECU (with fueling to the engine) has exceeded the vehicle speed limit that is defined in the ECU calibration. See ECU.

Flash Code 72 also may indicate that the vehicle speed signal to the ECU (without fueling to the engine) has exceeded a secondary vehicle speed limit that is defined in the ECU calibration.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 72

The SAE J1587 equivalent code for Flash Code 72 is p 084/0 or p 084/11.


 FLASH CODE 73 - AIR FILTER RESTRICTION HIGH

TROUBLESHOOT FLASH CODE 73


 FLASH CODE 74 - OI SAFETY LOOP

DESCRIPTION OF FLASH CODE 74

Flash Code 74 indicates that the park brake digital input is shorted to ground between the vehicle interface harness connector and one of the switches (park brake switch, neutral switch, hood switch or optional OEM interlock).

If this code is inactive, it may indicate that the vehicle moved during optimized idle operation or that two consecutive engine start attempts were not successful.

Flash Code 74 may also indicate that the relay coil is open or is shorted (causing the unsuccessful engine start).

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 74

The SAE J1587 equivalent code for Flash Code 74 is p 070.4.


 FLASH CODE 75 - BATTERY VOLT HIGH

DESCRIPTION OF FLASH CODE 75

Flash Code 75 indicates that the DDECECU has detected that the main battery supply voltage to the ECU has exceeded the recommended operating range.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 75

The SAE J1587 equivalent code for Flash Code 75 is p 168/0 ECU battery voltage high, or s 211/0 sensor supply voltage high (V 11-12), or s 232/0 sensor supply voltage high (E 26).


 FLASH CODE 76 - ENGINE OVERSPEED / BRAKE

DESCRIPTION OF FLASH CODE 76

Flash Code 76 indicates the engine speed exceeded a calibration limit, and the engine brake output was active at the time the condition occurred.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 76

The SAE J1587 equivalent code for Flash Code 76 is p 121/0, Engine Overspeed with Engine Brake.

TROUBLESHOOTING FLASH CODE 76

Perform the following steps to troubleshoot Flash Code 76.

Multiple Code Check

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Read all logged codes.

[a] If codes other than 121/0 are logged, service them first.

[b] If code 121/0 is logged, and no other codes are logged, there was an engine running condition at which the engine r/min exceeded a calibration limit during engine brake operation.

NOTE: Determine the reason the engine r/min went too high.


 FLASH CODE 77 - EXHAUST BACK PRESSURE FAULT AND SEVERAL INFORMATION CODES

DESCRIPTION OF FLASH CODE 77

Flash Code 77 is used for several DDEC information codes. The codes are listed in Table 76-1.

At this time, this code is logged without illuminating an AWL.

See ECU.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 77

The SAE J1587 equivalent codes for Flash Code 77 are listed in the following table:

PID | Description | Troubleshooting
p 73 1 | Fire pump pressure below range. Indicates the water pump pressure fell below a calibrated value. | No troubleshooting available for this code. Possible faults could be restricted water supply of failing pump.
p 81 0 p 81 1 | Exhaust back pressure above range Exhaust back pressure below range | Indicates the exhaust back pressure measured was above (FMI 0) or below (FMI 1) a calibrated value. Back pressure too high is usually a sign of a restricted exhaust or failing muffler/converter.
p 81 12 | Exhaust back pressure at rampdown threshold | Indicates the engine derated due to high exhaust back pressure. This could have been presented as a sudden power loss. This code is not a DDEC fault and should be treated as an information code only.
p 81 3 p 81 4 | Exhaust back pressure failed high Exhaust back pressure failed low | Indicates the signal voltage to the ECU went above or below a programmed limit. Typically, less than 25 V for FMI 4 and greater than 4.75 V for FMI3. Refer to Exhaust Back Pressure Fault for troubleshooting.
p 95 1 p 99 1 | Fuel filter differential pressure below range Oil filter differential pressure below range | Fuel filter or oil filter differential pressure sensor fell below calibrated limit. Not likely to show up on any on-highway engines. These sensors are used as part of the Maintenance Alert System.
p 100 0 | Engine oil pressure above range | Indicates that DDEC detected oil pressure too high following shutdown. Typically, this is caused by a stuck sensor. The code is generated on the next ignition cycle and stays active for the duration of the ignition cycle.
p 102 1 p 105 1 p 107 1 | Turbo boost pressure below range Inlet manifold temperature below range Air filter differential pressure below range | Indicates one of these parameters fell below a calibrated limit. Details of these codes should be recorded and technical service contacted, since it is unlikely these codes will be used on highway engines.
p 108 0 p 108 1 | Barometric pressure above range Barometric pressure below range | Currently these codes should not log with on-highway engines.
p 109 0 | Coolant pressure above range | Not used for Series 50 or Series 60.
p 110 1 p 111 0 | Coolant temperature below range coolant level above range | Neither of these codes should be seen for on-highway engines.
p 171 0 p 171 1 | Ambient air temperature above range Ambient air temperature below range | Neither of these codes should be seen for on-highway engines.
p 172 1 | Air inlet temperature below range |
p 174 0 | TCO temperature above range (temporary code) | Refer to FLASH CODE 49 - TCO OR TCI TEMPERATURE HIGH - 404 0.
p 174 0 | Fuel temperature above range | Indicates fuel temperature exceeded DDC limits for that particular engine. No DDEC troubleshooting is suggested. High fuel temperature should be reviewed with the OEM to determine if any additional fuel coolers need to be considered.
p 174 1 | TCO temperature below range (temporary code) | Refer to FLASH CODE 48 - AIR / FUEL / EGR PRESSURE LOW OR EGR / TCI / TCO TEMPERATURE LOW - 404 1.
p 174 1 | Fuel temperature below range | Indicates the fuel temperature fell below a calibrated range. No troubleshooting is suggest.
p 175 1 | Engine oil temperature below range | Indicates the engine oil temperature fell below a calibrated range. No troubleshooting is suggest.
p 222 14 | Anti theft fault present | Contact DDC Technical Service.
p 251 10 p 251 13 p 252 10 p 252 13 | Clock module abnormal rate of change Clock module failure Clock module abnormal rate of change Clock module failure | Codes indicate internal faults with the clock components. Contact DDC Technical Service.
p 354 0 p 354 1 | Relative humidity above range Relative humidity below range | Currently, these codes should not log with on-highway engines
TROUBLESHOOT FLASH CODE 77

There is an established procedure to troubleshoot Flash Code 77, p 81/3 and p 81/4 only (exhaust back pressure failed high or low). Refer to Exhaust Back Pressure Fault. There is no established procedure to troubleshoot other variations of this code.

The code is used to determine if high fuel temperature may be a cause of reduced power levels.

High fuel temperature will reduce available horsepower.

Refer to the recommendations of the vehicle manufacturer regarding the possible need for additional fuel cooling.


 FLASH CODE 78 - CRUISE CONTROL / ADAPTIVE CRUISE CONTROL

DESCRIPTION OF FLASH CODE 78

Flash Code 78 indicates the DDEC system has lost its ability to connect to the adaptive cruise control source.

Possible causes include:

Programmed wrong - smart cruise enabled and not used.

Shorted J1939 wires - (usually with code 216/14.)

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 78

The SAE J1587 equivalent code for Flash Code 78 is p 86/14, Cruise control/adaptive cruise control (aka Smart Cruise).

TROUBLESHOOT FLASH CODE 78

For troubleshooting Flash Code 78, follow these procedures:

  1. For intermittent fault code 86/14, contact Detroit Diesel Technical Service.

  2. If code 86/14 is logged with 216/14, for troubleshooting refer to FLASH CODE 55 - J1939 DATA LINK FAULT.


 FLASH CODE 79

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 80

No DDEC code is currently assigned to this number. If changes occur, notification will be sent from DDC.


 FLASH CODE 81 - OIL LEVEL OR EXHAUST TEMP CIRCUIT FAILED HIGH

DESCRIPTION OF FLASH CODE 81

Flash Code 81 is used to identify oil level or exhaust temperature voltage high.

Flash Code 81 is also used to identify EGR Rate Sensor fault.

For all EGR related codes, always perform the basic checks in EGR-1. Refer to MAINTENANCE ALERT SYSTEM for Series 60.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 81

The SAE J1587 equivalent code for Flash Code 81 is p 98/3, oil level sensor input voltage high; or p 173/3, exhaust gas temperature circuit failed high; or 411/3 EGR Delta Pressure check high; or 412/3 EGR temperature high.

TROUBLESHOOT FLASH CODE 81

Use the following procedures to troubleshoot Flash Code 81.

For code 411/3, start with Check for Open.

For code 412/3, start with Check for Open.

For code 98/3, refer to TROUBLESHOOT MAINTENANCE ALERT SYSTEM.

For code p 173/3, exhaust gas temperature circuit failed high, refer to TROUBLESHOOT EXHAUST GAS TEMPERATURE.


FLASH CODE 82 OIL LEVEL OR EXHAUST TEMP CIRCUIT FAILED LOW

 FLASH CODE 82 - OIL LEVEL OR EXHAUST TEMP CIRCUIT FAILED LOW

DESCRIPTION OF FLASH CODE 82

Flash Code 82 is used to identify oil level or exhaust temperature voltage low. EGR codes include EGR Delta-Pressure circuit low and EGR temperature circuit low.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 82

The SAE J1587 equivalent code for Flash Code 82 is p 98/4, oil level sensor input voltage low.

Equivalent codes are also or 411/4, EGR Delta-Pressure failed low and 412/4, EGR temperature failed low. Also code p 173/4, exhaust gas temperature circuit failed low. For Series 60 engines refer to MAINTENANCE ALERT SYSTEM.

TROUBLESHOOTING FLASH CODE 82

To troubleshoot:

code | refer to
p 98/4 | TROUBLESHOOTING MAINTENANCE ALERT SYSTEM.
411/4 | Check EGR Delta-Pressure Sensor.
412/4 | Check for Short.


FLASH CODE 83 EGR TEMP, EGR DELTA-PRESSURE

 FLASH CODE 83 - EGR TEMP, EGR DELTA-PRESSURE

DESCRIPTION OF FLASH CODE 83 (p 411/0)

Flash code 83, p 411/0 indicates that the EGR Delta pressure is high. These conditions are typically:

EGR valve stuck open

EGR valve stuck partly open

For all EGR related codes, always refer to Exhaust Gas Recirculation System Basic Checks for Series 60 Engines and perform the exhaust gas recirculation system checks.

DESCRIPTION OF FLASH CODE 83 (p 412/0)

Flash Code 83, p 412/0 is used to identify EGR temperature high. These conditions are typically due to:

EGR valve stuck open

EGR valve stuck partly open

Plugged EGR cooler

For all EGR related codes, always refer to Exhaust Gas Recirculation System Basic Checks for Series 60 Engines and perform the exhaust gas recirculation system checks.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 83

The SAE J1587 equivalent code for Flash Code 83 is one of the following:

p 411/0, EGR Delta-Pressure high,

p 412/0, EGR temperature high.

Refer to:

EGR Delta P Sensor

EGR Temperature Sensor

Delta-P Sensor and Related Parts

TROUBLESHOOTING FLASH CODE 83

To troubleshoot:

code | refer to
PID 411/FMI 0 | Check for an EGR valve stuck open or partly open (PID 411/FMI 0)
PID 412/FMI 0 | Check for an EGR valve stuck open or partly open (PID 412/FMI 0)


 FLASH CODE 84

DESCRIPTION OF FLASH CODE 84

Flash Code 84 indicates the lubricating oil level is below the sensor probe.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 84

The SAE J1587 equivalent code for Flash Code 84 is p 98/1, oil level low.

TROUBLESHOOT FLASH CODE 84

Add lubricating oil to the full mark on the dipstick. Refer to the appropriate engine service manual for recommended type and classification of lubricating oil.

If code persists with the sensor submerged in oil, contact DDC Technical Service.


 FLASH CODE 85 - ENGINE OVERSPEED

DESCRIPTION OF FLASH CODE 85

Flash Code 85 indicates that an engine overspeed condition exists.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 85

The SAE J1587 equivalent code for Flash Code 85 is p 190/0, engine overspeed.


 FLASH CODE 86 - PGS SENSOR HIGH

DESCRIPTION OF FLASH CODE 86

Flash Code 86 indicates that the pump pressure circuit failed high (below). For pressure transducer and connector, see Pressure Transducer.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 86

The SAE J1587 equivalent code for Flash Code 86 is p 073/3.


 FLASH CODE 87 - PGS SENSOR LOW

DESCRIPTION OF FLASH CODE 87

Flash Code 87 indicates pump pressure sensor input voltage low.

The signal volts dropped below 5% (normally = <0.25 volts) of the sensor supply. For pressure transducer and connector, see Pump Pressure Sensor.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 87

The SAE J1587 equivalent code for Flash Code 87 is p 073/4.

TROUBLESHOOT FLASH CODE 87

Use the following procedure to troubleshoot Flash Code 87.


 FLASH CODE 88

DESCRIPTION OF FLASH CODE 88

Flash Code 88 is used to identify coolant pressure low.

This code currently is not covered in this Troubleshooting Help. If changes occur, notification will be sent from DDC.


 FLASH CODE 89

DESCRIPTION OF FLASH CODE 89

Flash Code 89 indicates an ACLS fault. The coolant is reported low on the main CLS with ACLS coolant level okay.

Also, Flash Code 89 indicates the fuel inlet restriction has exceeded recommended limits.

SAE J1587 EQUIVALENT CODE FOR FLASH CODE 89

The SAE J1587 equivalent code for Flash Code 89 is 111/12, ACLS fault. This code is also p 95/0, fuel inlet restriction high.

TROUBLESHOOT FLASH CODE 89

Technically, code 111/12 should not occur. It is logged if the ECU reports the ACLS immersed in coolant with the second (lower level) sensor out of coolant. For ACLS troubleshooting, refer to ACLS Check.

Code 95/0 indicates the fuel inlet restriction is high. For fuel inlet restriction troubleshooting, refer to Check Fuel Inlet Restriction.


 Flash Code Method


 FLASH CODES VS SAE CODES

For more information, see

READING THE DIAGNOSTIC CODES - FLASH METHOD

READING CODES

DDEC DESCRIPTIONS

Next topic

READING THE DIAGNOSTIC CODES - FLASH METHOD

Previous topic


 Front Face of Connector


 Fuel

Keep the hose and nozzle or the funnel and container in contact with the metal of the fuel tank when refueling.

To avoid injury from fire, keep all potential ignition sources away from diesel fuel, open flames, sparks, and electrical resistance heating elements. Do not smoke when refueling.
The following cautions should be followed when filling a fuel tank:

To avoid injury from fire caused by heated diesel-fuel vapors:
Keep those people who are not directly involved in servicing away from the engine.
Stop the engine immediately if a fuel leak is detected.
Do not allow open flames or smoke when working on an operating engine.
Wear adequate protective clothing (face shield, insulated gloves and apron, etc.).
To prevent a buildup of potentially volatile vapors, keep the engine area well ventilated during operation.
Diesel fuel is relatively harmless at ambient temperatures.

To avoid injury from fire, contain and eliminate leaks of flammable fluids as they occur. Failure to eliminate leaks could result in fire.

Next topic

BATTERIES

Previous topic


 Fuel Economy Incentive

Fuel Economy Incentive (FEI) can be set with the DDR or programming station.

FEI is a DDEC feature that allows vehicle owners to set driver goals of fuel economy while offering the driver an incentive which is a result of his/her good driving habits. The FEI will automatically allow a higher vehicle speed (speed increase is dependent on the customer selected settings) than is set in the road speed limiting area of the ECU. FEI was released with ECU software level 5.00.

There are four items relative to FEI:

Minimum MPG (MIN MPG)

This would be defined as the customer's minimum fuel economy goal. Any fuel economy obtained by the driver greater than this figure would result in a allowed speed increase. Each increase of 0.1 mpg will provide the speed increase dictated by the Conversion factor (or Scaler MPH/MPG).

Maximum MPH (MAX MPH)

This would be the absolute maximum speed increase to which the customer wants the vehicle limited. The value is an increase above the vehicle speed limit. The allowed values are 0 to 20. A value of 0 disables the FEI feature. A value of 1 to 20 enables the FEI feature.

Conversion Factor (Scaler MPH/MPG)

The miles per hour you want to allow for each full mile per gallon above the minimum mpg. Example: a value of 10 will allow the driver to go 10 mph above the road speed limit for each full (1) mile per gallon above the minimum mpg. If the minimum mpg is 7.0, and the driver is getting 7.1 mpg, then the system will allow one additional mile per hour increase, etc. The unit will still be limited to the maximum MPH.

Calculation Type (CALC TYPE)

Two choices can be found under this item; FILTERED, or TRIP. This is what you want the FEI to use to base its calculations. Filtered bases the calculations on the fuel information, by periodic sampling of fuel consumption, recorded in the ECU. Trip bases the calculations on the trip portion of the fuel usage information.

FEI is only able to be set by the customer or service outlet and only with the DDR or programming station. Requires MPSI DDR version 5.0 or higher.

Next topic

FUEL PRESSURE SENSOR

Previous topic


 Fuel Filter Restriction Sensor


 Fuel Pressure Sensor

Fuel pressure sensing is currently only configured for some industrial engines. It is not available on all series. The fuel pressure sensor used is the same as the oil pressure sensor.

Next topic

FULL POWER CONTINUOUS OVERRIDE

Previous topic


 Fuel Restriction Sensor

The Fuel Restriction Sensor monitors the condition of the fue filter. The sensor is facotry installed at DDC for applications which have the Maintenance Alert System (MAS). See Fuel Restriction Sensor - Series 60 and Series 50 Engines.

Next topic

INTAKE AIR TEMPERATURE SENSOR

Previous topic


Fuel Restriction Sensor_2

 Fuel Restriction Sensor


 Fuel Restriction Sensor - Series 60 and Series 50 Engines


 Fuel Temperature Sensor


Fuel Temperature Sensor_1

 Fuel Temperature Sensor


 Full Power Continuous Override

Full Power Continuous Override allows the operator to override the shutdown protection and maintain full power rather than ramp down to a reduced performance. This is set on the mainframe.

Next topic

FUNCTION LOCKOUT

Previous topic


 Function Lockout

Function Lockout was added to the release of 4.00 ECU and DDR software.

The purpose of this new option is to allow users to have a selected area or areas of the customer parameters password protected. For example, a customer can now function lockout the cruise control parameters with a user entered password, and still have the other areas accessible with the DDR with no (four zeros) password.

The function lockout parameters are able to be selected and customized to the customer's request.

The areas that are able to be protected by function lockout are:

Idle Shutdown

VSG Configuration

Engine Protection

Cruise Control

Progressive Shift

Engine Droop

Engine/Vehicle Options

Air Compressor

ESS Transmission

When making changes with the DDR under the Reprogram Calibration section, you will already have entered a password to get past this step. If any of the functions in the selection list are function lockout protected, the DDR will ask for the function lockout password after that selection is made.

Next topic

HALF ENGINE ENABLE

Previous topic


 GENERAL DIAGNOSTIC INFORMATION

As a bulb and system check, the Amber Warning Lamp (AWL) and Red Stop Lamp (RSL) will come on for five seconds when the ignition switch is first turned on. If the unit is programmed for the cruise control feature, the "Cruise Active" light (if equipped) will also turn on for five seconds.

If the AWL comes on during vehicle operation, it indicates the self diagnostic system has detected a fault.

When the diagnostic request switch is held, the diagnostic system will flash the yellow or red light located on the dash of the vehicle. The light will be flashing the code(s) indicating the problem areas. If the RSL comes on during vehicle operation, it indicates the DDEC System has detected a potential engine damaging condition. The engine should be shut down immediately and checked for the problem.

Active codes will be flashed on the RSL in numerical flash code order. If there are no active codes, a code 25 will be flashed.

Inactive codes will be flashed on the AWL in most recent to least recent order. If there are no inactive codes, a code 25 will be flashed.

Next topic

READING CODES WITH DIAGNOSTIC DATA READER

Previous topic


 General wire recommendations

Detroit Diesel Corporation recommends color coding or hot stamping of wires.

NOTE: Color code the wires as shown in the schematics. If the wires used are the same color, hot stamp the cavity number on the wires.

NOTICE:
DDC does not recommend using any type of terminal lubricant or grease compounds. These products may cause dirt or other harmful substances to be retained in the connector.

NOTICE:
Insulation must be free of nicks.
Tape, conduit, loom or a combination thereof must be used to protect the wires. Refer to CONDUIT AND LOOM and TAPE AND TAPING. All wires must be annealed copper wire (not aluminum). All wires must comply with SAE J1128 JAN 95 Low Tension Primary Cable. Contact the Society of Automotive Engineers to obtain documents.

Next topic

TERMINAL INSTALLATION AND REMOVAL

Previous topic


 Glasses

Select appropriate safety glasses for the job. It is especially important to wear safety glasses when using tools such as hammers, chisels, pullers or punches.

To avoid injury, wear a face shield or goggles.

Next topic

WELDING

Previous topic


 Half Engine Enable

Half engine enable can be set with the DDR for ECMs with 7.00 ECU software or higher. A current DDR is required. Half engine options are:

No half engine - (OFF)

Half engine when cold air inlet temperature is less than 12.5°F (55°F), with parking brake set - (IF COLD)

Half engine all the time, whenever park brake is set - (ON)

N/A is displayed when changing half engine with the DDR or laptop is not allowed in the engine calibration. The engine may have half engine program as part of that engine calibration. View "Diagnostic Data List" to see if the engine is currently operating in half engine mode.

Next topic

IDLE SHUTDOWN

Previous topic


 Hardware

The hardware portion of the VEPS programming package includes the interface module and cables. The components that are included in the package are listed in the following table.

Part Description | Part Number
100 Foot Cable | 23512893
SAE J1708 6-Pin Dash Connector | 23515957
J1708/RS-232 Translator Box | 23512415
6 foot Cable | 23515869

A cable kit, listed in the following table, is also available.

Part Description | Part Number
Cable Kit (includes the 100 foot cable and the 6-pin dash connector) | 23512980

A translator and cable kit, listed in the following table, is also available.

Part Description | Part Number
Translator Kit (includes the J1708/RS-232 translator box, 100 foot cable and the 6-pin dash connector) | 23512895

The VEPS software kit, listed in the following table, is available.

Part Description | Part Number
Software Kit (includes the RP1202 Software and the VEPS Software) | Contact DDC Application Engineering

Next topic

DETROIT DIESEL DIAGNOSTIC LINK

Previous topic


 Idle Shutdown

Idle shutdown can be set with the DDR or programming station.

Enabled: Yes/No

Time: 01 - 99 minutes

Enabled on VSG: Yes/No; this determines if you want the idle timer to shut the engine down during idle only

No

Yes (Idle and High Idle)

Override:

Yes/No, will flash the AWL 90 seconds before shutdown to allow the driver to press the pedal that will cancel the idle shutdown, and run until the key is cycled or by pressing the pedal again.

Ambient Air Temp disallows override: Can be set with the DDR or programming station. (Override Temp Disable) Lower Limit = XX; Upper Limit =XX. (When upper and lower limits are set, the operator will only be able to override ISD if the calculated ambient air temperature is above or below these temperatures. Upper and lower limit both set to 167°F = disables the feature.

Adding Ambient Temp Sensor: DDC offers an actual ambient temperature sensor.

NOTE: If the override temperature disable function is wanted by a customer, it is recommended that this be added (Kit P/N: 23518521, with instructions 18SP397).

Next topic

IDLE SPEED

Previous topic


 Idle Speed

Idle speed can be set on the mainframe for some industrial applications to a maximum of 1000 r/min. It is a fixed speed for on-highway engines.

Next topic

IDLE SPEED OFFSET

Previous topic


 Idle Speed Offset

The Idle Speed Offset is read by the DDR as Idle Adjust.

Idle speed offset can be adjusted from + 100 r/min, to - 25 r/min using the DDR. Maximum combined speed for automatic transmission applications is 700 r/min. (Some special applications allow 750 r/min.)

Next topic

INJECTOR CALIBRATION CODES

Previous topic


 IMPORTANT INFORMATION

The following items must be read and thoroughly understood before using this manual.

  1. The engine and ignition should always be off before the harness connectors are disconnected or reconnected.

  2. When disconnecting harness connectors, ensure the pulling force is applied to the connectors themselves and not the wires extending from them.

NOTICE: To avoid damage to the harness connectors, ensure the pulling force is applied to the connections themselves and not the wires extending from them.

  3. After harness connectors are reconnected to the DDEC system, the codes logged should be ignored and cleared.

  4. In most all areas of repair/troubleshooting, a DDR will be required.

  5. In diagnosing an intermittent problem, wiggling wires or harnesses may allow the fault to be repeated. This may allow a technician to better isolate the problem area.

Next topic

EXPLANATION OF ABBREVIATIONS AND TERMS

Previous topic


 Inactive Codes

Inactive codes are faults that have occurred previously. All current inactive codes will be displayed for the entire system, including single, dual, and triple ECU applications. The display for each code is as follows:

SCREEN #1; | SCREEN #2
Line 1: ## MID: XXX XXXXXX XX; | Line 5: 1st: Last:
Line 2: PID Description; | Line 6: Total#:
Line 3: FMI Description; | Line 7: Total Time:
Line 4: |## PID: XXX FMI: XX [image] ; | Line 8: Min/Max:
Explanation:

##: Indicates the DDC diagnostic flash code number

|##: Numerical Count of inactive codes

  1. st: First occurrence of the diagnostic code in engine hours

Last: Last occurrence of the diagnostic code in engine hours

Total#: Total number of occurrences

Total Time: Total engine seconds that the diagnostic code was active

Min/Max: Minimum/Maximum value recorded during diagnostic condition

Next topic

CLEAR CODES

Previous topic


 Injector Calibration Codes

Injector calibration codes can be set with the DDR or programming station only. Codes are password protected. Allowed range is 01 - 99.

Next topic

INPUT FUNCTIONS

Previous topic


 Injector Calibration Update

Start with the Menu Selection screen.

  1. Select ENGINE and ENTER.

  2. Go down to FUEL INJECTOR INFO and ENTER.

  3. Go down to CAL UPDATE and ENTER.

  4. Select VIEW and ENTER or select UPDATE and ENTER.

  5. Enter password: 0000 or xxxx and ENTER twice.

  6. Enter new CAL # and ENTER. Use UP/DN arrow keys to select line.

  7. When finished, select FUNC, select YES, ENTER and wait.

  8. ENTER to continue.


 Injector Harness


Injector Harness_1

 Injector Harness


 Injectors


 Inlet Air Temperature Sensor


 Input Functions

DDEC has twelve digital input ports (cavities) listed in the following table, located on the Vehicle Interface Harness.

Input | Cavities | Input | Cavities
E1 | #451 | G2 | #543
F1 | #542 | H2 | #524
G1 | #528 | J2 | #531
H1 | #523 | K2 | #583
J1 | #541 | G3 | #545
F2 | #544 | K3 | #979
These digital inputs can be configured for various functions, listed in the following table. These functions can be ordered at the time of engine order. Any digital input function is able to be customized by programming the ECU with a the programming station.

Functions | Functions | Functions
None | Limiting Torque Curve | Trans Retarder Status
Engine Brake Low | Diagnostic Request | Dual Throttle (LSG)
Engine Brake Med | Alt Min VSG/Fast Idle | A/C Fan Status
Aux Shutdown #1 | Service Brake Release | Aux CLS
Aux Shutdown #2 | Clutch Released | Fan Control Override
Park Brake / ISD | Set Coast OFF DDEC II | VSG Station Change
Idle Validation | Set / Coast ON | VSG Station Complement
Pressure / RPM Mode | Resume/Accel OFF DDEC II | Air Load Switch
Throttle Inhibit | Resume / Accel ON | In Neutral Switch
RPM Sync (Marine) | Cruise Enable | In Gear Switch
RPM Freeze (Marine) | PGS System Enable | KD Brake
Rating Switch #1 | SEO / DIAG Request | Gas Valve Diagnostic
Rating Switch #2 | Engine Brake Disable | -

Next topic

JAKE BRAKE (SEE ENGINE BRAKE)

Previous topic


 Installing the FCI Male Terminal


 Installing the Terminal


 Intake Air Temperature Sensor

The Intake Air Temperature sensor, IAT, is a thermistor type sensor that has a variable resistance, when exposed to different temperatures. The IAT sensor provides necessary input for various functions such as varying hot idle speed, fan control, and injection timing which results in improved cold starts and reduced white smoke. See Intake Air Temperature Sensor - Series 60 and Series 50 Engines.

Next topic

THE INTAKE MANIFOLD PRESSURE SENSOR

Previous topic


 Intake Air Temperature Sensor - Series 60 and Series 50 Engines


 Intake Manifold Pressure Sensor


 INTERMITTENT CODE OR A SYMPTOM AND NO CODES

The following procedure will diagnose an intermittent code or symptom.

Diagnosis by Symptom

Perform the following steps to diagnose an intermittent code or symptom.

NOTE: Do not use any other procedures (except for the suggestions listed in this guide) when trying to solve an intermittent problem. Use of any other procedures for this type of problem can result in the replacement of non-defective parts.

Many intermittent problems are caused by faulty electrical connectors or wiring. Diagnosis must include a careful inspection of the indicated circuit wiring and connectors. For example, an intermittent code 35 (Oil Pressure Sensor High Voltage) would indicate a problem in the following areas associated with the Oil Pressure Sensor.

Wires E31 (signal line), E12 (+5 volt line), or E15 (ground line).

The Oil Pressure Sensor connector or ECU connector.

An intermittent problem in the Oil Pressure Sensor (least likely).

Use the following checklist:

  1. Check for poor mating of the connector halves or terminals not fully seated in the connector body (backed out terminals).

  2. Look for improperly formed or damaged terminals. All connector terminals in the problem circuit should be carefully inspected to determine proper contact tension. Use a mating terminal to test the contact tension.

  3. Electrical system interference caused by a defective relay, ECU driven solenoid, or a switch causing an electrical surge. Look for problems with the charging system (alternator, etc.). In certain cases, the problem can be made to occur when the faulty component is operated as in the case of a relay.

  4. Verify alternator grounds are clean and making good contact. Disconnect the alternator belt to test.

  5. Wiggle wires and harnesses to try to make the problem active, or occur again.

Verify Repairs

Perform the following steps to verify repairs.

  1. Clear codes.

  2. Confirm the AWL does not come on (except for the five second ignition ON bulb check).

  3. Run the engine for one minute.

  4. If the AWL stays ON, refer to Cruise Control.


 INTERMITTENT FAULT

See

INTERMITTENT CODE OR A SYMPTOM AND NO CODES

ENGINE CRANKS BUT WILL NOT START

ERRATIC PERFORMANCE AND NO CODES

AMBER WARNING LAMP AND RED STOP LAMP FAULT

NO DATA TO DIAGNOSTIC DATA READER

DIAGNOSTIC REQUEST SWITCH INOPERATIVE

CRUISE CONTROL INOPERATIVE

FAN OPERATIONAL CONCERN (ON/OFF TYPE)

FAN OPERATIONAL CONCERN (VARIABLE SPEED TYPE)

ENGINE BRAKE INOPERATIVE

MISCELLANEOUS DIGITAL INPUT FAULT

MISCELLANEOUS DIGITAL OUTPUT FAULT

FIRE TRUCK PRESSURE GOVERNOR FAULT

TROUBLESHOOTING ELECTRONIC FIRE COMMANDER

OPTIMIZED IDLE FEATURE DOES NOT FUNCTION

OPTIMIZED IDLE

TRANSMISSION INTERFACE FAULT

MAINTENANCE ALERT SYSTEM

EXHAUST GAS RECIRCULATION SYSTEM BASIC CHECKS FOR SERIES 60 ENGINES

Next section

INTERMITTENT CODE OR A SYMPTOM AND NO CODES

Previous section


 Jake Brake (See Engine Brake)

For information on the Jake Brake®, refer to Engine Brake (Jake Brake).

Next topic

OPTIMIZED IDLE FEATURE

Previous topic


 Locking Terminal Into Connector


 MAINTENANCE ALERT SYSTEM

The following procedures will troubleshoot the Maintenance Alert System (MAS).

Maintenance Alert System Troubleshooting

The following procedures will troubleshoot a Maintenance Alert System (MAS) display problem.

Listed in the following table are typical faults.

Fault | Typical Fault | Refer to
No lights, blank display. | Loss of power to display module | Checking for Power to Display, below
All red LEDs flashing. | Data link wire fault | Check for Open Data Link Wires
Single item LED blank. | Sensor fault, refer to sensor troubleshooting. | Refer to Information
Checking for Power to Display

Perform the following steps to check for power to the display:

  1. Unplug MAS display harness.

  2. Check connectors for bent, corroded, or unseated pins.

[a] If connectors are bent, corroded or otherwise damaged, replace them and test the operation.

[b] If connectors are in good condition, continue the inspection.

  3. Turn the ignition ON.

  4. Measure the voltage between cavity A ground and cavity C (V15) ignition. See Maintenance Pro Display Harness.

[a] If voltage is less than 10.5 volts, determine the reason for low voltage. Refer to OEM guidelines. One possibility is a battery fault.

[b] If voltage is greater than 10.5 volts, refer to Step 5.

  5. Measure voltage between cavity A ground and cavity B, battery (+). See Maintenance Pro Display Harness.

[a] If the measured voltage is less than 10.5 volts, charge the batteries or check for bad 12 volt wire. Refer to Verify Repairs.

[b] If the voltage is greater than 10.5 volts, replace the display; verify repair. Refer to Verify Repairs.


 Maintenance Alert System


 Maintenance Pro Display Harness


 MAS Pigtail


 Mass Air Flow Sensor

The Mass Air Flow sensor, MAF, measures the EGR flow rate. See Mass Air Flow Sensor.

Next topic

SUPPLY FUEL TEMPERATURE SENSOR

Previous topic


Mass Air Flow Sensor_1

 Mass Air Flow Sensor


 Measuring Battery Voltage


 Message Identification Descriptions

MID: 128 ENGINE, Single ECU applications

Diagnostic codes with Subsystem Identification Characters (SIDs) that reference Auxiliary Outputs # 1-8 (SIDs: 26, 40, 51, 52, 53, 54, 55, 56) will look up the parameter text description in a table to identify the function assigned to the auxiliary output channel.

Diagnostic codes with SIDs that reference PWM Outputs #1 through #4 (SIDs: 57, 58, 59 & 60) will look up the parameter text description in a table to identify the function assigned to the PWM output channel.

Injector Response Time Codes Long and Injector Response Time Codes Short will use a table of injector numbering to identify the appropriate engine cylinder number.

Next topic

ELECTRICAL CIRCUITS

Previous topic


 MISCELLANEOUS DIGITAL INPUT FAULT

The troubleshooting procedure will cover miscellaneous input switch faults. All faults function in the same manner, allowing the same troubleshooting process to be used regardless of the function.

There are 12 digital input cavities, listed in the following table, available on a DDEC ECU. Any available function can be assigned (programmed with the Programming Station) to any of the available cavities.

When a digital input wire is switched to battery ground (usually V59), it is a request to the ECU to activate the function assigned to that wire. Additional conditions may need to be met for the feature to activate. Refer to the appropriate Application and Installation manual for these conditions.

Input Cavities | Input Cavities
V41 | V0
V25 | V50
V24 | V10
V42 | V5
V47 | V08
V09 | V39

Available functions are listed in the following table.

Functions | Functions | Functions
None | Limiting Torque Curve | Trans Retarder Status
Engine Brake Low | Diagnostic Request | Dual Throttle (LSG)
Engine Brake Med | Alt Min VSG/Fast Idle | A/C Fan Status
Aux Shutdown #1 | Service Brake Release | Aux CLS
Aux Shutdown #2 | Clutch Released | Fan Control Override
Park Brake / ISD | Set Coast OFF DDEC II | VSG Station Change
Idle Validation | Set / Coast ON | VSG Station Complement
Pressure / RPM Mode | Resume/Accel OFF DDEC II | Air Load Switch
Throttle Inhibit | Resume / Accel ON | In Neutral Switch
RPM Sync (Marine) | Cruise Enable | In Gear Switch
RPM Freeze (Marine) | PSG System Enable | KD Brake
Rating Switch #1 | SEO / DIAG Request | Gas Valve Diagnostic
Rating Switch #2 | Engine Brake Disable | -


 MISCELLANEOUS DIGITAL OUTPUT FAULT

This section is designed to diagnose an output fault (feature not functioning). Since all outputs operate in the same manner, this troubleshooting section can be used regardless of the function assigned.

DDEC ECU

The DDEC ECU has seventeen available digital output cavities. Nine are located at the engine harness connector and eight at the vehicle harness connector. Output functions (features) are assigned (programmed with the programming station) to almost any available cavity. The ECU switches the cavity to battery (-) to allow the function to activate. Some output activation is dependent on other parameters being met. (e.g. minimum, r/min, etc.) Perform the following steps to check the DDR for codes.

NOTE: Some ECU software on newer engines will require that the ECU 'detects' activity on a brake, clutch and cruise active circuits. Following each ignition on cycle the ECU will require the brake, clutch and cruise activate (circuit goes open and close or message sent to the ECU) before cruise will be allowed to operate.

Additional outputs could be added at a later date. Available functions are listed in the following table.

Functions | Functions | Functions
No Function | Fan Control #2 | Turbo Recirc Valve
Low DDEC Volt | Deceleration Light | Optimized Idle Active
RPM Sync Active | Engine Brake Active | Low Range Solenoid (ESS)
PSG Active Light | VSG Active Indication | High Range Solenoid (ESS)
Vehicle Power Down | Oil Pressure Low Light | Shift Solenoid (Top2)
Starter Lockout | Oil Temp High Light | Shift Lockout (Top2)
Ext Brake Enable | Coolant Temp High Light | Gas Throttle Actuator
Trans Retarder Enable | Air Comp Solenoid | Fuel Supply Solenoid
Coolant Level Low Light | Crankcase Pressure High | KD Brake Solenoid
Cruise Active Light | Coolant Pressure Low | -
Fan Control #1 | Ether Start | -


 NO DATA TO DIAGNOSTIC DATA READER

Before using this procedure, all basic mechanical checks and physical inspections should have been performed with no problem found. Also the diagnosis of the DDEC system in DIAGNOSING A DDEC SYSTEM FAULT referred you to this section.

Read Codes on the Amber Warning Lamp

Perform the following steps to read the codes on the AWL or RSL:

  1. Unplug the DDR.

  2. Ignition should be ON; engine not running.

  3. Enable diagnostic request switch.

  4. Read codes flashing on the AWL and RSL.

[a] If codes are flashing out, refer to Check for Open.

NOTE: If you wish to bypass diagnosis of a potential data line of the DDR problem for now, diagnose the active code by referring to the section that matches the code number.

[b] If AWL and RSL are not flashing out codes, refer to Check Diagnostic Request Circuit.


 Normal Options


 OEM-Installed Sensors

All sensors must be of the proper type and continuously monitor vehicular and environmental conditions, so the ECU can react to changing situations. The OEM is responsible for installing the sensors

Sensor | Part Number | Function
Accelerator Pedal Sensor (AP Sensor) | -- | Senses operator's input to the ECU for throttle input.
Add Engine Coolant Level Sensor (AECL Sensor) | 23522855 23520380 23520381 | Senses coolant level for engine maintenance.
Air Filter Restriction Sensor(AFR Sensor) | 23523756 | Senses the condition of the air inlet filter for engine maintenance.
Engine Coolant Level Sensor (ECL Sensor) | 23522855 23520380 23520381 | Senses coolant level for engine protection.
Fire Truck Pump Pressure Sensor * | 23520795 | Senses water pump pressure to maintain a constant fire truck pump pressure. .
Turbo Compressor In Temperature Sensor | 23527831 | Senses the temperature of the turbo compressor inlet.
Vehicle Speed Sensor (VSS) | -- | Senses vehicle speed for Cruise Control and PTO Control. Total distance accumulation required for ProDriver and a speedometer.
  • Available in some applications

NOTE: The OEM harness must be securely fastened every 6 in. It is required that the harness be fastened within 6 in. of the sensor.

Next topic

ACCELERATOR PEDAL SENSOR

Previous topic


 Oil Level Sensor


 Oil Pressure Sensor


 Oil Temperature Sensor


 Open Previously Saved Snapshot

To open a previously saved snapshot, perform the following.

  1. Select Open from the Snapshot drop-down menu to display an Open dialog box.

Next topic

DDDL INSTRUMENTATION WINDOWS

Previous topic


 Open Window


 OPERATION

For details, see

DDEC BENEFITS

FEATURES

DDEC SYSTEM - HOW IT WORKS

DDEC RELATED PUBLICATIONS

Next topic

DDEC BENEFITS

Previous topic


 OPERATOR INFORMATION

This section should serve as a guideline for the technician:

Intermittent Problems - Talk to the operator/driver. Be specific!

Develop your own Driver Questionnaire. Refer to Driver Questionnaire.

Next topic

DRIVER QUESTIONNAIRE

Previous topic


 Optimized Idle

Optimized Idle must be turned on by the factory via order entry or mainframe setup.

To avoid injury from an accidental startup of an engine equipped with the Optimized Idle®system, remove the starter relay from the relay holder.

To avoid injury from accidental engine startup, replace a defective ECM with an ECM programmed with identical inputs and outputs.
Next topic

OPERATION

Previous topic


 OPTIMIZED IDLE

Optimized Idle®with DDEC V reduces engine idle time by running the engine only when required. Optimized Idle automatically stops and restarts the engine to accomplish the following:

Keep the engine oil temperature between factory set limits 60°F (16°C) - 104°F (40°C)

Keep the battery charged>12.2 V (12 V system), >24.4 V (24 V system)

Keep the cab/sleeper or passenger area at the desired temperature (using the optional thermostat) - On-highway truck and coach applications

Other benefits include overall reduction in exhaust emissions and noise, and improved starter and engine life (by starting a warm engine and eliminating starting aids). Idle time and fuel savings information stored in the ECU memory can be read with DDDL, ProDriver Reports or DRS. Optimized Idle run times can be accessed through DDEC Reports. The Optimized Idle Active Lamp is steadily illuminated when Optimized Idle run times are logged.

Next topic


 Optimized Idle Feature

The Optimized Idle®feature can be set with the mainframe. Refer to the Optimized Idle Installation and Troubleshooting Manual, 7SA734, for all required information.

Next topic

OUTPUT FUNCTIONS

Previous topic


 OPTIMIZED IDLE FEATURE DOES NOT FUNCTION

The following procedure will troubleshoot Optimized Idle not functioning.

To avoid injury from accidental engine startup, replace a defective ECM with an ECM programmed with identical inputs and outputs.
NOTE: If a replacement ECU is needed, replace the ECU with an ECU programmed with Optimized Idle.

To avoid injury from an accidental startup of an engine equipped with the Optimized Idle®system, remove the starter relay from the relay holder.
Check Diagnostic Data Reader for Codes

Perform the following steps to check the DDR for codes.

  1. Plug DDR into connector.

  2. Turn ignition ON.

  3. Check the active and inactive codes for any Optimized Idle codes.

  4. Turn ignition OFF.

NOTE: Service any code first.

[a] If an Optimized Idle code 62, 63, or 74 is logged, go to the appropriate flash code section, based on Optimized Idle code logged.

[b] If an Optimized Idle code 62, 63 or 74 is not logged, refer to Heater and Air Conditioning Fans Do Not Function.


 Optimized Idle Schematic


 Optimized Idle System Overview


 Output Functions

The DDEC system has three digital output ports located on the vehicle interface harness and three digital output ports located on a pigtail off the engine sensor harness. These digital outputs can be configured for various functions. The digital output cavities are listed in the following table..

Output | Cavities | Output | Cavities
VIH |  | ESH |
A1 | #988 | W3 | #563
A2 | #555 | X3 | #564
F3 | #499 | Y3 | #565
These functions can be ordered at the time of engine order. The digital output functions available are listed in the following table. Any digital output function can be customized by programming the ECU with the programming station

Functions | Functions | Functions
No Function | Fan Control #2 | Turbo Recirc Valve
Low DDEC Volt | Deceleration Light | Optimized Idle Active
RPM Sync Active | Engine Brake Active | Low Range Solenoid (ESS)
PGS Active Light | VSG Active Indication | High Range Solenoid (ESS)
Vehicle Power Down | Oil Pressure Low Light | Shift Solenoid (Top2)
Starter Lockout | Oil Temp High Light | Shift Lockout (Top2)
Ext Brake Enable | Coolant Temp High Light | Gas Throttle Actuator
Trans Retarder Enable | Air Comp Solenoid | Fuel Supply Solenoid
Coolant Level Low Light | Crankcase Pressure High | KD Brake Solenoid
Cruise Active Light | Coolant Pressure Low | -
Fan Control #1 | Ether Start | -
Next topic

PASSWORDS

Previous topic


Overview

 DETROIT DIESEL DIAGNOSTIC LINK - Overview

The Detroit Diesel Diagnostic Link (DDDL) Help system provides complete instructions for using the DDDL.

The DDDL is a sophisticated software package supporting the setting up, maintenance, and repair of engines using the DDEC II, DDEC III, DDEC IV, DDEC V Engine Control Modules, and also supports the MBE Engines.

DDDL functions are applicable to both DDEC and the MBE engines, although in some cases the details are different. Some functions are specific to either DDEC or the MBE engines. The Help system will make clear which type of engine a function applies to and, if it applies to both types, any differences there may be.

The capabilities of the program are as follows.

Calibration functions.

Diagnostic and maintenance functions.

Next topic

CALIBRATION FUNCTIONS

Previous topic


 Passwords

DDEC ECMs have the ability to have unique and separate passwords in the following areas:

Update customer calibration (calibration change)

Rating change

Function lockout (4.00 or higher ECU software function)

Injector calibration (Only the DDR will change this password)

Next topic

CHANGING PASSWORDS USING THE DIAGNOSTIC DATA READER

Previous topic


 Pins V61 through V68 to Battery Leads


 Positioning the Leads


 Power Harness


 Pressing the Locking Tang


Pressing the Locking Tang_1

 Pressing the Locking Tang


 Pressure Governor System (Fire Truck)

The pressure governor system allows the engine speed to fluctuate to maintain a steady water pump outlet pressure.

NOTE: This system can be set on the mainframe only (Fire Truck Applications 6N4C change).

The system requires the mainframe to be set to enable the feature. A pressure transducer is required.

NOTE: The same transducer is used for DDEC II systems and III systems.

Control of the system can be done with switches/Mastermind for DDEC II systems or with Switches/Mastermind or Electronic Fire Commander (EFC) for DDEC III systems. Basic operation is the same for all systems.

The mastermind part number differs for DDEC II systems vs. DDEC III systems.

Next topic

PROGRESSIVE SHIFT CONFIGURATION

Previous topic


 Pressure Sensors Schematic


 Pressure Transducer


 Pressure Transducer and Harness Connector


 Pressurized Fluids

Be extremely careful when dealing with fluids under pressure. Fluids under pressure can have enough force to penetrate the skin. These fluids can infect a minor cut or opening in the skin. If injured by escaping fluid, see a doctor at once. Serious infection or reaction can result without immediate medical treatment.

To avoid injury from the sudden release of a high-pressure hose connection, wear a face shield or goggles.

To avoid injury from penetrating fluids, do not put your hands in front of fluid under pressure. Fluids under pressure can penetrate skin and clothing.

Next topic

FUEL

Previous topic


 Print Function

Print custom data list of snapshot. The printer is attached to the DDR.

  1. Select PROLINK. ENTER.

  2. Select RS-232 SERIAL PORT. ENTER.

  3. Select PRINTER OUTPUT. ENTER.

  4. Arrow up or down to SNAPSHOT DATA. ENTER.

  5. Right to CUSTOM. ENTER twice.

  6. Select six items from data list using arrow up or down. ENTER after each selection. - FUNC.

  7. Type 001; ENTER; 090; ENTER.


 PROGRAMMING THE ELECTRONIC FIRE COMMANDER

Program the EFC by selecting items from a menu. When the EFC is in Programming Mode only the Information Center lights will be visible.

To enter the programming menu:

  1. Ensure the PTO/Pump is disengaged (i.e. 0 volts on pin B10 "PTO/Pump Engaged") and that engine speed is less than 900 RPM.

  2. Press and hold the MODE and MENU buttons at the same time until "PRESS IDLE TO EXIT" is momentarily displayed on the Information Center, then release both buttons.

  3. Scroll through the menu by pressing the MENU button.

  4. Change a menu selection using the INC and DEC buttons.

  5. Exit the programming menu in one of two ways:

[a] Press IDLE to exit the menu and save changes.

[b] Press MODE to exit the menu without saving changes.

Next topic

EFC PROGRAMMING MENU OPTIONS

Previous topic


 Progressive Shift Configuration

Progressive shift configuration can be set with the DDR or programming station and can be used to force shifting. It is also useful to limit engine r/min in certain gears, to force shifting to a higher gear. Use Spec Manager to determine values to enter.

Next topic

RATING SELECTIONS

Previous topic


 Pro-Link


 Pro-Link 9000


 Pro-Link 9000 Printer, J 38480


 Pro-Link Diagnostic Data Reader, J 38500


 Pump Pressure Sensor


 Pushing Terminal Into Grommet


 Questionnaire Response Guideline

The following are typical responses to the Driver Questionnaire:

  1. If the problem is repeatable, take the vehicle for a drive with the DDR connected and note the conditions when the problem occurs. Be prepared to take snapshot data using the DDR. Ensure you operate the vehicle after correcting the problem and duplicate the operating conditions before releasing the unit, to verify the problem is corrected.

  2. If the vehicle has been to other shops for the same problem, call the other shops and find out what has been done. Avoid replacing the same components again unless absolutely sure they are the problem! It is unlikely a component will fail again following a recent replacement.

  3. If other vehicle devices are affected, this indicates there may be something wrong with the ignition wiring. Refer to VEHICLE HARNESS for information on inspecting the ECU battery connections.

  4. Operate the engine under similar load conditions. Check the fuel system for restrictions, primary filter, and fuel tanks for foreign objects blocking the fuel supply. Also, check the air system. Utilize the DDR snapshot feature.

  5. Operate the engine at this temperature while attempting to duplicate the problem. Use the snapshot feature on the DDR.

  6. If possible, troubleshoot the problem in this temperature range.

  7. If the problem seems to occur during or after the engine is subjected to rain/spray washing, thoroughly inspect the connectors for moisture entry.

  8. If the problem occurs at a specific vehicle speed, check the parameters affecting vehicle speed to verify they are programmed close to the vehicle speed where the problem occurs. Check Vehicle Speed and watch the DDR (snapshot) for changes to see if the pulse wheel (VSS signal) is loose.

  9. If the problem occurs at a specific engine r/min, unplug the oil, coolant, and air temperature sensors, and note any changes to the problem. Gather this data and contact Detroit Diesel Technical Service.

Next topic

SERVICE TOOLS

Previous topic


 Rating Selections

Ratings can be selected with DDR or programming station. Selections are limited to ratings available within the 6N4D group.

Next topic

TOP 2 (EATON)

Previous topic


 Read Active Codes

Perform the following steps to read the active codes.

  1. Turn ignition on. Plug DDR into DDL connector. See Diagnostic Connector.

  2. Read active codes by selecting the DIAGNOSTIC CODE MENU (ACTIVE CODES) on the DDR.

[a] If active codes are displayed on the DDR, follow the appropriate diagnostic procedures for the codes received. Refer to the section number that is the same as the Flash Code number.

[b] If the DDR display is blank or random, refer to NO DATA TO DIAGNOSTIC DATA READER.

[c] If DDR displays NO DATA or DDEC Info not available, refer to NO DATA TO DIAGNOSTIC DATA READER.

[d] If the DDR display reads "No Active Codes", refer to AMBER WARNING LAMP AND RED STOP LAMP FAULT.


 Read Inactive Codes

Perform the following steps to read inactive codes.

  1. Plug DDR into the DDL connector.

  2. Read inactive codes. (Select inactive codes on the DDR.)

[a] If DDR displays no inactive codes, the problem may be intermittent. Refer to INTERMITTENT CODE OR A SYMPTOM AND NO CODES.

[b] If DDR display is blank or random, refer to NO DATA TO DIAGNOSTIC DATA READER.

[c] If DDR displays NO DATA or DDEC Info not available, refer to NO DATA TO DIAGNOSTIC DATA READER.

[d] If the DDR displays any inactive codes, clear the codes and refer to Attempt to Make Codes Active.


 READING CODES

For instructions for using the DDR or Pro-Link 9000®, (see Pro-Link 9000), refer to the Pro-Link Users Manual. Pro-Link®is a registered trademark of Micro Processor Systems, Inc. For a list of Flash Codes and SAE Fault Codes, refer to DDEC DESCRIPTIONS. Refer to flowchart.

Reading Codes with the DDDL is accomplished by selecting "Fault Codes" from the Diagnostic Reader. See Selecting Fault Codes.

Next topic

DDEC DESCRIPTIONS

Previous topic


 READING CODES WITH DIAGNOSTIC DATA READER

Flash codes are used for operator convenience to advise of an engine fault or sensor failure. SAE specific codes are read with the Diagnostic Data Reader (DDR). In some cases, one flash code may be used to cover more than one component fault. For this reason the DDR (or Diagnostic Data Link, DDL) must be used to identify the specific code.

The Diagnostic Code Menu selections are defined as follows.

Active codes

Inactive codes

Clear codes

To read codes, start with the Menu Selection screen.

  1. To call up active codes:

[a] Select ENGINE and ENTER three times.

  2. To call up inactive codes:

[a] Select ENGINE and ENTER twice.

[b] Select INACTIVE CODES and ENTER.

  3. To clear codes:

[a] Select ENGINE and push ENTER twice.

[b] Go down and select CLEAR CODES and ENTER.

[c] Left to YES, and ENTER.

[d] Wait and then push FUNC three times.

[e] Go to lines 1 and 2 of the Engine Data List, Active and Inactive Codes, and verify that both lines display NO.

Next topic

FAULT CODES AND DDDL

Previous topic


 READING THE DIAGNOSTIC CODES - FLASH METHOD

The following steps describe the flash method to interpret diagnostic codes:

NOTE: If you are here to begin diagnosis of a problem and already know how to read codes, as well as understand active and inactive codes, refer to DIAGNOSING A DDEC SYSTEM FAULT.

  1. Active versus Inactive codes:

[a] Active codes are the codes which are currently keeping the "Check or Stop Engine" light on. Active codes are flashed via the Red Stop Lamp (RSL).

[b] Inactive codes are all the codes previously logged in the ECU. These codes can be cleared by using the DDR. Inactive codes are flashed via the Amber Warning Lamp (AWL).

NOTE: The Diagnostic Request Switch reads codes on the AWL and RSL when an DDR is not available. The following steps will enable you to obtain codes.

  2. Turn vehicle ignition switch ON.

  3. Depress and hold the diagnostic request switch.

[a] As an example, observe Code 13 (active) and Code 21 (inactive) flashing out on the AWL and RSL; see Flash Code Method.

[b] If input used is SEO/Diagnostic Request, press and release the switch.

[c] If input used is Diagnostic Request, press and hold switch.

NOTE: Active codes are flashed in ascending numerical flash code order. Inactive codes are flashed in most recent to least recent order.

Next topic

CLEARING CODES

Previous topic


 Recommended Strain Relief of Spliced Joint


 Record Snapshot


 Removal Tool Insertion


 Removal Tool Position


 Removing the Terminal


Removing the Terminal_1

 Removing the Terminal


Removing the Terminal_2

 Removing the Terminal


 Removing the Terminal Position Assurance


 Replay Control Window


 Reprogram Calibration

Start with the Menu Selection screen.

  1. Select ENGINE and ENTER.

  2. Down to CALIBRATION CHANGE and ENTER.

  3. Select REPROGRAM CAL and ENTER.

  4. Enter password: 0000 or xxxx and ENTER (xxxx=1 to 9 and A to Z).

  5. Select menu to be changed with UP/DN arrow keys and ENTER twice.

  6. Use RT/LT arrow keys to change a word or put in a new # and ENTER.

  7. When finished, select FUNC.

  8. SELECT ANOTHER MENU: left to YES and ENTER, or NO and ENTER.

  9. Left to YES and ENTER.

  10. Wait and then ENTER to continue.


 Resistance Measurements

Perform the following steps to measure resistance:

  1. Connect the red test lead to the V- [image] (Volt-Ohm) input connector and the black lead to the com input connector on the meter.

  2. Set the function/range switch to the desired [image] [image] position. If the magnitude of the resistance is not known, set the switch to the highest range, then reduce until a satisfactory reading is obtained.

  3. If the resistance being measured is connected to a circuit, turn off the power to the circuit being tested. Turn off the ignition.

  4. Connect the test leads to the circuit being measured. When measuring high resistance, be careful not to contact adjacent points, even if they are insulated. Some insulators have a relatively low insulation resistance which can affect the resulting measurement.

  5. Read the resistance value on the digital display.

Next topic

CONTINUITY CHECKS

Previous topic


 REVISION NOTIFICATION

This Help is based on the DETROIT DIESEL®DDEC®V SINGLE ECM TROUBLESHOOTING GUIDE. Modifications to this manual are announced in the form of Service Information Bulletins. The bulletins include attachment pages and are posted on the World Wide Web. (www.detroitdiesel.com/svc/sibinex.htm).

Revisions to the manual will be sent marked with a revision bar. Sections containing revisions will have added information in the page footer.

Next topic

TROUBLESHOOTING INFORMATION

Previous topic


 SAFETY INSTRUCTIONS

To reduce the chance of personal injury and/or property damage, the instructions contained in this Troubleshooting Help must be carefully observed. Proper service and repair are important to the safety of the service technician and the safe, reliable operation of the engine.

If part replacement is necessary, the part must be replaced with one of the same part number or with an equivalent part number. Do not use a replacement part of lesser quality. The service procedures recommended and described in this manual are effective methods of performing repair. Some of these procedures require the use of specially designed tools. Accordingly, anyone who intends to use a replacement part, procedure or tool which is not recommended, must first determine that neither personal safety nor the safe operation of the engine will be jeopardized by the replacement part, procedure or tool selected.

It is important to note that this Help contains various "Cautions" and "Notices" that must be carefully observed in order to reduce the risk of personal injury during repair, or the possibility that improper repair may damage the engine or render it unsafe. It is also important to understand that these "Cautions" and "Notices" are not exhaustive, because it is impossible to warn personnel of the possible hazardous consequences that might result from failure to follow these instructions.

Next topic

REVISION NOTIFICATION

Previous topic


 SAFETY PRECAUTIONS

The following safety precautions must be observed when working on a Detroit Diesel engine:

Diesel engine exhaust and some of its constituents are known to the State of California to cause cancer, birth defects, and other reproductive harm.
Always start and operate an engine in a well ventilated area.
If operating an engine in an enclosed area, vent the exhaust to the outside.
Do not modify or tamper with the exhaust system or emission control system.

To avoid injury from accidental engine startup while servicing the engine, disconnect/disable the starting system.

To avoid injury from the sudden release of a high-pressure hose connection, wear a face shield or goggles. Bleed the air from the air starter system before disconnecting the air supply hose.
All engine installations, especially those within enclosed spaces, should be equipped with an exhaust discharge pipe so that exhaust gases are delivered into the outside air.

Next topic

DETROIT DIESEL DIAGNOSTIC LINK

Previous topic


 Securing the Leads With a Clip


 Selecting Fault Codes


 Sensors

The DDEC V system is designed to operate with several types of sensors as listed in the following table.

Sensor Type | Description
Variable Reluctance | Used to monitor the crankshaft position and the engine speed.
Thermistor | Used to monitor temperatures.
Variable Capacitance | Used to monitor barometric air, manifold, oil gallery and optional pump pressures.
Variable Resistance (Potentiometer) | Used to sense throttle position.
Switch | Used to signal coolant level, inlet air restriction, and oil level.
Magnetic Pick-up | Used to sense vehicle speed, accumulate trip distance, and enable several vehicle features.

The sensors integrated into the Engine Harness are factory-installed. The sensors integrated into the Vehicle Interface Harness are installed by the OEM.

Next topic

FACTORY-INSTALLED SENSORS

Previous topic


 Series 60 EGR Engine Senors

EGR
         9.
         EGR Temperature Sensor

VNT
         10.
         Turbo Boost Sensor

Turbo Compressor Outlet Temp Sensor
         11.
         Intake Air Temperature Sensor

Oil Temperature Sensor
         12.
         Oil Pressure Sensor

VPODs
         13.
         Barometric Pressure Sensor

Coolant Temperature Sensor
         14.
         SRS

Turbo Speed Sensor
         15.
         TRS

DElta-P Sensor


 Series 60 Injector


 Series 60 Injector Harness with Jake Brake


 SERVICE TOOLS

Listed in the following table are the service tools required to perform troubleshooting procedures for the DDEC-equipped engine.

Tool Number | Tool Name
J 47500 | DDDL Kit see DDDL Kit
J 40901 | DRS Interface Module (Programming ECU) see DRS Interface Module (Programming ECU)
J 39299 | Volt-Ohm Meter; see Volt-Ohm Meter
J 38500 | Pro-Link®Diagnostic Data Reader; see Pro-Link Diagnostic Data Reader
J 41005 | Vehicle Interface Module; see DDEC Interface Module
J 41005-5 | DDEC V adaptor harness for Vehicle Interface Module
J 38480 | Pro-Link Printer; see Pro-Link 9000 Printer
23516937 | Digital Diesel Sensor Simulator; see Digital Diesel Sensor Stimulator, P/N: 23516937 (Optional Tool)
J 35751 | Jumper Wire Kit
Next topic

DETROIT DIESEL DIAGNOSTIC LINK - Overview

Previous topic


 SERVICING DDEC CONNECTORS

Newly released kits make servicing DDEC connectors and terminals easier than ever. Crimp tools are not required for simple factory approved repairs. The DDEC V harness repair kit is P/N 23533513 - it contains all connectors and parts needed for wiring repairs.

Additionally, it is recommended that whenever possible, the connector and harness incorporate a "service loop" on sensor connections. To achieve this, the harness should be looped back and tie wrapped to the sensor leaving a 3-inch loop. This size loop has proved to substantially protect the mating connector terminals. See Connector Service Loop.

Whenever a connector tie wrap is removed for testing or servicing a connection, ensure it is replaced with a new tie wrap.

Next topic

IMPORTANT INFORMATION

Previous topic


 Setting Wire Gage Selector and Positioning the Terminal


 Shrink Wrap

Shrink wrap is required when splicing non insulated connections. Raychem HTAT or any equivalent heat shrink dual wall epoxy encapsulating adhesive polyolefin is required. Shrink wrap must extend at least .25 in. (6 mm) over wire insulation past splice in both directions.

Alpha Wire Corporation
         Tyco Electronics Corporation
711 Lidgerwood Ave
         Raychem Cable Identification and Protection
P.O. Box 711
         300 Constitution Drive
Elizabeth, New Jersey 07207-0711
         Menlo Park, CA 94025
  1. 800-52ALPHA
Phone: 1 - 800 - 926 - 2425
www.alphawire.com
         www.raychem.com
To heat shrink wrap a splice:

NOTICE:
The heat shrink wrap must overlap the wire insulation about .25 in. (6 mm) on both sides of the splice.
  1. Select the correct diameter to allow a tight wrap when heated.

  2. Heat the shrink wrap with a heat gun; do not concentrate the heat in one location, but apply the heat over the entire length of shrink wrap until the joint is complete.

  3. Repeat step 2 to apply a second layer of protection (if required by splicing guidelines).

Next topic

STAGGERING WIRE SPLICES

Previous topic


 Shroud Tabs


 Side View of Shroud, ECU Connector and Conduit


 Snapshot Sequence

Start with the Menu Selection screen.

  1. Select PRO-LINK and ENTER.

  2. Go up to SNAPSHOT and ENTER.

  3. Go down to DATA UPDATE RATE and ENTER.

  4. Type in NEW RATE and ENTER (.0 to 9.9 seconds), (90 frames will be recorded).

  5. Up to TRIGGER SETUP and ENTER.

  6. Select TRIGGER SOURCE and ENTER:

[a] Any Numeric Key

[b] Any code

[c] Specific PID

[d] Specific SID

  7. Adjust TRIGGER POINT: NO, or select YES and ENTER; change trigger point with RT/LT arrow keys. ENTER.

  8. WAITING FOR TRIGGER. When ready to take SNAPSHOT, apply the trigger. ANY NUMERIC KEY overrides all other triggers.

  9. PROCESSING TRIGGER; Filling remaining frames (90 frames max). When all frames are filled, the first three lines of the TRIGGER FRAME, T, will display.

[a] To do SNAPSHOT after setup is done, do items 1, 2, and 8 only, or go to QUICK TRIGGER and ENTER.

[b] SNAPSHOT DATA stays stored in Pro-Link memory as long as the DDR remains powered up.


 Snapshots

If you have opened a snapshot, the replay controls are added to the bottom of the Fault Codes window when it is selected. This way you can monitor fault codes produced during the snapshot.

When the window is used for a snapshot, the Clear Selected Codes and Clear Inactive Codes buttons are hidden since these operations are only relevant when you are connected to an operating ECU.

Next topic

TOOLS

Previous topic


 Software

The VEPS PC software package consists of the several files which are extracted when the software installation program is executed. A System Users Manual which defines the available parameters is included with the software package at the time of purchase.

The PC interface utilizes a communications driver which is defined in the TMC Recommended Practice RP1210A. The RP1210A software is used to translate the datalink signal of the ECU to the format required by Windows programs. The RP1210A communications driver is included as part of the VEPS software package.

Next topic

HARDWARE

Previous topic


 SOFTWARE UPGRADES

Note: These engines are equipped with DDEC software. This software generally assures optimal engine performance. The installation of software upgrades may cause minor changes in features and engine performance.

Next topic

SAFETY INSTRUCTIONS

Previous topic


 Speed Sensors Schematic


 Splicing and Repairing Straight Leads-Alternate Method 1

The tools required are listed in the following table.

Tool | Part Number
Heat Gun | --
Wire Stripper | Kent-Moore J 35615 or equivalent
Splice Clips (commercially available) | Wire size dependent
Heat Shrink Tubing | Raychem HTAT or equivalent

Criteria: Splicing Straight Leads

No more than one strand in a 16 strand wire may be cut or missing.

The recommended method to splice straight leads follows:

  1. Locate broken wire.

  2. Remove insulation as required; be sure exposed wire is clean and not corroded.

  3. Insert one wire into the splice clip until it butts against the clip. Stop and crimp (see Splicing Straight Leads - Alternate Method 1, A).

  4. Insert the other wire into the splice clip until it butts against the clip stop (see Splicing Straight Leads - Alternate Method 1, B).

NOTICE:
Any terminal that is cracked or ruptured is unacceptable as malfunctions may occur.
  5. Visually inspect the splice clip for cracks, rupture, or other crimping damage. Remove and replace damaged clips before proceeding.

  6. Pull on wire to ensure the splice integrity. The criteria listed in the following table must be met.

Wire Gage | Must Withstand Applied Load
14 AWG | 45 lb (200 N)
16 AWG | 27 lb (120 N)
18 AWG | 20 lb (90 N)

  7. Shrink the splice clip insulative casing with a heat gun to seal the splice (see Splicing Straight Leads - Alternate Method 1, C ).

  8. Loop the lead back over the spliced joint and tape. See Recommended Strain Relief of Spliced Joint.

Next topic

SPLICING AND REPAIRING STRAIGHT LEADS - ALTERNATE METHOD 2

Previous topic


 Splicing and Repairing Straight Leads - Alternate Method 2

This method is not allowed or recommended for power, ignition, or injector circuits. The tools required are listed in the following table.

Tool | Part Number
Heat Gun | --
Wire Stripper | Kent-Moore J 35615 or equivalent
Splice Clips (commercially available) | Wire size dependent
Heat Shrink | Tubing Raychem HTAT or equivalent

Criteria: Splicing Straight Leads

No more than one strand in a 16 strand wire may be cut or missing.

An acceptable option for splicing straight leads is:

  1. Locate broken wire.

  2. Remove insulation as required; be sure exposed wire is clean and not corroded.

  3. Slide a sleeve of glue lined, shrink tubing (Raychem HTAT or equivalent) long enough to cover the splice clip on the wire and overlap the wire insulation, about in. (6 mm) on both sides (see Splicing Straight Leads - Alternate Method 2, A).

  4. Insert one wire into splice clip until it butts against the splice clip. Stop and crimp (see Splicing Straight Leads - Alternate Method 2, B).

  5. Insert the remaining wires into the splice clip one at a time until each butts against the splice clip; stop and crimp (see Splicing Straight Leads - Alternate Method 2, B).

NOTICE:
Any terminal that is cracked or ruptured is unacceptable as malfunctions may occur.
  6. Visually inspect the terminal for cracks, rupture, or other crimping damage. Remove and replace damaged terminal before proceeding.

  7. Slide the shrink tubing over the crimped splice clip (see Splicing Straight Leads - Alternate Method 2, C ).

  8. Shrink tubing with a heat gun to seal the splice (see Splicing Straight Leads - Alternate Method 2, D).

NOTICE:
A minimum of two layers of heat shrink tubing must be applied to splices that have more than one lead in or out.
  9. Loop the lead back over the spliced joint and tape. See Recommended Strain Relief of Spliced Joint.

Next topic

SHRINK WRAP

Previous topic


 Splicing Guidelines

The following are guidelines which may be used for splices. The selection of crimpers and splice connectors is optional. Select a high quality crimper equivalent to the Kent-Moore tool, J38706, and commercially available splice clips.

The recommended technique for splicing and repairing circuits (other than power and ignition circuits) is a clipped and soldered splice. Alternatively, any method that produces a high quality, tight (mechanically and electronically sound) splice with durable insulation is considered to be acceptable.

Next topic

CLIPPED AND SOLDERED SPLICING METHOD

Previous topic


 Splicing Straight Leads - Alternate Method 1


 Splicing Straight Leads - Alternate Method 2


 Staggering Wire Splices

Position spliced wires properly as follows:

NOTICE:
You must stagger positions to prevent a large bulge in the harness and to prevent the wires from chafing against each other.
  1. Stagger the position of each splice (see The Correct and Incorrect Method of Staggering Multiple Splices) so there is at least a 2.5 in. (65 mm) separation between splices.

NOTICE:
A minimum of two layers of heat shrink tubing extending 0.25 in. (6 mm) past the splice must be used to complete the splice.
  2. Heat shrink a minimum of two layers of heat shrink tubing.

  3. Tape the spliced wires to each other. Refer to CONDUIT AND LOOM.

Next topic

CONDUIT AND LOOM

Previous topic


 Start New Snapshot

To start a new snapshot, perform the following steps.

  1. Select New from the Snapshot window to open the snapshot control window.

NOTE: The snapshot feature begins immediately upon the appearance of the control window. 3. All electronic engine data transmitted during the snapshot is stored for playback. Any codes that occur during the snapshot are automatically marked. You may mark events any time during the snapshot with the user event button.

  2. Click on the "Annotate" button and a window will appear allowing additional remarks about the current snapshot. See Record Snapshot.

NOTE: Beginning with DDDL 4.1, the user has the ability to add comments to the snapshot.

  3. Hit the stop recording button to finish your snapshot.

NOTE: A dialog box appears giving you the opportunity to save your snapshot. At this point you may choose a name for your snapshot and the location to store it.

Next topic

OPEN PREVIOUSLY SAVED SNAPSHOT

Previous topic


 Supply Fuel Temperature Sensor

The Supply Fuel Temperature sensor, SFT, is a thermistor type sensor that has a variable resistance, when exposed to different temperatures. The EFT Sensor measures fuel temperatures necessary for fuel consumption calculations and fuel input compensation. See Supply Fuel Temperature Sensor - Series 60 and Series 50 Engines.

Next topic

TURBO COMPRESSOR TEMPERATURE OUT SENSOR

Previous topic


 Supply Fuel Temperature Sensor - Series 60 and Series 50 Engines


 TAPE AND TAPING

Tape must be used when conduit is utilized. Be sure to follow the tape manufacturers' guidelines. The harness manufacturer may use tape under the harness covering (conduit or loom) to facilitate harness building. Tape must be tightly wrapped at all conduit interconnections with a minimum of two layers (refer to CONDUIT AND LOOM). Be sure to firmly secure the start and finish ends of tape.

NOTICE:
Black vinyl electrical tape should not be used in applications where the temperature exceeds 176°F (80°C).
Criteria: Tape

In applications where the temperature doesn't exceed 176°F (80°C), black vinyl electrical tape that is flame retardant and weather resistant may be used.

In applications where temperature exceeds 176°F (80°C), vinyl electrical tape should not be used. For these applications, adhesive cloth backed, flame retardant polyethylene or fiber glass tape (Delphi #PM-2203, Polikan #165 or equivalent) is recommended.

Criteria: Taping

The tape must extend a minimum of 1 in. (25 mm) past the conduit.

The tape must be crossed over butted conduit ends.

The tape must be extended a minimum of 1 in. (25 mm) in each direction at all branches.

Next topic

DDEC ECU SOFTWARE FEATURES

Previous topic


 TCI Connector


 TCO Connector


 Temperature Sensor Circuits (View 1)


 Temperature Sensor Circuits (View 2)


 Temperature Sensors Schematic


 Terminal installation and Removal

The method of terminal installation and removal varies, depending on the terminal/connector design. No other terminals are to be removed or installed on the Engine Harness.

Next topic

WIRE AND TERMINAL INSTALLATION - TYCO ECU CONNECTOR

Previous topic


 TESTING / SERVICE TOOLS / TIPS

For details, see

BASICS

OPERATOR INFORMATION

SERVICE TOOLS

DETROIT DIESEL DIAGNOSTIC LINK - Overview

Next topic

BASICS

Previous topic


 The Correct and Incorrect Method of Staggering Multiple Splices


 The Fault Code Window Information (DDEC II)

The DDEC II ECU does not allow you to clear individual codes, so when you are connected to a DDEC II the Clear Inactive Codes and Clear Selected Codes buttons are replaced by a single Clear All Codes button.

To clear all the codes from a DDEC II ECU, click on the Clear All Codes button.

Next topic

SNAPSHOTS

Previous topic


 The Intake Manifold Pressure Sensor

The Intake Manifold Pressure sensor, IMP, provides data to the ECU for use in engine fueling (smoke control). See The Intake Manifold Pressure Sensor - Series 60 and Series 50 Engines for the sensor used in on-highway applications.

Next topic

MASS AIR FLOW SENSOR

Previous topic


 The Intake Manifold Pressure Sensor - Series 60 and Series 50 Engines


 Throttle Position Sensor


Throttle Position Sensor_1

 Throttle Position Sensor


 TOOLS

For details, see

DIAGNOSTIC TOOLS

VEHICLE ELECTRONIC PROGRAMMING SYSTEM

DETROIT DIESEL DIAGNOSTIC LINK

DDEC REPROGRAMMING SYSTEM

DDEC MANUALS

Next topic

DIAGNOSTIC TOOLS

Previous topic


 Top 2 (Eaton)

Top 2 can be set with the programming station. Two outputs are required - shift solenoid and shift lockout. The transmission type is manual.

Next topic

TRANSMISSION TYPE

Previous topic


 TRANSMISSION INTERFACE FAULT

Numerous transmissions utilize the DDEC ECU to receive signals that are used to determine shift points, and/or other information.

Transmission Fault

Transmissions that currently utilize data links:

J1587 - Allison World Transmissions

J1939 Eaton, Allison

J1922 Ceemat

Advanced Interface

ESS ™, Rockwell - Refer to ESS Troubleshooting Manual

Top2, Eaton - Refer to MISC Output Troubleshooting

PWM Signal Type - DDEC provides a PWM signal that is used by the transmission or its components


 Transmission Type

Transmission type can be set with the programming station only. Choices at time of print (may be limited by the application code) are listed in the following table.

Transmission
Transmission
Transmission
00
         Manual
         14
         Other Automatic
         20
         Rockwell RSX9-R

Allison Hydraulic
         15
         GE Statex III
         21
         Rockwell RS10
03
         Voith
         16
         Autoshift / J1939
         22
         Rockwell RSX10
04
         Z-F Ecomat
         17
         Rockwell RS9
         23
         Reserved - RSX10-C
09
         Allison Electronic
         18
         Rockwell RSX9-A
         -
         -
12
         Allison WT
         19
         Rockwell RSX9-B
         -
         -
Next topic

VEHICLE OVERSPEED PARAMETERS

Previous topic


 TROUBLESHOOTING ELECTRONIC FIRE COMMANDER

The Information Center displays DDEC ECM diagnostic codes and limited engine information as well as PSG status.

The Information Center display can be used as an aid in troubleshooting the Pressure Governor System and the Electronic Fire Commander.

This section lists some of the common troubles encountered during the installation and check out of the Electronic Fire Commander. These conditions and suggested actions are listed in the following table.

Condition | Action
EFC Will Not Light Up | Check that the necessary switches are turned on. Check that there is a 12 VDC between pins #1 and #2 at the EFC 4-pin connector, as listed in the first table below.
Throttle Will Not Increase In RPM Mode | Check that the THROTTLE READY lamp is on. The EFC will not respond in RPM mode unless the OEM safety interlock requirements that enable the throttle are met. Press the PRESET and then the INC buttons. Does the EFC indicate it is increasing RPM on the data display? Check the switch and outputs I/O test. (Accessed in the Information Center menu.) Re-initialize the EFC. (Remove power to the EFC; wait ten seconds and then power the unit and try again. The EFC performs a "self-test" when it is powered up. This is indicated on the EFC by a momentary lighting of all the display segments.)
Throttle Will Not Increase In Pressure Mode | Check that all three lamps: PUMP ENGAGED, OKAY TO PUMP, and THROTTLE READY are on. Press the INC and then the PRESET buttons to increase pump pressure. Check for a pump discharge pressure reading in the Menu. Re-initialize the EFC. (Remove power to the EFC; wait ten seconds and then power the unit and try again. The EFC performs a "self-test" when it is powered up. This is indicated on the EFC by a momentary lighting of all the display segments.)
Engine Data Display Is Showing | Check that the connections at pins #3 and #4 of the EFC 4-pin connector, as listed in the first table below, are secure. All Zeroes Check that there is continuity on the 900 and 901 circuits from the ECM connector to the EFC connector.
THROTTLE READY Lamp Will Not Turn On | Check that the parking brake is on. Check that the transmission is in neutral, or the hand throttle (PTO) is engaged. Check for 12 VDC at pin #2 of the EFC 12-pin connector as listed in the second table below. Check that all OEM safety requirements for pump operation are fulfilled. Is the parking brake on? Is the transmission in the proper range for pump operation? Is the hand throttle (PTO) engaged? Is there an OK to PUMP indication in the cab. Check for 12 VDC at pin #10 of the EFC 12-pin connector as listed in the second table below.
Mode Will Not Change From RPM to Pressure | Are the PUMP ENGAGED and OKAY TO PUMP lamps on? Does the MODE switch pass the I/O test? (Accessed in the Information Center menu.)
PRESET Button Doesn't Work | Check that the proper lamps are on for the mode you want to operate. Is there a valid preset programmed into the menu? If not, refer to section Programming The Electronic Fire Commander and complete the steps given there. Does PRESET pass the I/O test? (Accessed in the Information Center menu.)

4-pin Connector, Deutsch DT06-4S, DDC P/N: 23512304

EFC Connector Cavity | Circuit Description | ECM Circuit | EFC Input/Output
A1 | DDEC Accessory Power | V15 | (+) System Power
A2 | DDEC Accessory Ground | Batt (-) | (-) System Ground
A3 | DDEC 1708 Data Link (+) | V56 | J1587 Serial Link
A4 | DDEC 1708 Data Link (-) | V57 | J1587 Serial Link

12-pin Connector, Deutsch DT06-12S, DDC P/N: 23520825

EFC Connector Cavity | Circuit Description | ECM Circuit * | EFC Input/Output
B1 | DDEC PSG Mode Select | V26 | Output (ground) to DDEC
B2 | OEM Interlock from OEM | - | Input (+12 VDC)
B3 | Cavity plug | - | No connection
B4 | DDEC PSG Mode | V5 | Input (ground) from DDEC
B5 | DDEC PSG Enable | V9 | Output (ground) to DDEC
B6 | DDEC PSG Increase | V8 | Output (ground) to DDEC
B7 | DDEC PSG Decrease | V47 | Output (ground) to DDEC
B8 | PSG Active | V6 | Input (ground) from DDEC
B9 | Alarm | - |
B10 | PTO Engaged | - | Input (+12 VDC) from OEM
B11 | Cavity Plug | - | No connection
B12 | Low fuel | - |
  • DDC circuit numbers and port assignments shown are typical but can differ from application to application.

Next topic


 TROUBLESHOOTING EXHAUST GAS RECIRCULATION (EGR) VALVE CURRENT HIGH

The following procedure will troubleshoot the EGR Valve current high problem. Perform the following steps if the EGR Valve current is high.

  1. Check for a short circuit:

[a] Disconnect harness connector at actuator control valve coil.

[b] Measure coil resistance between pins A and B. See the table below and EGR Valve Coil Wiring.

If coil resistance is too low replace the actuator assembly.

If coil resistance is okay go to step 2.

  2. Disconnect engine harness at ECU and at coil.

[a] Measure resistance across the two pin connector pins.

If resistance is less than 100 [image], the two wires are shorted to each other.

If the resistance is greater than 100 [image], try a test ECU or contact Detroit Diesel Technical Service.

Coil Temperature °C
         Coil Temperature °F
         Allowed Ranges (ohms)
22
         71
  3. 4 - 4.2
50
         122
         3.7 - 4.6
100
         212
  4. 4 - 5.4
Ranges Allowed (ohms)

Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Start and run engine.

  5. Check DDR/DDDL codes.

[a] If no codes are displayed, no further troubleshooting is required.

[b] If any other codes are logged. Refer to Exhaust Gas Recirculation System Basic Checks For Series 60 Engines.

[c] If code 146 6 returns contact Detroit Diesel Technical Service.


 TROUBLESHOOTING EXHAUST GAS RECIRCULATION (EGR) VALVE CURRENT TOO LOW

The following procedure will troubleshoot EGR valve low current.

Perform the following steps if the EGR valve current is low.

  1. Check for a power supply issue or open circuit:

[a] Turn ignition ON.

[b] Disconnect harness connector at the actuator control valve coil.

[c] Check electrical power supply. With ignition on, check voltage at pin B to battery ground, it should be battery voltage. See EGR Valve Coil Wiring.

If battery voltage was read go to step 2 .

If battery voltage was not read, or was low, go to step 2.

  2. Check actuator control valve coil resistance:

[a] Turn ignition OFF.

[b] Disconnect engine harness connector at the ECU.

[c] Insert a jumper wire between pins E-51 and E-1. See EGR Valve Coil Wiring.

[d] Measure resistance between pins A and B at the EGR valve coil connector.

If resistance is greater than 100 [image] this indicates E51 or E1 is open. Repair wire or replace harness.

If resistance is less than 100 [image] go to step 3

  3. Measure resistance at the EGR valve coil between pins A and B. Compare the resistance read with values shown in the table below.

[a] If the resistance is too high or is open replace the actuator.

[b] If the resistance was within specification, reprogram the ECU.

Note: Coil varies with temperature. It is 3.8 ohms ± 10% at 22°C and varies: see table below.

Coil Temperature °C
         Coil Temperature °F
         Allowed Ranges (ohms)
22
         71
         3.4 - 4.2
50
         122
         3.7 - 4.6
100
         212
  4. 4 - 5.4
Ranges Allowed (ohms)

Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Start and run engine.

  5. Check DDR/DDDL codes.

[a] If no codes are displayed, no further troubleshooting is required.

[b] If any other codes are logged. Refer to Exhaust Gas Recirculation System Basic Checks For Series 60 Engines.

[c] If code 146 3 returns contact Detroit Diesel Technical Service.


 TROUBLESHOOTING INFORMATION

The DDEC V system allows for an increased processor speed and increased memory. DDEC III ECMs and DDEC IV ECMs are not interchangeable with DDEC V.

Instructions for repair in this manual are generic. For example, "Repair Open" is used to advise the technician that a particular wire has been determined to be broken. In some cases it may not be best to try and locate the open. It may be that the best repair technique is to replace a complete harness. The technician should make the determination of the proper repair, with the best interest of the customer in mind.

Instructions to "Contact Detroit Diesel Technical Service" indicate that at the time of this publication, all known troubleshooting checks have been included. Review any recent Service Information Bulletins (SIB) or Service Information letters before calling.

It is also suggested that other DDC outlets be contacted. e.g. if you are a dealer or user, contact your closest DDC Distributor.

Ensure you have the engine serial number when you call. The FAX number for Detroit Diesel Technical Service is 313-592-7888.

Instructions in this manual may suggest replacing a non DDC component. It may be required to contact the supplier of the component, e.g. truck manufacturer for a TPS concern, to obtain approval to replace the component.

Instructions to check terminals and connectors should include checking for proper contact tension. Using a mating terminal, a modest force should be required to remove a terminal from its mate. Replace terminals with poor tension.

After completing any repair, always clear fault codes that may have been generated during the troubleshooting process.

NOTE: Be aware that troubleshooting in this manual is mostly concerned with DDEC related codes. Codes associated with other components, e.g. transmissions, ECUs, ABS, etc. can be found in the related publication. Refer to DDEC RELATED PUBLICATIONS

Next topic

SAFETY PRECAUTIONS

Previous topic


 Turbo Boost Sensor


 Turbo Boost Sensor Schematic


 Turbo Compressor Inlet Sensor


 Turbo Compressor Outlet Temperature Circuit


 Turbo Compressor Temperature Out Sensor

The Turbo Compressor Temperature Out sensor senses turbo out air temperature. See Turbo Compressor Temperature Out Sensor - Series 60 Engine for the sensor used with the Series 60 engine.

Next topic

TURBO SPEED SENSOR

Previous topic


 Turbo Compressor Temperature Out Sensor - Series 60 Engine


 Turbo Speed Sensor

The Turbo Speed Sensor, TSS, senses turbo speed for overspeed conditions; see Turbo Speed Sensor - Series 60 and Series 50 Engines for the sensor used with the Series 60 engine.

Next topic

OEM-INSTALLED SENSORS

Previous topic


 Turbo Speed Sensor - Series 60 and Series 50 Engines


 Turbo Speed Sensor Wiring


 Turbocharger Compressor Outlet Temperature Circuit


 Tyco Connector and Locking Tabs


 Typical Variable Speed Governor Circuit


Typical Variable Speed Governor Circuit_1

 Typical Variable Speed Governor Circuit


TShootVuntitled

 Sensor Check

Use the following procedure to troubleshoot Flash Code 23.

Perform the following steps to check the sensor:

  1. Turn ignition OFF.

  2. Disconnect the FTS connector.

  3. Install a jumper wire between sockets 1 and 2 of the FTS harness connector. See Fuel Temperature Sensor.

  4. Turn ignition ON.

  5. Read active codes.

[a] If code 174/4 and any other codes except code 174/3 are logged, refer to Check for Short to +5 Volt Line.

[b] If any code except 174/4 is logged, refer to Open Line Check.


TShootVuntitled00000167

 Fuel Check

Perform the following steps to check the fuel supply:

  1. Disconnect the fuel return line.

  2. Check for fuel flow while cranking the engine.

[a] If fuel flow is okay, refer to White Smoke Check.

[b] If fuel supply is not okay, refuel the vehicle. The system may need to be re-primed.

Refer to the appropriate engine service manual.


TShootVuntitled00000168

 White Smoke Check

Perform the following steps to check for white smoke:

  1. Reconnect fuel return line.

  2. Look for white smoke coming out of the exhaust stack while cranking the engine.

[a] If white smoke is present, refer to Check Timing Reference Sensor Status.

[b] If white smoke is not present, refer to Check Fuel Filters.


TShootVuntitled00000169

 Check Timing Reference Sensor Status

Perform the following steps to check the TRS status via a r/min readout:

  1. Select engine speed and active codes on the DDR.

  2. Crank the engine for ten seconds while observing DDR display. A battery voltage surge while cranking with electric starters may blank or reset the DDR.

[a] If the display reads greater than or equal to 60 r/min, refer to Check for Good Synchronous Reference Sensor Signal.

[b] If the display reads less than 60 r/min or constantly reads 60 r/min, refer to Check Timing Reference Sensor.

[c] If code 41 is displayed, refer to Check for Signal Open.

[d] If code 42 is displayed, refer to Resistance Check.


TShootVuntitled00000170

 Check Timing Reference Sensor

Perform the following steps to check the TRS:

  1. Turn vehicle ignition OFF.

  2. Disconnect engine harness connector at the ECU.

  3. Measure resistance between sockets T1 and T2 at the engine harness connector.

[a] If the resistance measurement is greater than 200 [image], refer to Open Timing Reference Sensor Line Check.

[b] If the resistance measurement is less than 100 [image], refer to Check for Short.

[c] If the resistance measurement is between 100 and 200 [image], refer to Check Synchronous Reference Sensor / Timing Reference Sensor.


TShootVuntitled00000171

 Check Synchronous Reference Sensor / Timing Reference Sensor Mounting

Perform the following steps to check the SRS/TRS mounting and the bracket:

  1. Inspect SRS/TRS mounting.

[a] If the sensor and mount are secure, refer to Check Pulse Wheel.

[b] If the sensor and mount are not secure, tighten the bolt or replace if necessary. Refer to Verify Repairs.


TShootVuntitled00000172

 Check Pulse Wheel

Perform the following steps to check the pulse wheel:

  1. Inspect DDEC®pulse wheel for loose wheel or chipped or missing teeth.

[a] If the pulse wheel is damaged, repair or replace as necessary. Refer to Verify Repairs.

[b] If the pulse wheel is not damaged, refer to Check ECU Connectors.


TShootVuntitled00000173

 Check ECU Connectors

Perform the following steps to check the ECU connectors:

  1. Turn vehicle ignition OFF.

  2. Disconnect both connectors at the ECU.

  3. Check terminals at all ECU connectors (both the ECU and harness side) for damaged, bent, corroded or unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the ECU. Refer to Verify Repairs. (Try a test ECU first.)


TShootVuntitled00000174

 Check for Good Synchronous Reference Sensor Signal

Perform the following steps to check for a good SRS signal:

  1. Select engine data list on DDR.

  2. Crank engine while observing DDR display of SRS received. Battery voltage surges while cranking with electric starters may blank or reset the DDR.

[a] If the SRS RECEIVED signal is YES, refer to Check for Open.

[b] If the SRS RECEIVED signal is NO, refer to Check Synchronous Reference Sensor.


TShootVuntitled00000175

 Check Synchronous Reference Sensor

Perform the following steps to check the SRS:

  1. Turn vehicle ignition OFF.

  2. Disconnect engine harness connector at the ECU.

  3. Measure resistance between sockets S1 and S2 at the engine harness connector.

[a] If the resistance measurement is greater than 200 [image], refer to Open Timing Reference Sensor Line Check.

[b] If the resistance measurement is less than 100 [image], refer to Check for Short.

[c] If the resistance measurement is between 100 and 200 [image], refer to Check Synchronous Reference Sensor / Timing Reference Sensor.


TShootVuntitled00000176

 Check for Open

Perform the following steps to check if the injector return wires are open:

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between the injector return pin and all the power driver pins on both harness connectors.

[a] If the resistance measurement is greater than 5 [image] on any reading, an open exists in one of the injector power driver or return wires. Repair the open. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 5 [image] on any reading, refer to Short to Ground.


TShootVuntitled00000177

 Short to Ground

Perform the following steps to check if the injector lines are shorted to the ground:

  1. Disconnect the engine harness connector at the ECU.

  2. Measure resistance between a battery ground to the injector harness Pins E 61 through E 68.

[a] If the resistance measurement is greater than or equal to 10,000 [image] or open on all readings, refer to Injector Drive Pulses.

[b] If the resistance measurement is less than 10,000 [image] on any reading, there is a short to ground on the wire where resistance was less than 10,000 [image]. Repair the short and refer to Verify Repairs.


TShootVuntitled00000178

 Injector Drive Pulses

Perform the following steps to check the injector drive pulses:

  1. Turn ignition OFF.

  2. Reconnect all ECU connectors.

  3. Remove rocker covers.

  4. Disconnect injector common wire E61 or E62 from one injector. See Pins V61 through V68 to Battery Leads.

  5. Place a 6-volt test light across the previously disconnected injector return side and a good ground.

  6. Crank engine and note the test light to see if it lights (flashes).

  7. Reconnect the return wire.

  8. Repeat the above procedure with all other injectors until all have been tested or until one test fails.

[a] If all tests pass, the problem does not appear to be in the DDEC system.

[b] If all tests do not pass and the test light is flashing for one or more tests, check for proper parts (e.g. bull gear) then try a test ECU. Refer to Verify Repairs.

[c] If all tests do not pass and the test light is not flashing for one or more tests, refer to Check ECU Connectors.


TShootVuntitled00000179

 Check DDEC Fuses

Perform the following steps to check the DDEC fuses:

  1. Check both ECU power fuses or circuit breakers.

[a] If both fuses are okay, refer to Battery Volts Check.

[b] If either fuse is not okay, refer to Check for Blown Fuses.


TShootVuntitled00000180

 Battery Volts Check

Perform the following steps to check for battery volts at the 5-way connector:

NOTE: A high resistance in these wires may prevent engine starting but measure correct voltage. Proper resistance based on wire length and size.

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU. See Pins V61 through V68 to Battery Leads.

  3. Measure voltage from socket V61, V62, V65, and V66 of the vehicle harness connector to a good ground.

[a] If all the voltage measurements are greater than 11.5 volts on all readings, refer to Check Volts at Ignition Wire.

[b] If the voltage measurement is less than 11.5 volts on any readings, refer to ECU Power Line Check.


TShootVuntitled00000181

 ECU Power Line Check

Perform the following steps to check if the ECU power lines are open:

  1. Measure voltage between battery side of one ECU fuse or circuit breaker (red lead) and a good ground (black lead).

  2. Measure voltage at other ECU fuse or circuit breaker. Note that battery side does not contain Pins V61, V62, V65, or V66.. See Pins V61 through V68 to Battery Leads.

[a] If the voltage measurement is less than 11.5 volts on any reading, refer to Check Battery.

[b] If the voltage measurement is greater than 11.5 volts on all readings, an open exists in either power wire (Pins V61, V62, V65, or V66). Repair the open; refer to Verify Repairs.


TShootVuntitled00000182

 Check Battery

Perform the following steps to check the battery:

  1. Connect all connectors.

  2. Turn ignition ON.

  3. Measure voltage at battery (+) terminal (red lead) to the battery (-) terminal (black lead).

[a] If the voltage reading is less than 11.5 volts, service the discharged battery. Refer to Verify Repairs.

[b] If the voltage reading is greater than or equal to 11.5 volts, an open or short to ground exists in the battery (+) line. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000183

 Check Volts at Ignition Wire

Perform the following steps to check for +12 or +24 volts at the ignition wire:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU. For vehicle harness schematic, see ECU Vehicle Harness Connector.

  3. Turn ignition ON.

  4. Measure voltage between socket V15 on the vehicle harness connector (red lead) and a good ground (black lead).

[a] If the voltage measurement is greater than or equal to 11.5 volts, refer to Ground Wire Check.

[b] If the voltage measurement is less than 11.5 volts, refer to Check Ignition Fuse.


TShootVuntitled00000184

 Ground Wire Check

Perform the following steps to check for a good ground wire:

  1. Measure voltage between socket V15 on the vehicle harness connector (red lead) and Pins V63, V64, V67, or V66 of the vehicle harness connector. For 5-way ECU power harness schematic, see Pins V61 through V68 to Battery Leads.

[a] If the voltage measurement is greater than or equal to 11.5 volts, refer to Check ECU Connectors.

[b] If the voltage measurement is less than 11.5 volts, the ECU ground wire is open or has a poor connection. Repair open; refer to Verify Repairs.


TShootVuntitled00000185

 Check Ignition Fuse

Perform the following steps to check the ignition fuse:

  1. Turn ignition OFF.

  2. Check ignition fuse or circuit breaker.

[a] If both the fuse and circuit breaker are okay, refer to Check for Open.

[b] If the fuse or circuit breaker are not okay, refer to Check for Ground.


TShootVuntitled00000186

 Check for Open

Perform the following steps to check if the ignition wire is open:

  1. Measure voltage between battery side (hot side) of the ignition fuse (red lead) and a good ground (black lead).

[a] If the voltage measurement is less than 11.5 volts, refer to Check Battery.

[b] If the voltage measurement is greater than or equal to 11.5 volts, the ignition line (circuit V15) is open. Repair the open; refer to Verify Repairs.


TShootVuntitled00000187

 Check for Ground

Perform the following steps to check if the ignition wire is shorted to ground:

  1. Replace blown fuse or reset open circuit breaker.

  2. Turn ignition ON for ten seconds.

  3. Run engine for one minute.

  4. Turn ignition OFF.

  5. Check ignition fuse or circuit breaker again.

[a] If both the fuse and circuit breaker are okay, refer to Check Fuse or Circuit Breaker.

[b] If the fuse and circuit breaker are not okay, the ignition line (circuit V15) is shorted to ground. Repair the short; refer to Verify Repairs.


TShootVuntitled00000188

 Check Fuse or Circuit Breaker

Perform the following steps to check if the ignition fuse or breaker is okay:

  1. Reconnect all harness connectors at the ECU.

  2. Start the engine.

  3. Run engine for one minute.

  4. Turn ignition OFF.

  5. Check ignition fuse or circuit breaker again. See Pins V61 through V68 to Battery Leads.

[a] If both the fuse and circuit breaker are okay, no short is currently present. Be warned of an intermittent short that could shut down the engine or blow a fuse due to reverse voltage at the battery. Refer to Verify Repairs.

[b] If the fuse or circuit breaker are not okay, refer to Check ECU Connectors.


TShootVuntitled00000189

 Check Battery

Perform the following steps to check the battery:

  1. Disconnect the battery cables at the battery.

  2. Measure voltage at the battery (+) terminal (red lead) to the battery (-) terminal (black lead).

[a] If the voltage measurement is less than 11.5 volts, service the discharged battery. Refer to Verify Repairs.

[b] If the voltage measurement is greater than or equal to 11.5 volts, an open or short to ground exists in unfused ignition line. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000190

 Check for Blown Fuses

Perform the following steps to check for blown fuses:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Replace blown fuse(s) or reset the circuit breaker(s).

  4. Wait ten seconds.

  5. Check whether fuse(s) or circuit breaker(s) have blown or opened up again.

[a] If the fuse and circuit breaker are okay, refer to Check Fuse or Circuit Breaker.

[b] If the fuse or circuit breaker are not okay, refer to Check for Short to Ground.


TShootVuntitled00000191

 Check for Short to Ground

Perform the following steps to check for a short to ground:

  1. Disconnect the batteries.

  2. Measure resistance between V61 and V62 and a good ground (black lead).

  3. Measure resistance between V65 and V66 and a good ground (black lead).

[a] If the resistance measurement is greater than or equal to 10,000 [image] on all readings, refer to Check ECU Connectors.

[b] If the resistance measurement is less than 10,000 [image] on any readings, a short to ground exists. Repair the short. Refer to Verify Repairs.


TShootVuntitled00000192

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop the engine.

  7. Read inactive codes.

[a] If the engine starts and no codes are displayed, troubleshooting is complete.

[b] If the engine does not start, refer to ENGINE CRANKS BUT WILL NOT START.

[c] If the engine starts and codes display, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000193

 Check Fuel Filters

Perform the following steps to check fuel filters:

  1. Turn ignition OFF.

  2. Check primary and secondary fuel filters to be sure they are not clogged and they are filled with clean fuel.

[a] If the fuel filters are clean, refer to Check Timing Reference Sensor Status.

[b] If the fuel filters are not clean, replace the filters. Prime the system if required. Refer to Verify Repairs.

NOTE: For information concerning Fuel Filters, refer to Section 29.4.11 in the appropriate service manual. For information concerning Fuel Filter Replacement, refer to Section 18 in the appropriate service manual.


TShootVuntitled00000196

 Display ECU Light Status

Perform the following steps to display light status:

  1. While the light is lit, plug in the DDR (ignition ON).

  2. Select switch light status.

  3. View the displayed status for the problem light.

[a] If status reads OFF, refer to Check for Grounded Wire.

[b] If status reads ON, refer to Determine Reason for ECU Request.


TShootVuntitled00000197

 Determine Reason for ECU Request

Perform the following steps to determine the reason the ECU is requesting the light to be ON:

  1. Verify the diagnostic request is not ON.

[a] If the diagnostic request is ON, refer to ENGINE BRAKE INOPERATIVE.

[b] If the diagnostic request is not ON, refer to DIAGNOSING A DDEC SYSTEM FAULT (troubleshoot code).


TShootVuntitled00000198

 Check for Grounded Wire

Perform the following steps to check for a grounded wire:

  1. Turn ignition OFF.

  2. Unplug vehicle connector.

  3. Turn ignition ON.

[a] If the light stays on, drive (V02 or V01) wire is shorted to the ground. Repair or replace the wire. Refer to Verify Repairs.

[b] If the light goes off, clean the connectors of the vehicle connector and assemble again. Then, refer to Verify Repairs.


TShootVuntitled00000199

 Activate Light With Diagnostic Data Reader

Perform the following steps to activate the light with the DDR:

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Select Activate Outputs.

  4. Activate affected light; watch status.

[a] If the light stays off. Refer to Check Bulb.

[b] If the light illuminates, the problem no longer exists. Refer to DDEC V Application and Installation manual, 7SA821, to review the light operation.


TShootVuntitled00000200

 Check Bulb

Perform the following steps to check the bulb:

  1. Turn ignition OFF.

  2. Refer to OEM recommendations for checking bulb.

[a] If the bulb is bad, replace the bulb and refer to Verify Repairs.

[b] If the bulb is okay, refer to Check for Voltage Supply.


TShootVuntitled00000201

 Check for Voltage Supply

Perform the following steps to check the voltage supply:

  1. Disconnect the power supply to the light.

  2. Turn ignition ON.

  3. Measure voltage between the removed connection and battery ground.

[a] If the voltage is correct based on the system of the vehicle (12V/24V), refer to Check for Open Output Wire.

[b] If the voltage is too low to expect the bulb to light, refer to the OEM recommendations to resolve the problem. Refer to Verify Repairs.


TShootVuntitled00000202

 Check for Open Output Wire

Perform the following steps to check for an open output wire:

  1. Measure the resistance between the ground side of the connector of the light and the battery ground.

[a] If the measured resistance is 45,000 to 48,000 [image], clean the connections. Refer to Verify Repairs.

[b] If the measured resistance is less than 45,000 or greater than 48,000 [image], the wire is shorted to voltage, or is opened. Repair wire. Refer to Verify Repairs.


TShootVuntitled00000203

 Verify Repairs

Perform the following steps to verify repairs.

  1. Ensure all removed connections are installed.

  2. Turn ignition ON.

[a] If the light comes on for five seconds, then goes out, troubleshooting is complete.

[b] If the light comes on and stays on, refer to AMBER WARNING LAMP AND RED STOP LAMP FAULT.

[c] If the light does not turn on, all troubleshooting is complete. Review this section and contact Detroit Diesel Technical Service.


TShootVuntitled00000205

 Check Diagnostic Request Circuit

Perform the following steps to check the diagnostic request circuit:

  1. Ensure ignition is ON.

  2. Plug in DDR.

  3. Select Calibration Configuration.

  4. Determine port assigned to Diagnostic Request on the ECU input switches.

  5. Go to switch light status.

  6. Depress and hold the diagnostic request switch.

  7. Read status of diagnostic request.

[a] If the switch reads OFF, the diagnostic request circuit (V24) is open or the V59 ground is poor or open. Repair the open wire or the bad ground. Refer to Verify Repairs.

[b] If the switch reads ON, refer to Check ECU Connectors.


TShootVuntitled00000206

 Check ECU Connectors

Follow this procedure to check the ECU connectors:

  1. Check the terminals at the vehicle harness connectors (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. See ECU Vehicle Harness Connector.

[a] If terminals and connectors are okay, replace the ECU. Refer to Verify Repairs.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000207

 Check for Open

Perform the following steps to check for an open:

  1. Turn ignition OFF.

  2. Place a jumper wire across pins A (V56) and B (V57) of the DDL connector. Unplug the vehicle harness connector and measure resistance between sockets V56 and V57.

  3. Turn ignition ON, and again measure resistance between sockets V56 and V57. See Diagnostic Connector.

[a] If both readings are greater than 5 [image], one or both data wires (circuit V56 or V57) are open. Repair the open and refer to Verify Repairs.

[b] If either reading is less than 5 [image], refer to Check for Short.


TShootVuntitled00000208

 Check for Short

Perform the following steps to check for a short:

  1. Remove the jumper wire from the DDL connector.

  2. Measure resistance between Pins V56 and V57 of the vehicle harness connector.

[a] If the resistance measurement is less than 5 [image], two data wires (V56 or V57) are shorted together. Repair the short and refer to Verify Repairs.

[b] If the measured resistance is greater than 5 [image], refer to Check for Short to Ignition and Ground.


TShootVuntitled00000209

 Check for Short to Ignition and Ground

Perform the following steps to check for a short to ignition and ground:

  1. Remove all jumpers for the DDL connector.

  2. Measure resistance between Pins V56 and C (ignition), A (V56) and E (ground), B (V57) and E (ground), and B (V57) and C (ignition switch) of the DDL connector.

[a] If the measured resistance is less than 5 [image] [image] on any reading, a short exists between the data wires and ignition or ground. Repair the short and refer to Verify Repairs.

[b] If the measured resistance is greater than 5 [image], refer to Check Diagnostic Data Reader on Another Engine.


TShootVuntitled00000210

 Check Diagnostic Data Reader on Another Engine

Follow this procedure to check the DDR on another engine:

  1. Connect the DDR to another engine and read any parameter in the menu.

[a] If the procedure worked okay, refer to Verify Repairs.

[b] If the procedure did not work, the DDR is probably defective. Refer to the DDR instruction manual for repair.


TShootVuntitled00000211

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Turn ignition OFF.

  6. Turn ignition ON.

  7. Note status of AWL.

  8. Start and run the engine for one minute.

  9. Read inactive codes.

[a] If the DDR display reads NO DATA BEING RECEIVED FROM DATA LINK or DDEC SYSTEM NOT RESPONDING, all system diagnostics are complete. Review this section from the first step to find the error - refer to NO DATA TO DIAGNOSTIC DATA READER.

[b] If the engine starts and no codes are read on the DDR, repairs are complete.

[c] If the engine starts and code displays, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000213

 Check Red Stop Lamp and Amber Warning Lamp Bulbs

Perform the following steps to check the RSL and AWL bulbs:

  1. Turn ignition OFF.

  2. Remove AWL and RSL bulbs. Check to see if either is burned out or damaged.

[a] If the bulbs are okay, refer to Check 12V / 24V Ignition Line.

[b] If the bulbs are defective, replace the bulbs. Refer to Verify Repairs.


TShootVuntitled00000214

 Check 12V / 24V Ignition Line

Perform the following steps to check the 12V/24V ignition line:

  1. Turn ignition ON.

  2. Disconnect vehicle harness connector at ECU.

  3. Measure voltage at cavity V15.

[a] If voltage measurement is less than 11.5V, ignition fuse or circuit breaker is blown, and the ignition line could be open or shorted to ground.

[b] If the voltage measurement is greater than 11.5V, the circuit V01 or V02 is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000215

 Verify Repairs

Perform the following steps to verify repairs:

  1. Reconnect all connectors.

  2. Turn ignition ON.

  3. Press diagnostic request switch.

[a] If codes flash, the system is working. Repairs are complete. If any other problems exist, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[b] If the system does not function, all system diagnostics are complete. Review this section to find the error - refer to DIAGNOSTIC REQUEST SWITCH INOPERATIVE.


TShootVuntitled00000217

 Check ECU Connectors

Perform the following to check the ECU connectors:

  1. Disconnect the vehicle harness connector at the ECU.

  2. Check the terminals at the ECU vehicle harness connector (both ECU and harness side) for damaged, corroded, or unseated pin or sockets.

[a] If terminals and connectors are not damaged, reprogram the ECU. Refer to Verify Repairs.

[b] If the terminals or connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000218

 Check Pin Assignments

Perform the following to check pin assignments:

  1. Turn ignition ON.

  2. Plug in the DDR.

  3. Select calibration configuration (ECU Ins/Outs).

  4. Write/print pin assignments.

[a] An example listed in the following table shows pins, wires and functions. Refer to Checking Out of Cruise Control Switch and Wiring.

Pin/Wire | Function
V47 | set/coast on
V9 | cruise enable
V3 | svc brk rel
V10 | clutch rel
V8 | res/accel on
[b] If the functions are not assigned, reprogram the ECU. Refer to Verify Repairs.


TShootVuntitled00000219

 Checking Out of Cruise Control Switch and Wiring

To speed up the checking out of cruise control switches, quick check tables have been developed.

These tests are to be run with the ignition ON, and the engine not running. A DDR must be plugged into the connector. All three quick check tables must be gone through to completely check out the cruise control wiring and switches.

For Example: Listed in Cruise Control Quick Check Table I, step 2, you would do the following:

  1. Ignition ON; engine not running; DDR plugged in.

  2. Turn the cruise enable switch to ON.

  3. Select switch/light status on the DDR.

  4. Note the DDR display; if ON, check out brake and clutch switch as listed in Cruise Control Quick Check Table II.

Cruise Control Quick Check Table I (Check Out Cruise Enable Switch and Wiring (Ignition ON Not Running):

Step
         Cruise Enable Switch
         Set / Coast Switch
         Res / Accel Switch
         DDR Readout Being Looked At
         DDR Display
         Okay
         Go To

Off
         Off
         Off
         Cruise Enable
         Off
         Yes
         Step 2

On
         No
         Check for Short at the Cruise Enable Circuit

On
         Off
         Off
         Cruise Enable
         Off
         No
         Check for Open at the Cruise Enable Circuit

On
         Yes
         Table II below, step 1

Cruise Control Quick Check Table II (Check Out Brake and Clutch Switch and Wiring (Ignition ON Not Running):

Step
         Cruise Enable Switch
         Brake Pedal
         Clutch Pedal
         DDR Readout Being Looked At
         DDR Display
         Okay
         Go To

On
         Released
         Released
         Service Brake Release
         On
         Yes
         step 2

Off
         No
         Refer to Check for Open or Miswired Brake Switch

On
         Depressed
         Released
         Service Brake Release
         On
         No
         Check for Short at the Brake Switch or Circuit

Off
         Yes
         step 3

On
         Released
         Released
         Clutch Release
         On
         Yes
         step 4

Off
         No
         Check for Open or Miswired Clutch Switch

On
         Released
         Depressed
         Clutch Release
         On
         No
         Check for Short at the Clutch Service/Circuit

Off
         Yes
         Table III below, step 1

Cruise Control Quick Check Table III (Check Out Set/Coast and Resume/Accel Switches and Wiring (Ignition ON Not Running)):

Step
         Cruise Enable Switch
         Set / Coast Switch
         Res / Accel Switch
         DDR Readout Being Looked At
         DDR Display
         Okay
         Go To

On
         Off
         Off
         Set/Coast On
         Off
         Yes
         step 2

On
         No
         Check for Short at the Set/Coast Circuit

On
         On
         Off
         Set/Coast On
         Off
         No
         Check for Open at the Set/Coast Circuit

On
         Yes
         step 3

On
         Off
         Off
         Res/Accel On
         Off
         Yes
         step 4

On
         No
         Check for Short at the Res/Accel Circuit

On
         Off
         On
         Res/Accel On
         Off
         No
         Check for Open at the Res/Accel Circuit

On
         Yes
         Verify Problem Still Exists


TShootVuntitled00000220

 Check for Short at the Cruise Enable Circuit

Perform the following steps to check for a short at the cruise enable circuit:

  1. Turn ignition ON.

  2. Turn cruise engage switch to off.

  3. Disconnect the vehicle harness connector at the ECU.

  4. Measure resistance between the cruise enable cavity (V09) on the vehicle harness connector and a good ground.

[a] If the resistance measurement is less than or equal to 10,000 [image], reconnect the vehicle harness. Turn the ignition on. Then run steps listed in Cruise Control Quick Check Table II; and Cruise Control Quick Check Table III. If any DDR display received is not okay, refer to the indicated step. If all steps listed in Cruise Control Quick Check Table II and Cruise Control Quick Check Table III pass, then the cruise engage wire is shorted to the ground. Repair the short, or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 10,000 [image], refer to Check ECU Connectors.


TShootVuntitled00000221

 Check for Open at the Cruise Enable Circuit

Perform the following steps to check for an open at the cruise enable circuit:

  1. Turn ignition ON.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Turn cruise enable switch to ON.

  4. Measure resistance between the cruise enable cavity (V09) on the vehicle harness connector and a good ground.

[a] If the resistance measurement is greater than 5 [image], or open, the cruise engage switch is bad, circuit V59 is open or the cruise enable wire is open. Repair the open or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.


TShootVuntitled00000222

 Check for Open or Miswired Brake Switch

Perform the following steps to check for an open or miswired brake switch:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Ensure the service brake is not engaged.

  4. Measure resistance between the service brake cavity (V03) on the vehicle harness connector and a good ground.

[a] If the resistance measurement is greater than 5 [image], or open, the brake switch is miswired or faulty, circuit V59 is open or the ground is bad. Repair the open, rewire or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.


TShootVuntitled00000223

 Check for Short at the Brake Switch or Circuit

Perform the following steps to check for a short at the brake switch or circuit:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Engage the service brake.

  4. Measure resistance between the service brake cavity (V03) on the vehicle harness connector and a good ground.

[a] If the resistance measurement is less than or equal to 10,000 [image], the brake switch is miswired or the service brake circuit is shorted to ground. Rewire, repair the short or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 10,000 [image], or open, refer to Check ECU Connectors.


TShootVuntitled00000224

 Check for Open or Miswired Clutch Switch

Perform the following steps to check for an open or miswired clutch switch:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Ensure the clutch is not engaged.

  4. Measure resistance between the clutch cavity (V10) on the vehicle harness connector and a good ground.

[a] If the resistance measurement is greater than 5 [image], or open, the clutch switch is miswired or faulty, circuit V59 is open, or there is a bad battery ground. Rewire, repair the short or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.


TShootVuntitled00000225

 Check for Short at the Clutch Service/Circuit

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Engage the clutch.

  4. Measure resistance between the clutch cavity (V10) on the vehicle harness connector and a good ground.

[a] If the resistance measurement is less than or equal to 100 [image], the clutch switch is miswired or faulty, or the clutch circuit is shorted to ground. Rewire, repair the short or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is greater than100 [image] or open, refer to Check ECU Connectors.


TShootVuntitled00000226

 Check for Short at the Set/Coast Circuit

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure resistance between the set/coast cavity (V47) and a good ground.

[a] If the resistance measurement is less than or equal to 100 [image], the set/coast switch is shorted, or a short to ground exists in the set/coast circuit (V47). Repair the short or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] [image] refer to Check ECU Connectors.


TShootVuntitled00000227

 Check for Open at the Set/Coast Circuit

Perform the following steps to check for an open:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Find a means to press and hold the set/coast switch.

  4. Measure resistance between the set/coast cavity (V47) and a good ground.

[a] If the resistance measurement is greater than 5 [image], or open, the set/coast switch is open or miswired, circuit V59 is open, or there is a bad battery ground. Rewire, repair the short or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.


TShootVuntitled00000228

 Check for Short at the Res/Accel Circuit

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure resistance between the Res/Accel cavity (V08) and a good ground.

[a] If the resistance measurement is less than or equal to 100 [image] [image] the Res/Accel switch is shorted, or a short to ground exists in the Res/Accel circuit (V08). Repair the short or replace the switch. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] [image] refer to Check ECU Connectors.


TShootVuntitled00000229

 Check for Open at the Res/Accel Circuit

Perform the following steps to check for an open:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Find a means to press and hold the Res/Accel switch.

  4. Measure resistance between the Res/Accel cavity (V08) and a good ground.

[a] If the resistance measurement is greater than 5 [image], or open, the Res/Accel switch is open or miswired, circuit V59 is open or the battery ground is bad. Repair the short, replace the switch, or rewire. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.


TShootVuntitled00000230

 Verify Problem Still Exists

Perform the following steps to verify the problem still exists:

  1. If you were referred to this step, you have completed the switch checkout process without detecting a fault.

  2. Take the vehicle for a road test and check the cruise control operation.

[a] If the cruise control operates correctly, the problem no longer exists. If any other problems exist, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[b] If the cruise control does not operate correctly, check the vehicle speed sensor. Refer to FLASH CODE 54 - VSS FAULT.


TShootVuntitled00000231

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Road test the vehicle.

[a] If the cruise control operates correctly, troubleshooting is complete.

[b] If the cruise control does not operate correctly, all system diagnostics are complete. Review this section from the start to find the error - refer to CRUISE CONTROL INOPERATIVE.


TShootVuntitled00000233

 Digital Fan Operation

Items used in digital fan operation include:

  1. The ECU provides ground (output Fan Control 1) and should be wired such that when this cavity grounds, the fan should turn off. When the circuit goes open, the fan should turn on.

  2. When Aux. Fan Control is configured (input), this wire must be connected to battery ground, or the fan will always be on. Typically, this is used with an air conditioning pressure switch. High pressure opens this circuit, and turns the fan on for a minimum time that can be set with the programming station on later ECU software versions.

  3. Fan Override - Grounding this wire will turn the fan on. This would normally be an OEM supplied switch on the dash.

Other than these items, the ECMs fan control output opens, turning the fan on due to engine temperatures that are above the programmed limits. Once a fan output turns the fan on for whatever reason, all fan off temperatures must be met before the fan will turn off.

Temperatures for most highway applications are listed in the following table.

Fan Control | Actual Fan Status | Coolant Temp | Oil Temp | Air Temp
Fan Control - 1 | Fan ON | 96°C / 204°F | 110°C / 230°F | 66°C / 150°F
Fan Control - 2 | Fan ON | 98°C / 208°F | 113°C / 235°F | N/A
- | Fan OFF | 92°C / 197°F | 104°C / 219°F | 49°F / 120°F

These temperature limits are only changeable in the base calibration.


TShootVuntitled00000234

 Check Output Status

Perform the following steps to troubleshoot a fan operation problem:

  1. Start engine.

  2. Ensure the air conditioning of the vehicle is OFF.

  3. Run engine for at least three minutes.

  4. Plug in DDR.

  5. Select switch / light status.

  6. Check the status of the Fan Control #1 while noting the actual fan status as listed in the following table.

 | Status | Status | Status | Status | Status
Fan Control #1 | ON/GND | OFF/OPN* | OFF/OPN | ON/GND | OFF/OPN
Actual Fan State | OFF | ON | ON | ON | OFF
 | Refer to Fan Information | Refer to Fan Information | Refer to Check Input Status | Refer to Check for Output Open | Refer to Check for Output Short
  • Hot engine


TShootVuntitled00000235

 Fan Information

The steps that led to this procedure do not indicate a problem with the fan control logic in the ECU. The fan operation is normal if the steps that you checked led you to this section.

The fan status is correct according to what the ECU is requesting.

If you believe the fan state should be different, review the DDEC application and installation manual for information on fan control configuration.


TShootVuntitled00000236

 Check Input Status

Read the status of the inputs used for fan operation listed in the following table. (Note both together.)

 | Status | Status | Status
Aux. Fan Control | OFF/OPN | ON/GRD | ON/GRD
Fan Override | OFF/OPN | ON/GRD | OFF/OPN
 | Refer to Check Auxiliary Fan Control Request | Refer to Check Override Request | Refer to Fan Information


TShootVuntitled00000237

 Check Auxiliary Fan Control Request

Perform the following tests to check the auxiliary fan control switch:

  1. Turn A/C OFF and ignition ON.

  2. Is the auxiliary fan control status ON?

[a] If the auxiliary fan control is on, this should not request the fan on; this is normal. The fan may remain on for up to three minutes after auxiliary fan control is turned on.

[b] If the auxiliary fan control is off, check that a normally open pressure switch is not installed; then, refer to Check for Input Open.


TShootVuntitled00000238

 Check for Input Open

Perform the following tests to check for an open:

  1. Turn ignition OFF.

  2. Disconnect vehicle connector at the ECU.

  3. Turn ignition ON.

  4. Measure resistance between auxiliary fan control wire V25 and a good ground.

[a] If the measured resistance is greater than 1,000 [image], an open exists in the auxiliary fan control wire, or auxiliary fan control is configured and not wired, or the switch is bad. Repair open or replace the switch if an auxiliary fan control is used. If this feature is not to be used, disable the auxiliary fan control with the programming station. Refer to Verify Repairs.

[b] If the measured resistance is less than or equal to 1,000 [image], refer to Check Connectors.

Perform the following steps to troubleshoot fan always on. The steps that led to this procedure do not indicate a problem with the fan control logic in the ECU. The fan operation is normal if the steps that you checked led you to this section.


TShootVuntitled00000239

 Check for Output Open

Perform the following steps to check for an output open:

  1. With ignition off, locate OEM supplied wire used for Fan Control #1.

  2. Determine where the wire terminates. (e.g. fan solenoid, relay, data module, etc.)

  3. Disconnect the Fan Control #1 wire at the solenoid/relay.

  4. Turn ignition ON.

  5. Measure resistance between the fan control #1 (V04) wire and a good ground, battery (-).

[a] If the measured resistance is greater than 48,000 [image] or open, an open exists in the FC#1 wire. Repair the open. Refer to Verify Repairs.

[b] If the measured resistance is less than or equal to 48,000 [image], refer to Check Connectors.


TShootVuntitled00000240

 Check for Output Short

Perform the following steps to check for an output short:

  1. With ignition off, locate OEM supplied wire used for Fan Control #1 (V04).

  2. Determine where the wire terminates. (e.g. fan solenoid, relay, data module, etc.)

  3. Disconnect the Fan Control #1 wire at the solenoid/relay.

  4. Measure resistance between the fan control #1 wire and a good ground, battery (-).

[a] If the measured resistance is greater than 1,000 [image] [image] or open, refer to Check Connectors.

[b] If the measured resistance is less than or equal to 1,000 [image], the output wire is shorted to ground, keeping the fan off. Repair the short or replace the wire. Refer to Verify Repairs.


TShootVuntitled00000241

 Check Override Request

Perform the following steps to check the fan override switch:

  1. Is the fan override switch on?

[a] If the fan override is on, and the fan override is requesting fan on, this is normal.

[b] If the fan override is not on, the fan override wire is shorted to ground, repair the short or re-configure the input if this is an error in programming. Refer to Verify Repairs.


TShootVuntitled00000242

 Check Connectors

Perform the following steps to check the connectors:

  1. Check connectors for damaged, bent, or corroded terminals.

[a] If the pins and terminals are not damaged, the problem may be due to the solenoid, ECU, or OEM device that operates the fan. Contact the OEM for further information or instructions. The ECU and wiring between the ECU and device appear to be operating correctly and in good repair. The ECU is requesting the fan operation correctly and the checks indicate the ECU and wire between the ECU and OEM device is okay.

[b] If the pins or terminals are damaged, repair or replace them. Refer to Verify Repairs.


TShootVuntitled00000243

 Verify Repairs

Perform the following steps to verify repairs:

  1. Connect any removed connectors.

  2. Start engine.

  3. Operate engine under conditions that brought you to this section.

  4. Check fan operation.

[a] If the fan operates correctly, troubleshooting is complete.

[b] If the fan does not operate correctly, review this section from the first step to find the error.


TShootVuntitled00000245

 Verify Correct DDEC Configuration

Perform the following steps to verify the configuration:

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Select "View Calibration" (ECU Ins/Outs).

  4. Review PWM functions to determine correct pin assignment for PWM fan.

[a] If the cavity is assigned to PWM Fan, refer to Check for Signal.

[b] If the cavity is not programmed, reprogram the ECU and refer to Verify Repairs.


TShootVuntitled00000246

 Check for Signal

Perform the following steps to check for signal:

  1. Start and run the engine at idle.

  2. Plug in DDR.

  3. Review engine data list and watch the pulse width modulation number x wire = # of fan assignment (normally PWM#4).

  4. Verify coolant, oil and air temperatures are cooler, less than 150°F. Verify the air conditioning input is grounded (On).

[a] If the PWM value is 80 to 90% and the fan is at Low Speed, refer to Check Signal Engine Hot.

[b] If the PWM value is 80 to 90% and the fan is at High Speed, refer to Check for Open.


TShootVuntitled00000247

 Check Signal Engine Hot

Perform the following steps to check the signal status:

  1. Start engine and warm up. Road test (until coolant temp is about 200°F).

  2. View DDR data list display, Coolant Temp/PWM # (normally #4).

[a] If PWM % decreases as the temperature increases, all checks appear normal. If this is an intermittent high speed operation, check A/C Freon pressure switch or wiring for an intermittent open. Refer to Verify Repairs.

[b] If PWM % decreases as the temperature increases, but the fan speed stays low, refer to Check for Short.


TShootVuntitled00000248

 Check for Open

Perform the following steps to check for an open:

  1. Turn ignition OFF.

  2. Unplug PWM wire at the fan control valve.

  3. Install a jumper between the PWM wire and the battery (-).

  4. Unplug the engine harness connector.

  5. Measure resistance between the PWM cavity and the battery (-).

[a] If the measured resistance is greater than 1,000 [image], the wire is open. Repair the open and refer to Verify Repairs.

[b] If the measured resistance is less than 1,000 [image], the valve or wiring (voltage supply) to the valve is defective. Replace.


TShootVuntitled00000249

 Check for Short

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Unplug the engine harness connector.

  3. Measure resistance between the PWM cavity and several ground sources (battery, chassis, etc.).

[a] If the measured resistance is greater than 1,000 [image], refer to Check Connectors.

[b] If the measured resistance is less than 1,000 [image] [image] at any time, the wiring is shorting. Replace the wire and refer to Verify Repairs.


TShootVuntitled00000250

 Check Connectors

Perform the following steps to check the connectors:

  1. Check for damaged, bent or corroded connectors, pins, and terminals.

[a] If the connectors, pins, and terminals are not damaged, contact the OEM or fan valve supplier for instructions on further troubleshooting. If the ECU and wiring to the component appear to be okay, the problems could be with the control valve or battery and wiring.

[b] If the connectors, pins or terminals are damaged, repair or replace them and refer to Verify Repairs.


TShootVuntitled00000251

 Verify Repairs

Perform the following steps to verify repairs:

  1. Connect all removed connectors, etc.

  2. Start and run the engine from cold to hot, while watching the fan speed operation.

[a] If the operation is normal, troubleshooting is complete.

[b] If the operation is not normal, all system diagnostics are complete. Review this section to find the error. Refer to Verify Correct DDEC Configuration.


TShootVuntitled00000253

 Check Switches

Perform the following steps to troubleshoot the switches:

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Select Switch Light status - Inputs.

  4. View DDR display of Eng Brk Low and Eng Brk Med.

NOTE: Set brake dash switch position on low.

[a] If Eng Brake Low is ON and Eng Brake Med is OFF, refer to View Diagnostic Data Reader Display.

[b] If Eng Brake Low is ON and Eng Brake Med is ON, medium and low inputs are shorted to each other. Repair. Refer to Verify Repairs.

[c] If Eng Brake Low is OFF and Eng Brake Med is ON, input wires are reversed. Correct and refer to Verify Repairs.

[d] If Eng Brake Low is OFF and Eng Brake Med is OFF, refer to Check for Open.

  5. Turn brake enable dash switch on.


TShootVuntitled00000254

 View Diagnostic Data Reader Display

Perform the following steps to troubleshoot the inoperative engine brake:

  1. View DDR display.

NOTE: Set brake dash switch position on medium.

[a] If Eng Brake Low is OFF and Eng Brake Med is ON, refer to View Calibration - Engine Configuration.

[b] If Eng Brake Low is ON and Eng Brake Med is ON, medium and low inputs are shorted to each other. Repair. Refer to Verify Repairs. If this is a Series 55 engine, refer to Check for Short.

[c] If Eng Brake Low is ON and Eng Brake Med is OFF, input wires are reversed. Correct and refer to Verify Repairs.

[d] If Eng Brake Low is OFF and Eng Brake Med is OFF, refer to Check for Open.


TShootVuntitled00000255

 Check for Open

Perform the following steps to check for an open:

  1. Turn ignition OFF.

  2. Turn engine brake switch to low.

  3. Measure resistance between the engine brake low switch and a good ground (ECU side).

  4. Set switch to Med. Measure resistance between medium input and a good ground.

[a] If the measured resistance is less than 10,000 [image], either the switch is bad or the wire from the switch to the battery ground is bad. Replace the switch or repair the open.

[b] If the measured resistance is greater than 10,000 [image], or open, an open exists in the input wire. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000256

 View Calibration - Engine Configuration

Perform the following steps to view calibration - engine configuration:

  1. Go to View Cal-Eng Configuration. Check status of Eng Brk Serv Brk and Eng Brk mph. If Eng Brk Serv Brk indicates YES, or Eng Brk Min mph has number other than "0", check with the operator to ensure he or she understands how these functions operate.

[a] If the Eng Brk Serv Brk indicates YES, the application of service brake is required for engine brake operation.

[b] If the Eng Brk Min mph has a number other than "0", the brakes will not operate below this mph.

NOTE: These two functions may work separately or together.

[c] If the Eng Brk Svc Brk indicate No, and Eng Brk Min mph indicate 0, refer to Check Engine Brake Operation.


TShootVuntitled00000257

 Check Engine Brake Operation

Perform the following steps listed in the table below to check out the brake and clutch switch, and the wiring.

NOTE: If table below leads to MISCELLANEOUS DIGITAL INPUT FAULT, troubleshoot clutch and brake inputs. Then check operation of engine brake. If engine brake is still inoperative, refer to Check Brake Solenoids.

  1. Turn ignition ON. Engine must not be running.

  2. Plug in DDR. Select switch/light status.

Step
         Brake Pedal
         Clutch Pedal
         DDR Readout Looked At
         DDR Display
         Status OK
         Reference

Released
         Released
         Service Brake (Release)
         On
         Ye
         Step 2

Off
         No
         MISCELLANEOUS DIGITAL INPUT FAULT

Depressed
         Released
         Service Brake Release
         On
         No
         MISCELLANEOUS DIGITAL INPUT FAULT

Off
         Yes
         Step 3

Released
         Released
         Clutch Release
         On
         Yes
         Step 4

Off
         No
         MISCELLANEOUS DIGITAL INPUT FAULT

Released
         Depressed
         Clutch Release
         On
         No
         MISCELLANEOUS DIGITAL INPUT FAULT

Off
         Yes
         Check Brake Solenoids


TShootVuntitled00000258

 Check Brake Solenoids

Perform the following steps to troubleshoot the brake solenoids:

  1. Check engine brake solenoids. Refer to OEM guidelines.

[a] If solenoids are okay, refer to Verify Conditions.

[b] If solenoids are bad, repair or replace the solenoids. Refer to Verify Repairs.


TShootVuntitled00000259

 Verify Conditions

Perform the following steps to verify conditions:

  1. Verify proper conditions are being met to enable engine brake:

[a] TPS % = 0 %

[b] Pulse width = 0 (or less)

[c] Engine speed >850 r/min

[d] Clutch release (input) = ON (if configured)

[e] Engine brake disable (input) = OFF (Auto Trans)

  2. Are the conditions listed in 1a through 1e met?

[a] If conditions are not met, correct the problem (i.e. TPS). Refer to Verify Repairs.

[b] If the conditions are met, reprogram the ECU. Contact the OEM for possible TPS repair. Then, refer to Verify Repairs.


TShootVuntitled00000260

 Verify Repairs

Perform the following steps to verify repairs:

  1. Reinstall all connectors.

  2. Test drive vehicle to see if the problem is corrected.

[a] If engine brakes operate correctly, troubleshooting is complete.

[b] If engine brakes do not operate, all system diagnostic checks are complete. Review this section to find the error - refer to ENGINE BRAKE INOPERATIVE, or contact Detroit Diesel Technical Service for possible ECU replacement.


TShootVuntitled00000262

 Verify Switch Status

Follow these steps to verify the switch status.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Select switch light status.

  4. Operate the engine or vehicle that would allow the feature to activate (e.g. activate switch, set brake, etc.).

  5. Observe the status when the feature is active (or supposed to be active). See ECU-to-Input / Sensor Return.

[a] The feature always reads OFF. Refer to Check for Open.

[b] The feature switches from OFF to ON. Refer to Review the Operation of the Feature.

[c] The feature always reads ON. This indicates the input wire is shorted to ground or the switch is faulty. Repair wire or replace switch. Refer to Verify Repairs.


TShootVuntitled00000263

 Check for Open

Perform the following steps to check for an open:

  1. Turn ignition OFF.

  2. Unplug the vehicle interface harness connector at the ECU.

  3. Operate switch. Enable the feature.

  4. Measure the resistance between the input cavity affected and the battery ground.

[a] If the measured resistance is greater than 10,000 [image], the input wire or ground wire is open, or the switch is bad. Repair the open or replace the switch. Refer to Verify Repairs.

[b] If the measured resistance is less than 10,000 [image], refer to Review the Operation of the Feature.


TShootVuntitled00000264

 Review the Operation of the Feature

Perform the following steps to check the operation of the feature:

  1. The step that led you here indicates the input, wire, and switch, are operating correctly. Review the intended operation of the feature to determine if any other conditions need to be met for the feature to operate. (e.g. appropriate Application and Installation manual for the engine). Refer to DDEC RELATED PUBLICATIONS, for a list of related troubleshooting publications.

  2. To verify the repairs to the feature, refer to Verify Repairs.


TShootVuntitled00000265

 Verify Repairs

Perform the following steps to verify repairs.

  1. Hook up all connectors that were previously removed.

  2. Operate the engine or vehicle.

  3. Activate the feature.

[a] If the input feature operates correctly, troubleshooting is complete.

[b] If the input feature is not operating, contact Detroit Diesel Technical Service.


TShootVuntitled00000267

 Activate Output

Perform the following steps to attempt activation to troubleshoot an output fault.

  1. Turn ignition ON.

  2. Plug in DDR. Select ACTIVATE OUTPUTS.

  3. Activate output associated with the fault.

NOTE: Service any other codes first.

[a] If the feature operates (e.g. light illuminates or solenoid activates, etc.) review the Application and Installation manual for the operation of the designated feature. Operation is dependent on other parameters. Refer to Verify Repairs.

[b] If the feature does not operate or cannot be activated, refer to Check for Open.


TShootVuntitled00000268

 Check for Open

Perform the following steps to check for open:

  1. Turn ignition OFF.

  2. Locate device end of output wire (e.g. light) and disconnect wire.

  3. Turn ignition ON.

  4. Measure resistance between the disconnected wire and battery (-).

[a] If the measured resistance is less than 30,000 [image], refer to Check for Voltage.

[b] If the measured resistance is greater than 30,000 [image], the wire is open. Refer to Verify Repairs.


TShootVuntitled00000269

 Check for Voltage

Perform the following steps to check the voltage:

  1. Measure voltage between the disconnected wire and a good ground.

[a] If voltage measurement is less than 2 volts, refer to Check for Resistance.

[b] If voltage measurement is greater than 2 volts, the output is shorted to a voltage source. Replace the wire and refer to Verify Repairs.


TShootVuntitled00000270

 Check for Resistance

Perform the following steps to check for resistance at the ECU:

  1. Turn ignition OFF.

  2. Disconnect connector that houses the wire/function you are checking (e.g. V49).

  3. Measure resistance between the pin on the ECU and the ECU case.

[a] If the measured resistance is 46,000 to 48,000 [image], contact the OEM or the hardware of the supplier of the features. For further troubleshooting, all output wiring and ECU operation appear to be operating correctly.

[b] If greater than 48,000 [image], try a test ECU. Refer to Verify Repairs.


TShootVuntitled00000271

 Verify Repairs

Perform the following steps to verify repairs.

  1. Connect all connectors.

  2. Test the vehicle and attempt to operate the feature.

[a] If the feature works correctly, troubleshooting is complete.

[b] If the feature still does not work correctly, review this section to find the error - refer to Activate Output.


TShootVuntitled00000273

 Identify Problem

Use the following procedure to identify the problem with the PSG:

Does not operate; refer to Check System Ground.

No pressure mode, refer to Verify Mode Selector Operation.

No increase function refer to Check Resume / Accel Switch (Increase).

No decrease function refer to Check Set / Coast Switch (Decrease).

EFC Fault Information refer to TROUBLESHOOTING ELECTRONIC FIRE COMMANDER.


TShootVuntitled00000274

 Check System Ground

Perform the following steps to check the system ground:

  1. Start engine.

  2. Turn ON pump control switch.

  3. Verify all interlocks are set (parking brake, transmission neutral, etc.).

  4. Plug in DDR. Select Switch/Light status.

  5. Observe the displays and PSG ENABLE.

[a] If PSG ENABLE reads OFF, the PSG ENABLE input V9 is not grounded. Check circuit V9 for an open between battery ground or a short to a voltage source. Repair fault and retest. Refer to Check Sensor Wiring.

[b] If PSG ENABLE reads ON, refer to Check Resume / Accel Switch (Increase).


TShootVuntitled00000275

 Check Sensor Wiring

Perform the following steps to identify the problem:

  1. Compare pressure sensor harness wiring to the diagram.

[a] If the EFC tests okay, refer to Verify Mode Selector Operation.

[b] If the wiring is incorrect, correct the wiring and retest.


TShootVuntitled00000276

 Verify Mode Selector Operation

Perform the following steps to identify the problem:

  1. Start engine.

  2. Turn ON pump control switch.

  3. Verify all interlocks are set (parking brake, transmission neutral, etc.).

  4. Plug in DDR. Select Switch/Light status.

  5. Observe the displays and PSG MODE.

[a] If DDR displays ON when Pressure Mode is selected, the mode selector V26 is functioning properly. Check for possible intermittent open or short to voltage source. Check for faulty pressure transducer. Refer to Check Sensor Wiring. See Pressure Transducer and Harness Connector.

[b] If the DDR displays OFF when Pressure Mode is selected, the mode selector wire V26 or switch is open or shorted to a voltage source. Repair the fault and retest.


TShootVuntitled00000277

 Check Resume / Accel Switch (Increase)

Perform the following steps to identify the problem:

  1. Start engine.

  2. Turn ON pump control switch.

  3. Verify all interlocks are set (parking brake, transmission neutral, etc.).

  4. Plug in DDR. Select Switch/Light status.

  5. Observe the displays and Res/Accel, while depressing the increase switch.

[a] If DDR displays OFF to ON when increase is depressed, check the EFC.

[b] If the DDR displays OFF when increase is depressed, circuit V8 is open or shorted to a voltage source. Repair the fault and retest.


TShootVuntitled00000278

 Check Set / Coast Switch (Decrease)

Perform the following steps to identify the problem:

  1. Start engine.

  2. Turn ON pump control switch.

  3. Verify all interlocks are set (parking brake, transmission neutral, etc.)

  4. Plug in DDR. Select Switch/Light status.

  5. Observe the displays and Set/Coast, while depressing the decrease switch.

[a] If DDR displays OFF to ON when Set/Coast decrease is depressed, check the EFC.

[b] If the DDR displays OFF when decrease is depressed, circuit V47 is open or shorted to a voltage source. Repair the fault and retest.


TShootVuntitled00000281

 EFC Programming Menu Options

As you scroll through the menu by repeatedly pressing the MENU button, the following items, listed in the following table, will appear sequentially in the Information Center display.

Programming

Menu Item | Explanation | Button | Change
RPM Preset Point: | Preset Engine Speed | Incr/Decr | +/- 25 RPM
Pressure PRESet (PSI): | Preset PSI | Incr/Decr | +/- 25 PSI
Engine Hour meter: | Information Only | -- | --
Pump Hour meter: | Information Only | -- | --
Engine Temperature: | Oil or Coolant | Incr/Decr | Cycles options
Pump Pressure (PSI): | Pressure Reading if Active | -- | --
DDEC Software Ver: | ECM Revision Level | -- | --
EFC Software Ver: | EFC Revision Level | -- | --
Fire Commander I/O Test: | Test Switches and Outputs | Any | --
Press [MODE] Test Lights:* | Tests Display Panel & Audible Alarm | Mode | --
Set Time Clock: | Set Clock | Incr/Decr | +/- 1 minute
Units of Measure: | English or Metric | Incr/Decr | Cycles options
Welcome Message: | Enable or Disable | Incr/Decr | Cycles options
Codes Currently Active: | Information Only | -- | --
Connector Data: | Displays Connection Pinouts | Incr/Decr | Scroll fwd/back
SAVE? [Idle Y] [Mode N] | Exit and Save Options | -- | --
  • PUMP ENGAGED and THROTTLE READY will not illuminate.

Previous topic


TShootVuntitled00000283

 Heater and Air Conditioning Fans Do Not Function

Perform the following steps to troubleshoot the heater and A/C fans.

  1. Check the heater and A/C blower fuse.

  2. Turn ignition ON.

  3. Plug in DDR.

  4. Check the vehicle power down relay switch. Select switch light status (VEH PWR DOWN).

[a] If the output status reads ON, check the relay and relay connections for proper operation. Refer to Check Optimized Idle Active Light.

[b] If the output status does not read ON, install a test ECU. Refer to Verify Repairs.


TShootVuntitled00000284

 Check Optimized Idle Active Light

The Optimized Idle active light should flash when all of the following occur:

  1. Engine idling.

  2. The transmission is in NEUTRAL and high-range, if equipped.

  3. The hood is closed and the park brake is set.

  4. The cruise switch is turned ON.

[a] If the active light is not flashing, refer to Check Idle Condition.

[b] If the light is flashing, after the engine shuts down, turn the thermostat on. When the light flashes, if the alarm turns ON and the engine starts, the system is OK.

[c] If the light is flashing, after the engine shuts down, turn the thermostat on. When the light flashes, if the alarm does not turn ON and the engine does not start, refer to Oil Temperature Sensor Connection Check.


TShootVuntitled00000285

 Check Idle Condition

Perform the following steps to troubleshoot Optimized Idle:

  1. Check idle condition.

  2. Verify the engine is at idle and not running on VSG. Optimized idle will not function if the engine is running on VSG, unless the idle timer is enabled on VSG.

[a] If the engine is not at idle, turn off the ISD on the VSG. Refer to Verify Repairs.

[b] If the engine is at idle, refer to Check Idle Shutdown Enabled.


TShootVuntitled00000286

 Check Idle Shutdown Enabled

Perform the following steps to troubleshoot Optimized Idle:

  1. Check for idle shutdown enabled.

  2. Using the DDR, view the calibration.

[a] If idle shutdown is not enabled, enable the idle shutdown and set a shutdown time. Refer to Verify Repairs.

[b] If the idle shutdown is enabled, refer to Check lnput Status.


TShootVuntitled00000287

 Check lnput Status

Perform the following steps to troubleshoot Optimized Idle:

  1. Check for input status.

  2. Using the DDR, check the park brake input status with the hood closed, the transmission in NEUTRAL (and high-range if equipped) and the park brake set.

[a] If the park brake status is ON, refer to Check the Thermostat.

[b] If the park brake status is not ON, refer to Check Hood Switch.


TShootVuntitled00000288

 Check Hood Switch

Perform the following steps to troubleshoot the hood switch:

  1. Check hood switch.

  2. Measure the resistance across the hood switch contacts with the hood closed. See Optimized Idle Schematic.

[a] If the resistance measures less than 100 [image] [image] refer to Check Park Brake Switch.

[b] If the resistance measures greater than 100 [image] [image] replace or adjust the hood switch. Refer to Verify Repairs.


TShootVuntitled00000289

 Check Park Brake Switch

Perform the following steps to troubleshoot the park brake switch and other OEM interlock devices.

  1. Check the park brake switch and other OEM interlock devices (e.g. high-range switch).

  2. Measure resistance across the park brake switch contacts with the park brake set.

[a] If the measured resistance is less than 100 [image] [image] the V63 ground wire is open somewhere between the ECU and the switch. Repair the open. Refer to Verify Repairs.

[b] If the measured resistance is more than 100 [image] [image] replace the park brake switch or other OEM interlock devices. Refer to Verify Repairs.


TShootVuntitled00000290

 Check the Thermostat

Perform the following steps to check the thermostat operation:

  1. Turn ignition ON.

  2. Plug in the DDR.

  3. Select switch light status OPIDL T-STAT.

[a] If the display reads ON with the thermostat enabled and the alarm is turned ON and the reader shows the switch status for the starter as ON after the alarm turns OFF, check the relay and starter solenoid connections. Refer to Verify Repairs.

[b] If the display reads ON with the thermostat enabled and the alarm is turned ON and the reader does not show the switch status for the starter as ON after the alarm turns OFF, refer to Oil Temperature Sensor Connection Check.

[c] If the display reads ON with the thermostat enabled and the alarm OFF, replace the alarm. Refer to Verify Repairs.

[d] If the display does not read ON with the thermostat enabled, the thermostat input wire V42 is open between the thermostat and the ECU. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000291

 Oil Temperature Sensor Connection Check

Perform the following steps to troubleshoot the OTS connection:

  1. Check the OTS connection.

[a] If the OTS connector is plugged into the oil temperature sensor, reprogram the ECU. Refer to Verify Repairs.

[b] If the OTS connector is not plugged into the OTS, plug in the OTS connector. Refer to Verify Repairs.


TShootVuntitled00000292

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Close the hood; set the park brake; put the transmission in NEUTRAL and the high-range, if equipped.

  4. Start the engine.

  5. Turn the cruise master switch to the ON position. If it was on before the vehicle started, turn the switch to OFF and then to ON.

  6. Wait for the engine to shut down. After the idle timer expires, the engine will either shutdown or continue to run to charge the battery or keep the oil temperature between 60°F (16°C) and 104°F (40°C).

  7. Turn the thermostat on, if installed. Change the set point and heating/cooling mode until the thermostat requires the engine to start. The icons will flash. If the thermostat is not installed, wait for the lube oil temperature to fall below 60°F (16°C).

  8. The alarm will sound and the engine will start. Vehicle power (blower fans) will turn on approximately 30 seconds after the engine starts, due to the thermostat.

[a] If Optimized Idle operates properly, troubleshooting is complete.

[b] If Optimized Idle does not operate properly, troubleshooting is complete. Review this section from the first step to find the error - refer to OPTIMIZED IDLE FEATURE DOES NOT FUNCTION.


TShootVuntitled00000294

 Operation

To activate Optimized Idle, the following conditions must be met:

Idle Shutdown timer must be enabled

Ignition ON with the vehicle idling

Hood, cab, and/or engine compartment doors closed

Transmission in neutral and splitter in high range (if equipped)

Park brake set

Once the above conditions are met:

Turn the Cruise Master Switch to the ON position (if in the ON position, turn to OFF then to ON), the Optimized Idle Active Lamp will flash.

Turn on Thermostat Mode (if equipped and the mode is desired) by turning ON the thermostat, setting the fan controls in the bunk and cab to HIGH and enabling the vehicle heating and cooling system.

Once these conditions are met, the Optimized Idle Active Lamp will flash until the Idle Shutdown timer expires. Optimized Idle allows the operation of all DDEC features such as VSG, throttle control, and Cruise Switch VSG, while the active light is flashing.

Once Optimized Idle becomes active, the engine will either shutdown if Optimized Idle parameters are satisfied or ramp to 1100 RPM. While the system is active (OI Active Lamp is steadily illuminated), the throttle, VSG, Cruise Switch VSG functions are disabled and the engine speed is controlled by the ECU.

Next topic

OPTIMIZED IDLE START UP SEQUENCE

Previous topic


TShootVuntitled00000295

 Optimized Idle Start Up Sequence

The following occurs during every OI engine start:

  1. Optimized Idle Active Light is ON. The ECU determines when the engine needs to start to charge the battery, warm the engine, or heat/cool the vehicle interior.

  2. The alarm (mounted in the engine compartment) will sound for five seconds.

  3. After a short delay, the starter will engage and the engine will start. If the engine does not reach a specified RPM within a few seconds, the system will be disarmed for the rest of the ignition cycle. If the engine does not start, Optimized Idle will attempt a second engine start in 45 seconds. The alarm will sound again prior to the second engine start.

  4. Once the engine starts, it will ramp up to 1100 RPM.

  5. Vehicle accessories will be turned on thirty seconds after any thermostat based engine start and will not be turned on for an engine mode start. If the engine is running in engine mode, and the thermostat mode is requested, the vehicle accessories will be turned on thirty seconds after the request.

If two or more conditions exist at the same time, DDEC will satisfy all parameters before shutting down the engine. For example, if the engine started due to battery voltage, the engine will run for a minimum of two hours. If the thermostat becomes unsatisfied and requests the engine to run during this time, DDEC will control the HVAC fans through the Vehicle Power Shutdown relay, turning them on and off as required by the thermostat. At the end of the two hours, if the thermostat was not satisfied, the engine would continue to run.

Next topic

ENGINE MODE

Previous topic


TShootVuntitled00000296

 Engine Mode

Engine Mode automatically stops and restarts the engine to maintain oil temperature and battery voltage. The Optimized Idle Active Light is illuminated whenever Engine Mode is active. Optimized Idle starts and stops the engine to keep the following parameters within limits while in Engine Mode.

Battery Voltage - The engine will start when the battery voltage drops below 12.2 V for 12 V systems or 24.4 V for 24 V systems. When Optimized Idle starts due to low battery voltage, the engine will run for a minimum of two hours.

Oil Temperature - The engine will start when the oil temperature drops below 60°F (15.55°C) and will run until the oil temperature reaches 104°F (40°C).

Next topic

THERMOSTAT MODE

Previous topic


TShootVuntitled00000297

 Thermostat Mode

Thermostat Mode automatically stops and restarts the engine to maintain oil temperature, battery voltage and cab temperature. For on-highway applications, Thermostat Mode is used to keep the cab/sleeper (on-highway truck) and passenger area (coach) at the desired temperature and maintain the Engine Mode parameters. The optional thermostat must be turned ON for Thermostat Mode to be active. The Optimized Idle Active Light is illuminated whenever Thermostat Mode is active.

Engine mode parameters as well as the interior temperature are monitored in Thermostat Mode.

The thermostat informs the ECU when to start/stop the engine to keep the interior warm/cool based on the thermostat setting. Ambient temperature is also monitored to determine if the ambient temperature is extreme enough that the engine should run continuously.

Any accessories (HVAC fans) connected to the Vehicle Power Shutdown relay will turn ON for Thermostat Mode engine starts. The HVAC fans will remain OFF for Engine Mode starts.

If Optimized Idle starts the engine for Engine Mode, and Thermostat Mode is then requested, the HVAC fans will turn ON approximately 30 seconds after the Thermostat Mode is requested.

Two automatic conditions which help keep the operator comfortable and reduce engine cycling are Continuous Run Mode and Extended Run Mode.

Continuous Run Mode - This mode allows the engine to run continuously if the outside temperature (determined by the skin temperature sensor) falls outside the hot or cold set limits and the thermostat set point can not be met. The default set limits are 25°F (-3.9°C) for heat mode and 90°F (32°C) for cool mode. These values are customer programmable in the thermostat and are password protected. When the thermostat is in the Continuous Run Mode the thermometer icon will flash along with the heat or cool icon on the thermostat. If the thermostat set point is satisfied, the engine will shutdown regardless of the outside temperature.

Extended Idle Mode - If the Continuous Run Mode is not needed and the thermostat set point is not met within 45 minutes, the engine will shutdown for fifteen minutes and restart and run for fifteen minutes. This fifteen-minute on and off cycle will continue until the thermostat set point is reached or until the thermostat is turned off. This may be an indication that the heat or cool setting on the thermostat does not match the vehicle heating or cooling system setting. It could also be an indication of low freon, blockage in the heater system or system tampering.

Next topic

INSTALLATION

Previous topic


TShootVuntitled00000298

 Installation

Optimized Idle utilizes up to three inputs: Park Brake Interlock (includes Park Brake Switch, Neutral Switch, and Hood Tilt Switch), OI Thermostat (optional), and Cruise Enable. Optimized Idle utilizes four digital outputs: Vehicle Power Shutdown Relay, OI Alarm, OI Starter Relay, and the Optimized Idle Active Light. A Vehicle Speed Sensor is required. See Optimized Idle System Overview for the Optimized Idle overall system schematic. Refer to Optimized Idle - DDEC V - Installation and Troubleshooting for installation requirements.

Prior to installation, check the following items:

The transmission must provide a reliable neutral signal (switch).

There must be three inputs and four digital outputs available for the Optimized Idle devices.

A Vehicle Speed Sensor (VSS) must be installed.

If vehicle speed is transmitted over a data link to the ECU, a Starter Lockout Feature based on a reliable neutral signal must be provided. Otherwise the VSS must be hardwired directly to the ECU. The transmission ECU must be powered on.

There must be an electric starter; air starters cannot be used with Optimized Idle.

Automatic transmissions may be used, but they must have a Starter Lockout Feature installed based on a reliable neutral signal.

Next topic

INPUTS

Previous topic


TShootVuntitled00000299

 Inputs

The inputs for Optimized Idle are listed in the following table.

Description | Type | Config ID
Park Brake / ISD | Analog Input - 1.5k [image] Pull-up | 4101
Cruise Enable | Analog Input - 1.5k [image] Pull-up | 4119
Optimized Idle Thermostat | Analog Input - 1.5k [image] Pull-up | 1040

Next topic

DIGITAL OUTPUTS

Previous topic


TShootVuntitled00000300

 Digital Outputs

There are ten low-side digital outputs located on the VIH. The digital outputs required for Optimized Idle are listed in the following table.

Description
         Type
         Function Number
Vehicle Power Shutdown
         Digital Output

Optimized Idle Active Lamp
         Digital Output
         26
Optimized Idle Starter Relay*
         Digital Output
         42
Optimized Idle Alarm
         Digital Output
         43
  • Optimized idle Starter Relay is dedicated to pin V-54. It cannot be enabled on any other pin.

Next topic

PROGRAMMING REQUIREMENTS AND FLEXIBILITY

Previous topic


TShootVuntitled00000301

 Programming Requirements and Flexibility

Optimized Idle must be turned on by the factory via order entry or by Detroit Diesel Technical Service. Software group 6N5-3 must be specified.

The digital inputs and outputs listed in the following table can be programmed at engine order entry, by the Vehicle Electronic Programming System (VEPS) or DDEC Reprogramming System (DRS).

Optimized Idle Inputs and Digital Outputs

Description | Type | Config ID/Function Number
Park Brake / ISD | Analog Input - 1.5k [image] Pull-up | 4101
Cruise Enable | Analog Input - 1.5k [image] Pull-up | 4119
Vehicle Power Shutdown | Digital Output | 6
Optimized Idle Active Lamp | Digital Output | 26
Optimized Idle Starter Relay* | Digital Output | 42
Optimized Idle Alarm* | Digital Output | 43
  • Automatically configured with order entry.

The Idle Timer must be enabled by VEPS, DDDL or DRS. The recommended Idle Timer parameters are listed in the following table.

Idle Shutdown Timer Parameters:

Parameter
         Description
         Recommended Setting
ENABLE IDLE SHUTDOWN
         Enables/Disables the Idle Shutdown Feature
         YES (Required)
TIME (min)
         The amount of engine idle time that is allowed before the idle shutdown feature stops fueling the engine
  1. 100 minutes (customer's choice)
OVERRIDE
         Disables the Idle Shutdown Timer Override feature. The override will flash the AWL 90 seconds before shutdown to allow the driver to cancel the shutdown by pressing the accelerator pedal.
         NO
ENABLED ON VSG
         Allows the Idle timer to shutdown the engine when operating on VSG.
         YES

Optimized Idle installations should have the parameters listed in the following table set to Shutdown.

NOTICE:
DDC recommends that Shutdown be enabled for all Engine Protection parameters with Optimized Idle installations.
Engine Protection Parameters:

Parameter | Description | Setting
OIL TEMP | Indication of the type of engine protection based on high engine oil temp. | SHTDN
COOLANT TMP | Indication of the type of engine protection based on high engine coolant temp. | SHTDN
OIL PRS | Indication of the type of engine protection based on low engine oil pressure. | SHTDN
COOLANT LVL | Indication of the type of engine protection based on low coolant level. | SHTDN

Next topic

DIAGNOSTICS

Previous topic


TShootVuntitled00000302

 Diagnostics

Refer to the Optimized Idle - DDEC V- Installation and Troubleshooting manual for diagnostic and troubleshooting information.

Next topic

INTERACTION WITH OTHER FEATURES

Previous topic


TShootVuntitled00000303

 Interaction With Other Features

The Vehicle Power shutdown feature is used by Optimized Idle to turn off all accessory loads when the engine is shutdown. Optimized Idle will turn these loads on for thermostat mode starts.

Stop Engine Override Switch is required if "Shutdown" is enabled for Engine Protection parameters.

The throttle, VSG, Cruise Switch VSG functions are disabled and the engine speed is controlled by the ECU when Optimized Idle is active (Optimized Idle lamp is illuminated).

Previous topic


TShootVuntitled00000305

 Verify Transmission Type

Perform the following steps to check the transmission type.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Check transmission origination.

[a] If a manual transmission, Allison hydraulic, Allison Electronic, Voith, ZF, refer to Review PWM #1 Signal.

[b] If a J1939/autoshift, Allison WT, Rockwell RXX-X, refer to the troubleshooting manual of the transmission manufacturer to troubleshoot the fault.

[c] If the transmission type does not match the transmission correctly, reprogram and refer to Verify Repairs.


TShootVuntitled00000306

 Review PWM #1 Signal

Perform the following steps to check the DDR for codes.

  1. Perform road test with assistant.

  2. Plug in DDR.

  3. Watch PWM #1 signal.

[a] If the PWM varies with the load changes, and the ECU is programmed as Allison®Electric, Voith or ZF, the signal is normal. Review the wiring or transmission.

[b] If the PWM signal is 0% or 100% when the signal is programmed for Allison Hydraulic with load changes, the program is normal. Review the transmission, wiring or relay. Refer to Verify Repairs.


TShootVuntitled00000307

 Verify Repairs

Perform the following steps to verify repairs. Start with the Menu Selection. An assistant is needed for the following procedure.

  1. Perform road test.

[a] If the problem is resolved, troubleshooting is complete.

[b] If the problem still exists, contact the OEM or transmission supplier. The steps that led you here do not indicate a problem with the PWM #2 output or output wire. Verify the correct configuration. Refer to the DDEC Application and Installation manual, 7SA821, for the appropriate engine.


TShootVuntitled00000309

 Check for Open Data Link Wires

Perform the following steps to check for open data link wires:

  1. Unplug the MAS display harness connector at the display.

  2. Insert a jumper wire between cavity E (DL+) and cavity D (DL-). See Maintenance Pro Display Harness.

  3. Unplug the vehicle interface harness at the ECU.

  4. Measure resistance between cavity V56 and V57 of the vehicle interface harness connector. See ECU Vehicle Harness Connector.

[a] If measured resistance is greater than 10 [image], one of the data link wires are open. Locate the open and repair or replace the wire; then test. Refer to Verify Repairs.

[b] If measured resistance is less than 10 [image], proceed with the troubleshooting. Refer to Check for Shorted Data Link.


TShootVuntitled00000310

 Check for Shorted Data Link

Perform the following steps to check for shorted data link wires:

  1. Remove jumper wire.

  2. Measure resistance between cavity V56 and V57 of the vehicle interface harness connector. See ECU Vehicle Harness Connector.

[a] If the measured resistance is less than 10 [image], the data link wires are shorted to each other. Replace wire or repair the short; test. Refer to Verify Repairs.

[b] If the measured resistance is greater than 10 [image], proceed with the troubleshooting. Refer to Check for Short to Ignition.


TShootVuntitled00000311

 Check for Short to Ignition

Perform the following steps to check for a short to the ignition:

  1. Measure resistance between cavity V15 and V57. Measure again between cavity V15 and V56. See ECU Vehicle Harness Connector.

[a] If any of the readings are less than 10 [image], that wire is shorted to the ignition wire where the reading was recorded. Repair the short; replace the wire; then test. Refer to Verify Repairs.

[b] If both readings are less than 10 [image], replace the MAS display and test. Refer to Verify Repairs.


TShootVuntitled00000312

 Information

A blank LED for an item indicates a fault in the sensor used for that display. If all lights (green and red) illuminate during the bulb check sequence, refer to the affected sensor troubleshooting section.


TShootVuntitled00000313

 Verify Repairs

Perform the following steps to verify repairs.

Turn ignition ON.

Observe the MAS display.

[a] If MAS display operates correctly, troubleshooting is complete.

[b] If MAS display does not operate correctly, repeat the checks. Refer to MAINTENANCE ALERT SYSTEM.


TShootVuntitled00000315

 Check EGR Controls

Perform the following steps to check the EGR:

  1. Turn ignition ON.

  2. Plug in DDR/DDDL.

  3. Any EGR Related codes (except Flash Code 39)?

[a] If codes were logged, troubleshoot the codes as necessary.

[b] If no codes were logged (besides Code 39), proceed to step 4.

  4. Inspect system for any air leaks in the exhaust, EGR, or intake system (including charge-air-cooler).

[a] If leaks were detected, repair as necessary.

[b] If no leaks are present, go to step 5.

  5. Check Delta P Counts on DDR/DDDL (counts should be between 86 and 118).

Note: The ignition is set to the ON position and the engine is not running

[a] If the counts were between 86 and 118, refer to Check VPOD Input Pressure.

[b] If the counts were not between 86 and 118, replace the Delta P Sensor and refer to Test.


TShootVuntitled00000316

 Check VPOD Input Pressure

Follow these steps to check VPOD input pressure:

  1. Measure the vehicle air supply pressure to VPOD input pressure to port 1; ensure it is between 102 - 188 psi (703 - 1296 kPa).

[a] If the supply pressure is not between 102 - 188 psi (703 - 1296 kPa), troubleshoot the vehicle air system until that result is obtained.

[b] If the supply pressure is between 102 - 188 psi (703 - 1296 kPa), refer to Check VPOD Output Pressure.


TShootVuntitled00000317

 Check VPOD Output Pressure

Follow these steps to check VPOD output pressure:

  1. Disconnect the air hose from the VGT (Variable Geometry Turbocharger) actuator.

  2. Install a 100 psi pressure gauge (accurate to within 1.4 kPa (0.2 psi)) at the outlet of the VGT hose.

  3. Using the DDR/DDDL, activate cavity E4 (VNT) duty cycle and monitor the output pressure from the VPOD.

  4. Test: Activate the cavity to 50 % duty cycle: Pressure = 310 ± 14 kPa (45 ± 2 psi).

[a] If the VPOD readings are as listed above, refer to Check EGR Valve.

[b] If the results in this step cannot be attained, or if the VPOD leaks when activated, replace the VPOD.

[c] If the VPOD has been replaced, refer to Check Variable Output Pressure Device (VPOD) P/N and Supply Voltage.


TShootVuntitled00000318

 Check Variable Output Pressure Device (VPOD) P/N and Supply Voltage

The following checks should be performed for the VPOD P/N and supply voltage:

  1. Check VPOD label to determine if it is + 12V or + 24V compatible.

  2. Unplug VPOD mating connector. A 1,000 Ohm resistor is needed for the next step. Insert the resistor between cavity 1 and 3 for ease of checking with the VOM.

[a] Turn ignition switch ON.

[b] Measure system voltage from pin 3 to pin 1. See VGT/VPOD Schematic.

[c] Plug in DDR and check ECU voltage.

  3. Is the VPOD P/N and supply voltage, and ECU voltage correct?

[a] If the VPOD P/N and system voltage are correct, refer to Check VPOD Wiring.


TShootVuntitled00000319

 Check VPOD Wiring

The following checks should be performed for the VPOD wiring.

NOTE: VPOD power should have been verified under the P/N check. If not, refer to Check Variable Output Pressure Device (VPOD) P/N and Supply Voltage.

  1. Turn ignition switch ON.

  2. Unplug the VPOD mating connector.

  3. Insert a 1,000 ohm resistor between cavities #2 and #1 for the 12V version, or cavities #2 and #3 for the 24V version. See Pins V61 through V68 to Battery Leads.

  4. Connect a VOM to the VPOD connector between pin #2 and pin #3 for the 12V VPOD or pin #2 and pin #1 for the 24V VPOD. See Pins V61 through V68 to Battery Leads.

  5. Using either a DDR or DDDL, activate the VPOD used for the VNT. Ensure activating 50% duty cycle: The reading should be = 50% of the VPOD supply voltage ± 1 volt, The acceptable range will depend on the supply system voltage (e.g. voltage to VPOD = 13.8V * 0.5 = 6.9V; therefore 5.9V to 7.9V at PWM is okay.)

  6. Note any air leakage when PWMs are activated to 90% and correct the leaks as needed.

[a] If the PWM voltage measurement is correct, replace the VPOD.

[b] If the PWM voltage measurement is incorrect, and the wiring checks are okay, try a test ECU programmed for EGR, or contact DDC Technical Service.


TShootVuntitled00000320

 Check EGR Valve

Perform the following steps to check the EGR Valve.

  1. Disconnect the oil supply from the EGR valve actuator. Connect shop air to the actuator and regulate the pressure at 10 psi to the EGR actuator. See EGR Valve Assembly with Oil Lines

  2. Plug in the DDDL.

  3. Activate the EGR Valve output (E1) and observe the EGR Valve travel (close 0% - open 100%).

Note: Do not activate more than 3 cycles.

  4. Visually inspect the EGR Valve for proper movement.

  5. Did the EGR Valve close (0%) when activated?

[a] If the EGR Valve was fully closed at 0%, refer to Check for Active Codes.

[b] If the EGR Valve did not fully close at 0%, replace the EGR Valve and refer to Test.

  6. Did the EGR Valve open (100%) when activated?

[a] If the EGR Valve was fully opened at 100%, refer to Check for Active Codes.

[b] If the EGR Valve did not fully open to 100%, replace the EGR Valve and refer to Test.


TShootVuntitled00000321

 Check for Active Codes

Follow this procedure to check for active codes.

  1. Turn ignition ON.

  2. Plug in DDR/DDDL.

  3. Read active codes.

  4. Record or print codes. Ensure that PID, SID, and FMI are recorded. Refer to the proper code section of this Help to troubleshoot that code.

NOTE: FMIs listed as 14 are diagnostic information codes and no troubleshooting is required. For example, an engine derates due to high TCO temperature; a 404/14 code will be stored. This would indicate that conditions warranted having the ECU derate the fueling to the engine. If the customer complaint was a power loss, it could be explained that loss of power was done by the ECU to protect other engine components.

  5. If the issue is not related to the EGR system components, or assistance is needed, contact Detroit Diesel Technical Service.


TShootVuntitled00000322

 Test

Follow these steps to test:

  1. Reassemble connectors or components.

  2. Start and run the engine.

  3. Perform loaded road test if this is necessary to duplicate original complaint.

[a] If symptoms/codes are gone, repairs are complete.

[b] If any codes display, review this section again; contact Detroit Diesel Technical Service.


TShootVuntitled00000324

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 11.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in DDR.

  3. Read active codes.

[a] If code 187/4 is logged and there are no VSG controls used, call DDC with the engine serial number to determine if re-calibration is necessary.

[b] If code 187/4 was logged and there are VSG controls used primarily, refer to Sensor Wiring Check.

[c] If codes 100/4 and 91/4 were logged, refer to VEHICLE HARNESS.


TShootVuntitled00000325

 Sensor Wiring Check

Perform the following steps to check the sensor and wiring:

  1. Turn ignition OFF.

  2. Disconnect VSG throttle sensor connector.

  3. Install a jumper wire between sockets V14 and V11 of the VSG harness connector. See Variable Speed Governor Circuit.

NOTE: Cavities of throttle controls may vary depending on the OEM.

  4. Turn ignition ON.

  5. Enable VSG throttle. Refer to OEM guidelines.

  6. Read DDR for active codes.

[a] If active code 187/3 and any other codes are logged, refer to Check Hand Throttle Sensor Adjustment.

[b] If active code 187/4 and any other codes are logged, refer to Check for +5 volts.


TShootVuntitled00000326

 Check Hand Throttle Sensor Adjustment

Perform the following steps to check the hand throttle sensor:

  1. Remove jumper and reconnect hand throttle sensor.

  2. Turn ignition ON.

  3. Plug in DDR.

  4. Select VSG COUNTS on the DDR.

  5. Enable VSG. Set to idle position.

  6. Read counts.

[a] If the count value set at idle (minimum throttle) is greater than 48 counts, refer to Check Hand Throttle Sensor Connectors.

[b] If the count value set at idle (minimum throttle) is less than 48 counts, refer to Adjust Hand Throttle Sensor.


TShootVuntitled00000327

 Adjust Hand Throttle Sensor

Perform the following steps to adjust the hand throttle sensor:

  1. Turn ignition OFF.

  2. If a variable hand throttle sensor is installed, adjust idle position (low-speed) stops on the hand throttle sensor.

  3. If fixed resistors are installed, replace with new resistors. (Minimum counts MUST be greater than 48.)

  4. Turn ignition ON.

  5. Read VSG counts with throttle at low-speed position.

[a] If the idle count reading is greater than 48 counts, refer to Verify Repair.

[b] If the idle count reading is less than 48 counts, refer to Check Hand Throttle Sensor Connectors.


TShootVuntitled00000328

 Check Hand Throttle Sensor Connectors

Perform the following steps to check the hand throttle sensor connectors.

  1. Turn ignition OFF.

  2. Inspect the terminals at the hand throttle sensor connectors (sensor side and harness side) for bent, corroded and unseated pins or sockets. See Variable Speed Governor Circuit.

[a] If the terminals and connectors are not damaged, replace hand throttle sensor. Refer to Verify Repair.

[b] If the terminals and connectors are damaged, repair as necessary. Refer to Verify Repair.


TShootVuntitled00000329

 Check for +5 volts

Perform the following steps to check for +5 volts:

  1. Turn ignition ON.

  2. Enable VSG. Refer to OEM guidelines.

  3. Measure voltage on the hand throttle sensor harness connector, socket V11 to socket V60. See Variable Speed Governor Circuit.

[a] If the voltage reading is between 4 to 6 volts, refer to Check for Short.

[b] If the voltage reading is greater than 6 volts, refer to FLASH CODE 12 - VSG HIGH.

[c] If the voltage reading is less than 4 volts, refer to Check for Short to 5 Volt.


TShootVuntitled00000330

 Check for Short

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Enable VSG. Refer to OEM guidelines.

  4. Measure resistance between sockets A V60 and B V14 on the hand throttle sensor harness connector. For VSG circuit, see Variable Speed Governor Circuit.

[a] If the resistance is greater than 1,000 [image] or open, refer to Check for Open Signal.

[b] If the resistance is less than or equal to 1,000 [image], the signal line #525 is shorted to the return line. Repair the short. Refer to Verify Repair.


TShootVuntitled00000331

 Check for Open Signal

Perform the following steps to check for open signal:

  1. Install a jumper wire between sockets A and B of the hand throttle sensor harness connector. See Variable Speed Governor Circuit.

  2. Enable VSG. Refer to OEM guidelines.

  3. Measure resistance between sockets V14 and V60 on the vehicle harness connector.

[a] If the resistance is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If the resistance is greater than 5 [image] [image] or open and the signal line V14 or return line V60 is open, repair the open. Refer to Verify Repair.


TShootVuntitled00000332

 Check ECU Connectors

Perform the following steps to check for signal open:

  1. Check terminals at the ECU vehicle harness connector (both the ECU and harness side) for bent, corroded, and unseated pins or sockets. See Electronic Control Module Vehicle Harness Connector.

[a] If the terminals and connectors are damaged, repair the terminals, connectors, or both. Refer to Verify Repair.

[b] If the terminals and connectors are not damaged, contact DDC Technical Service. Refer to Verify Repair.


TShootVuntitled00000333

 Check for Short to 5 Volt

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Disconnect the connector at the hand throttle sensor.

  4. Measure resistance between sockets A and C on the hand throttle sensor harness connector. See Variable Speed Governor Circuit.

[a] If the resistance measurement is greater than 1,000 [image], refer to Check for Open +5 Volt Line.

[b] If the resistance measurement is less than or equal to 1,000 [image], the vehicle +5 volt line V11 is shorted to the return line V60. Repair short. Refer to Verify Repair.


TShootVuntitled00000334

 Check for Open +5 Volt Line

Perform the following steps to check for an open +5 volt line.

  1. Install a jumper wire between sockets A and C of the hand throttle sensor harness connector. See Variable Speed Governor Circuit.

  2. Measure resistance between sockets V11 and V60 on the vehicle connector.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If the resistance measurement is greater than 5 [image], or open, the vehicle +5 volt line (#916) is open. Repair open. Refer to Verify Repair.


TShootVuntitled00000335

 Verify Repair

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check for logged codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 187/4 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 187/4 is logged, and other codes are logged, systems diagnostics are complete. Please review this section from the first step to find the error - refer to Multiple Code Check.


TShootVuntitled00000337

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 12.

Perform the following steps to check for multiple codes:

  1. Turn ignition ON. (For VSG circuit, see Variable Speed Governor Circuit.)

  2. Plug in DDR.

[a] If active code 187/3 and any other codes except 91/3 or 100/3 are logged, refer to Sensor Check.

[b] If active code 187/3 and codes 91/3 or 100/3 are logged, refer to VEHICLE HARNESS.


TShootVuntitled00000338

 Sensor Check

Perform the following steps to check the sensor:

  1. Turn ignition OFF.

  2. Unplug the VSG throttle connector. (For VSG circuit, see Variable Speed Governor Circuit.)

  3. Turn ignition ON.

  4. Read active codes.

[a] If active code 187/4 is logged, and code 187/3 only occurs when the throttle is moved at or near full throttle (when connected), refer to Check Calibration.

[b] If active code 187/3 is logged, and the code appears when the throttle is not at or near full throttle (when connected), refer to Return Circuit Check.


TShootVuntitled00000339

 Check Calibration

Perform these additional steps to check the calibration of the sensor:

  1. Plug in the VSG throttle connector.

  2. Turn ignition ON.

  3. Plug in DDR.

  4. Display VSG counts.

  5. Dial throttle to Full Throttle.

[a] If the VSG counts are greater than 968, adjust the maximum throttle travel. If not adjustable, replace the throttle control.

[b] If the VSG counts are less than 968, refer to Return Circuit Check.


TShootVuntitled00000340

 Return Circuit Check

Perform these steps to check the return circuit:

  1. Place the transmission in neutral.

  2. Turn ignition OFF.

  3. Install a jumper wire between pin A V60 and pin B V14 of the VSG throttle harness connector.

  4. Disconnect the vehicle harness connector at the ECU.

  5. Enable VSG control. (This may require the ignition be turned on.)

  6. Measure resistance between sockets V60 and V14 on the vehicle harness connector. See Typical Variable Speed Governor Circuit.

[a] If the resistance is less than or equal to 5 [image], refer to Variable Speed Governor Throttle Connector Check.

[b] If the resistance is greater than 5 [image], the return line V60 is open, repair the open. Refer to Verify Repairs.


TShootVuntitled00000341

 Variable Speed Governor Throttle Connector Check

Perform these steps to check the VSG throttle connectors:

  1. Inspect terminals at the VSG connectors (sensor side and harness side) for bent, corroded and unseated pins or sockets.

[a] If the VSG connector terminals are damaged, repair terminals and/or connectors. Refer to Verify Repairs.

[b] If the VSG connector terminals are in good condition with no signs of damage, refer to Check for Short to Battery (+).


TShootVuntitled00000342

 Check for Short to Battery (+)

Perform these steps to check for short to battery (+).

  1. Turn ignition OFF.

  2. Unplug VSG connector.

  3. Turn ignition ON.

  4. Measure voltage between V14 and battery ground. See Variable Speed Governor Circuit.

[a] If measured voltage is less than or equal to 0.2 volts, refer to Check for Short.

[b] If measured voltage is greater than 0.2 volts, signal wire is shorted to 12/24 volt source. Repair or replace V14 circuit. Refer to Verify Repairs.


TShootVuntitled00000343

 Check for Short

To check for short, perform the following:

  1. Turn ignition OFF.

  2. Unplug vehicle 30-pin connector and the VSG connector.

  3. Turn ignition ON.

  4. Enable VSG. Refer to OEM guidelines.

  5. Measure resistance between V11 and V14. See Variable Speed Governor Circuit.

[a] If resistance is greater than 5 [image], check ECU connector. Refer to Verify Repairs.

[b] If resistance is less than 5 [image], wire V11 (5-volt supply) is shorted to V11 (signal). Repair short or replace wire. Refer to Verify Repairs to verify repairs.


TShootVuntitled00000344

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Set parking brake, transmission in Neutral.

  4. Turn ignition ON.

  5. Clear codes.

  6. Start and run the engine for one minute.

  7. Stop engine.

  8. Check DDR for codes.

[a] If no codes are displayed, no further troubleshooting is required.

[b] If code 187/3 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 187/3 is logged, and other codes are logged, refer to Multiple Code Check.


TShootVuntitled00000346

 Sensor Check

Use the following procedure to troubleshoot Flash Code 13.

Perform the following steps to check the sensor.

  1. Turn vehicle ignition OFF.

  2. Disconnect Coolant Level Sensor (CLS).

  3. Turn ignition ON.

  4. Start engine.

  5. Read logged codes.

  6. Stop engine.

[a] If code p 111/3 is logged, refer to Check Engine Coolant Level Sensor Connector.

[b] If code p 111/4 is logged, refer to Check for Short.


TShootVuntitled00000347

 Check Engine Coolant Level Sensor Connector

Perform the following steps to check the ECL connector.

  1. Inspect terminals at the ECL connector for bent, corroded and unseated pins or sockets. Ensure wires are not reversed at the ECL See Engine Coolant Level Sensor.

[a] If terminals and connectors are damaged, repair both. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the ECL. Refer to Verify Repairs.


TShootVuntitled00000348

 Check for Short

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure resistance between sockets A and B on the ECL harness connector. Also measure resistance between socket A and battery ground; and socket A and chassis ground. See Engine Coolant Level Sensor.

[a] If the resistance is greater than 10,000 [image] [image] or open, refer to Check Engine Coolant Level Sensor Connector.

[b] If the resistance is less than or equal to 10,000 [image], the signal wire V38 is shorted to the ground V60, or to chassis ground. Repair short; refer to Verify Repairs.


TShootVuntitled00000349

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear DDR codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are displayed, troubleshooting is complete.

[b] If code 111/4 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 111/4 is logged, refer to Code 111/4 Logged.


TShootVuntitled00000350

 Code 111/4 Logged

Perform the following steps to troubleshoot Code 111/4.

  1. Remove ECL.

  2. Plug opening.

  3. Locate sensor probe in clean water.

  4. Start and run the engine for one minute.

  5. Check DDR for codes.

[a] If code 111/4 is logged, all system diagnostics are complete. Review this section to find the error - refer to Sensor Check.

[b] If code 111/4 is not logged, reprogram the ECU and replace the coolant with new. Repeat the test. Refer to Verify Repairs.


TShootVuntitled00000351

 TROUBLESHOOTING ADD COOLANT LEVEL SENSOR

Troubleshooting 111/6, Flash Code 13 follows: Listed in the following table are the flash codes for Add Coolant Level Sensor (ACLS) problems.

Flash Code | PID FMI | Description | Typical Cause
13 | 111/6 | ACLS failed low | Signal wire (#906) shorted low (ground)
16 | 111/5 | ACLS failed high | Open or poor ground; open signal wire
43 | 111/1 | Coolant level low (ACLS) | Coolant level below probe
89 | 111/12 | ACLS Fault | Coolant reported low on main ECL, with ACLS okay
Check Sensor

Perform the following steps to check the sensor.

  1. Unplug the ACLS.

  2. Start the engine.

  3. Plug in the DT. Read codes.

[a] If code 13 (111/6) displays, refer to Check for Short.

[b] If code 16 (111/5) displays, replace the ACLS; then go to test. Refer to Test Repair.


TShootVuntitled00000352

 Check for Short

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Unplug the ACLS module.

  3. Measure the resistance between cavities A and B of the ACLS connector. See Add Coolant Level Sensor Installation.

[a] If the measured resistance is greater than 10 [image], refer to Check for Voltage.

[b] If the measured resistance is less than 10 [image], V 37 and ground wires are shorted. Repair or replace the wires and test. Refer to Test Repair.


TShootVuntitled00000353

 Check for Voltage

Perform the following steps to check for voltage:

  1. Turn ignition ON.

  2. Measure voltage between cavities E and C of the ACLS module connector. See Add Coolant Level Sensor Installation.

[a] If the measurement is 11.0 volts or greater, refer to Check for Open Signal.

[b] If the measurement is less than 11.0 volts, determine the reason for the loss of ignition voltage.


TShootVuntitled00000354

 Check for Open Signal

Perform the following steps to check for open signal:

  1. Turn ignition OFF.

  2. Unplug the engine harness connector.

  3. Measure resistance between cavities D and G of the ACLS module connector. See MAS Pigtail.

[a] If the measured resistance is greater than 10 [image], replace the ACLS module; then, refer to Test Repair.

[b] If the measured resistance is less than 10 [image], the signal wire is shorted to the battery ground wire. Repair the short; replace the wire. Refer to Test Repair.


TShootVuntitled00000355

 Test Repair

Perform the following steps to test the repair:

  1. Connect all the removed connectors.

  2. Start and run the engine for 5 minutes.

  3. Plug in the DDR.

  4. Read the active codes.

[a] If no codes display, the repairs are complete. Return the unit to service.

[b] If code 13 displays, troubleshooting is complete; review these steps to find the error.

[c] If any codes other than code 13 display, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000357

 Code Check

Use the following procedure to troubleshoot Flash Code 14.

Perform the following steps to check for codes.

  1. Turn vehicle ignition ON.

  2. Plug in diagnostic data reader (DDR) and determine which code is logged.

[a] If codes PID 110-FMI 3 is logged, refer to Coolant Temperature Sensor Check.

[b] If codes PID 175-FMI 3 is logged, refer to Oil Temperature Sensor Check.


TShootVuntitled00000358

 Coolant Temperature Sensor Check

Perform the following steps to check the coolant temperature sensor (CTS).

  1. Turn vehicle ignition OFF.

  2. Disconnect CTS and install a jumper between the CTS connector sockets 1 and 2. See Temperature Sensor Circuits (View 1) and Temperature Sensor Circuits (View 2).

  3. Turn vehicle ignition ON.

  4. Read active codes.

[a] If code 110/4 or any other codes except 110/3 are logged, refer to Check for Signal Short to +5 Volt Line.

[b] If code 110/3 is logged and any codes except code 110/4 are logged, refer to Open Line Check.


TShootVuntitled00000359

 Oil Temperature Sensor Check

Perform the following steps to check the oil temperature sensor (OTS).

  1. Turn vehicle ignition OFF.

  2. Disconnect OTS and install a jumper between OTS connector sockets 1 and 2. See Temperature Sensor Circuits (View 1) and Temperature Sensor Circuits (View 2).

  3. Turn ignition ON.

  4. Read active codes.

[a] If code 175/4 is logged, refer to Open Line Check.

[b] If code 175/3 is logged and any codes except code 175/4 are logged, refer to Check for Signal Short to +5 Volt Line.


TShootVuntitled00000360

 Check for Signal Short to +5 Volt Line

Perform the following steps to check for a short to the +5 volt line.

  1. Turn ignition OFF.

  2. Remove jumper wire.

  3. Disconnect the engine harness connector at the ECU.

  4. Measure resistance between sockets E5 and V11 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is greater than 5 [image] [image] or open, refer to Check Coolant Temperature Sensor Connectors.

[b] If the resistance measurement is less than or equal to 5 [image], the signal line E5 is shorted to the engine +5 volt line V11. Repair the short and refer to Verify Repairs.


TShootVuntitled00000361

 Check for Signal Short to +5 Volt Line

Perform the following steps to check for a short to the +5 volt line.

  1. Turn vehicle ignition OFF.

  2. Remove jumper wire.

  3. Disconnect the engine harness connector at the ECU.

  4. Measure resistance between sockets E7 and V11 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is greater than or equal to 5 [image], refer to Check Oil Temperature Sensor Connectors.

[b] If the resistance measurement is less than 5 [image], the signal line E7 is shorted to the engine +5 volt line V11. Repair the short and refer to Verify Repairs.


TShootVuntitled00000362

 Check Coolant Temperature Sensor Connectors

Perform the following steps to check the CTS connectors.

  1. Check terminals at the CTS connector (both sensor and harness side) for damage; bent, corroded and unseated pins or sockets. See Temperature Sensor Circuits (View 1) and Temperature Sensor Circuits (View 2).

[a] If terminals and connectors are in good condition, replace the CTS. Refer to Verify Repairs.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000363

 Check Oil Temperature Sensor Connectors

Perform the following steps to check the OTS connectors.

  1. Check terminals at the OTS connector (both sensor and harness side) for damage: bent, corroded and unseated pins or sockets. See Temperature Sensor Circuits (View 1) and Temperature Sensor Circuits (View 2).

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the OTS. Refer to Verify Repairs.


TShootVuntitled00000364

 Open Line Check

Perform the following steps to check for an open line.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU. Leave the jumper wire between A and B of the Temperature Sensor Connector.

  3. Measure resistance between sockets E5 and E15 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line E5 or return line E15 is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000365

 Open Line Check

Perform the following steps to check for an open line.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU. Leave the jumper wire between A and B of the Temperature Sensor Connector.

  3. Measure resistance between sockets E7 and E15 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line E7 or return line E15 is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000366

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connector (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. See ECU Engine Harness Connector.

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the CTS/OTS.


TShootVuntitled00000367

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn vehicle ignition ON.

  4. Clear codes.

  5. Start and run the engine for eight minutes.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 110/3 or 175/3 and any other codes are logged, all system diagnostics are complete. Review this section to find the error - refer to Code Check.

[c] If any codes except code 110/3 or 175/3 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000369

 Code Check

Use the following procedure to troubleshoot Flash Code 15.

Perform the following steps to check for codes.

  1. Turn vehicle ignition ON.

  2. Plug in diagnostic data reader (DDR) and determine which code is logged.

[a] If codes PID 110-FMI 4 are logged, refer to Coolant Temperature Sensor Check.

[b] If codes PID 175-FMI 4 are logged, refer to Oil Temperature Sensor Check.


TShootVuntitled00000370

 Coolant Temperature Sensor Check

Perform the following steps to check the coolant temperature sensor (CTS).

  1. Turn vehicle ignition OFF.

  2. Disconnect (unplug) CTS connector.

  3. Start and run the engine for eight minutes.

  4. Read active codes with engine still running.

[a] If code 110/4 or any other codes are logged, refer to Check Coolant Temperature Sensor Connectors.

[b] If any codes except code 110/4 are logged, refer to Check for Short.


TShootVuntitled00000371

 Oil Temperature Sensor Check

Perform the following steps to check the oil temperature sensor (OTS).

  1. Turn vehicle ignition OFF.

  2. Disconnect OTS connector. See Coolant Temperature Sensor Circuits and Oil Temperature Sensor.

  3. Start and run the engine for eight minutes.

  4. Read active codes with engine running.

[a] If code 175/4 is logged, refer to Check for Short.

[b] If any codes except code 175/4 are logged, refer to Check Oil Temperature Sensor Connectors.


TShootVuntitled00000372

 Check Coolant Temperature Sensor Connectors

Perform the following steps to check the CTS connectors.

  1. Check terminals at the CTS connector (both sensor and harness side) for damage; bent, corroded and unseated pins or sockets. See Coolant Temperature Sensor Circuits and Oil Temperature Sensor.

[a] If terminals and connectors are in good condition, replace the CTS. Refer to Verify Repairs.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000373

 Check Oil Temperature Sensor Connectors

Perform the following steps to check the OTS connectors.

  1. Check terminals at the OTS connector (both sensor and harness side) for damage: bent, corroded and unseated pins or sockets. See Coolant Temperature Sensor Circuits and Oil Temperature Sensor.

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the OTS. Refer to Verify Repairs.


TShootVuntitled00000374

 Check for Short

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between sockets E5 and E15 on the engine harness connector. See ECU Engine Harness Connector.

  4. Measure resistance between socket E5 and a good ground.

[a] If the resistance measurement between sockets E5 and E15, or E5 and battery ground, is less than or equal to 5 [image], the signal line E5 is shorted to the return line E15 or battery ground. Repair the short. Refer to Verify Repairs.

[b] If the resistance measurement between sockets E5 and E15 is greater than 5 [image] [image] or open, and the resistance measurement between sockets E5 and a good ground is greater than or equal to 5 [image] [image] or open, refer to Check ECU Connectors.


TShootVuntitled00000375

 Check for Short

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between sockets E7 and E15 on the engine harness connector. See ECU Engine Harness Connector.

  4. Measure resistance between socket E7 and a good ground.

[a] If the resistance measurement between sockets E7 and E15, or E7 and battery (-) is less than or equal to 5 [image], the signal line E7 is shorted to the return line E15 or battery ground. Repair the short. Refer to Verify Repairs.

[b] If the resistance measurement between socket E7 and E15 is greater than 5 [image] [image] or open, and the resistance measurement between socket E7 and a good ground is greater than or equal to 5 [image] [image] or open, refer to Check ECU Connectors.


TShootVuntitled00000376

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connector (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. Check terminals E5 and E15 of the ECU connector. See ECU Engine Harness Connector.

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, reprogram the ECU. Refer to Verify Repairs.


TShootVuntitled00000377

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connector (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. Check terminals E7 and E15 of the ECU connector. See ECU Engine Harness Connector.

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, reprogram the ECU. Contact Detroit Diesel Technical Service Group. Refer to Verify Repairs.


TShootVuntitled00000378

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn vehicle ignition ON.

  4. Clear codes

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 110 or 175/4 and any other codes are logged, all system diagnostics are complete. Review this section to find the error - refer to Code Check.

[c] If any codes except code 110 or 175/4 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000380

 Sensor Check

Use the following procedure to troubleshoot Flash Code 16.

Perform the following steps to check the sensor.

  1. Turn ignition OFF.

  2. Disconnect Coolant Level Sensor (ECL) connector and install a jumper between sockets A and B of the ECL harness connector.

  3. Attempt to start and run engine at idle.

  4. Read DDR for active codes.

[a] If active code 111/3 and any other codes except code 111/4 are logged, refer to Signal Circuit Check.

[b] If active code 111/4 and any other codes are logged, refer to Signal Short to Ignition Check.

  5. Stop engine.


TShootVuntitled00000381

 Signal Circuit Check

Perform the following steps to check the signal circuit.

  1. Turn ignition OFF.

  2. Disconnect the ECL.

  3. Disconnect the vehicle harness connector.

  4. Measure resistance between socket H3 (#115) on the vehicle harness connector and A (#115 signal) of the ECL connector.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Ground Circuit Check.

[b] If the resistance measurement is greater than 5 [image], or the signal line #115 is open, repair the open. Refer to Verify Repairs.


TShootVuntitled00000382

 Ground Circuit Check

Perform the following steps to check the ground circuit.

  1. Measure resistance between cavity B (battery ground) of the ECL connector and battery ground.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Signal Short to Ignition Check.

[b] If the resistance measurement is greater than 5 [image], or open, the ground circuit is open. Repair and refer to Verify Repairs.


TShootVuntitled00000383

 Signal Short to Ignition Check

Perform the following steps to check for a signal short to ignition.

  1. Disconnect the vehicle harness connector at the ECU.

  2. Remove the jumper wire at the ECL harness connector.

  3. Turn ignition ON.

  4. Measure voltage at cavity V38 of the ECL connector and battery ground. See Engine Coolant Level Sensor and Circuits.

[a] If the voltage measurement is less than or equal to 6 volts, refer to ECU Connectors Check.

[b] If the voltage measurement is greater than 6 volts, the ECL signal line V38 is shorted to the 12/24 volt DC line. Repair the short or replace the V38 wire. Refer to Verify Repairs.


TShootVuntitled00000384

 ECU Connectors Check

Perform the following steps to check the ECU connectors.

  1. Inspect terminals at the vehicle harness connector (both the sensor and harness side) for bent, corroded and unseated pins or sockets. Check terminal and pin V38 at the ECU and all terminals and pins in the ECL connector. See Vehicle Harness Connector.

[a] If terminals and connectors are not damaged, replace the ECL. Refer to Verify Repairs. If this is a repeated failure of the ECL, refer to Alternator Ground Check.

[b] If terminals and connectors are damaged, repair both. Refer to Verify Repairs.


TShootVuntitled00000385

 Alternator Ground Check

Perform the following steps to check the alternator ground.

  1. Connect all connectors.

  2. Remove alternator belt or disable alternator from charging.

  3. Start and run the engine.

  4. Read logged codes.

[a] If no codes are logged, repair the alternator ground circuit. Refer to Verify Repairs.

[b] If codes are logged, replace ECL. Refer to Verify Repairs.


TShootVuntitled00000386

 Verify Repairs

Perform the following steps to verify the repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear DDR codes.

  5. Start and run the engine for one minute.

  6. Stop the engine.

  7. Check DDR for codes.

[a] If no codes are displayed, troubleshooting is complete.

[b] If code 111/3 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 111/3 is logged, and other codes are logged, refer to Sensor Check, and perform tasks.


TShootVuntitled00000387

 MAINTENANCE ALERT SYSTEM

Listed in the following table are the flash codes for Add Coolant Level Sensor (ACLS) problems.

Flash Code | PID FMI | Description | Typical Cause
13 | 111/6 | ACLS failed low | Signal wire (#906) shorted low (ground)
16 | 111/5 | ACLS failed high | Open or poor ground; open signal wire
43 | 111/1 | Coolant level low (ACLS) | Coolant level below probe
89 | 111/12 | ACLS Fault | Coolant reported low on main ECL, with ACLS okay
The first step in Troubleshooting 111/5, Flash Code 16 follows:

Check Sensor

Follow these steps to check the sensor:

  1. Unplug the ACLS.

  2. Insert a jumper between cavities A and B of the sensor connector.

  3. Start the engine.

  4. Plug in the DT. Read the codes displayed.

[a] If code 13, (111/5) displays, replace the ACLS. Go to Test Repair. See Maintenance Alert System.

[b] If code 16 (111/6) displays, go to the next procedure. Refer to Check for Open.


TShootVuntitled00000388

 Check for Open

Perform the following steps to check for open:

  1. Insert a jumper wire between cavities A and B of the ACLS module connector. See Maintenance Alert System.

  2. Measure resistance between cavities A and B of the sensor connector.

[a] If measured resistance is greater than 10 [image], the ground wire of the V37 wire is open. Repair the open and go to Test Repair.

[b] If measured resistance is less than 10 [image], refer to Check for Open Signal.


TShootVuntitled00000389

 Check for Open Signal

Perform the following steps to check for open signal:

  1. Turn the ignition OFF.

  2. Unplug the engine harness 30 - pin connector.

  3. Insert a jumper wire between cavity V37 and battery ground.

  4. Measure resistance between cavities A and B of the ACLS module connector.

[a] If the measured resistance is greater than 10 [image], the V37 wire or the battery ground wire is open between the ACLS module connector and the engine harness 30 - pin connector. Repair the open; replace the wire and go to test. Refer to Test Repair.

[b] If the measured resistance is less than 10 [image], replace the ACLS module; go to test. Refer to Test Repair.


TShootVuntitled00000390

 Test Repair

Perform the following steps to test the repair:

  1. Connect all removed connectors.

  2. Start and run engine for five minutes.

  3. Plug in DDR.

  4. Read active codes.

[a] If no codes display, repairs are complete. Return the unit to service.

[b] If code 16 displays, troubleshooting is complete. Review the above steps to find the error.

[c] If any other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000396

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 21.

Perform the following steps to check for multiple codes.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Read active codes.

[a] If active code 91/3 and no other active codes are logged, refer to Sensor Check.

[b] If any or all of the following codes are logged, 91/3, 91/4, 187/3, 100/3, refer to VEHICLE HARNESS.

[c] If any codes except 91/3 are logged, refer to Return Circuit Check.


TShootVuntitled00000397

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition OFF.

  2. Unplug the TPS connector.

  3. Turn ignition ON.

  4. Read for active codes.

[a] If active code 91/3 and any other codes are logged, refer to Check for Short.

[b] If code 91/4 is logged, refer to Return Circuit Check.


TShootVuntitled00000398

 Return Circuit Check

Perform the following steps to check the return circuit.

  1. Turn ignition OFF.

  2. Install a jumper wire between pin A (return #952) and pin B (signal #417) of the TPS harness connector.

  3. Disconnect the vehicle harness connector at the ECU.

  4. Measure resistance between sockets V60 and V13 on the vehicle harness connector. For Throttle Position Sensor schematic, See ECU Vehicle Harness Connector.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Check Throttle Position Sensor Adjustment.

[b] If the resistance measurement is greater than 5 [image], and the return line V60 is open, repair the open and refer to Verify Repairs.


TShootVuntitled00000399

 Check Throttle Position Sensor Adjustment

Perform the following steps to check for TPS adjustment.

  1. Reconnect vehicle harness connector and plug in the TPS.

  2. Hook up DDR to the DDL connector and select Throttle Sensor Display.

  3. Measure Throttle Counts at both no throttle and full throttle. Take several readings.

[a] If TPS counts are ever greater than 968 counts, refer to Throttle Position Sensor Adjustment.

[b] If TPS counts stay less than 968 counts, refer to Check Throttle Position Sensor Connectors.


TShootVuntitled00000400

 Throttle Position Sensor Adjustment

Perform the following steps to attempt TPS adjustment.

  1. Check for pedal or linkage interferences.

  2. Loosen the TPS screws and attempt to adjust for the correct throttle reading (64 - 205 counts). Do not attempt to adjust by bending the pedal mechanism.

  3. Recheck counts at idle and at full throttle.

[a] If the throttle counts are not correct, refer to Check Throttle Position Sensor Connectors.

[b] If the throttle counts are now correct, refer to Verify Repairs.


TShootVuntitled00000401

 Check Throttle Position Sensor Connectors

Perform the following steps to check the TPS connectors.

  1. Check terminals at the TPS connector (both sensor and harness side) for bent, corroded and unseated pins or sockets. See Throttle Position Sensor.

[a] If the terminals or connectors are damaged, repair both and refer to Verify Repairs.

[b] If the terminals or connectors are not damaged, replace the TPS; refer to Verify Repairs.


TShootVuntitled00000402

 Check for Short

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU. Unplug the TPS connector.

  3. Read resistance between sockets V13 and V11 on the vehicle harness connector. See ECU Vehicle Harness Connector.

[a] If the resistance is greater than 100 [image] or open, refer to Check for Short to Battery.

[b] If the resistance is less than or equal to 100 [image] [image] the signal line (V13) is shorted to the vehicle +5 volt line (V11). Repair the short and refer to Verify Repairs.


TShootVuntitled00000403

 Check for Short to Battery

Perform the following steps to check for a short to the battery.

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure resistance between socket V13 on the vehicle harness connector and the power sockets V61 and V65. See ECU Vehicle Harness Connector.

[a] If the resistance is greater than 100 [image] [image] refer to Check ECU Connectors.

[b] If the resistance is less than or equal to 100 [image] [image] a short exists between sockets where less than 100 [image] resistance was read. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000404

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU harness connector (both ECU and harness side) for bent, corroded and unseated pins or sockets. See ECU Vehicle Harness Connector.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, refer to Multiple Code Check, to review this section. If review leads back here, install a test ECU or contact Detroit Diesel Technical Service.


TShootVuntitled00000405

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear DDR codes.

  5. Start and run the engine for one minute. Check idle position and full throttle.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are displayed, troubleshooting is complete.

[b] If code 91/3 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 91/3 is logged, and other codes are logged, all system diagnostics are complete. If a problem still exists, review this section from the first step to troubleshoot the error, refer to Multiple Code Check.


TShootVuntitled00000407

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 22.

Perform the following steps to check for multiple codes.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Read active codes.

[a] If active code 91/4 and no other active codes are logged, refer to Check for Device.

[b] If code 91/4 and any or all of the following codes are logged, 91/3, 187/4, or 100/4, refer to section 88.

[c] If codes other than the above are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000408

 Check for Device

Perform the following steps to check for device.

  1. If there is a throttle (LSG) wired to use the V13 (LSG) circuit, refer to Sensor Check.

  2. If there is no throttle (LSG) wired to use the V13 (LSG) circuit, contact Detroit Diesel Technical Service, for possible change to the calibration.

[a] If required, reprogram the ECU after the mainframe is changed and refer to Verify Repairs.


TShootVuntitled00000409

 Sensor Check

Perform the following steps to check the sensor:

  1. Turn ignition OFF.

  2. Disconnect the TPS connector.

  3. Install a jumper wire between sockets A-V13 and C-V11. See Throttle Position Sensor.

  4. Turn ignition ON.

  5. Read active codes.

[a] If code 91/4 and any other codes are logged, refer to Check for +5 Volts.

[b] If code 91/3 and any other codes are logged, refer to Check Throttle Position Sensor Adjustment.


TShootVuntitled00000410

 Check Throttle Position Sensor Adjustment

Perform the following steps to check the TPS adjustment:

  1. Remove jumper and reconnect TPS.

  2. Hook DDR to the DDL connector and select TPS - Counts.

  3. Read Throttle Counts at both no throttle and full throttle positions. Take several readings.

[a] If at any time counts go lower than 49 counts, refer to Attempt Throttle Position Sensor Adjustment.

[b] If counts never go lower than 49 counts, refer to Check Throttle Position Sensor Connectors.


TShootVuntitled00000411

 Attempt Throttle Position Sensor Adjustment

Perform the following steps to attempt a TPS adjustment:

  1. Check for pedal or linkage interferences.

  2. Loosen the TPS screws and attempt to adjust for the correct throttle reading (normal range - 64-205 counts). Do not attempt to adjust by bending the pedal mechanism.

  3. Recheck counts at idle and at full throttle.

[a] If the throttle count has been corrected, refer to Verify Repairs.

[b] If the problem could not be corrected, refer to Check Throttle Position Sensor Connectors.


TShootVuntitled00000412

 Check Throttle Position Sensor Connectors

Perform the following steps to check the TPS connectors:

  1. Check terminals at the TPS connector (both sensor and harness side) for bent, corroded, and unseated pins or sockets.

[a] If the terminals or the connectors are damaged, repair them. Refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the TPS and refer to Verify Repairs.


TShootVuntitled00000413

 Check for +5 Volts

Perform the following steps to check for +5 volts:

  1. Remove jumper wire.

  2. Turn ignition ON.

  3. Measure voltage on TPS harness connector, socket C-V11 (red lead) to socket B-V60.

[a] If measured voltage is greater than 6 volts, refer to Check for Short to Battery +.

[b] If measured voltage is less than 4 volts, refer to Check for Short.

[c] If measured voltage is between 4 and 6 volts, refer to Check for Short.


TShootVuntitled00000414

 Check for Short

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure resistance between sockets B-V60 and A-V13 at the TPS harness connector. See Throttle Position Sensor.

  4. Measure resistance between socket A-V13 and a good ground (battery ground and chassis ground).

[a] If resistance measurement is less than or equal to 100 [image] [image] the signal line V13 is shorted to the return line V60 or battery ground. Repair short. Refer to Verify Repairs.

[b] If resistance measurement on both readings is greater than 100 [image] or open, refer to Check for Signal Open.


TShootVuntitled00000415

 Check for Signal Open

Perform the following steps to check for signal open:

  1. Install a jumper wire between sockets A-V13 and B-V60 of the TPS harness connector.

  2. Measure resistance between sockets V13 and V60 on the vehicle connector.

[a] If the resistance is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If the resistance is greater than 5 [image] [image] or open, the signal line V13 or return line V60 are open, repair the open. Refer to Verify Repairs.


TShootVuntitled00000416

 Check ECU Connectors

Perform the following steps to check the ECU connectors:

  1. Check terminals at the ECU harness connector (both ECU and harness side) for bent, corroded, and unseated pins or sockets. See ECU Vehicle Harness Connector.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, call Detroit Diesel Technical Service for assistance.


TShootVuntitled00000417

 Check for Short

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure resistance between sockets B-V60 and C-V11 on the TPS harness connector. See ECU Vehicle Harness Connector.

[a] If resistance between sockets A and C is greater than 1,000 [image] [image] or open, refer to Check for Open +5 Volt Line.

[b] If resistance between sockets A and C is less than or equal to 1,000 [image], the 5V wire (V11) is shorted to the return (V60). Repair the short and refer to Verify Repairs.


TShootVuntitled00000418

 Check for Open +5 Volt Line

Perform the following steps to check for an open +5 volt line:

  1. Install a jumper wire between sockets B-V60 and C-V11 on the TPS harness connector.

  2. Measure resistance between sockets V11 and V60 on the vehicle harness connector. See Throttle Position Sensor.

[a] If resistance between sockets V11 and V60 is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If resistance between sockets V11 and V60 is greater than or equal to 5 [image] [image] or open, the vehicle +5 volt line (V11) is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000419

 Check for Short to Battery +

Perform the following steps to check for a short to the battery +:

  1. Turn ignition OFF.

  2. Remove both fuses to ECU.

  3. Disconnect the vehicle connector at the ECU.

  4. Measure resistance between socket V13 on the vehicle harness connector and socket V61 and V65. See ECU Vehicle Harness Connector.

[a] If measured resistance is greater than 100 [image] or open, refer to Check for Outside DDEC Battery +.

[b] If measured resistance is less than or equal to 100 [image] [image] a short exists between sockets where resistance was measured. Repair short and reinsert fuses; refer to Verify Repairs.


TShootVuntitled00000420

 Check for Outside DDEC Battery +

Perform the following steps to check for outside DDEC battery +:

  1. Turn ignition OFF.

  2. Remove ECU vehicle harness connector.

  3. Turn ignition ON.

  4. Measure voltage V11 (red lead) to battery ground.

  5. Measure voltage V60 (red lead) to battery ground.

[a] If measured voltage is less than 0.2 volts, refer to Check ECU Connectors.

[b] If measured voltage is greater than 0.2 volts, outside power is spliced/shorted into either line V60 or line V11. Remove the splice/short. Refer to Verify Repairs.


TShootVuntitled00000421

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes with DDR.

  5. Start and run the engine for one minute at all throttle positions.

  6. Stop engine.

  7. Read active codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 91/4 and any other codes are logged, all system diagnostics are complete. Review this section from the first step to find the error - refer to Multiple Code Check.

[c] If code 91/4 is not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000424

 Check for Short to +5 Volt Line

Perform the following steps to check for a short to the +5 volt line.

  1. Turn ignition OFF.

  2. Remove jumper wire.

  3. Disconnect the engine harness connector at the ECU.

  4. Measure resistance between sockets E9 and E14 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the measured resistance is greater than 100 [image] or open, refer to Check Fuel Temperature Sensor Connectors.

[b] If the measured resistance is less than or equal to 100 [image] [image] the signal line E9 is shorted to the engine +5 volt line. Repair the short; refer to Verify Repairs.


TShootVuntitled00000425

 Check Fuel Temperature Sensor Connectors

Perform the following steps to check the FTS connectors:

  1. Check terminals at the FTS harness connector (both sensor and harness side) for bent, corroded, and unseated pins or sockets. See Fuel Temperature Sensor.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the FTS. Refer to Verify Repairs.


TShootVuntitled00000426

 Open Line Check

Perform the following steps to check for an open line.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU. The jumper wire is still in place at the FTS connector.

  3. Measure resistance between sockets E9 and E14 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the measured resistance is greater than 5 [image] [image] or open, the signal line E9 or return line E14 is open. Repair the open; refer to Verify Repairs.

[b] If the measured resistance is less than or equal to 5 [image], refer to Check ECU Connectors.


TShootVuntitled00000427

 Check ECU Connectors

Perform the following steps to check the ECU connectors:

  1. Check terminals at the ECU harness connector (both ECU and harness side) for bent, corroded, and unseated pins or sockets. See ECU Engine Harness Connector.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, install a test ECU . Refer to Verify Repairs.


TShootVuntitled00000428

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes with DDR.

  5. Start and run the engine for eight minutes.

  6. Stop engine.

  7. Read codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 174/3 and any other codes are logged, all system diagnostics are complete. Review this section from the first step to find the error - refer to Sensor Check.

[c] If code 173/4 is not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000430

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 24.

Perform the following steps to check for multiple codes.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Read active codes.

[a] If active code 174/4 and no other active codes are logged, refer to Sensor Check.

[b] If any or all of the following codes are logged, 110/3, 175/3, 174/3, or 102/3, refer to VEHICLE HARNESS.

[c] If codes other than the above are logged, refer to Sensor Check.


TShootVuntitled00000431

 Sensor Check

Perform the following steps to check the sensor:

  1. Turn ignition OFF.

  2. Disconnect the FTS connector.

  3. Start and run engine for eight minutes.

  4. Read active codes with engine still running.

[a] If code 174/4 and any other codes are logged, refer to Check for Short.

[b] If code 174/3 and any other codes except 174/4 are logged, refer to Check Fuel Temperature Sensor Connectors.


TShootVuntitled00000432

 Check Fuel Temperature Sensor Connectors

Perform the following steps to check the FTS connectors:

  1. Check terminals at the FTS connector (both sensor and harness side) for bent, corroded, and unseated pins or sockets. See Fuel Temperature Sensor.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the FTS. Refer to Verify Repairs.


TShootVuntitled00000433

 Check for Short

Perform the following steps to check for a short:

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between sockets E9 and E14 on the engine harness connector. See Engine Harness Connector.

  4. Measure resistance between socket E9 and a good ground (battery ground and chassis ground).

[a] If resistance between sockets E9 and E14, or E9 and battery ground, is less than or equal to 10,000 [image], the signal line (E9) is shorted to the return line (E14) or battery ground. Repair short. Refer to Verify Repairs.

[b] If resistance between sockets E9 and E14 is greater than 10,000 [image] [image] or open, and resistance between socket 2 and a good ground is greater than 10,000 [image] [image] or open, refer to Check ECU Connectors.


TShootVuntitled00000434

 Check ECU Connectors

Perform the following steps to check the ECU connectors:

  1. Check terminals at the ECU harness connector (both ECU and harness side) for bent, corroded, and unseated pins or sockets. See ECU Engine Harness Connector.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, contact Detroit Diesel Technical Service. Refer to Verify Repairs.


TShootVuntitled00000435

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes with DDR.

  5. Start and run the engine for eight minutes.

  6. Stop engine.

  7. Read active codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 174/4 and any other codes are logged, all system diagnostics are complete. Review this section from the first step to find the error - refer to Multiple Code Check.

[c] If code 174/4 is not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000438

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 25.

Perform the following steps to check for multiple codes.

  1. Turn ignition ON. Start and run the engine.

  2. Plug in DDR.

  3. Read active codes.

[a] If codes s 25/11 or s 61/11 are logged, refer to Check Calibration Configuration.

[b] If codes s 25/11 and s 61/11 are not logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000439

 Check Calibration Configuration

Perform the following steps to check the calibration configuration:

  1. Select ECU input/output configuration.

  2. Determine cavity and wire number that is causing code to be logged.

  3. Select switch/light status.

  4. Determine status of that wire/cavity.

[a] If the switch reads OFF, refer to Confirm Switch Status.

[b] If the switch reads ON, the OEM supplied switch/relay is grounding the wire or a short to ground exists. Determine OEM supplied device or repair the short. Refer to Verify Repairs.

[c] If no OEM device is used, remove the wire from the connector and plug, or use programming station to disable the function.


TShootVuntitled00000440

 Confirm Switch Status

Perform the following steps to confirm switch status:

  1. Start and run the engine for one minute.

  2. Again, read switch status.

[a] If the switch reads OFF, the condition no longer exists. Contact the OEM to learn which item is wired to this cavity. Refer to Verify Repairs.

[b] If the switch reads ON, the OEM supplied device is grounding this wire. Contact the OEM for repair procedure. Refer to Verify Repairs.


TShootVuntitled00000441

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition ON.

  2. Clear codes with DDR.

  3. Note status of AWL/RSL.

  4. If AWL/RSL not on, start and run the engine for one minute.

  5. Read active and inactive codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If codes 25 or 61/11 and any other codes are logged, all system diagnostics are complete. Review this section from the first step to find the error - refer to Multiple Code Check.

[c] If codes 25 or 61/11 are not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000443

 Sensor Check

Use the following procedure to troubleshoot Flash Code 27.

Perform the following steps to check the sensor.

  1. Turn vehicle ignition OFF.

  2. Disconnect ATS connector.

  3. Install a jumper wire between sockets 1 and 2 of the ATS harness connector. See Air Temperature Sensor.

  4. Turn ignition ON.

  5. Start and run engine for one minute; (ensure oil temp is greater than 140°F).

  6. Read active codes.

[a] If code 172/4 or any other codes except 172/3 are logged, refer to Check for Short to +5 Volt Line.

[b] If any codes except code 172/4 are logged, refer to Open Line Check.


TShootVuntitled00000444

 Check for Short to +5 Volt Line

Perform the following steps to check for a short to the +5 volt line.

  1. Turn ignition/engine OFF.

  2. Remove jumper wire.

  3. Disconnect the engine harness connector at the ECU.

  4. Measure resistance between sockets E2 and E14 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 10 [image], the signal line E2 is shorted to the engine +5 volt line (E14). Repair the short and refer to Verify Repairs.

[b] If the resistance measurement between sockets E2 and E14 is greater than 10 [image] [image] or open, refer to Check Air Temperature Sensor Connectors.


TShootVuntitled00000445

 Check Air Temperature Sensor Connectors

Perform the following steps to check the ATS connectors.

  1. Check terminals at the ATS connector (both sensor and harness side) for damage; bent, corroded and unseated pins or sockets. See Inlet Air Temperature Sensor.

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the ATS. Refer to Verify Repairs.


TShootVuntitled00000446

 Open Line Check

Perform the following steps to check for an open line.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connector at the ECU. (Jumper still in place.)

  3. Measure resistance between sockets E2 and E14 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 5 [image], refer to Check ECU Connectors.

[b] If the resistance measurement between sockets E2 and E14 is greater than 5 [image] [image] or open, the signal line E2 or return line E14 is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000447

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connector (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. See ECU Engine Harness Connector.

[a] If terminals or connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, contact Detroit Diesel Technical Service. Refer to Verify Repairs.


TShootVuntitled00000448

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn vehicle ignition ON.

  4. Clear codes.

  5. Start and run the engine for eight minutes.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 172/3 and any other codes are logged, all system diagnostics are complete. Review this section to find the error - refer to Sensor Check.

[c] If any codes except code 172/3 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000450

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 28.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in DDR.

  3. Read active codes.

[a] If code 172/4 was logged and there are no other codes logged, refer to Sensor Check.

[b] If code 172/4 and any of the following codes 110/3, 175/3, 174/3, 72/3 or 102/3 were logged, refer to ENGINE SENSOR HARNESS.

[c] If code 172/4 and any code except the following were logged 110/3, 175/3, 174/3, 72/3 or 102/3, refer to Sensor Check.


TShootVuntitled00000451

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn vehicle ignition OFF.

  2. Disconnect the ATS connector. See Engine Harness to Air Temperature Sensor Connector.

  3. Start engine and run until Check Engine light comes on, or for eight minutes.

  4. With engine still running, read active codes.

[a] If code 172/4 and any other codes were logged, refer to Check for Short.

[b] If 172/3 and any other codes except 172/4 were logged, refer to Check Air Temperature Sensor Connectors.


TShootVuntitled00000452

 Check Air Temperature Sensor Connectors

Perform the following steps to check the ATS connector.

  1. Check terminals at the ATS connector (both sensor and harness side) for damage; bent, corroded and unseated pins or sockets.

[a] If terminals and connectors are not damaged, replace ATS. Refer to Verify Repairs.

[b] If terminals and connectors are damaged, repair/replace wires and refer to Verify Repairs.


TShootVuntitled00000453

 Check for Short

Perform the following steps to check for a short.

  1. Turn the ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between sockets E2 and E14 on the engine harness connector. See ECU Engine Harness Connector.

  4. Measure resistance between socket E2 and a good ground.

[a] If the resistance measurement between sockets E2 and E14 and between socket E2 and a good ground is greater than 10 [image] [image] or open, refer to Check ECU Connectors.

[b] If the resistance measurement between sockets E2 and E14, or E2 and battery negative, is less than or equal to 10 [image], the signal line E2 is shorted to the return line E14 or battery ground. Repair short. Refer to Verify Repairs.


TShootVuntitled00000454

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU harness connector (both ECU and harness side) for damage; bent, corroded and unseated pins or sockets, especially E2 and E14 of the ECU connector.

[a] If terminals or connectors are not damaged, contact Detroit Diesel Technical Services and refer to Verify Repairs.

[b] If terminals and connectors are damaged, repair them. Refer to Verify Repairs


TShootVuntitled00000455

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for eight minutes.

  6. Stop engine.

  7. Read inactive codes.

[a] If no codes are displayed, troubleshooting is complete.

[b] If code 172/4 is logged with any other codes, all system diagnostics are complete. Review this section from the first step to find the error; refer to Multiple Code Check.

[c] If code 172/4 is not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000457

 Check for Codes

Use the following procedure to troubleshoot Flash Code 29.

Perform the following steps to check for codes:

  1. Turn ignition ON.

  2. Start and run engine for six minutes.

  3. Check DDR for codes.

[a] If any code other than p 351/4 or p 404/4 are logged, troubleshoot that code first.

[b] If code p 351/4 is logged, refer to Check Sensor.

[c] If code p 404/4 is logged, refer to Check for Short.


TShootVuntitled00000458

 Check Sensor

Perform the following steps to check the TCI connector.

  1. Unplug the connector at the TCI.

  2. Measure resistance between cavity 1 and cavity 2.

[a] If measured resistance is greater than 5 [image], refer to Check for Open. See ECU Engine Harness Connector.

[b] If measured resistance is less than 5 [image], V27 is shorted to V59. Repair the short and test.


TShootVuntitled00000459

 Check for Open

Perform the following steps to check for short:

  1. Unplug the vehicle harness.

  2. Measure resistance between cavity V27 and V11. See ECU Engine Harness Connector.

[a] If resistance is less than 1.0 K [image], wire V27 is shorted to V11. Repair and test.

[b] If resistance is greater than 1.1 K [image], refer to Check Connector Corrosion.


TShootVuntitled00000460

 Check Connector Corrosion

Perform the following steps to check for corrosion at the 4 - pin, 10 - pin interface and 30 - pin connectors.

  1. If corroded, clean corrosion from the terminals or replace the terminals. Test.

  2. If terminals are clean, without corrosion, replace the TCI sensor.


TShootVuntitled00000461

 Check for Short

Perform the following steps to check the turbo compressor outlet (TCO) connector.

  1. Unplug TCO connector.

  2. Measure resistance between cavity 1 and cavity 2 of connector.

[a] If measured resistance is greater than 5 [image], refer to Check for Failed Resistor.

[b] If measured resistance is less than 5 [image], E22 is shorted to E14. Repair the short. Test.


TShootVuntitled00000462

 Check for Failed Resistor

Perform the following steps to check for failed resistor:

  1. Unplug the engine sensor harness.

  2. Measure resistance between cavity E22 and E14. See Turbo Compressor Outlet Temperature Circuit.

[a] If resistance is less than 1.0 K [image], wire E14 is shorted to E22. Repair and test.

[b] If resistance is greater than 1.1 K [image], refer to Check for Corrosion.


TShootVuntitled00000463

 Check for Corrosion

Perform the following steps to check for corrosion at the 4 - pin, 10 - pin interface and 30 - pin connectors.

  1. If corroded, clean corrosion from the terminals or replace the terminals. Test.

  2. If terminals are clean, without corrosion, replace the TCO sensor. Test.


TShootVuntitled00000466

 Check Configuration

Use the following procedure to troubleshoot Flash Code 31.

Perform the following steps to check configuration.

  1. If the unit has engine brakes, refer to Determine Failure Mode.

  2. If the unit does not have engine brakes, the ECU is configured for engine brakes and shouldn't be. Contact DDC with the engine serial number to have the data changed. Reprogram the ECU after the change. Refer to Verify Repairs.


TShootVuntitled00000467

 Determine Failure Mode

Perform the following steps to determine failure mode.

  1. Turn vehicle ignition ON.

  2. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL) connector.

  3. Read SAE code (051 or 052).

[a] If the reading is FMI=3, there is an open - refer to Determine Engine Type.

[b] If the reading is FMI=4, there is a short to ground - refer to Check for Short.


TShootVuntitled00000468

 Determine Engine Type

Perform the following steps to determine engine type.

  1. Is this a Series 55 engine?

[a] If yes, reprogram the ECU. Then, refer to Verify Repairs.

[b] If no, refer to Check for Open.


TShootVuntitled00000469

 Check for Open

Perform the following steps to check for open.

  1. Turn vehicle ignition OFF.

  2. Disconnect 10-pin connector pigtail from engine brake injector harness.

  3. Disconnect 30-pin engine harness connector.

  4. Install a jumper wire between pins 9 and 10, ECU side of pigtail.

  5. Measure resistance between E48 and E49 of the engine harness connector.

[a] If measured resistance is less than 50 [image], refer to Check for Open (Inside Valve Cover).

[b] If measured resistance is greater than 50 [image], one or both wires are open. Repair open. Refer to Verify Repairs.


TShootVuntitled00000470

 Check for Open (Inside Valve Cover)

Perform the following steps to check for open in the inside valve cover.

  1. Reconnect the engine harness connector. See Engine Brake Harness Schematic.

  2. Measure resistance between pin 9 and the engine block and between pin 10 and engine block and the brake harness connector (brake side).

[a] If measured resistance is greater than 50 [image] or open, an open exists in one of the wires where the check was made. Repair open or replace the injector harness. Refer to Verify Repairs.

[b] If measured resistance is less than 50 [image], refer to Check for Cylinder Block Ground.


TShootVuntitled00000471

 Check for Cylinder Block Ground

Perform the following steps to check for cylinder block ground.

  1. If the cylinder block is connected to the battery ground, refer to Check Brake Solenoids.

  2. If the cylinder block is not connected to the battery ground, install a ground strap from the cylinder block to the battery negative (-). Refer to Verify Repairs.


TShootVuntitled00000472

 Check for Short

Perform the following steps to check for a short.

  1. Turn vehicle ignition OFF.

  2. Unplug the engine harness connector.

  3. Measure resistance between E48 and a battery ground, and E48 and the engine block. Repeat this check between E49 and battery ground, and E49 and the engine block.

[a] If resistance for all measurements is greater than 5 [image] [image] or open, refer to Check for Short Between Wires.

[b] If any measured resistance is less than 5 [image] [image] the wire where the measurement was read is shorted to ground or to the engine. Repair short or replace the wire. Refer to Verify Repairs.


TShootVuntitled00000473

 Check for Short Between Wires

Perform the following steps to check for a short between wires.

  1. Measure resistance between E48 and E49.

[a] If measured resistance is less than 10 [image], the E48 and E49 wires are shorted to each other. Repair short. Refer to Verify Repairs.

[b] If measured resistance is greater than 10 [image], refer to Check Brake Solenoids.


TShootVuntitled00000474

 Check Brake Solenoids

Perform the following steps to check for brake solenoids.

  1. Check brake solenoids. Refer to OEM guidelines.

[a] If the solenoids are in good condition, contact Detroit Diesel Technical Service. Refer to Verify Repairs.

[b] If the solenoids are damaged, repair or replace them. Refer to Verify Repairs.


TShootVuntitled00000475

 Verify Repairs

Perform the following steps to verify repairs.

  1. Connect any connectors removed for troubleshooting.

  2. Start, run the engine, and operate the engine brake.

[a] If no lights come on, and no codes are logged, the repairs are complete. No further troubleshooting is required.

[b] If Amber Warning Lamp displays with codes s 051/3, 51/4, 052/3, or 051/4, review this section to find the error - refer to Check Configuration.


TShootVuntitled00000477

 Determine Failure Mode Identifier (3 or 4)

Use the following procedure to troubleshoot Flash Code 32.

Perform the following steps to determine FMI.

  1. Turn ignition ON.

  2. Plug in diagnostic data reader (DDR) into the diagnostic data link (DDL).

  3. Read codes.

[a] If code 238/4 or 239/4 is logged, reprogram the ECU. Refer to Verify Repairs.

[b] If code 238/3 or 239/3 is logged, refer to Check for Short to Battery.


TShootVuntitled00000478

 Check for Short to Battery

Perform the following steps to determine failure.

  1. Turn vehicle ignition OFF.

  2. Disconnect vehicle harness connector.

  3. Turn ignition ON.

  4. Remove AWL bulb and RSL bulb.

  5. Measure voltage between V2 and a good ground. See ECU Vehicle Harness Connector.

  6. Measure voltage between V7 and a good ground.

[a] If either measurement was greater than 0.5 volts, the wire that had the reading is shorted to some voltage source. Replace the wire(s). Refer to Verify Repairs.

[b] If no measurement was greater than 0.5 volts, contact Detroit Diesel Technical Service.


TShootVuntitled00000479

 Verify Repairs

Perform the following steps to verify repairs.

  1. Connect all connectors.

  2. Start and run the engine.

  3. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL). Read codes.

[a] If active code 32 is logged, review this section to find the error - refer to FLASH CODE 32 - AWL / RSL FAULT.

[b] If code 32 is not logged, troubleshooting is complete.


TShootVuntitled00000481

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 33.

Perform the following steps to check for multiple codes.

  1. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  2. Turn vehicle ignition switch ON.

  3. Read active codes.

[a] If code 102/3 and no other codes were logged, refer to Sensor Check.

[b] If any of the following codes are also present: 72/3 or 4, 73/3 or 4, 94/3 or 4, 100/3 or 4, 101/3 or 4, 110/3 or 4, 174/3 or 4, 175/3 or 4, refer to ENGINE SENSOR HARNESS.


TShootVuntitled00000482

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn vehicle ignition OFF.

  2. Disconnect the TBS connector. See Turbo Boost Sensor.

  3. Start and run the engine at idle.

  4. Read active codes logged.

[a] If active code 102/3 and any other codes are logged, refer to Check for Short to +5 Volt Line.

[b] If active code 102/4 and any other codes except 102/3 are logged, refer to Return Circuit Check.


TShootVuntitled00000483

 Return Circuit Check

Perform the following steps to check the return circuit.

  1. Turn ignition switch OFF.

  2. Install a jumper wire between pin 1 and pin 2 of the TBS harness connector. See Turbo Boost Sensor.

  3. Disconnect the engine harness connector at the ECU. See ECU Engine Harness Connector.

  4. Measure resistance between sockets E15 and E39 on the engine harness connector.

[a] If resistance measurement is less than or equal to 5 [image] [image] refer to Check Turbo Boost Sensor Connectors.

[b] If resistance measurement is greater than 5 [image] [image] the return line E15 is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000484

 Check Turbo Boost Sensor Connectors

Perform the following steps to check the TBS connectors.

  1. Check terminals at the TBS connector (both sensor and harness side) for damage: bent, corroded, and unseated pins or sockets. See Turbo Boost Sensor.

[a] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the TBS. Refer to Verify Repairs.


TShootVuntitled00000485

 Check for Short to +5 Volt Line

Perform the following steps to check for a short to the +5 volt line:

  1. Turn vehicle ignition OFF.

  2. Disconnect engine harness connector from the ECU.

  3. Measure resistance between sockets E39 and E12 on the engine harness connector. See ECU Engine Harness Connector.

[a] If measured resistance is less than or equal to 10,000 [image], the signal line E39 is shorted to the engine +5 volt line E12. Repair short. Refer to Verify Repairs.

[b] If measured resistance is greater than 10,000 [image], or open, refer to Check for Short to Battery.


TShootVuntitled00000486

 Check for Short to Battery

Perform the following steps to check for a short to the battery (+):

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness and the engine harness at the ECU. See ECU Engine Harness Connector.

  3. Measure resistance between sockets E39 of the engine harness connector and V15 on the vehicle harness connector.

  4. Measure resistance between socket E39 on the engine harness connector vehicle harness connector sockets V61 and V65.

[a] If the resistance measurement is less than or equal to 100 [image] [image] a short exists between sockets where the measurement was taken. Repair short and reinsert fuses, or reset breakers. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] [image] or open, refer to Check ECU Connectors.


TShootVuntitled00000487

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connector (both the ECU and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If terminals and connectors are damaged, repair both. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, reprogram the ECU. Refer to Verify Repairs.


TShootVuntitled00000488

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 102/3 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 102/3 is logged, and other codes are logged, refer to Multiple Code Check.


TShootVuntitled00000490

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 34.

Perform the following steps to check for multiple codes.

  1. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL) connector.

  2. Turn vehicle ignition switch ON.

  3. Read active codes.

[a] If code 102/4 was logged and there are no other logged codes, refer to Sensor Check.

[b] If code 102/4 and any of the following codes 72/3 or 4, 73/3 or 4, 94/3 or 4, 100/3 or 4, 101/3 or 4, 110/3 or 4, 174/3 or 4, 175/3 or 4, were logged, refer to ENGINE SENSOR HARNESS.

[c] If code 102/4 was logged and none of the following codes 72/3 or 4, 73/3 or 4, 94/3 or 4, 100/3 or 4, 101/3 or 4, 110/3 or 4, 174/3 or 4, 175/3 or 4, were logged, refer to Sensor Check.


TShootVuntitled00000491

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn vehicle ignition OFF.

  2. Disconnect TBS connector.

  3. Install a jumper wire between sockets 2 and 3 of the TBS harness connector. See Turbo Boost Sensor Schematic.

  4. Turn ignition ON.

  5. Start engine and run until either the Amber Warning Lamp is on, or until the engine has been running at least one minute at greater than 1000 r/min.

  6. Read logged codes.

[a] If active code 102/4 and any other codes are logged, refer to Check for +5 Volt.

[b] If active code 102/3 and any other codes except 102/4 are logged, refer to Check Turbo Boost Sensor Connectors.


TShootVuntitled00000492

 Check Turbo Boost Sensor Connectors

Perform the following steps to check the TBS connector.

  1. Check terminals at the TBS connectors (both the TBS and harness side) for damage: bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the TBS. Refer to Verify Repairs.


TShootVuntitled00000493

 Check for +5 Volt

Perform the following steps to check for +5 volt.

  1. Remove jumper.

  2. Turn ignition ON.

  3. Measure voltage on TBS harness connector, pin 1 (red lead) to pin 3 (black lead).

[a] If the voltage measurement is greater than 6 volts, refer to Check for Short to Battery +.

[b] If the voltage measurement is between 4 and 6 volts, refer to Check for Signal Open.

[c] If the voltage measurement is less than 4 volts, refer to Check for Open +5 Volt Line.


TShootVuntitled00000494

 Check for Signal Open

Perform the following steps to check for signal open.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Install a jumper wire between pins 1 and 2 of the TBS harness connector. See Turbo Boost Sensor Schematic.

  4. Measure resistance between sockets E39 and E15 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short.

[b] If the resistance measurement is greater than 5 [image] [image] or open, and the signal line (E39) is open, repair the open. Refer to Verify Repairs.


TShootVuntitled00000495

 Check for Short

Perform the following steps to check for short.

  1. Remove jumper.

  2. Measure resistance between pins 1 and 2 on the TBS harness connector.

[a] If measured resistance between pins 1 and 2 is greater than 100 [image] [image] or open, go to step 3.

[b] If measured resistance between pins 1 and 2 is less than 100 [image] [image] the signal line (E39) is shorted to the return line (E15). Repair the short. Refer to Verify Repairs.

  3. Also measure resistance between socket 2 and a good ground.

[a] If measured resistance between socket 2 and a good ground is greater than 100 [image] [image] or open, refer to Check ECU Connectors.

[b] If measured resistance between socket 2 and a good ground is less than 100 [image] [image] the signal line (E39) is shorted to the battery ground. Repair the short and refer to Verify Repairs.


TShootVuntitled00000496

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU harness connector (both ECU and harness side) for damage: bent, corroded, and unseated pins or sockets. See Engine Harness Connector to Turbo Boost Sensor.

[a] If terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If terminals and connectors are not damaged, install a test ECU. Refer to Verify Repairs.


TShootVuntitled00000497

 Check for Open +5 Volt Line

Perform the following steps to check for open +5 volt line.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connectors at the ECU.

  3. Install a jumper wire between pins 1 and 3 of the TBS harness connector. See ECU Engine Harness Connector.

  4. Read resistance between sockets E15 and E12 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the ECU +5 volt line (E12) is open. Repair open. Refer to Verify Repairs.


TShootVuntitled00000498

 Check for Short

Perform the following steps to check for short.

  1. Remove jumper.

  2. Measure resistance between pins 1 and 3 on the TBS harness connector. See Turbo Boost Sensor Schematic.

[a] If measured resistance between pins 1 and 3 is greater than 100 [image] [image] or open, go to step 3.

[b] If measured resistance between pins 1 and 3 is less than 100 [image] [image] the 5 volt supply (E12) is shorted to the return line (E15). Repair the short. Refer to Verify Repairs.

  3. Also measure resistance between socket 3 and a good ground.

[a] If measured resistance between socket 3 and a good ground is greater than 100 [image] [image] or open, refer to Check ECU Connectors.

[b] If measured resistance between socket 3 and a good ground is less than 100 [image] [image] the 5 volt supply (E12) is shorted to the battery ground. Repair the short and refer to Verify Repairs.


TShootVuntitled00000499

 Check for Short to Battery +

Perform the following steps to check for short to battery +.

  1. Turn vehicle ignition OFF.

  2. Remove both fuses to the ECU.

  3. Disconnect the engine harness and vehicle harness at the ECU.

  4. Measure resistance between socket E12 on the engine harness connector and socket V15 of the vehicle harness connector, and between E12 and V61 and V65. See ECU Vehicle Harness Connector.

[a] If measured resistance is less than or equal to 100 [image] [image] a short exists between sockets where less than 100 [image] was measured. Repair short and reinsert fuses. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] [image] or open, refer to Check ECU Connectors.


TShootVuntitled00000500

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, no further troubleshooting is required.

[b] If code 102/4 and any other codes are logged, all system diagnostics are complete. Please review this section from the first step to find the error - refer to Multiple Code Check.

[c] If code 102/4 is not logged and any other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000502

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 35.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  3. Read active codes.

[a] If code 100/3 and no other codes were logged, refer to Sensor Check.

[b] If code 100/3 and any of the following codes were logged: 73/3 or 4, 94/3 or 4, 100/4, 101/3 or 4, 102/3 or 4, 110/3 or 4, 174/3 or 4, 175/3 or 4, refer to ENGINE SENSOR HARNESS.


TShootVuntitled00000503

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition switch OFF.

  2. Disconnect OPS connector.

  3. Turn ignition ON.

  4. Start and run the engine.

  5. Select engine temperature (COOLANT TEMP or OIL TEMP) on the DDR.

  6. Warm up engine until engine temperature reading is greater than 60°F (140°F).

  7. After warm-up, let engine run at idle.

  8. Read active codes.

[a] If active code 100/3 and any other codes were logged, refer to Check for Signal Short to 5 Volt.

[b] If code 100/4 and any other codes except 100/3 were logged, refer to Return Circuit Check.


TShootVuntitled00000504

 Return Circuit Check

Perform the following steps to check the return circuit.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Install a jumper wire between pin 1 and pin 2 of the OPS harness connector. See Engine Harness Connector to Oil Pressure Sensor.

  4. Measure resistance between sockets E15 and E31 on the engine harness connector.

[a] If resistance measurement is less than or equal to 5 [image] [image] refer to Check Oil Pressure Sensor Connectors.

[b] If resistance measurement is greater than 5 [image] [image] the return line (E15) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000505

 Check Oil Pressure Sensor Connectors

Perform the following steps to check the OPS connectors.

  1. Check terminals at the OPS connectors (both the sensor and harness side) for damage: bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the OPS. Refer to Verify Repairs.


TShootVuntitled00000506

 Check for Signal Short to 5 Volt

Perform the following steps to check for signal open.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between sockets E31 and E12 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 100 [image] [image] the signal line (E31) is shorted to the engine +5 volt line (E12). Repair the short and refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] [image] or open, refer to Check for Short to Battery (+).


TShootVuntitled00000507

 Check for Short to Battery (+)

Perform the following steps to check for a short to battery (+).

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness connector at the ECU. See ECU Vehicle Harness Connector.

  3. Measure resistance between socket E31 on the engine harness connector and socket V15 of the vehicle harness connector, and between E31 and V61 and V65.

[a] If resistance measurement is greater than 100 [image] [image] or open, refer to Check ECU Connector.

[b] If resistance measurement is less than or equal to 100 [image] [image] a short exists between sockets where less than 100 [image] resistance was read. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000508

 Check ECU Connector

Perform the following steps to check the ECU connector:

  1. Inspect the terminals at the ECU connector (ECU and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If the terminals and connector are damaged, repair both and refer to Verify Repairs.

[b] If the terminals and connector are not damaged, refer to Check Oil Pressure Sensor Connectors.


TShootVuntitled00000509

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check codes with DDR.

[a] If no codes are logged, no further troubleshooting is required.

[b] If code 100/3 is not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 100/3 is logged, all system diagnostics are complete. Contact Detroit Diesel Technical Service.


TShootVuntitled00000511

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 36.

Perform the following steps to check for multiple codes.

  1. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  2. Turn vehicle ignition switch ON.

  3. Read active codes.

[a] If code 100/4 and no other codes were logged, refer to Sensor Check.

[b] If code 100/4 was logged and none of the following codes were logged: 110/3 or 4, 174/3 or 4, 175/3 or 4, 101/3 or 4, 102/3 or 4, 73/3 or 4, 94/3 or 4, 100/3, refer to Sensor Check.

[c] If code 100/4 and any of the following codes were logged: 110/3 or 4, 174/3 or 4, 175/3 or 4, 101/3 or 4, 102/3 or 4, 73/3 or 4, 94/3 or 4, 100/3, refer to ENGINE SENSOR HARNESS.


TShootVuntitled00000512

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition switch OFF.

  2. Disconnect OPS connector and install a jumper wire between sockets B and C of the OPS harness connector. See Engine Harness Connector to Oil Pressure Sensor.

  3. Turn ignition ON.

  4. Read active codes.

  5. If active codes 100/3 or 4 were logged, proceed with the following:

[a] If active code 100/4 and any other codes were logged, refer to Check for +5 Volts.

[b] If code 100/3 and any other codes except 100/4 were logged, refer to Check Oil Pressure Sensor Connectors.

  6. If active codes 100/3 or 4 were not logged, warm up engine until either codes are logged or the engine temperature (COOLANT TEMP or OIL TEMP or DDR) has been greater than 60°C (140°F) for one minute.

[a] If active code 100/4 and any other codes were logged, refer to Check for +5 Volts.

[b] If code 100/3 and any other codes except 100/4 were logged, refer to Check Oil Pressure Sensor Connectors.


TShootVuntitled00000513

 Check Oil Pressure Sensor Connectors

Perform the following steps to check the OPS connectors.

  1. Turn ignition OFF.

  2. Check terminals at the OPS connectors (both the sensor and harness side) for damage: bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the OPS. Refer to Verify Repairs.


TShootVuntitled00000514

 Check for +5 Volts

Perform the following steps to check for +5 volts.

  1. Turn vehicle ignition OFF.

  2. Remove jumper wire.

  3. Turn ignition ON.

  4. Measure voltage on OPS harness connector, socket 3 (red lead) to socket 1 (black lead).

[a] If the voltage measurement is less than 4 volts, refer to Check for Open +5 Volt Line.

[b] If the voltage measurement is greater than 6 volts, refer to Check for Short to Battery +.

[c] If the voltage measurement is between 4 and 6 volts, refer to Check for Signal Open.


TShootVuntitled00000515

 Check for Signal Open

Perform the following steps to check for signal open.

  1. Turn the ignition OFF.

  2. Disconnect the engine harness connector at the ECU. See Engine Harness Connector to Oil Pressure Sensor.

  3. Install a jumper wire between sockets 1 and 2 of the OPS harness connector.

  4. Measure resistance between sockets E15 and E31 on the engine harness connectors.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short to Ground.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line (E31) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000516

 Check for Short

Perform the following steps to check for a short.

  1. Remove jumper wire.

  2. Measure resistance between socket E31 and a good ground. Also measure resistance between E31 and E15.

[a] If both resistance measurements are greater than 100 [image] or open, replace OPS. Refer to Verify Repairs.

[b] If either resistance measurement is less than 100 [image] [image] the signal line (E31) is shorted to the return line (E15) or battery ground. Repair short and refer to Verify Repairs.


TShootVuntitled00000517

 Check ECU Connectors

Perform the following steps to check ECU connectors.

  1. Check terminals at the ECU harness connector (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. Check E12, E15, and E31 terminals and pins at ECU.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, reprogram the ECU. Refer to Verify Repairs.


TShootVuntitled00000518

 Check for Open +5 Volt Line

Perform the following steps to check for open +5 volt line.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connectors at the ECU.

  3. Install a jumper wire between pins 1 and 3 of the OPS connector.

  4. Measure resistance between sockets E15 and E12 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the engine +5 volt line (E12) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000519

 Check for Short

Perform the following steps to check for a short.

  1. Remove jumper wire.

  2. Measure resistance between sockets 1 and 3 on the OPS harness connector. Also measure resistance between socket 3 and a good ground.

[a] If either resistance measurement is less than or equal to 100 [image] [image] the engine +5 volt line (E12) is shorted to the return line (E15) or battery ground. Repair the short and refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] or open, replace OPS and refer to Check ECU Connectors.


TShootVuntitled00000520

 Check for Short to Battery +

Perform the following steps to check for a short to battery.

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness connector at the ECU. See ECU Vehicle Harness Connector.

  3. Measure resistance between socket E31 on the engine harness connector and socket V15 of the vehicle harness connector, and between E31 and V61 and V65.

[a] If resistance measurement is greater than 100 [image] [image] or open, replace OPS. Refer to Verify Repairs.

[b] If resistance measurement is less than or equal to 100 [image] [image] a short exists between sockets where less than 100 [image] resistance was read. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000521

 Check for Short to Ground

Perform the following steps to check for a short to ground.

  1. Turn vehicle ignition OFF.

  2. Remove jumper wire.

  3. Measure resistance between sockets E31 and E15 on the engine harness connector. See Engine Harness Connector to Oil Pressure Sensor.

[a] If resistance measurement is greater than 100 [image] [image] or open, refer to Check for Short.

[b] If resistance measurement is less than or equal to 100 [image] [image] the signal line (E31) and return line (E15) are shorted together. Repair the short. Refer to Verify Repairs.


TShootVuntitled00000522

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 100/4 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 100/4 is logged, and other codes are logged, all system diagnostics are complete. Please review this section from the first step to find the error - refer to Multiple Code Check.


TShootVuntitled00000524

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 37.

Perform the following steps to check for multiple codes.

  1. Turn ignition ON.

  2. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  3. Read active codes.

[a] If active code 95/3 was logged, and no other codes were logged, refer to Sensor Check.

[b] If active codes 94/3 and any or all of the following codes were logged, 110/3 or 4, 174/3 or 4, 175/3 or 4, 101/3 or 4, 102/3 or 4, 100/3 or 4, 95/4, 73/3 or 4, refer to ENGINE SENSOR HARNESS.


TShootVuntitled00000525

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition switch OFF.

  2. Disconnect FRS connector.

  3. Turn ignition ON.

  4. Start and run engine.

  5. Select Engine Temperature (COOLANT TEMP & OIL) on DDR.

  6. Warm up engine until engine temperature reading is greater than 60°C (140°F).

  7. Leave engine running at idle after warm-up. Run for five minutes.

  8. Read active codes.

[a] If active codes 95/3 and any other codes were logged, refer to Check for Short.

[b] If active code 95/4 and any other codes except 95/3 was logged, refer to Return Circuit Check.


TShootVuntitled00000526

 Return Circuit Check

Perform the following steps to check the return circuit.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Install a jumper wire between pins A and B of the FRS harness connector.

  4. Measure resistance between sockets E16 and E15 on the engine harness connectors.

[a] If resistance measurement is less than or equal to 5 [image] [image] refer to Check Fuel Pressure Sensor Connectors.

[b] If resistance measurement is greater than 5 [image] [image] or open, the return line (E15) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000527

 Check Fuel Pressure Sensor Connectors

Perform the following steps to check the FRS connectors.

  1. Inspect terminals at the FRS connectors (both the sensor and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the FRS and refer to Verify Repairs.


TShootVuntitled00000528

 Check for Short

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connectors at the ECU.

  3. Measure resistance between sockets E12 and E16 on the engine harness connector.

[a] If the resistance measurement is greater than 100 [image] or open, refer to Check for Short to Battery +.

[b] If the resistance measurement is less than or equal to 100 [image] [image] the signal line (E16) is shorted to the engine +5 volt line (E12). Repair the short and refer to Verify Repairs.


TShootVuntitled00000529

 Check for Short to Battery +

Perform the following steps to check for a short to battery.

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness connector. See ECU Vehicle Harness Connector.

  3. Measure resistance between socket E16 on the engine harness connector and socket V15 of the vehicle harness connector, and between E16 and sockets V61 and V65.

[a] If the resistance measurement is greater than 1,000 [image] [image] or open, refer to Check ECU Connector.

[b] If the resistance measurement is less than or equal to 1,000 [image], a short exists between sockets where less than 1,000 [image] [image] was measured. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000530

 Final Check

Perform the following steps to do a final check.

  1. Reconnect all connectors.

  2. Turn vehicle ignition ON.

  3. Clear codes.

  4. Start and run the engine for one minute.

  5. Stop engine.

  6. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If active codes 95/3 was logged, reprogram the ECU. Refer to Verify Repairs.

[c] If any codes except codes 95/3 was logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000531

 Check ECU Connector

Perform the following steps to check the ECU connector.

  1. Inspect terminals at the ECU connector (both the ECU and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the FPS/FRS. Refer to Final Check. See Fuel Restriction Sensor.


TShootVuntitled00000532

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, no further troubleshooting is required.

[b] If codes 95/3 was not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If codes 95/3 was logged, and other codes are logged, all system diagnostics are complete. Please review this section from the first step to find the error - refer to Multiple Code Check.


TShootVuntitled00000534

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 38.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  3. Read active codes.

[a] If active code 95/4 and no other codes were logged, refer to Sensor Check.

[b] If active code 95/4 and any or all of the following codes were logged, 95/3, 100/3 or 4, 101/3 or 4, 110/3 or 4, 174/3 or 4, 175/3 or 4, refer to ENGINE SENSOR HARNESS.

[c] If active code 95/4 and codes other than the following codes were logged, 95/3, 100/3 or 4, 101/3 or 4, 110/3 or 4, 174/3 or 4, 175/3 or 4, refer to Sensor Check.


TShootVuntitled00000535

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition switch OFF.

  2. Disconnect FRS connector and install a jumper wire between sockets B and C of the FRS harness connector.

  3. Turn ignition ON.

  4. Read logged codes.

  5. If active codes 95/3 or 4 are not logged, start and run the engine until either these active codes display or engine temperature (COOLANT TEMP & OIL on DDR) has been greater than 60°C (140°F) for more than one minute.

[a] If active code 95/4 and any other codes are logged, refer to Check for +5 Volts.

[b] If active code 95/3 and any other codes except code 95/4 are logged, check to ensure ECU and FPS/FRS connectors are wired properly. Refer to Check Fuel Pressure Sensor Connectors.


TShootVuntitled00000536

 Check Fuel Pressure Sensor Connectors

Perform the following steps to check the FRS connectors.

  1. Inspect terminals at the FRS connectors (both the sensor and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the FRS and refer to Verify Repairs.


TShootVuntitled00000537

 Check for +5 Volts

Perform the following steps to check for +5 volts.

  1. Turn vehicle ignition OFF.

  2. Remove jumper wire.

  3. Turn ignition ON.

  4. Measure voltage on FRS harness connector, socket C to socket A.

[a] If the voltage measurement is greater than 6 volts, refer to Check for Short to Battery +.

[b] If the voltage measurement is less than 4 volts, refer to Check for Open +5 Volt Line.

[c] If the voltage measurement is between 4 and 6 volts, refer to Check for Signal Open.


TShootVuntitled00000538

 Check for Signal Open

Perform the following steps to check for signal open.

  1. Turn vehicle ignition OFF.

  2. Disconnect engine harness connector at the ECU.

  3. Install a jumper wire between pins A and B of the FRS harness connector.

  4. Measure resistance between sockets E16 and E15 on the engine harness connector.

[a] If resistance measurement is less than or equal to 5 [image] refer to Check for Short to Ground.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line (E16) or return line (E15) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000539

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU harness connector (both ECU and harness side) for damage: bent, corroded, and unseated pins or sockets. Check E12, E16 and E15 terminals at ECU.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, install a test ECU. Refer to Verify Repairs.


TShootVuntitled00000540

 Check for Open +5 Volt Line

Perform the following steps to check for open +5 volt line.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connectors at the ECU.

  3. Install a jumper wire between sockets A and C of the FRS harness connector.

  4. Measure resistance between sockets E12 and E15 on the engine harness connector.

[a] If resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the engine +5 volt line (E16) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000541

 Check for Short

Perform the following steps to check for a short.

  1. Remove jumper wire.

  2. Measure resistance between sockets A and C of the FRS harness connector.

[a] If the resistance measurement is greater than 100 [image] or open, refer to Replace Fuel Pressure Sensor / Fuel Restriction Sensor.

[b] If the resistance measurement is less than or equal to 100 [image] [image] the return line (E15) is shorted to the engine +5 volt line (E12). Repair the short and refer to Verify Repairs.


TShootVuntitled00000542

 Check for Short to Battery +

Perform the following steps to check for a short to battery.

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness connector at the ECU. See ECU Vehicle Harness Connector.

  3. Measure resistance between socket E12 on the engine harness connector and socket V15 of the vehicle harness connector, and between E12 and the 5-way power harness sockets V61 and V65.

[a] If the resistance measurement is greater than 1,000 [image] [image] or open, refer to Replace Fuel Pressure Sensor / Fuel Restriction Sensor.

[b] If the resistance measurement is less than or equal to 1,000 [image], a short exists between sockets where less than 1,000 [image] [image] was measured. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000543

 Check for Short to Ground

Perform the following steps to check for a short to ground.

  1. Turn ignition switch OFF.

  2. Remove jumper wires.

  3. Measure resistance between sockets E16 and E15 on the engine harness connector. Also measure resistance between socket E16 and a good ground.

[a] If both resistance measurements are greater than 100 [image] or open, refer to Replace Fuel Pressure Sensor / Fuel Restriction Sensor.

[b] If either resistance measurement is less than or equal to 100 [image] [image] the signal line (E16) and return line (E15) are shorted together, or the signal line (E16) is shorted to battery ground. Repair the short. Refer to Verify Repairs.


TShootVuntitled00000544

 Replace Fuel Pressure Sensor / Fuel Restriction Sensor

Perform the following steps to replace the FRS.

  1. Turn ignition switch OFF.

  2. Replace FRS.

  3. Reconnect all connectors.

  4. Turn ignition ON.

  5. Clear codes.

  6. Start and run the engine for one minute.

[a] If check engine light comes on, refer to Check ECU Connectors.

[b] If check engine light does not come on, refer to Verify Repairs.


TShootVuntitled00000545

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 95/4 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 95/4 is logged, and other codes are logged, all system diagnostics are complete. Please review this section from the first step to find the error - refer to Multiple Code Check.


TShootVuntitled00000549

 Check for Signal Open

Use the following procedure to troubleshoot Flash Code 41.

Perform the following steps to check for signal open.

  1. Turn ignition OFF.

  2. Disconnect engine harness connector at the ECU. See Engine Harness Connector.

  3. Read resistance between sockets E17 and E18 on the engine harness connector.

[a] If the resistance reading is less than or equal to 200 [image], refer to Check for Short.

[b] If the resistance reading is greater than 200 [image] or open, refer to Open Timing Reference Sensor Line Check.


TShootVuntitled00000550

 Check for Short

Perform the following steps to check for a short.

  1. Disconnect the TRS connector.

  2. Measure resistance between sockets E17 and E18 on the engine harness connector. See Engine Harness Connector to Timing Reference Sensor.

  3. Measure resistance between socket E17 and ground, and between socket E18 and ground.

[a] If the resistance measurement is greater than 10,000 [image] [image] or open, refer to Check Timing Reference Sensor Resistance.

[b] If the resistance measurement is less than or equal to 10,000 [image], a short exists between E17 and E18 or where less than 10,000 [image] [image] resistance was read. Repair the short. Refer to Verify Repairs.


TShootVuntitled00000551

 Open Timing Reference Sensor Line Check

Perform the following steps to check the open TRS line.

  1. Disconnect the TRS connector.

  2. Install a jumper wire between sockets 1 and 2 of the TRS harness connector.

  3. Measure resistance between sockets E17 and E18 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check Timing Reference Sensor Resistance.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line E18 or return line E17 is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000552

 Check Timing Reference Sensor Resistance

Perform the following steps to check TRS resistance.

  1. Measure resistance of TRS across sensor connector pins 1 and 2. See Engine Harness Connector to Timing Reference Sensor.

[a] If the resistance measurement is greater than 200 [image], refer to Check Timing Reference Sensor Connectors.

[b] If the resistance measurement is less than 100 [image] [image] refer to Check Timing Reference Sensor Connectors.

[c] If the resistance measurement is between 100 and 200 [image], refer to Check Timing Reference Sensor / Synchronous Reference Sensor.


TShootVuntitled00000553

 Check Timing Reference Sensor / Synchronous Reference Sensor Gap

Perform the following steps to check the TRS/SRS gap.

  1. Bar the engine until the TRS is over a TRS tooth of the pulse wheel.

  2. Check the gap between TRS and the tooth of the pulse wheel (0.020 to 0.040 in.). A depth micrometer can be used.

[a] If the gap setting is correct, refer to Synchronous Reference Sensor Code Check.

[b] If the gap setting is not correct, adjust the TRS/SRS until the gap setting is correct. If the problem returns, the pulse wheel may be loose or bad or damaged. Refer to Verify Repairs.


TShootVuntitled00000554

 Synchronous Reference Sensor Code Check

Perform the following steps to check for SRS code.

  1. Check for SRS code.

[a] If code 21/1 is not logged, refer to Check ECU Connectors.

[b] If code 21/1 is logged, refer to Synchronous Reference Sensor Resistance Check.


TShootVuntitled00000555

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connectors (both the ECU and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, install a test ECU. Refer to Verify Repairs.


TShootVuntitled00000556

 Synchronous Reference Sensor Resistance Check

Perform the following steps to check SRS resistance.

  1. Measure resistance between sockets E20 and E19 on the engine harness connector. See Engine Harness Connector to Synchronous Reference Sensor.

[a] If measured resistance is greater than 200 [image], or open, refer to Open Synchronous Reference Sensor Line Check.

[b] If measured resistance is less than 200 [image], or open, refer to Check for Short.


TShootVuntitled00000557

 Check for Short

Perform the following steps to check for a short.

  1. Disconnect the SRS connector.

  2. Measure resistance between sockets E19 and E20 on the engine harness connector.

[a] If measured resistance is greater than 10,000 [image], or open, refer to Synchronous Reference Sensor Test.

[b] If measured resistance is less than or equal to 10,000 [image], the signal line E20 is shorted to the return line E19. Repair the short. Refer to Verify Repairs.


TShootVuntitled00000558

 Open Synchronous Reference Sensor Line Check

Perform the following steps to check for an open SRS line.

  1. Disconnect the SRS connector.

  2. Install a jumper wire between sockets 1 and 2 of the SRS harness connectors.

  3. Measure resistance between sockets E19 and E20 on the engine harness connector.

[a] If measured resistance is less than or equal to 5 [image] [image] refer to Synchronous Reference Sensor Test.

[b] If measured resistance is greater than 5 [image] [image] or open, the signal line E20 or return line E19 is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000559

 Synchronous Reference Sensor Test

Perform the following steps to test the SRS.

  1. Measure resistance of SRS across the sensor connector pins 1 and 2.

[a] If measured resistance is less than or equal to 100 [image] [image] refer to Check Synchronous Reference Sensor Connectors.

[b] If measured resistance is greater than 200 [image], refer to Check Synchronous Reference Sensor Connectors.

[c] If measured resistance is between 100 and 200 [image], refer to Check ECU Connectors.


TShootVuntitled00000560

 Check Timing Reference Sensor Connectors

Perform the following steps to check TRS connectors.

  1. Check terminals at the TRS (both the TRS and harness side) for damage: bent, corroded, and unseated pins or sockets. See Engine Harness Connector to Synchronous Reference Sensor.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the TRS. Refer to Verify Synchronous Reference Sensor / Timing Reference Sensor.


TShootVuntitled00000561

 Check Synchronous Reference Sensor Connectors

Perform the following steps to check the SRS connectors.

  1. Check terminals at the SRS (both the SRS and harness side) for damage: bent, corroded, and unseated pins or sockets, or bad contacts.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the SRS. Refer to Verify Synchronous Reference Sensor / Timing Reference Sensor.


TShootVuntitled00000562

 Verify Synchronous Reference Sensor / Timing Reference Sensor

Perform the following steps to verify operation of the SRS/TRS.

  1. Reconnect all connectors.

  2. Turn vehicle ignition ON.

  3. Clear codes.

  4. Start and run the engine for one minute.

  5. Stop engine.

  6. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 21/0 and any other codes are logged, and the SRS was not replaced, refer to Synchronous Reference Sensor Code Check.

[c] If any codes except code 21/0 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000563

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn vehicle ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 21/0 and any other codes are logged, all system diagnostics are complete. Review this section to find the error. Refer to Check for Signal Open or contact Detroit Diesel Technical Service.

[c] If any codes except code 21/0 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000565

 Resistance Check

Use the following procedure to troubleshoot Flash Code 42.

Perform the following steps to check resistance.

  1. Turn vehicle ignition OFF.

  2. Disconnect engine harness connector at ECU.

  3. Measure resistance between sockets E19 and E20 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 200 [image], refer to Check for Short.

[b] If the resistance measurement is greater than 200 [image] or open, refer to Open Synchronous Reference Sensor Line Check.


TShootVuntitled00000566

 Check for Short

Perform the following steps to check for a short.

  1. Disconnect the SRS Connector.

  2. Measure resistance between sockets E19 and E20 on the engine harness connector. See Engine Harness Connector to Synchronous Reference Sensor.

  3. Measure resistance between socket E19 and ground, and between socket E20 and ground.

[a] If the resistance measurement is less than or equal to 10,000 [image], a short exists. Repair the short. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 10,000 [image], or open, refer to Synchronous Reference Sensor Test.


TShootVuntitled00000567

 Open Synchronous Reference Sensor Line Check

Perform the following steps to check for an open SRS line.

  1. Disconnect the SRS connector.

  2. Install a jumper wire between sockets 1 and 2 of the SRS harness connector. See Engine Harness Connector to Synchronous Sensor.

  3. Measure resistance between sockets E19 and E20 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Synchronous Reference Sensor Test.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line (E20) or return line (E19) is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000568

 Synchronous Reference Sensor Test

Perform the following steps to test the SRS.

  1. Measure resistance of SRS across the sensor connector pins 1 and 2.

[a] If the resistance measurement is less than or equal to 100 [image] [image] refer to Check Synchronous Reference Sensor Connectors.

[b] If the resistance measurement is greater than 200 [image], refer to Check Synchronous Reference Sensor Connectors.

[c] If the resistance measurement is between 100 and 200 [image], refer to Check Synchronous Reference Sensor Gap.


TShootVuntitled00000569

 Check Synchronous Reference Sensor Gap

Perform the following steps to check the SRS gap.

  1. Bar engine until SRS is over the SRS pin.

  2. Check the gap between SRS and the pin.

[a] If the gap setting is correct (0.020 - 0.040 in.), refer to Check for Timing Reference Sensor Code. A depth micrometer can be used.

[b] If the gap setting is not correct, adjust the SRS until the gap setting is correct. If the problem returns, the pulse wheel may be loose or bad. Refer to Verify Repairs.


TShootVuntitled00000570

 Check for Timing Reference Sensor Code

Perform the following steps to check for TRS code.

  1. Check for TRS code.

[a] If code 21/0 is not logged, refer to Check ECU Connectors.

[b] If code 21/0 is logged, refer to Timing Reference Sensor Resistance Check.


TShootVuntitled00000571

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connectors (both the ECU and harness side) for damage: bent, corroded, and unseated pins or sockets. See Engine Harness Connector to Synchronous Sensor.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, refer to Verify Cranking Voltage.


TShootVuntitled00000572

 Timing Reference Sensor Resistance Check

Perform the following steps to check TRS resistance.

  1. Remove the engine harness connector.

  2. Measure resistance between sockets E17 and E18 on the engine harness connector. See Engine Harness Connector to Timing Reference Sensor.

[a] If the resistance measurement is greater than 200 [image], refer to Open Timing Reference Sensor Line Check.

[b] If the resistance measurement is less than or equal to 200 [image], refer to Check for Short.


TShootVuntitled00000573

 Check for Short

Perform the following steps to check for a short.

  1. Disconnect the TRS connector.

  2. Measure resistance between sockets E17 and E18 on the engine harness connector.

[a] If measured resistance is greater than 10,000 [image], or open, refer to Timing Reference Sensor Test.

[b] If measured resistance is less than or equal to 10,000 [image], the signal line (E18) is shorted to the return line (E17). Repair the short. Refer to Verify Repairs.


TShootVuntitled00000574

 Open Timing Reference Sensor Line Check

Perform the following steps to check for an open TRS line.

  1. Disconnect the TRS connector.

  2. Install a jumper wire between sockets 1 and 2 of the TRS harness connector. See Engine Harness Connector to Timing Reference Sensor.

  3. Measure resistance between sockets E17 and E18 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Timing Reference Sensor Test.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line (E18) or return line (E17) is open. Repair the open. Refer to Verify Repairs.


TShootVuntitled00000575

 Timing Reference Sensor Test

Perform the following steps to test the TRS.

  1. Measure resistance of TRS across the sensor connector pins 1 and 2.

[a] If the resistance measurement is greater than200 [image], refer to Check Timing Reference Sensor Connectors.

[b] If the resistance measurement is less than 100 [image] [image] refer to Check Timing Reference Sensor Connectors.

[c] If the resistance measurement is between100 and 200 [image], refer to Check ECU Connectors.


TShootVuntitled00000576

 Check Synchronous Reference Sensor Connectors

Perform the following steps to check the SRS connectors.

  1. Check terminals at the SRS (both the SRS and harness side) for damage: bent, corroded, and unseated pins or sockets, or a bad contact. See Engine Harness Connector to Synchronous Reference Sensor.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the SRS. Refer to Verify Synchronous Reference Sensor / Timing Reference Sensor.


TShootVuntitled00000577

 Check Timing Reference Sensor Connectors

Perform the following steps to check the TRS connectors.

  1. Check terminals at the TRS (both the TRS and harness end) for damage: bent, corroded, and unseated pins or sockets or bad contacts. See Engine Harness Connector to Timing Reference Sensor.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, replace the TRS. Refer to Verify Synchronous Reference Sensor / Timing Reference Sensor.


TShootVuntitled00000578

 Verify Synchronous Reference Sensor / Timing Reference Sensor

Perform the following steps to verify operation of the SRS/TRS.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Clear codes.

  4. Start and run the engine for one minute.

  5. Stop engine.

  6. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If any codes except code 21/1 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 21/1 and any other codes are logged, and the TRS was not replaced, refer to Check for Timing Reference Sensor Code.

[d] If code 21/1 and any other codes are logged, and the TRS was replaced, refer to Verify Cranking Voltage.


TShootVuntitled00000579

 Verify Cranking Voltage

Perform the following steps to verify cranking voltage.

  1. Turn vehicle ignition OFF.

  2. Connect all connectors.

  3. Connect 12 volt from a fully charged battery power connector.

  4. Connect to ECU. See ECU Engine Harness Connector.

  5. Start engine.

[a] If engine starts, check the battery. If a voltage equalizer is installed, check the operation of the equalizer. If the equalizer is not working, refer to Verify Repairs.

[b] If the engine does not start, replace the ECU. Refer to Verify Repairs.


TShootVuntitled00000580

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn vehicle ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 21/1 and any other codes are logged, all system diagnostics are complete. Review this section to find the error - refer to Resistance Check.

[c] If any codes except code 21/1 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000582

 Coolant Level Low

Use the following procedure to troubleshoot Flash Code 43.

Perform the following steps to diagnose the coolant level low.

  1. Turn ignition ON; plug in DDR.

  2. Read active codes.

[a] If code 111/1 is logged, there is an indication of a low coolant level condition. Add coolant to ensure coolant level probe is immersed in coolant.

[b] If code 111/1 remains active, refer to Replace Coolant Level Sensor.


TShootVuntitled00000583

 Replace Coolant Level Sensor

Using the sensor tester may be of assistance. Use Tool J 37164.

NOTE: When replacing the coolant level sensor, the CLS could be an OEM supplied part.

  1. Turn ignition OFF; replace CLS.

  2. Turn ignition ON.

  3. Read active codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If codes are logged, refer to Clean and Check Alternator Grounds.


TShootVuntitled00000584

 Clean and Check Alternator Grounds

Perform the following steps to check the alternator ground.

  1. If the grounds are clean and good, troubleshooting is complete.

  2. If the grounds are damaged, repair the ground circuit and verify repairs.


TShootVuntitled00000585

 Verify Repairs

Perform the following steps to verify repairs

  1. Turn ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear DDR codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 111/1, and any other codes are logged, refer to Coolant Level Low, and repeat the procedure, or contact Detroit Diesel Technical Service.

[c] If any code other than 111/1 is logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000587

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 44.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Read active codes.

[a] If active codes other than 110/0 or 175/0 are logged, service them first.

[b] If active codes 110/0 or 175/0 are logged, and no other codes are logged, oil or coolant temperature was higher than it should have been. Inspect for damage. Plug in the reader and determine if code is coolant or oil temperature high.

[c] If active code 110/0 is logged, and the duration of this code is less than 20 seconds, or if it has multiple occurrences which average less than 20 seconds each, contact Detroit Diesel Technical Service.

[d] There is no action required for active code 110/14 or 175/14. This code is for information only.

NOTE: For information concerning high temperature levels, refer to Section 4.1 in the service manual.


TShootVuntitled00000589

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 45.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in the diagnostic data reader (DDR)

  3. Read active codes.

[a] If codes other than 100/1 are logged, service them first.

[b] If code 100/1 is logged, and no other codes are logged, there was an engine running condition at which oil pressure was lower than it should have been.

NOTE: For information concerning low oil pressure level, refer to DDEC DIAGNOSTIC CODES in the engine service manual.


TShootVuntitled00000591

 Battery Check

Use the following procedure to troubleshoot Flash Code 46.

Perform the following steps to check the battery.

  1. Start and run the engine for one minute.

  2. Measure voltage on battery + terminal (red lead) to battery - terminal (black lead). See Measuring Battery Voltage.

[a] If the engine does not start, inspect the battery and charging/starting system, and proceed if okay. Refer to DIAGNOSING A DDEC SYSTEM FAULT.

[b] If the engine does start and the voltage measurement is less than or equal to 10.0 volts, service the discharged battery and charging/starting system.

[c] If the engine does start and the voltage measurement is greater than 10.0 volts, refer to Voltage Check at ECU.


TShootVuntitled00000592

 Voltage Check at ECU

Perform the following steps to check voltage at the ECU.

  1. Keep engine running.

  2. Select ECU INPUT VOLT on DDR.

  3. Observe ECU voltage reading on DDR.

[a] If the voltage measurement is less than or equal to 10.0 volts, refer to Voltage Check at ECU Via Volt-Ohm Meter.

[b] If the voltage measurement is greater than 10.0 volts, refer to Ground Check at ECU.


TShootVuntitled00000593

 Voltage Check at ECU Via Volt-Ohm Meter

Perform the following steps to check voltage at the ECU.

  1. Turn the vehicle ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Measure voltage from socket V61, V62, V65, and V66 (red lead) harness connector and a good battery ground (black lead). Do not use lines (V63, V64, or V68) as a ground reference. See Engine Harness Connector and Power Harness.

[a] If the voltage measurement is less than or equal to 11.5 volts, refer to Check for Bad Battery + Line.

[b] If the voltage measurement is greater than 11.5 volts, refer to Ground Check at ECU.


TShootVuntitled00000594

 Check for Bad Battery + Line

Perform the following steps to check for a bad battery + line.

  1. Remove fuse(s) to the ECU.

  2. Measure voltage at socket A of one fuseholder (red lead) to a good ground (black lead). For the vehicle harness, see Vehicle Harness Connector.

  3. Repeat voltage measurement at other fuseholder.

[a] If the voltage measurement is greater than 11.5 volts on both readings, the battery + line between the fuseholder and ECU has an open, or the ECU power connector has a corroded connection. Repair the problem. Refer to Verify Repairs.

[b] If the voltage measurement is less than or equal to 11.5 volts on either reading, the battery + line near the battery is open, or a corroded connection exists at battery + terminal. Repair the problem. Refer to Verify Repairs.


TShootVuntitled00000595

 Ground Check at ECU

Perform the following steps to check the ground at the ECU.

  1. Disconnect the vehicle harness connectors at the ECU. See Vehicle Harness Connector.

  2. Measure voltage on socket V61 and V62 to socket V63 and V64 and socket V65 and V66 connector to socket V67 and V68.

[a] If voltage measurement is greater than 11.5 volts on either reading, refer to Check ECU Connectors.

[b] If the voltage measurement is less than or equal to 11.5 volts on either reading, the ground wire is open or has a corroded connection. Repair ground wire, and refer to Verify Repairs.


TShootVuntitled00000596

 Check ECU Connectors

Perform the following steps to check ECU connectors.

  1. Check terminals at the vehicle harness connector (both ECU and harness side) for damage; bent, corroded, and unseated pins or sockets.

[a] If terminals and connector are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connector are not damaged, verify the power and ground are wired directly to the battery. Refer to Code Check.


TShootVuntitled00000597

 Code Check

Perform the following steps to check for codes.

  1. Install the vehicle interface module.

  2. Turn ignition ON; plug in DDR.

  3. Check for codes.

[a] If code reoccurs, install test ECU, then refer to Verify Repairs.

[b] If code does not reoccur, check power harness wires for breaks, abrasions, etc. Then refer to Verify Repairs.


TShootVuntitled00000598

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes with DDR.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are displayed, troubleshooting is complete.

[b] If code 168/1 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 168/1 is logged, and other codes are logged, all system diagnostics are complete. To troubleshoot the error, refer to Battery Check.


TShootVuntitled00000601

 Check for Other Codes

Use the following procedure to troubleshoot Flash Code 48.

Perform the following steps to check for other codes:

  1. Turn ignition ON.

  2. Plug in DT.

  3. Read active codes.

[a] If code 39 displays, service those codes first.

[b] If code 39 does not display, refer to Vehicle Air Test.


TShootVuntitled00000602

 Vehicle Air Test

Perform the following steps to check the vehicle air test. The vehicle air test should have been performed during EGR - 1 on a Series 60 engine, refer to MAINTENANCE ALERT SYSTEM. If the test was not performed, refer to proper section and perform all steps.

  1. If the vehicle air system failed the test, resolve low vehicle air pressure.

  2. If the vehicle air system passed the test, replace the EGR valve and refer to Verify Repairs for verification of repairs.

  3. No additional DDEC troubleshooting is recommended for these codes. Check all Basic Checks and then contact Technical Service for instructions, providing a snapshot and code logging details.


TShootVuntitled00000603

 Verify Repairs

Perform these steps to verify repairs to the vehicle air system:

  1. Connect all connectors.

  2. Start engine.

  3. Perform road test.

  4. Has the fault returned?

[a] If the code is logged, review this section to find the error. If the fault returns after review, try a test ECM or contact Detroit Diesel Technical Services.

[b] If no codes are logged, troubleshooting is complete.


TShootVuntitled00000607

 Check for Codes

Use the following procedure to troubleshoot Flash Code 51.

Follow these steps to check for codes:

  1. Unplug coding sensor.

  2. Insert jumper wire; #1 - #2 (404 code) or #4 - #1 (351 code). See Turbo Compressor Inlet Sensor.

  3. Start and run engine for six minutes.

[a] If code 404 or 351 FMI 3 display, refer to Check for Open.

[b] If code 404 or 351 FMI 4 display, go to Check Connectors.


TShootVuntitled00000608

 Check for Open

The steps that brought you to this procedure indicate either the signal wire or return is open.

Follow these steps to check for open:

  1. If code 351 displays, check cavity 7 at the 10 - pin connector.

  2. Determine if repair was made.

[a] If the repair was made, refer to Verify Procedure.

[b] If the repair was not made, replace the sensor. For code 351, replace TCI (see TCI Connector); code 404, replace TCO (see Turbo Compressor Inlet Sensor). Then refer to Verify Procedure.

  3. Test the repair.


TShootVuntitled00000609

 Check Connectors

Follow this procedure to check the engine harness connectors.

  1. If code 351 displays, check the connectors for damaged, bent or broken pins.See Turbocharger Compressor Outlet Temperature Circuit.

[a] If damaged pins are found, repair the connector and test. Refer to Verify Procedure.

[b] If no damaged pins are found, replace the sensor. For code 404, replace TCO, code 351, replace TCI. Then, refer to Verify Procedure.


TShootVuntitled00000610

 Verify Procedure

Follow these steps to verify the procedure.

  1. Reconnect all connectors.

  2. Start and run the engine.

  3. Check for codes.

[a] If codes 351 or 404 display, try a test ECU programmed for EGR.

[b] If no codes display, the procedure is finished.

[c] If codes other than 351 or 404 display, troubleshoot those codes.


TShootVuntitled00000612

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 52.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Read active codes.

[a] If active codes other than 254/12 are logged, service them first.

[b] If active code 254/12 is logged, and no other codes are logged, hook up test ECU. If code clears, replace the ECU. If code is not cleared, contact Detroit Diesel Technical Service.

NOTE: For information concerning ECU replacement, refer to Section 2.9 in the service manual.


TShootVuntitled00000614

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 53.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Read active codes.

[a] If codes other than 253/12 or 253/2 are logged, service them first.

[b] If codes 253/12 or 253/2 are logged, and no other codes are logged, reprogram the ECU. Refer to Test for Codes.


TShootVuntitled00000615

 Test for Codes

Perform the following steps to test for codes.

  1. Start and run the engine.

  2. Read active codes with DDR.

[a] If active code 253/2 is logged, and no other codes are logged, install a test ECU. Refer to Verify Repairs.

NOTE: It is recommended that a "Test" ECU be tried first to determine the need to replace the ECU. For information concerning ECU replacement, refer to Section 2.9 in the service manual.

[b] If no codes are logged, troubleshooting is complete.


TShootVuntitled00000616

 Verify Repairs

Perform the following steps to verify repairs.

  1. Start and run the engine.

[a] If no codes are logged, troubleshooting is complete.

[b] If codes are logged, contact Detroit Diesel Technical Service.


TShootVuntitled00000618

 Test Drive Vehicle

Use the following procedure to troubleshoot Flash Code 54.

Take the vehicle for a test drive with an assistant.

  1. View DDR; select vehicle speed.

[a] If mph reads 0 (zero), or stays steady with the vehicle in motion, refer to Speed Sensor Identification.

[b] If speed appears correct, refer to Vehicle Speed Mechanical Checks.


TShootVuntitled00000619

 Speed Sensor Identification

Identify the speed sensor type - type one or type two.

  1. The type one sensor is a magnetic pickup and may be located in one of the following locations: transmission tail shaft, wheel rim, mechanical speedometer cable. If you have a type one sensor, refer to Check Vehicle Speed Sensor Circuit. (Verify with DDR signal type - magnetic.)

  2. The type two sensor communicates with square wave input and output signals and requires the ECU to be configured correctly. Refer to Check for Short to Ground. (Verify with DDR signal type - switched.)


TShootVuntitled00000620

 Check Vehicle Speed Sensor Circuit

Perform the following steps to check the vehicle speed sensor.

  1. With ignition off, disconnect the vehicle harness connector.

  2. Measure resistance of VSS circuit across vehicle harness connector pins, V17 and V18. See VIH-to-ECU Connector.

[a] If the resistance measurement is less than 50 [image], refer to Check for Short.

[b] If the resistance measurement is greater than 3,000 [image] [image] or open, refer to Check for Open.

[c] If the resistance measurement is between 50 and 3,000 [image], refer to Check for Short to Ground.


TShootVuntitled00000621

 Check for Short

Perform the following steps to check for short.

  1. Disconnect VSS connector.

  2. Measure resistance between vehicle harness connector terminals V17 and V18. See VIH-to-ECU Connector.

[a] If the resistance measurement is less than or equal to 1,000 [image], the signal wire V17 or return wire V18, are shorted together. Repair the short; refer to Verify Repairs.

[b] If the resistance measurement is greater than 1,000 [image] [image] or open, refer to Check Vehicle Speed Sensor.


TShootVuntitled00000622

 Check Vehicle Speed Sensor

Perform the following steps to check the vehicle speed sensor.

  1. Measure resistance of VSS across vehicle speed sensor connector pins. See VIH-to-ECU Connector.

[a] If the resistance measurement is less than 50 [image], refer to Check Vehicle Speed Sensor Connectors.

[b] If the resistance measurement is greater than 3,000 [image] or open, refer to Check Vehicle Speed Sensor Connectors.

[c] If the resistance measurement is between 50 and 3,000 [image], refer to Check ECU Connectors.


TShootVuntitled00000623

 Check for Open

Perform the following steps to check for open.

  1. Disconnect the ECU vehicle harness connector and VSS connector.

  2. Install a jumper wire between sockets 1 and 2 of the VSS harness connector.

  3. Measure resistance between sockets V17 and V18 on the ECU vehicle harness connector. See VIH-to-ECU Connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check Vehicle Speed Sensor.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the VSS signal line V17 or return line V18 is open. Repair open and refer to Verify Repairs.


TShootVuntitled00000624

 Check for Short to Ground

Perform the following steps to check for short to ground.

  1. Turn ignition OFF.

  2. Remove jumper wire.

  3. Measure resistance between sockets V17 and V18 and a good ground. See VIH-to-ECU Connector.

[a] If the resistance measurement is greater than 1,000 [image] [image] or open, refer to Check for Short to Power.

[b] If the resistance measurement is less than or equal to 1,000 [image], the signal wire V17 or return wire V18, is shorted to ground, or wired to an unauthorized device. Repair the short; refer to Verify Repairs.


TShootVuntitled00000625

 Check Vehicle Speed Sensor Connectors

Perform the following steps to check the VSS connectors.

  1. Check terminals at the VSS connectors (both sensor side and harness side) for bent, corroded, and unseated pins or sockets.

[a] If the terminals and connectors are not damaged, replace the VSS. Refer to Verify Repairs.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000626

 Check for Short to Power

Perform the following steps to check for short to power.

  1. Turn ignition ON.

  2. Measure voltage at the ECU vehicle harness connector between socket V17 and a good ground. Also measure voltage between socket V18 and a good ground. See VIH-to-ECU Connector.

[a] If both voltage measurements are less than 0.2 volts, refer to Check ECU Connectors.

[b] If either voltage measurement is greater than or equal to 0.2 volts, the VSS signal V17 or VSS return line V18 is shorted to the battery or some other source of voltage. Repair the short; refer to Verify Repairs.


TShootVuntitled00000627

 Check ECU Connectors

Perform the following steps to check ECU connectors.

  1. Check the terminals at the ECU engine harness connectors for bent, corroded, and unseated pins or sockets, on both the ECU and harness sides. See VIH-to-ECU Connector.

[a] If the terminals and connectors are not damaged, refer to Vehicle Speed Mechanical Checks.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000628

 Vehicle Speed Mechanical Checks

Perform the following vehicle speed mechanical checks.

  1. Check for plugged fuel filters.

  2. Check if any metal or debris is lodged between the VSS and the pulse wheel.

  3. Check if the sensor is loose.

  4. Ensure the VSS pulse wheel is in fixed position relative to magnetic pickup.

  5. Check for proper air gap between magnetic pickup and pulse wheel.

[a] If all mechanical checks are okay, contact Detroit Diesel Technical Service for review if anti-tamper = yes.

[b] If all mechanical checks are not okay, repair the mechanical failure. Refer to Verify Repairs.


TShootVuntitled00000629

 Check for Short to Ground

Perform the following steps to check for short to ground.

  1. Turn ignition OFF.

  2. Disconnect the ECU vehicle harness connector.

  3. Measure resistance between sockets V17 and a good ground. See VIH-to-ECU Connector.

[a] If the resistance measurement is greater than 10,000 [image] [image] or open, contact the component supplier for instructions. The wiring is okay, but the device may be defective. Refer to Verify Repairs.

[b] If the resistance measurement is less than or equal to 100 [image] [image] the VSS signal lineV17 is shorted to ground, Repair the short; refer to Verify Repairs.


TShootVuntitled00000630

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn the ignition OFF.

  2. Reconnect all the connectors.

  3. Turn the ignition ON.

  4. Clear DDR codes.

  5. Perform a road test with an assistant. Ensure the vehicle is loaded.

  6. Stop the engine.

  7. Check DDR for codes.

[a] If no codes are logged, no further troubleshooting is required.

[b] If code 84/12 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 84/12 is logged, and any other codes are logged, all system diagnostics are complete. To troubleshoot the error, refer to Speed Sensor Identification and perform tasks.


TShootVuntitled00000632

 Check J1939 Data Link

Use the following procedure to troubleshoot Flash Code 55.

Perform the following steps to check for J1939 data link fault.

  1. Is this a J1939 transmission/engine application?

[a] If yes, refer to ECU Code Check or contact Detroit Diesel Technical Service.

[b] If no, use programming station and go to "update customer calibration" and select transmission to manual, or correct transmission. Save changes. Refer to Verify Repairs.


TShootVuntitled00000633

 ECU Code Check

Perform the following steps if code 216/14, missing other ECU displays. This indicates DDEC ECU has lost its connection with other ECU devices and a lost or shorted J1939 data link.

  1. If code 86/14 displays also, there is a fault with the smart cruise. Contact OEM for instructions.

  2. If code 84/12 displays, the fault is with the programming of the ECU, or a short exists to the J1939 data link. Contact OEM for VSS (Vehicle Speed Sensor) troubleshooting.


TShootVuntitled00000634

 Verify Repairs

Perform the following steps to verify repairs.

  1. Start engine.

  2. Plug in DDR.

  3. Read codes.

[a] If active codes 216/14 or 231/12 are not logged, troubleshooting is complete.

[b] If active codes 216/14 or 231/12 are logged, contact Detroit Diesel Technical Service.

Check DDR software level. Update DDR software if current level is 1.2.


TShootVuntitled00000636

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 56.

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Read active codes.

[a] If codes other than 250/12 are logged, service them first.

[b] If code 250/12 is logged, and no other codes are logged, Refer to Clear Codes.

[c] If no data is logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000637

 Clear Codes

Perform the following steps to clear codes.

  1. Clear codes.

  2. Start and run the engine.

  3. Observe AWL/code.

[a] If AWL is on with code 250/12 logged, refer to Check for Devices of Original Equipment Manufacturer.

[b] If no AWL code is logged, refer to Verify Repairs.


TShootVuntitled00000638

 Check for Devices of Original Equipment Manufacturer

Perform the following steps to check for OEM devices.

  1. Turn vehicle ignition OFF.

  2. Determine if any OEM equipment utilizes the J1587 data link. (ABS, ProDriver®, satellite systems, etc.

[a] If any OEM devices are installed, refer to Disconnect Nodes (Data Link Devices). Refer to step 1.

[b] If no OEM devices are installed, refer to Disconnect Nodes (Data Link Devices). Refer to step 2[a].


TShootVuntitled00000639

 Disconnect Nodes (Data Link Devices)

Perform the following steps to disconnect the nodes.

  1. Disconnect OEM installed devices, one at a time e.g. ABS, satellite systems, etc. Verify ABS switch is not in "Test" mode.

[a] If the disconnect does not solve the problem, continue the procedure.

[b] If the disconnect solved the problem, go to 4[b].

  2. Connect vehicle interface module, J 41005.

  3. Start and run the engine.

  4. Observe AWL codes.

[a] If AWL or codes displayed, and the AWL is on with code 250/12 logged, replace the ECU with a test ECU. Refer to Verify Repairs.

[b] If no AWL or codes are displayed, contact OEM for instructions on how to proceed. Refer to Verify Repairs.


TShootVuntitled00000640

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition OFF.

  2. Reconnect all connectors.

  3. Start and run the engine.

[a] If the AWL or codes are displayed, and if code 250/12 is logged, all system diagnostics are complete. Review this section to find the error.

[b] If the AWL or codes are not displayed, troubleshooting is complete.


TShootVuntitled00000646

 Test Alternator Ground

Use the following procedure to troubleshoot Flash Code 61.

Perform the following steps to test alternator ground.

  1. Disable the alternator by removing the alternator belt.

  2. Start and run the engine; warm to greater than 87°F (30°C).

  3. Does the code return?

[a] If Flash Code 61 does not return, repair or replace the alternator grounds and refer to Verify Repairs.

[b] If the code(s) return, refer to Determine Cylinders With Fault.


TShootVuntitled00000647

 Determine Cylinders With Fault

The injector location that is logging the codes is listed in the following table.

#1
         #2
         #3
         #4
         #5
         #6

(SID 1)
         (SID 2)
         (SID 3)
         (SID 4)
         (SID 5)
         (SID 6)
S55/60

5
         3
         6

4
cyl #

S50

3
         4

-
         -
cyl #

  1. Disconnect the engine harness connector at the ECU for those injectors logging the codes.

  2. Establish a good ECU case ground by measuring the resistance across two points on the ECU. The resistance should measure less than or equal to 1 .

  3. Once a good case ground is established, keep one of the measurement probes in place and move the other probe to one of the five exposed male injector terminals on the ECU.

  4. Measure the resistance. Repeat this procedure at each of the five terminals.

[a] If any terminals have a resistance of less than 1,000 [image], replace the ECU. Refer to Verify Repairs.

[b] If all terminals have a resistance of greater than 1,000 [image], refer to Check for Short.


TShootVuntitled00000648

 Check for Short

Perform the following steps to check for a short.

  1. Disconnect the injector harness 10 pin connector and locate the terminals associated with the codes. See Injector Harness.

  2. Measure resistance between that cavity and the cylinder block on both sides of the 10 pin connector.

[a] If measured resistance is less than 10 [image], the wire is shorted to the engine. Repair or replace the harness and refer to Verify Repairs.

[b] If measured resistance is greater than 10 [image], go to step 3.

  3. Measure resistance between the 10 pin connector side and between the cavity logging the code and the return wire.

[a] If the measured resistance is less than 5 [image] [image] the wire is shorted to the return. Replace the harness between the 10 pin connector and the ECU. Refer to Verify Repairs.

[b] If the measured resistance is greater than 5 [image] [image] go to step 4.

  4. Remove the valve cover to gain access to the cylinder associated with the code.

  5. Remove the connector terminals at the injector solenoid(s).

  6. Measure resistance between that cavity and the appropriate return cavity (E61 or E62).

[a] If measured resistance is less than 5 [image] [image] the wire is shorted to the return wire. Repair or replace the harness and refer to Verify Repairs.

[b] If measured resistance is greater than 5 [image] [image] refer to Check for Open.


TShootVuntitled00000649

 Check for Open

Perform the following steps to check for an open.

  1. Insert a jumper wire between the cavity associated with the code and the return for that connector (E61 or E62).

  2. Measure resistance across the injector connectors (disconnected from injector solenoid).

[a] If the measured resistance is greater than 5 [image] [image] the injector wire is open. Repair or replace the harness and refer to Verify Repairs.

[b] If the measured resistance is less than 5 [image] [image] try a test ECU.Refer to Verify Repairs.

[c] If the measured resistance is less than 5 [image] [image] and the ECU was replaced, replace the injector.


TShootVuntitled00000650

 Verify Repairs

Perform the following steps to verify repairs:

  1. Start and run the engine. Warm to 87°F (30°C).

  2. Check DDR for codes.

[a] If injector codes are logged, please review this section from the first step to find the problem - refer to Determine Cylinders With Fault.

[b] If no codes are logged, no further troubleshooting is required.


TShootVuntitled00000652

 Code Check

Use the following procedure to troubleshoot Flash Code 62.

Perform the following steps to check for codes.

  1. Turn vehicle ignition ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Record codes logged.

  4. Clear codes.

  5. Start and run the engine for one minute.

[a] If the code becomes active, refer to Auxiliary Output Cavity Determination.

[b] If the code does not become active, refer to Intermittent Code Check.


TShootVuntitled00000653

 Intermittent Code Check

Perform the following steps to check intermittent codes.

  1. Perform road test.

[a] If the code returns, refer to Auxiliary Output Cavity Determination.

[b] If the code does not display again, return the vehicle to service, or refer to INTERMITTENT CODE OR A SYMPTOM AND NO CODES.


TShootVuntitled00000654

 Auxiliary Output Cavity Determination

Perform the following steps to determine which auxiliary output cavity is associated with the logged codes.

  1. Determine which auxiliary output cavity is associated with the code or codes being logged. The SAE code descriptions of the flash codes and the DDC wire numbers are listed in the following table. Continue troubleshooting. Refer to Electrical Check.

SAE Code Description - Flash Code | Cavity
Auxiliary Output #1 (026 3 or 026 4) 62 | V4)*
Auxiliary Output #2 (040 3 or 040 4) 62 | V5)
Auxiliary Output #5 (053 3 or 053 4) 62 | V6 †
Auxiliary Output #6 (054 3 or 053 4) 62 | V7
Auxiliary Output #7 (055 3 or 055 4) 62 | V40
Auxiliary Output #8 (056 3 or 056 4) 62 | V53
Auxiliary Output #9 (051 3 or 057 4) 62 | V54
Auxiliary Output #10 (058 3 or 058 4) 62 | V55
Auxiliary Output #11 (059 3 or 059 4) 62 | E13
Auxiliary Output #12 (060 3 or 060 4) 62 |
Auxiliary Output #13 (061 3 or 061 4) 62 | E47
Auxiliary Output #14 (062 3 or 062 4) 62 | E50
Auxiliary Output #15 (063 3 or 063 4) 62 | E51
Auxiliary Output #16 (064 3 or 064 4) 62 | E52
Auxiliary Output #17 (065 3 or 065 4) 62 | E53
  • Vehicle Interface Harness

† Engine Sensor Harness


TShootVuntitled00000655

 Electrical Check

Perform the following steps to check connectors, dash light or vehicle power-down relay, or item being driven.

  1. Check the connectors of the output wire associated with the code logged at the vehicle harness connector or engine sensor harness connector.

  2. Check the connectors of the output wire associated with the code logged at the item being driven.

[a] If the connectors are not good, repair or replace the terminals. Refer to Verify Repairs.

[b] If the connectors are good and the items being driven (e.g. relay, light) are not in good condition, repair or replace the device. (Contact OEM for test procedure.) Refer to Verify Repairs.

[c] If the connectors are good and the items being driven (e.g. relay, light, are in good condition, refer to Measure Resistance.


TShootVuntitled00000656

 Measure Resistance

Perform the following steps to measure the resistance.

  1. Turn ignition OFF.

  2. Connect the engine sensor harness or vehicle interface harness (connector with output fault).

  3. Disconnect the output wire associated with the code logged at the component.

  4. Measure the resistance between the removed connector and the ECU case.

[a] If the reading is less than 100 K [image], contact Detroit Diesel Technical Service.

[b] If the reading is greater than 100 K [image], this wire is shorted to the battery or open. Repair or replace this wire. Refer to Verify Repairs.


TShootVuntitled00000657

 Verify Repairs

Perform the following steps to verify repairs.

  1. Reconnect all connectors.

  2. Plug DDR into the connector.

  3. Clear all codes.

  4. Start and run the engine.

[a] If the output code returns, refer to Code Check.

[b] If the output code does not return, troubleshooting is complete.


TShootVuntitled00000659

 Determine Assignment

Use the following procedure to troubleshoot Flash Code 63.

For all EGR related codes, always perform the basic checks in the Exhaust Gas Recirculation System Basic Checks For Series 60 Engines section.

Perform the following steps to determine assignment.

  1. Turn ignition ON.

  2. Plug in the DDR.

  3. Select INs/OUTs. To what is PWM assigned? Write down assignment vs cavity and code, listed in the table below.

Code | PWM | Wire Location/Wire Number
s 057 | PWM #1 | V52
s 058 | PWM #2 | V46
s 059 | PWM #3 | E01
s 060 | PWM #4 | E04
s 267 | PWM #5 | E08
s 268 | PWM #6 | E11
  4. Select code display.

  5. Determine Failure Mode Identifier (FMI).

[a] If FMI 3 displays, there is a short to the battery. Refer to Verify Short to Battery.

[b] If FMI 4 displays, refer to step 6.

[c] If the FMI is 0, 1, or 7, call Detroit Diesel Technical Service.

  6. Verify function.

[a] If there is a component wired to this position, refer to Check Component Connections.

[b] If there is no component wired to this position, reprogram to eliminate the assigned function. (A change may be required to the DDC mainframe.) Refer to Verify Repairs.


TShootVuntitled00000660

 Verify Short to Battery

Perform the following steps to verify a short to battery:

  1. Turn ignition OFF.

  2. Disconnect the vehicle connector: if PWM 1 or 2; engine connector if PWM 3, 4, 5 or 6.

  3. Measure voltage between the cavity with the code and the good ground.

[a] If the voltage measurement is greater than 3 volts, the connector is shorted to the battery. Repair. Refer to Verify Repairs.

[b] If the voltage measurement is less than 3 volts, contact Detroit Diesel Technical Service.


TShootVuntitled00000661

 Check Component Connections

Perform the following steps to check component connections:

  1. Turn the vehicle ignition switch to the OFF position.

  2. Inspect the connections of the PWM wire associated with the flash code logged at both harness connector and the item being driven.

[a] If the connectors are damaged or broken, repair or replace the damaged terminals. Verify Repairs.

[b] If the connectors are not damaged or broken, ensure the item is connected to the pulse width modulation wire. If the item is not connected, repair or replace the connector. Verify Repairs.

[c] If the item is connected, measure the resistance. Refer to Measure Resistance Between Connector and the ECU Case.


TShootVuntitled00000662

 Measure Resistance Between Connector and the ECU Case

Perform the following steps to measure resistance between the connector and the ECU case:

  1. Turn the vehicle ignition to the OFF position.

  2. Ensure connector is installed on the engine harness side or vehicle harness side.

  3. Disconnect the PWM wire associated with the code logged at the component.

  4. Measure the resistance between the removed connector and the ECU case.

[a] If the resistance measurement is les than 100 K [image], verify the pin assignment with wiring - view with DDR. Refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 K [image], the wire is open or shorted to battery. Repair or replace the wire. Verify Repairs.


TShootVuntitled00000663

 Verify Repairs

Perform the following steps to verify repairs for Flash Code 63.

  1. Reconnect all connectors.

  2. Clear all codes from the DDR.

  3. Plug in the DDR.

  4. Turn vehicle ignition switch to the ON position.

[a] If Flash Code 63 was not logged, no further troubleshooting is required.

[b] If Flash Code 63 was logged, please review this section from the first step to find the error - refer to Determine Assignment.


TShootVuntitled00000665

 Turbocharger Overspeed Check

Use the following procedure to troubleshoot Flash Code 64.

Perform the following steps to check for turbocharger overspeed:

  1. Disconnect turbo speed sensor connector.

  2. Measure resistance between cavity 2 and battery ground. See Turbo Speed Sensor Wiring.

[a] If the resistance measurement is greater than or equal to 5 [image] [image] replace the sensor. Verify Repair.

[b] If the resistance measurement is less than 5 [image] [image] replace the wire. Verify Repair.


TShootVuntitled00000666

 Verify Repair

Perform the following steps to verify repairs for the EGR valve:

  1. Connect all connectors.

  2. Start and run the engine.

  3. Road test the engine.

[a] If code 64 was not logged, no further troubleshooting is required.

[b] If code 64 was logged, please review this section starting with EGR-1 - refer to EXHAUST GAS RECIRCULATION SYSTEM BASIC CHECKS FOR SERIES 60 ENGINES. Then call Detroit Diesel Technical Service, or try a test ECU.

[c] If checks passed in refer to EXHAUST GAS RECIRCULATION SYSTEM BASIC CHECKS FOR SERIES 60 ENGINES for the VPOD test, no further troubleshooting is required.

[d] If checks were not performed (refer to EXHAUST GAS RECIRCULATION SYSTEM BASIC CHECKS FOR SERIES 60 ENGINES), perform those checks first.


TShootVuntitled00000668

 AIR FILTER RESTRICTION SENSOR

Use the following procedure for diesel engine troubleshooting of Flash Code 65, 107/3, AFRS (Air Filter Restriction Sensor) failed high; and 107/4, AFRS failed low:

Multiple Code Check

Perform the following steps to check for multiple codes.

  1. Turn vehicle ignition switch ON.

  2. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  3. Read active codes.

[a] If code 107/3 and no other codes were logged, refer to Sensor Check.

[b] If code 107/4 or any other codes were logged, refer to Multiple Code Check.


TShootVuntitled00000669

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition switch OFF.

  2. Disconnect AFRS (Air Filter Restriction Sensor) connector. See Air Filter Restriction Sensor Wiring Diagram.

  3. Turn ignition ON.

  4. Start and run the engine.

  5. Select engine temperature (COOLANT TEMP or OIL TEMP) on the DDR.

  6. Warm up engine until engine temperature reading is greater than 60°C (140°F).

  7. After warm-up, let engine run at idle.

  8. Read active codes.

[a] If active code 107/3 and any other codes were logged, refer to Check for Signal Short to 5 Volt.

[b] If code 107/4 and any other codes except 107/3 were logged, refer to Return Circuit Check.


TShootVuntitled00000670

 Return Circuit Check

Perform the following steps to check the return circuit.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Install a jumper wire between pin A and pin B of the AFRS harness connector. See Engine Harness Connector to Air Filter Restriction Sensor.

  4. Measure resistance between sockets V22 and V60 on the engine harness connector.

[a] If resistance measurement is less than or equal to 5 [image] [image] refer to Check Air Filter Sensor Connectors.

[b] If resistance measurement is greater than 5 [image] [image] the return line (V60) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000671

 Check Air Filter Sensor Connectors

Perform the following steps to check the AFRS connectors.

  1. Check terminals at the AFRS connectors (both the sensor and harness side) for damage:

bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the AFRS. Refer to Verify Repairs.


TShootVuntitled00000672

 Check for Signal Short to 5 Volt

Perform the following steps to check for signal open.

  1. Turn vehicle ignition OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Measure resistance between sockets V22 and V11 on the engine harness connector. See ECU Engine Harness Connector.

[a] If the resistance measurement is less than or equal to 100 [image] [image] the signal line (V22) is shorted to the engine +5 volt line (V11). Repair the short and refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] [image] or open, refer to Check for Short to Battery (+).


TShootVuntitled00000673

 Check for Short to Battery (+)

Perform the following steps to check for a short to battery (+).

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness at the ECU. See ECU Vehicle Harness Connector.

  3. Measure resistance between socket V20 on the engine harness connector and sockets V61

and V65 of the vehicle harness connector.

[a] If resistance measurement is greater than 100 [image] [image] or open, refer to Check ECU Connector.

[b] If resistance measurement is less than or equal to 100 [image] [image] a short exists between sockets where less than 100 [image] resistance was read. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000674

 Check ECU Connector

Perform the following steps to check the ECU connector:

  1. Inspect the terminals at the ECU connector (ECU and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If the terminals and connector are damaged, repair both and refer to Verify Repairs.

[b] If the terminals and connector are not damaged, refer to Check Air Filter Sensor Connectors.


TShootVuntitled00000675

 Verify Repairs

Perform the following steps to verify repairs:

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check codes with DDR.

[a] If no codes are logged, no further troubleshooting is required.

[b] If code 107/3 is not logged, but other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 107/3 is logged, all system diagnostics are complete. Contact Detroit Diesel Technical Service.


TShootVuntitled00000676

 Multiple Code Check

Perform the following steps to check for multiple codes.

  1. Plug the diagnostic data reader (DDR) into the diagnostic data link (DDL).

  2. Turn vehicle ignition switch ON.

  3. Read active codes.

[a] If code 107/4 and no other codes were logged, refer to Sensor Check.

[b] If code 107/4 was logged and none of the following codes were logged: 110/3 or 4, 174/3 or 4, 175/3 or 4, 101/3 or 4, 102/3 or 4, 73/3 or 4, 94/3 or 4, 100/3, refer to Sensor Check.

[c] If code 107/4 and any of the following codes were logged: 110/3 or 4, 174/3 or 4, 175/3 or 4, 101/3 or 4, 102/3 or 4, 73/3 or 4, 94/3 or 4, 100/3, refer to ENGINE SENSOR HARNESS.


TShootVuntitled00000677

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition switch OFF.

  2. Disconnect AFRS connector and install a jumper wire between sockets B and C of the AFRS harness connector. See Engine Harness Connector to Air Filter Restriction Sensor.

  3. Turn ignition ON.

  4. Read active codes.

  5. If active codes 107/3 or 4 were logged, proceed with the following:

[a] If active code 107/4 and any other codes were logged, refer to Check for +5 Volts.

[b] If code 107/3 and any other codes except 107/4 were logged, refer to Check Air Filter Sensor Connectors.

  6. If active codes 107/3 or 4 were not logged, warm up engine until either codes are logged or the engine temperature (COOLANT TEMP or OIL TEMP or DDR) has been greater than 60°C (140°F) for one minute.

[a] If active code 107/4 and any other codes were logged, refer to Check for +5 Volts.

[b] If code 107/3 and any other codes except 107/4 were logged, refer to Check Air Filter Sensor Connectors.


TShootVuntitled00000678

 Check Air Filter Sensor Connectors

Perform the following steps to check the AFRS connectors.

  1. Turn ignition OFF.

  2. Check terminals at the AFRS connectors (both the sensor and harness side) for damage: bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the AFRS. Refer to Verify Repairs.


TShootVuntitled00000679

 Check for +5 Volts

Perform the following steps to check for +5 volts.

  1. Turn vehicle ignition OFF.

  2. Remove jumper wire.

  3. Turn ignition ON.

  4. Measure voltage on AFRS harness connector, socket C (red test lead) to socket A (black test lead).

[a] If the voltage measurement is less than 4 volts, refer to Check for Open +5 Volt Line.

[b] If the voltage measurement is greater than 6 volts, refer to Check for Short to Battery +.

[c] If the voltage measurement is between 4 and 6 volts, refer to Check for Signal Open.


TShootVuntitled00000680

 Check for Signal Open

Perform the following steps to check for signal open.

  1. Turn the ignition OFF.

  2. Disconnect the engine harness connector at the ECU. See Engine Harness Connector to Air Filter Restriction Sensor.

  3. Install a jumper wire between sockets A and B of the AFRS harness connector.

  4. Measure resistance between sockets V22 and V60 on the engine harness connectors.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short to Ground.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the signal line (V22) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000681

 Check for Short

Perform the following steps to check for a short.

  1. Remove jumper wire.

  2. Measure resistance between socket V22 and a good ground. Also measure resistance between V22 and V60.

[a] If both resistance measurements are greater than 100 [image] or open, replace AFRS. Refer to Verify Repairs.

[b] If either resistance measurement is less than 100 [image] [image] the signal line (V22) is shorted to the return line (V60) or battery ground. Repair short and refer to Verify Repairs.


TShootVuntitled00000682

 Check ECU Connectors

Perform the following steps to check ECU connectors.

  1. Check terminals at the ECU harness connector (both ECU and harness side) for damage: bent, corroded and unseated pins or sockets. Check V11, V22 and V60 terminals and pins at ECU.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, reprogram the ECU. Refer to Verify Repairs.


TShootVuntitled00000683

 Check for Open +5 Volt Line

Perform the following steps to check for open +5 volt line.

  1. Turn ignition OFF.

  2. Disconnect the engine harness connectors at the ECU.

  3. Install a jumper wire between pins A and C of the AFRS connector.

  4. Measure resistance between sockets V11 and V60 on the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the engine +5 volt line (V11) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000684

 Check for Short

Perform the following steps to check for a short.

  1. Remove jumper wire.

  2. Measure resistance between sockets A and C on the AFRS harness connector. Also measure resistance between socket C and a good ground.

[a] If either resistance measurement is less than or equal to 100 [image] [image] the engine +5 volt line (V11) is shorted to the return line (V60) or battery ground. Repair the short and refer to Verify Repairs.

[b] If the resistance measurement is greater than 100 [image] or open, replace AFRS and refer to Verify Repairs.


TShootVuntitled00000685

 Check for Short to Battery +

Perform the following steps to check for a short to battery.

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness at the ECU. See ECU Vehicle Harness Connector.

  3. Measure resistance between socket V11 on the vehicle harness connector and socket V61 and V65 of the vehicle harness connector and between V11 and V15.

[a] If resistance measurement is greater than 100 [image] [image] or open, replace AFRS. Refer to Verify Repairs.

[b] If resistance measurement is less than or equal to 100 [image] [image] a short exists between sockets where less than 100 [image] resistance was read. Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000686

 Check for Short to Ground

Perform the following steps to check for a short to ground.

  1. Turn vehicle ignition OFF.

  2. Remove jumper wire.

  3. Measure resistance between sockets V22 and V60 on the engine harness connector. See Engine Harness Connector to Air Filter Restriction Sensor.

[a] If resistance measurement is greater than 100 [image] [image] or open, refer to Check for Short.

[b] If resistance measurement is less than or equal to 100 [image] [image] the signal line (V22) and return line (V60) are shorted together. Repair the short. Refer to Verify Repairs.


TShootVuntitled00000687

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 107/4 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.

[c] If code 107/4 is logged, and other codes are logged, all system diagnostics are complete. Please review this section from the first step to find the error - refer to Multiple Code Check. If no error is located, refer to Check ECU Connectors.


TShootVuntitled00000691

 Check for Idle Validation Switch Code

Use the following procedure to troubleshoot Flash Code 68.

Perform the following steps to check for IVS active code:

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Cycle foot pedal; then read codes.

[a] If the IVS code is open (FMI=5), validate the throttle pedal application. Refer to Check for Throttle Pedal Application.

[b] If the IVS code is grounded (FMI=6), check the IVS switch. Refer to Check the Idle Validation Switch.


TShootVuntitled00000692

 Check the Idle Validation Switch

Perform the following step to check the idle validation switch:

  1. Turn the vehicle ignition switch to the ON position.

To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked
  2. Start and run the engine.

NOTE: Vehicle need not be moving to perform this check.

  3. Plug in DDR.

  4. Compare idle validation switch input status (switch light status) with the throttle position sensor counts.

[a] If the IVS status is ON with the TPS count being greater than 282, measure for resistance. Refer to Check Resistance Between Idle Validation Switch Contacts.

[b] If the IVS status is OFF with the TPS count being greater than 282, clear inactive codes. No further troubleshooting is required. Refer to Verify Repairs.


TShootVuntitled00000693

 Check Resistance Between Idle Validation Switch Contacts

Perform the following steps to measure resistance:

  1. Turn vehicle ignition to the ON position. Refer to OEM guidelines.

  2. Move TPS so counts are greater than 285.

  3. Measure resistance between the ECU input V16 at the TPS and V59 using a volt-ohm meter.

[a] If the resistance was less than 100 [image] [image] the idle validation input/switch is grounded or defective. Contact OEM for repair procedure. Refer to Verify Repairs.

[b] If the resistance was greater than 100 [image] [image] the fault condition no longer exists. No further troubleshooting is required. Refer to Verify Repairs.


TShootVuntitled00000694

 Check for Throttle Pedal Application

Perform the following steps to determine which type of TPS is being used:

  1. Visually check to determine which throttle pedal has been installed that utilizes the IVS function.

[a] If the throttle pedal has an idle validation switch installed, verify TPS count. Refer to Determine Throttle Position Sensor Counts / Idle Validation.

[b] If the throttle pedal has no idle validation switch installed, update customer calibration using a programming station. Change the settings from idle validation to "No Function" and save changes. Verify Repairs.


TShootVuntitled00000695

 Determine Throttle Position Sensor Counts / Idle Validation

Switch Status

Perform the following steps to determine TPS counts:

  1. Turn vehicle ignition to the ON position. Refer to OEM guidelines.

To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked.
  2. Plug in DDR.

NOTE: Vehicle need not be moving to determine TPS counts.

  3. Compare idle validation switch status (switch light status) with the throttle position sensor counts.

[a] If the IVS input is ON with the TPS count being less than 120, the problem no longer exists. Refer to Verify Repairs.

[b] If the IVS input is OFF with the TPS count being less than 120, refer to Check Resistance Between Idle Validation Switch Contacts.


TShootVuntitled00000696

 Check Resistance Between Idle Validation Switch Contacts

Perform the following steps to determine resistance:

  1. Turn vehicle ignition switch to the ON position.

  2. Measure resistance between the ECU input at the TPS/IVS end of the harness and battery ground.

[a] If the resistance is less than 100 [image] [image] the IVS is defective. Replace the switch. (Contact the OEM for procedure.) Verify Repairs.

[b] If the resistance is greater than 100 [image] [image] either the IVS input or V59 wire is open; repair the open. Verify Repairs.


TShootVuntitled00000697

 Verify Repairs

Perform the following steps to verify repairs:

  1. Clear inactive codes.

To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked.
  2. Start and run the engine.

  3. Depress foot pedal to at least half throttle (> 290 counts).

  4. Release foot pedal and allow the engine to idle.

  5. Visually observe the check engine light (AWL) and DDR.

[a] If the AWL comes on, no further troubleshooting is required.

[b] If code 68 is logged, refer to Check for Idle Validation Switch Code to troubleshoot Flash Code 68 again.


TShootVuntitled00000701

 Determine Cylinders With Fault

Use the following procedure to troubleshoot Flash Code 71.

The injector location that is logging the codes is listed in the following Table.

#1
         #2
         #3
         #4
         #5
         #6

(SID 1)
         (SID 2)
         (SID 3)
         (SID 4)
         (SID 5)
         (SID 6)
S55/60

5
         3
         6

4
         cyl #
S50

3
         4

-
         -
         cyl #
  1. Disconnect the 5-pin injector harness connector at the ECU for those injectors logging the codes.

  2. Establish a good ECU case ground by measuring the resistance across two points on the ECU. The resistance should measure less than or equal to 1 .

  3. Once a good case ground is established, keep one of the measurement probes in place and move the other probe to one of the five exposed male injector terminals on the ECU.

  4. Measure the resistance. Repeat this procedure at each of the five terminals.

[a] If any terminals have a resistance of less than 1000 [image], replace the ECU. Refer to Verify Repairs.

[b] If all terminals have a resistance of greater than 1000 [image], refer to Check for Short.


TShootVuntitled00000702

 Check for Short

Perform the following steps to check for a short. See Injector Harness.

  1. Locate the injector harness connector terminals associated with the codes.

  2. Measure resistance between those cavities and the cylinder block.

  3. Also, measure resistance between that cavity and the appropriate return cavity (G or E).

[a] If measured resistance is less than 5 [image] [image] the wire is shorted. Repair or replace the harness and refer to Verify Repairs.

[b] If measured resistance is greater than 5 [image] [image] refer to Check for Open.


TShootVuntitled00000703

 Check for Open

Perform the following steps to check for an open.

  1. Insert a jumper wire between the cavity associated with the code and the return for that connector (V61 and V62).

  2. Remove the valve cover to gain access to the cylinder associated with the code.

  3. Remove the connector terminals at the injector solenoid.

  4. Measure resistance between the terminal plugs.

[a] If the measured resistance is greater than 5 [image] [image] the injector wire is open. Repair or replace the harness and refer to Verify Repairs.

[b] If the measured resistance is less than 5 [image] [image] and the ECU software is less than 3.00, reprogram the ECU. Refer to Verify Repairs.

[c] If the measured resistance is less than 5 [image] [image] and the ECU software is 3.00 or higher, remove the alternator belt to disable the alternator and refer to Assemble.


TShootVuntitled00000704

 Assemble

Perform the following steps to assemble the components.

  1. Connect the connectors.

  2. Install the valve cover.

  3. Start and run the engine.

  4. Stop engine.

  5. Does the code return?

[a] If the code does not return, repair or replace the alternator grounds and refer to Verify Repairs.

[b] If the codes return, replace the injector and solenoid. Refer to Verify Repairs.


TShootVuntitled00000705

 Verify Repairs

Perform the following steps to verify repairs:

  1. Start and run the engine.

  2. Stop engine.

  3. Check DDR for codes.

[a] If no codes are logged, no further troubleshooting is required.

[b] If injector codes are logged, all system diagnostics are complete. Please review this section from the first step to find the error - refer to Determine Cylinders With Fault.


TShootVuntitled00000707

 Overspeed

Use the following procedure to troubleshoot Flash Code 72.

Perform the following steps to troubleshoot overspeed.

  1. These codes indicate the vehicle speed has exceeded the limits programmed into the ECU. Verify cruise control and VSS information.

[a] Code 84/0 - Overspeed with fuel limit has been exceeded.

[b] Code 84/11 - Overspeed without fuel limit has been exceeded.

  2. Limits are a reasonable distance above the road speed limit.

[a] If the limits are a reasonable distance, go to step 3.

[b] If the limits are not a reasonable distance above the road speed limit, change the limits and perform the test - refer to Test.

NOTE: For information regarding overspeed limits, refer to Vehicle Overspeed Parameters.

  3. Fuel Economy Incentive feature configured recently.

[a] If configured recently, review the limits. W/FEI limits may need to be increased.

[b] If not configured recently, the conditions are normal. The vehicle has exceeded speed limits set.


TShootVuntitled00000708

 Test

Perform the following steps to troubleshoot overspeed.

  1. Start and run the engine.

  2. Perform a road test.

[a] If the overspeed condition has disappeared, troubleshooting is complete.

[b] If the overspeed condition still exists, review this section from the beginning to find the error. Refer to Overspeed.


TShootVuntitled00000710

 Air Filter Restriction High

Use the following procedure to troubleshoot Flash Code 73 for diesel engines.

Perform the following steps to determine the SAE code.

  1. Plug in DDR.

  2. Turn ignition ON.

  3. Record logged codes.

[a] If code 107/0 is logged, service the air inlet system (typically, change the air filter).


TShootVuntitled00000712

 Check Diagnostic Data Reader for Codes

Use the following procedure to troubleshoot Flash Code 74.

For system overview, see Optimized Idle Schematic.

Perform the following steps to check the DDR for codes:

  1. Turn the vehicle ignition switch ON.

  2. Plug the DDR into the diagnostic data link (DDL).

  3. Check the DDR for active and inactive optimized idle codes.

NOTE: Service any other logged codes first.

  4. Visually examine the DDR for code 74.

[a] If code 74 was logged, check for short to ground. Refer to Check for Short to Ground.

[b] If code 74 was not logged, verify fault has been resolved. Refer to Verify Repairs.


TShootVuntitled00000713

 Check for Short to Ground

Perform the following steps to check for short to ground:

  1. Open the vehicle hood. Refer to OEM guidelines.

  2. Turn the vehicle ignition switch to the ON position.

  3. Plug the DDR into the DDL.

NOTE: The DDR may already be installed.

  4. Select the switch/light status (park brake/ISD).

  5. Verify the switch/light status (park brake/ISD).

[a] If the park brake status is not ON, refer to Check for Short to Ground, Continued.

[b] If the park brake status is ON, the input wire is shorted to ground between the hood switch and the ECU. Repair or replace the wire. Verify fault has been resolved. Refer to Verify Repairs.


TShootVuntitled00000714

 Check for Short to Ground, Continued

Perform the following steps to check for short to ground:

  1. Close the vehicle hood. Refer to OEM guidelines.

  2. Put the transmission in gear. Refer to OEM guidelines.

  3. Verify the switch/light status (park brake).

[a] If the park brake status is not ON, continue checking for a short to ground. Refer to Check for Short to Ground, Continued.

[b] If the park brake status is ON, the input wire is shorted to ground between the hood switch and the neutral switch. Repair or replace the wire. Verify fault has been resolved. Refer to Verify Repairs.


TShootVuntitled00000715

 Check for Short to Ground, Continued

Perform the following steps to continue checking for a short to ground:

  1. Put the transmission in neutral. Refer to OEM guidelines.

  2. Ensure the parking brake is not set. Refer to OEM guidelines.

  3. Verify the switch/light status (park brake/ISD).

[a] If the park brake/ISD status is not ON, check for vehicle speed. Refer to Check Vehicle Speed.

[b] If the park brake/ISD status is ON, the input wire is shorted to ground between the park brake switch and the neutral switch. Repair or replace the wire. Refer to FLASH CODE 54 - VSS FAULT. Verify fault has been resolved. Refer to Verify Repairs.


TShootVuntitled00000716

 Check Vehicle Speed

Perform the following steps to check vehicle speed:

To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked
  1. Start engine with vehicle in park. Refer to OEM guidelines.

  2. Plug the DDR into the DDL.

  3. View ECU data list (vehicle speed in mile/h or km/h).

  4. Increase engine r/min.

  5. Verify vehicle speed.

[a] If vehicle speed did not vary, verify fault has been resolved. Refer to Verify Repairs.

[b] If vehicle speed did vary or was ever greater than 0 r/min, perform flash code 54 troubleshooting. Refer to FLASH CODE 54 - VSS FAULT. Upon completion of repair, verify fault has been resolved. Refer to Verify Repairs.


TShootVuntitled00000717

 Verify Repairs

Perform the following steps to verify repairs for flash code 74.

  1. Turn vehicle ignition to the OFF position.

  2. Reconnect all connectors.

  3. Close vehicle hood. Refer to OEM guidelines.

  4. Set the park brake. Refer to OEM guidelines.

  5. Put the transmission in neutral position. Refer to OEM guidelines.

To avoid injury before starting and running the engine, ensure the vehicle is parked on a level surface, parking brake is set, and the wheels are blocked
  6. Start the engine.

  7. Turn the cruise master switch to the ON position.

NOTE: If the switch was set to the ON position before the vehicle was started, turn the switch to the OFF position and then to the ON position.

  8. Wait for the engine to shut down.

NOTE: After the idle timer expires, the engine will either shut down or continue to run to charge the battery or keep the oil temperature between 16°C (60°F) and 40°C (104°F).

  9. Turn the thermostat on (if installed).

  10. Adjust the set point and heating and cooling mode until the thermostat requires the engine to start.

NOTE: If the thermostat is not installed, wait for the lube oil temperature to fall below 16°C (60°F).

NOTE: The alarm will sound and the engine will start. Vehicle power (blower fans) will turn on approximately 30 seconds after the engine starts, due to the thermostat.

  11. Verify that optimized idle operates properly.

[a] If optimized idle is not operating properly, refer to Check Diagnostic Data Reader for Codes to troubleshoot code 74.

[b] If optimized idle is operating correctly, troubleshooting is complete.


TShootVuntitled00000719

 High Voltage

Use the following procedure to troubleshoot Flash Code 75.

Perform the following steps to troubleshoot high voltage.

  1. Turn ignition ON.

  2. Plug in the diagnostic data reader (DDR).

  3. Read logged codes.

[a] If any codes other than 168/0 are received, service the other codes first.

[b] If code 168/0 and no other codes are logged, the voltage to the ECU is too high.

Check batteries and/or vehicle charging system.

[c] If code 211/0 is logged, refer to VEHICLE HARNESS.

[d] If code 232/0 is logged, refer to ENGINE SENSOR HARNESS.

NOTE: Also indicates the sensor supply voltage is too high.


TShootVuntitled00000722

 Exhaust Back Pressure Fault

Follow these steps to troubleshoot an exhaust back pressure fault:

  1. If code 81/3 displays, refer to Exhaust Back Pressure Failed High.

  2. If code 81/4 displays, refer to Exhaust Back Pressure Sensor (BPS) Failed Low.


TShootVuntitled00000723

 Exhaust Back Pressure Failed High

Follow these steps to troubleshoot exhaust back pressure failed high:

  1. Disconnect exhaust back pressure sensor.

  2. Start and run the engine.

  3. Check codes displayed.

[a] If code 81/3 displays, refer to Check for Short to +5 Line.

[b] If code 81/4 displays, refer to Check Connectors.


TShootVuntitled00000724

 Check for Short to +5 Line

Follow these steps to check for a short to the +5 volt line:

  1. Unplug the ECU vehicle connector.

  2. Measure resistance between cavities B and C.

[a] If the resistance measures greater than 5 [image] [image] refer to Check for Open.

[b] If the resistance measures less than 5 [image] [image] wire #916 is shorted to #510. Repair the short and test.


TShootVuntitled00000725

 Check for Open

Perform the following steps to check for open:

  1. Install jumper between cavities V60 and V11.

  2. Measure resistance between cavities A and B of the BPS connector.

[a] If measured resistance is less than 50 [image], refer to Check Connectors.

[b] If measured resistance is greater than 50 [image], wire V60 is open. Repair the open and test.


TShootVuntitled00000726

 Check Connectors

Perform the following steps to check the connectors:

  1. If connectors are not damaged, replace the Backpressure Sensor. Test.

  2. If the connectors are corroded, bent, or damaged, repair or replace them. Test.


TShootVuntitled00000727

 Exhaust Back Pressure Sensor (BPS) Failed Low

Perform the following steps to troubleshoot this condition:

  1. Unplug BPS.

  2. Install a jumper cable between cavities A and B.

  3. Start engine.

[a] If code 81/3 displays, refer to Check for Short.

[b] If code 81/4 displays, wire #510 is open. Repair the open and test.


TShootVuntitled00000728

 Check for Short

  1. Remove jumper cable.

  2. Measure continuity between cavities A and C.

[a] If measured continuity is greater than 50 [image], refer to Check Connectors.

[b] If measured continuity is less than 50 [image], wire V29 is shorted to wire V60. Repair the short and test.


TShootVuntitled00000729

 Check Connectors

Perform the following steps to check the connectors:

  1. If connectors are not damaged, replace the Back Pressure Sensor. Test.

  2. If the connectors are corroded, bent, or damaged, repair or replace them. Test.


TShootVuntitled00000734

 Check for Open

Perform the following steps to check for an open.

  1. Unplug the engine sensor harness connector.

  2. Unplug the EGR Delta-Pressure sensor.

  3. Install a jumper wire between cavities E15 and E38 at the engine sensor connector. See EGR Delta-Pressure Sensor Wiring.

  4. Measure resistance between cavity 2 [image] and 3 [image]. See EGR Delta-Pressure Sensor Wiring.

[a] If the resistance measurement is less than or equal to 5 , Refer to section Check for Short.

[b] If the resistance measurement is greater than 5 , circuit E15 is open. Repair and Verify Repair.


TShootVuntitled00000735

 Check for Short

Perform the following steps to check for short.

  1. Remove the jumper wire.

  2. Measure resistance between E12 and E38. See EGR Delta-Pressure Sensor Wiring.

[a] If the resistance measurement is less than 1.5 k [image], circuit E12 is shorted to E38.Repair and verify. Refer to Verify Repair.

[b] If the resistance measurement is equal to 1.5 k , replace the EGR Delta P sensor and go to Verify Repair.


TShootVuntitled00000736

 Check for Open

Perform the following steps to check for an open.

  1. Disconnect the EGR temperature sensor.

  2. Install a jumper wire between cavities 1 and 2. See EGR Temperature Sensor Wiring.

  3. Disconnect the engine sensor harness connector.

  4. Measure resistance between E10 and E15. See EGR Temperature Sensor Wiring.

[a] If the resistance measurement is less than or equal to 5 [image], Refer to Check for Short.

[b] If the resistance measurement is greater than 5 [image], circuit E10 or E15 is open. Repair and Verify Repair.


TShootVuntitled00000737

 Check for Short

Perform the following steps to check for short:

  1. Remove jumper wire.

  2. Measure resistance between the engine block and E10. See EGR Temperature Sensor Wiring.

[a] If the resistance measurement is less than 1.5 k [image], circuit E10 is shorted. Repair and Verify Repair.

[b] If the resistance measurement is greater than 1.5 k [image], replace the EGR temperature sensor.


TShootVuntitled00000738

 Verify Repair

Perform the following steps to verify repairs.

  1. Connect all connectors.

  2. Start and run the engine.

  3. Road test the engine.

[a] If code 81 was not logged, no further troubleshooting is required.

[b] If code 81 was logged, please review this section from the first step to find the error. Refer to FLASH CODE 81 - OIL LEVEL, EXHAUST TEMP, CIRCUIT FAILED HIGH, OR EGR RATE SENSOR FAULT. If this is the second time through the procedure, call Detroit Diesel Technical Service, or try a test ECU.


TShootVuntitled00000739

 TROUBLESHOOT MAINTENANCE ALERT SYSTEM

The following procedures troubleshoot the Maintenance Alert System.

Multiple Code Check

Perform the following steps to check for multiple codes:

  1. Turn ignition ON.

  2. Plug in DT (diagnostic tool).

  3. Read active codes.

  4. Turn ignition OFF.

[a] If code 98/3 displays with code s 232/0, troubleshoot s 232/0 first.

[b] If code 98/3 displays, refer to Check Connectors.


TShootVuntitled00000740

 Check Connectors

Perform the following steps to check the connectors:

  1. Unplug the oil level sensor (OLS).

  2. Turn ignition ON.

  3. Read codes.

[a] If code 98/4 displays, check connectors for open, damage or unseated conditions. Refer to Sensor Check.

[b] If code 98/3 displays, refer to Check for Short.


TShootVuntitled00000741

 Sensor Check

Perform the following steps to replace the sensor:

  1. Replace the oil level sensor (OLS).

  2. Verify the repair. Refer to Verify Repairs.


TShootVuntitled00000742

 Check for Short

Perform the following steps to check for short:

  1. Measure resistance between pin B and pin C of the OLS. See Oil Level Sensor.

[a] If the reading is less than 10 [image], wire E 12 is shorted to wire E 21. Repair the short or replace the harness and verify the repair. Refer to Verify Repairs.

[b] If the reading is greater than 10 [image], refer to Check for Open.


TShootVuntitled00000743

 Check for Open

Perform the following steps to check for open:

  1. Unplug the engine sensor harness connector.

  2. Insert a jumper harness between the pins A and B of the OLS connector. Measure resistance between cavity E 15 and E 21. See Oil Level Sensor.

[a] If reading is greater than 10 [image], cavity E 15 is open. Repair the open or replace the harness; verify the repair. See Oil Level Sensor. Refer to Verify Repairs.

[b] If the reading is less than 10 [image], contact Detroit Diesel Technical Service, or try a test ECU.


TShootVuntitled00000744

 Verify Repairs

Perform the following steps to verify repairs:

  1. Plug in all connectors.

  2. Start and run the engine for two minutes.

  3. Check for codes.

[a] If no codes display, the repair is complete.

[b] If code 98/3 displays, troubleshooting is complete. Review the troubleshooting of the OLS to find the error. Refer to TROUBLESHOOT MAINTENANCE ALERT SYSTEM.


TShootVuntitled00000745

 TROUBLESHOOT EXHAUST GAS TEMPERATURE

The following procedures troubleshoot the Exhaust Gas Temperature. For exhaust temperature and pressure sensor wiring schematic, see Exhaust Temperature and Pressure Sensor Wiring Schematic.

Check for Open

Typically, the exhaust gas temperature circuit failed high is caused by an open signal or short to battery +. Perform the following steps to troubleshoot code p 173/3:

  1. Disconnect the ETS connector.

  2. Install a jumper wire between the two pins at the ETS.

  3. Unplug the vehicle harness connector at the ECU.

  4. Measure resistance between V60 of the VIH connector and V23 connector; see Exhaust Temperature and Pressure Sensor Wiring Schematic.

[a] If resistance measures less than 5 [image] [image] refer to Check for Short.

[b] If resistance is greater than 5 [image] [image] either the circuit V60 is opened, or V23 is open. Repair the open or replace the wire and test - refer to Test.


TShootVuntitled00000746

 Check for Short

Perform the following steps to check for a short:

  1. Remove the jumper.

  2. Measure resistance again between V60 and V23; see Exhaust Temperature and Pressure Sensor Wiring Schematic.

[a] If the reading is greater than 400 [image], the resistor between circuit V60 and V23 has failed. Replace the resistor or replace the harness.

[b] If the reading is less than 400 [image], replace the ETS, and refer to Test.


TShootVuntitled00000747

 Test

Perform the following steps to test the repair:

  1. Connect all removed connectors.

  2. Start and run the engine.

  3. Perform road test.

  4. Plug in DDR and read active codes.

[a] If no codes display, repairs are complete.

[b] If code 81 displays, review the procedure for checking exhaust gas temperature circuit failed high; refer to Troubleshoot Exhaust Gas Temperature. If this is the second time through the procedure, call DDC Technical Service, or try a test ECU.


TShootVuntitled00000749

 Check EGR Delta-Pressure Sensor

Perform the following steps to check the EGR Delta-Pressure sensor:

  1. Unplug the EGR Delta-P connector.

  2. Unplug the engine sensor harness connector.

  3. Install a jumper wire between cavities 2 and 3 at the EGR Delta-Pressure sensor. See EGR Delta-Pressure Sensor Wiring.

  4. Measure resistance between cavities E38 and E15. See EGR Delta-Pressure Sensor Wiring.

[a] If the resistance measurement is less than or equal to 5 , Refer to Check for Open.

[b] If the resistance measurement is greater than 5 , circuit E38 or E12 is open. Repair the open and refer to Verify Repair.


TShootVuntitled00000750

 Check for Open

Perform the following steps to check for an open.

  1. Remove jumper cable.

  2. Measure resistance between cavities E38 and E15. See See EGR Delta-Pressure Sensor Wiring.

[a] If the resistance measurement is less than 5 , E38 is shorted to E15. Repair short and refer to Verify Repair.

[b] If the resistance measurement is greater than 5 , replace the sensor and refer to Verify Repair.


TShootVuntitled00000751

 Check for Short

Perform the following steps to check for a short:

  1. Unplug the EGR temperature sensor.

  2. Measure resistance between cavities 1 and 2. See See EGR Temperature Sensor Wiring.

[a] If the resistance measurement is less than or equal to 5 , circuit E10 has shorted to circuit E15. Repair the short. Verify - refer to Verify Repair.

[b] If the resistance measurement is greater than 5 , replace the EGR temperature sensor and verify the repair. Refer to Verify Repair.


TShootVuntitled00000752

 Verify Repair

Perform the following steps to verify repairs for the EGR temperature or pressure sensor:

  1. Connect all connectors.

  2. Start and run the engine.

  3. Road test the engine.

[a] If code 82 was not logged, no further troubleshooting is required.

[b] If code 82 was logged, please review this section from the first step to find the error. Refer to Check EGR Delta-Pressure Sensor. If this is the second time through the procedure, call Detroit Diesel Technical Service, or try a test ECM.


TShootVuntitled00000753

 TROUBLESHOOTING MAINTENANCE ALERT SYSTEM

The following procedure will troubleshoot the Maintenance Alert System (MAS):

Read Codes

Perform the following steps to read codes:

  1. Turn ignition ON.

  2. Plug in the DT.

  3. Read active codes.

  4. Record or print codes and turn the ignition OFF.

[a] If code 98/4 displays with 232/1, troubleshoot 232/1 first.

[b] If code 98/4 displays, refer to Check for Open.


TShootVuntitled00000754

 Check for Open

Perform the following steps to check for open:

  1. Unplug the oil level sensor.

  2. Insert the jumper wire between cavities B and C. See Oil Level Sensor.

  3. Turn ignition ON.

  4. Read codes.

[a] If code 98/3 displays, check the connectors for damaged, open or broken pins. If everything checks out, refer to Check for Short. If damage is noted, repair and verify the repairs. Refer to Verify Repairs.

[b] If code 98/4 displays, refer to Check for Open.


TShootVuntitled00000755

 Check for Short

Perform the following steps to check for a short:

  1. Measure resistance between cavity A and C , and again between cavity A and B of the sensor connector. See Oil Level Sensor.

[a] If either reading is less than 10 , that wire is shorted to the sensor return E15. Repair the short or replace the harness. Verify the repair. Refer to Verify Repairs.

[b] If both readings are greater than 10 , replace the sensor. Verify the repair. Refer to Verify Repairs.


TShootVuntitled00000756

 Check for Open

Perform the following steps to check for open:

  1. Unplug the engine sensor connector at the ECU.

  2. Measure resistance with the jumper still plugged in, between cavity E21 and E12. See Oil Level Sensor.

[a] If the reading is greater than 10 , either the E12 or E21 wire is open. Repair the open or replace the harness. Verify the repair. Refer to Verify Repairs.

[b] If the reading is greater than 10 , replace the sensor. Verify the repair. Refer to Verify Repairs.


TShootVuntitled00000757

 Verify Repairs

Follow these steps to verify the repair:

  1. Plug in all connectors.

  2. Start and run the engine for five minutes.

  3. Plug in DT and read active codes.

[a] If no codes display, troubleshooting is complete. Return the engine to service.

[b] If code 98/4 displays, review the MAS troubleshooting to find the error or contact DDC Technical Service for assistance. Refer to TROUBLESHOOTING MAINTENANCE ALERT SYSTEM.


TShootVuntitled00000758

 TROUBLESHOOT EXHAUST GAS TEMPERATURE

Follow these procedures to troubleshoot exhaust gas temperature:

Check for Open

Typically, the exhaust gas temperature circuit failed low is caused by an open signal or short to battery+. Perform the following steps to troubleshoot code p 173/4:

  1. Disconnect the ETS connector.

  2. Install a jumper wire between the two pins at the ETS. See Exhaust Temperature and Pressure Sensor Wiring Schematic.

  3. Unplug vehicle harness connector at the ECU.

  4. Measure resistance between V23 and V60. See Exhaust Temperature and Pressure Sensor Wiring Schematic.

[a] If resistance measures < 5 , refer to Check for Short.

[b] If resistance is > 5 , either the circuit V60 is opened, or V23 is opened. Repair the open or replace the wire and test. Refer to Test.


TShootVuntitled00000759

 Check for Short

Perform the following steps to check for a short:

  1. Remove the jumper.

  2. Measure resistance again between V23 and V60. See Exhaust Temperature and Pressure Sensor Wiring Schematic.

[a] If the reading is > 400 , the resistor between circuit V60 and V23 has failed. Replace the resistor or replace the harness.

[b] If the reading is < 400 , replace the ETS, and refer to Check for Short to Ground.


TShootVuntitled00000760

 Check for Short to Ground

Perform the following steps to check for short to ground:

  1. Measure the resistance between cavity V23 and ground (battery and block). See Exhaust Temperature and Pressure Sensor Wiring Schematic.

  2. Measure the resistance between cavity V60 and ground (battery and block).

[a] If any readings are less than 5 , that wire is shorted to ground. Repair or replace the wire and test. Refer to Test.

[b] If both readings are greater than 5 , replace ETS and test. Refer to Test.


TShootVuntitled00000761

 Test

Perform the following steps to test the repair:

  1. Connect all removed connectors.

  2. Start and run the engine.

  3. Perform road test.

  4. Plug in DDR and read active codes.

[a] If no codes display, repairs are complete.

[b] If code 81 displays, review the procedure for checking exhaust gas temperature circuit failed high; refer to TROUBLESHOOT EXHAUST GAS TEMPERATURE. If this is the second time through the procedure, call DDC Technical Service, or try a test ECU.


TShootVuntitled00000763

 Verify Repairs

Perform the following steps to verify repairs for the EGR valve:

  1. Connect all connectors.

  2. Start and run the engine.

  3. Road test the engine.

[a] If code 83 was not logged, no further troubleshooting is required.

[b] If code 83 was logged, please review this section from the first step to find the error. If this is the second time through the procedure, call Detroit Diesel Customer Support Center (313-592-5800), or try a test ECM/ECU.


TShootVuntitled00000766

 Code Information

Use the following procedure to troubleshoot Flash Code 85.

Perform the following steps to gather information. This code is logged whenever the engine has been operating over 2500 r/min for at least two seconds.

  1. Turn ignition ON.

  2. Plug diagnostic data reader (DDR) into the diagnostic data link (DDL). See vehicle harness connector.

  3. Select inactive codes.

  4. Part of the display will read as follows:

[a] First Occurrence

[b] Last Occurrence

[c] Total Number

[d] Total Time

  5. If necessary, refer to OPERATOR INFORMATION.


TShootVuntitled00000768

 Multiple Code Check

Use the following procedure to troubleshoot Flash Code 86.

Perform the following steps to check for multiple codes.

  1. Turn ignition ON.

  2. Plug in DDR.

  3. Read active codes.

[a] If active code 73/3 was logged, and no other codes were logged, refer to Sensor Check.

[b] If active code 73/4 and any other codes were logged, refer to Return Circuit Check.

[c] If any codes other than 73/3 were logged, refer to VEHICLE HARNESS.


TShootVuntitled00000769

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition OFF.

  2. Disconnect the Pressure Governor System (PGS) sensor connector.

  3. Turn ignition ON.

  4. Start engine and operate the PGS in the PRESSURE mode.

  5. Read active codes.

[a] If active code 73/3 and any other codes were logged, refer to Check for Short to +5 Volts.

[b] If active code 73/4 and any other codes except 73/3 were logged, refer to Return Circuit Check.


TShootVuntitled00000770

 Return Circuit Check

Perform the following steps to check the return circuit.

  1. Turn vehicle ignition OFF.

  2. Disconnect the vehicle harness connector at the ECU. See ECU Vehicle Harness Connector and see VIH-to-ECU Connector.

  3. Install a jumper wire between pins A and B of the PGS sensor harness connector.

  4. Measure resistance between sockets V29 and V60 on the vehicle harness connectors.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check Pressure Governor System Connectors.

[b] If the resistance measurement is greater than 5 [image] [image] or open, the return line (circuit V60) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000771

 Check Pressure Governor System Connectors

Perform the following steps to check the PGS connectors.

  1. Inspect terminals at the PGS sensor connector (both the sensor and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If the terminals and connectors are damaged, repair them and refer to Verify Repairs.

[b] If the terminals and connectors are not damaged, replace the PGS sensor and refer to Verify Repairs.


TShootVuntitled00000772

 Check for Short to +5 Volts

Perform the following steps to check for a short to the +5 volts.

  1. Turn ignition OFF.

  2. Disconnect the vehicle harness connectors at the ECU.

  3. Measure resistance between sockets V11 and V29 on the vehicle harness connector.

[a] If the resistance measurement is greater than 100 [image] or open, refer to Check for Short to Battery +.

[b] If the resistance measurement is less than or equal to 100 [image] [image] the signal line (#749) is shorted to the engine +5 volt line (#916). Repair the short and refer to Verify Repairs.


TShootVuntitled00000773

 Check for Short to Battery +

Perform the following steps to check for a short to battery.

  1. Remove both fuses to the ECU.

  2. Disconnect the vehicle harness and 5-way power connectors at the ECU.

  3. Measure resistance between socket V29 on the engine harness connector and battery (+).

  4. Measure resistance between socket V29 of the vehicle harness connector, V61 and V65.

[a] If the resistance measurement for all readings is greater than 100 [image] or open, refer to Check ECU Connectors.

[b] If the resistance measurement is less than or equal to 100 [image] [image] a short exists between the signal line (V29) and battery (+). Repair short and reinsert fuses. Refer to Verify Repairs.


TShootVuntitled00000774

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Inspect terminals at the ECU connectors (both ECU and harness side) for damage: bent, corroded, and unseated pins or sockets.

[a] If terminals and connectors are damaged, repair them. Refer to Verify Repairs.

[b] If terminals and connectors are not damaged, install a test ECU. Refer to Final Check.


TShootVuntitled00000775

 Final Check

Perform the following steps to do a final check.

  1. Reconnect all connectors.

  2. Turn vehicle ignition ON.

  3. Clear codes.

  4. Start and run the engine for one minute.

  5. Stop engine.

  6. Check DDR for active codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If active code 73/3 is logged, install a test ECU. Refer to Verify Repairs.

[c] If any codes except code 73/3 are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT, to service other codes.


TShootVuntitled00000776

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn ignition switch OFF.

  2. Reconnect all connectors.

  3. Turn ignition ON.

  4. Clear codes.

  5. Start and run the engine for one minute.

  6. Stop engine.

  7. Check DDR for inactive codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code 73/3 is not logged, and other codes are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT, to service other codes.

[c] If code 73/3 is logged, and other codes are logged, all system diagnostics are complete. Review this section from the first step to find the problem - refer to Multiple Code Check.


TShootVuntitled00000778

 Multiple Code Check

Perform the following steps to check for codes.

  1. Turn vehicle ignition ON.

  2. Plug in DDR. Read the codes.

[a] If codes p 73/4, 100/3 or 4, 102/3 or 4, 110/3 or 4, 174/3 or 4 or 175/3 or 4 are logged, refer to VEHICLE HARNESS.

[b] If code 073/4 is logged and no other codes are logged, refer to Sensor Check.

[c] If code 073/4 is logged, and none of the following codes are logged: 100/3 or 4, 102/3 or 4, 110/3 or 4, 174/3 or 4 or 175/3 or 4, refer to Sensor Check.


TShootVuntitled00000779

 Sensor Check

Perform the following steps to check the sensor.

  1. Turn ignition OFF.

  2. Disconnect the pump pressure sensor connector and install a jumper between sockets B and C of the pump pressure sensor transducer connector.

  3. Turn ignition ON.

  4. Start engine and operate the Pressure Governor System (PGS) in the PRESSURE mode.

  5. Read active codes.

[a] If code p 73/3 and any other code except p 73/4 display, check to ensure the ECU and PGS sensor connectors are wired properly. If wired properly, refer to Check Pressure Governor System Sensor Connectors.

[b] If code p 73/4 and any other codes display, refer to Check for Short to Return.


TShootVuntitled00000780

 Check Pressure Governor System Sensor Connectors

Perform the following steps to check the pressure governor system (PGS) sensor connectors.

  1. Turn ignition OFF.

  2. Inspect terminals at the pump pressure sensor connectors (sensor and harness side) for damaged, bent, corroded, and unseated pins or sockets.

[a] If the terminals and connectors are not damaged, replace the PGS sensor. Refer to Verify Repairs.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000781

 Check for Short to Return

Perform the following steps to check for a short.

  1. Turn ignition OFF.

  2. Remove jumper wire.

  3. Remove vehicle interface harness connector (30-pin).

  4. Turn ignition ON.

  5. Measure resistance between V60 and V29.

[a] If the measured resistance is less than 1,000 [image], the wires are shorted to each other. Replace the harness.

[b] If the measured resistance is greater than 1,000 [image], refer to Check for Short to Battery (-).


TShootVuntitled00000782

 Check for Short to Battery (-)

Perform the following steps to check for a short to the battery (-).

  1. Measure resistance between V29 and battery ground.

[a] If the measured resistance is less than 1,000 [image], the V29 wire is shorted to the battery. Replace the harness and refer to Verify Repairs.

[b] If the measured resistance is greater than 1,000 [image], refer to Check for 5 Volt Open.


TShootVuntitled00000783

 Check for 5 Volt Open

Perform the following steps to check for a 5 volt open.

  1. Plug in the 30-pin connector for the vehicle sensor harness.

  2. Turn ignition ON.

  3. Measure voltage between cavity V11 and V60 of the transducer connector.

[a] If the measurement is less than 4.5 volts, wire V11 is open. Repair the open or replace the harness. Refer to Verify Repairs.

[b] If the measurement is between 4.5 and 5.5 volts, the signal wire V29 is open. Repair the wire and refer to Verify Repairs.


TShootVuntitled00000784

 Verify Repairs

Perform the following steps to verify repairs.

  1. Plug in all connectors.

  2. Start and run the engine.

  3. Plug in DDR and read the codes.

[a] If no codes are logged, troubleshooting is complete.

[b] If code p 073/4 is logged, review this section to find the error. Then, contact Detroit Diesel Technical Services.


TShootVuntitled00000787

 ACLS Check

Use the following procedure to troubleshoot the ACLS:

  1. Remove the ACLS and clean (or replace) the probe.

  2. If the code cannot be cleared, inspect all the grounds associated with the ACLS.

  3. Ensure the alternator in the unit has a good clean ground path to the battery.


TShootVuntitled00000788

 Check Fuel Inlet Restriction

Use the following procedure to troubleshoot the fuel inlet restriction:

  1. Check the fuel filters and replace if plugged or dirty. See Fuel Filter Restriction Sensor and see Engine Fuel Restriction Sensor.

  2. Refer to the appropriate engine service manual for the reasons for high fuel inlet restriction.


TShootVuntitled00000790

 Check for Low Battery Voltage

Use the following procedure to troubleshoot the engine sensor harness.

Perform the following steps to check for low battery voltage.

  1. Plug in the diagnostic data reader (DDR).

[a] If Flash Code 168/1 is logged, refer to FLASH CODE 46 - BATTERY VOLTAGE LOW.

[b] If code 168/1 is not logged, refer to Check for +5 Volts.


TShootVuntitled00000791

 Check for +5 Volts

Perform the following steps to check for +5 volts.

  1. Turn vehicle ignition switch OFF.

  2. Disconnect the Oil Pressure Sensor (OPS) and Turbo Boost Sensor (TBS) connectors.

  3. Turn vehicle ignition switch ON.

  4. At each sensor harness connector, measure voltage between socket E12 (red lead-socket 3) and socket E15 (black lead-socket 1).

[a] If the voltage measurement is between 4.7 and 5.2 volts, the voltage reading is correct. Check voltage at the next connector. If all connector voltage readings are correct, refer to Check ECU Connectors.

[b] If the voltage measurement is less than 4.7 volts at any or all connectors, refer to Check for +5 volts or Return Open.

[c] If the voltage measurement is greater than 5.2 volts at all connectors, refer to Check for Short to Battery.


TShootVuntitled00000792

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Check terminals at the ECU engine harness connector (both the ECU and harness side) for damaged, bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are not damaged, check all sensors, especially OPS, TBS, and TPS (on vehicle system), this indicates that there is no problem on the engine sensor harness. Refer to VEHICLE HARNESS.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000793

 Check for +5 volts or Return Open

Perform the following steps to check for +5 volts or return open.

  1. Turn vehicle ignition switch OFF.

  2. Disconnect the engine harness connector at the ECU.

  3. Install a jumper wire between sockets 1 and 3 of any sensor connector that reads less than 4.7 volts. Refer to Check for +5 Volts.

  4. Measure resistance between sockets E12 and E15 of the engine harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for Short to Ground.

[b] If the resistance measurement is greater than 5 [image] [image] or open, either the engine +5 volt line (E12), or the return line (E15) is open. Repair the open and refer to Verify Repairs.


TShootVuntitled00000794

 Check for Short to Ground

Perform the following steps to check for short to ground.

  1. Turn vehicle ignition switch OFF.

  2. Remove jumper wire.

  3. Measure resistance between sockets 1 and 3 of the sensor connector.

  4. Measure resistance between socket C of the sensor connector and a good ground.

[a] If the resistance measurement for both readings is greater than 1,000 [image], or open, refer to Check ECU Connectors.

[b] If either resistance measurement is less than or equal to 1,000 [image], the engine +5 volt line (E12) is shorted to either the sensor return line (E15) or to chassis ground. Repair the short and refer to Verify Repairs.


TShootVuntitled00000795

 Check for Short to Battery

Perform the following steps to check for a short to battery.

  1. Turn vehicle ignition switch OFF.

  2. Remove both fuses to the ECU.

  3. Disconnect both connectors at the ECU.

  4. Measure resistance between socket E12 on the engine harness connector and V15 on the vehicle harness connector.

  5. Measure resistance between socket E12 on the engine harness connector and the battery (+).

[a] If the resistance measurement for both readings is greater than 1,000 [image], or open, refer to Check ECU Connectors.

[b] If either resistance measurement is less than or equal to 1,000 [image], a short exists between sockets where reading was taken. Repair the short and refer to Verify Repairs.


TShootVuntitled00000796

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition switch OFF.

  2. Reconnect all connectors.

  3. Reconnect fuses (or circuit breakers) if previously disconnected.

  4. Turn ignition ON.

  5. Clear codes.

  6. If Amber Warning Lamp (AWL) does not stay on, start engine and run for one minute.

  7. Stop engine.

  8. Read inactive codes with the DDR.

[a] If no codes are logged, troubleshooting is complete.

[b] If codes that brought you to this section are still logged, all system diagnostics are complete. Review this section from the first step to find the error - refer to Check for Low Battery Voltage.

[c] If codes except those which brought you to this section are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00000798

 Check for Low Battery Voltage

Use the following procedure to troubleshoot vehicle harness.

Perform the following steps to check for low battery voltage.

  1. Plug in the diagnostic data reader (DDR).

[a] If code 168/1 is logged, refer to Battery Check.

[b] If code 168/1 is not logged, refer to Check for +5 Volts.


TShootVuntitled00000799

 Check for +5 Volts

Perform the following steps to check for +5 volts at the Throttle Position Sensor (TPS).

  1. Turn vehicle ignition switch OFF.

  2. Disconnect the TPS (disconnect the VSG and PGS, if applicable).

  3. Turn vehicle ignition switch ON.

  4. Measure voltage on the TPS harness connector, pin C (red lead) to pin A (black lead), and pin A to pin B at the PGS connector, if applicable.

[a] If the voltage measurement is between 4.7 and 5.2 volts, the voltage reading is correct. Check voltage at the next connector. If all connector voltage readings are correct, refer to Vehicle Harness 5V Check TPS.

[b] If the voltage measurement is less than 4.7 volts, refer to Check for +5 volts or Return Open.

[c] If the voltage measurement is greater than 5.2 volts at all connectors, refer to Check for Short to Battery (+).


TShootVuntitled00000800

 Check for +5 volts or Return Open

Perform the following steps to check for +5 volts or return open.

  1. Turn vehicle ignition switch OFF.

  2. Disconnect the vehicle harness connector at the ECU.

  3. Install a jumper wire between pins V11 and V60 of the TPS harness connector.

  4. Measure resistance between sockets V11 and V60 of the vehicle harness connector.

[a] If the resistance measurement is less than or equal to 5 [image] [image] refer to Check for +5 Short to Ground.

[b] If the resistance measurement is greater than 5 [image] [image] or open, either the vehicle +5 volt line (V11) or the sensor return line (V60) is open. Refer to Verify Repairs.


TShootVuntitled00000801

 Check for +5 Short to Ground

Perform the following steps to check for +5 short to ground.

  1. Remove jumper wire.

  2. Measure resistance between pins A and C of the TPS harness connector.

  3. Measure resistance between pin C of the TPS harness connector and a good ground (battery-).

[a] If the resistance measurement for both readings is greater than 1,000 [image], or open, refer to Check ECU Connectors.

[b] If either resistance measurement is less than or equal to 1,000 [image], wire (V11) is shorted to wire (V60), or battery ground. Repair the short and refer to Verify Repairs.


TShootVuntitled00000802

 Vehicle Harness 5V Check TPS

Perform the following steps to check TPS.

  1. Turn vehicle ignition switch OFF.

  2. Reconnect the TPS connector.

  3. Turn vehicle ignition switch ON.

  4. Select Throttle Sensor percentage on the DDR.

  5. Observe throttle percentage at both no throttle and full throttle (engine not running).

[a] If the percentage is between 0 and 100%, refer to Check ECU Connectors.

[b] If not getting a reading between 0 and 100%, refer to Vehicle Harness 5V Check Throttle Position Sensor Connectors.


TShootVuntitled00000803

 Vehicle Harness 5V Check Throttle Position Sensor Connectors

Perform the following steps to check TPS connectors.

  1. Turn vehicle ignition switch OFF.

  2. Disconnect the TPS.

  3. Inspect terminals at the TPS connectors (sensor side and harness side) for damage; bent, corroded and unseated pins or sockets.

[a] If the terminals and connectors are not damaged, replace TPS. Refer to Verify Repairs.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000804

 Check ECU Connectors

Perform the following steps to check the ECU connectors.

  1. Turn vehicle ignition switch OFF.

  2. Disconnect the vehicle harness connector at the ECU (if not already disconnected).

  3. Check terminals at the ECU vehicle harness connector (both the ECU and harness side) for damage; bent, corroded and unseated pins or sockets (especially terminals V60, V11, V13). Install new terminal if in doubt.

[a] If the terminals and connectors are not damaged, refer to Check for +5 Volts.

[b] If the terminals and connectors are damaged, repair them. Refer to Verify Repairs.


TShootVuntitled00000805

 Check for Short to Battery (+)

Perform the following steps to check for a short to battery (+).

  1. Turn vehicle ignition switch OFF.

  2. Remove both fuses or circuit breakers to the ECU.

  3. Disconnect the vehicle harness connectors at the ECU.

  4. Measure resistance between sockets V11 and V15 on the vehicle harness connector.

  5. Measure resistance between socket V11 on the vehicle harness connector and the battery (+).

[a] If the resistance measurement for all readings is greater than 1,000 [image], or open, refer to Check ECU Connectors.

[b] If the resistance measurement is less than 1,000 [image], a short exists between the vehicle +5 volt line V11 and the lines where less than 1,000 [image] [image] was read (+Battery or V15). Repair the short and refer to Verify Repairs.


TShootVuntitled00000806

 Verify Repairs

Perform the following steps to verify repairs.

  1. Turn vehicle ignition switch OFF.

  2. Reconnect all connectors.

  3. Reconnect fuses (or circuit breakers) if previously disconnected.

  4. Turn ignition ON.

  5. Clear codes.

  6. If Amber Warning Lamp (AWL) does not stay on, start engine and run for one minute.

  7. Stop engine.

  8. Read inactive codes with the DDR.

[a] If no codes are logged, troubleshooting is complete.

[b] If codes that brought you to this section are still logged, all system diagnostics are complete. Review this section from the first step to find the error - refer to Check for Low Battery Voltage.

[c] If codes except those that brought you to this section are logged, refer to DIAGNOSING A DDEC SYSTEM FAULT.


TShootVuntitled00001004

 Verify Repairs

Perform the following steps to verify repairs for the EGR valve:

  1. Connect all connectors.

  2. Start and run the engine.

  3. Road test the engine.

[a] If code 83 was not logged, no further troubleshooting is required.

[b] If code 83 was logged, please review this section from the first step to find the error. If this is the second time through the procedure, call Detroit Diesel Customer Support Center (313-592-5800), or try a test ECM/ECU.


 USE OF DIGITAL VOLT-OHM METER

Before using this manual, you should be familiar with the digital volt-ohm meter (VOM). You should be able to measure voltage and resistance. You should be familiar with the controls of the meter and how to use it correctly.

For use of a typical digital volt-ohm meter, refer to Resistance Measurements, refer to Continuity Checks, and refer to Voltage Measurements.

Next topic

RESISTANCE MEASUREMENTS

Previous topic


 USING SNAPSHOT REPLAY CONTROLS

When you have opened a snapshot, replay controls will appear at the bottom of the DDDL window you opened. See Replay Control Window.

  1. Start the replay of a snapshot by clicking on "Play." See Replay Control Window. The play button changes to "Pause" when a snapshot is replaying. While the snapshot is replaying, the replay slider next to the Play/Pause button moves showing the progress of the replay, and the time box next to it shows the time since the beginning of the recording. When you click on "Play" the snapshot begins to play from its current position and the instruments show the appropriate readings. The event window also changes during the replay to show the most recent event.

  2. Stop the replay at a particular point of interest by clicking on "Pause." The instruments will show the values at the time the replay was stopped.

  3. Beginning with DDDL 4.1, additional comments may be added to the snapshot while in replay mode. Click on the "Edit" box and a window will appear to add your remarks.

  4. Move to a specific time in the replay by dragging the replay slider button. As you drag the slider, the time shown in the time box changes to reflect the position of the slider.

Or,

  5. Move to a specific time in the replay by typing the time you require into the time box. Make sure you use the same format for the numbers as the box displays. Click on the "Return" key.

Or, to show the data at the time of a specific event,

  6. Click on the event drop-down list box to display the list. See Event Drop Down Box.

The box shows the events generated by the ECU and those marked by the user in the order in which they occurred. Select an event to move the replay point to the time at which the event occurred.

If the snapshot is playing when you move to a new position, it will continue playing from the new point. If the snapshot is paused when you move to a new position, the instruments will hold the data for the new position until you start playing the snapshot or move to another new position.

NOTE: Not all DDDL windows can be activated when replaying the snapshot feature. Windows that may be activated include: the normal instrumentation window, the diagnostic instrumentation window, the graph window, the user window, and the fault codes window. You cannot access the injector response time window or the cylinder cutout window in snapshot mode.

Next topic

FAULT CODES AND DDDL

Previous topic


 Using the Snapshot Feature in DDDL

The following sections Start New Snapshot and Open Previously Saved Snapshot will detail the DDDL snapshot features.

Next topic

START NEW SNAPSHOT

Previous topic


Variable Speed Governor or Limited Speed Governor Vehicle

 Variable Speed Governor or Limited Speed Governor Vehicle Speed Limiting Diagnostics

If low side diagnostics need to be enabled or disabled, this is set on the mainframe.

Low side diagnostics refers to throttle position sensor (TPS) or variable speed governor (VSG) "low volt" codes. This occurs when an ECU is configured to be looking for a signal at one of these items, but nothing is wired to it.

Next topic

VEHICLE SPEED SENSOR ANTI-TAMPER

Previous topic


 VEHICLE ELECTRONIC PROGRAMMING SYSTEM

The purpose of the DDEC Vehicle Electronics Programming System (VEPS) is to give OEMs the ability to configure many ECU parameters. This allows DDEC features to be tailored to the specific customer requirements when the vehicle is assembled. Some of the features which may be configured by VEPS are the transmission type, cruise control, vehicle speed limit, idle shutdown, rating switches, digital inputs, and digital outputs.

Next topic

SOFTWARE

Previous topic


 VEHICLE HARNESS

DESCRIPTION OF VEHICLE HARNESS +5 VOLT SUPPLY

Referral to this section indicates a fault within the vehicle interface harness.

NOTE: It is suggested that the vehicle interface module be installed for test. If the fault(s) clear, you may wish to contact the vehicle manufacturer for instructions on troubleshooting.

Otherwise, continue with this section.


 Vehicle Harness Connector


 Vehicle Harness Schematic Overview

Click on the picture to see magnified views of the schematic

CAVITY | LABEL | CAVITY | LABEL
V-1 | AMBER WARNING LIGHT | V-35 | NO CONNECTION
V-2 | RED STOP LIGHT | V-36 | NO CONNECTION
V-3 | SERVICE BRAKE RELEASED | V-37 | ADD COOLANT LEVEL
V-4 | FAN CONTROL #1 | V-38 | COOLANT LEVEL SHUTDOWN
V-5 | DIGITAL OUTPUT | V-39 | ENGINE BRAKE LOW
V-6 | DIGITAL OUTPUT | V-40 | OI ALARM
V-7 | VEHICLE PWR SHUTDOWN | V-41 | AUX SHUTDOWN #1
V-8 | RESUME/ACCEL | V-42 | OI THERMOSTAT
V-9 | CRUISE ENABLE | V-43 | J1939 DL (+)
V-10 | CLUTCH RELEASED | V-44 | J1939 DL SHIELD
V-11 | SENSOR SUPPLY #1 | V-45 | NO CONNECTION
V-12 | SENSOR SUPPLY #2 | V-46 | PWM OUTPUT
V-13 | THROTTLE POSITION | V-47 | SET/COAST
V-14 | VSG | V-48 | ANALOG INPUT - 1.5K PULL-UP
V-15 | IGNITION | V-49 | FAN CONTROL OVERRIDE
V-16 | IDLE VALIDATION | V-50 | PARK BRAKE
V-17 | VEHICLE SPEED SENSOR (+) | V-51 | ENGINE BRAKE MED
V-18 | VEHICLE SPEED SENSOR (-) | V-52 | PWM OUTPUT
V-19 | NO CONNECTION | V-53 | ETHER START
V-20 | NO CONNECTION | V-54 | OI STARTER
V-21 | NO CONNECTION | V-55 | OI ACTIVE LAMP
V-22 | AIR FILTER RESTRICTION | V-56 | J1587 +
V-23 | EXHAUST TEMPERATURE | V-57 | J1587 -
V-24 | SEO/DIAG REQUEST | V-58 | J1939 DL (-)
V-25 | A/C STATUS | V-59 | SENSOR RETURN #2
V-26 | ANALOG INPUT - 1.5K PULL-UP | V-60 | SENSOR RETURN #1
V-27 | TURBO COMPRESSOR IN TEMP | V-61 | +12V / +24V
V-28 | NO CONNECTION | V-62 | +12V / +24V
V-29 | EXHAUST BACK PRESSURE OR FIRE TRUCK PUMP PRESSURE | V-63 | BATTERY GROUND
V-30 | NO CONNECTION | V-64 | BATTERY GROUND
V-31 | TACHOMETER | V-65 | +12V / +24V
V-32 | FREQUENCY - SPARE | V-66 | +12V / +24V
V-33 | FREQUENCY - SPARE | V-67 | BATTERY GROUND
V-34 | NO CONNECTION | V-68 | BATTERY GROUND


 Vehicle Overspeed Parameters

Vehicle overspeed parameters can be set with the DDR or programming station. Customer decided parameters log vehicle overspeed codes. The parameter is typically set for +3 mph and +5 mph greater than the current vehicle speed limit; e.g. vehicle speed limit 65. Maximum overspeed limit is 68 and maximum speed no fuel is 70. Setting both to zero disables the function.

NOTE: Remember to review these figures if Fuel Economy Incentive is activated.

Next topic

VEHICLE SPEED LIMITING

Previous topic


 Vehicle Speed Limiting

Vehicle speed limiting can be set with the DDR or programming station. Requires VSS set to Yes.

Vehicle Speed Limit = Yes/No; Maximum speed = XX mph. Limited to the calculated gear bound vehicle speed at rated engine r/min, or if progressive shift = yes, then max cruise speed is limited to high gear r/min. (XX refers to customer selections.)

Next topic

VARIABLE SPEED GOVERNOR OR LIMITED SPEED GOVERNOR VEHICLE

Previous topic


 Vehicle Speed Sensor Anti-Tamper

Vehicle Speed Sensor (VSS) anti-tamper can be set with the DDR, or special ECU software available via parts.

Once set, VSS anti-tamper requires 5.0 level DDR or higher to disable.

Next topic

DDEC FEATURE SUMMARY

Previous topic


 VEHICLE WIRING SCHEMATICS

OPTIMIZED IDLE SYSTEM

See Optimized Idle System Overview.

VEHICLE HARNESS SCHEMATIC

See Vehicle Harness Schematic Overview.

ELECTRONIC FIRE COMMANDER HARNESS

See Electronic Fire Commander Harness.


 VGT/VPOD Schematic


 VIH-to-ECU Connector (Pins V11, V29 and V60)


 VIH-to-ECU Connector (Pins V17 and V18)


 VIH-to-ECU Connector (Pins V43, V44 and V56-58)


 Voltage Measurement Hook-up

  1. Red Lead 2. Black Lead


 Voltage Measurements

Perform the following steps to measure voltage.

  1. Connect the red test lead to the V- [image] connector and the black lead to the com input on the meter. If a DC-AC switch is present, ensure it is switched to the DC position.

  2. Set the function range/switch to the desired volts position. If the magnitude of the voltage is not known, set the switch to a range that will be able to read most voltages seen on a vehicle. Typically, a 20V range will do. Then, reduce the range until a satisfactory reading is obtained.

  3. Connect the test leads to the circuit being measured. In the DDEC system diagnostic procedures, voltage measurements are always given as being taken at pins, sockets, battery +, or ground. Following the voltage measurement point, the color test lead to be used is given in parenthesis (red is the V- [image] connection, and black is the com connection).

Example: If the procedure displays, "Take voltage reading at socket A3 (red lead) to socket C3 (black lead)", see Voltage Measurement Hook-up for the hook-up.

Next topic

SERVICING DDEC CONNECTORS

Previous topic


 Volt-Ohm Meter, J 39299


 VPOD, Coolant, Oil Temperature, EGR, and VNT VPOD Schematic


 VPOD, Injector, and MAS Schematic


 Welding

Wear welding goggles and gloves when welding or using an acetylene torch. Ensure that a metal shield separates the acetylene and oxygen tanks. These must be securely chained to a cart.

To avoid injury from arc welding, gas welding, or cutting, wear required safety equipment such as an arc welder’s face plate or gas welder’s goggles, welding gloves, protective apron, long sleeve shirt, head protection, and safety shoes. Always perform welding or cutting operations in a well-ventilated area. The gas in oxygen/acetylene cylinders used in gas welding and cutting is under high pressure. If a cylinder should fall due to careless handling, the gage end could strike an obstruction and fracture, resulting in a gas leak leading to fire or an explosion. If a cylinder should fall resulting in the gage end breaking off, the sudden release of cylinder pressure will turn the cylinder into a dangerous projectile. Observe the following precautions when using oxygen/acetylene gas cylinders:
Always wear required safety shoes.
Do not handle tanks in a careless manner or with greasy gloves or slippery hands.
Use a chain, bracket, or other restraining device at all times to prevent gas cylinders from falling.
Do not place gas cylinders on their sides, but stand them upright when in use.
Do not drop, drag, roll, or strike a cylinder forcefully.
Always close valves completely when finished welding or cutting.

To avoid injury from fire, check for fuel or oil leaks before welding or carrying an open flame near the engine.

Next topic

PRESSURIZED FLUIDS

Previous topic


 Wire and Terminal Installation - Tyco ECU Connector

To install the wires and terminals into the Tyco connector:

  1. Remove the Terminal Position Assurance (TPA) from the connector using a jeweler's (small) screwdriver (see Removing the Terminal Position Assurance).

  2. Push the terminal into the cavity until it clicks.

  3. Replace the TPA.

  4. Secure the harness in the shroud neck with two tie wraps (see Tyco Connector and Locking Tabs).

NOTE: The conduit must cover the harness wires in the neck of the shroud.

Next topic

WIRE AND TERMINAL REMOVAL - TYCO ECU CONNECTOR

Previous topic


 Wire and Terminal Removal - Tyco ECU Connector

Use a jeweler's (small) screwdriver as your extraction tool. To remove the terminals from the connector body:

  1. Cut the tie wraps holding the harness in the neck of the shroud.

  2. Remove the connector from the shroud by pushing the four locking tabs (arrows) back from the connector. Use the screwdriver to push back the tabs closest to the shroud wall (see Tyco Connector and Locking Tabs).

  3. Remove the Terminal Position Assurance from the connector with the screwdriver (see Removing the Terminal Position Assurance).

  4. Use the screwdriver to gently pry back the tab holding the terminal you wish to remove (see Removing the Terminal).

  5. While holding the tab back, carefully pull the wire and terminal out of the connector.

Next topic

DEUTSCH TERMINAL INSTALLATION GUIDELINES

Previous topic


 WIRES AND WIRING

This section contains recommendations and requirements for the VIH and EH connectors and wiring.

Next topic

GENERAL WIRE RECOMMENDATIONS

Previous topic


 Wiring for 9-pin Data Link Connector


 Working on a Running Engine

When working on an engine that is running, accidental contact with the hot exhaust manifold can cause severe burns. Remain alert to the location of the rotating fan, pulleys and belts. Avoid making contact across the two terminals of a battery which can result in severe arcing, or battery explosion.

To avoid injury from rotating belts and fans, do not remove and discard safety guards.

To avoid injury when working near or on an operating engine, remove loose items of clothing, jewelry, tie back or contain long hair that could be caught in any moving part causing injury.

Next topic

OPTIMIZED IDLE

Previous topic